Содержание

В настоящей документации представлено описание ActiveX-интерфейса программирования для системы автоматизированного проектирования IndorCAD 7. Данный интерфейс предназначен для разработки дополнительных встраиваемых модулей для IndorCAD 7, для написания макросов на встроенном языке Visual Basic for Applications, а также для внешнего управления системой из других приложений.

В общей сложности интерфейс програмирования системы проектирования IndorCAD 7 содержит около 130 классов и 60 типов констант.

Описание каждого класса ключает в себя краткое общее описание, а также детальные описания всех имеющихся свойств, методов и событий

При описании констант приводится общее описание назначения рассматриваемых констант, а также сводная таблица всех констант, их значений и кратких описаний

Смотри также

Class Интерфейс программирования

Classes Классы
Interfaces Интерфейсы
Enums Константы

Group Приложение

Group Пользовательский интерфейс

Group Проекты

Group Поверхности

Group Трассы

Group Трёхмерный вид

Group Внешние модули

Group Триангуляция

Group Рисование изображений

Support Поддержка продукта

License Лицензионное соглашение

WebSite Информация о производителе

В случае возникновения вопросов по документации обращайтесь по адресу support@indorsoft.ru.


Все типы

В данном разделе представлен общий список всех классов, интерфейсов и констант, предоставляемых интерфейсом программирования системы автоматизированного проектирования IndorCAD 7

Классы

Имя | Описание
Class Application | Приложение IndorCAD
Class ApplicationOptions | Реализация настроек программы
Class Calculator | Объект для вычисления выражений
Class CustomOptions | Настройки класса
Class Plugin | Дополнительный модуль к системе
Class PluginManager | Менеджер дополнительных модулей к системе
Class Version | Информация о версии приложения
Class Bar | Панель инструментов
Class BarButton | Кнопка на панели инструментов
Class BarItem | Элемент панелей инструментов
Class BarItemLink | Ссылка на действие
Class BarItemLinks | Список ссылок на действия
Class BarLargeButton | Большая кнопка на панели инструментов
Class BarManager | Менеджер элементов панелей и лент инструментов
Class BarModeButton | Кнопка режима на панели инструментов
Class BarPopupMenu | Всплывающее меню
Class BarSeparator | Разделитель элементов меню на панели инструментов
Class BarSubItem | Подменю на панели инструментов
Class CADAction | Реализация ICADAction
Class Images | Стандартный набор картинок
Class Menu | Описание меню окна
Class MenuItem | Элемент меню
Class MenuVerb | Описание пункта меню
Class Ribbon | Лента инструментов
Class RibbonTab | Закладка на ленте инструментов
Class RibbonTabGroup | Группа действий на ленте инструментов
Class Window | Любое экранное окно
Class Aggregate | Объект, содержащий в себе разнотипные объекты IndorCAD
Class BaseObject | Базовый объект IndorCAD
Class BaseObjectList | Базовый объект - список объектов IndorCAD
Class DrawingSheet | Лист чертежа плана
Class DrawingSheets | Листы чертежа плана
Class Grid | Сетка, покрывающая весь проект с шагом 10 см
Class Project | Проект IndorCAD
Class ProjectOptions | Настройки проекта
Class CADTriangulation | Триангуляция поверхности IndorCAD
Class Layer | Слой цифровой модели
Class LayerOptions | Настройки слоя
Class LayerPoint | Точка поверхности
Class LayerPoints | Набор точек (рельефных и ситуационных)
Class Layers | Список слоёв в проекте
Class Line | Структурная/ситуационная линия или полигон
Class LineGroup | Группа линий/полигонов
Class Lines | Коллекция структурных/ситуационных линий слоя
Class SurfaceDifference | Разность поверхностей
Class SurfaceDifferences | Набор разностей поверхностей
Class SurfacePainter | Элемент закраски поверхности в слое
Class SurfacePainters | Список элементов закраски поверхности в слое
Class Route | Трасса
Class RouteElement | Элемент разбивки трассы (поперечник)
Class RouteOptions | Параметры трассы
Class Routes | Список трасс в проекте
Class RouteVertex | Вершина трассы
Class Options3D | Настройки отображения 3D-вида проекта
Class SubSystem3D | Подсистема 3D-вида
Class Triangulation | Триангуляция
Class TrnArea | Регион триагуляции
Class TrnBreak | Структурная линия триангуляции
Class TrnFigure | Исходная точка для построения триангуляции
Class TrnFlip | Дополнительная переброска рёбер триангуляции
Class TrnModifier | Красящие и отсекающие линии триангуляции
Class TrnNode | Узел триангуляции
Class TrnRib | Структурное неперестраиваемое ребро триангуляции
Class TrnSource | Исходная точка для построения триангуляции
Class TrnTools | Объект для выполнения различных высокоуровневых операций с помощью триангуляции
Class TrnTriangle | Треугольник триангуляции. Состоит из указателей на точки и соседние треугольники. Напротив i-й точки P[i] всегда задается i-й треугольник. Точки нумеруются по часовой стрелке
Class PaintCanvas | Компонента, на которую осуществляется отрисовка
Class PropertyStream | Объект для записи и чтения данных из потока
Class StringName | Имя линии
Class StringNameCollection | Набор имён линий
Class StringNameGroup | Группа имён линий
Class UniConnection | Параметры подключения к абстрактной базе данных
Class UniConnectionParameters | Параметры подключения к абстрактной базе данных
Class VideoRowViewer | Объект "Просмотрщик видеорядов"
Class VideoRowWriter | Объект "Запись видеорядов"
Class AdditionalPoint | Абстрактная дополнительная точка (засечка)
Class By3PointAdditionalPoint | Дополнительная точка, вычисленная по трем точкам
Class CustomSurveyPoint | Абстрактная съёмочная точка
Class FieldTraverse | Теодолитный ход
Class FieldTraversePoint | Точка теодолитного хода
Class GeodesyAngle | Геодезический угол
Class GeodesyBook | Геодезический редактор
Class GeoPoint | Абстрактная геодезическая точка
Class IntersectionAdditionalPoint | Засечки
Class KnownAdditionalPoint | Точка с известными координатами
Class LinkedGeoPoint | Точка хода с возможностью ссылки на другую точку
Class MeasureAdditionalPoint | Дополнительная точка, вычисленная по промерам
Class Measuring | Абстрактная съёмка
Class RangeAdditionalPoint | Абстрактная дополнительная точка со створом
Class Survey | Пикетажная съёмка
Class SurveyEditor | Геодезический редактор
Class SurveyPoint | Съёмочная точка
Class Assembly | Запомненное собрание слоёв композиции
Class AssemblyLayerState | Запомненное состояние слоя в собрании слоёв
Class ClipRegion | Полигональный регион отсечения видимой области отображения
Class ContainerBookmark | Закладка в контейнере
Class ContainerModeHandler | Обработчик режима работы контейнера
Class ContainerSurface | Поверхность для рисования в системе координат контейнера
Class CustomContainer | Контейнер изображений
Class StandardScale | Стандартный масштаб отображения
Class VectorContainer | Контейнер изображений с векторными элементами
Class BrowserItem | Элемент - отображение поля таблицы
Class BrowserItems | Набор элементов просмотра таблиц баз данных
Class CalcField | Параметры вычисляемого поля
Class CalcFields | Список вычисляемых полей
Class Dataset | Набор данных
Class Field | Поле набора данных
Class FigureAttr | Определение атрибута элемента, хранящегося внутри элемента
Class FigureAttrs | Список внутренних атрибутов элементов
Class Collection | Коллекция объектов
Class CustomCollection | Коллекция объектов, чисел или интерфейсов
Class Depository | Хранилище пользовательских переменных
Class DoubleCollection | Коллекция вещественных чисел
Class IntegerCollection | Коллекция целых чисел
Class InterfaceCollection | Коллекция интерфейсов
Class StringCollection | Коллекция строк
Class Composition | Композиция
Class CompositionLayer | Слой композиции
Class CoordinateTransformator | Преобразователь координат для вывода данных на устройство
Class CustomMode | Режим работы, определяемый пользователем
Class CustomSubMode | Подрежим режима пользователя
Class FigureCollection | Коллекция фигур
Class FolderLayer | Папка слоёв
Class HotLink | Параметры горячей связи
Class LayerCalculator | Калькулятор для векторного слоя карты
Class LayerDataset | Набор данных слоя
Class LayeredComposition | Композиция со слоями
Class LayerRequest | Запрос к карте
Class Projection | Картографическая проекция
Class RequestVariable | Описание переменных в запросе LayerRequest
Class VectorLayer | Слой векторных данных
Class DatabaseInterface | Интерфейс с базами данных
Class DatabaseInterfaces | Список интерфейсов карты, проекта или темы
Class DatasetLink | Подключение набора данных
Class DatasetLinks | Список подключений наборов данных
Class LinkedADOCustomDataset | Элемент интерфейса - набор данных для TLinkedADODatabase
Class LinkedADODatabase | База данных ADO
Class LinkedADODataset | Элемент интерфейса - набор данных для TLinkedADODatabase
Class LinkedADOQuery | Элемент интерфейса - запрос для TLinkedADODatabase
Class LinkedADOStoredProc | Элемент интерфейса - хранимая процедура для TLinkedADODatabase
Class LinkedADOTable | Элемент интерфейса - таблица для TLinkedADODatabase
Class LinkedBDEDatabase | База данных BDE
Class LinkedBDEDataset | Элемент интерфейса - набор данных для TLinkedBDEDatabase
Class LinkedBDEQuery | Элемент интерфейса - запрос BDE набор данных для TLinkedBDEDatabase
Class LinkedBDEStoredProc | Элемент интерфейса - хранимая процедура BDE набор данных для TLinkedBDEDatabase
Class LinkedBDETable | Элемент интерфейса - таблица BDE набор данных для TLinkedBDEDatabase
Class LinkedClientDataset | Элемент интерфейса - набор данных для TLinkedRemoteDatabase
Class LinkedCorbaDatabase | База данных на удаленном сервере для ClientDataset(подключение через Corba)
Class LinkedDatabase | База данных интерфейса
Class LinkedDatabaseFolder | Элемент интерфейса - папка
Class LinkedDatabaseItem | Элемент баз данных в интерфейсе
Class LinkedDataset | Элемент интерфейса - набор данных
Class LinkedDCOMDatabase | База данных на удаленном сервере для ClientDataset(подключение через DCOM)
Class LinkedDispatchDatabase | База данных на удаленном сервере для ClientDataset(подключение через TDispatchConnection)
Class LinkedIBDatabase | База данных Interbase
Class LinkedIBDataset | Элемент интерфейса - набор данных для TLinkedIBDatabase
Class LinkedIBQuery | Элемент интерфейса - запрос для TLinkedIBDatabase
Class LinkedIBStoredProc | Элемент интерфейса - хранимая процедура для TLinkedIBDatabase
Class LinkedIBTable | Элемент интерфейса - таблица для TLinkedIBDatabase
Class LinkedOLEnterpriseDatabase | База данных на удаленном сервере для ClientDataset(подключение через OLEnterprise)
Class LinkedParams | Набор параметров для запроса или хранимой процедуры
Class LinkedRDSDatabase | База данных RDS (удаленые наборы данных)
Class LinkedRemoteDatabase | База данных на удаленном сервере для ClientDataset
Class LinkedSocketDatabase | База данных на удаленном сервере для ClientDataset(подключение через Socket)
Class LinkedUniDatabase | База данных UniDAC
Class LinkedUniDataset | Элемент интерфейса - набор данных для TLinkedUniDatabase
Class LinkedUniQuery | Элемент интерфейса - запрос UniDAC набор данных для TLinkedUniDatabase
Class LinkedUniStoredProc | Элемент интерфейса - хранимая процедура UniDAC набор данных для TLinkedUniDatabase
Class LinkedUniTable | Элемент интерфейса - таблица UniDAC набор данных для TLinkedUniDatabase
Class LinkedWebDatabase | База данных на удаленном сервере для ClientDataset(подключение через Web)
Class Figure | фигура
Class FigureBase | База фигур (состоит из нескольких наборов фигур)
Class FigureSet | Набор фигур
Class ShapeField | Атрибут текущей записи шейп-файла
Class ShapeFile | Шейп-файл
Class ShapeFigure | Фигура шейп-файла
Class ShapeMultipart | Шейп-фигура с несколькими контурами
Class ShapeMultipoint | Шейп-фигура "мультиточка"
Class ShapeMultipointM | Шейп-фигура "мультиточка" с мерой
Class ShapeMultipointZ | Шейп-фигура "мультиточка" с мерой и Z-координатой
Class ShapePoint | Шейп-фигура "точка"
Class ShapePointM | Шейп-фигура "точка" с мерой
Class ShapePointZ | Шейп-фигура "точка" с мерой и Z-координатой
Class ShapePolygon | Шейп-фигура "полигон"
Class ShapePolygonM | Шейп-фигура "полигон" с мерой
Class ShapePolygonZ | Шейп-фигура "полигон" с мерой и Z-координатой
Class ShapePolyline | Шейп-фигура "полилиния"
Class ShapePolylineM | Шейп-фигура "полилиния" с мерой
Class ShapePolylineZ | Шейп-фигура "полилиния" с мерой и Z-координатой
Class TopoArrowStyle | Стиль оформления стрелок
Class TopoDimensionStyle | Стиль оформления размерных линий
Class TopoFillStyle | Площадной условный знак
Class TopoFontStyle | Параметры шрифта
Class TopoLineStyle | Линейный условный знак
Class TopoSignStyle | Условный знак
Class TopoSymbolStyle | Точечный условный знак
Class TopoSymbolStyleAux | Отключаемый точечный условный знак
Class TopoTextStyle | Точечный условный знак
Class UndoManager | Менеджер откатов

Интерфейсы

Имя | Описание
Interface IApplicationEvents | События системы IndorCAD
Interface IPluginEvents | События, возникающие при создании дополнительного внутреннего модуля к системе
Interface IProjectEvents |
Interface IRoutesEvents |
Interface IView3DController | Реализуется объектами, обеспечивающими управление 3D-видом с помощью клавиатуры, джойстика
Interface ICADAssignableWithLayerObject | Реализуется объектами IndorCAD, поддерживающими импорт своих данных из другого проекта или слоя
Interface ICADDataCreator | Реализуется объектами, которые регистрируются в Application.RegisterData и умеют создавать экземпляры данных для IndorCAD
Interface ICADObject | Интерфейс, который обязан реализовывать любой объект IndorCAD, встраивающийся в дерево объектов
Interface IDocTreeHandler | Обработчик "перечисления" объектов какой-либо ветви проекта
Interface IImporter | Реализуется объектами, регистрируемыми в Application.RegisterImport, которые могут импортировать какие-либо данные из файла
Interface IObject3D | Реализуется объектами, поддерживающими отрисовку себя (и своих подобъектов) в 3D-виде
Interface IObject3DLight | Реализуется объектами, которые выставляют дополнительные источники освещения
Interface IObject3DTransparent | Реализуется объектами, поддерживающими отрисовку себя (и своих подобъектов) в 3D-виде в полупрозрачном состоянии
Interface IEnumerateNodes | Интерфейс, используемый в методе EnumerateNodes узла для получения всех узлов, смежных с данным узлом
Interface IEnumerateProfile | Интерфейс, используемый в методе EnumerateProfile триангуляции для получения всех отрезков профиля вдоль заданного отрезка
Interface IEnumerateProfilePoints | Интерфейс, используемый в методе EnumerateProfilePoints триангуляции для получения всех точек профиля вдоль заданного отрезка
Interface IEnumerateRibs | Интерфейс, используемый в методе EnumerateRibs узла для получения всех рёбер, смежных с данным узлом
Interface IEnumerateTriangles | Интерфейс, используемый в методе EnumerateTriangles узла для получения всех треугольников, смежных с данным узлом
Interface ITrnFigureFilter | Интерфейс, используемый в методах GetItem[s]AtPoint/GetItemsAtRect триангуляции для получения объектов в заданной точки плоскости
Interface IMultiPointGeometry | Геометрия мультиточек
Interface IPolygonGeometry | Геометрия полигона
Interface IPolylineGeometry | Геометрия полилинии
Interface IPropertyStreamed | Объект, умеющий сохраняться/загружаться, используя IPropertyStream
Interface IRenderAdapter3D | Интерфейс для передачи данных в 3D вид
Interface ITextureIdContainer | Массив идентификаторов текстур
Interface IContainerModeEvents | Обработчик режима работы контейнера
Interface IHotLinkHandler | Обработчик горячей связи
Interface ICoordinateTransformer | Преобразователь координат точек
Interface IUndoMemoryEstimator | Интерфейс для оценки занимаемой объектом памяти
Interface IUndoRestoreAfter | Обработчик событий
Interface IUndoRestoreArray | Обработчик события восстановления объекта, состояние которого было запомнено в виде массива с данными
Interface IUndoRestoreBefore | Обработчик событий
Interface IUndoRestoreBoolean | Обработчик события восстановления объекта, состояние которого было запомнено как логическое значение
Interface IUndoRestoreBuffer | Обработчик события восстановления объекта, состояние которого было запомнено в виде произвольного буфера с данными
Interface IUndoRestoreDouble | Обработчик события восстановления объекта, состояние которого было запомнено как вещественное значение
Interface IUndoRestoreInteger | Обработчик события восстановления объекта, состояние которого было запомнено как целочисленное значение
Interface IUndoRestoreMethod | Обработчик события восстановления объекта
Interface IUndoRestoreString | Обработчик события восстановления объекта, состояние которого было запомнено как строковое значение
Interface IUndoRestoreUnknown | Обработчик события восстановления объекта, состояние которого было запомнено как интерфейс объекта
Interface IExecutable | Интерфейс, предоставляющий метод Execute, вызываемый в основном потоке объекта

Записи

Имя | Описание
Record TColorVector |
Record TPointGeometry |
Record TPointInfo |
Record TPolygonInfo |
Record TPolylineInfo |
Record TTextInfo |
Record TTextureId |
Record TTreeInfo |
Record TVector |

Константы

Имя | Описание
Enum LogPrecisionConstants | Уровень детализации при журналировани
Enum PluginKindConstants | Тип дополнительного модуля
Enum PluginOptionConstants | Различные опции дополнительного модуля
Enum AlignmentConstants | Тип выравнивания
Enum BarButtonGroupPositionConstants | Способ участия кнопок на панели или ленте инструментов в группе кнопок
Enum BarItemPositionConstants | Способ размещения элементов на ленте инструментов
Enum BarPaintStyleConstants | Рекомендованный способ отображения элементов на панели или ленте инструментов
Enum CursorConstants | Типы курсоров
Enum MouseButtonConstants | Тип кнопки мышки
Enum ShiftStateConstants | Состояния клавиш Ctrl, Alt, Shift, кнопок мышки, а также контроллера привязки. Данные константы могут использоваться в комбинации для задания состояния сразу нескольких клавиш клавиатуры, кнопок мышки и контроллера привязки
Enum DrawPointCaption | Варианты отображения подписи точек в плане
Enum SurfaceDifferenceProjectionConstants | Виды проекций для отображения отметок при построении разности поверхностей
Enum RepresentLineConstants | Комбинацией данных флагов определяется, какие данные будут возвращены при представлении ломаной
Enum RouteModelModifiedConstants | Комбинацией данных флагов определяется, что изменилось в элементах трассы
Enum Controller3DEventConstants | Причина вызова метода KeyboardEvent у контроллера 3D-вида
Enum CallReasonKeyboardConstants | Причина вызова метода ProcessKeyboard у текущего режима работы
Enum CallReasonMouseConstants | Причина вызова метода ProcessMouse у текущего режима работы
Enum LogPriorityConstants | Приоритеты событий, записываемых в файл журнала
Enum PropertyStreamConstants | Типы элементов PropertyStream'a
Enum SelectsConstants | Типы селекций, реализованных в системе (используются дополнительными модулями)
Enum StatusPanelConstants | Индексы панелей в строке статуса главного окна приложения
Enum CompressionLevelConstants | Способ сжатия данных
Enum ProfilePointTypeConstants | Тип отрезка при генерации профиля
Enum ProfileSegmentTypeConstants | Тип отрезка при генерации профиля
Enum SlopeModeConstants | Способ задания наклона поверхности к горизонтали
Enum TriangulationFormatConstants | Тип исходных данных в триангуляции
Enum TrnAreaConstants | Тип региона триангуляции
Enum TrnFigureKindConstants | Тип объектов триангуляции
Enum TrnFlipAbilityConstants | Результат проверки на возможность переброски ребра в указанной точке триангуляции
Enum TrnModifierKindConstants | Тип модификатора
Enum TrnNodeConstants | Статус узла триангуляции
Enum TrnNodeWeightModeConstants | Способ вычисления весов треугольников вокруг узла при вычисление нормали узла по смежным треугольникам
Enum TrnSaveModeConstants | Режим сохранения триангуляции
Enum TrnTriangleConstants | Статус треугольника триангуляции
Enum VolumeTypeConstants | Способ вычисления объёмов работ под и над землей
Enum BrushStyleConstants | Способ закраски
Enum FontStyleConstants | Стиль шрифта
Enum PenStyleConstants | Способ рисования линий
Enum FrameFormatConstants | Формат кадра видеоряда.
Enum ServerTypeConstants | Тип сервера данных и, соответственно, диалекта языка SQL
Enum TAlignmentType |
Enum TCommunicationType |
Enum TElevationMethod |
Enum TLineType |
Enum TObjectType |
Enum TPointType |
Enum TPolygonType |
Enum TRoofType |
Enum TSurfaceType |
Enum TTreeType |
Enum AngleModeConstants | Точность отображения углов
Enum FieldTraverseConstants | Типы теодолитных ходов
Enum IntersectionConstants | Типы дополнительных точек (засечек)
Enum SurveyEditorPageConstants | Страницы геодезического редактора
Enum AssemblyParameterConstants | Запоминаемые параметры в собрании слоёв
Enum CompositionSmoothFilterConstants | Тип сглаживающего фильтра в контейнере
Enum ContainerAnimationConstants | Способ анимации навигации в контейнере
Enum ContainerGridTypeConstants | Тип сетки в контейнере
Enum EditPhaseConstants | Фаза режима редактирования контейнера
Enum PanDirectionConstants | Направление панорамирования
Enum SelectModeConstants | Способы выделения объектов
Enum SystemAxesConstants | Тип ввода мультиточек
Enum TrackerConstants | Тип ввода мультиточек
Enum TrackingStopConstants | Способ остановки ввода данных на карту
Enum BrowserConstants | Стиль браузера
Enum DatasetLinkingStatusConstants | Статус подключения к набору данных
Enum FieldConstants | Типы полей наборов данных
Enum FieldViewConstants | Представление полей таблицы в диалогах, способ их ввода
Enum LayerDatasetModeConstants | Тип множества элементов в наборе данных слоя
Enum TimeViewStyleConstants | Тип данных времени
Enum CompositionLayerConstants | Тип слоя карты
Enum LayerRequestConstants | Способ выполнения запроса LayerRequest
Enum PasteFromClipboardConstants | Режим вставки фигур из буфера обмена
Enum RequestVariableConstants | Способ ввода значений переменных, участвующих в запросе к карте
Enum SwitchItemStateConstants | Требуемое состояние при переключении состояний элементов
Enum SwitchItemTypesConstants | Допустимые типы переключаемых элементов чертежа
Enum ADOCommandConstants | Тип команды ADO
Enum ADOLockConstants | Тип блокировки ADO
Enum DatasetLinkAddConstants | Режимы добавления записей при связи наборов данных
Enum LinkedDatabaseStatusConstants | Статус подключения к БД
Enum LinkedDatasetStatusConstants | Результат последнего открытия набора данных
Enum AdjustPointConstants | Вид точки настройки
Enum ShapeFieldConstants | Тип атрибута шейп-файла
Enum NotchKindConstants | Тип засечек на концах размерной линии
Enum ShapeTypeConstants | Тип шейп-фигур
Enum TopoFillKindConstants | Тип площадного условного знака
Enum TopoLineKindConstants | Тип линейного условного знака
Enum TopoSymbolKindConstants | Тип точечного условного знака
Enum UndoFinishModeConstants | Режим завершения записи блока данных
Enum BSplineEdgeConstants | Тип краевого ограничения для B-сплайнов, построенных по полилиниям
Enum CurveKindConstants | Тип кривой (линия или сплайн)
Enum EdgeCurvatureConstants | Вид граничных условий при отрисовке сплайнами


Класс AdditionalPoint

Абстрактная дополнительная точка (засечка)

Наследование

GeoPoint Class AdditionalPoint Class KnownAdditionalPoint, RangeAdditionalPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AdditionalPointType (только для чтения) | Тип засечки
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Number | Номер (описание) точки
Property Position | Положение точки

Где используется

Класс | Член класса
Class FieldTraverse | Property AdditionalPoints (свойство) Method AddAdditionalPoint (метод)
Class SurveyEditor | Property ActiveAdditionalPoint (свойство)

Смотри также

Enum IntersectionConstants, Class ModelPoint, Group Геодезия


AdditionalPoint.AdditionalPointType (свойство)

Тип засечки

Синтаксис

[Visual Basic 6]
ReadOnly Property AdditionalPointType As IntersectionConstants

[Delphi]
{только для чтения} property AdditionalPointType: IntersectionConstants

Смотри также

Class AdditionalPoint, Enum IntersectionConstants, Group Геодезия


AdditionalPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class AdditionalPoint, Group Геодезия


AdditionalPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class AdditionalPoint, Group Геодезия


AdditionalPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class AdditionalPoint, Group Геодезия


AdditionalPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class AdditionalPoint, Group Геодезия


AdditionalPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class AdditionalPoint, Group Геодезия


AdditionalPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class AdditionalPoint, Class ModelPoint, Group Геодезия


Класс Aggregate

Объект, содержащий в себе разнотипные объекты IndorCAD

Наследование

BaseObject Class Aggregate Class Layer, Project, Route

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Возвращает подэлемент по его сингатуре (ветвь дерева)
Property Project (только для чтения) | Проект, к которому относится объект

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Changed | Информирует объект о том, что произошли изменения. SetModifiedFlag=True - объекту выставляется признак "Модифицирована". NeedRepaint=True - необходимо перерисовать план. OptionsChanged=True - изменились невизуальные свойства объекта
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method InvalidCrossectionsData | Вызывается подобъектами, если их данные, которые могут отображаться в сечениях, изменились
Method MakeTreeStructure | Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта
Method TreeStructureChanged | Информирует объект о том, что необходимо перерисовать либо перестроить дерево структуры проекта

Где используется

Класс | Член класса
Class ICADDataCreator | Method CreateInstance (метод)

Смотри также

Class Application, Interface ICADObject, Interface IDocTreeHandler, Class Project, Group Проекты


Aggregate.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Aggregate, Class Application, Group Проекты


Aggregate.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Aggregate, Group Проекты


Aggregate.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Aggregate, Group Проекты


Aggregate.Items (свойство)

Возвращает подэлемент по его сингатуре (ветвь дерева)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As ICADObject

[Delphi]
{только для чтения} property Items: ICADObject

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class Aggregate, Interface ICADObject, Group Проекты


Aggregate.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Aggregate, Class Project, Group Проекты


Aggregate.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Aggregate, Group Проекты


Aggregate.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Aggregate, Group Проекты


Aggregate.Changed (метод)

Информирует объект о том, что произошли изменения. SetModifiedFlag=True - объекту выставляется признак "Модифицирована". NeedRepaint=True - необходимо перерисовать план. OptionsChanged=True - изменились невизуальные свойства объекта

Синтаксис

[Visual Basic 6]
Sub Changed ( _
   ByVal SetModifiedFlag As Boolean, _
   ByVal NeedRepaint As Boolean, _
   ByVal OptionsChanged As Boolean _
)

[Delphi]
procedure Changed(
   const SetModifiedFlag: WordBool;
   const NeedRepaint: WordBool;
   const OptionsChanged: WordBool
)

Описание параметров

SetModifiedFlag
[in] True - необходимо установить у объекта признак "модифицирован"
NeedRepaint
[in] True - необходимо перерисовать план
OptionsChanged
[in] True - изменились невизуальные свойства объекта

Смотри также

Class Aggregate, Group Проекты


Aggregate.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Aggregate, Group Проекты


Aggregate.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Aggregate, Group Проекты


Aggregate.InvalidCrossectionsData (метод)

Вызывается подобъектами, если их данные, которые могут отображаться в сечениях, изменились

Синтаксис

[Visual Basic 6]
Sub InvalidCrossectionsData ( _
   ByVal StructureChanged As Boolean _
)

[Delphi]
procedure InvalidCrossectionsData(
   const StructureChanged: WordBool
)

Описание параметров

StructureChanged
[in] True - необходимо только перерисовать сечения, False - изменилась структура данных и необходимо перестроить список профильных объектов

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Aggregate, Group Проекты


Aggregate.MakeTreeStructure (метод)

Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта

Синтаксис

[Visual Basic 6]
Sub MakeTreeStructure ( _
   ByVal Handler As IDocTreeHandler, _
   ByVal ParentID As Long, _
   ByVal Reason As Long, _
   ByVal IncludeHidden As Boolean _
)

[Delphi]
procedure MakeTreeStructure(
   const Handler: IDocTreeHandler;
   const ParentID: Integer;
   const Reason: Integer;
   const IncludeHidden: WordBool
)

Описание параметров

Handler
[in] Объект, которому будут поочерёдно передаваться все объекты, содержащиеся в проекте
ParentID
[in] Некий идентификатор родительского узла (обычно "0")
Reason
[in] Значение, которое будет передаваться в Handler при добавлении объектов. По нему Handler, принимающий перечисляемые объекты, может определить, что с ними делать
IncludeHidden
[in] Некоторые объекты могут не перечислять себя, если они не содержат подобъектов. Если IncludeHidden установлен в True, то объект должен перечислить себя в любом случае

Смотри также

Class Aggregate, Interface IDocTreeHandler, Group Проекты


Aggregate.TreeStructureChanged (метод)

Информирует объект о том, что необходимо перерисовать либо перестроить дерево структуры проекта

Синтаксис

[Visual Basic 6]
Sub TreeStructureChanged ( _
   ByVal Rescan As Boolean _
)

[Delphi]
procedure TreeStructureChanged(
   const Rescan: WordBool
)

Описание параметров

Rescan
[in] True - дерево полностью будет перестроено, False - только перерисовано

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Aggregate, Group Проекты


Класс Application

Приложение IndorCAD

Наследование

IDispatch Class ICommonApplication Class Application

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ActiveProject (только для чтения) | Текущий активный проект
Property ApplicationHandle (только для чтения) | Handle приложения
Property AutoUnloadUnusedLibraries | Автоматически выгружать неиспользуемые библиотеки ActiveX
Property DrawFinished (только для чтения) | True - признак того, что отрисовка плана полностью закончена
Property ExeName (только для чтения) | Имя главного выполняемого файла системы
Property ExePath (только для чтения) | Путь к исполняемому exe-файлу приложения
Property HelpFile | Имя файла помощи
Property HInstance (только для чтения) | HInstance приложения
Property HintEnable | Отображать подсказки в системе
Property HintHidePause | Задержка перед удалением подсказки с экрана в милисекундах
Property HintNextPause | Задержка перед показом следующей подсказки в милисекундах
Property HintShortcuts | Включить в подсказки сочетания клавиш
Property HintShowPause | Задержка перед отображением подсказки в милисекундах
Property Images (только для чтения) | Стандартный набор картинок
Property Options (только для чтения) | Настройки проложения
Property Plugins (только для чтения) | Менеджер дополнительных модулей к системе
Property ProjectCount (только для чтения) | Количество проектов, открытых в данный момент
Property Projects (только для чтения) | Массив открытых проектов
Property RegistryKey (только для чтения) | Возвращает путь в реестре, в котором система хранит свои настройки
Property SubSystem3D (только для чтения) | Подсистема 3D-вида. Возвращает Nothing, если 3D-вид недоступен в данной версии
Property SurveyEditor (только для чтения) | Геодезический редактор
Property Title (только для чтения) | Заголовок главного окна системы
Property ValidMenuHotkeysChars (только для чтения) | Возвращает строку с "правильными" символами, которые могут быть подчёркнуты в меню
Property Version (только для чтения) | Информация о версии приложения
Property Visible | Видно ли главное окно приложения

Методы класса

Имя | Описание
Method Advise | Подключиться к событиям приложения (возвращаемое число нужно впоследствии передать в Unadvise)
Method BeginProgress | Инициализация строки прогресса
Method BeginSubProgress | Разрешить вложение прогрессов, выделив в текущем прогрессе допустимый диапазон
Method CreateFlatPoint | Создать новую двумерную точку с плоскими координатами контейнера
Method CreateFlatRect | Создать новый прямоугольник с плоскими координатами контейнера
Method CreateModelParallelogram | Создать новый параллелограмм с вещественными модельными координатами
Method CreateModelPoint | Создать новую двумерную точку с вещественными модельными координатами
Method CreateModelRect | Создать новый прямоугольник с вещественными модельными координатами
Method CreateParallelogram | Создать новый параллелограмм с целочисленными координатами
Method CreatePoint | Создать новую двумерную точку с целочисленными координатами
Method CreatePoint3D | Создать новую трёхмерную точку с целочисленными координатами
Method CreateRect | Создать новый прямоугольник с целочисленными координатами
Method DisableAllWindows | Временно полностью запретить все окна системы
Method EnableAllWindows | Разрешает окна системы, ранее запрещённые вызовом DisableAllWindows
Method EndProgress | Закончить процесс вывода строки прогресса
Method EndSubProgress | Запретить вложенные прогрессы
Method FindAndExecuteAction | Находит действие (Action) по указаному имени, выполняет и возвращает его
Method GetProgress | Получить значение статуса текущей длительной операции
Method GotoWeb | Открыть домашнюю Web-страницу системы
Method Help | Вызывает помощь по указанной строке-идентификатору
Method Hide | Скрыть главное окно приложение (минимизировать)
Method IncProgress | Увеличить статус операции на заданный шаг (по умолчанию на 1)
Method IsDemoMode | Проверить, работает ли программа в демонстрационном режиме
Method IsFeatureAvailable | Проверить, доступна ли лицензия на указанный объект
Method IsLicenseRestricted | Проверить, работает ли программа в режиме ограничения на объём данных
Method IsProgressVisible | В настоящий момент бежит строка Progress?
Method IsSubProgress | В настоящий момент бежит строка вложенного прогресса?
Method Log | Записывает указанное сообщение в файл журнала
Method NewProject | Создаёт новый (пустой) проект
Method OpenProject | Открывает проект из указанного файла
Method RegisterCursor | Зарегистрировать в системе новый курсор или заменить старый
Method RegisterImporter | Регистрирует процедуру импорта в системе
Method SendEmail | Послать письмо разработчиками системы по электронной почте
Method SetProgress | Установить текущее положение строки прогресса
Method SetProgressText | Задать отображаемый текст строки прогресса
Method Show | Восстановить главное окно приложения
Method ShowError | Вывести в диалоге краткое сообщение об ошибке
Method ShowMessage | Вывести в диалоге краткое сообщение
Method ShowWarning | Вывести в диалоге краткое предупреждение
Method Terminate | Завершить работу системы
Method Unadvise | Отключиться от событий приложения (передаваемое число ранее должно быть получено от метода Advise
Method UnloadUnusedLibraries | Выгружает из памяти неиспользуемые библиотеки с объектами ActiveX
Method UnRegisterImporter | Аннулирует регистрацию процедуры импорта в системе. Параметром передаётся Cookie, полученный при регистрации процедуры импорта

События класса

Имя | Описание
Method Idle | Вызывается при наличии свободного процессорного времени
Method ProjectActivated | Вызывается при активизации проекта
Method ProjectCreate | Вызывается при создании проекта

Где используется

Класс | Член класса
Class Aggregate | Property Application (свойство)
Class BaseObject | Property Application (свойство)
Class BaseObjectList | Property Application (свойство)
Class CADAction | Property Application (свойство)
Class DrawingSheet | Property Application (свойство)
Class DrawingSheets | Property Application (свойство)
Class Grid | Property Application (свойство)
Class Layer | Property Application (свойство)
Class LayerPoint | Property Application (свойство)
Class LayerPoints | Property Application (свойство)
Class Layers | Property Application (свойство)
Class Line | Property Application (свойство)
Class LineGroup | Property Application (свойство)
Class Lines | Property Application (свойство)
Class Project | Property Application (свойство)
Class Route | Property Application (свойство)
Class RouteElement | Property Application (свойство)
Class Routes | Property Application (свойство)
Class RouteVertex | Property Application (свойство)
Class StringName | Property Application (свойство)
Class StringNameCollection | Property Application (свойство)
Class StringNameGroup | Property Application (свойство)
Class SurfaceDifference | Property Application (свойство)
Class SurfaceDifferences | Property Application (свойство)
Class SurfacePainter | Property Application (свойство)
Class SurfacePainters | Property Application (свойство)

Смотри также

Class ApplicationOptions, Enum CursorConstants, Class FlatPoint, Class FlatRect, Interface IApplicationEvents, Interface IImporter, Class Images, Enum LogPrecisionConstants, Class ModelParallelogram, Class ModelPoint, Class ModelRect, Class Parallelogram, Class PluginManager, Class Point, Class Point3D, Class Rect, Class SubSystem3D, Class SurveyEditor, Class Version, Group Приложение


Application.ActiveProject (свойство)

Текущий активный проект

Синтаксис

[Visual Basic 6]
ReadOnly Property ActiveProject As Project

[Delphi]
{только для чтения} property ActiveProject: Project

Смотри также

Class Application, Class Project, Group Приложение


Application.ApplicationHandle (свойство)

Handle приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property ApplicationHandle As OLE_HANDLE

[Delphi]
{только для чтения} property ApplicationHandle: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Application, Group Приложение


Application.AutoUnloadUnusedLibraries (свойство)

Автоматически выгружать неиспользуемые библиотеки ActiveX

Синтаксис

[Visual Basic 6]
Property AutoUnloadUnusedLibraries As Boolean

[Delphi]
property AutoUnloadUnusedLibraries: WordBool

Смотри также

Class Application, Group Приложение


Application.DrawFinished (свойство)

True - признак того, что отрисовка плана полностью закончена

Синтаксис

[Visual Basic 6]
ReadOnly Property DrawFinished As Boolean

[Delphi]
{только для чтения} property DrawFinished: WordBool

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class Application, Group Приложение


Application.ExeName (свойство)

Имя главного выполняемого файла системы

Синтаксис

[Visual Basic 6]
ReadOnly Property ExeName As String

[Delphi]
{только для чтения} property ExeName: WideString

Смотри также

Class Application, Group Приложение


Application.ExePath (свойство)

Путь к исполняемому exe-файлу приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property ExePath As String

[Delphi]
{только для чтения} property ExePath: WideString

Смотри также

Class Application, Group Приложение


Application.HelpFile (свойство)

Имя файла помощи

Синтаксис

[Visual Basic 6]
Property HelpFile As String

[Delphi]
property HelpFile: WideString

Смотри также

Class Application, Group Приложение


Application.HInstance (свойство)

HInstance приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property HInstance As OLE_HANDLE

[Delphi]
{только для чтения} property HInstance: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Application, Group Приложение


Application.HintEnable (свойство)

Отображать подсказки в системе

Синтаксис

[Visual Basic 6]
Property HintEnable As Boolean

[Delphi]
property HintEnable: WordBool

Смотри также

Class Application, Group Приложение


Application.HintHidePause (свойство)

Задержка перед удалением подсказки с экрана в милисекундах

Синтаксис

[Visual Basic 6]
Property HintHidePause As Long

[Delphi]
property HintHidePause: Integer

Смотри также

Class Application, Group Приложение


Application.HintNextPause (свойство)

Задержка перед показом следующей подсказки в милисекундах

Синтаксис

[Visual Basic 6]
Property HintNextPause As Long

[Delphi]
property HintNextPause: Integer

Смотри также

Class Application, Group Приложение


Application.HintShortcuts (свойство)

Включить в подсказки сочетания клавиш

Синтаксис

[Visual Basic 6]
Property HintShortcuts As Boolean

[Delphi]
property HintShortcuts: WordBool

Смотри также

Class Application, Group Приложение


Application.HintShowPause (свойство)

Задержка перед отображением подсказки в милисекундах

Синтаксис

[Visual Basic 6]
Property HintShowPause As Long

[Delphi]
property HintShowPause: Integer

Смотри также

Class Application, Group Приложение


Application.Images (свойство)

Стандартный набор картинок

Синтаксис

[Visual Basic 6]
ReadOnly Property Images As Images

[Delphi]
{только для чтения} property Images: Images

Смотри также

Class Application, Class Images, Group Приложение


Application.Options (свойство)

Настройки проложения

Синтаксис

[Visual Basic 6]
ReadOnly Property Options As ApplicationOptions

[Delphi]
{только для чтения} property Options: ApplicationOptions

Смотри также

Class Application, Class ApplicationOptions, Group Приложение


Application.Plugins (свойство)

Менеджер дополнительных модулей к системе

Синтаксис

[Visual Basic 6]
ReadOnly Property Plugins As PluginManager

[Delphi]
{только для чтения} property Plugins: PluginManager

Смотри также

Class Application, Class PluginManager, Group Приложение


Application.ProjectCount (свойство)

Количество проектов, открытых в данный момент

Синтаксис

[Visual Basic 6]
ReadOnly Property ProjectCount As Long

[Delphi]
{только для чтения} property ProjectCount: Integer

Смотри также

Class Application, Group Приложение


Application.Projects (свойство)

Массив открытых проектов

Синтаксис

[Visual Basic 6]
ReadOnly Property Projects As Project

[Delphi]
{только для чтения} property Projects: Project

Смотри также

Class Application, Class Project, Group Приложение


Application.RegistryKey (свойство)

Возвращает путь в реестре, в котором система хранит свои настройки

Синтаксис

[Visual Basic 6]
ReadOnly Property RegistryKey As String

[Delphi]
{только для чтения} property RegistryKey: WideString

Смотри также

Class Application, Group Приложение


Application.SubSystem3D (свойство)

Подсистема 3D-вида. Возвращает Nothing, если 3D-вид недоступен в данной версии

Синтаксис

[Visual Basic 6]
ReadOnly Property SubSystem3D As SubSystem3D

[Delphi]
{только для чтения} property SubSystem3D: SubSystem3D

Смотри также

Class Application, Class SubSystem3D, Group Приложение


Application.SurveyEditor (свойство)

Геодезический редактор

Синтаксис

[Visual Basic 6]
ReadOnly Property SurveyEditor As SurveyEditor

[Delphi]
{только для чтения} property SurveyEditor: SurveyEditor

Смотри также

Class Application, Class SurveyEditor, Group Приложение


Application.Title (свойство)

Заголовок главного окна системы

Синтаксис

[Visual Basic 6]
ReadOnly Property Title As String

[Delphi]
{только для чтения} property Title: WideString

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Application, Group Приложение


Application.ValidMenuHotkeysChars (свойство)

Возвращает строку с "правильными" символами, которые могут быть подчёркнуты в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidMenuHotkeysChars As String

[Delphi]
{только для чтения} property ValidMenuHotkeysChars: WideString

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Application, Group Приложение


Application.Version (свойство)

Информация о версии приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property Version As Version

[Delphi]
{только для чтения} property Version: Version

Смотри также

Class Application, Class Version, Group Приложение


Application.Visible (свойство)

Видно ли главное окно приложения

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Application, Group Приложение


Application.Advise (метод)

Подключиться к событиям приложения (возвращаемое число нужно впоследствии передать в Unadvise)

Синтаксис

[Visual Basic 6]
Function Advise ( _
   ByVal EventHandler As IApplicationEvents _
) As Long

[Delphi]
function Advise(
   const EventHandler: IApplicationEvents
): Integer

Описание параметров

EventHandler
[in] Обработчик событий приложения

Возвращаемое значение

Возвращает код соединения, который нужно впоследствии передать в метод Unadvise

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class Application, Interface IApplicationEvents, Group Приложение


Application.BeginProgress (метод)

Инициализация строки прогресса

Синтаксис

[Visual Basic 6]
Sub BeginProgress ( _
   ByVal Caption As String, _
   ByVal MaxValue As Long _
)

[Delphi]
procedure BeginProgress(
   const Caption: WideString;
   const MaxValue: Integer
)

Описание параметров

Caption
[in] Заголовок, выводимый в строке прогресса
MaxValue
[in] Макcимальное значение, до которого будет идти прогресс

Смотри также

Class Application, Group Приложение


Application.BeginSubProgress (метод)

Разрешить вложение прогрессов, выделив в текущем прогрессе допустимый диапазон

Синтаксис

[Visual Basic 6]
Sub BeginSubProgress ( _
   ByVal MainMinPos As Long, _
   ByVal MainMaxPos As Long _
)

[Delphi]
procedure BeginSubProgress(
   const MainMinPos: Integer;
   const MainMaxPos: Integer
)

Описание параметров

MainMinPos
[in] Минимальное значение диапазона в родительском прогрессе
MainMaxPos
[in] Максимальное значение диапазона в родительском прогрессе

Смотри также

Class Application, Group Приложение


Application.CreateFlatPoint (метод)

Создать новую двумерную точку с плоскими координатами контейнера

Синтаксис

[Visual Basic 6]
Function CreateFlatPoint As FlatPoint

[Delphi]
function CreateFlatPoint: FlatPoint

Возвращаемое значение

Возвращает новую двумерную точку с плоскими координатами контейнера

Смотри также

Class Application, Class FlatPoint, Group Приложение


Application.CreateFlatRect (метод)

Создать новый прямоугольник с плоскими координатами контейнера

Синтаксис

[Visual Basic 6]
Function CreateFlatRect As FlatRect

[Delphi]
function CreateFlatRect: FlatRect

Возвращаемое значение

Возвращает новый прямоугольник с плоскими координатами контейнера

Смотри также

Class Application, Class FlatRect, Group Приложение


Application.CreateModelParallelogram (метод)

Создать новый параллелограмм с вещественными модельными координатами

Синтаксис

[Visual Basic 6]
Function CreateModelParallelogram As ModelParallelogram

[Delphi]
function CreateModelParallelogram: ModelParallelogram

Возвращаемое значение

Возвращает новый прямоугольник с вещественными модельными координатами

Смотри также

Class Application, Class ModelParallelogram, Group Приложение


Application.CreateModelPoint (метод)

Создать новую двумерную точку с вещественными модельными координатами

Синтаксис

[Visual Basic 6]
Function CreateModelPoint As ModelPoint

[Delphi]
function CreateModelPoint: ModelPoint

Возвращаемое значение

Возвращает двумерную новую точку с вещественными модельными координатами

Смотри также

Class Application, Class ModelPoint, Group Приложение


Application.CreateModelRect (метод)

Создать новый прямоугольник с вещественными модельными координатами

Синтаксис

[Visual Basic 6]
Function CreateModelRect As ModelRect

[Delphi]
function CreateModelRect: ModelRect

Возвращаемое значение

Возвращает новый прямоугольник с вещественными модельными координатами

Смотри также

Class Application, Class ModelRect, Group Приложение


Application.CreateParallelogram (метод)

Создать новый параллелограмм с целочисленными координатами

Синтаксис

[Visual Basic 6]
Function CreateParallelogram As Parallelogram

[Delphi]
function CreateParallelogram: Parallelogram

Возвращаемое значение

Возвращает новый прямоугольник с целочисленными координатами

Смотри также

Class Application, Class Parallelogram, Group Приложение


Application.CreatePoint (метод)

Создать новую двумерную точку с целочисленными координатами

Синтаксис

[Visual Basic 6]
Function CreatePoint As Point

[Delphi]
function CreatePoint: Point

Возвращаемое значение

Возвращает новую двумерную точку с целочисленными координатами

Смотри также

Class Application, Class Point, Group Приложение


Application.CreatePoint3D (метод)

Создать новую трёхмерную точку с целочисленными координатами

Синтаксис

[Visual Basic 6]
Function CreatePoint3D As Point3D

[Delphi]
function CreatePoint3D: Point3D

Возвращаемое значение

Возвращает новую трёхмерную точку с целочисленными координатами

Смотри также

Class Application, Class Point3D, Group Приложение


Application.CreateRect (метод)

Создать новый прямоугольник с целочисленными координатами

Синтаксис

[Visual Basic 6]
Function CreateRect As Rect

[Delphi]
function CreateRect: Rect

Возвращаемое значение

Возвращает новый прямоугольник с целочисленными координатами

Смотри также

Class Application, Class Rect, Group Приложение


Application.DisableAllWindows (метод)

Временно полностью запретить все окна системы

Синтаксис

[Visual Basic 6]
Function DisableAllWindows As Long

[Delphi]
function DisableAllWindows: Integer

Возвращаемое значение

Возвращает код, который нужно обязательно передать в функцию EnableAllWindows после окончании взаимодействия с программой

Смотри также

Class Application, Group Приложение


Application.EnableAllWindows (метод)

Разрешает окна системы, ранее запрещённые вызовом DisableAllWindows

Синтаксис

[Visual Basic 6]
Sub EnableAllWindows ( _
   ByVal Cookie As Long _
)

[Delphi]
procedure EnableAllWindows(
   const Cookie: Integer
)

Описание параметров

Cookie
[in] Код, который был получен в предыдущем вызове DisableAllWindows

Смотри также

Class Application, Group Приложение


Application.EndProgress (метод)

Закончить процесс вывода строки прогресса

Синтаксис

[Visual Basic 6]
Sub EndProgress

[Delphi]
procedure EndProgress

Смотри также

Class Application, Group Приложение


Application.EndSubProgress (метод)

Запретить вложенные прогрессы

Синтаксис

[Visual Basic 6]
Sub EndSubProgress

[Delphi]
procedure EndSubProgress

Смотри также

Class Application, Group Приложение


Application.FindAndExecuteAction (метод)

Находит действие (Action) по указаному имени, выполняет и возвращает его

Синтаксис

[Visual Basic 6]
Function FindAndExecuteAction ( _
   ByVal ActionName As String, _
   ByVal Param1 As Variant, _
   ByVal Param2 As Variant, _
   ByVal Param3 As Variant _
) As CADAction

[Delphi]
function FindAndExecuteAction(
   const ActionName: WideString;
   const Param1: Variant;
   const Param2: Variant;
   const Param3: Variant
): CADAction

Описание параметров

ActionName
[in] Имя действия
Param1
[in] Первый параметр действия
Param2
[in] Второй параметр действия
Param3
[in] Третий параметр действия

Возвращаемое значение

Возвращается указатель на действие (Action)

Смотри также

Class Application, Class CADAction, Group Приложение


Application.GetProgress (метод)

Получить значение статуса текущей длительной операции

Синтаксис

[Visual Basic 6]
Function GetProgress As Long

[Delphi]
function GetProgress: Integer

Возвращаемое значение

Возвращает текущее положение отметки прогресса

Смотри также

Class Application, Group Приложение


Application.GotoWeb (метод)

Открыть домашнюю Web-страницу системы

Синтаксис

[Visual Basic 6]
Sub GotoWeb

[Delphi]
procedure GotoWeb

Смотри также

Class Application, Group Приложение


Application.Help (метод)

Вызывает помощь по указанной строке-идентификатору

Синтаксис

[Visual Basic 6]
Sub Help ( _
   ByVal Signature As String _
)

[Delphi]
procedure Help(
   const Signature: WideString
)

Описание параметров

Signature
[in] Строка (латиница), идентифицирующая индекс в файле помощи

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Application, Group Приложение


Application.Hide (метод)

Скрыть главное окно приложение (минимизировать)

Синтаксис

[Visual Basic 6]
Sub Hide

[Delphi]
procedure Hide

Смотри также

Class Application, Group Приложение


Application.IncProgress (метод)

Увеличить статус операции на заданный шаг (по умолчанию на 1)

Синтаксис

[Visual Basic 6]
Sub IncProgress ( _
   [ByVal Step As Long = 1] _
)

[Delphi]
procedure IncProgress(
   const Step: Integer
)

Описание параметров

Step
[in] Шаг, на который следует увеличить текущее состояние прогресса

Смотри также

Class Application, Group Приложение


Application.IsDemoMode (метод)

Проверить, работает ли программа в демонстрационном режиме

Синтаксис

[Visual Basic 6]
Function IsDemoMode As Boolean

[Delphi]
function IsDemoMode: WordBool

Возвращаемое значение

Возвращает True, если программа работает в демонстрационном режиме

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Application, Group Приложение


Application.IsFeatureAvailable (метод)

Проверить, доступна ли лицензия на указанный объект

Синтаксис

[Visual Basic 6]
Function IsFeatureAvailable ( _
   ByVal FeatureName As String _
) As Boolean

[Delphi]
function IsFeatureAvailable(
   const FeatureName: WideString
): WordBool

Описание параметров

FeatureName
[in] Имя лицензируемого объекта

Возвращаемое значение

Возвращает True, если объект лицензирован

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class Application, Group Приложение


Application.IsLicenseRestricted (метод)

Проверить, работает ли программа в режиме ограничения на объём данных

Синтаксис

[Visual Basic 6]
Function IsLicenseRestricted As Boolean

[Delphi]
function IsLicenseRestricted: WordBool

Возвращаемое значение

Возвращает True, если программа работает в режиме ограничения на объём данных

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Application, Group Приложение


Application.IsProgressVisible (метод)

В настоящий момент бежит строка Progress?

Синтаксис

[Visual Basic 6]
Function IsProgressVisible As Boolean

[Delphi]
function IsProgressVisible: WordBool

Возвращаемое значение

Возвращает True, если в настоящее время строка прогресса видна

Смотри также

Class Application, Group Приложение


Application.IsSubProgress (метод)

В настоящий момент бежит строка вложенного прогресса?

Синтаксис

[Visual Basic 6]
Function IsSubProgress As Boolean

[Delphi]
function IsSubProgress: WordBool

Возвращаемое значение

Возвращает True, если в настоящий момент бежит строка вложенного прогресса

Смотри также

Class Application, Group Приложение


Application.Log (метод)

Записывает указанное сообщение в файл журнала

Синтаксис

[Visual Basic 6]
Sub Log ( _
   ByVal Message As String, _
   [ByVal LogPrecision As LogPrecisionConstants = 1] _
)

[Delphi]
procedure Log(
   const Message: WideString;
   const LogPrecision: LogPrecisionConstants
)

Описание параметров

Message
[in] Сообщение для записи в файл журнала
LogPrecision
[in] Уровень детализации при журналировани

Смотри также

Class Application, Enum LogPrecisionConstants, Group Приложение


Application.NewProject (метод)

Создаёт новый (пустой) проект

Синтаксис

[Visual Basic 6]
Function NewProject As Project

[Delphi]
function NewProject: Project

Возвращаемое значение

Созданный проект

Смотри также

Class Application, Class Project, Group Приложение


Application.OpenProject (метод)

Открывает проект из указанного файла

Синтаксис

[Visual Basic 6]
Function OpenProject ( _
   ByVal FileName As String _
) As Project

[Delphi]
function OpenProject(
   const FileName: WideString
): Project

Описание параметров

FileName
[in] Имя файла проектв

Возвращаемое значение

Загруженный из файла проект, либо Nothing в случае ошибки

Смотри также

Class Application, Class Project, Group Приложение


Application.RegisterCursor (метод)

Зарегистрировать в системе новый курсор или заменить старый

Синтаксис

[Visual Basic 6]
Sub RegisterCursor ( _
   ByVal Cursor As CursorConstants, _
   ByVal HCursor As OLE_HANDLE _
)

[Delphi]
procedure RegisterCursor(
   const Cursor: CursorConstants;
   const HCursor: OLE_HANDLE
)

Описание параметров

Cursor
[in] Номер курсора (можно использовать стандартный из списка CursorConstants или любой другой номер)
HCursor
[in] HCursor нового курсора

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Application, Enum CursorConstants, Group Приложение


Application.RegisterImporter (метод)

Регистрирует процедуру импорта в системе

Синтаксис

[Visual Basic 6]
Function RegisterImporter ( _
   ByVal Importer As IImporter, _
   ByVal FileMask As String, _
   ByVal UserData As Long _
) As Long

[Delphi]
function RegisterImporter(
   const Importer: IImporter;
   const FileMask: WideString;
   const UserData: Integer
): Integer

Описание параметров

Importer
[in] Объект, реализующий процедуру импорта
FileMask
[in] Маска файла в формате: 'Описание формата (*.xxx)>|*.xxx', где 'xxx'-расширение файлов, поддерживаемое процедурой импорта
UserData
[in] Произвольное число, ассоциируемое с процедурой импорта. Актуально, если один объект реализует несколько процедур импорта

Возвращаемое значение

Возвращает код экспорта, который можно впоследствии передать в метод UnRegisterImporter

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class Application, Interface IImporter, Group Приложение


Application.SendEmail (метод)

Послать письмо разработчиками системы по электронной почте

Синтаксис

[Visual Basic 6]
Sub SendEmail

[Delphi]
procedure SendEmail

Смотри также

Class Application, Group Приложение


Application.SetProgress (метод)

Установить текущее положение строки прогресса

Синтаксис

[Visual Basic 6]
Sub SetProgress ( _
   ByVal Position As Long _
)

[Delphi]
procedure SetProgress(
   const Position: Integer
)

Описание параметров

Position
[in] Установить текущую позицию строки прогресса

Смотри также

Class Application, Group Приложение


Application.SetProgressText (метод)

Задать отображаемый текст строки прогресса

Синтаксис

[Visual Basic 6]
Sub SetProgressText ( _
   ByVal Caption As String _
)

[Delphi]
procedure SetProgressText(
   const Caption: WideString
)

Описание параметров

Caption
[in] Текст надписи прогресса

Смотри также

Class Application, Group Приложение


Application.Show (метод)

Восстановить главное окно приложения

Синтаксис

[Visual Basic 6]
Sub Show

[Delphi]
procedure Show

Смотри также

Class Application, Group Приложение


Application.ShowError (метод)

Вывести в диалоге краткое сообщение об ошибке

Синтаксис

[Visual Basic 6]
Sub ShowError ( _
   ByVal Text As String _
)

[Delphi]
procedure ShowError(
   const Text: WideString
)

Описание параметров

Text
[in] Текст сообщения

Смотри также

Class Application, Group Приложение


Application.ShowMessage (метод)

Вывести в диалоге краткое сообщение

Синтаксис

[Visual Basic 6]
Sub ShowMessage ( _
   ByVal Msg As String _
)

[Delphi]
procedure ShowMessage(
   const Msg: WideString
)

Описание параметров

Msg
[in] Текст выводимого сообщения

Смотри также

Class Application, Group Приложение


Application.ShowWarning (метод)

Вывести в диалоге краткое предупреждение

Синтаксис

[Visual Basic 6]
Sub ShowWarning ( _
   ByVal Text As String _
)

[Delphi]
procedure ShowWarning(
   const Text: WideString
)

Описание параметров

Text
[in] Текст предупреждения

Смотри также

Class Application, Group Приложение


Application.Terminate (метод)

Завершить работу системы

Синтаксис

[Visual Basic 6]
Sub Terminate

[Delphi]
procedure Terminate

Смотри также

Class Application, Group Приложение


Application.Unadvise (метод)

Отключиться от событий приложения (передаваемое число ранее должно быть получено от метода Advise

Синтаксис

[Visual Basic 6]
Sub Unadvise ( _
   ByVal Cookie As Long _
)

[Delphi]
procedure Unadvise(
   const Cookie: Integer
)

Описание параметров

Cookie
[in] Код, возвращённый методом Advise)

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class Application, Group Приложение


Application.UnloadUnusedLibraries (метод)

Выгружает из памяти неиспользуемые библиотеки с объектами ActiveX

Синтаксис

[Visual Basic 6]
Sub UnloadUnusedLibraries

[Delphi]
procedure UnloadUnusedLibraries

Смотри также

Class Application, Group Приложение


Application.UnRegisterImporter (метод)

Аннулирует регистрацию процедуры импорта в системе. Параметром передаётся Cookie, полученный при регистрации процедуры импорта

Синтаксис

[Visual Basic 6]
Function UnRegisterImporter ( _
   ByVal Cookie As Long _
) As Boolean

[Delphi]
function UnRegisterImporter(
   const Cookie: Integer
): WordBool

Описание параметров

Cookie
[in] Код, полученный ранее при регистрации процедуры импорта

Возвращаемое значение

Возвращает True, если процедура импорта была успешно аннулирована

Смотри также

Class Application, Group Приложение


Application.Idle (метод)

Вызывается при наличии свободного процессорного времени

Синтаксис

[Visual Basic 6]
Event Idle ( _
   Done As Boolean _
)

[Delphi]
procedure Idle(
   var Done: WordBool
)

Описание параметров

Done
[in, out] Если обработчик данного события вернет Done=False, значит данный обработчик будет вызываться повторно до тех пор, пока не будет возвращен Done=True

Смотри также

Class Application, Group Приложение


Application.ProjectActivated (метод)

Вызывается при активизации проекта

Синтаксис

[Visual Basic 6]
Event ProjectActivated ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectActivated(
   const Project: Project
)

Описание параметров

Project
[in] Проект, который стал текущим. Если Project=Nothing, значит нет активного проекта

Смотри также

Class Application, Class Project, Group Приложение


Application.ProjectCreate (метод)

Вызывается при создании проекта

Синтаксис

[Visual Basic 6]
Event ProjectCreate ( _
   ByVal Project As Project, _
   ByVal CreatedAsNew As Boolean _
)

[Delphi]
procedure ProjectCreate(
   const Project: Project;
   const CreatedAsNew: WordBool
)

Описание параметров

Project
[in] Созданный проект
CreatedAsNew
[in] True - проект создан как новый. False - проект будет загружаться из файла

Смотри также

Class Application, Class Project, Group Приложение


Класс ApplicationOptions

Реализация настроек программы

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property DefaultLocalPlanetableLeft | Положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (X-координата)
Property DefaultLocalPlanetableTop | Положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (Y-координата)
Property DefaultStatePlanetableLeft | Положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат: (X-координата)
Property DefaultStatePlanetableTop | Положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат: (Y-координата)
Property LogFileName | Файл журнала событий (logs)
Property LogPrecision | Уровень детализации журнала событий
Property MouseWheelInverted | Обратная реакция на колесо мыши
Property ZoomTime | Время масштабирования при операциях ZoomIn, ZoomOut. При "0" рисуется сразу

Где используется

Класс | Член класса
Class Application | Property Options (свойство)

Смотри также

Enum LogPrecisionConstants, Group Приложение


ApplicationOptions.DefaultLocalPlanetableLeft (свойство)

Положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (X-координата)

Синтаксис

[Visual Basic 6]
Property DefaultLocalPlanetableLeft As Double

[Delphi]
property DefaultLocalPlanetableLeft: Double

Смотри также

Class ApplicationOptions, Group Приложение


ApplicationOptions.DefaultLocalPlanetableTop (свойство)

Положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (Y-координата)

Синтаксис

[Visual Basic 6]
Property DefaultLocalPlanetableTop As Double

[Delphi]
property DefaultLocalPlanetableTop: Double

Смотри также

Class ApplicationOptions, Group Приложение


ApplicationOptions.DefaultStatePlanetableLeft (свойство)

Положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат: (X-координата)

Синтаксис

[Visual Basic 6]
Property DefaultStatePlanetableLeft As Double

[Delphi]
property DefaultStatePlanetableLeft: Double

Смотри также

Class ApplicationOptions, Group Приложение


ApplicationOptions.DefaultStatePlanetableTop (свойство)

Положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат: (Y-координата)

Синтаксис

[Visual Basic 6]
Property DefaultStatePlanetableTop As Double

[Delphi]
property DefaultStatePlanetableTop: Double

Смотри также

Class ApplicationOptions, Group Приложение


ApplicationOptions.LogFileName (свойство)

Файл журнала событий (logs)

Синтаксис

[Visual Basic 6]
Property LogFileName As String

[Delphi]
property LogFileName: WideString

Смотри также

Class ApplicationOptions, Group Приложение


ApplicationOptions.LogPrecision (свойство)

Уровень детализации журнала событий

Синтаксис

[Visual Basic 6]
Property LogPrecision As LogPrecisionConstants

[Delphi]
property LogPrecision: LogPrecisionConstants

Смотри также

Class ApplicationOptions, Enum LogPrecisionConstants, Group Приложение


ApplicationOptions.MouseWheelInverted (свойство)

Обратная реакция на колесо мыши

Синтаксис

[Visual Basic 6]
Property MouseWheelInverted As Boolean

[Delphi]
property MouseWheelInverted: WordBool

Смотри также

Class ApplicationOptions, Group Приложение


ApplicationOptions.ZoomTime (свойство)

Время масштабирования при операциях ZoomIn, ZoomOut. При "0" рисуется сразу

Синтаксис

[Visual Basic 6]
Property ZoomTime As Long

[Delphi]
property ZoomTime: Integer

Смотри также

Class ApplicationOptions, Group Приложение


Класс Assembly

Запомненное собрание слоёв композиции

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Assembly

ClassID = {60040016-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Caption | Название собрания слоёв
Property Composition (только для чтения) | Композиция, для которой определено собрание слоёв
Property Description | Дополнительное описание собрания слоёв
Property ImageIndex | Код иконки для отображения в списке собраний композиции
Property LayerStateCount (только для чтения) | Количество запомненных слоёв композиции
Property LayerStates (только для чтения) | Массив запомненных слоёв композиции
Property Parameters (только для чтения) | Запомненные параметры слоёв (в виде побитовой комбинации констант типа AssemblyParameterConstants)

Методы класса

Имя | Описание
Method Apply | Применить собрание к композиции
Method Remember | Запомнить собрание из композиции
Method WillChange | Проверить, изменит ли собрание состояние композиции

Где используется

Класс | Член класса
Class AssemblyLayerState | Property Assembly (свойство)
Class LayeredComposition | Property Assemblies (свойство) Method AddAssembly (метод)

Смотри также

Enum AssemblyParameterConstants, Group Контейнеры изображений


Assembly.Caption (свойство)

Название собрания слоёв

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class Assembly, Group Контейнеры изображений


Assembly.Composition (свойство)

Композиция, для которой определено собрание слоёв

Синтаксис

[Visual Basic 6]
ReadOnly Property Composition As LayeredComposition

[Delphi]
{только для чтения} property Composition: LayeredComposition

Смотри также

Class Assembly, Class LayeredComposition, Group Контейнеры изображений


Assembly.Description (свойство)

Дополнительное описание собрания слоёв

Синтаксис

[Visual Basic 6]
Property Description As String

[Delphi]
property Description: WideString

Смотри также

Class Assembly, Group Контейнеры изображений


Assembly.ImageIndex (свойство)

Код иконки для отображения в списке собраний композиции

Синтаксис

[Visual Basic 6]
Property ImageIndex As Long

[Delphi]
property ImageIndex: Integer

Смотри также

Class Assembly, Group Контейнеры изображений


Assembly.LayerStateCount (свойство)

Количество запомненных слоёв композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property LayerStateCount As Long

[Delphi]
{только для чтения} property LayerStateCount: Integer

Смотри также

Class Assembly, Group Контейнеры изображений


Assembly.LayerStates (свойство)

Массив запомненных слоёв композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property LayerStates As AssemblyLayerState

[Delphi]
{только для чтения} property LayerStates: AssemblyLayerState

Смотри также

Class Assembly, Class AssemblyLayerState, Group Контейнеры изображений


Assembly.Parameters (свойство)

Запомненные параметры слоёв (в виде побитовой комбинации констант типа AssemblyParameterConstants)

Синтаксис

[Visual Basic 6]
ReadOnly Property Parameters As AssemblyParameterConstants

[Delphi]
{только для чтения} property Parameters: AssemblyParameterConstants

Смотри также

Class Assembly, Enum AssemblyParameterConstants, Group Контейнеры изображений


Assembly.Apply (метод)

Применить собрание к композиции

Синтаксис

[Visual Basic 6]
Sub Apply

[Delphi]
procedure Apply

Смотри также

Class Assembly, Group Контейнеры изображений


Assembly.Remember (метод)

Запомнить собрание из композиции

Синтаксис

[Visual Basic 6]
Sub Remember ( _
   ByVal Parameters As AssemblyParameterConstants _
)

[Delphi]
procedure Remember(
   const Parameters: AssemblyParameterConstants
)

Описание параметров

Parameters
[in] Список запоминаемых параметров в виде побитовой комбинации констант типа AssemblyParameterConstants. Если указать 0, то будут запомнены все возможные параметры

Смотри также

Class Assembly, Enum AssemblyParameterConstants, Group Контейнеры изображений


Assembly.WillChange (метод)

Проверить, изменит ли собрание состояние композиции

Синтаксис

[Visual Basic 6]
Function WillChange ( _
   ByVal Composition As LayeredComposition _
) As Boolean

[Delphi]
function WillChange(
   const Composition: LayeredComposition
): WordBool

Описание параметров

Composition
[in] Проверяемая композиция

Возвращаемое значение

Возвращает True, если состояние указанной композиции изменится после применения данного собрания

Смотри также

Class Assembly, Class LayeredComposition, Group Контейнеры изображений


Класс AssemblyLayerState

Запомненное состояние слоя в собрании слоёв

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.AssemblyLayerState

ClassID = {60040014-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Assembly (только для чтения) | Собрание слоёв, которому принадлежит запомненное состояние
Property ClipRegion (только для чтения) | Запомненная зона отсечения изображения
Property Closed (только для чтения) | Запомненное состояние закрытости легенда слоя
Property IndividualProjection (только для чтения) | Запомненный признак того, что надо использовать индивидуальную проекцию слоя
Property LayerSeqId (только для чтения) | Код запомненного слоя композиции
Property Projected (только для чтения) | Запомненный признак того, слой надо проектировать
Property Projection (только для чтения) | Запомненная индивидуальная проекция слоя
Property Transparency (только для чтения) | Запомненная прозрачность слоя (0 - непрозрачен, 255 - полностью прозрачен)
Property Visible (только для чтения) | Запомненное состояние видимости слоя

Методы класса

Имя | Описание
Method Apply | Применить состояние слоя к указанному слою композиции
Method Remember | Запомнить состояние слоя из указанного слоя композиции
Method WillChange | Проверить, изменится ли слой композиции после применения данного состояния

Где используется

Класс | Член класса
Class Assembly | Property LayerStates (свойство)

Смотри также

Class ClipRegion, Class CompositionLayer, Class Projection, Group Контейнеры изображений


AssemblyLayerState.Assembly (свойство)

Собрание слоёв, которому принадлежит запомненное состояние

Синтаксис

[Visual Basic 6]
ReadOnly Property Assembly As Assembly

[Delphi]
{только для чтения} property Assembly: Assembly

Смотри также

Class Assembly, Class AssemblyLayerState, Group Контейнеры изображений


AssemblyLayerState.ClipRegion (свойство)

Запомненная зона отсечения изображения

Синтаксис

[Visual Basic 6]
ReadOnly Property ClipRegion As ClipRegion

[Delphi]
{только для чтения} property ClipRegion: ClipRegion

Смотри также

Class AssemblyLayerState, Class ClipRegion, Group Контейнеры изображений


AssemblyLayerState.Closed (свойство)

Запомненное состояние закрытости легенда слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Closed As Boolean

[Delphi]
{только для чтения} property Closed: WordBool

Смотри также

Class AssemblyLayerState, Group Контейнеры изображений


AssemblyLayerState.IndividualProjection (свойство)

Запомненный признак того, что надо использовать индивидуальную проекцию слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property IndividualProjection As Boolean

[Delphi]
{только для чтения} property IndividualProjection: WordBool

Смотри также

Class AssemblyLayerState, Group Контейнеры изображений


AssemblyLayerState.LayerSeqId (свойство)

Код запомненного слоя композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property LayerSeqId As Long

[Delphi]
{только для чтения} property LayerSeqId: Integer

Смотри также

Class AssemblyLayerState, Group Контейнеры изображений


AssemblyLayerState.Projected (свойство)

Запомненный признак того, слой надо проектировать

Синтаксис

[Visual Basic 6]
ReadOnly Property Projected As Boolean

[Delphi]
{только для чтения} property Projected: WordBool

Смотри также

Class AssemblyLayerState, Group Контейнеры изображений


AssemblyLayerState.Projection (свойство)

Запомненная индивидуальная проекция слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Projection As Projection

[Delphi]
{только для чтения} property Projection: Projection

Смотри также

Class AssemblyLayerState, Class Projection, Group Контейнеры изображений


AssemblyLayerState.Transparency (свойство)

Запомненная прозрачность слоя (0 - непрозрачен, 255 - полностью прозрачен)

Синтаксис

[Visual Basic 6]
ReadOnly Property Transparency As Long

[Delphi]
{только для чтения} property Transparency: Integer

Смотри также

Class AssemblyLayerState, Group Контейнеры изображений


AssemblyLayerState.Visible (свойство)

Запомненное состояние видимости слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Visible As Boolean

[Delphi]
{только для чтения} property Visible: WordBool

Смотри также

Class AssemblyLayerState, Group Контейнеры изображений


AssemblyLayerState.Apply (метод)

Применить состояние слоя к указанному слою композиции

Синтаксис

[Visual Basic 6]
Sub Apply ( _
   ByVal Layer As CompositionLayer _
)

[Delphi]
procedure Apply(
   const Layer: CompositionLayer
)

Описание параметров

Layer
[in] Слой, состояние которого нужно изменить

Смотри также

Class AssemblyLayerState, Class CompositionLayer, Group Контейнеры изображений


AssemblyLayerState.Remember (метод)

Запомнить состояние слоя из указанного слоя композиции

Синтаксис

[Visual Basic 6]
Sub Remember ( _
   ByVal Layer As CompositionLayer _
)

[Delphi]
procedure Remember(
   const Layer: CompositionLayer
)

Описание параметров

Layer
[in] Слой, состояние которого запоминается

Смотри также

Class AssemblyLayerState, Class CompositionLayer, Group Контейнеры изображений


AssemblyLayerState.WillChange (метод)

Проверить, изменится ли слой композиции после применения данного состояния

Синтаксис

[Visual Basic 6]
Function WillChange ( _
   ByVal Layer As CompositionLayer _
) As Boolean

[Delphi]
function WillChange(
   const Layer: CompositionLayer
): WordBool

Описание параметров

Layer
[in] Слой композиции

Возвращаемое значение

Возвращает True, если состояние указанного слоя изменится после применения данного состояния

Смотри также

Class AssemblyLayerState, Class CompositionLayer, Group Контейнеры изображений


Класс Bar

Панель инструментов

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Caption | Название панели
Property ItemLinks (только для чтения) | Ссылки на элементы панели инструментов
Property Visible | Видна ли панель инструментов

Где используется

Класс | Член класса
Class BarManager | Property Bars (свойство) Method BarByName (метод) Method CreateNewBar (метод)
Class RibbonTabGroup | Property Bar (свойство)

Смотри также

Class BarItemLinks, Group Пользовательский интерфейс


Bar.Caption (свойство)

Название панели

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class Bar, Group Пользовательский интерфейс


Bar.ItemLinks (свойство)

Ссылки на элементы панели инструментов

Синтаксис

[Visual Basic 6]
ReadOnly Property ItemLinks As BarItemLinks

[Delphi]
{только для чтения} property ItemLinks: BarItemLinks

Смотри также

Class Bar, Class BarItemLinks, Group Пользовательский интерфейс


Bar.Visible (свойство)

Видна ли панель инструментов

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Bar, Group Пользовательский интерфейс


Класс BarButton

Кнопка на панели инструментов

Наследование

BarItem Class BarButton

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Action | Назначенное действие
Property Category | Номер категории в менеджере элементов
Property ClassName (только для чтения) | Имя класса элемента, например, Button, LargeButton, SubItem
Property Index | Номер элемента в категории в менеджере элементов
Property Name | Внутреннее имя элемента

Где используется

Класс | Член класса
Class BarItemLinks | Method CreateNewButton (метод)
Class BarManager | Method CreateNewButton (метод)

Смотри также

Class Action, Group Пользовательский интерфейс


BarButton.Action (свойство)

Назначенное действие

Синтаксис

[Visual Basic 6]
Property Action As Action

[Delphi]
property Action: Action

Смотри также

Class Action, Class BarButton, Group Пользовательский интерфейс


BarButton.Category (свойство)

Номер категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Category As Long

[Delphi]
property Category: Integer

Смотри также

Class BarButton, Group Пользовательский интерфейс


BarButton.ClassName (свойство)

Имя класса элемента, например, Button, LargeButton, SubItem

Синтаксис

[Visual Basic 6]
ReadOnly Property ClassName As String

[Delphi]
{только для чтения} property ClassName: WideString

Смотри также

Class BarButton, Group Пользовательский интерфейс


BarButton.Index (свойство)

Номер элемента в категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Index As Long

[Delphi]
property Index: Integer

Смотри также

Class BarButton, Group Пользовательский интерфейс


BarButton.Name (свойство)

Внутреннее имя элемента

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class BarButton, Group Пользовательский интерфейс


Класс BarItem

Элемент панелей инструментов

Наследование

BarItem Class BarButton, BarLargeButton, BarModeButton, BarSeparator, BarSubItem

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Action | Назначенное действие
Property Category | Номер категории в менеджере элементов
Property ClassName (только для чтения) | Имя класса элемента, например, Button, LargeButton, SubItem
Property Index | Номер элемента в категории в менеджере элементов
Property Name | Внутреннее имя элемента

Где используется

Класс | Член класса
Class BarItemLink | Property Item (свойство)
Class BarManager | Property Items (свойство) Method ItemByName (метод)

Смотри также

Class Action, Group Пользовательский интерфейс


BarItem.Action (свойство)

Назначенное действие

Синтаксис

[Visual Basic 6]
Property Action As Action

[Delphi]
property Action: Action

Смотри также

Class Action, Class BarItem, Group Пользовательский интерфейс


BarItem.Category (свойство)

Номер категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Category As Long

[Delphi]
property Category: Integer

Смотри также

Class BarItem, Group Пользовательский интерфейс


BarItem.ClassName (свойство)

Имя класса элемента, например, Button, LargeButton, SubItem

Синтаксис

[Visual Basic 6]
ReadOnly Property ClassName As String

[Delphi]
{только для чтения} property ClassName: WideString

Смотри также

Class BarItem, Group Пользовательский интерфейс


BarItem.Index (свойство)

Номер элемента в категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Index As Long

[Delphi]
property Index: Integer

Смотри также

Class BarItem, Group Пользовательский интерфейс


BarItem.Name (свойство)

Внутреннее имя элемента

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class BarItem, Group Пользовательский интерфейс


Класс BarItemLink

Ссылка на действие

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BeginGroup | Признак того, что на этом элементе начинается новая группа элементов
Property ButtonGroup | Способ участия кнопки на панели инструментов в группе кнопок
Property Distributed | Признак того, что элемент надо позиционировать по центру свободного пространства, не прижимая влево вверх
Property Item | Действие
Property MostRecentlyUsed | Признак того, что элемент был недавно использован
Property Position | Способ размещения элемента на ленте инструментов
Property UserCaption | Перекрытое в ссылке название элемента
Property UserGlyph | Пользовательская картинка элемента (объект IPicture)
Property UserPaintStyle | Рекомендованный способ отображения элемента на панели или ленте инструментов
Property UserWidth | Перекрытая в ссылке ширина элемента
Property ViewLevelControlOnly | Допустимо ли отображение элемента на панели или ленте инструментов только в виде элемента управления без иконок и текста
Property ViewLevelLargeIconWithText | Допустимо ли отображение элемента на панели или ленте инструментов в виде большой иконки с текстом
Property ViewLevelSmallIcon | Допустимо ли отображение элемента на панели или ленте инструментов в виде маленькой иконки без текста
Property ViewLevelSmallIconWithText | Допустимо ли отображение элемента на панели или ленте инструментов в виде маленькой иконки с текстом
Property Visible | Видна ли панель инструментов

Где используется

Класс | Член класса
Class BarItemLinks | Property Links (свойство) Method CreateEmptyLink (метод) Method CreateNewLink (метод)

Смотри также

Enum BarButtonGroupPositionConstants, Class BarItem, Enum BarItemPositionConstants, Enum BarPaintStyleConstants, Picture, Group Пользовательский интерфейс


BarItemLink.BeginGroup (свойство)

Признак того, что на этом элементе начинается новая группа элементов

Синтаксис

[Visual Basic 6]
Property BeginGroup As Boolean

[Delphi]
property BeginGroup: WordBool

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.ButtonGroup (свойство)

Способ участия кнопки на панели инструментов в группе кнопок

Синтаксис

[Visual Basic 6]
Property ButtonGroup As BarButtonGroupPositionConstants

[Delphi]
property ButtonGroup: BarButtonGroupPositionConstants

Смотри также

Enum BarButtonGroupPositionConstants, Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.Distributed (свойство)

Признак того, что элемент надо позиционировать по центру свободного пространства, не прижимая влево вверх

Синтаксис

[Visual Basic 6]
Property Distributed As Boolean

[Delphi]
property Distributed: WordBool

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.Item (свойство)

Действие

Синтаксис

[Visual Basic 6]
Property Item As BarItem

[Delphi]
property Item: BarItem

Смотри также

Class BarItem, Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.MostRecentlyUsed (свойство)

Признак того, что элемент был недавно использован

Синтаксис

[Visual Basic 6]
Property MostRecentlyUsed As Boolean

[Delphi]
property MostRecentlyUsed: WordBool

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.Position (свойство)

Способ размещения элемента на ленте инструментов

Синтаксис

[Visual Basic 6]
Property Position As BarItemPositionConstants

[Delphi]
property Position: BarItemPositionConstants

Смотри также

Class BarItemLink, Enum BarItemPositionConstants, Group Пользовательский интерфейс


BarItemLink.UserCaption (свойство)

Перекрытое в ссылке название элемента

Синтаксис

[Visual Basic 6]
Property UserCaption As String

[Delphi]
property UserCaption: WideString

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.UserGlyph (свойство)

Пользовательская картинка элемента (объект IPicture)

Синтаксис

[Visual Basic 6]
Property UserGlyph As Picture

[Delphi]
property UserGlyph: PictureDisp

Смотри также

Class BarItemLink, Picture, Group Пользовательский интерфейс


BarItemLink.UserPaintStyle (свойство)

Рекомендованный способ отображения элемента на панели или ленте инструментов

Синтаксис

[Visual Basic 6]
Property UserPaintStyle As BarPaintStyleConstants

[Delphi]
property UserPaintStyle: BarPaintStyleConstants

Смотри также

Class BarItemLink, Enum BarPaintStyleConstants, Group Пользовательский интерфейс


BarItemLink.UserWidth (свойство)

Перекрытая в ссылке ширина элемента

Синтаксис

[Visual Basic 6]
Property UserWidth As Long

[Delphi]
property UserWidth: Integer

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.ViewLevelControlOnly (свойство)

Допустимо ли отображение элемента на панели или ленте инструментов только в виде элемента управления без иконок и текста

Синтаксис

[Visual Basic 6]
Property ViewLevelControlOnly As Boolean

[Delphi]
property ViewLevelControlOnly: WordBool

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.ViewLevelLargeIconWithText (свойство)

Допустимо ли отображение элемента на панели или ленте инструментов в виде большой иконки с текстом

Синтаксис

[Visual Basic 6]
Property ViewLevelLargeIconWithText As Boolean

[Delphi]
property ViewLevelLargeIconWithText: WordBool

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.ViewLevelSmallIcon (свойство)

Допустимо ли отображение элемента на панели или ленте инструментов в виде маленькой иконки без текста

Синтаксис

[Visual Basic 6]
Property ViewLevelSmallIcon As Boolean

[Delphi]
property ViewLevelSmallIcon: WordBool

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.ViewLevelSmallIconWithText (свойство)

Допустимо ли отображение элемента на панели или ленте инструментов в виде маленькой иконки с текстом

Синтаксис

[Visual Basic 6]
Property ViewLevelSmallIconWithText As Boolean

[Delphi]
property ViewLevelSmallIconWithText: WordBool

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


BarItemLink.Visible (свойство)

Видна ли панель инструментов

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class BarItemLink, Group Пользовательский интерфейс


Класс BarItemLinks

Список ссылок на действия

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property LinkCount (только для чтения) | Количество ссылок
Property Links (только для чтения) | Массив ссылок

Методы класса

Имя | Описание
Method CreateEmptyLink | Создать новую пустую ссылку
Method CreateNewButton | Создать новую ссылку с новой кнопкой с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewLargeButton | Создать новую ссылку с новой большой кнопкой с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewLink | Создать новую ссылку и сразу назначить ей ссылку на элемент
Method CreateNewModeButton | Создать новую ссылку с новой кнопкой режима с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewSeparator | Создать новую ссылку с новым разделителем пунктов меню с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewSubItem | Создать новую ссылку с новой кнопкой подменю с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Где используется

Класс | Член класса
Class Bar | Property ItemLinks (свойство)
Class BarPopupMenu | Property ItemLinks (свойство)
Class BarSubItem | Property ItemLinks (свойство)

Смотри также

Class BarButton, Class BarItemLink, Class BarLargeButton, Class BarModeButton, Class BarSeparator, Group Пользовательский интерфейс


BarItemLinks.LinkCount (свойство)

Количество ссылок

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkCount As Long

[Delphi]
{только для чтения} property LinkCount: Integer

Смотри также

Class BarItemLinks, Group Пользовательский интерфейс


BarItemLinks.Links (свойство)

Массив ссылок

Синтаксис

[Visual Basic 6]
ReadOnly Property Links As BarItemLink

[Delphi]
{только для чтения} property Links: BarItemLink

Смотри также

Class BarItemLink, Class BarItemLinks, Group Пользовательский интерфейс


BarItemLinks.CreateEmptyLink (метод)

Создать новую пустую ссылку

Синтаксис

[Visual Basic 6]
Function CreateEmptyLink As BarItemLink

[Delphi]
function CreateEmptyLink: BarItemLink

Возвращаемое значение

Возвращает новую ссылку

Смотри также

Class BarItemLink, Class BarItemLinks, Group Пользовательский интерфейс


BarItemLinks.CreateNewButton (метод)

Создать новую ссылку с новой кнопкой с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewButton ( _
   [ByVal Name As String = ""] _
) As BarButton

[Delphi]
function CreateNewButton(
   const Name: WideString
): BarButton

Описание параметров

Name
[in] Имя нового элемента в виде

Возвращаемое значение

Возвращает новую кнопку

Смотри также

Class BarButton, Class BarItemLinks, Group Пользовательский интерфейс


BarItemLinks.CreateNewLargeButton (метод)

Создать новую ссылку с новой большой кнопкой с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewLargeButton ( _
   [ByVal Name As String = ""] _
) As BarLargeButton

[Delphi]
function CreateNewLargeButton(
   const Name: WideString
): BarLargeButton

Описание параметров

Name
[in] Имя нового элемента в виде

Возвращаемое значение

Возвращает новую большую кнопку

Смотри также

Class BarItemLinks, Class BarLargeButton, Group Пользовательский интерфейс


BarItemLinks.CreateNewLink (метод)

Создать новую ссылку и сразу назначить ей ссылку на элемент

Синтаксис

[Visual Basic 6]
Function CreateNewLink ( _
   [ByVal BarItemName As String = ""] _
) As BarItemLink

[Delphi]
function CreateNewLink(
   const BarItemName: WideString
): BarItemLink

Описание параметров

BarItemName
[in] Внутреннее имя существующего элемента в виде

Возвращаемое значение

Возвращает новую ссылку

Смотри также

Class BarItemLink, Class BarItemLinks, Group Пользовательский интерфейс


BarItemLinks.CreateNewModeButton (метод)

Создать новую ссылку с новой кнопкой режима с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewModeButton ( _
   [ByVal Name As String = ""] _
) As BarModeButton

[Delphi]
function CreateNewModeButton(
   const Name: WideString
): BarModeButton

Описание параметров

Name
[in] Внутреннее имя новой кнопки режима в виде

Возвращаемое значение

Возвращает новую кнопку режима

Смотри также

Class BarItemLinks, Class BarModeButton, Group Пользовательский интерфейс


BarItemLinks.CreateNewSeparator (метод)

Создать новую ссылку с новым разделителем пунктов меню с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewSeparator ( _
   [ByVal Name As String = ""] _
) As BarSeparator

[Delphi]
function CreateNewSeparator(
   const Name: WideString
): BarSeparator

Описание параметров

Name
[in] Внутреннее имя нового разделителя пунктов меню в виде

Возвращаемое значение

Возвращает новый разделитель пунктов меню

Смотри также

Class BarItemLinks, Class BarSeparator, Group Пользовательский интерфейс


BarItemLinks.CreateNewSubItem (метод)

Создать новую ссылку с новой кнопкой подменю с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewSubItem ( _
   [ByVal Name As String = ""] _
) As BarSubItem

[Delphi]
function CreateNewSubItem(
   const Name: WideString
): BarSubItem

Описание параметров

Name
[in] Имя новой кнопки подменю в виде

Возвращаемое значение

Возвращает новую кнопку подменю

Смотри также

Class BarItemLinks, Class BarSubItem, Group Пользовательский интерфейс


Класс BarLargeButton

Большая кнопка на панели инструментов

Наследование

BarItem Class BarLargeButton

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Action | Назначенное действие
Property Category | Номер категории в менеджере элементов
Property ClassName (только для чтения) | Имя класса элемента, например, Button, LargeButton, SubItem
Property Index | Номер элемента в категории в менеджере элементов
Property Name | Внутреннее имя элемента

Где используется

Класс | Член класса
Class BarItemLinks | Method CreateNewLargeButton (метод)
Class BarManager | Method CreateNewLargeButton (метод)

Смотри также

Class Action, Group Пользовательский интерфейс


BarLargeButton.Action (свойство)

Назначенное действие

Синтаксис

[Visual Basic 6]
Property Action As Action

[Delphi]
property Action: Action

Смотри также

Class Action, Class BarLargeButton, Group Пользовательский интерфейс


BarLargeButton.Category (свойство)

Номер категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Category As Long

[Delphi]
property Category: Integer

Смотри также

Class BarLargeButton, Group Пользовательский интерфейс


BarLargeButton.ClassName (свойство)

Имя класса элемента, например, Button, LargeButton, SubItem

Синтаксис

[Visual Basic 6]
ReadOnly Property ClassName As String

[Delphi]
{только для чтения} property ClassName: WideString

Смотри также

Class BarLargeButton, Group Пользовательский интерфейс


BarLargeButton.Index (свойство)

Номер элемента в категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Index As Long

[Delphi]
property Index: Integer

Смотри также

Class BarLargeButton, Group Пользовательский интерфейс


BarLargeButton.Name (свойство)

Внутреннее имя элемента

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class BarLargeButton, Group Пользовательский интерфейс


Класс BarManager

Менеджер элементов панелей и лент инструментов

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BarCount (только для чтения) | Количество панелей инструментов
Property Bars (только для чтения) | Массив панелей инструментов
Property ItemCount (только для чтения) | Количество элементов
Property Items (только для чтения) | Массив элементов

Методы класса

Имя | Описание
Method BarByName | Получить панель инструментов по внутреннему имени
Method BeginUpdate | Начать обновление панелей и лент инструментов
Method CreateNewBar | Создать новую панель инструментов с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewButton | Создать новую кнопку с указанным внутренним именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewLargeButton | Создать новую большую кнопку с указанным внутренним именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewModeButton | Создать новую кнопку режима с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewSeparator | Создать новый разделитель пунктов меню с указанным внутренним именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method CreateNewSubItem | Создать новую кнопку подменю с указанным внутренним именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method EndUpdate | Завершить обновление панелей и лент инструментов
Method ItemByName | Получить элемент по внутреннему имени

Смотри также

Class Bar, Class BarButton, Class BarItem, Class BarLargeButton, Class BarModeButton, Class BarSeparator, Class BarSubItem, Group Пользовательский интерфейс


BarManager.BarCount (свойство)

Количество панелей инструментов

Синтаксис

[Visual Basic 6]
ReadOnly Property BarCount As Long

[Delphi]
{только для чтения} property BarCount: Integer

Смотри также

Class BarManager, Group Пользовательский интерфейс


BarManager.Bars (свойство)

Массив панелей инструментов

Синтаксис

[Visual Basic 6]
ReadOnly Property Bars As Bar

[Delphi]
{только для чтения} property Bars: Bar

Смотри также

Class Bar, Class BarManager, Group Пользовательский интерфейс


BarManager.ItemCount (свойство)

Количество элементов

Синтаксис

[Visual Basic 6]
ReadOnly Property ItemCount As Long

[Delphi]
{только для чтения} property ItemCount: Integer

Смотри также

Class BarManager, Group Пользовательский интерфейс


BarManager.Items (свойство)

Массив элементов

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BarItem

[Delphi]
{только для чтения} property Items: BarItem

Смотри также

Class BarItem, Class BarManager, Group Пользовательский интерфейс


BarManager.BarByName (метод)

Получить панель инструментов по внутреннему имени

Синтаксис

[Visual Basic 6]
Function BarByName ( _
   ByVal Name As String _
) As Bar

[Delphi]
function BarByName(
   const Name: WideString
): Bar

Описание параметров

Name
[in] Имя панели инструментов

Возвращаемое значение

Возвращает панель инструментов по указанному имени или Nothing, если таковой не существует

Смотри также

Class Bar, Class BarManager, Group Пользовательский интерфейс


BarManager.BeginUpdate (метод)

Начать обновление панелей и лент инструментов

Синтаксис

[Visual Basic 6]
Sub BeginUpdate

[Delphi]
procedure BeginUpdate

Смотри также

Class BarManager, Group Пользовательский интерфейс


BarManager.CreateNewBar (метод)

Создать новую панель инструментов с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewBar ( _
   [ByVal Name As String = ""] _
) As Bar

[Delphi]
function CreateNewBar(
   const Name: WideString
): Bar

Описание параметров

Name
[in] Имя новой панели инструментов в виде

Возвращаемое значение

Возвращает новую панель инструментов

Смотри также

Class Bar, Class BarManager, Group Пользовательский интерфейс


BarManager.CreateNewButton (метод)

Создать новую кнопку с указанным внутренним именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewButton ( _
   [ByVal Name As String = ""] _
) As BarButton

[Delphi]
function CreateNewButton(
   const Name: WideString
): BarButton

Описание параметров

Name
[in] Внутреннее имя нового элемента в виде

Возвращаемое значение

Возвращает новую кнопку

Смотри также

Class BarButton, Class BarManager, Group Пользовательский интерфейс


BarManager.CreateNewLargeButton (метод)

Создать новую большую кнопку с указанным внутренним именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewLargeButton ( _
   [ByVal Name As String = ""] _
) As BarLargeButton

[Delphi]
function CreateNewLargeButton(
   const Name: WideString
): BarLargeButton

Описание параметров

Name
[in] Внутреннее имя нового элемента в виде

Возвращаемое значение

Возвращает новую большую кнопку

Смотри также

Class BarLargeButton, Class BarManager, Group Пользовательский интерфейс


BarManager.CreateNewModeButton (метод)

Создать новую кнопку режима с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewModeButton ( _
   [ByVal Name As String = ""] _
) As BarModeButton

[Delphi]
function CreateNewModeButton(
   const Name: WideString
): BarModeButton

Описание параметров

Name
[in] Внутреннее имя новой кнопки режима в виде

Возвращаемое значение

Возвращает новую кнопку режима

Смотри также

Class BarManager, Class BarModeButton, Group Пользовательский интерфейс


BarManager.CreateNewSeparator (метод)

Создать новый разделитель пунктов меню с указанным внутренним именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewSeparator ( _
   [ByVal Name As String = ""] _
) As BarSeparator

[Delphi]
function CreateNewSeparator(
   const Name: WideString
): BarSeparator

Описание параметров

Name
[in] Внутреннее имя нового разделителя пунктов меню в виде

Возвращаемое значение

Возвращает новый разделитель пунктов меню

Смотри также

Class BarManager, Class BarSeparator, Group Пользовательский интерфейс


BarManager.CreateNewSubItem (метод)

Создать новую кнопку подменю с указанным внутренним именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewSubItem ( _
   [ByVal Name As String = ""] _
) As BarSubItem

[Delphi]
function CreateNewSubItem(
   const Name: WideString
): BarSubItem

Описание параметров

Name
[in] Внутреннее имя новой кнопки подменю в виде

Возвращаемое значение

Возвращает новую кнопку подменю

Смотри также

Class BarManager, Class BarSubItem, Group Пользовательский интерфейс


BarManager.EndUpdate (метод)

Завершить обновление панелей и лент инструментов

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class BarManager, Group Пользовательский интерфейс


BarManager.ItemByName (метод)

Получить элемент по внутреннему имени

Синтаксис

[Visual Basic 6]
Function ItemByName ( _
   ByVal Name As String _
) As BarItem

[Delphi]
function ItemByName(
   const Name: WideString
): BarItem

Описание параметров

Name
[in] Внутреннее имя элемента

Возвращаемое значение

Возвращает элемент по указанному внутренним имени или Nothing, если такового не существует

Смотри также

Class BarItem, Class BarManager, Group Пользовательский интерфейс


Класс BarModeButton

Кнопка режима на панели инструментов

Наследование

BarItem Class BarModeButton

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Action | Назначенное действие
Property Category | Номер категории в менеджере элементов
Property ClassName (только для чтения) | Имя класса элемента, например, Button, LargeButton, SubItem
Property Index | Номер элемента в категории в менеджере элементов
Property Name | Внутреннее имя элемента

Где используется

Класс | Член класса
Class BarItemLinks | Method CreateNewModeButton (метод)
Class BarManager | Method CreateNewModeButton (метод)

Смотри также

Class Action, Group Пользовательский интерфейс


BarModeButton.Action (свойство)

Назначенное действие

Синтаксис

[Visual Basic 6]
Property Action As Action

[Delphi]
property Action: Action

Смотри также

Class Action, Class BarModeButton, Group Пользовательский интерфейс


BarModeButton.Category (свойство)

Номер категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Category As Long

[Delphi]
property Category: Integer

Смотри также

Class BarModeButton, Group Пользовательский интерфейс


BarModeButton.ClassName (свойство)

Имя класса элемента, например, Button, LargeButton, SubItem

Синтаксис

[Visual Basic 6]
ReadOnly Property ClassName As String

[Delphi]
{только для чтения} property ClassName: WideString

Смотри также

Class BarModeButton, Group Пользовательский интерфейс


BarModeButton.Index (свойство)

Номер элемента в категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Index As Long

[Delphi]
property Index: Integer

Смотри также

Class BarModeButton, Group Пользовательский интерфейс


BarModeButton.Name (свойство)

Внутреннее имя элемента

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class BarModeButton, Group Пользовательский интерфейс


Класс BarPopupMenu

Всплывающее меню

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ItemLinks (только для чтения) | Ссылки на элементы всплывающего меню

Смотри также

Class BarItemLinks, Group Пользовательский интерфейс


BarPopupMenu.ItemLinks (свойство)

Ссылки на элементы всплывающего меню

Синтаксис

[Visual Basic 6]
ReadOnly Property ItemLinks As BarItemLinks

[Delphi]
{только для чтения} property ItemLinks: BarItemLinks

Смотри также

Class BarItemLinks, Class BarPopupMenu, Group Пользовательский интерфейс


Класс BarSeparator

Разделитель элементов меню на панели инструментов

Наследование

BarItem Class BarSeparator

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Action | Назначенное действие
Property Category | Номер категории в менеджере элементов
Property ClassName (только для чтения) | Имя класса элемента, например, Button, LargeButton, SubItem
Property Index | Номер элемента в категории в менеджере элементов
Property Name | Внутреннее имя элемента

Где используется

Класс | Член класса
Class BarItemLinks | Method CreateNewSeparator (метод)
Class BarManager | Method CreateNewSeparator (метод)

Смотри также

Class Action, Group Пользовательский интерфейс


BarSeparator.Action (свойство)

Назначенное действие

Синтаксис

[Visual Basic 6]
Property Action As Action

[Delphi]
property Action: Action

Смотри также

Class Action, Class BarSeparator, Group Пользовательский интерфейс


BarSeparator.Category (свойство)

Номер категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Category As Long

[Delphi]
property Category: Integer

Смотри также

Class BarSeparator, Group Пользовательский интерфейс


BarSeparator.ClassName (свойство)

Имя класса элемента, например, Button, LargeButton, SubItem

Синтаксис

[Visual Basic 6]
ReadOnly Property ClassName As String

[Delphi]
{только для чтения} property ClassName: WideString

Смотри также

Class BarSeparator, Group Пользовательский интерфейс


BarSeparator.Index (свойство)

Номер элемента в категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Index As Long

[Delphi]
property Index: Integer

Смотри также

Class BarSeparator, Group Пользовательский интерфейс


BarSeparator.Name (свойство)

Внутреннее имя элемента

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class BarSeparator, Group Пользовательский интерфейс


Класс BarSubItem

Подменю на панели инструментов

Наследование

BarItem Class BarSubItem

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Action | Назначенное действие
Property Category | Номер категории в менеджере элементов
Property ClassName (только для чтения) | Имя класса элемента, например, Button, LargeButton, SubItem
Property Index | Номер элемента в категории в менеджере элементов
Property ItemLinks (только для чтения) | Ссылки на элементы подменю
Property Name | Внутреннее имя элемента

Где используется

Класс | Член класса
Class BarItemLinks | Method CreateNewSubItem (метод)
Class BarManager | Method CreateNewSubItem (метод)

Смотри также

Class Action, Group Пользовательский интерфейс


BarSubItem.Action (свойство)

Назначенное действие

Синтаксис

[Visual Basic 6]
Property Action As Action

[Delphi]
property Action: Action

Смотри также

Class Action, Class BarSubItem, Group Пользовательский интерфейс


BarSubItem.Category (свойство)

Номер категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Category As Long

[Delphi]
property Category: Integer

Смотри также

Class BarSubItem, Group Пользовательский интерфейс


BarSubItem.ClassName (свойство)

Имя класса элемента, например, Button, LargeButton, SubItem

Синтаксис

[Visual Basic 6]
ReadOnly Property ClassName As String

[Delphi]
{только для чтения} property ClassName: WideString

Смотри также

Class BarSubItem, Group Пользовательский интерфейс


BarSubItem.Index (свойство)

Номер элемента в категории в менеджере элементов

Синтаксис

[Visual Basic 6]
Property Index As Long

[Delphi]
property Index: Integer

Смотри также

Class BarSubItem, Group Пользовательский интерфейс


BarSubItem.ItemLinks (свойство)

Ссылки на элементы подменю

Синтаксис

[Visual Basic 6]
ReadOnly Property ItemLinks As BarItemLinks

[Delphi]
{только для чтения} property ItemLinks: BarItemLinks

Смотри также

Class BarItemLinks, Class BarSubItem, Group Пользовательский интерфейс


BarSubItem.Name (свойство)

Внутреннее имя элемента

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class BarSubItem, Group Пользовательский интерфейс


Класс BaseObject

Базовый объект IndorCAD

Наследование

BaseObject Class Aggregate, BaseObjectList, DrawingSheet, DrawingSheets, Grid, Layer, LayerPoint, LayerPoints, Layers, Line, LineGroup, Lines, Project, Route, RouteElement, Routes, RouteVertex, StringName, StringNameCollection, StringNameGroup, SurfaceDifference, SurfaceDifferences, SurfacePainter, SurfacePainters

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Project (только для чтения) | Проект, к которому относится объект

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Где используется

Класс | Член класса
Class BaseObjectList | Property Items (свойство)
Class DrawingSheets | Property Items (свойство)
Class LayerPoints | Property Items (свойство)
Class Layers | Property Items (свойство)
Class Lines | Property Items (свойство)
Class Routes | Property Items (свойство)
Class SurfaceDifferences | Property Items (свойство)
Class SurfacePainters | Property Items (свойство)

Смотри также

Class Application, Class Project, Group Проекты


BaseObject.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class BaseObject, Group Проекты


BaseObject.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class BaseObject, Group Проекты


BaseObject.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class BaseObject, Group Проекты


BaseObject.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class BaseObject, Class Project, Group Проекты


BaseObject.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class BaseObject, Group Проекты


BaseObject.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class BaseObject, Group Проекты


BaseObject.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class BaseObject, Group Проекты


BaseObject.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class BaseObject, Group Проекты


Класс BaseObjectList

Базовый объект - список объектов IndorCAD

Наследование

BaseObject Class BaseObjectList Class DrawingSheets, LayerPoints, Layers, Lines, Routes, SurfaceDifferences, SurfacePainters

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Count (только для чтения) | Количество объектов, которое содержит в себе данный объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Массив объектов (нумерация идёт от 0 до Count-1)
Property Project (только для чтения) | Проект, к которому относится объект

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Clear | Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект
Method Delete | Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Смотри также

Class Application, Class BaseObject, Class Project, Group Проекты


BaseObjectList.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class BaseObjectList, Group Проекты


BaseObjectList.Count (свойство)

Количество объектов, которое содержит в себе данный объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class BaseObjectList, Group Проекты


BaseObjectList.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class BaseObjectList, Group Проекты


BaseObjectList.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class BaseObjectList, Group Проекты


BaseObjectList.Items (свойство)

Массив объектов (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BaseObject

[Delphi]
{только для чтения} property Items: BaseObject

Смотри также

Class BaseObject, Class BaseObjectList, Group Проекты


BaseObjectList.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class BaseObjectList, Class Project, Group Проекты


BaseObjectList.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class BaseObjectList, Group Проекты


BaseObjectList.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class BaseObjectList, Group Проекты


BaseObjectList.Clear (метод)

Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class BaseObjectList, Group Проекты


BaseObjectList.Delete (метод)

Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс объекта (нумерация идёт от 0 до Count-1)

Смотри также

Class BaseObjectList, Group Проекты


BaseObjectList.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class BaseObjectList, Group Проекты


BaseObjectList.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class BaseObjectList, Group Проекты


Класс BrowserItem

Элемент - отображение поля таблицы

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Alignment | Выравнивание текста при выводе значения поля (fvString)
Property AutoDisplay | Автоматическая отрисовка изображения (fvImage)
Property BinaryBitePerRow | Количество байт в строке (fvBinary)
Property BinaryCtrlAsDots | Показывать управляющие символы как точки (fvBinary)
Property BinaryShowAsText | Показывать как текст (fvBinary)
Property BinaryShowOffset | Показывать смещение (fvBinary)
Property ButtonText | Текст кнопки
Property ColumnName | Имя поля в колонке таблицы
Property ColumnWidth | Ширина колонки для отображения поля
Property ComboDatabaseID | Код базы данных данных для списка
Property ComboDatasetID | Код источника данных для списка
Property ComboField | Поле источника данных для заполнения списка
Property ComboInterfaceID | Код интерфейса с данными для списка
Property ComboItems | Строчки для [комбо]списка (fvComboBox, fvListBox)
Property ControlHeight | Высота элемента ввода
Property ControlWidth | Ширина элемента ввода
Property DateTimeStyle | Тип вводимых параметров: время, дата или и то и другое (fvDateTime)
Property DefaultValue | Значение поля по умолчанию
Property DisplayFormat | Формат отображения чисел (fvInteger, fvFloat, fvDateTime)
Property DisplayName | Имя поля на экране
Property DropDownAlign | Положение выпадающего списка
Property DropDownWidth | Ширина выпадающего списка. Если = 0, то равно ширине комбосписка
Property EditFormat | Формат редактирования чисел (fvInteger, fvFloat, fvDateTime)
Property EditMask | Маска для редактирования (fvString)
Property FieldName | Имя поля в физической таблице
Property FieldView | Представление полей таблицы в диалогах, способ их ввода
Property FontCharset | Набор символов шрифта
Property FontColor | Цвет шрифта
Property FontName | Имя шрифта
Property FontSize | Размер шрифта
Property FontStyle | Стиль шрифта
Property ImageCenter | Центрировать изображение (fvImage)
Property ImageStretch | Растягивать изображение (fvImage)
Property LookupDatabaseID | Код базы данных со справочником
Property LookupDatasetID | Код источника данных со справочником
Property LookupInterfaceID | Код интерфейса со справочником
Property LookupKeyField | Поле справочника, которое копируется в главную таблицу (fvLookupBox, fvLookupList)
Property LookupListField | Отображаемое поле справочника (fvLookupBox, fvLookupList)
Property LookupParams | Подставляемые из главного набора данных параметры для справочников-процедур
Property MaxFloatValue | Максимальное допустимое вещественное значение (fvFloat)
Property MaxIntValue | Максимальное допустимое целочисленное значение (fvInteger)
Property MemoScrollbars | Типы скроллеров (fvMemo)
Property MemoWordWrap | Переносить предложения (fvMemo)
Property MinFloatValue | Минимальное допустимое вещественное значение (fvFloat)
Property MinIntValue | Минимальное допустимое целочисленное значение (fvInteger)
Property Precision | Точность отображения вещественных чисел (fvFloat)
Property RadioDatabaseID | Код базы данных для списка
Property RadioDatasetID | Код источника данных для списка
Property RadioInterfaceID | Код интерфейса с данными для списка
Property RadioItems | Список заголовков радиокнопок (fvRadioGroup)
Property RadioItemsField | Поле источника данных для заполнения списка видимых значений
Property RadioValues | Список значений, соответствующих радиокнопкам (fvRadioGroup)
Property RadioValuesField | Поле источника данных для заполнения списка значений в наборе данных
Property RangeCheck | Проверять ли значения на попадание в диапазон допустимых (fvInteger, fvFloat, fvDateTime)
Property ReadOnly | Поле доступно только для чтения
Property Required | Обязательно ли поле должно заполняться при вводе
Property RtfHideScrollers | Скрывать скроллеры (fvRichEdit)
Property RtfPlainText | Отображать плоский текст (fvRichEdit)
Property TimeViewStyle | Тип вводимых параметров времени
Property ValueChecked | Значения, разделённые точками с запятыми при которых галочка стоит (fvCheck)
Property ValueUnchecked | Значения, разделённые точками с запятыми при которых галочка не стоит (fvCheck)
Property Visible | Видимо ли поле

Методы класса

Имя | Описание
Method EditProperties | Редактирование свойств элемента

Где используется

Класс | Член класса
Class BrowserItems | Property Items (свойство) Method Add (метод) Method ItemByDisplayName (метод) Method ItemByName (метод)

Смотри также

Enum AlignmentConstants, Enum DateTimeConstants, Enum DropDownAlignConstants, Enum FieldViewConstants, Enum ScrollConstants, Enum TimeViewStyleConstants, Group Базы данных


BrowserItem.Alignment (свойство)

Выравнивание текста при выводе значения поля (fvString)

Синтаксис

[Visual Basic 6]
Property Alignment As AlignmentConstants

[Delphi]
property Alignment: AlignmentConstants

Смотри также

Enum AlignmentConstants, Class BrowserItem, Group Базы данных


BrowserItem.AutoDisplay (свойство)

Автоматическая отрисовка изображения (fvImage)

Синтаксис

[Visual Basic 6]
Property AutoDisplay As Boolean

[Delphi]
property AutoDisplay: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.BinaryBitePerRow (свойство)

Количество байт в строке (fvBinary)

Синтаксис

[Visual Basic 6]
Property BinaryBitePerRow As Long

[Delphi]
property BinaryBitePerRow: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.BinaryCtrlAsDots (свойство)

Показывать управляющие символы как точки (fvBinary)

Синтаксис

[Visual Basic 6]
Property BinaryCtrlAsDots As Boolean

[Delphi]
property BinaryCtrlAsDots: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.BinaryShowAsText (свойство)

Показывать как текст (fvBinary)

Синтаксис

[Visual Basic 6]
Property BinaryShowAsText As Boolean

[Delphi]
property BinaryShowAsText: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.BinaryShowOffset (свойство)

Показывать смещение (fvBinary)

Синтаксис

[Visual Basic 6]
Property BinaryShowOffset As Boolean

[Delphi]
property BinaryShowOffset: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ButtonText (свойство)

Текст кнопки

Синтаксис

[Visual Basic 6]
Property ButtonText As String

[Delphi]
property ButtonText: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ColumnName (свойство)

Имя поля в колонке таблицы

Синтаксис

[Visual Basic 6]
Property ColumnName As String

[Delphi]
property ColumnName: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ColumnWidth (свойство)

Ширина колонки для отображения поля

Синтаксис

[Visual Basic 6]
Property ColumnWidth As Long

[Delphi]
property ColumnWidth: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ComboDatabaseID (свойство)

Код базы данных данных для списка

Синтаксис

[Visual Basic 6]
Property ComboDatabaseID As Long

[Delphi]
property ComboDatabaseID: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ComboDatasetID (свойство)

Код источника данных для списка

Синтаксис

[Visual Basic 6]
Property ComboDatasetID As Long

[Delphi]
property ComboDatasetID: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ComboField (свойство)

Поле источника данных для заполнения списка

Синтаксис

[Visual Basic 6]
Property ComboField As String

[Delphi]
property ComboField: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ComboInterfaceID (свойство)

Код интерфейса с данными для списка

Синтаксис

[Visual Basic 6]
Property ComboInterfaceID As String

[Delphi]
property ComboInterfaceID: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ComboItems (свойство)

Строчки для [комбо]списка (fvComboBox, fvListBox)

Синтаксис

[Visual Basic 6]
Property ComboItems As String

[Delphi]
property ComboItems: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ControlHeight (свойство)

Высота элемента ввода

Синтаксис

[Visual Basic 6]
Property ControlHeight As Long

[Delphi]
property ControlHeight: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ControlWidth (свойство)

Ширина элемента ввода

Синтаксис

[Visual Basic 6]
Property ControlWidth As Long

[Delphi]
property ControlWidth: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.DateTimeStyle (свойство)

Тип вводимых параметров: время, дата или и то и другое (fvDateTime)

Синтаксис

[Visual Basic 6]
Property DateTimeStyle As DateTimeConstants

[Delphi]
property DateTimeStyle: DateTimeConstants

Смотри также

Class BrowserItem, Enum DateTimeConstants, Group Базы данных


BrowserItem.DefaultValue (свойство)

Значение поля по умолчанию

Синтаксис

[Visual Basic 6]
Property DefaultValue As String

[Delphi]
property DefaultValue: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.DisplayFormat (свойство)

Формат отображения чисел (fvInteger, fvFloat, fvDateTime)

Синтаксис

[Visual Basic 6]
Property DisplayFormat As String

[Delphi]
property DisplayFormat: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.DisplayName (свойство)

Имя поля на экране

Синтаксис

[Visual Basic 6]
Property DisplayName As String

[Delphi]
property DisplayName: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.DropDownAlign (свойство)

Положение выпадающего списка

Синтаксис

[Visual Basic 6]
Property DropDownAlign As DropDownAlignConstants

[Delphi]
property DropDownAlign: DropDownAlignConstants

Смотри также

Class BrowserItem, Enum DropDownAlignConstants, Group Базы данных


BrowserItem.DropDownWidth (свойство)

Ширина выпадающего списка. Если = 0, то равно ширине комбосписка

Синтаксис

[Visual Basic 6]
Property DropDownWidth As Long

[Delphi]
property DropDownWidth: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.EditFormat (свойство)

Формат редактирования чисел (fvInteger, fvFloat, fvDateTime)

Синтаксис

[Visual Basic 6]
Property EditFormat As String

[Delphi]
property EditFormat: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.EditMask (свойство)

Маска для редактирования (fvString)

Синтаксис

[Visual Basic 6]
Property EditMask As String

[Delphi]
property EditMask: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.FieldName (свойство)

Имя поля в физической таблице

Синтаксис

[Visual Basic 6]
Property FieldName As String

[Delphi]
property FieldName: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.FieldView (свойство)

Представление полей таблицы в диалогах, способ их ввода

Синтаксис

[Visual Basic 6]
Property FieldView As FieldViewConstants

[Delphi]
property FieldView: FieldViewConstants

Смотри также

Class BrowserItem, Enum FieldViewConstants, Group Базы данных


BrowserItem.FontCharset (свойство)

Набор символов шрифта

Синтаксис

[Visual Basic 6]
Property FontCharset As Long

[Delphi]
property FontCharset: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.FontColor (свойство)

Цвет шрифта

Синтаксис

[Visual Basic 6]
Property FontColor As OLE_COLOR

[Delphi]
property FontColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.FontName (свойство)

Имя шрифта

Синтаксис

[Visual Basic 6]
Property FontName As String

[Delphi]
property FontName: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.FontSize (свойство)

Размер шрифта

Синтаксис

[Visual Basic 6]
Property FontSize As Long

[Delphi]
property FontSize: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.FontStyle (свойство)

Стиль шрифта

Синтаксис

[Visual Basic 6]
Property FontStyle As Long

[Delphi]
property FontStyle: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ImageCenter (свойство)

Центрировать изображение (fvImage)

Синтаксис

[Visual Basic 6]
Property ImageCenter As Boolean

[Delphi]
property ImageCenter: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ImageStretch (свойство)

Растягивать изображение (fvImage)

Синтаксис

[Visual Basic 6]
Property ImageStretch As Boolean

[Delphi]
property ImageStretch: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.LookupDatabaseID (свойство)

Код базы данных со справочником

Синтаксис

[Visual Basic 6]
Property LookupDatabaseID As Long

[Delphi]
property LookupDatabaseID: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.LookupDatasetID (свойство)

Код источника данных со справочником

Синтаксис

[Visual Basic 6]
Property LookupDatasetID As Long

[Delphi]
property LookupDatasetID: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.LookupInterfaceID (свойство)

Код интерфейса со справочником

Синтаксис

[Visual Basic 6]
Property LookupInterfaceID As String

[Delphi]
property LookupInterfaceID: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.LookupKeyField (свойство)

Поле справочника, которое копируется в главную таблицу (fvLookupBox, fvLookupList)

Синтаксис

[Visual Basic 6]
Property LookupKeyField As String

[Delphi]
property LookupKeyField: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.LookupListField (свойство)

Отображаемое поле справочника (fvLookupBox, fvLookupList)

Синтаксис

[Visual Basic 6]
Property LookupListField As String

[Delphi]
property LookupListField: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.LookupParams (свойство)

Подставляемые из главного набора данных параметры для справочников-процедур

Синтаксис

[Visual Basic 6]
Property LookupParams As String

[Delphi]
property LookupParams: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.MaxFloatValue (свойство)

Максимальное допустимое вещественное значение (fvFloat)

Синтаксис

[Visual Basic 6]
Property MaxFloatValue As Double

[Delphi]
property MaxFloatValue: Double

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.MaxIntValue (свойство)

Максимальное допустимое целочисленное значение (fvInteger)

Синтаксис

[Visual Basic 6]
Property MaxIntValue As Long

[Delphi]
property MaxIntValue: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.MemoScrollbars (свойство)

Типы скроллеров (fvMemo)

Синтаксис

[Visual Basic 6]
Property MemoScrollbars As ScrollConstants

[Delphi]
property MemoScrollbars: ScrollConstants

Смотри также

Class BrowserItem, Enum ScrollConstants, Group Базы данных


BrowserItem.MemoWordWrap (свойство)

Переносить предложения (fvMemo)

Синтаксис

[Visual Basic 6]
Property MemoWordWrap As Boolean

[Delphi]
property MemoWordWrap: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.MinFloatValue (свойство)

Минимальное допустимое вещественное значение (fvFloat)

Синтаксис

[Visual Basic 6]
Property MinFloatValue As Double

[Delphi]
property MinFloatValue: Double

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.MinIntValue (свойство)

Минимальное допустимое целочисленное значение (fvInteger)

Синтаксис

[Visual Basic 6]
Property MinIntValue As Long

[Delphi]
property MinIntValue: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.Precision (свойство)

Точность отображения вещественных чисел (fvFloat)

Синтаксис

[Visual Basic 6]
Property Precision As Long

[Delphi]
property Precision: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RadioDatabaseID (свойство)

Код базы данных для списка

Синтаксис

[Visual Basic 6]
Property RadioDatabaseID As Long

[Delphi]
property RadioDatabaseID: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RadioDatasetID (свойство)

Код источника данных для списка

Синтаксис

[Visual Basic 6]
Property RadioDatasetID As Long

[Delphi]
property RadioDatasetID: Integer

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RadioInterfaceID (свойство)

Код интерфейса с данными для списка

Синтаксис

[Visual Basic 6]
Property RadioInterfaceID As String

[Delphi]
property RadioInterfaceID: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RadioItems (свойство)

Список заголовков радиокнопок (fvRadioGroup)

Синтаксис

[Visual Basic 6]
Property RadioItems As String

[Delphi]
property RadioItems: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RadioItemsField (свойство)

Поле источника данных для заполнения списка видимых значений

Синтаксис

[Visual Basic 6]
Property RadioItemsField As String

[Delphi]
property RadioItemsField: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RadioValues (свойство)

Список значений, соответствующих радиокнопкам (fvRadioGroup)

Синтаксис

[Visual Basic 6]
Property RadioValues As String

[Delphi]
property RadioValues: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RadioValuesField (свойство)

Поле источника данных для заполнения списка значений в наборе данных

Синтаксис

[Visual Basic 6]
Property RadioValuesField As String

[Delphi]
property RadioValuesField: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RangeCheck (свойство)

Проверять ли значения на попадание в диапазон допустимых (fvInteger, fvFloat, fvDateTime)

Синтаксис

[Visual Basic 6]
Property RangeCheck As Boolean

[Delphi]
property RangeCheck: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ReadOnly (свойство)

Поле доступно только для чтения

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.Required (свойство)

Обязательно ли поле должно заполняться при вводе

Синтаксис

[Visual Basic 6]
Property Required As Boolean

[Delphi]
property Required: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RtfHideScrollers (свойство)

Скрывать скроллеры (fvRichEdit)

Синтаксис

[Visual Basic 6]
Property RtfHideScrollers As Boolean

[Delphi]
property RtfHideScrollers: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.RtfPlainText (свойство)

Отображать плоский текст (fvRichEdit)

Синтаксис

[Visual Basic 6]
Property RtfPlainText As Boolean

[Delphi]
property RtfPlainText: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.TimeViewStyle (свойство)

Тип вводимых параметров времени

Синтаксис

[Visual Basic 6]
Property TimeViewStyle As TimeViewStyleConstants

[Delphi]
property TimeViewStyle: TimeViewStyleConstants

Смотри также

Class BrowserItem, Enum TimeViewStyleConstants, Group Базы данных


BrowserItem.ValueChecked (свойство)

Значения, разделённые точками с запятыми при которых галочка стоит (fvCheck)

Синтаксис

[Visual Basic 6]
Property ValueChecked As String

[Delphi]
property ValueChecked: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.ValueUnchecked (свойство)

Значения, разделённые точками с запятыми при которых галочка не стоит (fvCheck)

Синтаксис

[Visual Basic 6]
Property ValueUnchecked As String

[Delphi]
property ValueUnchecked: WideString

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.Visible (свойство)

Видимо ли поле

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class BrowserItem, Group Базы данных


BrowserItem.EditProperties (метод)

Редактирование свойств элемента

Синтаксис

[Visual Basic 6]
Sub EditProperties

[Delphi]
procedure EditProperties

Смотри также

Class BrowserItem, Group Базы данных


Класс BrowserItems

Набор элементов просмотра таблиц баз данных

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property CalcFields (только для чтения) | Вычисляемые поля
Property Count (только для чтения) | Количество элементов просмотра
Property Items (только для чтения) | Массив элементов просмотра

Методы класса

Имя | Описание
Method Add | Добавить новый пустой элемент просмотра
Method AddDialog | Вызывает диалог добавления элементов
Method EditProperties | Редактирование свойств
Method ItemByDisplayName | Найти элемент просмотра по отображаемому имени
Method ItemByName | Найти элемент просмотра по имени поля, если таких элементов несколько - то выдается только первый
Method MakeDefault | Создать элементы по умолчанию

Где используется

Класс | Член класса
Class LayerDataset | Property BrowserItems (свойство) Property MainBrowserItems (свойство)
Class LinkedADOCustomDataset | Property BrowserItems (свойство)
Class LinkedADODataset | Property BrowserItems (свойство)
Class LinkedADOQuery | Property BrowserItems (свойство)
Class LinkedADOStoredProc | Property BrowserItems (свойство)
Class LinkedADOTable | Property BrowserItems (свойство)
Class LinkedBDEDataset | Property BrowserItems (свойство)
Class LinkedBDEQuery | Property BrowserItems (свойство)
Class LinkedBDEStoredProc | Property BrowserItems (свойство)
Class LinkedBDETable | Property BrowserItems (свойство)
Class LinkedClientDataset | Property BrowserItems (свойство)
Class LinkedDataset | Property BrowserItems (свойство)
Class LinkedIBDataset | Property BrowserItems (свойство)
Class LinkedIBQuery | Property BrowserItems (свойство)
Class LinkedIBStoredProc | Property BrowserItems (свойство)
Class LinkedIBTable | Property BrowserItems (свойство)
Class LinkedUniDataset | Property BrowserItems (свойство)
Class LinkedUniQuery | Property BrowserItems (свойство)
Class LinkedUniStoredProc | Property BrowserItems (свойство)
Class LinkedUniTable | Property BrowserItems (свойство)
Class VectorLayer | Property BrowserItems (свойство)

Смотри также

Class BrowserItem, Class CalcFields, Group Базы данных


BrowserItems.CalcFields (свойство)

Вычисляемые поля

Синтаксис

[Visual Basic 6]
ReadOnly Property CalcFields As CalcFields

[Delphi]
{только для чтения} property CalcFields: CalcFields

Смотри также

Class BrowserItems, Class CalcFields, Group Базы данных


BrowserItems.Count (свойство)

Количество элементов просмотра

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class BrowserItems, Group Базы данных


BrowserItems.Items (свойство)

Массив элементов просмотра

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BrowserItem

[Delphi]
{только для чтения} property Items: BrowserItem

Смотри также

Class BrowserItem, Class BrowserItems, Group Базы данных


BrowserItems.Add (метод)

Добавить новый пустой элемент просмотра

Синтаксис

[Visual Basic 6]
Function Add As BrowserItem

[Delphi]
function Add: BrowserItem

Возвращаемое значение

Возвращает новый элемент просмотра

Смотри также

Class BrowserItem, Class BrowserItems, Group Базы данных


BrowserItems.AddDialog (метод)

Вызывает диалог добавления элементов

Синтаксис

[Visual Basic 6]
Sub AddDialog

[Delphi]
procedure AddDialog

Смотри также

Class BrowserItems, Group Базы данных


BrowserItems.EditProperties (метод)

Редактирование свойств

Синтаксис

[Visual Basic 6]
Function EditProperties As Boolean

[Delphi]
function EditProperties: WordBool

Возвращаемое значение

Возвращает True, если свойства элементов просмотра были изменены

Смотри также

Class BrowserItems, Group Базы данных


BrowserItems.ItemByDisplayName (метод)

Найти элемент просмотра по отображаемому имени

Синтаксис

[Visual Basic 6]
Function ItemByDisplayName ( _
   ByVal DisplayName As String _
) As BrowserItem

[Delphi]
function ItemByDisplayName(
   const DisplayName: WideString
): BrowserItem

Описание параметров

DisplayName
[in] Отображаемое имя разыскиваемого поля

Возвращаемое значение

Возвращает элемент просмотра для заданного отображаемого имени поля, либо Nothing, если такого поля не существует

Смотри также

Class BrowserItem, Class BrowserItems, Group Базы данных


BrowserItems.ItemByName (метод)

Найти элемент просмотра по имени поля, если таких элементов несколько - то выдается только первый

Синтаксис

[Visual Basic 6]
Function ItemByName ( _
   ByVal FieldName As String _
) As BrowserItem

[Delphi]
function ItemByName(
   const FieldName: WideString
): BrowserItem

Описание параметров

FieldName
[in] Имя разыскиваемого поля

Возвращаемое значение

Возвращает элемент просмотра для заданного имени поля, либо Nothing, если такого поля не существует

Смотри также

Class BrowserItem, Class BrowserItems, Group Базы данных


BrowserItems.MakeDefault (метод)

Создать элементы по умолчанию

Синтаксис

[Visual Basic 6]
Sub MakeDefault

[Delphi]
procedure MakeDefault

Смотри также

Class BrowserItems, Group Базы данных


Класс By3PointAdditionalPoint

Дополнительная точка, вычисленная по трем точкам

Наследование

GeoPoint Class AdditionalPoint Class RangeAdditionalPoint Class By3PointAdditionalPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AdditionalPointType (только для чтения) | Тип засечки
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Number | Номер (описание) точки
Property Position | Положение точки
Property RangeLinkToPoints | Массив ссылок створных точек на другие точки
Property RangePointCount (только для чтения) | Количество створных (опорных) точек
Property RangePoints | Массив координат створных точек

Смотри также

Class GeoPoint, Enum IntersectionConstants, Class ModelPoint, Group Геодезия


By3PointAdditionalPoint.AdditionalPointType (свойство)

Тип засечки

Синтаксис

[Visual Basic 6]
ReadOnly Property AdditionalPointType As IntersectionConstants

[Delphi]
{только для чтения} property AdditionalPointType: IntersectionConstants

Смотри также

Class By3PointAdditionalPoint, Enum IntersectionConstants, Group Геодезия


By3PointAdditionalPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class By3PointAdditionalPoint, Group Геодезия


By3PointAdditionalPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class By3PointAdditionalPoint, Group Геодезия


By3PointAdditionalPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class By3PointAdditionalPoint, Group Геодезия


By3PointAdditionalPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class By3PointAdditionalPoint, Group Геодезия


By3PointAdditionalPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class By3PointAdditionalPoint, Group Геодезия


By3PointAdditionalPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class By3PointAdditionalPoint, Class ModelPoint, Group Геодезия


By3PointAdditionalPoint.RangeLinkToPoints (свойство)

Массив ссылок створных точек на другие точки

Синтаксис

[Visual Basic 6]
Property RangeLinkToPoints As GeoPoint

[Delphi]
property RangeLinkToPoints: GeoPoint

Смотри также

Class By3PointAdditionalPoint, Class GeoPoint, Group Геодезия


By3PointAdditionalPoint.RangePointCount (свойство)

Количество створных (опорных) точек

Синтаксис

[Visual Basic 6]
ReadOnly Property RangePointCount As Long

[Delphi]
{только для чтения} property RangePointCount: Integer

Смотри также

Class By3PointAdditionalPoint, Group Геодезия


By3PointAdditionalPoint.RangePoints (свойство)

Массив координат створных точек

Синтаксис

[Visual Basic 6]
Property RangePoints As ModelPoint

[Delphi]
property RangePoints: ModelPoint

Смотри также

Class By3PointAdditionalPoint, Class ModelPoint, Group Геодезия


Класс CADAction

Реализация ICADAction

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, к которому относится действие
Property Caption | Подпись действия (например, для пункта меню)
Property Checked | Отмечено ли действие в меню (нажата ли кнопка)
Property CustomData | Произвольное пользовательское значение
Property CustomData2 | Произвольное пользовательское значение
Property CustomData3 | Произвольное пользовательское значение
Property Enabled | Доступно ли действие
Property Handle (только для чтения) | Handle действия (Указатель на объект TAction)
Property Hint | Всплывающая подсказка
Property ImageIndex | Код иконки
Property Name | Имя действия для получения доступа к нему
Property ShortCut | Горячая клавиша
Property SingleKey | Клавиша, активизирующая действие, если нажатие клавиши не было обработано текущей командой
Property Visible | Видим ли пункт меню (или кнопка)

Методы класса

Имя | Описание
Method Execute | Выполнить действие, если оно разрешено

Где используется

Класс | Член класса
Class Application | Method FindAndExecuteAction (метод)

Смотри также

Group Пользовательский интерфейс


CADAction.Application (свойство)

Приложение, к которому относится действие

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class CADAction, Group Пользовательский интерфейс


CADAction.Caption (свойство)

Подпись действия (например, для пункта меню)

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.Checked (свойство)

Отмечено ли действие в меню (нажата ли кнопка)

Синтаксис

[Visual Basic 6]
Property Checked As Boolean

[Delphi]
property Checked: WordBool

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.CustomData (свойство)

Произвольное пользовательское значение

Синтаксис

[Visual Basic 6]
Property CustomData

[Delphi]
property CustomData

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.CustomData2 (свойство)

Произвольное пользовательское значение

Синтаксис

[Visual Basic 6]
Property CustomData2

[Delphi]
property CustomData2

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.CustomData3 (свойство)

Произвольное пользовательское значение

Синтаксис

[Visual Basic 6]
Property CustomData3

[Delphi]
property CustomData3

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.Enabled (свойство)

Доступно ли действие

Синтаксис

[Visual Basic 6]
Property Enabled As Boolean

[Delphi]
property Enabled: WordBool

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.Handle (свойство)

Handle действия (Указатель на объект TAction)

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.Hint (свойство)

Всплывающая подсказка

Синтаксис

[Visual Basic 6]
Property Hint As String

[Delphi]
property Hint: WideString

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.ImageIndex (свойство)

Код иконки

Синтаксис

[Visual Basic 6]
Property ImageIndex As Long

[Delphi]
property ImageIndex: Integer

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.Name (свойство)

Имя действия для получения доступа к нему

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.ShortCut (свойство)

Горячая клавиша

Синтаксис

[Visual Basic 6]
Property ShortCut As String

[Delphi]
property ShortCut: WideString

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.SingleKey (свойство)

Клавиша, активизирующая действие, если нажатие клавиши не было обработано текущей командой

Синтаксис

[Visual Basic 6]
Property SingleKey As Long

[Delphi]
property SingleKey: Integer

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.Visible (свойство)

Видим ли пункт меню (или кнопка)

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class CADAction, Group Пользовательский интерфейс


CADAction.Execute (метод)

Выполнить действие, если оно разрешено

Синтаксис

[Visual Basic 6]
Function Execute As Boolean

[Delphi]
function Execute: WordBool

Возвращаемое значение

Результат операции: True - действие выполнено, False - действие не может быть выполнено (Disabled)

Смотри также

Class CADAction, Group Пользовательский интерфейс


Класс CADTriangulation

Триангуляция поверхности IndorCAD

Наследование

FigureBase Class CADTriangulation

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AllowNodeDuplicates | Разрешить генерацию дублирующихся узлов (при этом дубликаты не будут входить в структуру триангуляции, но будут в списке Duplicate узлов)
Property AreaCount | Количество регионов триангуляции (входные данные)
Property Areas (только для чтения) | Массив регионов триангуляции (входные данные)
Property AutoHideBoundaryTriangles | Выставлять ли автоматически граничным узким треугольникам флаг "Скрытый"
Property AutoHideTriangles | Выставлять ли автоматически длинным треугольникам после построения триангуляциии флаг "Скрытый"
Property Bounds (только для чтения) | Минимальный объемлющий все фигуры прямоугольник
Property BreakCount | Количество структурных линий триангуляции (входные данные)
Property Breaks (только для чтения) | Массив структурных линий триангуляции (входные данные)
Property BuildTime (только для чтения) | Время построения триангуляции в милисекундах
Property Built (только для чтения) | Построена ли триангуляция
Property Caption (только для чтения) | Название базы фигур
Property CompressionLevel | Способ сжатия данных при сохранении в поток
Property DataFormat | Тип исходных данных в триангуляции
Property DefaultColor | Цвет по умолчанию для отображения треугольников (входные данные)
Property FigureSetCount (только для чтения) | Количество наборов фигур в базе
Property FigureSets (только для чтения) | Массив наборов фигур в базе (наборы фигур рисуются от последнего к первому) (индексы должны иметь номера от 0 до FigureSetCount-1)
Property FileName (только для чтения) | Имя файла с триангуляцией
Property FlipCount | Количество перебросок рёбер (входные данные)
Property Flips (только для чтения) | Массив перебросок рёбер (входные данные)
Property IgnoreRibSourceLines | Запретить генерацию данных в структурных рёбрах об исходных структурных линиях (ускоряет процесс построения триангуляции)
Property MaxRibLength | Максимальная длина ребра треугольников в метрах, не помечающихся как "Cкрытые" автоматически
Property MinAngleForBoundaryTriangles | Минимальный угол (в градусах) для граничных треугольников. Если он менее, то треугольник помечается как "Скрытый"
Property Modified | Произошли ли какие-либо изменения фигур
Property ModifierCount | Количество красящих/отсекающих линий (входные данные)
Property Modifiers (только для чтения) | Массив красящих/отсекающих линий (входные данные)
Property NodeCount (только для чтения) | Количество узлов триангуляции (выходные данные)
Property Nodes (только для чтения) | Массив узлов
Property RibCount (только для чтения) | Количество рёбер триангуляции, входящих в состав структурных линий (выходные данные)
Property Ribs (только для чтения) | Количество рёбер триангуляции, входящих в состав структурных линий (выходные данные)
Property SourceCount | Количество точек триангуляции (входные данные)
Property Sources (только для чтения) | Массив исходных точек триангуляции (входные данные)
Property TriangleCount (только для чтения) | Количество треугольников триангуляции (выходные данные)
Property Triangles (только для чтения) | Количество треугольников триангуляции (выходные данные)
Property UseProgress | Показывать ли прогресс при загрузке/сохранении/построении?

Методы класса

Имя | Описание
Method AddModifier | Добавить новую красящую линию, заданную в виде последовательности точек
Method AddModifierShape | Добавить новую красящую линию, заданный в виде полилинии
Method AddPolygon | Добавить новый регион, заданный в виде последовательности точек, образующих один контур
Method AddPolygonShape | Добавить новый регион, заданный в виде полигона
Method AddPolyline | Добавить новую структурную линию, заданную в виде последовательности точек
Method AddPolylineShape | Добавить новую структурную линию, заданную в виде полилинии
Method AddSource | Добавить новую исходную точку
Method Build | Построить триангуляцию по указанным входным данных
Method BuildIsoexpos | Построить экспозиции (изонаправления) заданных разделителей направлений ExpoDelimiters и вернуть их в Isoexpos в виде полигонов (возможны Nothing в коллекции)
Method BuildIsoline | Построить изолинию заданного уровня Level и вернуть её в виде полиполилинии
Method BuildIsolines | Построить изолинии заданных уровней Levels и вернуть их в Isolines в виде полиполилиний или полигонов
Method BuildIsoslopes | Построить изоклины (изоуклоны) заданных наклонов Slopes и вернуть их в Isoslopes в виде полиполилиний или полигонов
Method BuildNoAreaClassify | Построить триангуляцию по указанным данных без классификации треугольников по регионам
Method BuildVisibilities | Построение зон и линий видимости из заданной точки
Method CalcHash | Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников. Используется для выявления факта различия разных триангуляций
Method CalcHashInPolygon | Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников в заданном регионе. Используется для выявления факта различия разных триангуляций
Method CalcHashInRect | Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников в заданном прямоугольнике. Используется для выявления факта различия разных триангуляций
Method CalcSimpleAlongPolyline | Вычислить значение простой хеш-функции по координатам узлов и топологии треугольников вдоль полилинии
Method CalcSimpleAlongSegment | Вычислить значение простой хеш-функции по координатам узлов и топологии треугольников вдоль полилинии
Method CalcSimpleHash | Вычислить значение хеш-функции по координатам узлов и топологии треугольников. Используется для выявления факта различия разных триангуляций
Method CalcSimpleHashInPolygon | Вычислить значение хеш-функции по координатам узлов и топологии треугольников в заданном регионе. Используется для выявления факта различия разных триангуляций
Method CalcSimpleHashInRect | Вычислить значение хеш-функции по координатам узлов и топологии треугольников в заданном прямоугольнике. Используется для выявления факта различия разных триангуляций
Method CalcSquare | Расчёт площади по всей видимой части триангуляции, возможно, только по треугольникам c Tag>0
Method CanFlipAtPoint | Проверить, возможно ли в указанной точке триангуляции выполнить переброску
Method Clear | Очистить триангуляцию
Method CustomBuild | Построить или достроить триангуляцию по указанным входным данных
Method CutByPolygon | Вырезать подтриангуляцию, попадающую внутрь полигона
Method CutByPolygons | Вырезать подтриангуляцию, попадающую внутрь списка полигонов
Method DeleteArea | Удалить регион по индексу
Method DeleteBreak | Удалить структурную линию по индексу
Method DeleteFlip | Удалить переброску рёбер по индексу
Method DeleteModifier | Удалить модификатор по индексу
Method DeleteSource | Удалить исходную точку по индексу
Method EarthVolume | Расчёт объёма земляных работ при выравнивании всей видимой части триангуляции до уровня Z=Level. AboveVolume - объём выше, BelowVolume - объём ниже уровня, AboveSquare - площадь участка, поверхность которого находится выше Level
Method EnumerateProfile | Построение профиля на отрезке Point1-Point2, на выходе отрезки профиля выдаются в EnumerateProfile.Register
Method EnumerateProfilePoints | Построение профиля на отрезке Point1-Point2, на выходе узловые точки профиля выдаются в EnumerateProfilePoints.Register
Method ExportToXmlFile | Сохранение в Xml-файл
Method ExportToXmlNode | Сохранение в узел Xml-файла
Method ExpositionAtPoint | Вычисление экспозиции (направления) склона в заданной точке триангуляции
Method ExtractBorder | Создать полигон по границе триангуляции
Method ExtractPolygon | Выделить из триангуляции все связанные области треугольников, имеющих поле положительное поле Tag. Результат возвращается в виде полиполигона
Method ExtractPolygons | Выделить из триангуляции все связанные области треугольников, имеющих положительное поле Tag. Результат возвращается в виде коллекции полигонов
Method ExtractTriangles | Выделить из триангуляции все области треугольников, имеющих поле Tag>0. В один полигон объединяются все треугольники с одинаковым Tag. Результат возвращается в виде коллекций полигонов и соответствующих им значений поля Tag
Method ExtractVoronoi | Построить диаграммы Вороного. Результат возвращается в виде коллекции полигонов. Результат возвращается в виде коллекций полигонов, образующих отдельные диаграммы Вороного, и соответствующих им значений поля Id узлов
Method FindHeightRange | Найти минимальную и максимальную высоту видимой части триангуляции
Method FindNode | Найти узел триангуляции в заданой точке
Method FindTriangle | Поиск треугольника для заданной точки
Method FindTriangles | Выделить все треугольники вдоль отрезка Point1-Point2. Все найденные треугольники будут помещены в коллекцию Triangles
Method FlipAtPoint | Выполнить переброску рёбер, если возможно в указанной точке триангуляции. Возвращает True, если переброска выполнена
Method GetObjectAtPoint | Получить объект в заданной позиции. Если там ничего нет, то возвращает Nothing
Method GetObjectsAtPoint | Получить все объекты в заданной позиции в виде коллекции объектов типа TrnFigure. Если там ничего нет, то возвращает Nothing
Method GetObjectsAtRect | Получить все объекты в заданном прямоугольнике в виде коллекции объектов типа TrnFigure. Если там ничего нет, то возвращает Nothing
Method GetProfile | Получить сечение поверхности по полининии заданной в Polyline
Method GetSoftRibAtPoint | Найти в указанной точке триангуляции ребро в виде пары смежных треугольников. В переменных RibIndex1/2 возвращаются номера ссылок на парный треугольник, в HardRib - жёсткое ребро, если оно существует
Method HeightAtPoint | Вычисление высоты в заданной точке триангуляции
Method IncrementalAddBoundary | Перестроить структуру триангуляции, вставив туда регион (границу триангуляции), заданный в виде последовательности точек. При этом в список Areas регион не добавляется
Method IncrementalAddBoundaryShape | Перестроить структуру триангуляции, вставив туда регион (границу триангуляции), заданный в виде полигона. При этом в список Areas регион не добавляется
Method Invalidate | Разорвать связь исходных данных с построенными структурами
Method LoadFromFile | Загрузка триангуляции из файла
Method LoadFromStream | Загрузка триангуляции из файла потока
Method MakeCopy | Создать копию триангуляции (можно без копирования исходных данных)
Method NormalAtPoint | Вычисление интерполированного вектора нормали в заданной точке триангуляции
Method OptimizeFlips | По текущей триангуляции строит оптимальную структуру перебросок
Method PolygonSquare | Площадь полигона по поверхности видимой части триангуляции и в проекции
Method PolygonsSquare | Площадь внутри списка полигонов по поверхности видимой части триангуляции и в проекции
Method RemoveSources | Удалить исходные данные
Method Reset | Удалить построенные структуры, оставить только исходные данные
Method Save | Если FileName='', то запрашивается имя и вызывается SaveToFile(FileName)}
Method SaveAsToFile | Сохранение в заданный файл
Method SaveCopyTo | Сохранение копии в заданный файл
Method SaveToFile | Сохранение триангуляции в заданный файл
Method SaveToStream | Сохранение триангуляции в заданный поток
Method SetAllNodeTags | Выставить поля Tag для всех узлов триангуляции
Method SetAllTriangleTags | Выставить поля Tag для всех треугольников (можно только для всех видимых)
Method SlopeAtPoint | Вычисление уклона в заданной точке триангуляции
Method SurfaceDifference | Вычислить поверхность, полученную вычитанием другой поверхности из исходной
Method SurfaceEarthVolume | Расчёт объёма земляных работ при выравнивании всей видимой части триангуляции до другой триангуляции. Возвращает также регион, внутри которого выполнены измерения.
Method Thicken | Выполнить сгущение триангуляции до заданной точности представления поверхности или до максимального числа узлов триангуляции
Method TrnToBreakLines | Преобразовать текущую структуру триангуляции в структурные линии
Method TrnToSources | Преобразовать текущую структуру триангуляции в исходные точки, структурные линии и регионы
Method ValidateLevels | Отсортировать список уровней и удалить лишние уровни (которые выше или ниже всей триангуляции)
Method Verify | Проверить структуру триангуляции - для отладки
Method ZeroEarthVolumes | Расчёт объёмов земляных работ при выравнивании всей видимой триангуляции до уровня ZeroLevel, причём объёмы вычисляются отдельно для каждого интервала уровней высот. Всегда в массив интервалов заносится ZeroLevel. Размер выходного массива на 1 > входного.

Где используется

Класс | Член класса
Class Layer | Property Triangulation (свойство)

Смотри также

Enum BSplineEdgeConstants, Class Collection, Enum CompressionLevelConstants, Enum CurveKindConstants, Class DoubleCollection, Enum EdgeCurvatureConstants, Class FigureSet, Interface IEnumerateProfile, Interface IEnumerateProfilePoints, Class IntegerCollection, Interface ITrnFigureFilter, Class ModelPoint, Class ModelRect, Class Point3D, Class ShapePolygon, Class ShapePolyline, Enum SlopeModeConstants, Class Triangulation, Enum TriangulationFormatConstants, Class TrnArea, Class TrnBreak, Class TrnFigure, Class TrnFlip, Enum TrnFlipAbilityConstants, Class TrnModifier, Enum TrnModifierKindConstants, Class TrnNode, Enum TrnNodeWeightModeConstants, Class TrnRib, Enum TrnSaveModeConstants, Class TrnSource, Class TrnTriangle, Enum VolumeTypeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.AllowNodeDuplicates (свойство)

Разрешить генерацию дублирующихся узлов (при этом дубликаты не будут входить в структуру триангуляции, но будут в списке Duplicate узлов)

Синтаксис

[Visual Basic 6]
Property AllowNodeDuplicates As Boolean

[Delphi]
property AllowNodeDuplicates: WordBool

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.AreaCount (свойство)

Количество регионов триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
Property AreaCount As Long

[Delphi]
property AreaCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Areas (свойство)

Массив регионов триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Areas As TrnArea

[Delphi]
{только для чтения} property Areas: TrnArea

Смотри также

Class CADTriangulation, Class TrnArea, Group Поверхности, Group Триангуляция


CADTriangulation.AutoHideBoundaryTriangles (свойство)

Выставлять ли автоматически граничным узким треугольникам флаг "Скрытый"

Синтаксис

[Visual Basic 6]
Property AutoHideBoundaryTriangles As Boolean

[Delphi]
property AutoHideBoundaryTriangles: WordBool

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.AutoHideTriangles (свойство)

Выставлять ли автоматически длинным треугольникам после построения триангуляциии флаг "Скрытый"

Синтаксис

[Visual Basic 6]
Property AutoHideTriangles As Boolean

[Delphi]
property AutoHideTriangles: WordBool

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Bounds (свойство)

Минимальный объемлющий все фигуры прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class CADTriangulation, Class ModelRect, Group Поверхности, Group Триангуляция


CADTriangulation.BreakCount (свойство)

Количество структурных линий триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
Property BreakCount As Long

[Delphi]
property BreakCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Breaks (свойство)

Массив структурных линий триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Breaks As TrnBreak

[Delphi]
{только для чтения} property Breaks: TrnBreak

Смотри также

Class CADTriangulation, Class TrnBreak, Group Поверхности, Group Триангуляция


CADTriangulation.BuildTime (свойство)

Время построения триангуляции в милисекундах

Синтаксис

[Visual Basic 6]
ReadOnly Property BuildTime As Long

[Delphi]
{только для чтения} property BuildTime: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Built (свойство)

Построена ли триангуляция

Синтаксис

[Visual Basic 6]
ReadOnly Property Built As Boolean

[Delphi]
{только для чтения} property Built: WordBool

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Caption (свойство)

Название базы фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.CompressionLevel (свойство)

Способ сжатия данных при сохранении в поток

Синтаксис

[Visual Basic 6]
Property CompressionLevel As CompressionLevelConstants

[Delphi]
property CompressionLevel: CompressionLevelConstants

Смотри также

Class CADTriangulation, Enum CompressionLevelConstants, Group Поверхности, Group Триангуляция


CADTriangulation.DataFormat (свойство)

Тип исходных данных в триангуляции

Синтаксис

[Visual Basic 6]
Property DataFormat As TriangulationFormatConstants

[Delphi]
property DataFormat: TriangulationFormatConstants

Смотри также

Class CADTriangulation, Enum TriangulationFormatConstants, Group Поверхности, Group Триангуляция


CADTriangulation.DefaultColor (свойство)

Цвет по умолчанию для отображения треугольников (входные данные)

Синтаксис

[Visual Basic 6]
Property DefaultColor As OLE_COLOR

[Delphi]
property DefaultColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.FigureSetCount (свойство)

Количество наборов фигур в базе

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureSetCount As Long

[Delphi]
{только для чтения} property FigureSetCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.FigureSets (свойство)

Массив наборов фигур в базе (наборы фигур рисуются от последнего к первому) (индексы должны иметь номера от 0 до FigureSetCount-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureSets As FigureSet

[Delphi]
{только для чтения} property FigureSets: FigureSet

Смотри также

Class CADTriangulation, Class FigureSet, Group Поверхности, Group Триангуляция


CADTriangulation.FileName (свойство)

Имя файла с триангуляцией

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.FlipCount (свойство)

Количество перебросок рёбер (входные данные)

Синтаксис

[Visual Basic 6]
Property FlipCount As Long

[Delphi]
property FlipCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Flips (свойство)

Массив перебросок рёбер (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Flips As TrnFlip

[Delphi]
{только для чтения} property Flips: TrnFlip

Смотри также

Class CADTriangulation, Class TrnFlip, Group Поверхности, Group Триангуляция


CADTriangulation.IgnoreRibSourceLines (свойство)

Запретить генерацию данных в структурных рёбрах об исходных структурных линиях (ускоряет процесс построения триангуляции)

Синтаксис

[Visual Basic 6]
Property IgnoreRibSourceLines As Boolean

[Delphi]
property IgnoreRibSourceLines: WordBool

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.MaxRibLength (свойство)

Максимальная длина ребра треугольников в метрах, не помечающихся как "Cкрытые" автоматически

Синтаксис

[Visual Basic 6]
Property MaxRibLength As Double

[Delphi]
property MaxRibLength: Double

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.MinAngleForBoundaryTriangles (свойство)

Минимальный угол (в градусах) для граничных треугольников. Если он менее, то треугольник помечается как "Скрытый"

Синтаксис

[Visual Basic 6]
Property MinAngleForBoundaryTriangles As Double

[Delphi]
property MinAngleForBoundaryTriangles: Double

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Modified (свойство)

Произошли ли какие-либо изменения фигур

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.ModifierCount (свойство)

Количество красящих/отсекающих линий (входные данные)

Синтаксис

[Visual Basic 6]
Property ModifierCount As Long

[Delphi]
property ModifierCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Modifiers (свойство)

Массив красящих/отсекающих линий (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Modifiers As TrnModifier

[Delphi]
{только для чтения} property Modifiers: TrnModifier

Смотри также

Class CADTriangulation, Class TrnModifier, Group Поверхности, Group Триангуляция


CADTriangulation.NodeCount (свойство)

Количество узлов триангуляции (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property NodeCount As Long

[Delphi]
{только для чтения} property NodeCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Nodes (свойство)

Массив узлов

Синтаксис

[Visual Basic 6]
ReadOnly Property Nodes As TrnNode

[Delphi]
{только для чтения} property Nodes: TrnNode

Смотри также

Class CADTriangulation, Class TrnNode, Group Поверхности, Group Триангуляция


CADTriangulation.RibCount (свойство)

Количество рёбер триангуляции, входящих в состав структурных линий (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property RibCount As Long

[Delphi]
{только для чтения} property RibCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Ribs (свойство)

Количество рёбер триангуляции, входящих в состав структурных линий (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Ribs As TrnRib

[Delphi]
{только для чтения} property Ribs: TrnRib

Смотри также

Class CADTriangulation, Class TrnRib, Group Поверхности, Group Триангуляция


CADTriangulation.SourceCount (свойство)

Количество точек триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
Property SourceCount As Long

[Delphi]
property SourceCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Sources (свойство)

Массив исходных точек триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Sources As TrnSource

[Delphi]
{только для чтения} property Sources: TrnSource

Смотри также

Class CADTriangulation, Class TrnSource, Group Поверхности, Group Триангуляция


CADTriangulation.TriangleCount (свойство)

Количество треугольников триангуляции (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property TriangleCount As Long

[Delphi]
{только для чтения} property TriangleCount: Integer

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Triangles (свойство)

Количество треугольников триангуляции (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangles As TrnTriangle

[Delphi]
{только для чтения} property Triangles: TrnTriangle

Смотри также

Class CADTriangulation, Class TrnTriangle, Group Поверхности, Group Триангуляция


CADTriangulation.UseProgress (свойство)

Показывать ли прогресс при загрузке/сохранении/построении?

Синтаксис

[Visual Basic 6]
Property UseProgress As Boolean

[Delphi]
property UseProgress: WordBool

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.AddModifier (метод)

Добавить новую красящую линию, заданную в виде последовательности точек

Синтаксис

[Visual Basic 6]
Function AddModifier ( _
   ByVal Points As Collection, _
   [ByVal Kind As TrnModifierKindConstants = 0], _
   [ByVal Color As OLE_COLOR = 0] _
) As TrnModifier

[Delphi]
function AddModifier(
   const Points: Collection;
   const Kind: TrnModifierKindConstants;
   const Color: OLE_COLOR
): TrnModifier

Описание параметров

Points
[in] Коллекция точек типа ModelPoint, образующих модификатор
Kind
[in] Тип модификатора
Color
[in] Цвет окраски треугольников для модификаторов типа TrnModifierKindPainter (красители)

Возвращаемое значение

Возвращает новый модификатор

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CADTriangulation, Class Collection, Class TrnModifier, Enum TrnModifierKindConstants, Group Поверхности, Group Триангуляция


CADTriangulation.AddModifierShape (метод)

Добавить новую красящую линию, заданный в виде полилинии

Синтаксис

[Visual Basic 6]
Function AddModifierShape ( _
   ByVal Polyline As ShapePolyline, _
   [ByVal Kind As TrnModifierKindConstants = 0], _
   [ByVal Color As OLE_COLOR = 0] _
) As TrnModifier

[Delphi]
function AddModifierShape(
   const Polyline: ShapePolyline;
   const Kind: TrnModifierKindConstants;
   const Color: OLE_COLOR
): TrnModifier

Описание параметров

Polyline
[in] Полилиния, определяющая красящую линию
Kind
[in] Тип модификатора
Color
[in] Цвет окраски треугольников для модификаторов типа TrnModifierKindPainter (красители)

Возвращаемое значение

Возвращает новый модификатор

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CADTriangulation, Class ShapePolyline, Class TrnModifier, Enum TrnModifierKindConstants, Group Поверхности, Group Триангуляция


CADTriangulation.AddPolygon (метод)

Добавить новый регион, заданный в виде последовательности точек, образующих один контур

Синтаксис

[Visual Basic 6]
Function AddPolygon ( _
   ByVal Points As Collection, _
   [ByVal EqualZ As Double = 0] _
) As TrnArea

[Delphi]
function AddPolygon(
   const Points: Collection;
   const EqualZ: Double
): TrnArea

Описание параметров

Points
[in] Коллекция точек типа ModelPoint, образующих контур полигона
EqualZ
[in] Общая высота, задаваемая всем узлам полигона

Возвращаемое значение

Возвращает новый регион

Смотри также

Class CADTriangulation, Class Collection, Class TrnArea, Group Поверхности, Group Триангуляция


CADTriangulation.AddPolygonShape (метод)

Добавить новый регион, заданный в виде полигона

Синтаксис

[Visual Basic 6]
Function AddPolygonShape ( _
   ByVal Polygon As ShapePolygon, _
   [ByVal EqualZ As Double = 0] _
) As TrnArea

[Delphi]
function AddPolygonShape(
   const Polygon: ShapePolygon;
   const EqualZ: Double
): TrnArea

Описание параметров

Polygon
[in] Добавляемый полигон
EqualZ
[in] Общая высота, задаваемая всем узлам полигона

Возвращаемое значение

Возвращает новый регион

Смотри также

Class CADTriangulation, Class ShapePolygon, Class TrnArea, Group Поверхности, Group Триангуляция


CADTriangulation.AddPolyline (метод)

Добавить новую структурную линию, заданную в виде последовательности точек

Синтаксис

[Visual Basic 6]
Function AddPolyline ( _
   ByVal Points As Collection, _
   [ByVal Smooth As Boolean = False], _
   [ByVal EqualZ As Double = 0] _
) As TrnBreak

[Delphi]
function AddPolyline(
   const Points: Collection;
   const Smooth: WordBool;
   const EqualZ: Double
): TrnBreak

Описание параметров

Points
[in] Коллекция точек типа ModelPoint, образующих полилинию
Smooth
[in] Признак того, что добавляемая структурная линия не должна определять резкий излом модели поверхности, а определять гладкий перегиб
EqualZ
[in] Общая высота, задаваемая всем узлам полилинии

Возвращаемое значение

Возвращает новую структурную линию

Смотри также

Class CADTriangulation, Class Collection, Class TrnBreak, Group Поверхности, Group Триангуляция


CADTriangulation.AddPolylineShape (метод)

Добавить новую структурную линию, заданную в виде полилинии

Синтаксис

[Visual Basic 6]
Function AddPolylineShape ( _
   ByVal Polyline As ShapePolyline, _
   [ByVal Smooth As Boolean = False], _
   [ByVal EqualZ As Double = 0] _
) As TrnBreak

[Delphi]
function AddPolylineShape(
   const Polyline: ShapePolyline;
   const Smooth: WordBool;
   const EqualZ: Double
): TrnBreak

Описание параметров

Polyline
[in] Добавляемая полилиния
Smooth
[in] Признак того, что добавляемая структурная линия не должна определять резкий излом модели поверхности, а определять гладкий перегиб
EqualZ
[in] Общая высота, задаваемая всем узлам полилинии

Возвращаемое значение

Возвращает новую структурную линию

Смотри также

Class CADTriangulation, Class ShapePolyline, Class TrnBreak, Group Поверхности, Group Триангуляция


CADTriangulation.AddSource (метод)

Добавить новую исходную точку

Синтаксис

[Visual Basic 6]
Function AddSource ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
) As TrnSource

[Delphi]
function AddSource(
   const X: Double;
   const Y: Double;
   const Z: Double
): TrnSource

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки

Возвращаемое значение

Возвращает новую исходную точку

Смотри также

Class CADTriangulation, Class TrnSource, Group Поверхности, Group Триангуляция


CADTriangulation.Build (метод)

Построить триангуляцию по указанным входным данных

Синтаксис

[Visual Basic 6]
Sub Build

[Delphi]
procedure Build

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.BuildIsoexpos (метод)

Построить экспозиции (изонаправления) заданных разделителей направлений ExpoDelimiters и вернуть их в Isoexpos в виде полигонов (возможны Nothing в коллекции)

Синтаксис

[Visual Basic 6]
Sub BuildIsoexpos ( _
   ByVal ExpoDelimiters As DoubleCollection, _
   Isoexpos As Collection, _
   ByVal MinSlope As Double, _
   [ByVal MinSlopeMode As SlopeModeConstants = 0] _
)

[Delphi]
procedure BuildIsoexpos(
   const ExpoDelimiters: DoubleCollection;
   var Isoexpos: Collection;
   const MinSlope: Double;
   const MinSlopeMode: SlopeModeConstants
)

Описание параметров

ExpoDelimiters
[in] Коллекция DoubleCollection заданных разделителей направлений
Isoexpos
[in, out] Возращает коллекцию Collection найденных полигонов PolygonShape
MinSlope
[in] Минимальный допустимый наклон. Если вычисленный наклон будет меньше этого, то функция возвратит False
MinSlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле

Смотри также

Class CADTriangulation, Class Collection, Class DoubleCollection, Enum SlopeModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.BuildIsoline (метод)

Построить изолинию заданного уровня Level и вернуть её в виде полиполилинии

Синтаксис

[Visual Basic 6]
Function BuildIsoline ( _
   ByVal Level As Double, _
   [ByVal CurveKind As CurveKindConstants = 0], _
   [ByVal Curvature As EdgeCurvatureConstants = 0], _
   [ByVal Tension As Double = 1], _
   [ByVal BSplineEdge As BSplineEdgeConstants = 0] _
) As ShapePolyline

[Delphi]
function BuildIsoline(
   const Level: Double;
   const CurveKind: CurveKindConstants;
   const Curvature: EdgeCurvatureConstants;
   const Tension: Double;
   const BSplineEdge: BSplineEdgeConstants
): ShapePolyline

Описание параметров

Level
[in] Уровень, на котором нужно построить изолинию
CurveKind
[in] Тип сглаживания (если CurveKindLine, то сглаживания нет и последующие параметры игнорируются)
Curvature
[in] Кривизна на концах полилинии для интерполяционных сплайнов
Tension
[in] Степень натяжения сплайнов
BSplineEdge
[in] Тип краевого ограничения для B-сплайнов

Возвращаемое значение

Возращает построенную изолинию или Nothing, если изолиния на таком уровне не может быть построена

Смотри также

Enum BSplineEdgeConstants, Class CADTriangulation, Enum CurveKindConstants, Enum EdgeCurvatureConstants, Class ShapePolyline, Group Поверхности, Group Триангуляция


CADTriangulation.BuildIsolines (метод)

Построить изолинии заданных уровней Levels и вернуть их в Isolines в виде полиполилиний или полигонов

Синтаксис

[Visual Basic 6]
Sub BuildIsolines ( _
   ByVal Levels As DoubleCollection, _
   Isolines As Collection, _
   [ByVal BuildBands As Boolean = False], _
   [ByVal CurveKind As CurveKindConstants = 0], _
   [ByVal Curvature As EdgeCurvatureConstants = 0], _
   [ByVal Tension As Double = 1], _
   [ByVal BSplineEdge As BSplineEdgeConstants = 0] _
)

[Delphi]
procedure BuildIsolines(
   const Levels: DoubleCollection;
   var Isolines: Collection;
   const BuildBands: WordBool;
   const CurveKind: CurveKindConstants;
   const Curvature: EdgeCurvatureConstants;
   const Tension: Double;
   const BSplineEdge: BSplineEdgeConstants
)

Описание параметров

Levels
[in] Коллекция DoubleCollection уровней
Isolines
[in, out] Возращает коллекцию Collection найденных полилиний PolylineShape (для BuildBands = False) или полигонов PolygonShape (для BuildBands = True)
BuildBands
[in] Строить ли изоконтуры? Иначе будут просто изолинии
CurveKind
[in] Тип сглаживания (если CurveKindLine, то сглаживания нет и последующие параметры игнорируются)
Curvature
[in] Кривизна на концах полилинии для интерполяционных сплайнов
Tension
[in] Степень натяжения сплайнов
BSplineEdge
[in] Тип краевого ограничения для B-сплайнов

Смотри также

Enum BSplineEdgeConstants, Class CADTriangulation, Class Collection, Enum CurveKindConstants, Class DoubleCollection, Enum EdgeCurvatureConstants, Group Поверхности, Group Триангуляция


CADTriangulation.BuildIsoslopes (метод)

Построить изоклины (изоуклоны) заданных наклонов Slopes и вернуть их в Isoslopes в виде полиполилиний или полигонов

Синтаксис

[Visual Basic 6]
Sub BuildIsoslopes ( _
   ByVal Slopes As DoubleCollection, _
   Isoslopes As Collection, _
   [ByVal SlopeMode As SlopeModeConstants = 0], _
   [ByVal BuildBands As Boolean = False], _
   [ByVal CurveKind As CurveKindConstants = 0], _
   [ByVal Curvature As EdgeCurvatureConstants = 0], _
   [ByVal Tension As Double = 1], _
   [ByVal BSplineEdge As BSplineEdgeConstants = 0] _
)

[Delphi]
procedure BuildIsoslopes(
   const Slopes: DoubleCollection;
   var Isoslopes: Collection;
   const SlopeMode: SlopeModeConstants;
   const BuildBands: WordBool;
   const CurveKind: CurveKindConstants;
   const Curvature: EdgeCurvatureConstants;
   const Tension: Double;
   const BSplineEdge: BSplineEdgeConstants
)

Описание параметров

Slopes
[in] Коллекция DoubleCollection уровней уклонов
Isoslopes
[in, out] Возращает коллекцию Collection найденных полилиний PolylineShape (для BuildBands = False) или полигонов PolygonShape (для BuildBands = True)
SlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле
BuildBands
[in] Строить ли изоконтуры? Иначе будут просто изолинии
CurveKind
[in] Тип сглаживания (если CurveKindLine, то сглаживания нет и последующие параметры игнорируются)
Curvature
[in] Кривизна на концах полилинии для интерполяционных сплайнов
Tension
[in] Степень натяжения сплайнов
BSplineEdge
[in] Тип краевого ограничения для B-сплайнов

Смотри также

Enum BSplineEdgeConstants, Class CADTriangulation, Class Collection, Enum CurveKindConstants, Class DoubleCollection, Enum EdgeCurvatureConstants, Enum SlopeModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.BuildNoAreaClassify (метод)

Построить триангуляцию по указанным данных без классификации треугольников по регионам

Синтаксис

[Visual Basic 6]
Sub BuildNoAreaClassify

[Delphi]
procedure BuildNoAreaClassify

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.BuildVisibilities (метод)

Построение зон и линий видимости из заданной точки

Синтаксис

[Visual Basic 6]
Sub BuildVisibilities ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   VisibleAreas As Collection, _
   UnvisibleAreas As Collection, _
   VisibleLines As Collection, _
   UnvisibleLines As Collection, _
   ByVal ZOverSurface As Boolean _
)

[Delphi]
procedure BuildVisibilities(
   const X: Double;
   const Y: Double;
   const Z: Double;
   var VisibleAreas: Collection;
   var UnvisibleAreas: Collection;
   var VisibleLines: Collection;
   var UnvisibleLines: Collection;
   const ZOverSurface: WordBool
)

Описание параметров

X
[in] Координата X точки наблюдения
Y
[in] Координата Y точки наблюдения
Z
[in] Координата Z точки наблюдения
VisibleAreas
[in, out] Возращает коллекцию Collection полигонов, показывающих видимую часть триангуляции
UnvisibleAreas
[in, out] Возращает коллекцию Collection полигонов, показывающих невидимую часть триангуляции
VisibleLines
[in, out] Возращает коллекцию Collection радиальных полилиний, показывающих видимую части триангуляции
UnvisibleLines
[in, out] Возращает коллекцию Collection радиальных полилиний, показывающих видимую части триангуляции
ZOverSurface
[in] Если True, то заданная координата Z определяет возвышение точки наблюдения над поверхностью, иначе Z - это абсолютная координата

Смотри также

Class CADTriangulation, Class Collection, Group Поверхности, Group Триангуляция


CADTriangulation.CalcHash (метод)

Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcHash ( _
   [ByVal UseZ As Boolean = True], _
   [ByVal UseIsolines As Boolean = True], _
   [ByVal UseHidden As Boolean = True], _
   [ByVal UseColors As Boolean = True] _
) As String

[Delphi]
function CalcHash(
   const UseZ: WordBool;
   const UseIsolines: WordBool;
   const UseHidden: WordBool;
   const UseColors: WordBool
): WideString

Описание параметров

UseZ
[in] Использовать ли для вычисления хеша координату Z узлов
UseIsolines
[in] Использовать ли для вычисления хеша признак NoIsolines треугольников
UseHidden
[in] Использовать ли для вычисления хеша признак Hidden треугольников
UseColors
[in] Использовать ли для вычисления хеша цвет треугольников

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.CalcHashInPolygon (метод)

Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников в заданном регионе. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcHashInPolygon ( _
   ByVal Polygon As ShapePolygon, _
   [ByVal UseZ As Boolean = True], _
   [ByVal UseIsolines As Boolean = True], _
   [ByVal UseHidden As Boolean = True], _
   [ByVal UseColors As Boolean = True] _
) As String

[Delphi]
function CalcHashInPolygon(
   const Polygon: ShapePolygon;
   const UseZ: WordBool;
   const UseIsolines: WordBool;
   const UseHidden: WordBool;
   const UseColors: WordBool
): WideString

Описание параметров

Polygon
[in] Полигон, внутри которого нужно расчитать хеш
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов
UseIsolines
[in] Использовать ли для вычисления хеша признак NoIsolines треугольников
UseHidden
[in] Использовать ли для вычисления хеша признак Hidden треугольников
UseColors
[in] Использовать ли для вычисления хеша цвет треугольников

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class CADTriangulation, Class ShapePolygon, Group Поверхности, Group Триангуляция


CADTriangulation.CalcHashInRect (метод)

Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников в заданном прямоугольнике. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcHashInRect ( _
   ByVal Rect As ModelRect, _
   [ByVal UseZ As Boolean = True], _
   [ByVal UseIsolines As Boolean = True], _
   [ByVal UseHidden As Boolean = True], _
   [ByVal UseColors As Boolean = True] _
) As String

[Delphi]
function CalcHashInRect(
   const Rect: ModelRect;
   const UseZ: WordBool;
   const UseIsolines: WordBool;
   const UseHidden: WordBool;
   const UseColors: WordBool
): WideString

Описание параметров

Rect
[in] Прямоугольник, внутри которого нужно расчитать хеш
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов
UseIsolines
[in] Использовать ли для вычисления хеша признак NoIsolines треугольников
UseHidden
[in] Использовать ли для вычисления хеша признак Hidden треугольников
UseColors
[in] Использовать ли для вычисления хеша цвет треугольников

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class CADTriangulation, Class ModelRect, Group Поверхности, Group Триангуляция


CADTriangulation.CalcSimpleAlongPolyline (метод)

Вычислить значение простой хеш-функции по координатам узлов и топологии треугольников вдоль полилинии

Синтаксис

[Visual Basic 6]
Function CalcSimpleAlongPolyline ( _
   ByVal Polyline As ShapePolyline _
) As Double

[Delphi]
function CalcSimpleAlongPolyline(
   const Polyline: ShapePolyline
): Double

Описание параметров

Polyline
[in] Полилиния, вдоль которой нужно расчитать хеш

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class CADTriangulation, Class ShapePolyline, Group Поверхности, Group Триангуляция


CADTriangulation.CalcSimpleAlongSegment (метод)

Вычислить значение простой хеш-функции по координатам узлов и топологии треугольников вдоль полилинии

Синтаксис

[Visual Basic 6]
Function CalcSimpleAlongSegment ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint _
) As Double

[Delphi]
function CalcSimpleAlongSegment(
   const Point1: ModelPoint;
   const Point2: ModelPoint
): Double

Описание параметров

Point1
[in] Первая точка отрезка, вдоль которого нужно расчитать хеш
Point2
[in] Вторая точка отрезка, вдоль которого нужно расчитать хеш

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class CADTriangulation, Class ModelPoint, Group Поверхности, Group Триангуляция


CADTriangulation.CalcSimpleHash (метод)

Вычислить значение хеш-функции по координатам узлов и топологии треугольников. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcSimpleHash ( _
   [ByVal UseGeometry As Boolean = True], _
   [ByVal UseZ As Boolean = True] _
) As Double

[Delphi]
function CalcSimpleHash(
   const UseGeometry: WordBool;
   const UseZ: WordBool
): Double

Описание параметров

UseGeometry
[in] Использовать ли для вычисления хеша координаты узлов
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.CalcSimpleHashInPolygon (метод)

Вычислить значение хеш-функции по координатам узлов и топологии треугольников в заданном регионе. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcSimpleHashInPolygon ( _
   ByVal Polygon As ShapePolygon, _
   [ByVal UseGeometry As Boolean = True], _
   [ByVal UseZ As Boolean = True] _
) As Double

[Delphi]
function CalcSimpleHashInPolygon(
   const Polygon: ShapePolygon;
   const UseGeometry: WordBool;
   const UseZ: WordBool
): Double

Описание параметров

Polygon
[in] Полигон, внутри которого нужно расчитать хеш
UseGeometry
[in] Использовать ли для вычисления хеша координаты узлов
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class CADTriangulation, Class ShapePolygon, Group Поверхности, Group Триангуляция


CADTriangulation.CalcSimpleHashInRect (метод)

Вычислить значение хеш-функции по координатам узлов и топологии треугольников в заданном прямоугольнике. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcSimpleHashInRect ( _
   ByVal Rect As ModelRect, _
   [ByVal UseGeometry As Boolean = True], _
   [ByVal UseZ As Boolean = True] _
) As Double

[Delphi]
function CalcSimpleHashInRect(
   const Rect: ModelRect;
   const UseGeometry: WordBool;
   const UseZ: WordBool
): Double

Описание параметров

Rect
[in] Прямоугольник, внутри которого нужно расчитать хеш
UseGeometry
[in] Использовать ли для вычисления хеша координаты узлов
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class CADTriangulation, Class ModelRect, Group Поверхности, Group Триангуляция


CADTriangulation.CalcSquare (метод)

Расчёт площади по всей видимой части триангуляции, возможно, только по треугольникам c Tag>0

Синтаксис

[Visual Basic 6]
Sub CalcSquare ( _
   FlatSquare As Double, _
   SpatialSquare As Double, _
   [ByVal UsePositiveTag As Boolean = False] _
)

[Delphi]
procedure CalcSquare(
   out FlatSquare: Double;
   out SpatialSquare: Double;
   const UsePositiveTag: WordBool
)

Описание параметров

FlatSquare
[out] Площадь триангуляции в проекции на плоскость
SpatialSquare
[out] Площадь поверхности триангуляции
UsePositiveTag
[in] В случае указания True в данном параметре, то вычисление площадей будет выполняться только по тем треугольникам, у которых свойство Tag>0

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.CanFlipAtPoint (метод)

Проверить, возможно ли в указанной точке триангуляции выполнить переброску

Синтаксис

[Visual Basic 6]
Function CanFlipAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Precision As Double _
) As TrnFlipAbilityConstants

[Delphi]
function CanFlipAtPoint(
   const X: Double;
   const Y: Double;
   const Precision: Double
): TrnFlipAbilityConstants

Описание параметров

X
[in] Координата X точки на плоскости, в которой необходимо найти ребро триангуляции, пригодное для выполнения переброски
Y
[in] Координата Y точки на плоскости, в которой необходимо найти ребро триангуляции, пригодное для выполнения переброски
Precision
[in] Максимальный радиус поиска подходящих ребер триангуляции для переброски в указанной точке плоскости

Возвращаемое значение

Возвращает вариант выполнения переброски в указанной точки триангуляции

Смотри также

Class CADTriangulation, Enum TrnFlipAbilityConstants, Group Поверхности, Group Триангуляция


CADTriangulation.Clear (метод)

Очистить триангуляцию

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.CustomBuild (метод)

Построить или достроить триангуляцию по указанным входным данных

Синтаксис

[Visual Basic 6]
Sub CustomBuild ( _
   [ByVal New As Boolean = True], _
   [ByVal NoDeloneTest As Boolean = False], _
   [ByVal NeedProgress As Boolean = False], _
   [ByVal AllRibHard As Boolean = False], _
   [ByVal NoAreaClassify As Boolean = False], _
   [ByVal WorkSources As Collection = 0], _
   [ByVal WorkLines As Collection = 0], _
   [ByVal WorkAreas As Collection = 0], _
   [ByVal WorkFlips As Collection = 0], _
   [ByVal WorkModifiers As Collection = 0] _
)

[Delphi]
procedure CustomBuild(
   const New: WordBool;
   const NoDeloneTest: WordBool;
   const NeedProgress: WordBool;
   const AllRibHard: WordBool;
   const NoAreaClassify: WordBool;
   const WorkSources: Collection;
   const WorkLines: Collection;
   const WorkAreas: Collection;
   const WorkFlips: Collection;
   const WorkModifiers: Collection
)

Описание параметров

New
[in] Построить триангуляцию с нуля (иначе добавить к старым структурам)
NoDeloneTest
[in] Не выполнять перестроения Делоне
NeedProgress
[in] Отображать ли прогресс
AllRibHard
[in] Трактовать все пересекаемые ребра как жёсткие
NoAreaClassify
[in] Не выполнять классификацию регионов
WorkSources
[in] Список исходных точек или Nothing
WorkLines
[in] Список структурных линий или Nothing
WorkAreas
[in] Список регионов или Nothing
WorkFlips
[in] Список перебросок рёбер или Nothing
WorkModifiers
[in] Список модификаторов или Nothing

Смотри также

Class CADTriangulation, Class Collection, Group Поверхности, Group Триангуляция


CADTriangulation.CutByPolygon (метод)

Вырезать подтриангуляцию, попадающую внутрь полигона

Синтаксис

[Visual Basic 6]
Function CutByPolygon ( _
   ByVal Polygon As ShapePolygon _
) As Triangulation

[Delphi]
function CutByPolygon(
   const Polygon: ShapePolygon
): Triangulation

Описание параметров

Polygon
[in] Полигон, в пределах которого нужно обрезать подтриангуляцию

Возвращаемое значение

Возвращает новую обрезанную триангуляцию

Смотри также

Class CADTriangulation, Class ShapePolygon, Class Triangulation, Group Поверхности, Group Триангуляция


CADTriangulation.CutByPolygons (метод)

Вырезать подтриангуляцию, попадающую внутрь списка полигонов

Синтаксис

[Visual Basic 6]
Function CutByPolygons ( _
   ByVal Polygons As Collection _
) As Triangulation

[Delphi]
function CutByPolygons(
   const Polygons: Collection
): Triangulation

Описание параметров

Polygons
[in] Список полигонов PolygonShape, в пределах которых нужно обрезать подтриангуляцию

Возвращаемое значение

Возвращает новую обрезанную триангуляцию

Смотри также

Class CADTriangulation, Class Collection, Class Triangulation, Group Поверхности, Group Триангуляция


CADTriangulation.DeleteArea (метод)

Удалить регион по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteArea ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteArea(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемого региона (нумерация идёт от 0 до AreaCount-1)

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.DeleteBreak (метод)

Удалить структурную линию по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteBreak ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteBreak(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемой структурной линии (нумерация идёт от 0 до LineCount-1)

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.DeleteFlip (метод)

Удалить переброску рёбер по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteFlip ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteFlip(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемой переброски рёбер (нумерация идёт от 0 до FlipCount-1)

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.DeleteModifier (метод)

Удалить модификатор по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteModifier ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteModifier(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемого модификатора (нумерация идёт от 0 до ModifierCount-1)

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.DeleteSource (метод)

Удалить исходную точку по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteSource ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteSource(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемой точки (нумерация идёт от 0 до SourceCount-1)

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.EarthVolume (метод)

Расчёт объёма земляных работ при выравнивании всей видимой части триангуляции до уровня Z=Level. AboveVolume - объём выше, BelowVolume - объём ниже уровня, AboveSquare - площадь участка, поверхность которого находится выше Level

Синтаксис

[Visual Basic 6]
Sub EarthVolume ( _
   ByVal Level As Double, _
   BelowVolume As Double, _
   BelowSquare As Double, _
   AboveVolume As Double, _
   AboveSquare As Double _
)

[Delphi]
procedure EarthVolume(
   const Level: Double;
   out BelowVolume: Double;
   out BelowSquare: Double;
   out AboveVolume: Double;
   out AboveSquare: Double
)

Описание параметров

Level
[in] Уровень выравнивания
BelowVolume
[out] Вычисленный объём земляных работ ниже указанной плоскости
BelowSquare
[out] Площадь участка, поверхность которого ниже указанной плоскости
AboveVolume
[out] Вычисленный объём земляных работ выше указанной плоскости
AboveSquare
[out] Площадь участка, поверхность которого выше указанной плоскости

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.EnumerateProfile (метод)

Построение профиля на отрезке Point1-Point2, на выходе отрезки профиля выдаются в EnumerateProfile.Register

Синтаксис

[Visual Basic 6]
Function EnumerateProfile ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint, _
   ByVal EnumerateProfileInterface As IEnumerateProfile _
) As Boolean

[Delphi]
function EnumerateProfile(
   const Point1: ModelPoint;
   const Point2: ModelPoint;
   const EnumerateProfileInterface: IEnumerateProfile
): WordBool

Описание параметров

Point1
[in] Первая точка отрезка
Point2
[in] Вторая точка отрезка
EnumerateProfileInterface
[in] Интерфейс, у которого будет вызван метод Register, в который будут переданы все найденные отрезки

Возвращаемое значение

Возвращает True, если профиль успешно найден

Смотри также

Class CADTriangulation, Interface IEnumerateProfile, Class ModelPoint, Group Поверхности, Group Триангуляция


CADTriangulation.EnumerateProfilePoints (метод)

Построение профиля на отрезке Point1-Point2, на выходе узловые точки профиля выдаются в EnumerateProfilePoints.Register

Синтаксис

[Visual Basic 6]
Function EnumerateProfilePoints ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint, _
   ByVal EnumerateProfilePointsInterface As IEnumerateProfilePoints _
) As Boolean

[Delphi]
function EnumerateProfilePoints(
   const Point1: ModelPoint;
   const Point2: ModelPoint;
   const EnumerateProfilePointsInterface: IEnumerateProfilePoints
): WordBool

Описание параметров

Point1
[in] Первая точка отрезка
Point2
[in] Вторая точка отрезка
EnumerateProfilePointsInterface
[in] Интерфейс, у которого будет вызван метод Register, в который будут переданы все найденные точки профиля

Возвращаемое значение

Возвращает True, если узловые точки профиля успешно найдены

Смотри также

Class CADTriangulation, Interface IEnumerateProfilePoints, Class ModelPoint, Group Поверхности, Group Триангуляция


CADTriangulation.ExportToXmlFile (метод)

Сохранение в Xml-файл

Синтаксис

[Visual Basic 6]
Sub ExportToXmlFile ( _
   ByVal FileName As String, _
   [ByVal SaveMode As TrnSaveModeConstants = 0], _
   [ByVal Format As Boolean = False] _
)

[Delphi]
procedure ExportToXmlFile(
   const FileName: WideString;
   const SaveMode: TrnSaveModeConstants;
   const Format: WordBool
)

Описание параметров

FileName
[in] Имя Xml-файла, в который необходимо выполнить сохранение триангуляции
SaveMode
[in] Режим сохранения триангуляции
Format
[in] Следует ли выполнять форматирование с отступами создаваемого xml-файла

Смотри также

Class CADTriangulation, Enum TrnSaveModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.ExportToXmlNode (метод)

Сохранение в узел Xml-файла

Синтаксис

[Visual Basic 6]
Sub ExportToXmlNode ( _
   ByVal IXMLNode As IUnknown, _
   [ByVal SaveMode As TrnSaveModeConstants = 0] _
)

[Delphi]
procedure ExportToXmlNode(
   const IXMLNode: IUnknown;
   const SaveMode: TrnSaveModeConstants
)

Описание параметров

IXMLNode
[in] Xml-узел, под которым необходимо выполнить сохранение триангуляции
SaveMode
[in] Режим сохранения триангуляции

Смотри также

Class CADTriangulation, Enum TrnSaveModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.ExpositionAtPoint (метод)

Вычисление экспозиции (направления) склона в заданной точке триангуляции

Синтаксис

[Visual Basic 6]
Function ExpositionAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal MinSlope As Double, _
   ByVal SlopeMode As SlopeModeConstants, _
   ByVal WeightMode As TrnNodeWeightModeConstants, _
   Exposition As Double _
) As Boolean

[Delphi]
function ExpositionAtPoint(
   const X: Double;
   const Y: Double;
   const MinSlope: Double;
   const SlopeMode: SlopeModeConstants;
   const WeightMode: TrnNodeWeightModeConstants;
   out Exposition: Double
): WordBool

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо вычислить экспозицию
Y
[in] Координата Y точки плоскости, в которой необходимо вычислить экспозицию
MinSlope
[in] Минимальное значение уклона, меньше которого участок рельефа считается горизонтальным
SlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников
Exposition
[out] Вычисленный экспозиция

Возвращаемое значение

Возвращает True, если в указанной точке экспозиция вычислена

Смотри также

Class CADTriangulation, Enum SlopeModeConstants, Enum TrnNodeWeightModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.ExtractBorder (метод)

Создать полигон по границе триангуляции

Синтаксис

[Visual Basic 6]
Function ExtractBorder ( _
   [ByVal WithZ As Boolean = False], _
   [ByVal VisibleOnly As Boolean = True] _
) As ShapePolygon

[Delphi]
function ExtractBorder(
   const WithZ: WordBool;
   const VisibleOnly: WordBool
): ShapePolygon

Описание параметров

WithZ
[in] Следует ли извлекать полигон вместе с координатой Z
VisibleOnly
[in] Следует ли извлекать полигон только по видимой части триангуляции

Возвращаемое значение

Возращает полигон, образующий границу триангуляции

Смотри также

Class CADTriangulation, Class ShapePolygon, Group Поверхности, Group Триангуляция


CADTriangulation.ExtractPolygon (метод)

Выделить из триангуляции все связанные области треугольников, имеющих поле положительное поле Tag. Результат возвращается в виде полиполигона

Синтаксис

[Visual Basic 6]
Function ExtractPolygon ( _
   [ByVal WithZ As Boolean = False] _
) As ShapePolygon

[Delphi]
function ExtractPolygon(
   const WithZ: WordBool
): ShapePolygon

Описание параметров

WithZ
[in] Следует ли извлекать полигон вместе с координатой Z

Возвращаемое значение

Возращает найденный полиполигон

Смотри также

Class CADTriangulation, Class ShapePolygon, Group Поверхности, Group Триангуляция


CADTriangulation.ExtractPolygons (метод)

Выделить из триангуляции все связанные области треугольников, имеющих положительное поле Tag. Результат возвращается в виде коллекции полигонов

Синтаксис

[Visual Basic 6]
Sub ExtractPolygons ( _
   FoundPolygons As Collection, _
   [ByVal WithZ As Boolean = False] _
)

[Delphi]
procedure ExtractPolygons(
   var FoundPolygons: Collection;
   const WithZ: WordBool
)

Описание параметров

FoundPolygons
[in, out] Возращает коллекцию Collection найденных полигонов PolygonShape
WithZ
[in] Следует ли извлекать полигоны вместе с координатой Z

Смотри также

Class CADTriangulation, Class Collection, Group Поверхности, Group Триангуляция


CADTriangulation.ExtractTriangles (метод)

Выделить из триангуляции все области треугольников, имеющих поле Tag>0. В один полигон объединяются все треугольники с одинаковым Tag. Результат возвращается в виде коллекций полигонов и соответствующих им значений поля Tag

Синтаксис

[Visual Basic 6]
Sub ExtractTriangles ( _
   ByVal WithZ As Boolean, _
   ByVal MakePolyPolygons As Boolean, _
   Polygons As Collection, _
   PolygonTags As IntegerCollection _
)

[Delphi]
procedure ExtractTriangles(
   const WithZ: WordBool;
   const MakePolyPolygons: WordBool;
   var Polygons: Collection;
   var PolygonTags: IntegerCollection
)

Описание параметров

WithZ
[in] Следует ли извлекать полигоны вместе с координатой Z
MakePolyPolygons
[in] Следует ли извлекать полигоны в виде полполигонов, объединяя несмежные области с одним значением Tag
Polygons
[in, out] Возращает коллекцию Collection найденных полигонов PolygonShape
PolygonTags
[in, out] Возращает коллекцию IntegerCollection значений поля Tag для каждого возвращённого в коллекции Polygons полигона

Смотри также

Class CADTriangulation, Class Collection, Class IntegerCollection, Group Поверхности, Group Триангуляция


CADTriangulation.ExtractVoronoi (метод)

Построить диаграммы Вороного. Результат возвращается в виде коллекции полигонов. Результат возвращается в виде коллекций полигонов, образующих отдельные диаграммы Вороного, и соответствующих им значений поля Id узлов

Синтаксис

[Visual Basic 6]
Sub ExtractVoronoi ( _
   NodePolygons As Collection, _
   PolygonNodeIds As IntegerCollection _
)

[Delphi]
procedure ExtractVoronoi(
   var NodePolygons: Collection;
   var PolygonNodeIds: IntegerCollection
)

Описание параметров

NodePolygons
[in, out] Возращает коллекцию Collection найденных полигонов PolygonShape, образующих отдельные диаграммы Вороного
PolygonNodeIds
[in, out] Возращает коллекцию IntegerCollection значений поля Id узла для каждого возвращённого в коллекции Polygons полигона (каждый полигон строится вокруг некоторого узла)

Смотри также

Class CADTriangulation, Class Collection, Class IntegerCollection, Group Поверхности, Group Триангуляция


CADTriangulation.FindHeightRange (метод)

Найти минимальную и максимальную высоту видимой части триангуляции

Синтаксис

[Visual Basic 6]
Function FindHeightRange ( _
   Min As Double, _
   Max As Double _
) As Boolean

[Delphi]
function FindHeightRange(
   out Min: Double;
   out Max: Double
): WordBool

Описание параметров

Min
[out] Минимальная высота триангуляции
Max
[out] Максимальная высота триангуляции

Возвращаемое значение

Возвращает True, если в триангуляции есть хотя бы один треугольник

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.FindNode (метод)

Найти узел триангуляции в заданой точке

Синтаксис

[Visual Basic 6]
Function FindNode ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As TrnNode

[Delphi]
function FindNode(
   const X: Double;
   const Y: Double
): TrnNode

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо найти узел
Y
[in] Координата Y точки плоскости, в которой необходимо найти узел

Возвращаемое значение

Возвращает узел в указанной точке плоскости или Nothing, если таковой не найден

Смотри также

Class CADTriangulation, Class TrnNode, Group Поверхности, Group Триангуляция


CADTriangulation.FindTriangle (метод)

Поиск треугольника для заданной точки

Синтаксис

[Visual Basic 6]
Function FindTriangle ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As TrnTriangle

[Delphi]
function FindTriangle(
   const X: Double;
   const Y: Double
): TrnTriangle

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо найти треугольник
Y
[in] Координата Y точки плоскости, в которой необходимо найти треугольник

Возвращаемое значение

Возвращает треугольник в указанной точке плоскости или Nothing, если таковой не найден

Смотри также

Class CADTriangulation, Class TrnTriangle, Group Поверхности, Group Триангуляция


CADTriangulation.FindTriangles (метод)

Выделить все треугольники вдоль отрезка Point1-Point2. Все найденные треугольники будут помещены в коллекцию Triangles

Синтаксис

[Visual Basic 6]
Function FindTriangles ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint, _
   Triangles As Collection, _
   [ByVal VisibleTrianglesOnly As Boolean = True] _
) As Boolean

[Delphi]
function FindTriangles(
   const Point1: ModelPoint;
   const Point2: ModelPoint;
   var Triangles: Collection;
   const VisibleTrianglesOnly: WordBool
): WordBool

Описание параметров

Point1
[in] Первая точка отрезка
Point2
[in] Вторая точка отрезка
Triangles
[in, out] Коллекция, в которую будут помещены все найденные пересекаемые отрезком треугольники
VisibleTrianglesOnly
[in] Если True, то будут искаться только видимые треугольники

Возвращаемое значение

Возвращает True, если треугольники успешно найдены

Смотри также

Class CADTriangulation, Class Collection, Class ModelPoint, Group Поверхности, Group Триангуляция


CADTriangulation.FlipAtPoint (метод)

Выполнить переброску рёбер, если возможно в указанной точке триангуляции. Возвращает True, если переброска выполнена

Синтаксис

[Visual Basic 6]
Function FlipAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Precision As Double, _
   ByVal ImmediatelyFlip As Boolean _
) As TrnFlip

[Delphi]
function FlipAtPoint(
   const X: Double;
   const Y: Double;
   const Precision: Double;
   const ImmediatelyFlip: WordBool
): TrnFlip

Описание параметров

X
[in] Координата X точки на плоскости, в которой необходимо найти ребро триангуляции и выполнить его переброску
Y
[in] Координата Y точки на плоскости, в которой необходимо найти ребро триангуляции и выполнить его переброску
Precision
[in] Максимальный радиус поиска подходящих ребер триангуляции для переброски в указанной точке плоскости
ImmediatelyFlip
[in] Необходимо ли немедленно выполнить переброску

Возвращаемое значение

Возвращает новую переброску

Смотри также

Class CADTriangulation, Class TrnFlip, Group Поверхности, Group Триангуляция


CADTriangulation.GetObjectAtPoint (метод)

Получить объект в заданной позиции. Если там ничего нет, то возвращает Nothing

Синтаксис

[Visual Basic 6]
Function GetObjectAtPoint ( _
   ByVal Point As ModelPoint, _
   ByVal Delta As Double, _
   ByVal GetSources As Boolean, _
   ByVal GetBreaks As Boolean, _
   ByVal GetAreas As Boolean, _
   ByVal GetFlips As Boolean, _
   ByVal GetModifiers As Boolean, _
   ByVal GetNodes As Boolean, _
   ByVal GetRibs As Boolean, _
   ByVal GetTriangles As Boolean, _
   ByVal GetCutted As Boolean, _
   [ByVal Filter As ITrnFigureFilter = 0] _
) As TrnFigure

[Delphi]
function GetObjectAtPoint(
   const Point: ModelPoint;
   const Delta: Double;
   const GetSources: WordBool;
   const GetBreaks: WordBool;
   const GetAreas: WordBool;
   const GetFlips: WordBool;
   const GetModifiers: WordBool;
   const GetNodes: WordBool;
   const GetRibs: WordBool;
   const GetTriangles: WordBool;
   const GetCutted: WordBool;
   const Filter: ITrnFigureFilter
): TrnFigure

Описание параметров

Point
[in] Точка на плоскости, в которой нужно получить объект
Delta
[in] Максимальное отклонение от указанной точки, в пределах которого нужно искать объекты
GetSources
[in] Следует ли искать исходные точки
GetBreaks
[in] Следует ли искать структурные линии
GetAreas
[in] Следует ли искать регионы
GetFlips
[in] Следует ли искать переброски рёбер
GetModifiers
[in] Следует ли искать модификаторы
GetNodes
[in] Следует ли искать узлы триангуляции
GetRibs
[in] Следует ли искать жёсткие рёбра триангуляции
GetTriangles
[in] Следует ли искать треугольники триангуляции
GetCutted
[in] Следует ли искать в невидимой части триангуяции
Filter
[in] Дополнительный фильтр разыскиваемых объектов, реализуемый пользователем. Метод IsValidObject интерфейса ITrnFigureFilter должен вернуть True, если указанный в аргументах метода IsValidObject объект является допустимым

Возвращаемое значение

Возращает найденный объект в указанной позиции или Nothing, если ничего не найдено

Смотри также

Class CADTriangulation, Interface ITrnFigureFilter, Class ModelPoint, Class TrnFigure, Group Поверхности, Group Триангуляция


CADTriangulation.GetObjectsAtPoint (метод)

Получить все объекты в заданной позиции в виде коллекции объектов типа TrnFigure. Если там ничего нет, то возвращает Nothing

Синтаксис

[Visual Basic 6]
Sub GetObjectsAtPoint ( _
   ByVal Point As ModelPoint, _
   ByVal Delta As Double, _
   FoundObjects As Collection, _
   [ByVal GetSources As Boolean = True], _
   [ByVal GetBreaks As Boolean = False], _
   [ByVal GetAreas As Boolean = False], _
   [ByVal GetFlips As Boolean = False], _
   [ByVal GetModifiers As Boolean = False], _
   [ByVal GetNodes As Boolean = False], _
   [ByVal GetRibs As Boolean = False], _
   [ByVal GetTriangles As Boolean = False], _
   [ByVal GetCutted As Boolean = False], _
   [ByVal Filter As ITrnFigureFilter = 0] _
)

[Delphi]
procedure GetObjectsAtPoint(
   const Point: ModelPoint;
   const Delta: Double;
   var FoundObjects: Collection;
   const GetSources: WordBool;
   const GetBreaks: WordBool;
   const GetAreas: WordBool;
   const GetFlips: WordBool;
   const GetModifiers: WordBool;
   const GetNodes: WordBool;
   const GetRibs: WordBool;
   const GetTriangles: WordBool;
   const GetCutted: WordBool;
   const Filter: ITrnFigureFilter
)

Описание параметров

Point
[in] Точка на плоскости, в которой нужно получить объекты
Delta
[in] Максимальное отклонение от указанной точки, в пределах которого нужно искать объекты
FoundObjects
[in, out] Возращает коллекцию Collection со всеми найденными объектами TrnFigure в указанной позиции или Nothing, если ничего не найдено
GetSources
[in] Следует ли искать исходные точки
GetBreaks
[in] Следует ли искать структурные линии
GetAreas
[in] Следует ли искать регионы
GetFlips
[in] Следует ли искать переброски рёбер
GetModifiers
[in] Следует ли искать модификаторы
GetNodes
[in] Следует ли искать узлы триангуляции
GetRibs
[in] Следует ли искать жёсткие рёбра триангуляции
GetTriangles
[in] Следует ли искать треугольники триангуляции
GetCutted
[in] Следует ли искать в невидимой части триангуяции
Filter
[in] Дополнительный фильтр разыскиваемых объектов, реализуемый пользователем. Метод IsValidObject интерфейса ITrnFigureFilter должен вернуть True, если указанный в аргументах метода IsValidObject объект является допустимым

Смотри также

Class CADTriangulation, Class Collection, Interface ITrnFigureFilter, Class ModelPoint, Group Поверхности, Group Триангуляция


CADTriangulation.GetObjectsAtRect (метод)

Получить все объекты в заданном прямоугольнике в виде коллекции объектов типа TrnFigure. Если там ничего нет, то возвращает Nothing

Синтаксис

[Visual Basic 6]
Sub GetObjectsAtRect ( _
   ByVal Rect As ModelRect, _
   FoundObjects As Collection, _
   [ByVal GetSources As Boolean = True], _
   [ByVal GetBreaks As Boolean = False], _
   [ByVal GetAreas As Boolean = False], _
   [ByVal GetFlips As Boolean = False], _
   [ByVal GetModifiers As Boolean = False], _
   [ByVal GetNodes As Boolean = False], _
   [ByVal GetRibs As Boolean = False], _
   [ByVal GetTriangles As Boolean = False], _
   [ByVal GetCutted As Boolean = False], _
   [ByVal Filter As ITrnFigureFilter = 0] _
)

[Delphi]
procedure GetObjectsAtRect(
   const Rect: ModelRect;
   var FoundObjects: Collection;
   const GetSources: WordBool;
   const GetBreaks: WordBool;
   const GetAreas: WordBool;
   const GetFlips: WordBool;
   const GetModifiers: WordBool;
   const GetNodes: WordBool;
   const GetRibs: WordBool;
   const GetTriangles: WordBool;
   const GetCutted: WordBool;
   const Filter: ITrnFigureFilter
)

Описание параметров

Rect
[in] Прямоугольник на плоскости, в котором нужно получить объект
FoundObjects
[in, out] Возращает коллекцию Collection со всеми найденными объектами TrnFigure в указанном прямоугольнике или Nothing, если ничего не найдено
GetSources
[in] Следует ли искать исходные точки
GetBreaks
[in] Следует ли искать структурные линии
GetAreas
[in] Следует ли искать регионы
GetFlips
[in] Следует ли искать переброски рёбер
GetModifiers
[in] Следует ли искать модификаторы
GetNodes
[in] Следует ли искать узлы триангуляции
GetRibs
[in] Следует ли искать жёсткие рёбра триангуляции
GetTriangles
[in] Следует ли искать треугольники триангуляции
GetCutted
[in] Следует ли искать в невидимой части триангуяции
Filter
[in] Дополнительный фильтр разыскиваемых объектов, реализуемый пользователем. Метод IsValidObject интерфейса ITrnFigureFilter должен вернуть True, если указанный в аргументах метода IsValidObject объект является допустимым

Смотри также

Class CADTriangulation, Class Collection, Interface ITrnFigureFilter, Class ModelRect, Group Поверхности, Group Триангуляция


CADTriangulation.GetProfile (метод)

Получить сечение поверхности по полининии заданной в Polyline

Синтаксис

[Visual Basic 6]
Function GetProfile ( _
   ByVal Polyline As ShapePolyline _
) As ShapePolyline

[Delphi]
function GetProfile(
   const Polyline: ShapePolyline
): ShapePolyline

Описание параметров

Polyline
[in] Полилиния, по которой необходимо построить сечение. Если полилиния имеет меру (свойство HasM имеет значение True), то массив Ms может содержать пикетажные положения точек полилинии. Если полилиния не имеет меры, то пикетажное положение вычисляется автоматически по длине линии от нуля

Возвращаемое значение

Возращает построенное сечение или Nothing, если сечение не может быть построено

Смотри также

Class CADTriangulation, Class ShapePolyline, Group Поверхности, Group Триангуляция


CADTriangulation.GetSoftRibAtPoint (метод)

Найти в указанной точке триангуляции ребро в виде пары смежных треугольников. В переменных RibIndex1/2 возвращаются номера ссылок на парный треугольник, в HardRib - жёсткое ребро, если оно существует

Синтаксис

[Visual Basic 6]
Sub GetSoftRibAtPoint ( _
   ByVal Point As ModelPoint, _
   ByVal Delta As Double, _
   Triangle1 As TrnTriangle, _
   Triangle2 As TrnTriangle, _
   RibIndex1 As Long, _
   RibIndex2 As Long, _
   HardRib As TrnRib _
)

[Delphi]
procedure GetSoftRibAtPoint(
   const Point: ModelPoint;
   const Delta: Double;
   out Triangle1: TrnTriangle;
   out Triangle2: TrnTriangle;
   out RibIndex1: Integer;
   out RibIndex2: Integer;
   out HardRib: TrnRib
)

Описание параметров

Point
[in] Точка на плоскости, в которой нужно получить ребро
Delta
[in] Максимальное отклонение от указанной точки, в пределах которого нужно искать ребро
Triangle1
[out] Первый треугольник, смежный с найденным ребром, или Nothing, если ребро не найдено
Triangle2
[out] Второй треугольник, смежный с найденным ребром, или Nothing, если ребро не найдено
RibIndex1
[out] Номер найденного ребра в первом треугольнике, или -1, если ребро не найдено
RibIndex2
[out] Номер найденного ребра во втором треугольнике, или -1, если ребро не найдено
HardRib
[out] Найденное жёсткое ребро или Nothing, если жёсткого ребра в данной позиции нет

Смотри также

Class CADTriangulation, Class ModelPoint, Class TrnRib, Class TrnTriangle, Group Поверхности, Group Триангуляция


CADTriangulation.HeightAtPoint (метод)

Вычисление высоты в заданной точке триангуляции

Синтаксис

[Visual Basic 6]
Function HeightAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   Height As Double, _
   [ByVal DefaultHeight As Double = 0] _
) As Boolean

[Delphi]
function HeightAtPoint(
   const X: Double;
   const Y: Double;
   out Height: Double;
   const DefaultHeight: Double
): WordBool

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо вычислить высоту
Y
[in] Координата Y точки плоскости, в которой необходимо вычислить высоту
Height
[out] Вычисленная высота
DefaultHeight
[in] Возвращаемое значение для случая, если указанная точка выйдет за видимую границу триангуляции

Возвращаемое значение

Возвращает True, если в указанной точке высота вычислена

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.IncrementalAddBoundary (метод)

Перестроить структуру триангуляции, вставив туда регион (границу триангуляции), заданный в виде последовательности точек. При этом в список Areas регион не добавляется

Синтаксис

[Visual Basic 6]
Sub IncrementalAddBoundary ( _
   ByVal Points As Collection _
)

[Delphi]
procedure IncrementalAddBoundary(
   const Points: Collection
)

Описание параметров

Points
[in] Коллекция точек типа ModelPoint, образующих контур полигона

Смотри также

Class CADTriangulation, Class Collection, Group Поверхности, Group Триангуляция


CADTriangulation.IncrementalAddBoundaryShape (метод)

Перестроить структуру триангуляции, вставив туда регион (границу триангуляции), заданный в виде полигона. При этом в список Areas регион не добавляется

Синтаксис

[Visual Basic 6]
Sub IncrementalAddBoundaryShape ( _
   ByVal Polygon As ShapePolygon _
)

[Delphi]
procedure IncrementalAddBoundaryShape(
   const Polygon: ShapePolygon
)

Описание параметров

Polygon
[in] Добавляемый полигон

Смотри также

Class CADTriangulation, Class ShapePolygon, Group Поверхности, Group Триангуляция


CADTriangulation.Invalidate (метод)

Разорвать связь исходных данных с построенными структурами

Синтаксис

[Visual Basic 6]
Sub Invalidate

[Delphi]
procedure Invalidate

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.LoadFromFile (метод)

Загрузка триангуляции из файла

Синтаксис

[Visual Basic 6]
Sub LoadFromFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure LoadFromFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла, из которого необходимо загрузить триангуляцию

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.LoadFromStream (метод)

Загрузка триангуляции из файла потока

Синтаксис

[Visual Basic 6]
Sub LoadFromStream ( _
   ByVal IStream As IUnknown _
)

[Delphi]
procedure LoadFromStream(
   const IStream: IUnknown
)

Описание параметров

IStream
[in] Поток, из которого необходимо загрузить триангуляцию

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.MakeCopy (метод)

Создать копию триангуляции (можно без копирования исходных данных)

Синтаксис

[Visual Basic 6]
Function MakeCopy ( _
   [ByVal SaveMode As TrnSaveModeConstants = 0] _
) As Triangulation

[Delphi]
function MakeCopy(
   const SaveMode: TrnSaveModeConstants
): Triangulation

Описание параметров

SaveMode
[in] Режим копирования триангуляции

Возвращаемое значение

Возвращает копию триангуляции

Смотри также

Class CADTriangulation, Class Triangulation, Enum TrnSaveModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.NormalAtPoint (метод)

Вычисление интерполированного вектора нормали в заданной точке триангуляции

Синтаксис

[Visual Basic 6]
Function NormalAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   [ByVal WeightMode As TrnNodeWeightModeConstants = 0] _
) As Point3D

[Delphi]
function NormalAtPoint(
   const X: Double;
   const Y: Double;
   const WeightMode: TrnNodeWeightModeConstants
): Point3D

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо вычислить нормаль
Y
[in] Координата Y точки плоскости, в которой необходимо вычислить нормаль
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников

Возвращаемое значение

Возвращает нормаль в указанной точке плоскости или Nothing, если в данной точке триангуляция отсутствует

Смотри также

Class CADTriangulation, Class Point3D, Enum TrnNodeWeightModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.OptimizeFlips (метод)

По текущей триангуляции строит оптимальную структуру перебросок

Синтаксис

[Visual Basic 6]
Function OptimizeFlips As Boolean

[Delphi]
function OptimizeFlips: WordBool

Возвращаемое значение

Возвращает True, если оптимизация была успешно выполнена и дала эффект

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.PolygonSquare (метод)

Площадь полигона по поверхности видимой части триангуляции и в проекции

Синтаксис

[Visual Basic 6]
Sub PolygonSquare ( _
   ByVal Polygon As ShapePolygon, _
   FlatSquare As Double, _
   SpatialSquare As Double _
)

[Delphi]
procedure PolygonSquare(
   const Polygon: ShapePolygon;
   out FlatSquare: Double;
   out SpatialSquare: Double
)

Описание параметров

Polygon
[in] Полигон, в пределах которого необходимо вычислить площади
FlatSquare
[out] Вычисленная площадь поверхности в проекции в пределах полигона
SpatialSquare
[out] Вычисленная площадь поверхности в пределах полигона

Смотри также

Class CADTriangulation, Class ShapePolygon, Group Поверхности, Group Триангуляция


CADTriangulation.PolygonsSquare (метод)

Площадь внутри списка полигонов по поверхности видимой части триангуляции и в проекции

Синтаксис

[Visual Basic 6]
Sub PolygonsSquare ( _
   ByVal Polygons As Collection, _
   FlatSquare As Double, _
   SpatialSquare As Double _
)

[Delphi]
procedure PolygonsSquare(
   const Polygons: Collection;
   out FlatSquare: Double;
   out SpatialSquare: Double
)

Описание параметров

Polygons
[in] Список полигонов PolygonShape, в пределах которых необходимо вычислить площади
FlatSquare
[out] Вычисленная площадь поверхности в проекции в пределах полигона
SpatialSquare
[out] Вычисленная площадь поверхности в пределах полигона

Смотри также

Class CADTriangulation, Class Collection, Group Поверхности, Group Триангуляция


CADTriangulation.RemoveSources (метод)

Удалить исходные данные

Синтаксис

[Visual Basic 6]
Sub RemoveSources

[Delphi]
procedure RemoveSources

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Reset (метод)

Удалить построенные структуры, оставить только исходные данные

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Save (метод)

Если FileName='', то запрашивается имя и вызывается SaveToFile(FileName)}

Синтаксис

[Visual Basic 6]
Sub Save

[Delphi]
procedure Save

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.SaveAsToFile (метод)

Сохранение в заданный файл

Синтаксис

[Visual Basic 6]
Sub SaveAsToFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveAsToFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла, в который необходимо выполнить сохранение триангуляции

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.SaveCopyTo (метод)

Сохранение копии в заданный файл

Синтаксис

[Visual Basic 6]
Sub SaveCopyTo ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveCopyTo(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла, в который необходимо выполнить сохранение копии триангуляции

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.SaveToFile (метод)

Сохранение триангуляции в заданный файл

Синтаксис

[Visual Basic 6]
Sub SaveToFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveToFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла, в который необходимо выполнить сохранение триангуляции

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.SaveToStream (метод)

Сохранение триангуляции в заданный поток

Синтаксис

[Visual Basic 6]
Sub SaveToStream ( _
   ByVal IStream As IUnknown, _
   [ByVal SaveMode As TrnSaveModeConstants = 0] _
)

[Delphi]
procedure SaveToStream(
   const IStream: IUnknown;
   const SaveMode: TrnSaveModeConstants
)

Описание параметров

IStream
[in] Поток, в который необходимо выполнить сохранение триангуляции
SaveMode
[in] Режим сохранения триангуляции

Смотри также

Class CADTriangulation, Enum TrnSaveModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.SetAllNodeTags (метод)

Выставить поля Tag для всех узлов триангуляции

Синтаксис

[Visual Basic 6]
Sub SetAllNodeTags ( _
   ByVal Tag As Long _
)

[Delphi]
procedure SetAllNodeTags(
   const Tag: Integer
)

Описание параметров

Tag
[in] Выставляемое значение Tag

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.SetAllTriangleTags (метод)

Выставить поля Tag для всех треугольников (можно только для всех видимых)

Синтаксис

[Visual Basic 6]
Sub SetAllTriangleTags ( _
   ByVal Tag As Long, _
   ByVal VisibleOnly As Boolean _
)

[Delphi]
procedure SetAllTriangleTags(
   const Tag: Integer;
   const VisibleOnly: WordBool
)

Описание параметров

Tag
[in] Выставляемое значение Tag
VisibleOnly
[in] Если True, то поле Tag будет изменено только для видимых треугольников

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.SlopeAtPoint (метод)

Вычисление уклона в заданной точке триангуляции

Синтаксис

[Visual Basic 6]
Function SlopeAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal SlopeMode As SlopeModeConstants, _
   Slope As Double, _
   [ByVal WeightMode As TrnNodeWeightModeConstants = 0] _
) As Boolean

[Delphi]
function SlopeAtPoint(
   const X: Double;
   const Y: Double;
   const SlopeMode: SlopeModeConstants;
   out Slope: Double;
   const WeightMode: TrnNodeWeightModeConstants
): WordBool

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо вычислить уклон
Y
[in] Координата Y точки плоскости, в которой необходимо вычислить уклон
SlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле
Slope
[out] Вычисленный уклон
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников

Возвращаемое значение

Возвращает True, если в указанной точке уклон вычислен

Смотри также

Class CADTriangulation, Enum SlopeModeConstants, Enum TrnNodeWeightModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.SurfaceDifference (метод)

Вычислить поверхность, полученную вычитанием другой поверхности из исходной

Синтаксис

[Visual Basic 6]
Function SurfaceDifference ( _
   ByVal LevelingTriangulation As Triangulation, _
   [ByVal RegionOfInterest As ShapePolygon = 0] _
) As Triangulation

[Delphi]
function SurfaceDifference(
   const LevelingTriangulation: Triangulation;
   const RegionOfInterest: ShapePolygon
): Triangulation

Описание параметров

LevelingTriangulation
[in] Вторая (выравнивающая) триангуляция
RegionOfInterest
[in] Регион, внутри которого нужно расчитать разность или Nothing, если нужно считать везде

Возвращаемое значение

Возвращает новую поверхность, являющуюся разностью исходной и второй заданной триангуляции

Смотри также

Class CADTriangulation, Class ShapePolygon, Class Triangulation, Group Поверхности, Group Триангуляция


CADTriangulation.SurfaceEarthVolume (метод)

Расчёт объёма земляных работ при выравнивании всей видимой части триангуляции до другой триангуляции. Возвращает также регион, внутри которого выполнены измерения.

Синтаксис

[Visual Basic 6]
Sub SurfaceEarthVolume ( _
   ByVal LevelingTriangulation As Triangulation, _
   ByVal RegionOfInterest As ShapePolygon, _
   BelowVolume As Double, _
   BelowSquare As Double, _
   AboveVolume As Double, _
   AboveSquare As Double, _
   RegionTotal As ShapePolygon, _
   RegionBelow As ShapePolygon, _
   RegionAbove As ShapePolygon _
)

[Delphi]
procedure SurfaceEarthVolume(
   const LevelingTriangulation: Triangulation;
   const RegionOfInterest: ShapePolygon;
   out BelowVolume: Double;
   out BelowSquare: Double;
   out AboveVolume: Double;
   out AboveSquare: Double;
   out RegionTotal: ShapePolygon;
   out RegionBelow: ShapePolygon;
   out RegionAbove: ShapePolygon
)

Описание параметров

LevelingTriangulation
[in] Вторая (выравнивающая) триангуляция
RegionOfInterest
[in] Регион, внутри которого нужно расчитать разность или Nothing, если нужно считать везде
BelowVolume
[out] Вычисленный объём ниже выравнивающей триангуляции
BelowSquare
[out] Вычисленная площадь территории, в пределах которой поверхность ниже выравнивающей триангуляции
AboveVolume
[out] Вычисленный объём выше выравнивающей триангуляции
AboveSquare
[out] Вычисленная площадь территории, в пределах которой поверхность выше выравнивающей триангуляции
RegionTotal
[out] Возвращает регион, в пределах которого произведены вычисления
RegionBelow
[out] Возвращает регион, в пределах которого вторая триангуляция ниже исходной
RegionAbove
[out] Возвращает регион, в пределах которого вторая триангуляция выше исходной

Смотри также

Class CADTriangulation, Class ShapePolygon, Class Triangulation, Group Поверхности, Group Триангуляция


CADTriangulation.Thicken (метод)

Выполнить сгущение триангуляции до заданной точности представления поверхности или до максимального числа узлов триангуляции

Синтаксис

[Visual Basic 6]
Function Thicken ( _
   ByVal HeightPrecision As Double, _
   ByVal MinRibLength As Double, _
   [ByVal MaxNodeCount As Long = 100000], _
   [ByVal MaxIterations As Long = 10], _
   [ByVal WeightMode As TrnNodeWeightModeConstants = 0], _
   [ByVal Tension As Double = 1] _
) As Point3D

[Delphi]
function Thicken(
   const HeightPrecision: Double;
   const MinRibLength: Double;
   const MaxNodeCount: Integer;
   const MaxIterations: Integer;
   const WeightMode: TrnNodeWeightModeConstants;
   const Tension: Double
): Point3D

Описание параметров

HeightPrecision
[in] Величина отклонения новых треугольников от старых, когда дальнейшее дробление треугольников на части не имеет смысла
MinRibLength
[in] Минимальная длина ребёр, которые будут разбиваться на части
MaxNodeCount
[in] Максимально допустимое количество узлов в триангуляции
MaxIterations
[in] Максиальное количество итераций
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников
Tension
[in] Степень натяжения сплайна, используемого для интерполяции

Возвращаемое значение

Возвращает трёхмерный вектор нормали к указанному узлу

Смотри также

Class CADTriangulation, Class Point3D, Enum TrnNodeWeightModeConstants, Group Поверхности, Group Триангуляция


CADTriangulation.TrnToBreakLines (метод)

Преобразовать текущую структуру триангуляции в структурные линии

Синтаксис

[Visual Basic 6]
Sub TrnToBreakLines ( _
   [ByVal VisibleOnly As Boolean = False] _
)

[Delphi]
procedure TrnToBreakLines(
   const VisibleOnly: WordBool
)

Описание параметров

VisibleOnly
[in] Если True, то преобразовывать только видимую часть триангуляции

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.TrnToSources (метод)

Преобразовать текущую структуру триангуляции в исходные точки, структурные линии и регионы

Синтаксис

[Visual Basic 6]
Sub TrnToSources

[Delphi]
procedure TrnToSources

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.ValidateLevels (метод)

Отсортировать список уровней и удалить лишние уровни (которые выше или ниже всей триангуляции)

Синтаксис

[Visual Basic 6]
Sub ValidateLevels ( _
   ByVal Levels As DoubleCollection, _
   [ByVal MinMaxCheck As Boolean = True] _
)

[Delphi]
procedure ValidateLevels(
   const Levels: DoubleCollection;
   const MinMaxCheck: WordBool
)

Описание параметров

Levels
[in] Коллекция DoubleCollection уровней
MinMaxCheck
[in] Следует ли проверять уровни на выход за минимальный и максимальный уровень высот, имеющийся сейчас в триангуляции

Смотри также

Class CADTriangulation, Class DoubleCollection, Group Поверхности, Group Триангуляция


CADTriangulation.Verify (метод)

Проверить структуру триангуляции - для отладки

Синтаксис

[Visual Basic 6]
Sub Verify

[Delphi]
procedure Verify

Смотри также

Class CADTriangulation, Group Поверхности, Group Триангуляция


CADTriangulation.ZeroEarthVolumes (метод)

Расчёт объёмов земляных работ при выравнивании всей видимой триангуляции до уровня ZeroLevel, причём объёмы вычисляются отдельно для каждого интервала уровней высот. Всегда в массив интервалов заносится ZeroLevel. Размер выходного массива на 1 > входного.

Синтаксис

[Visual Basic 6]
Sub ZeroEarthVolumes ( _
   ByVal ZeroLevel As Double, _
   ByVal Levels As DoubleCollection, _
   Volumes As DoubleCollection, _
   Squares As DoubleCollection, _
   [ByVal CoveringVolumeType As VolumeTypeConstants = 0], _
   [ByVal ClippingVolumeType As VolumeTypeConstants = 0] _
)

[Delphi]
procedure ZeroEarthVolumes(
   const ZeroLevel: Double;
   const Levels: DoubleCollection;
   var Volumes: DoubleCollection;
   var Squares: DoubleCollection;
   const CoveringVolumeType: VolumeTypeConstants;
   const ClippingVolumeType: VolumeTypeConstants
)

Описание параметров

ZeroLevel
[in] Эталонный (нулевой) уровень выравнивания
Levels
[in] Уровни, по которым нужно отдельно расчитать объёмы работ. При этом по выходу из этой процедуры в этом аргументе будут лежать отсортированный список уровней (включая ZeroLevel) без дубликатов, реально использованный в расчётах
Volumes
[in, out] Вычисленные объёмы по каждому промежутку между значениями Levels
Squares
[in, out] Вычисленные площади по каждому промежутку между значениями Levels
CoveringVolumeType
[in] Интерпретация объёмов засыпки задается в параметрах CoveringVolumeType
ClippingVolumeType
[in] Интерпретация объёмов срезки задается в параметрах ClippingVolumeType

Смотри также

Class CADTriangulation, Class DoubleCollection, Enum VolumeTypeConstants, Group Поверхности, Group Триангуляция


Класс CalcField

Параметры вычисляемого поля

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property DataType | Тип данных
Property Expression | Выражение для вычисления значения поля
Property FieldName | Имя поля
Property FieldSize | Размер строкового поля

Методы класса

Имя | Описание
Method EditProperties | Редактирование свойств

Где используется

Класс | Член класса
Class CalcFields | Property Fields (свойство) Method Add (метод)

Смотри также

Enum FieldConstants, Group Базы данных


CalcField.DataType (свойство)

Тип данных

Синтаксис

[Visual Basic 6]
Property DataType As FieldConstants

[Delphi]
property DataType: FieldConstants

Смотри также

Class CalcField, Enum FieldConstants, Group Базы данных


CalcField.Expression (свойство)

Выражение для вычисления значения поля

Синтаксис

[Visual Basic 6]
Property Expression As String

[Delphi]
property Expression: WideString

Смотри также

Class CalcField, Group Базы данных


CalcField.FieldName (свойство)

Имя поля

Синтаксис

[Visual Basic 6]
Property FieldName As String

[Delphi]
property FieldName: WideString

Смотри также

Class CalcField, Group Базы данных


CalcField.FieldSize (свойство)

Размер строкового поля

Синтаксис

[Visual Basic 6]
Property FieldSize As Long

[Delphi]
property FieldSize: Integer

Смотри также

Class CalcField, Group Базы данных


CalcField.EditProperties (метод)

Редактирование свойств

Синтаксис

[Visual Basic 6]
Function EditProperties As Boolean

[Delphi]
function EditProperties: WordBool

Возвращаемое значение

Возвращает True, если параметры вычисляемого поля были изменены

Смотри также

Class CalcField, Group Базы данных


Класс CalcFields

Список вычисляемых полей

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество вычисляемых полей
Property Fields (только для чтения) | Массив вычисляемых полей

Методы класса

Имя | Описание
Method Add | Добавить вычисляемое поле
Method Clear | Очистить список полей
Method Delete | Удалить вычисляемое поле

Где используется

Класс | Член класса
Class BrowserItems | Property CalcFields (свойство)

Смотри также

Class CalcField, Group Базы данных


CalcFields.Count (свойство)

Количество вычисляемых полей

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class CalcFields, Group Базы данных


CalcFields.Fields (свойство)

Массив вычисляемых полей

Синтаксис

[Visual Basic 6]
ReadOnly Property Fields As CalcField

[Delphi]
{только для чтения} property Fields: CalcField

Смотри также

Class CalcField, Class CalcFields, Group Базы данных


CalcFields.Add (метод)

Добавить вычисляемое поле

Синтаксис

[Visual Basic 6]
Function Add As CalcField

[Delphi]
function Add: CalcField

Возвращаемое значение

Возвращает новое вычисляемое поле

Смотри также

Class CalcField, Class CalcFields, Group Базы данных


CalcFields.Clear (метод)

Очистить список полей

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class CalcFields, Group Базы данных


CalcFields.Delete (метод)

Удалить вычисляемое поле

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемого вычисляемого поля (нумерация идёт от 0 до Count-1)

Смотри также

Class CalcFields, Group Базы данных


Класс Calculator

Объект для вычисления выражений

Наследование

Calculator Class LayerCalculator

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Calculator

ClassID = {6003000B-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property ErrorMessage (только для чтения) | Соощение об ошибке
Property ErrorPosition (только для чтения) | Позиция, где найдена ошибка
Property Expression | Выражение, подлежащее вычислению
Property ResultKind (только для чтения) | Тип результата
Property Value (только для чтения) | Результат в виде варианта

Методы класса

Имя | Описание
Method Calculate | Вычисляет выражение
Method SyntaxCheck | Проверка синтаксиса входной строки

Смотри также

Enum CalculatorResultConstants, Group Приложение


Calculator.ErrorMessage (свойство)

Соощение об ошибке

Синтаксис

[Visual Basic 6]
ReadOnly Property ErrorMessage As String

[Delphi]
{только для чтения} property ErrorMessage: WideString

Смотри также

Class Calculator, Group Приложение


Calculator.ErrorPosition (свойство)

Позиция, где найдена ошибка

Синтаксис

[Visual Basic 6]
ReadOnly Property ErrorPosition As Long

[Delphi]
{только для чтения} property ErrorPosition: Integer

Смотри также

Class Calculator, Group Приложение


Calculator.Expression (свойство)

Выражение, подлежащее вычислению

Синтаксис

[Visual Basic 6]
Property Expression As String

[Delphi]
property Expression: WideString

Смотри также

Class Calculator, Group Приложение


Calculator.ResultKind (свойство)

Тип результата

Синтаксис

[Visual Basic 6]
ReadOnly Property ResultKind As CalculatorResultConstants

[Delphi]
{только для чтения} property ResultKind: CalculatorResultConstants

Смотри также

Class Calculator, Enum CalculatorResultConstants, Group Приложение


Calculator.Value (свойство)

Результат в виде варианта

Синтаксис

[Visual Basic 6]
ReadOnly Property Value

[Delphi]
{только для чтения} property Value

Смотри также

Class Calculator, Group Приложение


Calculator.Calculate (метод)

Вычисляет выражение

Синтаксис

[Visual Basic 6]
Sub Calculate

[Delphi]
procedure Calculate

Смотри также

Class Calculator, Group Приложение


Calculator.SyntaxCheck (метод)

Проверка синтаксиса входной строки

Синтаксис

[Visual Basic 6]
Function SyntaxCheck As Boolean

[Delphi]
function SyntaxCheck: WordBool

Возвращаемое значение

Возвращает True, если синтаксис верен

Смотри также

Class Calculator, Group Приложение


Класс ClipRegion

Полигональный регион отсечения видимой области отображения

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ClipRegion

ClassID = {60040023-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property DialogTitle | Заголовок диалога ввода региона
Property Region | Регион как полигон шейп-файла

Методы класса

Имя | Описание
Method Clear | Очистить регион
Method CopyFromRegion | Скопировать из другого региона
Method IntersectClipRgn | Применить как зону отсечения канваса, возвращает старый регион
Method RestoreClipRgn | Восстановить старый регион, всегда применяется после IntersectClipRgn

Где используется

Класс | Член класса
Class AssemblyLayerState | Property ClipRegion (свойство)
Class ClipRegion | Method CopyFromRegion (метод)
Class CompositionLayer | Property ClipRegion (свойство)
Class FolderLayer | Property ClipRegion (свойство)
Class VectorLayer | Property ClipRegion (свойство)

Смотри также

Class CoordinateTransformator, Class ShapePolygon, Group Контейнеры изображений


ClipRegion.DialogTitle (свойство)

Заголовок диалога ввода региона

Синтаксис

[Visual Basic 6]
Property DialogTitle As String

[Delphi]
property DialogTitle: WideString

Смотри также

Class ClipRegion, Group Контейнеры изображений


ClipRegion.Region (свойство)

Регион как полигон шейп-файла

Синтаксис

[Visual Basic 6]
Property Region As ShapePolygon

[Delphi]
property Region: ShapePolygon

Смотри также

Class ClipRegion, Class ShapePolygon, Group Контейнеры изображений


ClipRegion.Clear (метод)

Очистить регион

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class ClipRegion, Group Контейнеры изображений


ClipRegion.CopyFromRegion (метод)

Скопировать из другого региона

Синтаксис

[Visual Basic 6]
Sub CopyFromRegion ( _
   ByVal SourceRegion As ClipRegion _
)

[Delphi]
procedure CopyFromRegion(
   const SourceRegion: ClipRegion
)

Описание параметров

SourceRegion
[in] Исходный регион, из которого будет выполнено копирование параметров отсечения

Смотри также

Class ClipRegion, Group Контейнеры изображений


ClipRegion.IntersectClipRgn (метод)

Применить как зону отсечения канваса, возвращает старый регион

Синтаксис

[Visual Basic 6]
Function IntersectClipRgn ( _
   ByVal HDC As OLE_HANDLE, _
   ByVal Transformator As CoordinateTransformator _
) As Long

[Delphi]
function IntersectClipRgn(
   const HDC: OLE_HANDLE;
   const Transformator: CoordinateTransformator
): Integer

Описание параметров

HDC
[in] HDC устройства вывода
Transformator
[in] Текущий преобразователь координат

Возвращаемое значение

Возвращает старый регион, который в дальнейшем нужно обязательно передать в метод RestoreClipRgn

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ClipRegion, Class CoordinateTransformator, Group Контейнеры изображений


ClipRegion.RestoreClipRgn (метод)

Восстановить старый регион, всегда применяется после IntersectClipRgn

Синтаксис

[Visual Basic 6]
Sub RestoreClipRgn ( _
   ByVal HDC As OLE_HANDLE, _
   ByVal OldRegion As Long _
)

[Delphi]
procedure RestoreClipRgn(
   const HDC: OLE_HANDLE;
   const OldRegion: Integer
)

Описание параметров

HDC
[in] HDC устройства вывода
OldRegion
[in] Старый регион отсечения, возвращённый функцией IntersectClipRgn

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ClipRegion, Group Контейнеры изображений


Класс Collection

Коллекция объектов

Наследование

CustomCollection Class Collection

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Collection

ClassID = {60020006-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество объектов списке
Property Items | Массив элементов списка

Методы класса

Имя | Описание
Method Add | Добавить новый элемент в коллекцию
Method AddItems | Добавить несколько новых элементов в коллекцию
Method Clear | Удаляет все элементы из коллекции
Method Delete | Удаляет элемент из коллекции
Method Invert | Меняет порядок элементов в коллекции на обратный

Где используется

Класс | Член класса
Class CADTriangulation | Method AddModifier (метод) Method AddPolygon (метод) Method AddPolyline (метод) Method BuildIsoexpos (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод) Method BuildVisibilities (метод) Method CustomBuild (метод) Method CutByPolygons (метод) Method ExtractPolygons (метод) Method ExtractTriangles (метод) Method ExtractVoronoi (метод) Method FindTriangles (метод) Method GetObjectsAtPoint (метод) Method GetObjectsAtRect (метод) Method IncrementalAddBoundary (метод) Method PolygonsSquare (метод)
Class Triangulation | Method AddModifier (метод) Method AddPolygon (метод) Method AddPolyline (метод) Method BuildIsoexpos (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод) Method BuildVisibilities (метод) Method CustomBuild (метод) Method CutByPolygons (метод) Method ExtractPolygons (метод) Method ExtractTriangles (метод) Method ExtractVoronoi (метод) Method FindTriangles (метод) Method GetObjectsAtPoint (метод) Method GetObjectsAtRect (метод) Method IncrementalAddBoundary (метод) Method PolygonsSquare (метод)
Class TrnNode | Method FindNodes (метод) Method FindRibs (метод) Method FindTriangles (метод)
Class TrnTools | Method BuildAccesibilyAreas (метод) Method BuildVoronoiAreas (метод) Method MakeBufferAreas (метод) Method MergePolygons (метод) Method SplitStripPicket (метод)
Class VectorContainer | Method FlashFigures (метод)
Class VectorLayer | Method GetAllFigures (метод) Method GetDefIdFigures (метод) Method GetFiguresAtPolygon (метод) Method GetFiguresAtPolyline (метод) Method GetFiguresAtPos (метод) Method GetFiguresAtRect (метод) Method GetSelectedFigures (метод) Method SelectFigures (метод)

Смотри также

Group Хранилища объектов


Collection.Count (свойство)

Количество объектов списке

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class Collection, Group Хранилища объектов


Collection.Items (свойство)

Массив элементов списка

Синтаксис

[Visual Basic 6]
Property Items As Object

[Delphi]
property Items: IDispatch

Смотри также

Class Collection, Group Хранилища объектов


Collection.Add (метод)

Добавить новый элемент в коллекцию

Синтаксис

[Visual Basic 6]
Sub Add ( _
   ByVal Object As Object _
)

[Delphi]
procedure Add(
   const Object: IDispatch
)

Описание параметров

Object
[in] Добавляемый в коллекцию элемент

Смотри также

Class Collection, Group Хранилища объектов


Collection.AddItems (метод)

Добавить несколько новых элементов в коллекцию

Синтаксис

[Visual Basic 6]
Sub AddItems ( _
   ParamArray Objects() As Variant _
)

[Delphi]
procedure AddItems(
   const Objects: PSafeArray
)

Описание параметров

Objects
[in] Добавляемые в коллекцию элементы

Смотри также

Class Collection, Group Хранилища объектов


Collection.Clear (метод)

Удаляет все элементы из коллекции

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class Collection, Group Хранилища объектов


Collection.Delete (метод)

Удаляет элемент из коллекции

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер элемента в коллекции

Смотри также

Class Collection, Group Хранилища объектов


Collection.Invert (метод)

Меняет порядок элементов в коллекции на обратный

Синтаксис

[Visual Basic 6]
Sub Invert

[Delphi]
procedure Invert

Смотри также

Class Collection, Group Хранилища объектов


Класс Composition

Композиция

Наследование

Composition Class LayeredComposition

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Author | Автор композиции
Property BackColor | Цвет фона композиции
Property BookmarkCount (только для чтения) | Количество закладок на композиции
Property Bookmarks (только для чтения) | Массив закладок композиции
Property Caption | Название композиции
Property Company | Учреждение, где выполнена работа
Property ContainerCount (только для чтения) | Количество контейнеров, отображающих данную композицию
Property Containers (только для чтения) | Массив контейнеров, отображающих данную композицию
Property Depository (только для чтения) | Хранилище переменных
Property Description | Описание композиции
Property DistanceUnit | Единицы измерения расстояний
Property FileName (только для чтения) | Имя файла с композицией
Property MainContainer (только для чтения) | Главный контейнер, отображающий карту
Property MaxScale | Максимальный доступный MaxDevScale контейнера при отрисовке
Property MinScale | Минимальный доступный MapDevScale контейнера при отрисовке
Property ModelUnit | Исходные единицы модели
Property Modified | Признак модификации композиции
Property RootPath (только для чтения) | Возвращает путь, относительно которого должны сохраняться параметры композиции и её слоёв
Property ShowScrollBars | Показывать ли полосы скроллинга в главном контейнере
Property SquareUnit | Единицы измерения площадей на композиции
Property StandardScaleCount (только для чтения) | Количество стандартных масштабов композиции
Property StandardScales (только для чтения) | Массив стандартных масштабов композиции
Property SystemAxes | Ориентация осей координат (по умолчанию SystemAxesXright_Yup)
Property SystemAxesRotation | Поворот системы координат
Property ValidCaption (только для чтения) | Название композиции (если Caption не задано, то используется имя файла)

Методы класса

Имя | Описание
Method AddBookmark | Добавить новую закладку
Method AddStandardScale | Добавить стандартный масштаб
Method DeleteAllBookmarks | Удалить все закладки
Method DeleteBookmark | Удалить закладку
Method DeleteStandardScale | Удалить стандартный масштаб
Method GotoBookmark | Перейти по заданной закладке
Method InvalidateContainers | Перерисовать все связанные контейнеры
Method Print | Распечатать на принтере на одной странице видимую часть карты
Method PrintPages | Распечатать на принтере заданную часть карты (возможно на нескольких страницах)
Method PrintRect | Распечатать на принтере на одной странице видимую часть карты
Method RefreshContainers | Обновить изображение во всех связанных контейнерах

Где используется

Класс | Член класса
Class CustomMode | Property Composition (свойство)

Смотри также

Class ContainerBookmark, Class CustomContainer, Class Depository, Enum ModelUnitConstants, Class StandardScale, Enum SystemAxesConstants, Group Карты


Composition.Author (свойство)

Автор композиции

Синтаксис

[Visual Basic 6]
Property Author As String

[Delphi]
property Author: WideString

Смотри также

Class Composition, Group Карты


Composition.BackColor (свойство)

Цвет фона композиции

Синтаксис

[Visual Basic 6]
Property BackColor As OLE_COLOR

[Delphi]
property BackColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Composition, Group Карты


Composition.BookmarkCount (свойство)

Количество закладок на композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property BookmarkCount As Long

[Delphi]
{только для чтения} property BookmarkCount: Integer

Смотри также

Class Composition, Group Карты


Composition.Bookmarks (свойство)

Массив закладок композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property Bookmarks As ContainerBookmark

[Delphi]
{только для чтения} property Bookmarks: ContainerBookmark

Смотри также

Class Composition, Class ContainerBookmark, Group Карты


Composition.Caption (свойство)

Название композиции

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class Composition, Group Карты


Composition.Company (свойство)

Учреждение, где выполнена работа

Синтаксис

[Visual Basic 6]
Property Company As String

[Delphi]
property Company: WideString

Смотри также

Class Composition, Group Карты


Composition.ContainerCount (свойство)

Количество контейнеров, отображающих данную композицию

Синтаксис

[Visual Basic 6]
ReadOnly Property ContainerCount As Long

[Delphi]
{только для чтения} property ContainerCount: Integer

Смотри также

Class Composition, Group Карты


Composition.Containers (свойство)

Массив контейнеров, отображающих данную композицию

Синтаксис

[Visual Basic 6]
ReadOnly Property Containers As CustomContainer

[Delphi]
{только для чтения} property Containers: CustomContainer

Смотри также

Class Composition, Class CustomContainer, Group Карты


Composition.Depository (свойство)

Хранилище переменных

Синтаксис

[Visual Basic 6]
ReadOnly Property Depository As Depository

[Delphi]
{только для чтения} property Depository: Depository

Смотри также

Class Composition, Class Depository, Group Карты


Composition.Description (свойство)

Описание композиции

Синтаксис

[Visual Basic 6]
Property Description As String

[Delphi]
property Description: WideString

Смотри также

Class Composition, Group Карты


Composition.DistanceUnit (свойство)

Единицы измерения расстояний

Синтаксис

[Visual Basic 6]
Property DistanceUnit As ModelUnitConstants

[Delphi]
property DistanceUnit: ModelUnitConstants

Смотри также

Class Composition, Enum ModelUnitConstants, Group Карты


Composition.FileName (свойство)

Имя файла с композицией

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class Composition, Group Карты


Composition.MainContainer (свойство)

Главный контейнер, отображающий карту

Синтаксис

[Visual Basic 6]
ReadOnly Property MainContainer As CustomContainer

[Delphi]
{только для чтения} property MainContainer: CustomContainer

Смотри также

Class Composition, Class CustomContainer, Group Карты


Composition.MaxScale (свойство)

Максимальный доступный MaxDevScale контейнера при отрисовке

Синтаксис

[Visual Basic 6]
Property MaxScale As Double

[Delphi]
property MaxScale: Double

Смотри также

Class Composition, Group Карты


Composition.MinScale (свойство)

Минимальный доступный MapDevScale контейнера при отрисовке

Синтаксис

[Visual Basic 6]
Property MinScale As Double

[Delphi]
property MinScale: Double

Смотри также

Class Composition, Group Карты


Composition.ModelUnit (свойство)

Исходные единицы модели

Синтаксис

[Visual Basic 6]
Property ModelUnit As ModelUnitConstants

[Delphi]
property ModelUnit: ModelUnitConstants

Смотри также

Class Composition, Enum ModelUnitConstants, Group Карты


Composition.Modified (свойство)

Признак модификации композиции

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class Composition, Group Карты


Composition.RootPath (свойство)

Возвращает путь, относительно которого должны сохраняться параметры композиции и её слоёв

Синтаксис

[Visual Basic 6]
ReadOnly Property RootPath As String

[Delphi]
{только для чтения} property RootPath: WideString

Смотри также

Class Composition, Group Карты


Composition.ShowScrollBars (свойство)

Показывать ли полосы скроллинга в главном контейнере

Синтаксис

[Visual Basic 6]
Property ShowScrollBars As Boolean

[Delphi]
property ShowScrollBars: WordBool

Смотри также

Class Composition, Group Карты


Composition.SquareUnit (свойство)

Единицы измерения площадей на композиции

Синтаксис

[Visual Basic 6]
Property SquareUnit As ModelUnitConstants

[Delphi]
property SquareUnit: ModelUnitConstants

Смотри также

Class Composition, Enum ModelUnitConstants, Group Карты


Composition.StandardScaleCount (свойство)

Количество стандартных масштабов композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property StandardScaleCount As Long

[Delphi]
{только для чтения} property StandardScaleCount: Integer

Смотри также

Class Composition, Group Карты


Composition.StandardScales (свойство)

Массив стандартных масштабов композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property StandardScales As StandardScale

[Delphi]
{только для чтения} property StandardScales: StandardScale

Смотри также

Class Composition, Class StandardScale, Group Карты


Composition.SystemAxes (свойство)

Ориентация осей координат (по умолчанию SystemAxesXright_Yup)

Синтаксис

[Visual Basic 6]
Property SystemAxes As SystemAxesConstants

[Delphi]
property SystemAxes: SystemAxesConstants

Смотри также

Class Composition, Enum SystemAxesConstants, Group Карты


Composition.SystemAxesRotation (свойство)

Поворот системы координат

Синтаксис

[Visual Basic 6]
Property SystemAxesRotation As Double

[Delphi]
property SystemAxesRotation: Double

Смотри также

Class Composition, Group Карты


Composition.ValidCaption (свойство)

Название композиции (если Caption не задано, то используется имя файла)

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidCaption As String

[Delphi]
{только для чтения} property ValidCaption: WideString

Смотри также

Class Composition, Group Карты


Composition.AddBookmark (метод)

Добавить новую закладку

Синтаксис

[Visual Basic 6]
Function AddBookmark ( _
   ByVal Container As CustomContainer _
) As ContainerBookmark

[Delphi]
function AddBookmark(
   const Container: CustomContainer
): ContainerBookmark

Описание параметров

Container
[in] Контейнер, из которого необходимо запомнить текущую видимую область

Возвращаемое значение

Возвращает новую закладку

Смотри также

Class Composition, Class ContainerBookmark, Class CustomContainer, Group Карты


Composition.AddStandardScale (метод)

Добавить стандартный масштаб

Синтаксис

[Visual Basic 6]
Function AddStandardScale As StandardScale

[Delphi]
function AddStandardScale: StandardScale

Возвращаемое значение

Новый стандартный масштаб

Смотри также

Class Composition, Class StandardScale, Group Карты


Composition.DeleteAllBookmarks (метод)

Удалить все закладки

Синтаксис

[Visual Basic 6]
Sub DeleteAllBookmarks

[Delphi]
procedure DeleteAllBookmarks

Смотри также

Class Composition, Group Карты


Composition.DeleteBookmark (метод)

Удалить закладку

Синтаксис

[Visual Basic 6]
Sub DeleteBookmark ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteBookmark(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемой закладки (нумерация идёт от 0 до BookmarkCount-1)

Смотри также

Class Composition, Group Карты


Composition.DeleteStandardScale (метод)

Удалить стандартный масштаб

Синтаксис

[Visual Basic 6]
Sub DeleteStandardScale ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteStandardScale(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемого стандартного масштаба композиции (нумерация идёт от 0 до StandardScaleCount-1)

Смотри также

Class Composition, Group Карты


Composition.GotoBookmark (метод)

Перейти по заданной закладке

Синтаксис

[Visual Basic 6]
Sub GotoBookmark ( _
   ByVal Container As CustomContainer, _
   ByVal Index As Long _
)

[Delphi]
procedure GotoBookmark(
   const Container: CustomContainer;
   const Index: Integer
)

Описание параметров

Container
[in] Контейнер, в котором нужно выполнить переход
Index
[in] Номер закладки, по которой необходимо выполнить переход

Смотри также

Class Composition, Class CustomContainer, Group Карты


Composition.InvalidateContainers (метод)

Перерисовать все связанные контейнеры

Синтаксис

[Visual Basic 6]
Sub InvalidateContainers

[Delphi]
procedure InvalidateContainers

Смотри также

Class Composition, Group Карты


Composition.Print (метод)

Распечатать на принтере на одной странице видимую часть карты

Синтаксис

[Visual Basic 6]
Sub Print ( _
   ByVal ATitle As String _
)

[Delphi]
procedure Print(
   const ATitle: WideString
)

Описание параметров

ATitle
[in] Заголовок задания для печати

Смотри также

Class Composition, Group Карты


Composition.PrintPages (метод)

Распечатать на принтере заданную часть карты (возможно на нескольких страницах)

Синтаксис

[Visual Basic 6]
Sub PrintPages ( _
   ByVal ATitle As String, _
   ByVal FlatXmin As Double, _
   ByVal FlatXmax As Double, _
   ByVal FlatYmin As Double, _
   ByVal FlatYmax As Double, _
   ByVal ViewScale As Double _
)

[Delphi]
procedure PrintPages(
   const ATitle: WideString;
   const FlatXmin: Double;
   const FlatXmax: Double;
   const FlatYmin: Double;
   const FlatYmax: Double;
   const ViewScale: Double
)

Описание параметров

ATitle
[in] Заголовок задания для печати
FlatXmin
[in] Левая граница области печати в плоской системе координат
FlatXmax
[in] Правая граница области печати в плоской системе координат
FlatYmin
[in] Нижняя граница области печати в плоской системе координат
FlatYmax
[in] Верхняя граница области печати в плоской системе координат
ViewScale
[in] Масштаб изображения при печати

Смотри также

Class Composition, Group Карты


Composition.PrintRect (метод)

Распечатать на принтере на одной странице видимую часть карты

Синтаксис

[Visual Basic 6]
Sub PrintRect ( _
   ByVal ATitle As String, _
   ByVal FlatXmin As Double, _
   ByVal FlatXmax As Double, _
   ByVal FlatYmin As Double, _
   ByVal FlatYmax As Double _
)

[Delphi]
procedure PrintRect(
   const ATitle: WideString;
   const FlatXmin: Double;
   const FlatXmax: Double;
   const FlatYmin: Double;
   const FlatYmax: Double
)

Описание параметров

ATitle
[in] Заголовок задания для печати
FlatXmin
[in] Левая граница области печати в плоской системе координат
FlatXmax
[in] Правая граница области печати в плоской системе координат
FlatYmin
[in] Нижняя граница области печати в плоской системе координат
FlatYmax
[in] Верхняя граница области печати в плоской системе координат

Смотри также

Class Composition, Group Карты


Composition.RefreshContainers (метод)

Обновить изображение во всех связанных контейнерах

Синтаксис

[Visual Basic 6]
Sub RefreshContainers

[Delphi]
procedure RefreshContainers

Смотри также

Class Composition, Group Карты


Класс CompositionLayer

Слой композиции

Наследование

CompositionLayer Class FolderLayer, VectorLayer

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Caption | Подпись слоя
Property ClipRegion (только для чтения) | Зона отсечения изображения слоя
Property FileLocked | Файл с данными слоя заблокирован для записи
Property FileName (только для чтения) | Имя файла слоя
Property FullExtent (только для чтения) | Полный размер слоя
Property Index (только для чтения) | Номер в списке родителя
Property IndividualProjection | Слой имеет индивидуальную проекцию
Property Kind (только для чтения) | Тип слоя
Property LegendOpen | Легенда развёрнута
Property MaxDrawScale | Максимальный масштаб отрисовки
Property MinDrawScale | Минимальный масштаб отрисовки
Property Modified | Изменён ли слой
Property Parent (только для чтения) | Папка, которой принадлежит слой
Property Projected | Проектировать ли слой?
Property Projection | Индивидуальная проекция слоя
Property ScaleCheck | Отрисовка в зависимости от масштаба
Property Selected (только для чтения) | Выделен ли слой в легенде
Property SeqID (только для чтения) | Уникальный идентификатор слоя на карте
Property Tag | Можно использовать по своему усмотрению
Property Transparency | Значение прозрачности, с которой надо отображать слой (0 - непрозрачен, 255 - полностью прозрачен)
Property UsedTransparency (только для чтения) | Прозрачность, реально используемая при отрисовке слоя, с учетом прозрачности родительских папок (0 - непрозрачен, 255 - полностью прозрачен)
Property ValidProjected (только для чтения) | Реально проектировать ли слой
Property ValidProjection (только для чтения) | Реально используемая проекция слоя
Property VerbCount (только для чтения) | Количество доступных элементов локального меню
Property Verbs (только для чтения) | Массив пунктов локального меню слоя
Property Visible | Видим ли слой на карте
Property VisibleState (только для чтения) | Состояние отметки видимости слоя

Методы класса

Имя | Описание
Method CanProjected | Можно ли отобразить сейчас слой в проекции
Method CanShow | Проверить, будет ли отображён слой на карте с учётом текущего масштаба
Method EditProperties | Редактирование свойств слоя
Method EditRenderer | Редактирование свойств отрисовки слоя
Method ExecuteVerb | Выполнить заданный пункт локального меню
Method GetDescriptionAtPos | Получение краткой информации в заданной точке
Method Save | Сохранить содержимое слоя
Method SupportsProjection | Поддерживается ли слоем отображение в проекции

Где используется

Класс | Член класса
Class AssemblyLayerState | Method Apply (метод) Method Remember (метод) Method WillChange (метод)
Class FolderLayer | Property Layers (свойство)
Class LayeredComposition | Method AddLayer (метод) Method AddNewLayer (метод) Method LayerByName (метод) Method LayerBySeqID (метод)
Class VectorContainer | Property CurrentLayer (свойство)
Class VectorLayer | Property SnapLayers (свойство) Method AddSnapLayer (метод)

Смотри также

Enum CheckBoxConstants, Class ClipRegion, Enum CompositionLayerConstants, Class CustomContainer, Class MenuVerb, Class ModelPoint, Class ModelRect, Class Projection, Group Карты


CompositionLayer.Caption (свойство)

Подпись слоя

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.ClipRegion (свойство)

Зона отсечения изображения слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property ClipRegion As ClipRegion

[Delphi]
{только для чтения} property ClipRegion: ClipRegion

Смотри также

Class ClipRegion, Class CompositionLayer, Group Карты


CompositionLayer.FileLocked (свойство)

Файл с данными слоя заблокирован для записи

Синтаксис

[Visual Basic 6]
Property FileLocked As Boolean

[Delphi]
property FileLocked: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.FileName (свойство)

Имя файла слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.FullExtent (свойство)

Полный размер слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property FullExtent As ModelRect

[Delphi]
{только для чтения} property FullExtent: ModelRect

Смотри также

Class CompositionLayer, Class ModelRect, Group Карты


CompositionLayer.Index (свойство)

Номер в списке родителя

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.IndividualProjection (свойство)

Слой имеет индивидуальную проекцию

Синтаксис

[Visual Basic 6]
Property IndividualProjection As Boolean

[Delphi]
property IndividualProjection: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.Kind (свойство)

Тип слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Kind As CompositionLayerConstants

[Delphi]
{только для чтения} property Kind: CompositionLayerConstants

Смотри также

Class CompositionLayer, Enum CompositionLayerConstants, Group Карты


CompositionLayer.LegendOpen (свойство)

Легенда развёрнута

Синтаксис

[Visual Basic 6]
Property LegendOpen As Boolean

[Delphi]
property LegendOpen: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.MaxDrawScale (свойство)

Максимальный масштаб отрисовки

Синтаксис

[Visual Basic 6]
Property MaxDrawScale As Double

[Delphi]
property MaxDrawScale: Double

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.MinDrawScale (свойство)

Минимальный масштаб отрисовки

Синтаксис

[Visual Basic 6]
Property MinDrawScale As Double

[Delphi]
property MinDrawScale: Double

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.Modified (свойство)

Изменён ли слой

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.Parent (свойство)

Папка, которой принадлежит слой

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As FolderLayer

[Delphi]
{только для чтения} property Parent: FolderLayer

Смотри также

Class CompositionLayer, Class FolderLayer, Group Карты


CompositionLayer.Projected (свойство)

Проектировать ли слой?

Синтаксис

[Visual Basic 6]
Property Projected As Boolean

[Delphi]
property Projected: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.Projection (свойство)

Индивидуальная проекция слоя

Синтаксис

[Visual Basic 6]
Property Projection As Projection

[Delphi]
property Projection: Projection

Смотри также

Class CompositionLayer, Class Projection, Group Карты


CompositionLayer.ScaleCheck (свойство)

Отрисовка в зависимости от масштаба

Синтаксис

[Visual Basic 6]
Property ScaleCheck As Boolean

[Delphi]
property ScaleCheck: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.Selected (свойство)

Выделен ли слой в легенде

Синтаксис

[Visual Basic 6]
ReadOnly Property Selected As Boolean

[Delphi]
{только для чтения} property Selected: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.SeqID (свойство)

Уникальный идентификатор слоя на карте

Синтаксис

[Visual Basic 6]
ReadOnly Property SeqID As Long

[Delphi]
{только для чтения} property SeqID: Integer

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.Tag (свойство)

Можно использовать по своему усмотрению

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.Transparency (свойство)

Значение прозрачности, с которой надо отображать слой (0 - непрозрачен, 255 - полностью прозрачен)

Синтаксис

[Visual Basic 6]
Property Transparency As Long

[Delphi]
property Transparency: Integer

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.UsedTransparency (свойство)

Прозрачность, реально используемая при отрисовке слоя, с учетом прозрачности родительских папок (0 - непрозрачен, 255 - полностью прозрачен)

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedTransparency As Long

[Delphi]
{только для чтения} property UsedTransparency: Integer

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.ValidProjected (свойство)

Реально проектировать ли слой

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidProjected As Boolean

[Delphi]
{только для чтения} property ValidProjected: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.ValidProjection (свойство)

Реально используемая проекция слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidProjection As Projection

[Delphi]
{только для чтения} property ValidProjection: Projection

Смотри также

Class CompositionLayer, Class Projection, Group Карты


CompositionLayer.VerbCount (свойство)

Количество доступных элементов локального меню

Синтаксис

[Visual Basic 6]
ReadOnly Property VerbCount As Long

[Delphi]
{только для чтения} property VerbCount: Integer

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.Verbs (свойство)

Массив пунктов локального меню слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Verbs As MenuVerb

[Delphi]
{только для чтения} property Verbs: MenuVerb

Смотри также

Class CompositionLayer, Class MenuVerb, Group Карты


CompositionLayer.Visible (свойство)

Видим ли слой на карте

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.VisibleState (свойство)

Состояние отметки видимости слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property VisibleState As CheckBoxConstants

[Delphi]
{только для чтения} property VisibleState: CheckBoxConstants

Смотри также

Enum CheckBoxConstants, Class CompositionLayer, Group Карты


CompositionLayer.CanProjected (метод)

Можно ли отобразить сейчас слой в проекции

Синтаксис

[Visual Basic 6]
Function CanProjected As Boolean

[Delphi]
function CanProjected: WordBool

Возвращаемое значение

Возвращает True, если сейчас можно отобразить слой в проекции

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.CanShow (метод)

Проверить, будет ли отображён слой на карте с учётом текущего масштаба

Синтаксис

[Visual Basic 6]
Function CanShow ( _
   ByVal Container As CustomContainer _
) As Boolean

[Delphi]
function CanShow(
   const Container: CustomContainer
): WordBool

Описание параметров

Container
[in] Контейнер, в котором отображается текущий слой

Возвращаемое значение

Возвращает True, если отображение возможно

Смотри также

Class CompositionLayer, Class CustomContainer, Group Карты


CompositionLayer.EditProperties (метод)

Редактирование свойств слоя

Синтаксис

[Visual Basic 6]
Sub EditProperties

[Delphi]
procedure EditProperties

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.EditRenderer (метод)

Редактирование свойств отрисовки слоя

Синтаксис

[Visual Basic 6]
Sub EditRenderer

[Delphi]
procedure EditRenderer

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.ExecuteVerb (метод)

Выполнить заданный пункт локального меню

Синтаксис

[Visual Basic 6]
Sub ExecuteVerb ( _
   ByVal Index As Long _
)

[Delphi]
procedure ExecuteVerb(
   const Index: Integer
)

Описание параметров

Index
[in] Номер выполняемого пункта локального меню слоя (нумерация идёт от 0 до VerbCount-1)

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.GetDescriptionAtPos (метод)

Получение краткой информации в заданной точке

Синтаксис

[Visual Basic 6]
Function GetDescriptionAtPos ( _
   ByVal Pos As ModelPoint, _
   ByVal Delta As Double _
) As String

[Delphi]
function GetDescriptionAtPos(
   const Pos: ModelPoint;
   const Delta: Double
): WideString

Описание параметров

Pos
[in] Точка на карте в модельной системе координат, для которой требуется получить краткю информацию
Delta
[in] Максимальное допустимое отклонение при поиске объектов, для которых выдается краткая информация

Возвращаемое значение

Возвращает текст краткой информации или пустую строку

Смотри также

Class CompositionLayer, Class ModelPoint, Group Карты


CompositionLayer.Save (метод)

Сохранить содержимое слоя

Синтаксис

[Visual Basic 6]
Sub Save

[Delphi]
procedure Save

Смотри также

Class CompositionLayer, Group Карты


CompositionLayer.SupportsProjection (метод)

Поддерживается ли слоем отображение в проекции

Синтаксис

[Visual Basic 6]
Function SupportsProjection As Boolean

[Delphi]
function SupportsProjection: WordBool

Возвращаемое значение

Возвращает True, если отображение в проекции поддерживается слоем

Смотри также

Class CompositionLayer, Group Карты


Класс ContainerBookmark

Закладка в контейнере

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Key | Номер горячей клавиши от 0 до 9 или -1, если таковой нет
Property Name | Имя закладки
Property ScaleXY | Запомненное соотношение масштабов изображения по осям X и Y (допустимы значения от 1E-5 до 1E5)
Property ViewCenter | Запомненный центр изображения
Property ViewScale | Запомненный масштаб изображения (допустимы значения от 1E-33 до 1E33)

Где используется

Класс | Член класса
Class Composition | Property Bookmarks (свойство) Method AddBookmark (метод)
Class LayeredComposition | Property Bookmarks (свойство) Method AddBookmark (метод)

Смотри также

Class ModelPoint, Group Контейнеры изображений


ContainerBookmark.Key (свойство)

Номер горячей клавиши от 0 до 9 или -1, если таковой нет

Синтаксис

[Visual Basic 6]
Property Key As Long

[Delphi]
property Key: Integer

Смотри также

Class ContainerBookmark, Group Контейнеры изображений


ContainerBookmark.Name (свойство)

Имя закладки

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class ContainerBookmark, Group Контейнеры изображений


ContainerBookmark.ScaleXY (свойство)

Запомненное соотношение масштабов изображения по осям X и Y (допустимы значения от 1E-5 до 1E5)

Синтаксис

[Visual Basic 6]
Property ScaleXY As Double

[Delphi]
property ScaleXY: Double

Смотри также

Class ContainerBookmark, Group Контейнеры изображений


ContainerBookmark.ViewCenter (свойство)

Запомненный центр изображения

Синтаксис

[Visual Basic 6]
Property ViewCenter As ModelPoint

[Delphi]
property ViewCenter: ModelPoint

Смотри также

Class ContainerBookmark, Class ModelPoint, Group Контейнеры изображений


ContainerBookmark.ViewScale (свойство)

Запомненный масштаб изображения (допустимы значения от 1E-33 до 1E33)

Синтаксис

[Visual Basic 6]
Property ViewScale As Double

[Delphi]
property ViewScale: Double

Смотри также

Class ContainerBookmark, Group Контейнеры изображений


Класс ContainerModeHandler

Обработчик режима работы контейнера

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Handler (только для чтения) | Обработчик событий режима (определён только для нестандартных режимов)
Property IdString (только для чтения) | Строковый идентификатор обработчика режима
Property SubModeGroup (только для чтения) | Группа текущего подрежима
Property SubModeGroupNumber (только для чтения) | Количество групп подрежимов
Property SubModeIndex (только для чтения) | Номер текущего подрежима в группе

Методы класса

Имя | Описание
Method DrawSubModeExample | Рисование примера типа элемента в заданном месте и размера
Method GetModeDefinition | Получить описание режима
Method GetSubModeDefinition | Получить описание элемента меню в подрежиме группы
Method GetSubModeGroupDefinition | Получить описание группы подрежимов в меню
Method HasSubModes | Проверить, определены ли подрежимы
Method IsActive | Проверить, включен ли сейчас данный режим
Method IsSubModeOwnerDraw | Проверить, будет ли выполняться специальная отрисовка иконок режимов, не используя ImageIndex

Где используется

Класс | Член класса
Class CustomContainer | Property ActiveMode (свойство) Property RegisteredModes (свойство) Method RegisterMode (метод) Method SelectActiveMode (метод)
Class VectorContainer | Property ActiveMode (свойство) Property RegisteredModes (свойство) Method RegisterMode (метод) Method SelectActiveMode (метод)

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


ContainerModeHandler.Handler (свойство)

Обработчик событий режима (определён только для нестандартных режимов)

Синтаксис

[Visual Basic 6]
ReadOnly Property Handler As IContainerModeEvents

[Delphi]
{только для чтения} property Handler: IContainerModeEvents

Смотри также

Class ContainerModeHandler, Interface IContainerModeEvents, Group Контейнеры изображений


ContainerModeHandler.IdString (свойство)

Строковый идентификатор обработчика режима

Синтаксис

[Visual Basic 6]
ReadOnly Property IdString As String

[Delphi]
{только для чтения} property IdString: WideString

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.SubModeGroup (свойство)

Группа текущего подрежима

Синтаксис

[Visual Basic 6]
ReadOnly Property SubModeGroup As Long

[Delphi]
{только для чтения} property SubModeGroup: Integer

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.SubModeGroupNumber (свойство)

Количество групп подрежимов

Синтаксис

[Visual Basic 6]
ReadOnly Property SubModeGroupNumber As Long

[Delphi]
{только для чтения} property SubModeGroupNumber: Integer

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.SubModeIndex (свойство)

Номер текущего подрежима в группе

Синтаксис

[Visual Basic 6]
ReadOnly Property SubModeIndex As Long

[Delphi]
{только для чтения} property SubModeIndex: Integer

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.DrawSubModeExample (метод)

Рисование примера типа элемента в заданном месте и размера

Синтаксис

[Visual Basic 6]
Sub DrawSubModeExample ( _
   ByVal SubModeGroup As Long, _
   ByVal SubModeIndex As Long, _
   ByVal HDC As OLE_HANDLE, _
   ByVal Left As Long, _
   ByVal Top As Long, _
   ByVal Right As Long, _
   ByVal Bottom As Long _
)

[Delphi]
procedure DrawSubModeExample(
   const SubModeGroup: Integer;
   const SubModeIndex: Integer;
   const HDC: OLE_HANDLE;
   const Left: Integer;
   const Top: Integer;
   const Right: Integer;
   const Bottom: Integer
)

Описание параметров

SubModeGroup
[in] Номер группы подрежима
SubModeIndex
[in] Номер подрежима внутри группы
HDC
[in] HDC устройства вывода
Left
[in] Левая сторона области рисования примера
Top
[in] Верхняя сторона области рисования примера
Right
[in] Правая сторона области рисования примера
Bottom
[in] Нижняя сторона области рисования примера

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.GetModeDefinition (метод)

Получить описание режима

Синтаксис

[Visual Basic 6]
Sub GetModeDefinition ( _
   Caption As String, _
   Description As String, _
   Hint As String, _
   ImageIndex As Long, _
   Enabled As Boolean, _
   ShortCut As Long _
)

[Delphi]
procedure GetModeDefinition(
   out Caption: WideString;
   out Description: WideString;
   out Hint: WideString;
   out ImageIndex: Integer;
   out Enabled: WordBool;
   out ShortCut: Integer
)

Описание параметров

Caption
[out] Название для элемента меню
Description
[out] Описание режима, показываемое в строке статуса
Hint
[out] Всплывающая подсказка
ImageIndex
[out] Код иконки из набора картинок приложения
Enabled
[out] Разрешен ли в настоящее время режим
ShortCut
[out] Горячая клавиша для выбора режима

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.GetSubModeDefinition (метод)

Получить описание элемента меню в подрежиме группы

Синтаксис

[Visual Basic 6]
Sub GetSubModeDefinition ( _
   ByVal SubModeGroup As Long, _
   ByVal SubModeIndex As Long, _
   Caption As String, _
   ImageIndex As Long, _
   Enabled As Boolean, _
   ShortCut As Long _
)

[Delphi]
procedure GetSubModeDefinition(
   const SubModeGroup: Integer;
   const SubModeIndex: Integer;
   out Caption: WideString;
   out ImageIndex: Integer;
   out Enabled: WordBool;
   out ShortCut: Integer
)

Описание параметров

SubModeGroup
[in] Номер группы подрежима
SubModeIndex
[in] Номер подрежима внутри группы
Caption
[out] Название, отображаемое в меню
ImageIndex
[out] Код иконки из набора картинок приложения
Enabled
[out] Разрешен ли в настоящее время подрежим
ShortCut
[out] Горячая клавиша для выбора подрежима

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.GetSubModeGroupDefinition (метод)

Получить описание группы подрежимов в меню

Синтаксис

[Visual Basic 6]
Sub GetSubModeGroupDefinition ( _
   ByVal SubModeGroup As Long, _
   GroupName As String, _
   ItemNumber As Long, _
   ImageIndex As Long _
)

[Delphi]
procedure GetSubModeGroupDefinition(
   const SubModeGroup: Integer;
   out GroupName: WideString;
   out ItemNumber: Integer;
   out ImageIndex: Integer
)

Описание параметров

SubModeGroup
[in] Номер группы подрежима
GroupName
[out] Название группы
ItemNumber
[out] Количество подрежимов в группе
ImageIndex
[out] Код иконки из набора картинок приложения

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.HasSubModes (метод)

Проверить, определены ли подрежимы

Синтаксис

[Visual Basic 6]
Function HasSubModes As Boolean

[Delphi]
function HasSubModes: WordBool

Возвращаемое значение

Возвращает True, если указанный режим имеет подрежимы

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.IsActive (метод)

Проверить, включен ли сейчас данный режим

Синтаксис

[Visual Basic 6]
Function IsActive As Boolean

[Delphi]
function IsActive: WordBool

Возвращаемое значение

Возвращает True, если данный режим в настоящее время включен в контейнере

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


ContainerModeHandler.IsSubModeOwnerDraw (метод)

Проверить, будет ли выполняться специальная отрисовка иконок режимов, не используя ImageIndex

Синтаксис

[Visual Basic 6]
Function IsSubModeOwnerDraw As Boolean

[Delphi]
function IsSubModeOwnerDraw: WordBool

Возвращаемое значение

Возвращает True, если будет выполняться специальная отрисовка, иначе будет отрисована стандартная картинка с номером ImageIndex из набора картинок приложения

Смотри также

Class ContainerModeHandler, Group Контейнеры изображений


Класс ContainerSurface

Поверхность для рисования в системе координат контейнера

Наследование

CustomSurface Class ContainerSurface

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ContainerSurface

ClassID = {60040018-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Canvas (только для чтения) | Получить TCanvas в режиме GDI
Property DC (только для чтения) | Получить контекст устройства в режиме GDI
Property GdiPlusMode | Работает ли поверхность в режиме GDI+ (иначе в режиме GDI)
Property Graphics (только для чтения) | Получить объект TGPGraphics в режиме GDI+

Методы класса

Имя | Описание
Method BrushSelect | Установить текущие параметры кисти
Method DrawArc | Нарисовать дугу эллипса, задав объемлющий эллипс прямоугольник и точки, определяющие начало и конец дуги
Method DrawBeziers | Нарисовать последовательность кривых Безье по точкам, переданным в массиве вещественных чисел
Method DrawBeziersPtr | Нарисовать последовательность кривых Безье по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawEllipse | Нарисовать эллипс без заливки
Method DrawLine | Нарисовать отрезок прямой
Method DrawPolygon | Нарисовать полигон по точкам, переданным в массиве вещественных чисел
Method DrawPolygonPtr | Нарисовать полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawPolyline | Нарисовать полилинию по точкам, переданным в массиве вещественных чисел
Method DrawPolylinePtr | Нарисовать полилинию по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawRectangle | Нарисовать прямоугольник без заливки
Method DrawText | Нарисовать текстовую надпись
Method FillEllipse | Нарисовать закрашенный эллипс
Method FillPolygon | Закрасить полигон по точкам, переданным в массиве вещественных чисел
Method FillPolygonPtr | Закрасить полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method FillRectangle | Нарисовать закрашенный прямоугольник
Method FontSelect | Установить текущие параметры шрифта
Method NeedSurfacePoints | Получить временный кусок памяти с вещественными точками. Внимание! Метод небезопасный и может быть использовать только при внутрипроцессной активации COM-сервера
Method PenSelect | Установить текущие параметры пера
Method PointModelToSurface | Преобразовать точку из системы координат модели в целочисленную систему координат устройства вывода
Method PointsModelToSurface | Преобразовать точки из системы координат модели в целочисленную систему координат устройства вывода. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Где используется

Класс | Член класса
Class CustomContainer | Property ContentDeviceSurface (свойство) Property ContentModelSurface (свойство) Property MemoryDeviceSurface (свойство) Property MemoryModelSurface (свойство) Property ScreenDeviceSurface (свойство) Property ScreenModelSurface (свойство)
Class VectorContainer | Property ContentDeviceSurface (свойство) Property ContentModelSurface (свойство) Property MemoryDeviceSurface (свойство) Property MemoryModelSurface (свойство) Property ScreenDeviceSurface (свойство) Property ScreenModelSurface (свойство)

Смотри также

Enum BrushStyleConstants, Enum FontStyleConstants, Enum PenStyleConstants, Group Контейнеры изображений


ContainerSurface.Canvas (свойство)

Получить TCanvas в режиме GDI

Синтаксис

[Visual Basic 6]
ReadOnly Property Canvas As OLE_HANDLE

[Delphi]
{только для чтения} property Canvas: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DC (свойство)

Получить контекст устройства в режиме GDI

Синтаксис

[Visual Basic 6]
ReadOnly Property DC As OLE_HANDLE

[Delphi]
{только для чтения} property DC: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.GdiPlusMode (свойство)

Работает ли поверхность в режиме GDI+ (иначе в режиме GDI)

Синтаксис

[Visual Basic 6]
Property GdiPlusMode As Boolean

[Delphi]
property GdiPlusMode: WordBool

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.Graphics (свойство)

Получить объект TGPGraphics в режиме GDI+

Синтаксис

[Visual Basic 6]
ReadOnly Property Graphics As OLE_HANDLE

[Delphi]
{только для чтения} property Graphics: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.BrushSelect (метод)

Установить текущие параметры кисти

Синтаксис

[Visual Basic 6]
Sub BrushSelect ( _
   ByVal Color As OLE_COLOR, _
   ByVal BrushStyle As BrushStyleConstants _
)

[Delphi]
procedure BrushSelect(
   const Color: OLE_COLOR;
   const BrushStyle: BrushStyleConstants
)

Описание параметров

Color
[in] Цвет кисти
BrushStyle
[in] Стиль заливки

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Enum BrushStyleConstants, Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawArc (метод)

Нарисовать дугу эллипса, задав объемлющий эллипс прямоугольник и точки, определяющие начало и конец дуги

Синтаксис

[Visual Basic 6]
Sub DrawArc ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double, _
   ByVal StartX As Double, _
   ByVal StartY As Double, _
   ByVal EndX As Double, _
   ByVal EndY As Double _
)

[Delphi]
procedure DrawArc(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double;
   const StartX: Double;
   const StartY: Double;
   const EndX: Double;
   const EndY: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника
StartX
[in] Координата X точки, определяющей начало дуги
StartY
[in] Координата Y точки, определяющей начало дуги
EndX
[in] Координата X точки, определяющей конец дуги
EndY
[in] Координата Y точки, определяющей конец дуги

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawBeziers (метод)

Нарисовать последовательность кривых Безье по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawBeziers ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawBeziers(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты контрольных точек последовательности кривых Безье

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawBeziersPtr (метод)

Нарисовать последовательность кривых Безье по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawBeziersPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawBeziersPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив контрольных точек в модельной системе координат
PointNumber
[in] Общее число котрольных точек поледовательности линий Безье

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawEllipse (метод)

Нарисовать эллипс без заливки

Синтаксис

[Visual Basic 6]
Sub DrawEllipse ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure DrawEllipse(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X прямоугольника
Ymin
[in] Минимальная координата по Y прямоугольника
Xmax
[in] Максимальная координата по X прямоугольника
Ymax
[in] Максимальная координата по Y прямоугольника

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawLine (метод)

Нарисовать отрезок прямой

Синтаксис

[Visual Basic 6]
Sub DrawLine ( _
   ByVal X1 As Double, _
   ByVal Y1 As Double, _
   ByVal X2 As Double, _
   ByVal Y2 As Double _
)

[Delphi]
procedure DrawLine(
   const X1: Double;
   const Y1: Double;
   const X2: Double;
   const Y2: Double
)

Описание параметров

X1
[in] Координата X начальной точки отрезка
Y1
[in] Координата Y начальной точки отрезка
X2
[in] Координата X конечной точки отрезка
Y2
[in] Координата Y конечной точки отрезка

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawPolygon (метод)

Нарисовать полигон по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawPolygon ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawPolygon(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полигона

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawPolygonPtr (метод)

Нарисовать полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawPolygonPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawPolygonPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полигоне

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawPolyline (метод)

Нарисовать полилинию по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawPolyline ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawPolyline(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полилинии

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawPolylinePtr (метод)

Нарисовать полилинию по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawPolylinePtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawPolylinePtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полилинии

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawRectangle (метод)

Нарисовать прямоугольник без заливки

Синтаксис

[Visual Basic 6]
Sub DrawRectangle ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure DrawRectangle(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X прямоугольника
Ymin
[in] Минимальная координата по Y прямоугольника
Xmax
[in] Максимальная координата по X прямоугольника
Ymax
[in] Максимальная координата по Y прямоугольника

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.DrawText (метод)

Нарисовать текстовую надпись

Синтаксис

[Visual Basic 6]
Sub DrawText ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Text As String _
)

[Delphi]
procedure DrawText(
   const X: Double;
   const Y: Double;
   const Text: WideString
)

Описание параметров

X
[in] Координата X левого верхнего угла надписи
Y
[in] Координата Y левого верхнего угла надписи
Text
[in] Текст надписи

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.FillEllipse (метод)

Нарисовать закрашенный эллипс

Синтаксис

[Visual Basic 6]
Sub FillEllipse ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure FillEllipse(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.FillPolygon (метод)

Закрасить полигон по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub FillPolygon ( _
   ByVal Points() As Double _
)

[Delphi]
procedure FillPolygon(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полигона

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.FillPolygonPtr (метод)

Закрасить полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub FillPolygonPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure FillPolygonPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полигоне

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.FillRectangle (метод)

Нарисовать закрашенный прямоугольник

Синтаксис

[Visual Basic 6]
Sub FillRectangle ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure FillRectangle(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.FontSelect (метод)

Установить текущие параметры шрифта

Синтаксис

[Visual Basic 6]
Sub FontSelect ( _
   ByVal FontName As String, _
   ByVal Size As Double, _
   ByVal FontStyles As FontStyleConstants _
)

[Delphi]
procedure FontSelect(
   const FontName: WideString;
   const Size: Double;
   const FontStyles: FontStyleConstants
)

Описание параметров

FontName
[in] Имя шрифта
Size
[in] Размер шрифта
FontStyles
[in] Набор флагов, задающих стиль шрифта (любая комбинация жирности, наклона, подчеркивания и зачеркивания)

Смотри также

Class ContainerSurface, Enum FontStyleConstants, Group Контейнеры изображений


ContainerSurface.NeedSurfacePoints (метод)

Получить временный кусок памяти с вещественными точками. Внимание! Метод небезопасный и может быть использовать только при внутрипроцессной активации COM-сервера

Синтаксис

[Visual Basic 6]
Function NeedSurfacePoints ( _
   ByVal PointNumber As Long _
) As Long

[Delphi]
function NeedSurfacePoints(
   const PointNumber: Integer
): Integer

Описание параметров

PointNumber
[in] Требуемое число вещественных точек в выделенной области памяти

Возвращаемое значение

Возвращает указатель на кусок памяти с вещественными точками

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.PenSelect (метод)

Установить текущие параметры пера

Синтаксис

[Visual Basic 6]
Sub PenSelect ( _
   ByVal Color As OLE_COLOR, _
   ByVal Width As Double, _
   ByVal PenStyle As PenStyleConstants _
)

[Delphi]
procedure PenSelect(
   const Color: OLE_COLOR;
   const Width: Double;
   const PenStyle: PenStyleConstants
)

Описание параметров

Color
[in] Цвет пера
Width
[in] Ширина пера
PenStyle
[in] Стиль пера

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ContainerSurface, Enum PenStyleConstants, Group Контейнеры изображений


ContainerSurface.PointModelToSurface (метод)

Преобразовать точку из системы координат модели в целочисленную систему координат устройства вывода

Синтаксис

[Visual Basic 6]
Sub PointModelToSurface ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   SurfaceX As Long, _
   SurfaceY As Long _
)

[Delphi]
procedure PointModelToSurface(
   const ModelX: Double;
   const ModelY: Double;
   out SurfaceX: Integer;
   out SurfaceY: Integer
)

Описание параметров

ModelX
[in] Исходная координата X в модельной системе координат
ModelY
[in] Исходная координата Y в модельной системе координат
SurfaceX
[out] Расчитанная координата X в системе координат поверхности
SurfaceY
[out] Расчитанная координата Y в системе координат поверхности

Смотри также

Class ContainerSurface, Group Контейнеры изображений


ContainerSurface.PointsModelToSurface (метод)

Преобразовать точки из системы координат модели в целочисленную систему координат устройства вывода. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub PointsModelToSurface ( _
   ByVal ModelPoints As Double, _
   ByVal SurfacePoints As Long, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure PointsModelToSurface(
   const ModelPoints: Double;
   const SurfacePoints: Integer;
   const PointNumber: Integer
)

Описание параметров

ModelPoints
[in] Массив исходных точек в модельной системе координат
SurfacePoints
[in] Массив расчитанных точек в системе координат поверхности
PointNumber
[in] Общее число точек

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ContainerSurface, Group Контейнеры изображений


Класс CoordinateTransformator

Преобразователь координат для вывода данных на устройство

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.CoordinateTransformator

ClassID = {6003000D-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property DeltaDevicePixels (только для чтения) | Допустимая точность позиционирования мышки в системе координат устройства вывода
Property DeltaFlatPixels (только для чтения) | Допустимая точность позиционирования мышки в плоских координатах
Property DeltaModelPixels (только для чтения) | Допустимая точность позиционирования мышки в модельных координатах
Property DeviceOrigin (только для чтения) | Координаты левого верхнего угла окна вывода (соответствует ViewOrigin)
Property DeviceRect (только для чтения) | Прямоугольник на устройстве, в который производится вывод информации
Property FlatUnit (только для чтения) | Единицы измерения плоских координат
Property IsAffine (только для чтения) | Проверить, является ли выполняемое преобразование афинным (прямые преобразуются в прямые)
Property IsMirror (только для чтения) | Проверить, отражается ли зеркально изображение, т.е. меняется порядок обхода любых точек от "по часовой стрелке" на "против"
Property Printing (только для чтения) | Выставляется в True, когда идёт отрисовка изображения для печати, для экспорта изображения или в иных случаях, когда не нужно отображать служебные слои изображения (например, направляющие и непечатаемые слои)
Property SizeFactor (только для чтения) | Дополнительный масштабный коэффициент для утолщения линий и увеличения немасштабируемых символов
Property ViewOrigin (только для чтения) | Координаты верхнего окна карты, выводимого на экран
Property ViewRect (только для чтения) | Модельные координаты прямоугольника вывода (вычисляется по ViewOrigin и DeviceRect). Используется для поиска объектов, подлежащих отображению
Property ViewScale (только для чтения) | Масштаб вывода: отношение длины на карте к устройству

Методы класса

Имя | Описание
Method DistanceDeviceToModel | Преобразовать расстояние из СКУ в СКК
Method DistanceModelToDevice | Преобразовать расстояние из СКК в СКУ
Method FlatRectToModelParallelogram | Преобразовать прямоугольник из плоской системы координат в модельный параллелограмм
Method PointDeviceToFlat | Преобразовать точку из экранных целочисленных координат в модельные координаты
Method PointDeviceToModel | Преобразовать точку из экранных целочисленных координат в модельные координаты
Method PointFlatToDevice | Преобразовать точку из модельных координат в экранные целочисленные координаты
Method PointFlatToModel | Преобразовать точку из плоских координат в модельные координаты
Method PointFlatToSurface | Преобразовать точку из модельных координат в экранные вещественные координаты
Method PointModelToDevice | Преобразовать точку из модельных координат в экранные целочисленные координаты
Method PointModelToFlat | Преобразовать точку из модельных координат в плоские координаты
Method PointModelToSurface | Преобразовать точку из модельных координат в экранные вещественные координаты
Method PointSurfaceToFlat | Преобразовать точку из экранные вещественных координат в модельные координаты
Method PointSurfaceToModel | Преобразовать точку из экранные вещественных координат в модельные координаты
Method RectDeviceToFlat | Преобразовать прямоугольник из экранных целочисленных координат в модельные координаты
Method RectFlatToDevice | Преобразовать прямоугольник из модельных координат в экранные целочисленные координаты
Method RectFlatToSurface | Преобразовать прямоугольник из модельных координат в экранные вещественные координаты
Method RectSurfaceToFlat | Преобразовать прямоугольник из экранные вещественных координат в модельные координаты
Method RotationModelToDevice | Преобразовать угол поворота из системы координат модели в систему координат устройства
Method SimpleRectFlatToModel | Преобразовать прямоугольник из ПКУ в СКК (просто преобразуются точек углов прямоугольника и получение минимального объемлющего прямоугольника)
Method SimpleRectModelToFlat | Преобразовать прямоугольник из СКК в ПСК (просто преобразуются точек углов прямоугольника и получение минимального объемлющего прямоугольника)

Где используется

Класс | Член класса
Class ClipRegion | Method IntersectClipRgn (метод)

Смотри также

Class ModelParallelogram, Class ModelPoint, Class ModelRect, Enum ModelUnitConstants, Class Point, Class Rect, Group Карты


CoordinateTransformator.DeltaDevicePixels (свойство)

Допустимая точность позиционирования мышки в системе координат устройства вывода

Синтаксис

[Visual Basic 6]
ReadOnly Property DeltaDevicePixels As Double

[Delphi]
{только для чтения} property DeltaDevicePixels: Double

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.DeltaFlatPixels (свойство)

Допустимая точность позиционирования мышки в плоских координатах

Синтаксис

[Visual Basic 6]
ReadOnly Property DeltaFlatPixels As Double

[Delphi]
{только для чтения} property DeltaFlatPixels: Double

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.DeltaModelPixels (свойство)

Допустимая точность позиционирования мышки в модельных координатах

Синтаксис

[Visual Basic 6]
ReadOnly Property DeltaModelPixels As Double

[Delphi]
{только для чтения} property DeltaModelPixels: Double

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.DeviceOrigin (свойство)

Координаты левого верхнего угла окна вывода (соответствует ViewOrigin)

Синтаксис

[Visual Basic 6]
ReadOnly Property DeviceOrigin As Point

[Delphi]
{только для чтения} property DeviceOrigin: Point

Смотри также

Class CoordinateTransformator, Class Point, Group Карты


CoordinateTransformator.DeviceRect (свойство)

Прямоугольник на устройстве, в который производится вывод информации

Синтаксис

[Visual Basic 6]
ReadOnly Property DeviceRect As Rect

[Delphi]
{только для чтения} property DeviceRect: Rect

Смотри также

Class CoordinateTransformator, Class Rect, Group Карты


CoordinateTransformator.FlatUnit (свойство)

Единицы измерения плоских координат

Синтаксис

[Visual Basic 6]
ReadOnly Property FlatUnit As ModelUnitConstants

[Delphi]
{только для чтения} property FlatUnit: ModelUnitConstants

Смотри также

Class CoordinateTransformator, Enum ModelUnitConstants, Group Карты


CoordinateTransformator.IsAffine (свойство)

Проверить, является ли выполняемое преобразование афинным (прямые преобразуются в прямые)

Синтаксис

[Visual Basic 6]
ReadOnly Property IsAffine As Boolean

[Delphi]
{только для чтения} property IsAffine: WordBool

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.IsMirror (свойство)

Проверить, отражается ли зеркально изображение, т.е. меняется порядок обхода любых точек от "по часовой стрелке" на "против"

Синтаксис

[Visual Basic 6]
ReadOnly Property IsMirror As Boolean

[Delphi]
{только для чтения} property IsMirror: WordBool

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.Printing (свойство)

Выставляется в True, когда идёт отрисовка изображения для печати, для экспорта изображения или в иных случаях, когда не нужно отображать служебные слои изображения (например, направляющие и непечатаемые слои)

Синтаксис

[Visual Basic 6]
ReadOnly Property Printing As Boolean

[Delphi]
{только для чтения} property Printing: WordBool

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.SizeFactor (свойство)

Дополнительный масштабный коэффициент для утолщения линий и увеличения немасштабируемых символов

Синтаксис

[Visual Basic 6]
ReadOnly Property SizeFactor As Double

[Delphi]
{только для чтения} property SizeFactor: Double

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.ViewOrigin (свойство)

Координаты верхнего окна карты, выводимого на экран

Синтаксис

[Visual Basic 6]
ReadOnly Property ViewOrigin As ModelPoint

[Delphi]
{только для чтения} property ViewOrigin: ModelPoint

Смотри также

Class CoordinateTransformator, Class ModelPoint, Group Карты


CoordinateTransformator.ViewRect (свойство)

Модельные координаты прямоугольника вывода (вычисляется по ViewOrigin и DeviceRect). Используется для поиска объектов, подлежащих отображению

Синтаксис

[Visual Basic 6]
ReadOnly Property ViewRect As ModelRect

[Delphi]
{только для чтения} property ViewRect: ModelRect

Смотри также

Class CoordinateTransformator, Class ModelRect, Group Карты


CoordinateTransformator.ViewScale (свойство)

Масштаб вывода: отношение длины на карте к устройству

Синтаксис

[Visual Basic 6]
ReadOnly Property ViewScale As Double

[Delphi]
{только для чтения} property ViewScale: Double

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.DistanceDeviceToModel (метод)

Преобразовать расстояние из СКУ в СКК

Синтаксис

[Visual Basic 6]
Function DistanceDeviceToModel ( _
   ByVal Distance As Double _
) As Double

[Delphi]
function DistanceDeviceToModel(
   const Distance: Double
): Double

Описание параметров

Distance
[in] Расстояние в плоской системе координат

Возвращаемое значение

Возвращает расстояние в модельной системе координат.

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.DistanceModelToDevice (метод)

Преобразовать расстояние из СКК в СКУ

Синтаксис

[Visual Basic 6]
Function DistanceModelToDevice ( _
   ByVal Distance As Double _
) As Double

[Delphi]
function DistanceModelToDevice(
   const Distance: Double
): Double

Описание параметров

Distance
[in] Расстояние в модельной системе координат

Возвращаемое значение

Возвращает расстояние плоской в системе координат.

Смотри также

Class CoordinateTransformator, Group Карты


CoordinateTransformator.FlatRectToModelParallelogram (метод)

Преобразовать прямоугольник из плоской системы координат в модельный параллелограмм

Синтаксис

[Visual Basic 6]
Function FlatRectToModelParallelogram ( _
   ByVal FlatRect As ModelRect _
) As ModelParallelogram

[Delphi]
function FlatRectToModelParallelogram(
   const FlatRect: ModelRect
): ModelParallelogram

Описание параметров

FlatRect
[in] Координаты прямоугольника в плоской системе координат

Возвращаемое значение

Возвращает координаты параллелограмма в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelParallelogram, Class ModelRect, Group Карты


CoordinateTransformator.PointDeviceToFlat (метод)

Преобразовать точку из экранных целочисленных координат в модельные координаты

Синтаксис

[Visual Basic 6]
Function PointDeviceToFlat ( _
   ByVal DevicePoint As Point _
) As ModelPoint

[Delphi]
function PointDeviceToFlat(
   const DevicePoint: Point
): ModelPoint

Описание параметров

DevicePoint
[in] Координата точки в экранной целочисленной системе координат

Возвращаемое значение

Возвращает координаты точки в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Class Point, Group Карты


CoordinateTransformator.PointDeviceToModel (метод)

Преобразовать точку из экранных целочисленных координат в модельные координаты

Синтаксис

[Visual Basic 6]
Function PointDeviceToModel ( _
   ByVal DevicePoint As Point _
) As ModelPoint

[Delphi]
function PointDeviceToModel(
   const DevicePoint: Point
): ModelPoint

Описание параметров

DevicePoint
[in] Координата точки в экранной целочисленной системе координат

Возвращаемое значение

Возвращает координаты точки в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Class Point, Group Карты


CoordinateTransformator.PointFlatToDevice (метод)

Преобразовать точку из модельных координат в экранные целочисленные координаты

Синтаксис

[Visual Basic 6]
Function PointFlatToDevice ( _
   ByVal FlatPoint As ModelPoint _
) As Point

[Delphi]
function PointFlatToDevice(
   const FlatPoint: ModelPoint
): Point

Описание параметров

FlatPoint
[in] Координата точки в модельной системе координат

Возвращаемое значение

Возвращает координаты точки в экранной целочисленной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Class Point, Group Карты


CoordinateTransformator.PointFlatToModel (метод)

Преобразовать точку из плоских координат в модельные координаты

Синтаксис

[Visual Basic 6]
Function PointFlatToModel ( _
   ByVal FlatPoint As ModelPoint _
) As ModelPoint

[Delphi]
function PointFlatToModel(
   const FlatPoint: ModelPoint
): ModelPoint

Описание параметров

FlatPoint
[in] Координата точки в плоской системе координат

Возвращаемое значение

Возвращает координаты точки в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Group Карты


CoordinateTransformator.PointFlatToSurface (метод)

Преобразовать точку из модельных координат в экранные вещественные координаты

Синтаксис

[Visual Basic 6]
Function PointFlatToSurface ( _
   ByVal FlatPoint As ModelPoint _
) As ModelPoint

[Delphi]
function PointFlatToSurface(
   const FlatPoint: ModelPoint
): ModelPoint

Описание параметров

FlatPoint
[in] Координата точки в модельной системе координат

Возвращаемое значение

Возвращает координаты точки в экранной вещественной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Group Карты


CoordinateTransformator.PointModelToDevice (метод)

Преобразовать точку из модельных координат в экранные целочисленные координаты

Синтаксис

[Visual Basic 6]
Function PointModelToDevice ( _
   ByVal ModelPoint As ModelPoint _
) As Point

[Delphi]
function PointModelToDevice(
   const ModelPoint: ModelPoint
): Point

Описание параметров

ModelPoint
[in] Координата точки в модельной системе координат

Возвращаемое значение

Возвращает координаты точки в экранной целочисленной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Class Point, Group Карты


CoordinateTransformator.PointModelToFlat (метод)

Преобразовать точку из модельных координат в плоские координаты

Синтаксис

[Visual Basic 6]
Function PointModelToFlat ( _
   ByVal ModelPoint As ModelPoint _
) As ModelPoint

[Delphi]
function PointModelToFlat(
   const ModelPoint: ModelPoint
): ModelPoint

Описание параметров

ModelPoint
[in] Координата точки в модельной системе координат

Возвращаемое значение

Возвращает координаты точки в плоской системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Group Карты


CoordinateTransformator.PointModelToSurface (метод)

Преобразовать точку из модельных координат в экранные вещественные координаты

Синтаксис

[Visual Basic 6]
Function PointModelToSurface ( _
   ByVal ModelPoint As ModelPoint _
) As ModelPoint

[Delphi]
function PointModelToSurface(
   const ModelPoint: ModelPoint
): ModelPoint

Описание параметров

ModelPoint
[in] Координата точки в модельной системе координат

Возвращаемое значение

Возвращает координаты точки в экранной вещественной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Group Карты


CoordinateTransformator.PointSurfaceToFlat (метод)

Преобразовать точку из экранные вещественных координат в модельные координаты

Синтаксис

[Visual Basic 6]
Function PointSurfaceToFlat ( _
   ByVal SurfacePoint As ModelPoint _
) As ModelPoint

[Delphi]
function PointSurfaceToFlat(
   const SurfacePoint: ModelPoint
): ModelPoint

Описание параметров

SurfacePoint
[in] Координата точки в экранной вещественной системе координат

Возвращаемое значение

Возвращает координаты точки в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Group Карты


CoordinateTransformator.PointSurfaceToModel (метод)

Преобразовать точку из экранные вещественных координат в модельные координаты

Синтаксис

[Visual Basic 6]
Function PointSurfaceToModel ( _
   ByVal SurfacePoint As ModelPoint _
) As ModelPoint

[Delphi]
function PointSurfaceToModel(
   const SurfacePoint: ModelPoint
): ModelPoint

Описание параметров

SurfacePoint
[in] Координата точки в экранной вещественной системе координат

Возвращаемое значение

Возвращает координаты точки в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelPoint, Group Карты


CoordinateTransformator.RectDeviceToFlat (метод)

Преобразовать прямоугольник из экранных целочисленных координат в модельные координаты

Синтаксис

[Visual Basic 6]
Function RectDeviceToFlat ( _
   ByVal DeviceRect As Rect _
) As ModelRect

[Delphi]
function RectDeviceToFlat(
   const DeviceRect: Rect
): ModelRect

Описание параметров

DeviceRect
[in] Координаты прямоугольника в экранной целочисленной системе координат

Возвращаемое значение

Возвращает координаты прямоугольника в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelRect, Class Rect, Group Карты


CoordinateTransformator.RectFlatToDevice (метод)

Преобразовать прямоугольник из модельных координат в экранные целочисленные координаты

Синтаксис

[Visual Basic 6]
Function RectFlatToDevice ( _
   ByVal FlatRect As ModelRect _
) As Rect

[Delphi]
function RectFlatToDevice(
   const FlatRect: ModelRect
): Rect

Описание параметров

FlatRect
[in] Координаты прямоугольника в модельной системе координат

Возвращаемое значение

Возвращает координаты прямоугольника в экранной целочисленной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelRect, Class Rect, Group Карты


CoordinateTransformator.RectFlatToSurface (метод)

Преобразовать прямоугольник из модельных координат в экранные вещественные координаты

Синтаксис

[Visual Basic 6]
Function RectFlatToSurface ( _
   ByVal FlatRect As ModelRect _
) As ModelRect

[Delphi]
function RectFlatToSurface(
   const FlatRect: ModelRect
): ModelRect

Описание параметров

FlatRect
[in] Координаты прямоугольника в модельной системе координат

Возвращаемое значение

Возвращает координаты прямоугольника в экранной вещественной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelRect, Group Карты


CoordinateTransformator.RectSurfaceToFlat (метод)

Преобразовать прямоугольник из экранные вещественных координат в модельные координаты

Синтаксис

[Visual Basic 6]
Function RectSurfaceToFlat ( _
   ByVal SurfaceRect As ModelRect _
) As ModelRect

[Delphi]
function RectSurfaceToFlat(
   const SurfaceRect: ModelRect
): ModelRect

Описание параметров

SurfaceRect
[in] Координаты прямоугольника в экранной вещественной системе координат

Возвращаемое значение

Возвращает координаты прямоугольника в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelRect, Group Карты


CoordinateTransformator.RotationModelToDevice (метод)

Преобразовать угол поворота из системы координат модели в систему координат устройства

Синтаксис

[Visual Basic 6]
Function RotationModelToDevice ( _
   ByVal Rotation As Double, _
   [ByVal ModelPoint As ModelPoint = 0] _
) As Double

[Delphi]
function RotationModelToDevice(
   const Rotation: Double;
   const ModelPoint: ModelPoint
): Double

Описание параметров

Rotation
[in] Угол поворота в радианах
ModelPoint
[in] Точка на карте, в которой выполняется перерасчёт угла поворота

Возвращаемое значение

Возвращает угол поворота в системе координат устройства

Смотри также

Class CoordinateTransformator, Class ModelPoint, Group Карты


CoordinateTransformator.SimpleRectFlatToModel (метод)

Преобразовать прямоугольник из ПКУ в СКК (просто преобразуются точек углов прямоугольника и получение минимального объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function SimpleRectFlatToModel ( _
   ByVal FlatRect As ModelRect _
) As ModelRect

[Delphi]
function SimpleRectFlatToModel(
   const FlatRect: ModelRect
): ModelRect

Описание параметров

FlatRect
[in] Координаты прямоугольника в плоской системе координат

Возвращаемое значение

Возвращает координаты прямоугольника в модельной системе координат.

Смотри также

Class CoordinateTransformator, Class ModelRect, Group Карты


CoordinateTransformator.SimpleRectModelToFlat (метод)

Преобразовать прямоугольник из СКК в ПСК (просто преобразуются точек углов прямоугольника и получение минимального объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function SimpleRectModelToFlat ( _
   ByVal ModelRect As ModelRect _
) As ModelRect

[Delphi]
function SimpleRectModelToFlat(
   const ModelRect: ModelRect
): ModelRect

Описание параметров

ModelRect
[in] Координаты прямоугольника в модельной системе координат

Возвращаемое значение

Возвращает координаты прямоугольника в плоской системе координат.

Смотри также

Class CoordinateTransformator, Class ModelRect, Group Карты


Класс CustomCollection

Коллекция объектов, чисел или интерфейсов

Наследование

CustomCollection Class Collection, DoubleCollection, FigureCollection, IntegerCollection, InterfaceCollection, StringCollection

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество объектов списке

Методы класса

Имя | Описание
Method Clear | Удаляет все элементы из коллекции
Method Delete | Удаляет элемент из коллекции
Method Invert | Меняет порядок элементов в коллекции на обратный

Смотри также

Group Хранилища объектов


CustomCollection.Count (свойство)

Количество объектов списке

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class CustomCollection, Group Хранилища объектов


CustomCollection.Clear (метод)

Удаляет все элементы из коллекции

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class CustomCollection, Group Хранилища объектов


CustomCollection.Delete (метод)

Удаляет элемент из коллекции

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер элемента в коллекции

Смотри также

Class CustomCollection, Group Хранилища объектов


CustomCollection.Invert (метод)

Меняет порядок элементов в коллекции на обратный

Синтаксис

[Visual Basic 6]
Sub Invert

[Delphi]
procedure Invert

Смотри также

Class CustomCollection, Group Хранилища объектов


Класс CustomContainer

Контейнер изображений

Наследование

CustomContainer Class VectorContainer

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ActiveMode | Текущий обработчик режима работы с контейнером
Property BitmapDC (только для чтения) | DC текущего изображения в контейнере
Property BitmapHandle (только для чтения) | HBitmap текущего изображения в контейнере
Property BitmapHeight (только для чтения) | Высота временного изображения
Property BitmapWidth (только для чтения) | Ширина временного изображения
Property BorderStyle | Тип рамки контейнера
Property ContentDeviceSurface (только для чтения) | Поверхность для рисования в памяти
Property ContentModelSurface (только для чтения) | Поверхность для рисования в памяти
Property ForceCursor | Курсор, который должен обязательно выставляться в настоящий момент
Property GridColor | Цвет сетки (используется, если нет специальных установок в текущем слое)
Property GridSizeX | Размер сетки по X (используется, если нет специальных установок в текущем слое)
Property GridSizeY | Размер сетки по Y (используется, если нет специальных установок в текущем слое)
Property GridType | Тип сетки (используется, если нет специальных установок в текущем слое)
Property Height (только для чтения) | Высота контейнера карты на экране в пикселях
Property ImageFlatExtent (только для чтения) | Часть карты, отображаемая в памяти
Property LastViewOrg (только для чтения) | Последний левый верхний угол (=Nothing, если нет предыдущего положения)
Property LastViewScale (только для чтения) | Последний из масштабов (=0, если нет предыдущего положения)
Property MasterContainer | Главный контейнер по отношению к данному
Property MemoryDeviceSurface (только для чтения) | Поверхность для рисования на экране без мельтешения в событии BeforePaint
Property MemoryModelSurface (только для чтения) | Поверхность для рисования на экране без мельтешения в событии BeforePaint
Property MultiPointTracker | Символ, используемый для трассировки мультиточек
Property RegisteredModeCount (только для чтения) | Общее число зарегистрированных режимов работы контейнера
Property RegisteredModes (только для чтения) | Массив зарегистрированных режимов работы контейнера
Property ScreenDeviceSurface (только для чтения) | Поверхность для рисования сразу на экране
Property ScreenModelSurface (только для чтения) | Поверхность для рисования сразу на экране
Property ScrollTracking | Трэккинг скроллера изображением
Property ShowGrid | Показывать ли сетку
Property ShowScrollBars | Показывать полосы скроллинга
Property TrackStopMode | Способ остановки при трассировке полилиний, полигонов, мультиточек
Property UsedGridColor (только для чтения) | Реально используемый в настоящее время цвет сетки
Property UsedGridSizeX (только для чтения) | Реально используемый в настоящее время размер сетки по X
Property UsedGridSizeY (только для чтения) | Реально используемый в настоящее время размер сетки по Y
Property UsedGridType (только для чтения) | Реально используемый в настоящее время тип сетки
Property ViewOrigin | Плоские координаты верхнего окна карты, выводимого на экран
Property ViewScale | Масштаб вывода: отношение длины на карте к устройству
Property VisibleFlatCenter | Координаты видимого центра карты
Property VisibleFlatExtent | Часть карты, отображаемая на экране
Property Width (только для чтения) | Ширина контейнера карты на экране в пикселях
Property WindowDC (только для чтения) | DC контейнера карты
Property WindowHandle (только для чтения) | HWnd контейнера карты

Методы класса

Имя | Описание
Method CheckInView | Убедиться, что прямоугольник карты попадает в область видимости
Method DisableRefresh | Запретить перерисовку изображения
Method EnableRefresh | Разрешить перерисовку изображения
Method FlashDevicePoint | Подсвечивает миганием точку, заданную в целочисленной системе координат окна контейнера
Method FlashDevicePoints | Подсвечивает миганием массив точек, заданных в целочисленной системе координат окна контейнера
Method FlashFlatPoint | Подсвечивает миганием точку, заданную в вещественной плоской системе координат окна контейнера
Method FlashFlatPoints | Подсвечивает миганием массив точек, заданных в вещественной плоской системе координат окна контейнера
Method FlashModelPoint | Подсвечивает миганием точку, заданную в вещественной системе координат модели
Method FlashModelPoints | Подсвечивает миганием массив точек, заданных в вещественной системе координат модели
Method HighlightDevicePoint | Показывает последовательностью сужающихся концентрических окружностей точку, заданную в целочисленной системе координат окна контейнера
Method HighlightFlatPoint | Показывает последовательностью сужающихся концентрических окружностей точку, заданную в вещественной плоской системе координат окна контейнера
Method HighlightModelPoint | Подсвечивает миганием точку, заданную в вещественной системе координат модели
Method Invalidate | Обновить изображение контейнера, как только появится свободное процессорное время
Method LockRefresh | Заблокировать перерисовку изображения (после этого метода обязательно надо будет вызвать UnlockRefresh)
Method MasterPan | Панорамировать видимое изображение главного контейнера
Method MasterSelect | Выбрать видимое изображение главного контейнера
Method MouseCapture | Захват мыши
Method Pan | Панорамировать изображение с помощью руки
Method PanTo | Сдвинуть изображение в заданном направлении (LargeStep - с большим шагом)
Method PanToPoint | Немного сдвинуть изображение в направлении указанной точки. Реально данный метод вызывает метод PanTo с соответствующими параметрами
Method PrintView | Распечатать на принтере на одной странице видимую часть изображения
Method RefreshContent | Указать, что надо перерисовать изображение в памяти
Method RegisterMode | Зарегистрировать новый режим работы контейнера с указанным обработчиком событий
Method Repaint | Обновить изображение контейнера немедленно
Method RestoreLastView | Восстановить последний запомненный масштаб из списка
Method SaveCurrentView | Сохранить текущий масштаб в списке
Method SelectActiveMode | Выбрать текущий обработчик режима работы с контейнером
Method SelectActiveModeByName | Выбрать текущий обработчик режима работы с контейнером
Method Synchronize | Вызвать метод Executable.Execute в основном потоке объекта
Method TrackFixedRect | Оттрасировать прямоугольник заданного размера на карте
Method TrackFlatCircle | Оттрасировать окружность на карте в плоских координатах
Method TrackFlatEllipse | Оттрасировать эллипс на карте в плоских координатах
Method TrackFlatFillCircle | Оттрасировать залитый круг на карте в плоских координатах
Method TrackFlatFillEllipse | Оттрасировать залитый эллипс на карте в плоских координатах
Method TrackFlatFillPolygon | Оттрасировать залитый полигон на карте в плоских координатах
Method TrackFlatFillRectangle | Оттрасировать залитый прямоугольник на карте в плоских координатах
Method TrackFlatMultipoint | Оттрасировать мультиточку на карте в плоских координатах
Method TrackFlatPoint | Оттрасировать точку на карте в плоских координатах
Method TrackFlatPolygon | Оттрасировать полигон на карте в плоских координатах
Method TrackFlatPolyline | Оттрасировать полилинию на карте в плоских координатах
Method TrackFlatRectangle | Оттрасировать прямоугольник на карте в плоских координатах
Method TrackFlatSegment | Оттрасировать отрезок на карте в плоских координатах
Method TrackModelCircle | Оттрасировать окружность на карте в модельных координатах
Method TrackModelEllipse | Оттрасировать эллипс на карте в модельных координатах
Method TrackModelFillCircle | Оттрасировать залитый круг на карте в модельных координатах
Method TrackModelFillEllipse | Оттрасировать залитый эллипс на карте в модельных координатах
Method TrackModelFillPolygon | Оттрасировать залитый полигон на карте в модельных координатах
Method TrackModelFillRectangle | Оттрасировать залитый прямоугольник на карте в модельных координатах
Method TrackModelMultipoint | Оттрасировать мультиточку на карте в модельных координатах
Method TrackModelPoint | Оттрасировать точку на карте в модельных координатах
Method TrackModelPolygon | Оттрасировать полигон на карте в модельных координатах
Method TrackModelPolyline | Оттрасировать полилинию на карте в модельных координатах
Method TrackModelRectangle | Оттрасировать прямоугольник на карте в модельных координатах
Method TrackModelSegment | Оттрасировать отрезок на карте в модельных координатах
Method TrackZoomIn | Укрупнить изображение с помощью трассировки прямоугольника
Method TrackZoomOut | Уменьшить изображение с помощью трассировки прямоугольника
Method TrackZoomRect | Оттрасировать прямоугольник, пропорциональный заданным высоте и ширине
Method TrackZoomRectangle | Оттрасировать прямоугольник, пропорциональный клиентскому размеру данного контейнера
Method UnlockRefresh | Разблокировать перерисовку изображения (обязательно вызывается после LockRefresh)
Method UpdateContentAll | Полностью обновить изображение
Method UpdateCursor | Обновить курсор
Method UpdateScrollbars | Обновить содержимое скроллеров
Method ZoomInCenter | Укрупнить изображение в центре в 5/4 раза
Method ZoomOutCenter | Уменьшить изображение в центре в 5/4 раза
Method ZoomToAll | Вписать в окно всю карту
Method ZoomToExtent | Вписать в окно заданный прямоугольник. Данный метод по сути эквивалентен методу ZoomToRect, у которого задана анимация изображения
Method ZoomToPoint | Смасштабировать в заданный масштаб с точкой в центре
Method ZoomToRect | Смасштабировать в заданное окно
Method ZoomToScale | Смасштабировать относительно центра окна до заданного масштаба
Method ZoomToView | Смасштабировать в заданное окно

Где используется

Класс | Член класса
Class Composition | Property Containers (свойство) Property MainContainer (свойство) Method AddBookmark (метод) Method GotoBookmark (метод)
Class CompositionLayer | Method CanShow (метод)
Class CustomContainer | Property MasterContainer (свойство)
Class FolderLayer | Method CanShow (метод)
Class HotLink | Method Execute (метод)
Class IHotLinkHandler | Method EditProperties (метод) Method Execute (метод)
Class LayeredComposition | Property Containers (свойство) Property MainContainer (свойство) Method AddBookmark (метод) Method GotoBookmark (метод)
Class Project | Property Container (свойство)
Class VectorContainer | Property MasterContainer (свойство)
Class VectorLayer | Method CanShow (метод)

Смотри также

Enum BorderConstants, Enum ContainerGridTypeConstants, Class ContainerModeHandler, Class ContainerSurface, Enum CursorConstants, Class FlatPoint, Class FlatRect, Interface IContainerModeEvents, Interface IExecutable, Class ModelPoint, Enum PanDirectionConstants, Class Point, Class ShapeMultipoint, Class ShapePolygon, Class ShapePolyline, Enum ShapeTypeConstants, Enum TrackerConstants, Enum TrackingStopConstants, Group Контейнеры изображений


CustomContainer.ActiveMode (свойство)

Текущий обработчик режима работы с контейнером

Синтаксис

[Visual Basic 6]
Property ActiveMode As ContainerModeHandler

[Delphi]
property ActiveMode: ContainerModeHandler

Смотри также

Class ContainerModeHandler, Class CustomContainer, Group Контейнеры изображений


CustomContainer.BitmapDC (свойство)

DC текущего изображения в контейнере

Синтаксис

[Visual Basic 6]
ReadOnly Property BitmapDC As OLE_HANDLE

[Delphi]
{только для чтения} property BitmapDC: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.BitmapHandle (свойство)

HBitmap текущего изображения в контейнере

Синтаксис

[Visual Basic 6]
ReadOnly Property BitmapHandle As OLE_HANDLE

[Delphi]
{только для чтения} property BitmapHandle: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.BitmapHeight (свойство)

Высота временного изображения

Синтаксис

[Visual Basic 6]
ReadOnly Property BitmapHeight As Long

[Delphi]
{только для чтения} property BitmapHeight: Integer

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.BitmapWidth (свойство)

Ширина временного изображения

Синтаксис

[Visual Basic 6]
ReadOnly Property BitmapWidth As Long

[Delphi]
{только для чтения} property BitmapWidth: Integer

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.BorderStyle (свойство)

Тип рамки контейнера

Синтаксис

[Visual Basic 6]
Property BorderStyle As BorderConstants

[Delphi]
property BorderStyle: BorderConstants

Смотри также

Enum BorderConstants, Class CustomContainer, Group Контейнеры изображений


CustomContainer.ContentDeviceSurface (свойство)

Поверхность для рисования в памяти

Синтаксис

[Visual Basic 6]
ReadOnly Property ContentDeviceSurface As ContainerSurface

[Delphi]
{только для чтения} property ContentDeviceSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class CustomContainer, Group Контейнеры изображений


CustomContainer.ContentModelSurface (свойство)

Поверхность для рисования в памяти

Синтаксис

[Visual Basic 6]
ReadOnly Property ContentModelSurface As ContainerSurface

[Delphi]
{только для чтения} property ContentModelSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class CustomContainer, Group Контейнеры изображений


CustomContainer.ForceCursor (свойство)

Курсор, который должен обязательно выставляться в настоящий момент

Синтаксис

[Visual Basic 6]
Property ForceCursor As CursorConstants

[Delphi]
property ForceCursor: CursorConstants

Смотри также

Enum CursorConstants, Class CustomContainer, Group Контейнеры изображений


CustomContainer.GridColor (свойство)

Цвет сетки (используется, если нет специальных установок в текущем слое)

Синтаксис

[Visual Basic 6]
Property GridColor As OLE_COLOR

[Delphi]
property GridColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.GridSizeX (свойство)

Размер сетки по X (используется, если нет специальных установок в текущем слое)

Синтаксис

[Visual Basic 6]
Property GridSizeX As Double

[Delphi]
property GridSizeX: Double

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.GridSizeY (свойство)

Размер сетки по Y (используется, если нет специальных установок в текущем слое)

Синтаксис

[Visual Basic 6]
Property GridSizeY As Double

[Delphi]
property GridSizeY: Double

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.GridType (свойство)

Тип сетки (используется, если нет специальных установок в текущем слое)

Синтаксис

[Visual Basic 6]
Property GridType As ContainerGridTypeConstants

[Delphi]
property GridType: ContainerGridTypeConstants

Смотри также

Enum ContainerGridTypeConstants, Class CustomContainer, Group Контейнеры изображений


CustomContainer.Height (свойство)

Высота контейнера карты на экране в пикселях

Синтаксис

[Visual Basic 6]
ReadOnly Property Height As Long

[Delphi]
{только для чтения} property Height: Integer

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.ImageFlatExtent (свойство)

Часть карты, отображаемая в памяти

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageFlatExtent As FlatRect

[Delphi]
{только для чтения} property ImageFlatExtent: FlatRect

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.LastViewOrg (свойство)

Последний левый верхний угол (=Nothing, если нет предыдущего положения)

Синтаксис

[Visual Basic 6]
ReadOnly Property LastViewOrg As ModelPoint

[Delphi]
{только для чтения} property LastViewOrg: ModelPoint

Смотри также

Class CustomContainer, Class ModelPoint, Group Контейнеры изображений


CustomContainer.LastViewScale (свойство)

Последний из масштабов (=0, если нет предыдущего положения)

Синтаксис

[Visual Basic 6]
ReadOnly Property LastViewScale As Double

[Delphi]
{только для чтения} property LastViewScale: Double

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.MasterContainer (свойство)

Главный контейнер по отношению к данному

Синтаксис

[Visual Basic 6]
Property MasterContainer As CustomContainer

[Delphi]
property MasterContainer: CustomContainer

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.MemoryDeviceSurface (свойство)

Поверхность для рисования на экране без мельтешения в событии BeforePaint

Синтаксис

[Visual Basic 6]
ReadOnly Property MemoryDeviceSurface As ContainerSurface

[Delphi]
{только для чтения} property MemoryDeviceSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class CustomContainer, Group Контейнеры изображений


CustomContainer.MemoryModelSurface (свойство)

Поверхность для рисования на экране без мельтешения в событии BeforePaint

Синтаксис

[Visual Basic 6]
ReadOnly Property MemoryModelSurface As ContainerSurface

[Delphi]
{только для чтения} property MemoryModelSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class CustomContainer, Group Контейнеры изображений


CustomContainer.MultiPointTracker (свойство)

Символ, используемый для трассировки мультиточек

Синтаксис

[Visual Basic 6]
Property MultiPointTracker As TrackerConstants

[Delphi]
property MultiPointTracker: TrackerConstants

Смотри также

Class CustomContainer, Enum TrackerConstants, Group Контейнеры изображений


CustomContainer.RegisteredModeCount (свойство)

Общее число зарегистрированных режимов работы контейнера

Синтаксис

[Visual Basic 6]
ReadOnly Property RegisteredModeCount As Long

[Delphi]
{только для чтения} property RegisteredModeCount: Integer

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.RegisteredModes (свойство)

Массив зарегистрированных режимов работы контейнера

Синтаксис

[Visual Basic 6]
ReadOnly Property RegisteredModes As ContainerModeHandler

[Delphi]
{только для чтения} property RegisteredModes: ContainerModeHandler

Смотри также

Class ContainerModeHandler, Class CustomContainer, Group Контейнеры изображений


CustomContainer.ScreenDeviceSurface (свойство)

Поверхность для рисования сразу на экране

Синтаксис

[Visual Basic 6]
ReadOnly Property ScreenDeviceSurface As ContainerSurface

[Delphi]
{только для чтения} property ScreenDeviceSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class CustomContainer, Group Контейнеры изображений


CustomContainer.ScreenModelSurface (свойство)

Поверхность для рисования сразу на экране

Синтаксис

[Visual Basic 6]
ReadOnly Property ScreenModelSurface As ContainerSurface

[Delphi]
{только для чтения} property ScreenModelSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class CustomContainer, Group Контейнеры изображений


CustomContainer.ScrollTracking (свойство)

Трэккинг скроллера изображением

Синтаксис

[Visual Basic 6]
Property ScrollTracking As Boolean

[Delphi]
property ScrollTracking: WordBool

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.ShowGrid (свойство)

Показывать ли сетку

Синтаксис

[Visual Basic 6]
Property ShowGrid As Boolean

[Delphi]
property ShowGrid: WordBool

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.ShowScrollBars (свойство)

Показывать полосы скроллинга

Синтаксис

[Visual Basic 6]
Property ShowScrollBars As Boolean

[Delphi]
property ShowScrollBars: WordBool

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.TrackStopMode (свойство)

Способ остановки при трассировке полилиний, полигонов, мультиточек

Синтаксис

[Visual Basic 6]
Property TrackStopMode As TrackingStopConstants

[Delphi]
property TrackStopMode: TrackingStopConstants

Смотри также

Class CustomContainer, Enum TrackingStopConstants, Group Контейнеры изображений


CustomContainer.UsedGridColor (свойство)

Реально используемый в настоящее время цвет сетки

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedGridColor As OLE_COLOR

[Delphi]
{только для чтения} property UsedGridColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.UsedGridSizeX (свойство)

Реально используемый в настоящее время размер сетки по X

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedGridSizeX As Double

[Delphi]
{только для чтения} property UsedGridSizeX: Double

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.UsedGridSizeY (свойство)

Реально используемый в настоящее время размер сетки по Y

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedGridSizeY As Double

[Delphi]
{только для чтения} property UsedGridSizeY: Double

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.UsedGridType (свойство)

Реально используемый в настоящее время тип сетки

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedGridType As ContainerGridTypeConstants

[Delphi]
{только для чтения} property UsedGridType: ContainerGridTypeConstants

Смотри также

Enum ContainerGridTypeConstants, Class CustomContainer, Group Контейнеры изображений


CustomContainer.ViewOrigin (свойство)

Плоские координаты верхнего окна карты, выводимого на экран

Синтаксис

[Visual Basic 6]
Property ViewOrigin As FlatPoint

[Delphi]
property ViewOrigin: FlatPoint

Смотри также

Class CustomContainer, Class FlatPoint, Group Контейнеры изображений


CustomContainer.ViewScale (свойство)

Масштаб вывода: отношение длины на карте к устройству

Синтаксис

[Visual Basic 6]
Property ViewScale As Double

[Delphi]
property ViewScale: Double

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.VisibleFlatCenter (свойство)

Координаты видимого центра карты

Синтаксис

[Visual Basic 6]
Property VisibleFlatCenter As FlatPoint

[Delphi]
property VisibleFlatCenter: FlatPoint

Смотри также

Class CustomContainer, Class FlatPoint, Group Контейнеры изображений


CustomContainer.VisibleFlatExtent (свойство)

Часть карты, отображаемая на экране

Синтаксис

[Visual Basic 6]
Property VisibleFlatExtent As FlatRect

[Delphi]
property VisibleFlatExtent: FlatRect

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.Width (свойство)

Ширина контейнера карты на экране в пикселях

Синтаксис

[Visual Basic 6]
ReadOnly Property Width As Long

[Delphi]
{только для чтения} property Width: Integer

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.WindowDC (свойство)

DC контейнера карты

Синтаксис

[Visual Basic 6]
ReadOnly Property WindowDC As OLE_HANDLE

[Delphi]
{только для чтения} property WindowDC: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.WindowHandle (свойство)

HWnd контейнера карты

Синтаксис

[Visual Basic 6]
ReadOnly Property WindowHandle As OLE_HANDLE

[Delphi]
{только для чтения} property WindowHandle: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.CheckInView (метод)

Убедиться, что прямоугольник карты попадает в область видимости

Синтаксис

[Visual Basic 6]
Sub CheckInView ( _
   ByVal Rectangle As FlatRect, _
   [ByVal Animate As Boolean = False] _
)

[Delphi]
procedure CheckInView(
   const Rectangle: FlatRect;
   const Animate: WordBool
)

Описание параметров

Rectangle
[in] Прямоугольник, заданный в плоской системе координат контейнера
Animate
[in] Выполнять ли анимацию, если возникнет необходимость изменения видимой области изображения

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.DisableRefresh (метод)

Запретить перерисовку изображения

Синтаксис

[Visual Basic 6]
Sub DisableRefresh

[Delphi]
procedure DisableRefresh

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.EnableRefresh (метод)

Разрешить перерисовку изображения

Синтаксис

[Visual Basic 6]
Sub EnableRefresh

[Delphi]
procedure EnableRefresh

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.FlashDevicePoint (метод)

Подсвечивает миганием точку, заданную в целочисленной системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub FlashDevicePoint ( _
   ByVal X As Long, _
   ByVal Y As Long _
)

[Delphi]
procedure FlashDevicePoint(
   const X: Integer;
   const Y: Integer
)

Описание параметров

X
[in] Координата X подсвечиваемой точки в целочисленной системе координат окна контейнера
Y
[in] Координата Y подсвечиваемой точки в целочисленной системе координат окна контейнера

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.FlashDevicePoints (метод)

Подсвечивает миганием массив точек, заданных в целочисленной системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub FlashDevicePoints ( _
   ByVal Points() As Long _
)

[Delphi]
procedure FlashDevicePoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат подсвечиваемых точек в целочисленной системе координат окна контейнера. Точки в массиве задаются последовательно: X1,Y1,X2,Y2,...

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.FlashFlatPoint (метод)

Подсвечивает миганием точку, заданную в вещественной плоской системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub FlashFlatPoint ( _
   ByVal FlatX As Double, _
   ByVal FlatY As Double _
)

[Delphi]
procedure FlashFlatPoint(
   const FlatX: Double;
   const FlatY: Double
)

Описание параметров

FlatX
[in] Координата X подсвечиваемой точки в вещественной плоской системе координат окна контейнера
FlatY
[in] Координата Y подсвечиваемой точки в вещественной плоской системе координат окна контейнера

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.FlashFlatPoints (метод)

Подсвечивает миганием массив точек, заданных в вещественной плоской системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub FlashFlatPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure FlashFlatPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат подсвечиваемых точек в вещественной плоской системе координат окна контейнера. Точки в массиве задаются последовательно: X1,Y1,X2,Y2,...

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.FlashModelPoint (метод)

Подсвечивает миганием точку, заданную в вещественной системе координат модели

Синтаксис

[Visual Basic 6]
Sub FlashModelPoint ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal Layer As Object = Nothing] _
)

[Delphi]
procedure FlashModelPoint(
   const ModelX: Double;
   const ModelY: Double;
   const Layer: IDispatch
)

Описание параметров

ModelX
[in] Координата X подсвечиваемой точки в вещественной системе координат модели
ModelY
[in] Координата Y подсвечиваемой точки в вещественной системе координат модели
Layer
[in] Текущий слой карты, в системе координат которого задаются координаты показываемой точки. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.FlashModelPoints (метод)

Подсвечивает миганием массив точек, заданных в вещественной системе координат модели

Синтаксис

[Visual Basic 6]
Sub FlashModelPoints ( _
   ByVal Points() As Double, _
   [ByVal Layer As Object = Nothing] _
)

[Delphi]
procedure FlashModelPoints(
   const Points: PSafeArray;
   const Layer: IDispatch
)

Описание параметров

Points
[in] Массив координат подсвечиваемых точек в вещественной плоской системе координат окна контейнера. Точки в массиве задаются последовательно: X1,Y1,X2,Y2,...
Layer
[in] Текущий слой карты, в системе координат которого задаются координаты показываемой точки. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.HighlightDevicePoint (метод)

Показывает последовательностью сужающихся концентрических окружностей точку, заданную в целочисленной системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub HighlightDevicePoint ( _
   ByVal X As Long, _
   ByVal Y As Long _
)

[Delphi]
procedure HighlightDevicePoint(
   const X: Integer;
   const Y: Integer
)

Описание параметров

X
[in] Координата X показываемой точки на карте в целочисленной системе координат окна контейнера
Y
[in] Координата Y показываемой точки на карте в целочисленной системе координат окна контейнера

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.HighlightFlatPoint (метод)

Показывает последовательностью сужающихся концентрических окружностей точку, заданную в вещественной плоской системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub HighlightFlatPoint ( _
   ByVal FlatX As Double, _
   ByVal FlatY As Double _
)

[Delphi]
procedure HighlightFlatPoint(
   const FlatX: Double;
   const FlatY: Double
)

Описание параметров

FlatX
[in] Координата X показываемой точки на карте в вещественной плоской системе координат окна контейнера
FlatY
[in] Координата Y показываемой точки на карте в вещественной плоской системе координат окна контейнера

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.HighlightModelPoint (метод)

Подсвечивает миганием точку, заданную в вещественной системе координат модели

Синтаксис

[Visual Basic 6]
Sub HighlightModelPoint ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal Layer As Object = Nothing] _
)

[Delphi]
procedure HighlightModelPoint(
   const ModelX: Double;
   const ModelY: Double;
   const Layer: IDispatch
)

Описание параметров

ModelX
[in] Координата X показываемой точки на карте в вещественной системе координат модели
ModelY
[in] Координата Y показываемой точки на карте в вещественной системе координат модели
Layer
[in] Текущий слой карты, в системе координат которого задаются координаты показываемой точки. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.Invalidate (метод)

Обновить изображение контейнера, как только появится свободное процессорное время

Синтаксис

[Visual Basic 6]
Sub Invalidate

[Delphi]
procedure Invalidate

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.LockRefresh (метод)

Заблокировать перерисовку изображения (после этого метода обязательно надо будет вызвать UnlockRefresh)

Синтаксис

[Visual Basic 6]
Sub LockRefresh

[Delphi]
procedure LockRefresh

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.MasterPan (метод)

Панорамировать видимое изображение главного контейнера

Синтаксис

[Visual Basic 6]
Sub MasterPan

[Delphi]
procedure MasterPan

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.MasterSelect (метод)

Выбрать видимое изображение главного контейнера

Синтаксис

[Visual Basic 6]
Sub MasterSelect

[Delphi]
procedure MasterSelect

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.MouseCapture (метод)

Захват мыши

Синтаксис

[Visual Basic 6]
Sub MouseCapture

[Delphi]
procedure MouseCapture

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.Pan (метод)

Панорамировать изображение с помощью руки

Синтаксис

[Visual Basic 6]
Function Pan As Boolean

[Delphi]
function Pan: WordBool

Возвращаемое значение

Возвращает True, если панорамирование было выполнено

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.PanTo (метод)

Сдвинуть изображение в заданном направлении (LargeStep - с большим шагом)

Синтаксис

[Visual Basic 6]
Sub PanTo ( _
   ByVal PanDirection As PanDirectionConstants, _
   ByVal LargeStep As Boolean _
)

[Delphi]
procedure PanTo(
   const PanDirection: PanDirectionConstants;
   const LargeStep: WordBool
)

Описание параметров

PanDirection
[in] Направление, в котором необходимо сдвинуть изображение
LargeStep
[in] Использовать ли большой шаг при сдвиге изображения

Смотри также

Class CustomContainer, Enum PanDirectionConstants, Group Контейнеры изображений


CustomContainer.PanToPoint (метод)

Немного сдвинуть изображение в направлении указанной точки. Реально данный метод вызывает метод PanTo с соответствующими параметрами

Синтаксис

[Visual Basic 6]
Function PanToPoint ( _
   ByVal Point As Point _
) As Boolean

[Delphi]
function PanToPoint(
   const Point: Point
): WordBool

Описание параметров

Point
[in] Точка, в направлении которой необходимо выполнить сдвиг

Возвращаемое значение

Возвращает True, если сдвиг был выполнен

Смотри также

Class CustomContainer, Class Point, Group Контейнеры изображений


CustomContainer.PrintView (метод)

Распечатать на принтере на одной странице видимую часть изображения

Синтаксис

[Visual Basic 6]
Sub PrintView ( _
   ByVal Title As String _
)

[Delphi]
procedure PrintView(
   const Title: WideString
)

Описание параметров

Title
[in] Заголовок задания для печати

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.RefreshContent (метод)

Указать, что надо перерисовать изображение в памяти

Синтаксис

[Visual Basic 6]
Sub RefreshContent ( _
   [ByVal EraseBackground As Boolean = True] _
)

[Delphi]
procedure RefreshContent(
   const EraseBackground: WordBool
)

Описание параметров

EraseBackground
[in] Если EraseBackground=True, то фон изображения будет стерт и изображение в контейнере будет перерисовано полностью заново

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.RegisterMode (метод)

Зарегистрировать новый режим работы контейнера с указанным обработчиком событий

Синтаксис

[Visual Basic 6]
Function RegisterMode ( _
   ByVal Value As IContainerModeEvents _
) As ContainerModeHandler

[Delphi]
function RegisterMode(
   const Value: IContainerModeEvents
): ContainerModeHandler

Описание параметров

Value
[in] Обработчик событий, который будет реализовывать режим

Возвращаемое значение

Возвращает новый обработчик режима работы контейнера

Смотри также

Class ContainerModeHandler, Class CustomContainer, Interface IContainerModeEvents, Group Контейнеры изображений


CustomContainer.Repaint (метод)

Обновить изображение контейнера немедленно

Синтаксис

[Visual Basic 6]
Sub Repaint

[Delphi]
procedure Repaint

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.RestoreLastView (метод)

Восстановить последний запомненный масштаб из списка

Синтаксис

[Visual Basic 6]
Sub RestoreLastView

[Delphi]
procedure RestoreLastView

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.SaveCurrentView (метод)

Сохранить текущий масштаб в списке

Синтаксис

[Visual Basic 6]
Sub SaveCurrentView

[Delphi]
procedure SaveCurrentView

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.SelectActiveMode (метод)

Выбрать текущий обработчик режима работы с контейнером

Синтаксис

[Visual Basic 6]
Sub SelectActiveMode ( _
   ByVal Value As ContainerModeHandler, _
   [ByVal SubModeGroup As Long = -1], _
   [ByVal SubModeIndex As Long = -1] _
)

[Delphi]
procedure SelectActiveMode(
   const Value: ContainerModeHandler;
   const SubModeGroup: Integer;
   const SubModeIndex: Integer
)

Описание параметров

Value
[in] Обработчик режима работы
SubModeGroup
[in] Группа подрежимов, которая должна быть выбрана. Если будет задано -1, то текущая группа не будет изменена
SubModeIndex
[in] Номер подрежима в группе, который должна быть выбрана. Если будет задано -1, то текущий номер режима меняться не будет

Смотри также

Class ContainerModeHandler, Class CustomContainer, Group Контейнеры изображений


CustomContainer.SelectActiveModeByName (метод)

Выбрать текущий обработчик режима работы с контейнером

Синтаксис

[Visual Basic 6]
Sub SelectActiveModeByName ( _
   ByVal ContainerModeName As String, _
   [ByVal SubModeGroup As Long = -1], _
   [ByVal SubModeIndex As Long = -1] _
)

[Delphi]
procedure SelectActiveModeByName(
   const ContainerModeName: WideString;
   const SubModeGroup: Integer;
   const SubModeIndex: Integer
)

Описание параметров

ContainerModeName
[in] Имя класса обработчика режима работы
SubModeGroup
[in] Группа подрежимов, которая должна быть выбрана. Если будет задано -1, то текущая группа не будет изменена
SubModeIndex
[in] Номер подрежима в группе, который должна быть выбрана. Если будет задано -1, то текущий номер режима меняться не будет

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.Synchronize (метод)

Вызвать метод Executable.Execute в основном потоке объекта

Синтаксис

[Visual Basic 6]
Function Synchronize ( _
   ByVal Executable As IExecutable, _
   Result As Boolean _
) As Long

[Delphi]
function Synchronize(
   const Executable: IExecutable;
   out Result: WordBool
): HResult

Описание параметров

Executable
[in] Интерфейс с методом Execute, у которого будет вызван метод Execute в основном потоке объекта
Result
[out] Возвращает True, если вызов выполнен успешно

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class CustomContainer, Interface IExecutable, Group Контейнеры изображений


CustomContainer.TrackFixedRect (метод)

Оттрасировать прямоугольник заданного размера на карте

Синтаксис

[Visual Basic 6]
Function TrackFixedRect ( _
   ByVal Size As FlatPoint, _
   [ByVal Snap As Boolean = False], _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFixedRect(
   const Size: FlatPoint;
   const Snap: WordBool;
   const Layer: IDispatch
): FlatRect

Описание параметров

Size
[in] Размер прямоугольника
Snap
[in] Выполнять ли подтяжку вводимого прямоугольника по сетке
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatPoint, Class FlatRect, Group Контейнеры изображений


CustomContainer.TrackFlatCircle (метод)

Оттрасировать окружность на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatCircle ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatCircle(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную окружность в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.TrackFlatEllipse (метод)

Оттрасировать эллипс на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatEllipse ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatEllipse(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный эллипс в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.TrackFlatFillCircle (метод)

Оттрасировать залитый круг на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatFillCircle ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatFillCircle(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную окружность в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.TrackFlatFillEllipse (метод)

Оттрасировать залитый эллипс на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatFillEllipse ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatFillEllipse(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный эллипс в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.TrackFlatFillPolygon (метод)

Оттрасировать залитый полигон на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatFillPolygon ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackFlatFillPolygon(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный полигон в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class ShapePolygon, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackFlatFillRectangle (метод)

Оттрасировать залитый прямоугольник на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatFillRectangle ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatFillRectangle(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.TrackFlatMultipoint (метод)

Оттрасировать мультиточку на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatMultipoint ( _
   [ByVal Layer As Object = Nothing] _
) As ShapeMultipoint

[Delphi]
function TrackFlatMultipoint(
   const Layer: IDispatch
): ShapeMultipoint

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную мультиточку в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class ShapeMultipoint, Group Контейнеры изображений


CustomContainer.TrackFlatPoint (метод)

Оттрасировать точку на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatPoint ( _
   [ByVal Layer As Object = Nothing] _
) As FlatPoint

[Delphi]
function TrackFlatPoint(
   const Layer: IDispatch
): FlatPoint

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную точку в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatPoint, Group Контейнеры изображений


CustomContainer.TrackFlatPolygon (метод)

Оттрасировать полигон на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatPolygon ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackFlatPolygon(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный полигон в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class ShapePolygon, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackFlatPolyline (метод)

Оттрасировать полилинию на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatPolyline ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackFlatPolyline(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную полилинию в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class ShapePolyline, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackFlatRectangle (метод)

Оттрасировать прямоугольник на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatRectangle ( _
   [ByVal InternalLineCountX As Long = 0], _
   [ByVal InternalLineCountY As Long = 0], _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatRectangle(
   const InternalLineCountX: Integer;
   const InternalLineCountY: Integer;
   const Layer: IDispatch
): FlatRect

Описание параметров

InternalLineCountX
[in] Количество промежуточных вертикальных линий у трассируемого прямоугольника
InternalLineCountY
[in] Количество промежуточных горизонтальных линий у трассируемого прямоугольника
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.TrackFlatSegment (метод)

Оттрасировать отрезок на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatSegment ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackFlatSegment(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный отрезок в виде полилинии в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class ShapePolyline, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelCircle (метод)

Оттрасировать окружность на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelCircle ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelCircle(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную окружность в виде полилинии, заданной в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolyline, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelEllipse (метод)

Оттрасировать эллипс на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelEllipse ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelEllipse(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный эллипс в виде полилинии, заданной в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolyline, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelFillCircle (метод)

Оттрасировать залитый круг на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelFillCircle ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelFillCircle(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную окружность в виде полигона, заданного в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolygon, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelFillEllipse (метод)

Оттрасировать залитый эллипс на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelFillEllipse ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelFillEllipse(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный эллипс в виде полигона, заданного в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolygon, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelFillPolygon (метод)

Оттрасировать залитый полигон на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelFillPolygon ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelFillPolygon(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный полигон в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolygon, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelFillRectangle (метод)

Оттрасировать залитый прямоугольник на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelFillRectangle ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelFillRectangle(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в виде полигона, заданного в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolygon, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelMultipoint (метод)

Оттрасировать мультиточку на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelMultipoint ( _
   [ByVal Layer As Object = Nothing] _
) As ShapeMultipoint

[Delphi]
function TrackModelMultipoint(
   const Layer: IDispatch
): ShapeMultipoint

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную мультиточку в системе координат модели

Смотри также

Class CustomContainer, Class ShapeMultipoint, Group Контейнеры изображений


CustomContainer.TrackModelPoint (метод)

Оттрасировать точку на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelPoint ( _
   [ByVal Layer As Object = Nothing] _
) As ModelPoint

[Delphi]
function TrackModelPoint(
   const Layer: IDispatch
): ModelPoint

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную мультиточку в системе координат модели

Смотри также

Class CustomContainer, Class ModelPoint, Group Контейнеры изображений


CustomContainer.TrackModelPolygon (метод)

Оттрасировать полигон на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelPolygon ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelPolygon(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный полигон в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolygon, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelPolyline (метод)

Оттрасировать полилинию на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelPolyline ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelPolyline(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную полилинию в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolyline, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelRectangle (метод)

Оттрасировать прямоугольник на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelRectangle ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal InternalLineCountX As Long = 0], _
   [ByVal InternalLineCountY As Long = 0], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelRectangle(
   const ShapeType: ShapeTypeConstants;
   const InternalLineCountX: Integer;
   const InternalLineCountY: Integer;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
InternalLineCountX
[in] Количество промежуточных вертикальных линий у трассируемого прямоугольника
InternalLineCountY
[in] Количество промежуточных горизонтальных линий у трассируемого прямоугольника
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в виде полилинии, заданной в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolyline, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackModelSegment (метод)

Оттрасировать отрезок на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelSegment ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelSegment(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный отрезок в виде полилинии в системе координат модели

Смотри также

Class CustomContainer, Class ShapePolyline, Enum ShapeTypeConstants, Group Контейнеры изображений


CustomContainer.TrackZoomIn (метод)

Укрупнить изображение с помощью трассировки прямоугольника

Синтаксис

[Visual Basic 6]
Sub TrackZoomIn

[Delphi]
procedure TrackZoomIn

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.TrackZoomOut (метод)

Уменьшить изображение с помощью трассировки прямоугольника

Синтаксис

[Visual Basic 6]
Sub TrackZoomOut

[Delphi]
procedure TrackZoomOut

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.TrackZoomRect (метод)

Оттрасировать прямоугольник, пропорциональный заданным высоте и ширине

Синтаксис

[Visual Basic 6]
Function TrackZoomRect ( _
   ByVal WidthAspect As Long, _
   ByVal HeightAspect As Long, _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackZoomRect(
   const WidthAspect: Integer;
   const HeightAspect: Integer;
   const Layer: IDispatch
): FlatRect

Описание параметров

WidthAspect
[in] Ширина прямоугольника, пропорционально которой будет выполняться трассировка
HeightAspect
[in] Высота прямоугольника, пропорционально которой будет выполняться трассировка
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.TrackZoomRectangle (метод)

Оттрасировать прямоугольник, пропорциональный клиентскому размеру данного контейнера

Синтаксис

[Visual Basic 6]
Function TrackZoomRectangle ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackZoomRectangle(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.UnlockRefresh (метод)

Разблокировать перерисовку изображения (обязательно вызывается после LockRefresh)

Синтаксис

[Visual Basic 6]
Sub UnlockRefresh

[Delphi]
procedure UnlockRefresh

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.UpdateContentAll (метод)

Полностью обновить изображение

Синтаксис

[Visual Basic 6]
Sub UpdateContentAll

[Delphi]
procedure UpdateContentAll

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.UpdateCursor (метод)

Обновить курсор

Синтаксис

[Visual Basic 6]
Sub UpdateCursor

[Delphi]
procedure UpdateCursor

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.UpdateScrollbars (метод)

Обновить содержимое скроллеров

Синтаксис

[Visual Basic 6]
Sub UpdateScrollbars

[Delphi]
procedure UpdateScrollbars

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.ZoomInCenter (метод)

Укрупнить изображение в центре в 5/4 раза

Синтаксис

[Visual Basic 6]
Sub ZoomInCenter

[Delphi]
procedure ZoomInCenter

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.ZoomOutCenter (метод)

Уменьшить изображение в центре в 5/4 раза

Синтаксис

[Visual Basic 6]
Sub ZoomOutCenter

[Delphi]
procedure ZoomOutCenter

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.ZoomToAll (метод)

Вписать в окно всю карту

Синтаксис

[Visual Basic 6]
Sub ZoomToAll

[Delphi]
procedure ZoomToAll

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.ZoomToExtent (метод)

Вписать в окно заданный прямоугольник. Данный метод по сути эквивалентен методу ZoomToRect, у которого задана анимация изображения

Синтаксис

[Visual Basic 6]
Sub ZoomToExtent ( _
   ByVal Extent As FlatRect _
)

[Delphi]
procedure ZoomToExtent(
   const Extent: FlatRect
)

Описание параметров

Extent
[in] Прямоугольная область, заданная в плоской системе координат контейнера, которая должна стать текущей видимой в контейнере

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.ZoomToPoint (метод)

Смасштабировать в заданный масштаб с точкой в центре

Синтаксис

[Visual Basic 6]
Sub ZoomToPoint ( _
   ByVal Scale As Double, _
   ByVal ScaleXY As Double, _
   ByVal Center As FlatPoint, _
   ByVal Animate As Boolean _
)

[Delphi]
procedure ZoomToPoint(
   const Scale: Double;
   const ScaleXY: Double;
   const Center: FlatPoint;
   const Animate: WordBool
)

Описание параметров

Scale
[in] Масштаб отображения (соотношение размеров в целочисленной системе координат окна контейнера и вещественных размеров в плоской системе координат контейнера)
ScaleXY
[in] Соотношение масштабов отображения по осям X и Y
Center
[in] Координата центра видимой части изображения в плоской системе координат контейнера
Animate
[in] Выполнять ли анимацию процесса масштабирования

Смотри также

Class CustomContainer, Class FlatPoint, Group Контейнеры изображений


CustomContainer.ZoomToRect (метод)

Смасштабировать в заданное окно

Синтаксис

[Visual Basic 6]
Sub ZoomToRect ( _
   ByVal FlatRect As FlatRect, _
   ByVal ScaleXY As Double, _
   ByVal Animate As Boolean _
)

[Delphi]
procedure ZoomToRect(
   const FlatRect: FlatRect;
   const ScaleXY: Double;
   const Animate: WordBool
)

Описание параметров

FlatRect
[in] Прямоугольная область, заданная в плоской системе координат контейнера, которая должна стать текущей видимой в контейнере
ScaleXY
[in] Соотношение масштабов отображения по осям X и Y
Animate
[in] Выполнять ли анимацию процесса масштабирования

Смотри также

Class CustomContainer, Class FlatRect, Group Контейнеры изображений


CustomContainer.ZoomToScale (метод)

Смасштабировать относительно центра окна до заданного масштаба

Синтаксис

[Visual Basic 6]
Sub ZoomToScale ( _
   ByVal Scale As Double, _
   ByVal ScaleXY As Double, _
   ByVal Animate As Boolean _
)

[Delphi]
procedure ZoomToScale(
   const Scale: Double;
   const ScaleXY: Double;
   const Animate: WordBool
)

Описание параметров

Scale
[in] Масштаб отображения (соотношение размеров в целочисленной системе координат окна контейнера и вещественных размеров в плоской системе координат контейнера)
ScaleXY
[in] Соотношение масштабов отображения по осям X и Y
Animate
[in] Выполнять ли анимацию процесса масштабирования

Смотри также

Class CustomContainer, Group Контейнеры изображений


CustomContainer.ZoomToView (метод)

Смасштабировать в заданное окно

Синтаксис

[Visual Basic 6]
Sub ZoomToView ( _
   ByVal Scale As Double, _
   ByVal ScaleXY As Double, _
   ByVal ViewOrigin As FlatPoint, _
   ByVal Animate As Boolean _
)

[Delphi]
procedure ZoomToView(
   const Scale: Double;
   const ScaleXY: Double;
   const ViewOrigin: FlatPoint;
   const Animate: WordBool
)

Описание параметров

Scale
[in] Масштаб отображения (соотношение размеров в целочисленной системе координат окна контейнера и вещественных размеров в плоской системе координат контейнера)
ScaleXY
[in] Соотношение масштабов отображения по осям X и Y
ViewOrigin
[in] Координата левого верхнего угла видимой части изображения в плоской системе координат контейнера
Animate
[in] Выполнять ли анимацию процесса масштабирования

Смотри также

Class CustomContainer, Class FlatPoint, Group Контейнеры изображений


Класс CustomMode

Режим работы, определяемый пользователем

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Caption | Название элемента меню с режимом
Property Composition (только для чтения) | Композиция, в которой определены подрежимы
Property Cursor | Тип курсора
Property Description | Краткое описание режима
Property Enabled | Доступен ли режим
Property GroupLocation | Номер группы с иконкой режима
Property Hint | Подсказка на кнопку
Property ID (только для чтения) | Уникальный код режима пользователя на данной карте
Property ImageIndex | Код иконки
Property ModeLocation | Номер положения иконки режима внутри группы
Property ShortCut | Горячая клавиша
Property SubModeCount | Количество подрежимов
Property SubModes (только для чтения) | Массив подрежимов
Property Tag | Переменная для свободного использования

Методы класса

Имя | Описание
Method AddSubMode | Добавляет новый подрежим
Method ClearSubModes | Удалить все подрежимы
Method Delete | Удалить режим
Method SubModeById | Получить подрежим режима пользователя по коду

Где используется

Класс | Член класса
Class CustomSubMode | Property Mode (свойство)

Смотри также

Class Composition, Enum CursorConstants, Group Карты


CustomMode.Caption (свойство)

Название элемента меню с режимом

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class CustomMode, Group Карты


CustomMode.Composition (свойство)

Композиция, в которой определены подрежимы

Синтаксис

[Visual Basic 6]
ReadOnly Property Composition As Composition

[Delphi]
{только для чтения} property Composition: Composition

Смотри также

Class Composition, Class CustomMode, Group Карты


CustomMode.Cursor (свойство)

Тип курсора

Синтаксис

[Visual Basic 6]
Property Cursor As CursorConstants

[Delphi]
property Cursor: CursorConstants

Смотри также

Enum CursorConstants, Class CustomMode, Group Карты


CustomMode.Description (свойство)

Краткое описание режима

Синтаксис

[Visual Basic 6]
Property Description As String

[Delphi]
property Description: WideString

Смотри также

Class CustomMode, Group Карты


CustomMode.Enabled (свойство)

Доступен ли режим

Синтаксис

[Visual Basic 6]
Property Enabled As Boolean

[Delphi]
property Enabled: WordBool

Смотри также

Class CustomMode, Group Карты


CustomMode.GroupLocation (свойство)

Номер группы с иконкой режима

Синтаксис

[Visual Basic 6]
Property GroupLocation As Long

[Delphi]
property GroupLocation: Integer

Смотри также

Class CustomMode, Group Карты


CustomMode.Hint (свойство)

Подсказка на кнопку

Синтаксис

[Visual Basic 6]
Property Hint As String

[Delphi]
property Hint: WideString

Смотри также

Class CustomMode, Group Карты


CustomMode.ID (свойство)

Уникальный код режима пользователя на данной карте

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class CustomMode, Group Карты


CustomMode.ImageIndex (свойство)

Код иконки

Синтаксис

[Visual Basic 6]
Property ImageIndex As Long

[Delphi]
property ImageIndex: Integer

Смотри также

Class CustomMode, Group Карты


CustomMode.ModeLocation (свойство)

Номер положения иконки режима внутри группы

Синтаксис

[Visual Basic 6]
Property ModeLocation As Long

[Delphi]
property ModeLocation: Integer

Смотри также

Class CustomMode, Group Карты


CustomMode.ShortCut (свойство)

Горячая клавиша

Синтаксис

[Visual Basic 6]
Property ShortCut As Long

[Delphi]
property ShortCut: Integer

Смотри также

Class CustomMode, Group Карты


CustomMode.SubModeCount (свойство)

Количество подрежимов

Синтаксис

[Visual Basic 6]
Property SubModeCount As Long

[Delphi]
property SubModeCount: Integer

Смотри также

Class CustomMode, Group Карты


CustomMode.SubModes (свойство)

Массив подрежимов

Синтаксис

[Visual Basic 6]
ReadOnly Property SubModes As CustomSubMode

[Delphi]
{только для чтения} property SubModes: CustomSubMode

Смотри также

Class CustomMode, Class CustomSubMode, Group Карты


CustomMode.Tag (свойство)

Переменная для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As String

[Delphi]
property Tag: WideString

Смотри также

Class CustomMode, Group Карты


CustomMode.AddSubMode (метод)

Добавляет новый подрежим

Синтаксис

[Visual Basic 6]
Function AddSubMode ( _
   [ByVal Caption As String = ""], _
   [ByVal ImageIndex As Long = 0], _
   [ByVal Tag As String = ""] _
) As CustomSubMode

[Delphi]
function AddSubMode(
   const Caption: WideString;
   const ImageIndex: Integer;
   const Tag: WideString
): CustomSubMode

Описание параметров

Caption
[in] Название подрежима
ImageIndex
[in] Код иконки в наборе иконок приложения
Tag
[in] Дополнительный параметр Tag

Возвращаемое значение

Возвращает новый подрежим

Смотри также

Class CustomMode, Class CustomSubMode, Group Карты


CustomMode.ClearSubModes (метод)

Удалить все подрежимы

Синтаксис

[Visual Basic 6]
Sub ClearSubModes

[Delphi]
procedure ClearSubModes

Смотри также

Class CustomMode, Group Карты


CustomMode.Delete (метод)

Удалить режим

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class CustomMode, Group Карты


CustomMode.SubModeById (метод)

Получить подрежим режима пользователя по коду

Синтаксис

[Visual Basic 6]
Function SubModeById ( _
   ByVal SubModeId As Long _
) As CustomSubMode

[Delphi]
function SubModeById(
   const SubModeId: Integer
): CustomSubMode

Описание параметров

SubModeId
[in] Код подрежима

Возвращаемое значение

Возвращает найденный подрежим или Nothing, если ничего не найдено

Смотри также

Class CustomMode, Class CustomSubMode, Group Карты


Класс CustomOptions

Настройки класса

Наследование

CustomOptions Class LayerOptions, Options3D, ProjectOptions, RouteOptions

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property CustomValueName (только для чтения) | Массив имён пользовательских значений
Property CustomValuesCount (только для чтения) | Количество пользовательских значений

Методы класса

Имя | Описание
Method DeleteCustomValue | Удалить из настроек пользовательское значение
Method GetCustomValue | Получить из настроек пользовательское значение
Method SetCustomValue | Запомнить в настройках пользовательское значение

Смотри также

Group Поверхности, Group Приложение, Group Трассы


CustomOptions.CustomValueName (свойство)

Массив имён пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValueName As String

[Delphi]
{только для чтения} property CustomValueName: WideString

Смотри также

Class CustomOptions, Group Поверхности, Group Приложение, Group Трассы


CustomOptions.CustomValuesCount (свойство)

Количество пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValuesCount As Long

[Delphi]
{только для чтения} property CustomValuesCount: Integer

Смотри также

Class CustomOptions, Group Поверхности, Group Приложение, Group Трассы


CustomOptions.DeleteCustomValue (метод)

Удалить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Function DeleteCustomValue ( _
   ByVal Name As String _
) As Boolean

[Delphi]
function DeleteCustomValue(
   const Name: WideString
): WordBool

Описание параметров

Name
[in] Имя значения, подлежащего удалению

Возвращаемое значение

True - значение удалено, False - не найдено значения с указанным именем

Смотри также

Class CustomOptions, Group Поверхности, Group Приложение, Group Трассы


CustomOptions.GetCustomValue (метод)

Получить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Sub GetCustomValue ( _
   ByVal Name As String, _
   ByVal DefaultValue As Variant _
)

[Delphi]
procedure GetCustomValue(
   const Name: WideString;
   const DefaultValue: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
DefaultValue
[in] Значение, которое будет возвращено, если в настройках не содержится ассоциациированного с указанным именем значения

Смотри также

Class CustomOptions, Group Поверхности, Group Приложение, Group Трассы


CustomOptions.SetCustomValue (метод)

Запомнить в настройках пользовательское значение

Синтаксис

[Visual Basic 6]
Sub SetCustomValue ( _
   ByVal Name As String, _
   ByVal Value As Variant _
)

[Delphi]
procedure SetCustomValue(
   const Name: WideString;
   const Value: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
Value
[in] Значение, ассоциируемое с указанным именем

Смотри также

Class CustomOptions, Group Поверхности, Group Приложение, Group Трассы


Класс CustomSubMode

Подрежим режима пользователя

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Caption | Название элемента меню с подрежимом
Property ID (только для чтения) | Уникальный код подрежима в данном режиме пользователя
Property ImageIndex | Иконка элемента меню с подрежимом
Property Mode (только для чтения) | Режим пользователя, которому принадлежит данный подрежим
Property ShortCut | Горячая клавиша
Property Tag | Переменная для свободного использования программистами на VBA

Методы класса

Имя | Описание
Method Delete | Удалить подрежим

Где используется

Класс | Член класса
Class CustomMode | Property SubModes (свойство) Method AddSubMode (метод) Method SubModeById (метод)

Смотри также

Group Карты


CustomSubMode.Caption (свойство)

Название элемента меню с подрежимом

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class CustomSubMode, Group Карты


CustomSubMode.ID (свойство)

Уникальный код подрежима в данном режиме пользователя

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class CustomSubMode, Group Карты


CustomSubMode.ImageIndex (свойство)

Иконка элемента меню с подрежимом

Синтаксис

[Visual Basic 6]
Property ImageIndex As Long

[Delphi]
property ImageIndex: Integer

Смотри также

Class CustomSubMode, Group Карты


CustomSubMode.Mode (свойство)

Режим пользователя, которому принадлежит данный подрежим

Синтаксис

[Visual Basic 6]
ReadOnly Property Mode As CustomMode

[Delphi]
{только для чтения} property Mode: CustomMode

Смотри также

Class CustomMode, Class CustomSubMode, Group Карты


CustomSubMode.ShortCut (свойство)

Горячая клавиша

Синтаксис

[Visual Basic 6]
Property ShortCut As Long

[Delphi]
property ShortCut: Integer

Смотри также

Class CustomSubMode, Group Карты


CustomSubMode.Tag (свойство)

Переменная для свободного использования программистами на VBA

Синтаксис

[Visual Basic 6]
Property Tag As String

[Delphi]
property Tag: WideString

Смотри также

Class CustomSubMode, Group Карты


CustomSubMode.Delete (метод)

Удалить подрежим

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class CustomSubMode, Group Карты


Класс CustomSurveyPoint

Абстрактная съёмочная точка

Наследование

GeoPoint Class LinkedGeoPoint Class CustomSurveyPoint Class FieldTraversePoint, SurveyPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property DH | Приращение высоты (превышение)
Property DirAngle | Дирекционный угол
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property HorzAngle | Измеренный горизонтальный угол
Property HorzLength | Горизонтальная длина (в проекции)
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Length | Измеренное расстояние
Property LinkedPoint | Ссылка на другую точку
Property Number | Номер (описание) точки
Property Position | Положение точки
Property SourceStation (только для чтения) | Станция, с которой снята точка
Property VaneHeight | Высота линейки (вешки)
Property VertAngle | Вертикальный угол

Смотри также

Class GeodesyAngle, Class GeoPoint, Class ModelPoint, Group Геодезия


CustomSurveyPoint.DH (свойство)

Приращение высоты (превышение)

Синтаксис

[Visual Basic 6]
Property DH As Double

[Delphi]
property DH: Double

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.DirAngle (свойство)

Дирекционный угол

Синтаксис

[Visual Basic 6]
Property DirAngle As GeodesyAngle

[Delphi]
property DirAngle: GeodesyAngle

Смотри также

Class CustomSurveyPoint, Class GeodesyAngle, Group Геодезия


CustomSurveyPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.HorzAngle (свойство)

Измеренный горизонтальный угол

Синтаксис

[Visual Basic 6]
Property HorzAngle As GeodesyAngle

[Delphi]
property HorzAngle: GeodesyAngle

Смотри также

Class CustomSurveyPoint, Class GeodesyAngle, Group Геодезия


CustomSurveyPoint.HorzLength (свойство)

Горизонтальная длина (в проекции)

Синтаксис

[Visual Basic 6]
Property HorzLength As Double

[Delphi]
property HorzLength: Double

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.Length (свойство)

Измеренное расстояние

Синтаксис

[Visual Basic 6]
Property Length As Double

[Delphi]
property Length: Double

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.LinkedPoint (свойство)

Ссылка на другую точку

Синтаксис

[Visual Basic 6]
Property LinkedPoint As GeoPoint

[Delphi]
property LinkedPoint: GeoPoint

Смотри также

Class CustomSurveyPoint, Class GeoPoint, Group Геодезия


CustomSurveyPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class CustomSurveyPoint, Class ModelPoint, Group Геодезия


CustomSurveyPoint.SourceStation (свойство)

Станция, с которой снята точка

Синтаксис

[Visual Basic 6]
ReadOnly Property SourceStation As GeoPoint

[Delphi]
{только для чтения} property SourceStation: GeoPoint

Смотри также

Class CustomSurveyPoint, Class GeoPoint, Group Геодезия


CustomSurveyPoint.VaneHeight (свойство)

Высота линейки (вешки)

Синтаксис

[Visual Basic 6]
Property VaneHeight As Double

[Delphi]
property VaneHeight: Double

Смотри также

Class CustomSurveyPoint, Group Геодезия


CustomSurveyPoint.VertAngle (свойство)

Вертикальный угол

Синтаксис

[Visual Basic 6]
Property VertAngle As GeodesyAngle

[Delphi]
property VertAngle: GeodesyAngle

Смотри также

Class CustomSurveyPoint, Class GeodesyAngle, Group Геодезия


Класс DatabaseInterface

Интерфейс с базами данных

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Author | Автор интерфейса
Property Copyright | Авторское право
Property DatabaseCount (только для чтения) | Количество баз данных
Property Databases (только для чтения) | Массив баз данных
Property FileName (только для чтения) | Имя файла с интерфейсом
Property ID (только для чтения) | Уникальный идентификатор интерфейса
Property Interfaces (только для чтения) | Содержащий интерфейс список
Property Internal (только для чтения) | Внутренний ли интерфейс
Property IsProtected (только для чтения) | Защита интерфейса от изменений
Property Location (только для чтения) | Расположение интерфейса
Property Modified | Признак изменения интерфейса
Property Name | Описание интерфейса
Property Notes | Заметки по интерфейсу
Property Password | Пароль на изменение интерфейса

Методы класса

Имя | Описание
Method CanPasteFromClipboard | Можно ли вставить из буфера базу данных
Method Clear | Удалить все базы данных
Method CopyToClipboard | Скопировать интерфейс в буфер
Method FindDatabaseByID | Найти базу данных по коду
Method FindDatabaseByName | Найти базу данных по заданному имени
Method LoadFrom | Загрузить из файла под новым именем
Method LoadFromFile | Загрузить из файла
Method PasteFromClipboard | Вставить из буфера базу данных
Method Save | Сохранить
Method SaveAs | Сохранить в файл под новым именем
Method SaveToFile | Сохранить копию в файл

Где используется

Класс | Член класса
Class DatabaseInterfaces | Property Interfaces (свойство) Method AddFromFile (метод) Method AddNew (метод) Method FindInterfaceByID (метод) Method FindInterfaceByName (метод) Method PasteFromClipboard (метод)
Class LinkedADODatabase | Property DatabaseInterface (свойство)
Class LinkedBDEDatabase | Property DatabaseInterface (свойство)
Class LinkedCorbaDatabase | Property DatabaseInterface (свойство)
Class LinkedDatabase | Property DatabaseInterface (свойство)
Class LinkedDCOMDatabase | Property DatabaseInterface (свойство)
Class LinkedDispatchDatabase | Property DatabaseInterface (свойство)
Class LinkedIBDatabase | Property DatabaseInterface (свойство)
Class LinkedOLEnterpriseDatabase | Property DatabaseInterface (свойство)
Class LinkedRDSDatabase | Property DatabaseInterface (свойство)
Class LinkedRemoteDatabase | Property DatabaseInterface (свойство)
Class LinkedSocketDatabase | Property DatabaseInterface (свойство)
Class LinkedUniDatabase | Property DatabaseInterface (свойство)
Class LinkedWebDatabase | Property DatabaseInterface (свойство)

Смотри также

Group Интерфейсы с базой данных


DatabaseInterface.Author (свойство)

Автор интерфейса

Синтаксис

[Visual Basic 6]
Property Author As String

[Delphi]
property Author: WideString

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Copyright (свойство)

Авторское право

Синтаксис

[Visual Basic 6]
Property Copyright As String

[Delphi]
property Copyright: WideString

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.DatabaseCount (свойство)

Количество баз данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseCount As Long

[Delphi]
{только для чтения} property DatabaseCount: Integer

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Databases (свойство)

Массив баз данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Databases As LinkedDatabase

[Delphi]
{только для чтения} property Databases: LinkedDatabase

Смотри также

Class DatabaseInterface, Class LinkedDatabase, Group Интерфейсы с базой данных


DatabaseInterface.FileName (свойство)

Имя файла с интерфейсом

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.ID (свойство)

Уникальный идентификатор интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Interfaces (свойство)

Содержащий интерфейс список

Синтаксис

[Visual Basic 6]
ReadOnly Property Interfaces As DatabaseInterfaces

[Delphi]
{только для чтения} property Interfaces: DatabaseInterfaces

Смотри также

Class DatabaseInterface, Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterface.Internal (свойство)

Внутренний ли интерфейс

Синтаксис

[Visual Basic 6]
ReadOnly Property Internal As Boolean

[Delphi]
{только для чтения} property Internal: WordBool

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.IsProtected (свойство)

Защита интерфейса от изменений

Синтаксис

[Visual Basic 6]
ReadOnly Property IsProtected As Boolean

[Delphi]
{только для чтения} property IsProtected: WordBool

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Location (свойство)

Расположение интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property Location As String

[Delphi]
{только для чтения} property Location: WideString

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Modified (свойство)

Признак изменения интерфейса

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Name (свойство)

Описание интерфейса

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Notes (свойство)

Заметки по интерфейсу

Синтаксис

[Visual Basic 6]
Property Notes As String

[Delphi]
property Notes: WideString

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Password (свойство)

Пароль на изменение интерфейса

Синтаксис

[Visual Basic 6]
Property Password As String

[Delphi]
property Password: WideString

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.CanPasteFromClipboard (метод)

Можно ли вставить из буфера базу данных

Синтаксис

[Visual Basic 6]
Function CanPasteFromClipboard As Boolean

[Delphi]
function CanPasteFromClipboard: WordBool

Возвращаемое значение

Возвращает True, если можно вставить из буфера базу данных

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Clear (метод)

Удалить все базы данных

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.CopyToClipboard (метод)

Скопировать интерфейс в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.FindDatabaseByID (метод)

Найти базу данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatabaseByID ( _
   ByVal DatabaseId As Long _
) As LinkedDatabase

[Delphi]
function FindDatabaseByID(
   const DatabaseId: Integer
): LinkedDatabase

Описание параметров

DatabaseId
[in] Код базы данных в интерфейсе

Возвращаемое значение

Возвращает базу данных в интерфейсе или Nothing, если таковой не существует

Смотри также

Class DatabaseInterface, Class LinkedDatabase, Group Интерфейсы с базой данных


DatabaseInterface.FindDatabaseByName (метод)

Найти базу данных по заданному имени

Синтаксис

[Visual Basic 6]
Function FindDatabaseByName ( _
   ByVal DatabaseName As String _
) As LinkedDatabase

[Delphi]
function FindDatabaseByName(
   const DatabaseName: WideString
): LinkedDatabase

Описание параметров

DatabaseName
[in] Имя базы данных в интерфейсе

Возвращаемое значение

Возвращает базу данных в интерфейсе или Nothing, если таковой не существует

Смотри также

Class DatabaseInterface, Class LinkedDatabase, Group Интерфейсы с базой данных


DatabaseInterface.LoadFrom (метод)

Загрузить из файла под новым именем

Синтаксис

[Visual Basic 6]
Sub LoadFrom ( _
   ByVal FileName As String _
)

[Delphi]
procedure LoadFrom(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла интерфейса с базой данных

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.LoadFromFile (метод)

Загрузить из файла

Синтаксис

[Visual Basic 6]
Sub LoadFromFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure LoadFromFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла интерфейса с базой данных

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.PasteFromClipboard (метод)

Вставить из буфера базу данных

Синтаксис

[Visual Basic 6]
Sub PasteFromClipboard

[Delphi]
procedure PasteFromClipboard

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.Save (метод)

Сохранить

Синтаксис

[Visual Basic 6]
Sub Save

[Delphi]
procedure Save

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.SaveAs (метод)

Сохранить в файл под новым именем

Синтаксис

[Visual Basic 6]
Sub SaveAs ( _
   ByVal AFileName As String _
)

[Delphi]
procedure SaveAs(
   const AFileName: WideString
)

Описание параметров

AFileName
[in] Имя файла интерфейса с базой данных

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


DatabaseInterface.SaveToFile (метод)

Сохранить копию в файл

Синтаксис

[Visual Basic 6]
Sub SaveToFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveToFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла интерфейса с базой данных

Смотри также

Class DatabaseInterface, Group Интерфейсы с базой данных


Класс DatabaseInterfaces

Список интерфейсов карты, проекта или темы

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество интерфейсов
Property Interfaces (только для чтения) | Массив интерфейсов с базой данных

Методы класса

Имя | Описание
Method AddFromFile | Добавить интерфейс из файла
Method AddNew | Создать новый внутренний интерфейс
Method CanPasteFromClipboard | Можно ли вставить из буфера интерфейс
Method Clear | Очистить список
Method Delete | Удалить интерфейс с указанным номером
Method FindDatabaseByIDs | Получить базу данных по его идентификатору
Method FindDatabaseByNames | Получить базу данных по её имени и имени интерфейса с базой данных
Method FindDatasetByIDs | Получить набор данных по его идентификатору
Method FindDatasetByNames | Получить набор данных по именам интерфейса, базы данных и набора данных
Method FindInterfaceByID | Получить интерфейс по его идентификатору
Method FindInterfaceByName | Получить интерфейс по его имени
Method MakeInternal | Сделать интерфейс с указанным номером внутренним
Method PasteFromClipboard | Вставить из буфера интерфейс

Где используется

Класс | Член класса
Class DatabaseInterface | Property Interfaces (свойство)

Смотри также

Class LinkedDatabase, Class LinkedDataset, Group Интерфейсы с базой данных


DatabaseInterfaces.Count (свойство)

Количество интерфейсов

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.Interfaces (свойство)

Массив интерфейсов с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Interfaces As DatabaseInterface

[Delphi]
{только для чтения} property Interfaces: DatabaseInterface

Смотри также

Class DatabaseInterface, Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.AddFromFile (метод)

Добавить интерфейс из файла

Синтаксис

[Visual Basic 6]
Function AddFromFile ( _
   ByVal FileName As String _
) As DatabaseInterface

[Delphi]
function AddFromFile(
   const FileName: WideString
): DatabaseInterface

Описание параметров

FileName
[in] Имя файла интерфейса базы данных

Возвращаемое значение

Возвращает новый интерфейс базы данных

Смотри также

Class DatabaseInterface, Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.AddNew (метод)

Создать новый внутренний интерфейс

Синтаксис

[Visual Basic 6]
Function AddNew As DatabaseInterface

[Delphi]
function AddNew: DatabaseInterface

Возвращаемое значение

Возвращает новый внутренний интерфейс базы данных

Смотри также

Class DatabaseInterface, Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.CanPasteFromClipboard (метод)

Можно ли вставить из буфера интерфейс

Синтаксис

[Visual Basic 6]
Function CanPasteFromClipboard As Boolean

[Delphi]
function CanPasteFromClipboard: WordBool

Возвращаемое значение

Возвращает True, если вставка из буфера возможна

Смотри также

Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.Clear (метод)

Очистить список

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.Delete (метод)

Удалить интерфейс с указанным номером

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемого интерфейса с базой данных

Смотри также

Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.FindDatabaseByIDs (метод)

Получить базу данных по его идентификатору

Синтаксис

[Visual Basic 6]
Function FindDatabaseByIDs ( _
   ByVal InterfaceID As String, _
   ByVal DatabaseId As Long _
) As LinkedDatabase

[Delphi]
function FindDatabaseByIDs(
   const InterfaceID: WideString;
   const DatabaseId: Integer
): LinkedDatabase

Описание параметров

InterfaceID
[in] Код интерфейса с базой данных
DatabaseId
[in] Код базы данных интерфейса с базой данных

Возвращаемое значение

Возвращает базу данных по заданным коду или Nothing, если таковой не удалось найти

Смотри также

Class DatabaseInterfaces, Class LinkedDatabase, Group Интерфейсы с базой данных


DatabaseInterfaces.FindDatabaseByNames (метод)

Получить базу данных по её имени и имени интерфейса с базой данных

Синтаксис

[Visual Basic 6]
Function FindDatabaseByNames ( _
   ByVal InterfaceName As String, _
   ByVal DatabaseName As String _
) As LinkedDatabase

[Delphi]
function FindDatabaseByNames(
   const InterfaceName: WideString;
   const DatabaseName: WideString
): LinkedDatabase

Описание параметров

InterfaceName
[in] Имя интерфейса с базой данных
DatabaseName
[in] Имя базы данных интерфейса с базой данных

Возвращаемое значение

Возвращает базу данных по заданным именам или Nothing, если таковой не удалось найти

Смотри также

Class DatabaseInterfaces, Class LinkedDatabase, Group Интерфейсы с базой данных


DatabaseInterfaces.FindDatasetByIDs (метод)

Получить набор данных по его идентификатору

Синтаксис

[Visual Basic 6]
Function FindDatasetByIDs ( _
   ByVal InterfaceID As String, _
   ByVal DatabaseId As Long, _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByIDs(
   const InterfaceID: WideString;
   const DatabaseId: Integer;
   const DatasetID: Integer
): LinkedDataset

Описание параметров

InterfaceID
[in] Код интерфейса с базой данных
DatabaseId
[in] Код базы данных интерфейса с базой данных
DatasetID
[in] Код набора данных базы данных интерфейса с базой данных

Возвращаемое значение

Возвращает набор данных по заданным коду или Nothing, если такового не удалось найти

Смотри также

Class DatabaseInterfaces, Class LinkedDataset, Group Интерфейсы с базой данных


DatabaseInterfaces.FindDatasetByNames (метод)

Получить набор данных по именам интерфейса, базы данных и набора данных

Синтаксис

[Visual Basic 6]
Function FindDatasetByNames ( _
   ByVal InterfaceName As String, _
   ByVal DatabaseName As String, _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByNames(
   const InterfaceName: WideString;
   const DatabaseName: WideString;
   const DatasetName: WideString
): LinkedDataset

Описание параметров

InterfaceName
[in] Имя интерфейса с базой данных
DatabaseName
[in] Имя базы данных интерфейса с базой данных
DatasetName
[in] Имя набора данных базы данных интерфейса с базой данных

Возвращаемое значение

Возвращает набор данных по заданным коду или Nothing, если такового не удалось найти

Смотри также

Class DatabaseInterfaces, Class LinkedDataset, Group Интерфейсы с базой данных


DatabaseInterfaces.FindInterfaceByID (метод)

Получить интерфейс по его идентификатору

Синтаксис

[Visual Basic 6]
Function FindInterfaceByID ( _
   ByVal InterfaceID As String _
) As DatabaseInterface

[Delphi]
function FindInterfaceByID(
   const InterfaceID: WideString
): DatabaseInterface

Описание параметров

InterfaceID
[in] Код интерфейса с базой данных

Возвращаемое значение

Возвращает интерфейс с базой данных по заданному коду или Nothing, если такового не удалось найти

Смотри также

Class DatabaseInterface, Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.FindInterfaceByName (метод)

Получить интерфейс по его имени

Синтаксис

[Visual Basic 6]
Function FindInterfaceByName ( _
   ByVal InterfaceName As String _
) As DatabaseInterface

[Delphi]
function FindInterfaceByName(
   const InterfaceName: WideString
): DatabaseInterface

Описание параметров

InterfaceName
[in] Имя интерфейса с базой данных

Возвращаемое значение

Возвращает интерфейс с базой данных по заданному имени или Nothing, если такового не удалось найти

Смотри также

Class DatabaseInterface, Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.MakeInternal (метод)

Сделать интерфейс с указанным номером внутренним

Синтаксис

[Visual Basic 6]
Sub MakeInternal ( _
   ByVal Index As Long _
)

[Delphi]
procedure MakeInternal(
   const Index: Integer
)

Описание параметров

Index
[in] Номер интерфейса с базой данных

Смотри также

Class DatabaseInterfaces, Group Интерфейсы с базой данных


DatabaseInterfaces.PasteFromClipboard (метод)

Вставить из буфера интерфейс

Синтаксис

[Visual Basic 6]
Function PasteFromClipboard As DatabaseInterface

[Delphi]
function PasteFromClipboard: DatabaseInterface

Возвращаемое значение

Возвращает вставленный из буфера интерфейс с базой данных

Смотри также

Class DatabaseInterface, Class DatabaseInterfaces, Group Интерфейсы с базой данных


Класс Dataset

Набор данных

Наследование

Dataset Class LayerDataset

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Active | Открыт ли набор данных в настоящее время
Property BOF (только для чтения) | Курсор находится на начале набора данных
Property Bookmark | Закладка текущего положения в наборе данных
Property CanModify (только для чтения) | Возможно ли изменение набора данных
Property EOF (только для чтения) | Последняя запись набора данных
Property FieldCount (только для чтения) | Количество полей в наборе данных
Property Fields (только для чтения) | Массив полей набора данных
Property Filter | Фильтр на записи
Property Filtered | Включен ли фильтр
Property Index | Текущий индекс набора данных
Property Indexes (только для чтения) | Все индексы набора данных
Property IsEmpty (только для чтения) | Пуст ли набор данных (т.е. нет записей)
Property IsSequenced (только для чтения) | Можно использовать порядковые номера записей для перемещения по набору данных
Property RecNo | Номер текущей записи
Property RecordCount (только для чтения) | Количество записей в наборе данных

Методы класса

Имя | Описание
Method Append | Добавить в набор данных новую запись
Method Cancel | Отменить результаты редактирования
Method CheckBrowseMode | Перейти в режим просмотра
Method ClearFields | Очистить значения всех полей
Method Close | Закрыть набор данных
Method Delete | Удалить текущую запись
Method DisableControls | Запретить отображений изменений в визуальных элементах
Method Edit | Начать редактировать текущую запись
Method EnableControls | Разрешить отображений изменений в визуальных элементах
Method FieldByDisplayName | Получить поле по отображаемому имени
Method FieldByName | Получить поле по его имени
Method First | Перейти к первой записи набора данных
Method Insert | Вставить новую запись в набор данных
Method Last | Перейти к последней записи набора данных
Method Locate | Перейти к записи с заданными значениями ключевых полей
Method MoveBy | Переместиться по набору данных на заданное количество записей вперед или назад
Method Next | Перейти к следующей записи
Method Open | Открыть набор данных
Method Post | Сохранить результаты редактирования в наборе данных
Method Prior | Перейти к предыдущей записи
Method Refresh | Перечитать записи набора данных

Где используется

Класс | Член класса
Class Field | Property LookupDataset (свойство)
Class LinkedADOCustomDataset | Property Datasets (свойство) Method Open (метод)
Class LinkedADODataset | Property Datasets (свойство) Method Open (метод)
Class LinkedADOQuery | Property Datasets (свойство) Method Open (метод)
Class LinkedADOStoredProc | Property Datasets (свойство) Method Open (метод)
Class LinkedADOTable | Property Datasets (свойство) Method Open (метод)
Class LinkedBDEDataset | Property Datasets (свойство) Method Open (метод)
Class LinkedBDEQuery | Property Datasets (свойство) Method Open (метод)
Class LinkedBDEStoredProc | Property Datasets (свойство) Method Open (метод)
Class LinkedBDETable | Property Datasets (свойство) Method Open (метод)
Class LinkedClientDataset | Property Datasets (свойство) Method Open (метод)
Class LinkedDataset | Property Datasets (свойство) Method Open (метод)
Class LinkedIBDataset | Property Datasets (свойство) Method Open (метод)
Class LinkedIBQuery | Property Datasets (свойство) Method Open (метод)
Class LinkedIBStoredProc | Property Datasets (свойство) Method Open (метод)
Class LinkedIBTable | Property Datasets (свойство) Method Open (метод)
Class LinkedUniDataset | Property Datasets (свойство) Method Open (метод)
Class LinkedUniQuery | Property Datasets (свойство) Method Open (метод)
Class LinkedUniStoredProc | Property Datasets (свойство) Method Open (метод)
Class LinkedUniTable | Property Datasets (свойство) Method Open (метод)

Смотри также

Group Базы данных


Dataset.Active (свойство)

Открыт ли набор данных в настоящее время

Синтаксис

[Visual Basic 6]
Property Active As Boolean

[Delphi]
property Active: WordBool

Смотри также

Class Dataset, Group Базы данных


Dataset.BOF (свойство)

Курсор находится на начале набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property BOF As Boolean

[Delphi]
{только для чтения} property BOF: WordBool

Смотри также

Class Dataset, Group Базы данных


Dataset.Bookmark (свойство)

Закладка текущего положения в наборе данных

Синтаксис

[Visual Basic 6]
Property Bookmark As String

[Delphi]
property Bookmark: WideString

Смотри также

Class Dataset, Group Базы данных


Dataset.CanModify (свойство)

Возможно ли изменение набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property CanModify As Boolean

[Delphi]
{только для чтения} property CanModify: WordBool

Смотри также

Class Dataset, Group Базы данных


Dataset.EOF (свойство)

Последняя запись набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property EOF As Boolean

[Delphi]
{только для чтения} property EOF: WordBool

Смотри также

Class Dataset, Group Базы данных


Dataset.FieldCount (свойство)

Количество полей в наборе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldCount As Long

[Delphi]
{только для чтения} property FieldCount: Integer

Смотри также

Class Dataset, Group Базы данных


Dataset.Fields (свойство)

Массив полей набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Fields As Field

[Delphi]
{только для чтения} property Fields: Field

Смотри также

Class Dataset, Class Field, Group Базы данных


Dataset.Filter (свойство)

Фильтр на записи

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class Dataset, Group Базы данных


Dataset.Filtered (свойство)

Включен ли фильтр

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class Dataset, Group Базы данных


Dataset.Index (свойство)

Текущий индекс набора данных

Синтаксис

[Visual Basic 6]
Property Index As String

[Delphi]
property Index: WideString

Смотри также

Class Dataset, Group Базы данных


Dataset.Indexes (свойство)

Все индексы набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Indexes As String

[Delphi]
{только для чтения} property Indexes: WideString

Смотри также

Class Dataset, Group Базы данных


Dataset.IsEmpty (свойство)

Пуст ли набор данных (т.е. нет записей)

Синтаксис

[Visual Basic 6]
ReadOnly Property IsEmpty As Boolean

[Delphi]
{только для чтения} property IsEmpty: WordBool

Смотри также

Class Dataset, Group Базы данных


Dataset.IsSequenced (свойство)

Можно использовать порядковые номера записей для перемещения по набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property IsSequenced As Boolean

[Delphi]
{только для чтения} property IsSequenced: WordBool

Смотри также

Class Dataset, Group Базы данных


Dataset.RecNo (свойство)

Номер текущей записи

Синтаксис

[Visual Basic 6]
Property RecNo As Long

[Delphi]
property RecNo: Integer

Смотри также

Class Dataset, Group Базы данных


Dataset.RecordCount (свойство)

Количество записей в наборе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property RecordCount As Long

[Delphi]
{только для чтения} property RecordCount: Integer

Смотри также

Class Dataset, Group Базы данных


Dataset.Append (метод)

Добавить в набор данных новую запись

Синтаксис

[Visual Basic 6]
Sub Append

[Delphi]
procedure Append

Смотри также

Class Dataset, Group Базы данных


Dataset.Cancel (метод)

Отменить результаты редактирования

Синтаксис

[Visual Basic 6]
Sub Cancel

[Delphi]
procedure Cancel

Смотри также

Class Dataset, Group Базы данных


Dataset.CheckBrowseMode (метод)

Перейти в режим просмотра

Синтаксис

[Visual Basic 6]
Sub CheckBrowseMode

[Delphi]
procedure CheckBrowseMode

Смотри также

Class Dataset, Group Базы данных


Dataset.ClearFields (метод)

Очистить значения всех полей

Синтаксис

[Visual Basic 6]
Sub ClearFields

[Delphi]
procedure ClearFields

Смотри также

Class Dataset, Group Базы данных


Dataset.Close (метод)

Закрыть набор данных

Синтаксис

[Visual Basic 6]
Sub Close

[Delphi]
procedure Close

Смотри также

Class Dataset, Group Базы данных


Dataset.Delete (метод)

Удалить текущую запись

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class Dataset, Group Базы данных


Dataset.DisableControls (метод)

Запретить отображений изменений в визуальных элементах

Синтаксис

[Visual Basic 6]
Sub DisableControls

[Delphi]
procedure DisableControls

Смотри также

Class Dataset, Group Базы данных


Dataset.Edit (метод)

Начать редактировать текущую запись

Синтаксис

[Visual Basic 6]
Sub Edit

[Delphi]
procedure Edit

Смотри также

Class Dataset, Group Базы данных


Dataset.EnableControls (метод)

Разрешить отображений изменений в визуальных элементах

Синтаксис

[Visual Basic 6]
Sub EnableControls

[Delphi]
procedure EnableControls

Смотри также

Class Dataset, Group Базы данных


Dataset.FieldByDisplayName (метод)

Получить поле по отображаемому имени

Синтаксис

[Visual Basic 6]
Function FieldByDisplayName ( _
   ByVal DisplayName As String _
) As Field

[Delphi]
function FieldByDisplayName(
   const DisplayName: WideString
): Field

Описание параметров

DisplayName
[in] Отображаемое название поля

Возвращаемое значение

Возвращает поле с указанным отображаемым назанием полем, либо Nothing, если поля с таким названием не существует

Смотри также

Class Dataset, Class Field, Group Базы данных


Dataset.FieldByName (метод)

Получить поле по его имени

Синтаксис

[Visual Basic 6]
Function FieldByName ( _
   ByVal FieldName As String _
) As Field

[Delphi]
function FieldByName(
   const FieldName: WideString
): Field

Описание параметров

FieldName
[in] Имя поля

Возвращаемое значение

Возвращает поле с указанным именем, либо Nothing, если поля с таким именем не существует

Смотри также

Class Dataset, Class Field, Group Базы данных


Dataset.First (метод)

Перейти к первой записи набора данных

Синтаксис

[Visual Basic 6]
Sub First

[Delphi]
procedure First

Смотри также

Class Dataset, Group Базы данных


Dataset.Insert (метод)

Вставить новую запись в набор данных

Синтаксис

[Visual Basic 6]
Sub Insert

[Delphi]
procedure Insert

Смотри также

Class Dataset, Group Базы данных


Dataset.Last (метод)

Перейти к последней записи набора данных

Синтаксис

[Visual Basic 6]
Sub Last

[Delphi]
procedure Last

Смотри также

Class Dataset, Group Базы данных


Dataset.Locate (метод)

Перейти к записи с заданными значениями ключевых полей

Синтаксис

[Visual Basic 6]
Function Locate ( _
   ByVal KeyFields As String, _
   ByVal KeyValues As Variant, _
   [ByVal CaseInsensitive As Boolean = False], _
   [ByVal PartialKey As Boolean = False] _
) As Boolean

[Delphi]
function Locate(
   const KeyFields: WideString;
   const KeyValues: Variant;
   const CaseInsensitive: WordBool;
   const PartialKey: WordBool
): WordBool

Описание параметров

KeyFields
[in] Список ключевых полей, разделенных точками с запятой
KeyValues
[in] Значение ключевого поля или массив значений ключевых полей
CaseInsensitive
[in] Если True, то при сравнении значений игнорировать различия в регистре букв
PartialKey
[in] Если True, то при сравнении достаточно, чтобы найденная запись хотя бы начиналась с заданного в KeyValues значения

Возвращаемое значение

Возвращает True, если запись с указанными значениями ключевым полей успешно найдена

Смотри также

Class Dataset, Group Базы данных


Dataset.MoveBy (метод)

Переместиться по набору данных на заданное количество записей вперед или назад

Синтаксис

[Visual Basic 6]
Sub MoveBy ( _
   ByVal Distance As Long _
)

[Delphi]
procedure MoveBy(
   const Distance: Integer
)

Описание параметров

Distance
[in] Количество записей, на котороые надо переместиться в наборе данных

Смотри также

Class Dataset, Group Базы данных


Dataset.Next (метод)

Перейти к следующей записи

Синтаксис

[Visual Basic 6]
Sub Next

[Delphi]
procedure Next

Смотри также

Class Dataset, Group Базы данных


Dataset.Open (метод)

Открыть набор данных

Синтаксис

[Visual Basic 6]
Sub Open

[Delphi]
procedure Open

Смотри также

Class Dataset, Group Базы данных


Dataset.Post (метод)

Сохранить результаты редактирования в наборе данных

Синтаксис

[Visual Basic 6]
Sub Post

[Delphi]
procedure Post

Смотри также

Class Dataset, Group Базы данных


Dataset.Prior (метод)

Перейти к предыдущей записи

Синтаксис

[Visual Basic 6]
Sub Prior

[Delphi]
procedure Prior

Смотри также

Class Dataset, Group Базы данных


Dataset.Refresh (метод)

Перечитать записи набора данных

Синтаксис

[Visual Basic 6]
Sub Refresh

[Delphi]
procedure Refresh

Смотри также

Class Dataset, Group Базы данных


Класс DatasetLink

Подключение набора данных

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AddMode | Режим добавления записей в подчиненный набор данных
Property Caption (только для чтения) | Название страницы - изменённое имя, имя набора данных или "Набор данных"
Property DatabaseId | Идентификатор базы данных в интерфейсе
Property DatasetID | Идентификатор набора данных в базе данных интерфейса
Property Description | Изменённое имя набора данных
Property DetailFields | Имя поля поключенного набора данных
Property ImageIndex (только для чтения) | Код иконки, ассоциированный с данным набором данных
Property InterfaceID | Идентификатор интерфейса
Property MasterFields | Имя главного атрибута слоя
Property Name (только для чтения) | Имя набора данных, как прописано в TLinkedDataset
Property Owner (только для чтения) | Хранящий данный элемент список страниц
Property ShowCaption | Показывать название подключенного набора данных перед списком полей
Property SubLinks (только для чтения) | Подсвязи набора

Методы класса

Имя | Описание
Method FindLinkedDataset | Установить связь с набором данных или вернуть Nothing
Method ModeDown | Переместиться в списке связей Owner на позицию ниже
Method MoveUp | Переместиться в списке связей Owner на позицию выше

Где используется

Класс | Член класса
Class DatasetLinks | Property Links (свойство) Method Add (метод)

Смотри также

Enum DatasetLinkAddConstants, Class LinkedDataset, Group Интерфейсы с базой данных


DatasetLink.AddMode (свойство)

Режим добавления записей в подчиненный набор данных

Синтаксис

[Visual Basic 6]
Property AddMode As DatasetLinkAddConstants

[Delphi]
property AddMode: DatasetLinkAddConstants

Смотри также

Class DatasetLink, Enum DatasetLinkAddConstants, Group Интерфейсы с базой данных


DatasetLink.Caption (свойство)

Название страницы - изменённое имя, имя набора данных или "Набор данных"

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.DatabaseId (свойство)

Идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
Property DatabaseId As Long

[Delphi]
property DatabaseId: Integer

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.DatasetID (свойство)

Идентификатор набора данных в базе данных интерфейса

Синтаксис

[Visual Basic 6]
Property DatasetID As Long

[Delphi]
property DatasetID: Integer

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.Description (свойство)

Изменённое имя набора данных

Синтаксис

[Visual Basic 6]
Property Description As String

[Delphi]
property Description: WideString

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.DetailFields (свойство)

Имя поля поключенного набора данных

Синтаксис

[Visual Basic 6]
Property DetailFields As String

[Delphi]
property DetailFields: WideString

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.ImageIndex (свойство)

Код иконки, ассоциированный с данным набором данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.InterfaceID (свойство)

Идентификатор интерфейса

Синтаксис

[Visual Basic 6]
Property InterfaceID As String

[Delphi]
property InterfaceID: WideString

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.MasterFields (свойство)

Имя главного атрибута слоя

Синтаксис

[Visual Basic 6]
Property MasterFields As String

[Delphi]
property MasterFields: WideString

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.Name (свойство)

Имя набора данных, как прописано в TLinkedDataset

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.Owner (свойство)

Хранящий данный элемент список страниц

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As DatasetLinks

[Delphi]
{только для чтения} property Owner: DatasetLinks

Смотри также

Class DatasetLink, Class DatasetLinks, Group Интерфейсы с базой данных


DatasetLink.ShowCaption (свойство)

Показывать название подключенного набора данных перед списком полей

Синтаксис

[Visual Basic 6]
Property ShowCaption As Boolean

[Delphi]
property ShowCaption: WordBool

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.SubLinks (свойство)

Подсвязи набора

Синтаксис

[Visual Basic 6]
ReadOnly Property SubLinks As DatasetLinks

[Delphi]
{только для чтения} property SubLinks: DatasetLinks

Смотри также

Class DatasetLink, Class DatasetLinks, Group Интерфейсы с базой данных


DatasetLink.FindLinkedDataset (метод)

Установить связь с набором данных или вернуть Nothing

Синтаксис

[Visual Basic 6]
Function FindLinkedDataset As LinkedDataset

[Delphi]
function FindLinkedDataset: LinkedDataset

Возвращаемое значение

Возвращает найденный связанный набор данных из интерфейса с базой данных или Nothing, если такового не удалось найти

Смотри также

Class DatasetLink, Class LinkedDataset, Group Интерфейсы с базой данных


DatasetLink.ModeDown (метод)

Переместиться в списке связей Owner на позицию ниже

Синтаксис

[Visual Basic 6]
Sub ModeDown

[Delphi]
procedure ModeDown

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


DatasetLink.MoveUp (метод)

Переместиться в списке связей Owner на позицию выше

Синтаксис

[Visual Basic 6]
Sub MoveUp

[Delphi]
procedure MoveUp

Смотри также

Class DatasetLink, Group Интерфейсы с базой данных


Класс DatasetLinks

Список подключений наборов данных

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество подключений
Property Links (только для чтения) | Массив подключений

Методы класса

Имя | Описание
Method Add | Добавить новую страницу
Method Delete | Удалить страницу с номером Index
Method Move | Переместить страницы с номерами FromIndex, ToIndex

Где используется

Класс | Член класса
Class DatasetLink | Property Owner (свойство) Property SubLinks (свойство)
Class VectorLayer | Property DatasetLinks (свойство) Property DefIdDatasetLinks (свойство)

Смотри также

Group Интерфейсы с базой данных


DatasetLinks.Count (свойство)

Количество подключений

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class DatasetLinks, Group Интерфейсы с базой данных


DatasetLinks.Links (свойство)

Массив подключений

Синтаксис

[Visual Basic 6]
ReadOnly Property Links As DatasetLink

[Delphi]
{только для чтения} property Links: DatasetLink

Смотри также

Class DatasetLink, Class DatasetLinks, Group Интерфейсы с базой данных


DatasetLinks.Add (метод)

Добавить новую страницу

Синтаксис

[Visual Basic 6]
Function Add As DatasetLink

[Delphi]
function Add: DatasetLink

Возвращаемое значение

Возвращает добавленную страницу

Смотри также

Class DatasetLink, Class DatasetLinks, Group Интерфейсы с базой данных


DatasetLinks.Delete (метод)

Удалить страницу с номером Index

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер страницы

Смотри также

Class DatasetLinks, Group Интерфейсы с базой данных


DatasetLinks.Move (метод)

Переместить страницы с номерами FromIndex, ToIndex

Синтаксис

[Visual Basic 6]
Sub Move ( _
   ByVal FromIndex As Long, _
   ByVal ToIndex As Long _
)

[Delphi]
procedure Move(
   const FromIndex: Integer;
   const ToIndex: Integer
)

Описание параметров

FromIndex
[in] Номер перемещаемой страницы
ToIndex
[in] Новое положение перемещаемой страницы

Смотри также

Class DatasetLinks, Group Интерфейсы с базой данных


Класс Depository

Хранилище пользовательских переменных

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество хранящихся переменных
Property Name (только для чтения) | Массив имен переменных
Property Value | Значение переменной по номеру или имени (допустимы значения: строчные, целые, вещественные, логические, дата, массивы, пусто и нуль)

Методы класса

Имя | Описание
Method Clear | Очистить хранилище
Method Delete | Удалить переменную по номеру или имени
Method Exists | Проверить, существует ли переменная с заданным именем
Method IndexOf | Номер переменной с заданным именем

Где используется

Класс | Член класса
Class Composition | Property Depository (свойство)
Class LayeredComposition | Property Depository (свойство)

Смотри также

Group Хранилища объектов


Depository.Count (свойство)

Количество хранящихся переменных

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class Depository, Group Хранилища объектов


Depository.Name (свойство)

Массив имен переменных

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class Depository, Group Хранилища объектов


Depository.Value (свойство)

Значение переменной по номеру или имени (допустимы значения: строчные, целые, вещественные, логические, дата, массивы, пусто и нуль)

Синтаксис

[Visual Basic 6]
Property Value

[Delphi]
property Value

Смотри также

Class Depository, Group Хранилища объектов


Depository.Clear (метод)

Очистить хранилище

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class Depository, Group Хранилища объектов


Depository.Delete (метод)

Удалить переменную по номеру или имени

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal IndexOrName As Variant _
)

[Delphi]
procedure Delete(
   const IndexOrName: Variant
)

Описание параметров

IndexOrName
[in] Индекс переменной или её имя

Смотри также

Class Depository, Group Хранилища объектов


Depository.Exists (метод)

Проверить, существует ли переменная с заданным именем

Синтаксис

[Visual Basic 6]
Function Exists ( _
   ByVal Name As String _
) As Boolean

[Delphi]
function Exists(
   const Name: WideString
): WordBool

Описание параметров

Name
[in] Проверяемое имя переменной

Возвращаемое значение

Возвращает True, если указанная переменная существует в хранилище

Смотри также

Class Depository, Group Хранилища объектов


Depository.IndexOf (метод)

Номер переменной с заданным именем

Синтаксис

[Visual Basic 6]
Function IndexOf ( _
   ByVal Name As String _
) As Long

[Delphi]
function IndexOf(
   const Name: WideString
): Integer

Описание параметров

Name
[in] Имя переменной

Возвращаемое значение

Возвращает номер переменной с указанным именем

Смотри также

Class Depository, Group Хранилища объектов


Класс DoubleCollection

Коллекция вещественных чисел

Наследование

CustomCollection Class DoubleCollection

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.DoubleCollection

ClassID = {6002000A-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество объектов списке
Property Items | Массив элементов коллекции

Методы класса

Имя | Описание
Method Add | Добавить новое число в коллекцию
Method AddItems | Добавить несколько чисел в коллекцию
Method Clear | Удаляет все элементы из коллекции
Method Delete | Удаляет элемент из коллекции
Method Invert | Меняет порядок элементов в коллекции на обратный
Method Sort | Выполнить сортировку чисел по возрастанию

Где используется

Класс | Член класса
Class CADTriangulation | Method BuildIsoexpos (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод) Method ValidateLevels (метод) Method ZeroEarthVolumes (метод)
Class Route | Method FindCrossPoints (метод) Method RepresentCodedLineAsPolyline (метод)
Class Triangulation | Method BuildIsoexpos (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод) Method ValidateLevels (метод) Method ZeroEarthVolumes (метод)
Class TrnTools | Method BuildAccesibilyAreas (метод) Method SplitStripPicket (метод)

Смотри также

Group Хранилища объектов


DoubleCollection.Count (свойство)

Количество объектов списке

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class DoubleCollection, Group Хранилища объектов


DoubleCollection.Items (свойство)

Массив элементов коллекции

Синтаксис

[Visual Basic 6]
Property Items As Double

[Delphi]
property Items: Double

Смотри также

Class DoubleCollection, Group Хранилища объектов


DoubleCollection.Add (метод)

Добавить новое число в коллекцию

Синтаксис

[Visual Basic 6]
Sub Add ( _
   ByVal Number As Double _
)

[Delphi]
procedure Add(
   const Number: Double
)

Описание параметров

Number
[in] Добавляемое в коллекцию число

Смотри также

Class DoubleCollection, Group Хранилища объектов


DoubleCollection.AddItems (метод)

Добавить несколько чисел в коллекцию

Синтаксис

[Visual Basic 6]
Sub AddItems ( _
   ParamArray Numbers() As Variant _
)

[Delphi]
procedure AddItems(
   const Numbers: PSafeArray
)

Описание параметров

Numbers
[in] Добавляемые в коллекцию числа

Смотри также

Class DoubleCollection, Group Хранилища объектов


DoubleCollection.Clear (метод)

Удаляет все элементы из коллекции

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class DoubleCollection, Group Хранилища объектов


DoubleCollection.Delete (метод)

Удаляет элемент из коллекции

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер элемента в коллекции

Смотри также

Class DoubleCollection, Group Хранилища объектов


DoubleCollection.Invert (метод)

Меняет порядок элементов в коллекции на обратный

Синтаксис

[Visual Basic 6]
Sub Invert

[Delphi]
procedure Invert

Смотри также

Class DoubleCollection, Group Хранилища объектов


DoubleCollection.Sort (метод)

Выполнить сортировку чисел по возрастанию

Синтаксис

[Visual Basic 6]
Sub Sort

[Delphi]
procedure Sort

Смотри также

Class DoubleCollection, Group Хранилища объектов


Класс DrawingSheet

Лист чертежа плана

Наследование

BaseObject Class DrawingSheet

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Angle | Угол, на который повёрнут лист
Property Application (только для чтения) | Приложение, в котором существует объект
Property BottomMargin | Нижнее поле листа в миллиметрах
Property Handle (только для чтения) | Handle объекта
Property Height | Высота листа в мм
Property ID (только для чтения) | ID объекта
Property LeftMargin | Левое поле листа в миллиметрах
Property Project (только для чтения) | Проект, к которому относится объект
Property RightMargin | Правое поле листа в миллиметрах
Property TopMargin | Верхнее поле листа в миллиметрах
Property Width | Ширина листа в мм
Property X | Модельная X-координата центра листа
Property Y | Модельная Y-координата центра листа

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Где используется

Класс | Член класса
Class DrawingSheets | Property Sheets (свойство)

Смотри также

Class Application, Class Project, Group Проекты


DrawingSheet.Angle (свойство)

Угол, на который повёрнут лист

Синтаксис

[Visual Basic 6]
Property Angle As Double

[Delphi]
property Angle: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class DrawingSheet, Group Проекты


DrawingSheet.BottomMargin (свойство)

Нижнее поле листа в миллиметрах

Синтаксис

[Visual Basic 6]
Property BottomMargin As Double

[Delphi]
property BottomMargin: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.Height (свойство)

Высота листа в мм

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.LeftMargin (свойство)

Левое поле листа в миллиметрах

Синтаксис

[Visual Basic 6]
Property LeftMargin As Double

[Delphi]
property LeftMargin: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class DrawingSheet, Class Project, Group Проекты


DrawingSheet.RightMargin (свойство)

Правое поле листа в миллиметрах

Синтаксис

[Visual Basic 6]
Property RightMargin As Double

[Delphi]
property RightMargin: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.TopMargin (свойство)

Верхнее поле листа в миллиметрах

Синтаксис

[Visual Basic 6]
Property TopMargin As Double

[Delphi]
property TopMargin: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.Width (свойство)

Ширина листа в мм

Синтаксис

[Visual Basic 6]
Property Width As Double

[Delphi]
property Width: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.X (свойство)

Модельная X-координата центра листа

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.Y (свойство)

Модельная Y-координата центра листа

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class DrawingSheet, Group Проекты


DrawingSheet.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class DrawingSheet, Group Проекты


Класс DrawingSheets

Листы чертежа плана

Наследование

BaseObject Class DrawingSheets

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Count (только для чтения) | Количество объектов, которое содержит в себе данный объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Массив объектов (нумерация идёт от 0 до Count-1)
Property NewSheetBottomMargin | Нижнее поле вновь создаваемых листов в миллиметрах
Property NewSheetHeight | Высота вновь создаваемых листов в миллиметрах
Property NewSheetLeftMargin | Левое поле вновь создаваемых листов в миллиметрах
Property NewSheetRightMargin | Правое поле вновь создаваемых листов в миллиметрах
Property NewSheetTopMargin | Верхнее поле вновь создаваемых листов в миллиметрах
Property NewSheetWidth | Ширина вновь создаваемых листов в миллиметрах
Property Project (только для чтения) | Проект, к которому относится объект
Property Sheets (только для чтения) | Массив листов чертежа (нумерация идёт от 0 до Count-1)
Property Visible | Отображаются ли листы чертежа на плане

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Clear | Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект
Method Delete | Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method SetupSelectedSheets | Вызвать диалог редактирования свойств выделенных листов

Где используется

Класс | Член класса
Class Project | Property DrawingSheets (свойство)

Смотри также

Class Application, Class BaseObject, Class DrawingSheet, Group Проекты


DrawingSheets.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class DrawingSheets, Group Проекты


DrawingSheets.Count (свойство)

Количество объектов, которое содержит в себе данный объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.Items (свойство)

Массив объектов (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BaseObject

[Delphi]
{только для чтения} property Items: BaseObject

Смотри также

Class BaseObject, Class DrawingSheets, Group Проекты


DrawingSheets.NewSheetBottomMargin (свойство)

Нижнее поле вновь создаваемых листов в миллиметрах

Синтаксис

[Visual Basic 6]
Property NewSheetBottomMargin As Double

[Delphi]
property NewSheetBottomMargin: Double

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.NewSheetHeight (свойство)

Высота вновь создаваемых листов в миллиметрах

Синтаксис

[Visual Basic 6]
Property NewSheetHeight As Double

[Delphi]
property NewSheetHeight: Double

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.NewSheetLeftMargin (свойство)

Левое поле вновь создаваемых листов в миллиметрах

Синтаксис

[Visual Basic 6]
Property NewSheetLeftMargin As Double

[Delphi]
property NewSheetLeftMargin: Double

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.NewSheetRightMargin (свойство)

Правое поле вновь создаваемых листов в миллиметрах

Синтаксис

[Visual Basic 6]
Property NewSheetRightMargin As Double

[Delphi]
property NewSheetRightMargin: Double

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.NewSheetTopMargin (свойство)

Верхнее поле вновь создаваемых листов в миллиметрах

Синтаксис

[Visual Basic 6]
Property NewSheetTopMargin As Double

[Delphi]
property NewSheetTopMargin: Double

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.NewSheetWidth (свойство)

Ширина вновь создаваемых листов в миллиметрах

Синтаксис

[Visual Basic 6]
Property NewSheetWidth As Double

[Delphi]
property NewSheetWidth: Double

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class DrawingSheets, Class Project, Group Проекты


DrawingSheets.Sheets (свойство)

Массив листов чертежа (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Sheets As DrawingSheet

[Delphi]
{только для чтения} property Sheets: DrawingSheet

Смотри также

Class DrawingSheet, Class DrawingSheets, Group Проекты


DrawingSheets.Visible (свойство)

Отображаются ли листы чертежа на плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.Clear (метод)

Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.Delete (метод)

Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс объекта (нумерация идёт от 0 до Count-1)

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class DrawingSheets, Group Проекты


DrawingSheets.SetupSelectedSheets (метод)

Вызвать диалог редактирования свойств выделенных листов

Синтаксис

[Visual Basic 6]
Function SetupSelectedSheets As Boolean

[Delphi]
function SetupSelectedSheets: WordBool

Возвращаемое значение

Результат операции: True - Пользователь завершил диалог кнопкой "OK", False - ошибка, либо пользователь завершил диалог кнопкой "Отмена"

Смотри также

Class DrawingSheets, Group Проекты


Класс Field

Поле набора данных

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Alignment (только для чтения) | Выравнивание значений поля
Property AsBoolean | Значение поля в виде логического значения
Property AsDateTime | Значение поля виде даты и времени
Property AsFloat | Значение поля в виде вещественного значения
Property AsInteger | Значение поля в виде целого числа
Property AsString | Значение поля в виде строки
Property Calculated (только для чтения) | Поле является вычисляемым
Property CanModify (только для чтения) | Можно ли изменять значение поля
Property DataType (только для чтения) | Тип данных поля
Property DefaultExpression (только для чтения) | Значение поля по умолчанию
Property DisplayName (только для чтения) | Метка поля
Property DisplayText (только для чтения) | Значение поля, отформатированное для отображения
Property DisplayWidth (только для чтения) | Ширина колонки таблицы
Property FieldName (только для чтения) | Имя поля
Property IsBlob (только для чтения) | BLOB-поле?
Property IsNull (только для чтения) | Значение поля пусто
Property KeyFields (только для чтения) | Поля набора данных, используемые для сопоставления с ключевыми полями подстановочного набора
Property Lookup (только для чтения) | Поле является подстановочным
Property LookupCache (только для чтения) | Кэшировать ли подстановочные значения
Property LookupDataset (только для чтения) | Подстановочный набор данных
Property LookupKeyFields (только для чтения) | Ключевые поля подстановочного набора данных
Property LookupResultField (только для чтения) | Результирующее поле подстановочного набора данных
Property Origin (только для чтения) | Имя поля физического набора данных, лежащего в основе данного
Property ReadOnly (только для чтения) | Внесение изменений в поле запрещено
Property Required (только для чтения) | Значение поле не может быть пустым
Property Size (только для чтения) | Размер поля
Property Value | Значение поля для текущей записи
Property Visible (только для чтения) | Поле видимо в диалогах

Методы класса

Имя | Описание
Method Clear | Очистить значение поля
Method FocusControl | Переместить фокус на любой визуальный элемент, редактирующий данное поле
Method RefreshLookupList | Обновить значения подстановочных полей

Где используется

Класс | Член класса
Class Dataset | Property Fields (свойство) Method FieldByDisplayName (метод) Method FieldByName (метод)
Class LayerDataset | Property Fields (свойство) Method FieldByDisplayName (метод) Method FieldByName (метод)

Смотри также

Enum AlignmentConstants, Enum FieldConstants, Group Базы данных


Field.Alignment (свойство)

Выравнивание значений поля

Синтаксис

[Visual Basic 6]
ReadOnly Property Alignment As AlignmentConstants

[Delphi]
{только для чтения} property Alignment: AlignmentConstants

Смотри также

Enum AlignmentConstants, Class Field, Group Базы данных


Field.AsBoolean (свойство)

Значение поля в виде логического значения

Синтаксис

[Visual Basic 6]
Property AsBoolean As Boolean

[Delphi]
property AsBoolean: WordBool

Смотри также

Class Field, Group Базы данных


Field.AsDateTime (свойство)

Значение поля виде даты и времени

Синтаксис

[Visual Basic 6]
Property AsDateTime As Double

[Delphi]
property AsDateTime: Double

Смотри также

Class Field, Group Базы данных


Field.AsFloat (свойство)

Значение поля в виде вещественного значения

Синтаксис

[Visual Basic 6]
Property AsFloat As Double

[Delphi]
property AsFloat: Double

Смотри также

Class Field, Group Базы данных


Field.AsInteger (свойство)

Значение поля в виде целого числа

Синтаксис

[Visual Basic 6]
Property AsInteger As Long

[Delphi]
property AsInteger: Integer

Смотри также

Class Field, Group Базы данных


Field.AsString (свойство)

Значение поля в виде строки

Синтаксис

[Visual Basic 6]
Property AsString As String

[Delphi]
property AsString: WideString

Смотри также

Class Field, Group Базы данных


Field.Calculated (свойство)

Поле является вычисляемым

Синтаксис

[Visual Basic 6]
ReadOnly Property Calculated As Boolean

[Delphi]
{только для чтения} property Calculated: WordBool

Смотри также

Class Field, Group Базы данных


Field.CanModify (свойство)

Можно ли изменять значение поля

Синтаксис

[Visual Basic 6]
ReadOnly Property CanModify As Boolean

[Delphi]
{только для чтения} property CanModify: WordBool

Смотри также

Class Field, Group Базы данных


Field.DataType (свойство)

Тип данных поля

Синтаксис

[Visual Basic 6]
ReadOnly Property DataType As FieldConstants

[Delphi]
{только для чтения} property DataType: FieldConstants

Смотри также

Class Field, Enum FieldConstants, Group Базы данных


Field.DefaultExpression (свойство)

Значение поля по умолчанию

Синтаксис

[Visual Basic 6]
ReadOnly Property DefaultExpression As String

[Delphi]
{только для чтения} property DefaultExpression: WideString

Смотри также

Class Field, Group Базы данных


Field.DisplayName (свойство)

Метка поля

Синтаксис

[Visual Basic 6]
ReadOnly Property DisplayName As String

[Delphi]
{только для чтения} property DisplayName: WideString

Смотри также

Class Field, Group Базы данных


Field.DisplayText (свойство)

Значение поля, отформатированное для отображения

Синтаксис

[Visual Basic 6]
ReadOnly Property DisplayText As String

[Delphi]
{только для чтения} property DisplayText: WideString

Смотри также

Class Field, Group Базы данных


Field.DisplayWidth (свойство)

Ширина колонки таблицы

Синтаксис

[Visual Basic 6]
ReadOnly Property DisplayWidth As Long

[Delphi]
{только для чтения} property DisplayWidth: Integer

Смотри также

Class Field, Group Базы данных


Field.FieldName (свойство)

Имя поля

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldName As String

[Delphi]
{только для чтения} property FieldName: WideString

Смотри также

Class Field, Group Базы данных


Field.IsBlob (свойство)

BLOB-поле?

Синтаксис

[Visual Basic 6]
ReadOnly Property IsBlob As Boolean

[Delphi]
{только для чтения} property IsBlob: WordBool

Смотри также

Class Field, Group Базы данных


Field.IsNull (свойство)

Значение поля пусто

Синтаксис

[Visual Basic 6]
ReadOnly Property IsNull As Boolean

[Delphi]
{только для чтения} property IsNull: WordBool

Смотри также

Class Field, Group Базы данных


Field.KeyFields (свойство)

Поля набора данных, используемые для сопоставления с ключевыми полями подстановочного набора

Синтаксис

[Visual Basic 6]
ReadOnly Property KeyFields As String

[Delphi]
{только для чтения} property KeyFields: WideString

Смотри также

Class Field, Group Базы данных


Field.Lookup (свойство)

Поле является подстановочным

Синтаксис

[Visual Basic 6]
ReadOnly Property Lookup As Boolean

[Delphi]
{только для чтения} property Lookup: WordBool

Смотри также

Class Field, Group Базы данных


Field.LookupCache (свойство)

Кэшировать ли подстановочные значения

Синтаксис

[Visual Basic 6]
ReadOnly Property LookupCache As Boolean

[Delphi]
{только для чтения} property LookupCache: WordBool

Смотри также

Class Field, Group Базы данных


Field.LookupDataset (свойство)

Подстановочный набор данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LookupDataset As Dataset

[Delphi]
{только для чтения} property LookupDataset: Dataset

Смотри также

Class Dataset, Class Field, Group Базы данных


Field.LookupKeyFields (свойство)

Ключевые поля подстановочного набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LookupKeyFields As String

[Delphi]
{только для чтения} property LookupKeyFields: WideString

Смотри также

Class Field, Group Базы данных


Field.LookupResultField (свойство)

Результирующее поле подстановочного набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LookupResultField As String

[Delphi]
{только для чтения} property LookupResultField: WideString

Смотри также

Class Field, Group Базы данных


Field.Origin (свойство)

Имя поля физического набора данных, лежащего в основе данного

Синтаксис

[Visual Basic 6]
ReadOnly Property Origin As String

[Delphi]
{только для чтения} property Origin: WideString

Смотри также

Class Field, Group Базы данных


Field.ReadOnly (свойство)

Внесение изменений в поле запрещено

Синтаксис

[Visual Basic 6]
ReadOnly Property ReadOnly As Boolean

[Delphi]
{только для чтения} property ReadOnly: WordBool

Смотри также

Class Field, Group Базы данных


Field.Required (свойство)

Значение поле не может быть пустым

Синтаксис

[Visual Basic 6]
ReadOnly Property Required As Boolean

[Delphi]
{только для чтения} property Required: WordBool

Смотри также

Class Field, Group Базы данных


Field.Size (свойство)

Размер поля

Синтаксис

[Visual Basic 6]
ReadOnly Property Size As Long

[Delphi]
{только для чтения} property Size: Integer

Смотри также

Class Field, Group Базы данных


Field.Value (свойство)

Значение поля для текущей записи

Синтаксис

[Visual Basic 6]
Property Value

[Delphi]
property Value

Смотри также

Class Field, Group Базы данных


Field.Visible (свойство)

Поле видимо в диалогах

Синтаксис

[Visual Basic 6]
ReadOnly Property Visible As Boolean

[Delphi]
{только для чтения} property Visible: WordBool

Смотри также

Class Field, Group Базы данных


Field.Clear (метод)

Очистить значение поля

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class Field, Group Базы данных


Field.FocusControl (метод)

Переместить фокус на любой визуальный элемент, редактирующий данное поле

Синтаксис

[Visual Basic 6]
Sub FocusControl

[Delphi]
procedure FocusControl

Смотри также

Class Field, Group Базы данных


Field.RefreshLookupList (метод)

Обновить значения подстановочных полей

Синтаксис

[Visual Basic 6]
Sub RefreshLookupList

[Delphi]
procedure RefreshLookupList

Смотри также

Class Field, Group Базы данных


Класс FieldTraverse

Теодолитный ход

Наследование

Measuring Class FieldTraverse

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AbsLengthDiscrepancy (только для чтения) | Абсолютная невязка
Property AdditionalPointCount (только для чтения) | Количество дополнительных точек
Property AdditionalPoints (только для чтения) | Массив дополнительных точек
Property AimingBeginPoint (только для чтения) | Начальная точка наведения теодолитного хода
Property AimingEndPoint (только для чтения) | Конечная точка наведения теодолитного хода
Property AngleDiscrepancy (только для чтения) | Угловая невязка
Property AngleDiscrepancyLimit | Коэффициент в формуле допустимой угловой невязки
Property AnglesAreLeft | Измеренные углы являются левыми (в противном случае - правыми)
Property BeginDirAngle | Начальный примычной дирекционный угол теодолитного хода
Property BeginPoint (только для чтения) | Начальная точка теодолитного хода
Property Date | Дата выполнения измерений
Property EndDirAngle | Конечный примычной дирекционный угол теодолитного хода
Property EndPoint (только для чтения) | Конечная точка теодолитного хода
Property FieldTraverseType | Тип теодолитного хода
Property FirstStationHorzAngle | Горизонтальный угол, измеренный на первой станции хода
Property FullLength (только для чтения) | Полная длина хода
Property Handle (только для чтения) | Handle объекта
Property HeightDiscrepancy (только для чтения) | Невязка превышений
Property HeightDiscrepancyLimit | Коэффициент в формуле допустимой невязки превышений
Property HorzAngleCorrection | Поправка прибора для горизонтального угла
Property IsAimingDirAngle | Начальный и конечный примычные углы заданы дирекционными углами, в противном случае - координатами
Property LastStation (только для чтения) | Измерения последней станции теодолитного хода
Property LastStationHorzAngle | Горизонтальный угол, измеренный на последней станции хода
Property LengthCorrection | Поправка прибора для расстояний
Property LengthDiscrepancyLimit | Частное в формуле допустимой невязки длин
Property Name | Наименование съёмки
Property RelativeLengthDiscrepancy (только для чтения) | Относительная невязка
Property StationCount (только для чтения) | Количество станций теодолитного хода
Property Stations (только для чтения) | Массив станций теодолитного хода
Property SurveyCount (только для чтения) | Количество пикетажных съёмок в ходе
Property Surveys (только для чтения) | Массив пикетажных съёмок
Property VertAngleCorrection | Поправка прибора для вертикального угла
Property VertAnglesAreFromZenith | Вертикальный угол измеряется от зенита (в противном случае - от горизонта)
Property Visible | Видима ли съёмка на плане

Методы класса

Имя | Описание
Method AddAdditionalPoint | Добавить дополнительную точку в ход
Method AddStation | Добавить станцию в теодолитный ход
Method AddSurvey | Добавить съёмку в ход
Method DeleteAdditionalPoint | Удалить дополнительную точку
Method DeleteStation | Удалить станцию теодолитного хода
Method DeleteSurvey | Удалить съёмку по номеру
Method RemoveSurvey | Удалить съёмку
Method SurveyByName | Найти пикетажную съёмку по имени

Где используется

Класс | Член класса
Class GeodesyBook | Property FieldTraverses (свойство) Method AddFieldTraverse (метод) Method FieldTraverseByName (метод) Method RemoveFieldTraverse (метод)
Class SurveyEditor | Property ActiveFieldTraverse (свойство)

Смотри также

Class AdditionalPoint, Enum FieldTraverseConstants, Class FieldTraversePoint, Class GeodesyAngle, Enum IntersectionConstants, Class LinkedGeoPoint, Class Survey, Group Геодезия


FieldTraverse.AbsLengthDiscrepancy (свойство)

Абсолютная невязка

Синтаксис

[Visual Basic 6]
ReadOnly Property AbsLengthDiscrepancy As Double

[Delphi]
{только для чтения} property AbsLengthDiscrepancy: Double

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.AdditionalPointCount (свойство)

Количество дополнительных точек

Синтаксис

[Visual Basic 6]
ReadOnly Property AdditionalPointCount As Long

[Delphi]
{только для чтения} property AdditionalPointCount: Integer

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.AdditionalPoints (свойство)

Массив дополнительных точек

Синтаксис

[Visual Basic 6]
ReadOnly Property AdditionalPoints As AdditionalPoint

[Delphi]
{только для чтения} property AdditionalPoints: AdditionalPoint

Смотри также

Class AdditionalPoint, Class FieldTraverse, Group Геодезия


FieldTraverse.AimingBeginPoint (свойство)

Начальная точка наведения теодолитного хода

Синтаксис

[Visual Basic 6]
ReadOnly Property AimingBeginPoint As LinkedGeoPoint

[Delphi]
{только для чтения} property AimingBeginPoint: LinkedGeoPoint

Смотри также

Class FieldTraverse, Class LinkedGeoPoint, Group Геодезия


FieldTraverse.AimingEndPoint (свойство)

Конечная точка наведения теодолитного хода

Синтаксис

[Visual Basic 6]
ReadOnly Property AimingEndPoint As LinkedGeoPoint

[Delphi]
{только для чтения} property AimingEndPoint: LinkedGeoPoint

Смотри также

Class FieldTraverse, Class LinkedGeoPoint, Group Геодезия


FieldTraverse.AngleDiscrepancy (свойство)

Угловая невязка

Синтаксис

[Visual Basic 6]
ReadOnly Property AngleDiscrepancy As GeodesyAngle

[Delphi]
{только для чтения} property AngleDiscrepancy: GeodesyAngle

Смотри также

Class FieldTraverse, Class GeodesyAngle, Group Геодезия


FieldTraverse.AngleDiscrepancyLimit (свойство)

Коэффициент в формуле допустимой угловой невязки

Синтаксис

[Visual Basic 6]
Property AngleDiscrepancyLimit As Double

[Delphi]
property AngleDiscrepancyLimit: Double

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.AnglesAreLeft (свойство)

Измеренные углы являются левыми (в противном случае - правыми)

Синтаксис

[Visual Basic 6]
Property AnglesAreLeft As Boolean

[Delphi]
property AnglesAreLeft: WordBool

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.BeginDirAngle (свойство)

Начальный примычной дирекционный угол теодолитного хода

Синтаксис

[Visual Basic 6]
Property BeginDirAngle As GeodesyAngle

[Delphi]
property BeginDirAngle: GeodesyAngle

Смотри также

Class FieldTraverse, Class GeodesyAngle, Group Геодезия


FieldTraverse.BeginPoint (свойство)

Начальная точка теодолитного хода

Синтаксис

[Visual Basic 6]
ReadOnly Property BeginPoint As FieldTraversePoint

[Delphi]
{только для чтения} property BeginPoint: FieldTraversePoint

Смотри также

Class FieldTraverse, Class FieldTraversePoint, Group Геодезия


FieldTraverse.Date (свойство)

Дата выполнения измерений

Синтаксис

[Visual Basic 6]
Property Date As Date

[Delphi]
property Date: TDateTime

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.EndDirAngle (свойство)

Конечный примычной дирекционный угол теодолитного хода

Синтаксис

[Visual Basic 6]
Property EndDirAngle As GeodesyAngle

[Delphi]
property EndDirAngle: GeodesyAngle

Смотри также

Class FieldTraverse, Class GeodesyAngle, Group Геодезия


FieldTraverse.EndPoint (свойство)

Конечная точка теодолитного хода

Синтаксис

[Visual Basic 6]
ReadOnly Property EndPoint As FieldTraversePoint

[Delphi]
{только для чтения} property EndPoint: FieldTraversePoint

Смотри также

Class FieldTraverse, Class FieldTraversePoint, Group Геодезия


FieldTraverse.FieldTraverseType (свойство)

Тип теодолитного хода

Синтаксис

[Visual Basic 6]
Property FieldTraverseType As FieldTraverseConstants

[Delphi]
property FieldTraverseType: FieldTraverseConstants

Смотри также

Class FieldTraverse, Enum FieldTraverseConstants, Group Геодезия


FieldTraverse.FirstStationHorzAngle (свойство)

Горизонтальный угол, измеренный на первой станции хода

Синтаксис

[Visual Basic 6]
Property FirstStationHorzAngle As GeodesyAngle

[Delphi]
property FirstStationHorzAngle: GeodesyAngle

Смотри также

Class FieldTraverse, Class GeodesyAngle, Group Геодезия


FieldTraverse.FullLength (свойство)

Полная длина хода

Синтаксис

[Visual Basic 6]
ReadOnly Property FullLength As Double

[Delphi]
{только для чтения} property FullLength: Double

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.HeightDiscrepancy (свойство)

Невязка превышений

Синтаксис

[Visual Basic 6]
ReadOnly Property HeightDiscrepancy As Double

[Delphi]
{только для чтения} property HeightDiscrepancy: Double

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.HeightDiscrepancyLimit (свойство)

Коэффициент в формуле допустимой невязки превышений

Синтаксис

[Visual Basic 6]
Property HeightDiscrepancyLimit As Double

[Delphi]
property HeightDiscrepancyLimit: Double

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.HorzAngleCorrection (свойство)

Поправка прибора для горизонтального угла

Синтаксис

[Visual Basic 6]
Property HorzAngleCorrection As GeodesyAngle

[Delphi]
property HorzAngleCorrection: GeodesyAngle

Смотри также

Class FieldTraverse, Class GeodesyAngle, Group Геодезия


FieldTraverse.IsAimingDirAngle (свойство)

Начальный и конечный примычные углы заданы дирекционными углами, в противном случае - координатами

Синтаксис

[Visual Basic 6]
Property IsAimingDirAngle As Boolean

[Delphi]
property IsAimingDirAngle: WordBool

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.LastStation (свойство)

Измерения последней станции теодолитного хода

Синтаксис

[Visual Basic 6]
ReadOnly Property LastStation As FieldTraversePoint

[Delphi]
{только для чтения} property LastStation: FieldTraversePoint

Смотри также

Class FieldTraverse, Class FieldTraversePoint, Group Геодезия


FieldTraverse.LastStationHorzAngle (свойство)

Горизонтальный угол, измеренный на последней станции хода

Синтаксис

[Visual Basic 6]
Property LastStationHorzAngle As GeodesyAngle

[Delphi]
property LastStationHorzAngle: GeodesyAngle

Смотри также

Class FieldTraverse, Class GeodesyAngle, Group Геодезия


FieldTraverse.LengthCorrection (свойство)

Поправка прибора для расстояний

Синтаксис

[Visual Basic 6]
Property LengthCorrection As Double

[Delphi]
property LengthCorrection: Double

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.LengthDiscrepancyLimit (свойство)

Частное в формуле допустимой невязки длин

Синтаксис

[Visual Basic 6]
Property LengthDiscrepancyLimit As Double

[Delphi]
property LengthDiscrepancyLimit: Double

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.Name (свойство)

Наименование съёмки

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.RelativeLengthDiscrepancy (свойство)

Относительная невязка

Синтаксис

[Visual Basic 6]
ReadOnly Property RelativeLengthDiscrepancy As Double

[Delphi]
{только для чтения} property RelativeLengthDiscrepancy: Double

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.StationCount (свойство)

Количество станций теодолитного хода

Синтаксис

[Visual Basic 6]
ReadOnly Property StationCount As Long

[Delphi]
{только для чтения} property StationCount: Integer

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.Stations (свойство)

Массив станций теодолитного хода

Синтаксис

[Visual Basic 6]
ReadOnly Property Stations As FieldTraversePoint

[Delphi]
{только для чтения} property Stations: FieldTraversePoint

Смотри также

Class FieldTraverse, Class FieldTraversePoint, Group Геодезия


FieldTraverse.SurveyCount (свойство)

Количество пикетажных съёмок в ходе

Синтаксис

[Visual Basic 6]
ReadOnly Property SurveyCount As Long

[Delphi]
{только для чтения} property SurveyCount: Integer

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.Surveys (свойство)

Массив пикетажных съёмок

Синтаксис

[Visual Basic 6]
ReadOnly Property Surveys As Survey

[Delphi]
{только для чтения} property Surveys: Survey

Смотри также

Class FieldTraverse, Class Survey, Group Геодезия


FieldTraverse.VertAngleCorrection (свойство)

Поправка прибора для вертикального угла

Синтаксис

[Visual Basic 6]
Property VertAngleCorrection As GeodesyAngle

[Delphi]
property VertAngleCorrection: GeodesyAngle

Смотри также

Class FieldTraverse, Class GeodesyAngle, Group Геодезия


FieldTraverse.VertAnglesAreFromZenith (свойство)

Вертикальный угол измеряется от зенита (в противном случае - от горизонта)

Синтаксис

[Visual Basic 6]
Property VertAnglesAreFromZenith As Boolean

[Delphi]
property VertAnglesAreFromZenith: WordBool

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.Visible (свойство)

Видима ли съёмка на плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.AddAdditionalPoint (метод)

Добавить дополнительную точку в ход

Синтаксис

[Visual Basic 6]
Function AddAdditionalPoint ( _
   ByVal IntersectionType As IntersectionConstants _
) As AdditionalPoint

[Delphi]
function AddAdditionalPoint(
   const IntersectionType: IntersectionConstants
): AdditionalPoint

Описание параметров

IntersectionType
[in] Тип дополнительной точки

Возвращаемое значение

Возвращает новую дополнительную точку

Смотри также

Class AdditionalPoint, Class FieldTraverse, Enum IntersectionConstants, Group Геодезия


FieldTraverse.AddStation (метод)

Добавить станцию в теодолитный ход

Синтаксис

[Visual Basic 6]
Function AddStation As FieldTraversePoint

[Delphi]
function AddStation: FieldTraversePoint

Возвращаемое значение

Возвращает новую станцию в теодолитном ходе

Смотри также

Class FieldTraverse, Class FieldTraversePoint, Group Геодезия


FieldTraverse.AddSurvey (метод)

Добавить съёмку в ход

Синтаксис

[Visual Basic 6]
Function AddSurvey As Survey

[Delphi]
function AddSurvey: Survey

Возвращаемое значение

Возвращает добавленную в ход пикетажную съёмку

Смотри также

Class FieldTraverse, Class Survey, Group Геодезия


FieldTraverse.DeleteAdditionalPoint (метод)

Удалить дополнительную точку

Синтаксис

[Visual Basic 6]
Sub DeleteAdditionalPoint ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteAdditionalPoint(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемой дополнительной точки (нумерация точек идёт от 0 до AdditionalPointCount(-1)

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.DeleteStation (метод)

Удалить станцию теодолитного хода

Синтаксис

[Visual Basic 6]
Sub DeleteStation ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteStation(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемой станции теодолитного хода (нумерация точек идёт от 0 до StationCount(-1)

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.DeleteSurvey (метод)

Удалить съёмку по номеру

Синтаксис

[Visual Basic 6]
Sub DeleteSurvey ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteSurvey(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемой съёмки (нумерация идёт от 0 до SurveyCount-1)

Смотри также

Class FieldTraverse, Group Геодезия


FieldTraverse.RemoveSurvey (метод)

Удалить съёмку

Синтаксис

[Visual Basic 6]
Sub RemoveSurvey ( _
   ByVal Survey As Survey _
)

[Delphi]
procedure RemoveSurvey(
   const Survey: Survey
)

Описание параметров

Survey
[in] Удаляемая съёмка

Смотри также

Class FieldTraverse, Class Survey, Group Геодезия


FieldTraverse.SurveyByName (метод)

Найти пикетажную съёмку по имени

Синтаксис

[Visual Basic 6]
Function SurveyByName ( _
   ByVal Name As String _
) As Survey

[Delphi]
function SurveyByName(
   const Name: WideString
): Survey

Описание параметров

Name
[in] Имя съёмки

Возвращаемое значение

Возвращает съёмку с указанным именем или Nothing, если съёмка не найдена

Смотри также

Class FieldTraverse, Class Survey, Group Геодезия


Класс FieldTraversePoint

Точка теодолитного хода

Наследование

GeoPoint Class LinkedGeoPoint Class CustomSurveyPoint Class FieldTraversePoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BackLength | Обратное расстояние
Property BackVaneHeight | Обратная высота линейки (вешки)
Property BackVertAngle | Обратный вертикальный угол
Property CorrectedDH (только для чтения) | Исправленное превышение
Property CorrectedDirAngle (только для чтения) | Исправленный дирекционный угол
Property CorrectedDX (только для чтения) | Исправленное приращение координаты Х
Property CorrectedDY (только для чтения) | Исправленное приращение координаты Y
Property CorrectedH (только для чтения) | Увязанная высота точки
Property CorrectedX (только для чтения) | Увязанная координата X точки
Property CorrectedY (только для чтения) | Увязанная координата Y точки
Property DH | Приращение высоты (превышение)
Property DirAngle | Дирекционный угол
Property DX (только для чтения) | Приращение координаты X (после увязывания углов)
Property DY (только для чтения) | Приращение координаты Y (после увязывания углов)
Property Fa (только для чтения) | Угловая невязка
Property Fh (только для чтения) | Невязка превышения
Property Fx (только для чтения) | Невязка по координате X
Property Fy (только для чтения) | Невязка по координате Y
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property HorzAngle | Измеренный горизонтальный угол
Property HorzLength | Горизонтальная длина (в проекции)
Property InstrumentHeight | Высота инструмента
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Length | Измеренное расстояние
Property LinkedPoint | Ссылка на другую точку
Property Number | Номер (описание) точки
Property Position | Положение точки
Property SourceStation (только для чтения) | Станция, с которой снята точка
Property VaneHeight | Высота линейки (вешки)
Property VertAngle | Вертикальный угол

Где используется

Класс | Член класса
Class FieldTraverse | Property BeginPoint (свойство) Property EndPoint (свойство) Property LastStation (свойство) Property Stations (свойство) Method AddStation (метод)

Смотри также

Class GeodesyAngle, Class GeoPoint, Class ModelPoint, Group Геодезия


FieldTraversePoint.BackLength (свойство)

Обратное расстояние

Синтаксис

[Visual Basic 6]
Property BackLength As Double

[Delphi]
property BackLength: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.BackVaneHeight (свойство)

Обратная высота линейки (вешки)

Синтаксис

[Visual Basic 6]
Property BackVaneHeight As Double

[Delphi]
property BackVaneHeight: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.BackVertAngle (свойство)

Обратный вертикальный угол

Синтаксис

[Visual Basic 6]
Property BackVertAngle As GeodesyAngle

[Delphi]
property BackVertAngle: GeodesyAngle

Смотри также

Class FieldTraversePoint, Class GeodesyAngle, Group Геодезия


FieldTraversePoint.CorrectedDH (свойство)

Исправленное превышение

Синтаксис

[Visual Basic 6]
ReadOnly Property CorrectedDH As Double

[Delphi]
{только для чтения} property CorrectedDH: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.CorrectedDirAngle (свойство)

Исправленный дирекционный угол

Синтаксис

[Visual Basic 6]
ReadOnly Property CorrectedDirAngle As GeodesyAngle

[Delphi]
{только для чтения} property CorrectedDirAngle: GeodesyAngle

Смотри также

Class FieldTraversePoint, Class GeodesyAngle, Group Геодезия


FieldTraversePoint.CorrectedDX (свойство)

Исправленное приращение координаты Х

Синтаксис

[Visual Basic 6]
ReadOnly Property CorrectedDX As Double

[Delphi]
{только для чтения} property CorrectedDX: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.CorrectedDY (свойство)

Исправленное приращение координаты Y

Синтаксис

[Visual Basic 6]
ReadOnly Property CorrectedDY As Double

[Delphi]
{только для чтения} property CorrectedDY: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.CorrectedH (свойство)

Увязанная высота точки

Синтаксис

[Visual Basic 6]
ReadOnly Property CorrectedH As Double

[Delphi]
{только для чтения} property CorrectedH: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.CorrectedX (свойство)

Увязанная координата X точки

Синтаксис

[Visual Basic 6]
ReadOnly Property CorrectedX As Double

[Delphi]
{только для чтения} property CorrectedX: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.CorrectedY (свойство)

Увязанная координата Y точки

Синтаксис

[Visual Basic 6]
ReadOnly Property CorrectedY As Double

[Delphi]
{только для чтения} property CorrectedY: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.DH (свойство)

Приращение высоты (превышение)

Синтаксис

[Visual Basic 6]
Property DH As Double

[Delphi]
property DH: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.DirAngle (свойство)

Дирекционный угол

Синтаксис

[Visual Basic 6]
Property DirAngle As GeodesyAngle

[Delphi]
property DirAngle: GeodesyAngle

Смотри также

Class FieldTraversePoint, Class GeodesyAngle, Group Геодезия


FieldTraversePoint.DX (свойство)

Приращение координаты X (после увязывания углов)

Синтаксис

[Visual Basic 6]
ReadOnly Property DX As Double

[Delphi]
{только для чтения} property DX: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.DY (свойство)

Приращение координаты Y (после увязывания углов)

Синтаксис

[Visual Basic 6]
ReadOnly Property DY As Double

[Delphi]
{только для чтения} property DY: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.Fa (свойство)

Угловая невязка

Синтаксис

[Visual Basic 6]
ReadOnly Property Fa As Double

[Delphi]
{только для чтения} property Fa: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.Fh (свойство)

Невязка превышения

Синтаксис

[Visual Basic 6]
ReadOnly Property Fh As Double

[Delphi]
{только для чтения} property Fh: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.Fx (свойство)

Невязка по координате X

Синтаксис

[Visual Basic 6]
ReadOnly Property Fx As Double

[Delphi]
{только для чтения} property Fx: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.Fy (свойство)

Невязка по координате Y

Синтаксис

[Visual Basic 6]
ReadOnly Property Fy As Double

[Delphi]
{только для чтения} property Fy: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.HorzAngle (свойство)

Измеренный горизонтальный угол

Синтаксис

[Visual Basic 6]
Property HorzAngle As GeodesyAngle

[Delphi]
property HorzAngle: GeodesyAngle

Смотри также

Class FieldTraversePoint, Class GeodesyAngle, Group Геодезия


FieldTraversePoint.HorzLength (свойство)

Горизонтальная длина (в проекции)

Синтаксис

[Visual Basic 6]
Property HorzLength As Double

[Delphi]
property HorzLength: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.InstrumentHeight (свойство)

Высота инструмента

Синтаксис

[Visual Basic 6]
Property InstrumentHeight As Double

[Delphi]
property InstrumentHeight: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.Length (свойство)

Измеренное расстояние

Синтаксис

[Visual Basic 6]
Property Length As Double

[Delphi]
property Length: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.LinkedPoint (свойство)

Ссылка на другую точку

Синтаксис

[Visual Basic 6]
Property LinkedPoint As GeoPoint

[Delphi]
property LinkedPoint: GeoPoint

Смотри также

Class FieldTraversePoint, Class GeoPoint, Group Геодезия


FieldTraversePoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class FieldTraversePoint, Class ModelPoint, Group Геодезия


FieldTraversePoint.SourceStation (свойство)

Станция, с которой снята точка

Синтаксис

[Visual Basic 6]
ReadOnly Property SourceStation As GeoPoint

[Delphi]
{только для чтения} property SourceStation: GeoPoint

Смотри также

Class FieldTraversePoint, Class GeoPoint, Group Геодезия


FieldTraversePoint.VaneHeight (свойство)

Высота линейки (вешки)

Синтаксис

[Visual Basic 6]
Property VaneHeight As Double

[Delphi]
property VaneHeight: Double

Смотри также

Class FieldTraversePoint, Group Геодезия


FieldTraversePoint.VertAngle (свойство)

Вертикальный угол

Синтаксис

[Visual Basic 6]
Property VertAngle As GeodesyAngle

[Delphi]
property VertAngle: GeodesyAngle

Смотри также

Class FieldTraversePoint, Class GeodesyAngle, Group Геодезия


Класс Figure

фигура

Наследование

Figure Class ShapeFigure, ShapeMultipart, ShapeMultipoint, ShapeMultipointM, ShapeMultipointZ, ShapePoint, ShapePointM, ShapePointZ, ShapePolygon, ShapePolygonM, ShapePolygonZ, ShapePolyline, ShapePolylineM, ShapePolylineZ, TrnArea, TrnBreak, TrnFigure, TrnFlip, TrnModifier, TrnNode, TrnRib, TrnSource, TrnTriangle

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Figure

ClassID = {60090003-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Owner (только для чтения) | Список-владелец данной фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class Figure | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class FigureSet | Property Figures (свойство)
Class LayerCalculator | Property Figure (свойство)
Class LayerDataset | Property AloneFigure (свойство) Property Figure (свойство)
Class ShapeFigure | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapeMultipart | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapeMultipoint | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapeMultipointM | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapeMultipointZ | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePoint | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePointM | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePointZ | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePolygon | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePolygonM | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePolygonZ | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePolyline | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePolylineM | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class ShapePolylineZ | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnArea | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnBreak | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnFigure | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnFlip | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnModifier | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnNode | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnRib | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnSource | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class TrnTriangle | Method Assign (метод) Method Clone (метод) Method CloneEmpty (метод)
Class VectorContainer | Property CurrentPopupFigure (свойство) Property EditedFigure (свойство) Property EditedFigures (свойство) Method FlashFigure (метод)
Class VectorLayer | Property Figures (свойство) Method ExecuteFigureVerb (метод) Method GetFigureAtPos (метод) Method GetFigureDescription (метод) Method GetFigureName (метод) Method GetFigureVerb (метод) Method GetFigureVerbCount (метод) Method GetSnapPoint (метод) Method GetSnapPointCount (метод) Method GetSnapSegment (метод) Method GetSnapSegmentCount (метод) Method HotLinkAction (метод) Method SnapFigure (метод)

Смотри также

Enum AdjustPointConstants, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Group фигуры


Figure.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class Figure, Class ModelRect, Group фигуры


Figure.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class Figure, Group фигуры


Figure.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class Figure, Group фигуры


Figure.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class Figure, Class FigureSet, Group фигуры


Figure.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class Figure, Group фигуры


Figure.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class Figure, Group фигуры


Figure.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class Figure, Group фигуры


Figure.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Figure, Group фигуры


Figure.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Group фигуры


Figure.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class Figure, Group фигуры


Figure.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Group фигуры


Figure.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Group фигуры


Figure.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class Figure, Group фигуры


Figure.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class Figure, Group фигуры


Figure.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class Figure, Group фигуры


Figure.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class Figure, Group фигуры


Figure.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class Figure, Group фигуры


Figure.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class Figure, Group фигуры


Figure.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class Figure, Class ModelPoint, Group фигуры


Figure.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class Figure, Group фигуры


Figure.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class Figure, Class ModelPoint, Group фигуры


Figure.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class Figure, Group фигуры


Figure.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class Figure, Group фигуры


Figure.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class Figure, Group фигуры


Figure.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class Figure, Group фигуры


Figure.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class Figure, Group фигуры


Figure.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Class Figure, Interface ICoordinateTransformer, Group фигуры


Класс FigureAttr

Определение атрибута элемента, хранящегося внутри элемента

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property DefaultValue | Значение по умолчанию в виде строки
Property DisplayName | Видимое название поля
Property FieldName | Имя поля
Property FieldType | Тип данных
Property Precision | Точность представления вещественных чисел после запятой
Property ReadOnly | Поле нельзя изменять в испекторах объектов и данных
Property Size | Размер поля
Property Visible | Поле видно в испекторах объектов и данных

Где используется

Класс | Член класса
Class FigureAttrs | Property Attrs (свойство) Method Add (метод)

Смотри также

Enum FieldConstants, Group Базы данных


FigureAttr.DefaultValue (свойство)

Значение по умолчанию в виде строки

Синтаксис

[Visual Basic 6]
Property DefaultValue As String

[Delphi]
property DefaultValue: WideString

Смотри также

Class FigureAttr, Group Базы данных


FigureAttr.DisplayName (свойство)

Видимое название поля

Синтаксис

[Visual Basic 6]
Property DisplayName As String

[Delphi]
property DisplayName: WideString

Смотри также

Class FigureAttr, Group Базы данных


FigureAttr.FieldName (свойство)

Имя поля

Синтаксис

[Visual Basic 6]
Property FieldName As String

[Delphi]
property FieldName: WideString

Смотри также

Class FigureAttr, Group Базы данных


FigureAttr.FieldType (свойство)

Тип данных

Синтаксис

[Visual Basic 6]
Property FieldType As FieldConstants

[Delphi]
property FieldType: FieldConstants

Смотри также

Enum FieldConstants, Class FigureAttr, Group Базы данных


FigureAttr.Precision (свойство)

Точность представления вещественных чисел после запятой

Синтаксис

[Visual Basic 6]
Property Precision As Long

[Delphi]
property Precision: Integer

Смотри также

Class FigureAttr, Group Базы данных


FigureAttr.ReadOnly (свойство)

Поле нельзя изменять в испекторах объектов и данных

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class FigureAttr, Group Базы данных


FigureAttr.Size (свойство)

Размер поля

Синтаксис

[Visual Basic 6]
Property Size As Long

[Delphi]
property Size: Integer

Смотри также

Class FigureAttr, Group Базы данных


FigureAttr.Visible (свойство)

Поле видно в испекторах объектов и данных

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class FigureAttr, Group Базы данных


Класс FigureAttrs

Список внутренних атрибутов элементов

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Attrs (только для чтения) | Массив атрибутов
Property Count (только для чтения) | Количество атрибутов

Методы класса

Имя | Описание
Method Add | Добавить новый атрибут
Method Clear | Удалить все атрибуты
Method Delete | Удалить атрибут по его номеру
Method Move | Переместить атрибут в списке из одной позиуию в другую

Смотри также

Class FigureAttr, Group Базы данных


FigureAttrs.Attrs (свойство)

Массив атрибутов

Синтаксис

[Visual Basic 6]
ReadOnly Property Attrs As FigureAttr

[Delphi]
{только для чтения} property Attrs: FigureAttr

Смотри также

Class FigureAttr, Class FigureAttrs, Group Базы данных


FigureAttrs.Count (свойство)

Количество атрибутов

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class FigureAttrs, Group Базы данных


FigureAttrs.Add (метод)

Добавить новый атрибут

Синтаксис

[Visual Basic 6]
Function Add As FigureAttr

[Delphi]
function Add: FigureAttr

Возвращаемое значение

Возвращает новый атрибут фигуры

Смотри также

Class FigureAttr, Class FigureAttrs, Group Базы данных


FigureAttrs.Clear (метод)

Удалить все атрибуты

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class FigureAttrs, Group Базы данных


FigureAttrs.Delete (метод)

Удалить атрибут по его номеру

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемого атрибута (нумерация идёт от 0 до Count-1)

Смотри также

Class FigureAttrs, Group Базы данных


FigureAttrs.Move (метод)

Переместить атрибут в списке из одной позиуию в другую

Синтаксис

[Visual Basic 6]
Sub Move ( _
   ByVal FromIndex As Long, _
   ByVal ToIndex As Long _
)

[Delphi]
procedure Move(
   const FromIndex: Integer;
   const ToIndex: Integer
)

Описание параметров

FromIndex
[in] Номер перемещаемого атрибута (нумерация идёт от 0 до Count-1)
ToIndex
[in] Новое положение атрибута (нумерация идёт от 0 до Count-1)

Смотри также

Class FigureAttrs, Group Базы данных


Класс FigureBase

База фигур (состоит из нескольких наборов фигур)

Наследование

FigureBase Class CADTriangulation, ShapeFile, Triangulation

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.FigureBase

ClassID = {60090007-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий все фигуры прямоугольник
Property Caption (только для чтения) | Название базы фигур
Property FigureSetCount (только для чтения) | Количество наборов фигур в базе
Property FigureSets (только для чтения) | Массив наборов фигур в базе (наборы фигур рисуются от последнего к первому) (индексы должны иметь номера от 0 до FigureSetCount-1)
Property Modified | Произошли ли какие-либо изменения фигур

Где используется

Класс | Член класса
Class FigureSet | Property FigureBase (свойство)

Смотри также

Class ModelRect, Group фигуры


FigureBase.Bounds (свойство)

Минимальный объемлющий все фигуры прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class FigureBase, Class ModelRect, Group фигуры


FigureBase.Caption (свойство)

Название базы фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class FigureBase, Group фигуры


FigureBase.FigureSetCount (свойство)

Количество наборов фигур в базе

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureSetCount As Long

[Delphi]
{только для чтения} property FigureSetCount: Integer

Смотри также

Class FigureBase, Group фигуры


FigureBase.FigureSets (свойство)

Массив наборов фигур в базе (наборы фигур рисуются от последнего к первому) (индексы должны иметь номера от 0 до FigureSetCount-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureSets As FigureSet

[Delphi]
{только для чтения} property FigureSets: FigureSet

Смотри также

Class FigureBase, Class FigureSet, Group фигуры


FigureBase.Modified (свойство)

Произошли ли какие-либо изменения фигур

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class FigureBase, Group фигуры


Класс FigureCollection

Коллекция фигур

Наследование

CustomCollection Class FigureCollection

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.FigureCollection

ClassID = {60040030-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество объектов списке
Property Items | Массив элементов списка

Методы класса

Имя | Описание
Method Add | Добавить новый элемент в коллекцию
Method AddItems | Добавить несколько новых элементов в коллекцию
Method Clear | Удаляет все элементы из коллекции
Method Delete | Удаляет элемент из коллекции
Method Invert | Меняет порядок элементов в коллекции на обратный

Смотри также

Group Карты


FigureCollection.Count (свойство)

Количество объектов списке

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class FigureCollection, Group Карты


FigureCollection.Items (свойство)

Массив элементов списка

Синтаксис

[Visual Basic 6]
Property Items As Object

[Delphi]
property Items: IDispatch

Смотри также

Class FigureCollection, Group Карты


FigureCollection.Add (метод)

Добавить новый элемент в коллекцию

Синтаксис

[Visual Basic 6]
Sub Add ( _
   ByVal Object As Object _
)

[Delphi]
procedure Add(
   const Object: IDispatch
)

Описание параметров

Object
[in] Добавляемый в коллекцию элемент

Смотри также

Class FigureCollection, Group Карты


FigureCollection.AddItems (метод)

Добавить несколько новых элементов в коллекцию

Синтаксис

[Visual Basic 6]
Sub AddItems ( _
   ParamArray Objects() As Variant _
)

[Delphi]
procedure AddItems(
   const Objects: PSafeArray
)

Описание параметров

Objects
[in] Добавляемые в коллекцию элементы

Смотри также

Class FigureCollection, Group Карты


FigureCollection.Clear (метод)

Удаляет все элементы из коллекции

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class FigureCollection, Group Карты


FigureCollection.Delete (метод)

Удаляет элемент из коллекции

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер элемента в коллекции

Смотри также

Class FigureCollection, Group Карты


FigureCollection.Invert (метод)

Меняет порядок элементов в коллекции на обратный

Синтаксис

[Visual Basic 6]
Sub Invert

[Delphi]
procedure Invert

Смотри также

Class FigureCollection, Group Карты


Класс FigureSet

Набор фигур

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.FigureSet

ClassID = {60090005-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий все фигуры прямоугольник
Property Caption (только для чтения) | Название набора фигур
Property Count (только для чтения) | Общее число фигур
Property FigureBase (только для чтения) | База фигур, в которую входит набор фигур
Property FigureName (только для чтения) | Название фигур, входящих в набор фигур
Property Figures (только для чтения) | Массив фигур (индексы должны иметь номера от 0 до Count-1)
Property Visible | Видим ли сейчас набор фигур в базе фигур

Где используется

Класс | Член класса
Class CADTriangulation | Property FigureSets (свойство)
Class Figure | Property Owner (свойство) Method CloneEmpty (метод)
Class FigureBase | Property FigureSets (свойство)
Class ShapeFigure | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapeFile | Property FigureSets (свойство)
Class ShapeMultipart | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapeMultipoint | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapeMultipointM | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapeMultipointZ | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePoint | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePointM | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePointZ | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePolygon | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePolygonM | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePolygonZ | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePolyline | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePolylineM | Property Owner (свойство) Method CloneEmpty (метод)
Class ShapePolylineZ | Property Owner (свойство) Method CloneEmpty (метод)
Class Triangulation | Property FigureSets (свойство)
Class TrnArea | Property Owner (свойство) Method CloneEmpty (метод)
Class TrnBreak | Property Owner (свойство) Method CloneEmpty (метод)
Class TrnFigure | Property Owner (свойство) Method CloneEmpty (метод)
Class TrnFlip | Property Owner (свойство) Method CloneEmpty (метод)
Class TrnModifier | Property Owner (свойство) Method CloneEmpty (метод)
Class TrnNode | Property Owner (свойство) Method CloneEmpty (метод)
Class TrnRib | Property Owner (свойство) Method CloneEmpty (метод)
Class TrnSource | Property Owner (свойство) Method CloneEmpty (метод)
Class TrnTriangle | Property Owner (свойство) Method CloneEmpty (метод)

Смотри также

Class ModelRect, Group фигуры


FigureSet.Bounds (свойство)

Минимальный объемлющий все фигуры прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class FigureSet, Class ModelRect, Group фигуры


FigureSet.Caption (свойство)

Название набора фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class FigureSet, Group фигуры


FigureSet.Count (свойство)

Общее число фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class FigureSet, Group фигуры


FigureSet.FigureBase (свойство)

База фигур, в которую входит набор фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureBase As FigureBase

[Delphi]
{только для чтения} property FigureBase: FigureBase

Смотри также

Class FigureBase, Class FigureSet, Group фигуры


FigureSet.FigureName (свойство)

Название фигур, входящих в набор фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureName As String

[Delphi]
{только для чтения} property FigureName: WideString

Смотри также

Class FigureSet, Group фигуры


FigureSet.Figures (свойство)

Массив фигур (индексы должны иметь номера от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Figures As Figure

[Delphi]
{только для чтения} property Figures: Figure

Смотри также

Class Figure, Class FigureSet, Group фигуры


FigureSet.Visible (свойство)

Видим ли сейчас набор фигур в базе фигур

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class FigureSet, Group фигуры


Класс FolderLayer

Папка слоёв

Наследование

CompositionLayer Class FolderLayer

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Caption | Подпись слоя
Property ClipRegion (только для чтения) | Зона отсечения изображения слоя
Property FileLocked | Файл с данными слоя заблокирован для записи
Property FileName (только для чтения) | Имя файла слоя
Property FullExtent (только для чтения) | Полный размер слоя
Property Index (только для чтения) | Номер в списке родителя
Property IndividualProjection | Слой имеет индивидуальную проекцию
Property Kind (только для чтения) | Тип слоя
Property LayerCount (только для чтения) | Количество слоёв в папке
Property Layers (только для чтения) | Массив слоёв в папке
Property LegendOpen | Легенда развёрнута
Property MaxDrawScale | Максимальный масштаб отрисовки
Property MinDrawScale | Минимальный масштаб отрисовки
Property Modified | Изменён ли слой
Property Parent (только для чтения) | Папка, которой принадлежит слой
Property Projected | Проектировать ли слой?
Property Projection | Индивидуальная проекция слоя
Property ScaleCheck | Отрисовка в зависимости от масштаба
Property Selected (только для чтения) | Выделен ли слой в легенде
Property SeqID (только для чтения) | Уникальный идентификатор слоя на карте
Property Tag | Можно использовать по своему усмотрению
Property Transparency | Значение прозрачности, с которой надо отображать слой (0 - непрозрачен, 255 - полностью прозрачен)
Property UsedTransparency (только для чтения) | Прозрачность, реально используемая при отрисовке слоя, с учетом прозрачности родительских папок (0 - непрозрачен, 255 - полностью прозрачен)
Property ValidProjected (только для чтения) | Реально проектировать ли слой
Property ValidProjection (только для чтения) | Реально используемая проекция слоя
Property VerbCount (только для чтения) | Количество доступных элементов локального меню
Property Verbs (только для чтения) | Массив пунктов локального меню слоя
Property Visible | Видим ли слой на карте
Property VisibleState (только для чтения) | Состояние отметки видимости слоя

Методы класса

Имя | Описание
Method CanProjected | Можно ли отобразить сейчас слой в проекции
Method CanShow | Проверить, будет ли отображён слой на карте с учётом текущего масштаба
Method EditProperties | Редактирование свойств слоя
Method EditRenderer | Редактирование свойств отрисовки слоя
Method ExecuteVerb | Выполнить заданный пункт локального меню
Method GetDescriptionAtPos | Получение краткой информации в заданной точке
Method HasData | Имеет ли папка слои-непапки
Method Save | Сохранить содержимое слоя
Method SupportsProjection | Поддерживается ли слоем отображение в проекции

Где используется

Класс | Член класса
Class CompositionLayer | Property Parent (свойство)
Class FolderLayer | Property Parent (свойство)
Class LayeredComposition | Property Layers (свойство) Method AddNewLayer (метод)
Class VectorLayer | Property Parent (свойство)

Смотри также

Enum CheckBoxConstants, Class ClipRegion, Enum CompositionLayerConstants, Class CustomContainer, Class MenuVerb, Class ModelPoint, Class ModelRect, Class Projection, Group Карты


FolderLayer.Caption (свойство)

Подпись слоя

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class FolderLayer, Group Карты


FolderLayer.ClipRegion (свойство)

Зона отсечения изображения слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property ClipRegion As ClipRegion

[Delphi]
{только для чтения} property ClipRegion: ClipRegion

Смотри также

Class ClipRegion, Class FolderLayer, Group Карты


FolderLayer.FileLocked (свойство)

Файл с данными слоя заблокирован для записи

Синтаксис

[Visual Basic 6]
Property FileLocked As Boolean

[Delphi]
property FileLocked: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.FileName (свойство)

Имя файла слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class FolderLayer, Group Карты


FolderLayer.FullExtent (свойство)

Полный размер слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property FullExtent As ModelRect

[Delphi]
{только для чтения} property FullExtent: ModelRect

Смотри также

Class FolderLayer, Class ModelRect, Group Карты


FolderLayer.Index (свойство)

Номер в списке родителя

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.IndividualProjection (свойство)

Слой имеет индивидуальную проекцию

Синтаксис

[Visual Basic 6]
Property IndividualProjection As Boolean

[Delphi]
property IndividualProjection: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Kind (свойство)

Тип слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Kind As CompositionLayerConstants

[Delphi]
{только для чтения} property Kind: CompositionLayerConstants

Смотри также

Enum CompositionLayerConstants, Class FolderLayer, Group Карты


FolderLayer.LayerCount (свойство)

Количество слоёв в папке

Синтаксис

[Visual Basic 6]
ReadOnly Property LayerCount As Long

[Delphi]
{только для чтения} property LayerCount: Integer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Layers (свойство)

Массив слоёв в папке

Синтаксис

[Visual Basic 6]
ReadOnly Property Layers As CompositionLayer

[Delphi]
{только для чтения} property Layers: CompositionLayer

Смотри также

Class CompositionLayer, Class FolderLayer, Group Карты


FolderLayer.LegendOpen (свойство)

Легенда развёрнута

Синтаксис

[Visual Basic 6]
Property LegendOpen As Boolean

[Delphi]
property LegendOpen: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.MaxDrawScale (свойство)

Максимальный масштаб отрисовки

Синтаксис

[Visual Basic 6]
Property MaxDrawScale As Double

[Delphi]
property MaxDrawScale: Double

Смотри также

Class FolderLayer, Group Карты


FolderLayer.MinDrawScale (свойство)

Минимальный масштаб отрисовки

Синтаксис

[Visual Basic 6]
Property MinDrawScale As Double

[Delphi]
property MinDrawScale: Double

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Modified (свойство)

Изменён ли слой

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Parent (свойство)

Папка, которой принадлежит слой

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As FolderLayer

[Delphi]
{только для чтения} property Parent: FolderLayer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Projected (свойство)

Проектировать ли слой?

Синтаксис

[Visual Basic 6]
Property Projected As Boolean

[Delphi]
property Projected: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Projection (свойство)

Индивидуальная проекция слоя

Синтаксис

[Visual Basic 6]
Property Projection As Projection

[Delphi]
property Projection: Projection

Смотри также

Class FolderLayer, Class Projection, Group Карты


FolderLayer.ScaleCheck (свойство)

Отрисовка в зависимости от масштаба

Синтаксис

[Visual Basic 6]
Property ScaleCheck As Boolean

[Delphi]
property ScaleCheck: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Selected (свойство)

Выделен ли слой в легенде

Синтаксис

[Visual Basic 6]
ReadOnly Property Selected As Boolean

[Delphi]
{только для чтения} property Selected: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.SeqID (свойство)

Уникальный идентификатор слоя на карте

Синтаксис

[Visual Basic 6]
ReadOnly Property SeqID As Long

[Delphi]
{только для чтения} property SeqID: Integer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Tag (свойство)

Можно использовать по своему усмотрению

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Transparency (свойство)

Значение прозрачности, с которой надо отображать слой (0 - непрозрачен, 255 - полностью прозрачен)

Синтаксис

[Visual Basic 6]
Property Transparency As Long

[Delphi]
property Transparency: Integer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.UsedTransparency (свойство)

Прозрачность, реально используемая при отрисовке слоя, с учетом прозрачности родительских папок (0 - непрозрачен, 255 - полностью прозрачен)

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedTransparency As Long

[Delphi]
{только для чтения} property UsedTransparency: Integer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.ValidProjected (свойство)

Реально проектировать ли слой

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidProjected As Boolean

[Delphi]
{только для чтения} property ValidProjected: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.ValidProjection (свойство)

Реально используемая проекция слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidProjection As Projection

[Delphi]
{только для чтения} property ValidProjection: Projection

Смотри также

Class FolderLayer, Class Projection, Group Карты


FolderLayer.VerbCount (свойство)

Количество доступных элементов локального меню

Синтаксис

[Visual Basic 6]
ReadOnly Property VerbCount As Long

[Delphi]
{только для чтения} property VerbCount: Integer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Verbs (свойство)

Массив пунктов локального меню слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Verbs As MenuVerb

[Delphi]
{только для чтения} property Verbs: MenuVerb

Смотри также

Class FolderLayer, Class MenuVerb, Group Карты


FolderLayer.Visible (свойство)

Видим ли слой на карте

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class FolderLayer, Group Карты


FolderLayer.VisibleState (свойство)

Состояние отметки видимости слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property VisibleState As CheckBoxConstants

[Delphi]
{только для чтения} property VisibleState: CheckBoxConstants

Смотри также

Enum CheckBoxConstants, Class FolderLayer, Group Карты


FolderLayer.CanProjected (метод)

Можно ли отобразить сейчас слой в проекции

Синтаксис

[Visual Basic 6]
Function CanProjected As Boolean

[Delphi]
function CanProjected: WordBool

Возвращаемое значение

Возвращает True, если сейчас можно отобразить слой в проекции

Смотри также

Class FolderLayer, Group Карты


FolderLayer.CanShow (метод)

Проверить, будет ли отображён слой на карте с учётом текущего масштаба

Синтаксис

[Visual Basic 6]
Function CanShow ( _
   ByVal Container As CustomContainer _
) As Boolean

[Delphi]
function CanShow(
   const Container: CustomContainer
): WordBool

Описание параметров

Container
[in] Контейнер, в котором отображается текущий слой

Возвращаемое значение

Возвращает True, если отображение возможно

Смотри также

Class CustomContainer, Class FolderLayer, Group Карты


FolderLayer.EditProperties (метод)

Редактирование свойств слоя

Синтаксис

[Visual Basic 6]
Sub EditProperties

[Delphi]
procedure EditProperties

Смотри также

Class FolderLayer, Group Карты


FolderLayer.EditRenderer (метод)

Редактирование свойств отрисовки слоя

Синтаксис

[Visual Basic 6]
Sub EditRenderer

[Delphi]
procedure EditRenderer

Смотри также

Class FolderLayer, Group Карты


FolderLayer.ExecuteVerb (метод)

Выполнить заданный пункт локального меню

Синтаксис

[Visual Basic 6]
Sub ExecuteVerb ( _
   ByVal Index As Long _
)

[Delphi]
procedure ExecuteVerb(
   const Index: Integer
)

Описание параметров

Index
[in] Номер выполняемого пункта локального меню слоя (нумерация идёт от 0 до VerbCount-1)

Смотри также

Class FolderLayer, Group Карты


FolderLayer.GetDescriptionAtPos (метод)

Получение краткой информации в заданной точке

Синтаксис

[Visual Basic 6]
Function GetDescriptionAtPos ( _
   ByVal Pos As ModelPoint, _
   ByVal Delta As Double _
) As String

[Delphi]
function GetDescriptionAtPos(
   const Pos: ModelPoint;
   const Delta: Double
): WideString

Описание параметров

Pos
[in] Точка на карте в модельной системе координат, для которой требуется получить краткю информацию
Delta
[in] Максимальное допустимое отклонение при поиске объектов, для которых выдается краткая информация

Возвращаемое значение

Возвращает текст краткой информации или пустую строку

Смотри также

Class FolderLayer, Class ModelPoint, Group Карты


FolderLayer.HasData (метод)

Имеет ли папка слои-непапки

Синтаксис

[Visual Basic 6]
Function HasData As Boolean

[Delphi]
function HasData: WordBool

Возвращаемое значение

Возвращает True, если в папке есть слои-непапки

Смотри также

Class FolderLayer, Group Карты


FolderLayer.Save (метод)

Сохранить содержимое слоя

Синтаксис

[Visual Basic 6]
Sub Save

[Delphi]
procedure Save

Смотри также

Class FolderLayer, Group Карты


FolderLayer.SupportsProjection (метод)

Поддерживается ли слоем отображение в проекции

Синтаксис

[Visual Basic 6]
Function SupportsProjection As Boolean

[Delphi]
function SupportsProjection: WordBool

Возвращаемое значение

Возвращает True, если отображение в проекции поддерживается слоем

Смотри также

Class FolderLayer, Group Карты


Класс GeoPoint

Абстрактная геодезическая точка

Наследование

GeoPoint Class AdditionalPoint, LinkedGeoPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Number | Номер (описание) точки
Property Position | Положение точки

Где используется

Класс | Член класса
Class By3PointAdditionalPoint | Property RangeLinkToPoints (свойство)
Class CustomSurveyPoint | Property LinkedPoint (свойство) Property SourceStation (свойство)
Class FieldTraversePoint | Property LinkedPoint (свойство) Property SourceStation (свойство)
Class IntersectionAdditionalPoint | Property RangeLinkToPoints (свойство)
Class LinkedGeoPoint | Property LinkedPoint (свойство)
Class MeasureAdditionalPoint | Property RangeLinkToPoints (свойство)
Class RangeAdditionalPoint | Property RangeLinkToPoints (свойство)
Class Survey | Property AimingStation (свойство) Property FromStation (свойство)
Class SurveyEditor | Property ActiveFieldTraversePoint (свойство)
Class SurveyPoint | Property LinkedPoint (свойство) Property SourceStation (свойство)

Смотри также

Class ModelPoint, Group Геодезия


GeoPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class GeoPoint, Group Геодезия


GeoPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class GeoPoint, Group Геодезия


GeoPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class GeoPoint, Group Геодезия


GeoPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class GeoPoint, Group Геодезия


GeoPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class GeoPoint, Group Геодезия


GeoPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class GeoPoint, Class ModelPoint, Group Геодезия


Класс GeodesyAngle

Геодезический угол

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.GeodesyAngle

ClassID = {66010006-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Degrees | Градусы (всегда неотрицательное целое число. Если угол отрицательный, то это отмечено в свойстве Minus)
Property IsEmpty (только для чтения) | Значение угла отсутствует
Property Minus | Признак того, что угол является отрицательным (при этом для отрицательных углов градусы, минуты и секунды задаются положительными)
Property Minutes | Минуты (всегда неотрицательное целое число. Если угол отрицательный, то это отмечено в свойстве Minus)
Property Radians | Значение угла в радианах
Property Seconds | Секунды (всегда неотрицательное вещественное число. Если угол отрицательный, то это отмечено в свойстве Minus)
Property Text | Значение угла в виде строки

Где используется

Класс | Член класса
Class CustomSurveyPoint | Property DirAngle (свойство) Property HorzAngle (свойство) Property VertAngle (свойство)
Class FieldTraverse | Property AngleDiscrepancy (свойство) Property BeginDirAngle (свойство) Property EndDirAngle (свойство) Property FirstStationHorzAngle (свойство) Property HorzAngleCorrection (свойство) Property LastStationHorzAngle (свойство) Property VertAngleCorrection (свойство)
Class FieldTraversePoint | Property BackVertAngle (свойство) Property CorrectedDirAngle (свойство) Property DirAngle (свойство) Property HorzAngle (свойство) Property VertAngle (свойство)
Class MeasureAdditionalPoint | Property AimingDirAngle (свойство) Property DirAngle (свойство) Property HorzAngle (свойство) Property VertAngle (свойство)
Class Measuring | Property HorzAngleCorrection (свойство) Property VertAngleCorrection (свойство)
Class Survey | Property HorzAngleCorrection (свойство) Property VertAngleCorrection (свойство)
Class SurveyPoint | Property DirAngle (свойство) Property HorzAngle (свойство) Property VertAngle (свойство)

Смотри также

Group Геодезия


GeodesyAngle.Degrees (свойство)

Градусы (всегда неотрицательное целое число. Если угол отрицательный, то это отмечено в свойстве Minus)

Синтаксис

[Visual Basic 6]
Property Degrees As Long

[Delphi]
property Degrees: Integer

Смотри также

Class GeodesyAngle, Group Геодезия


GeodesyAngle.IsEmpty (свойство)

Значение угла отсутствует

Синтаксис

[Visual Basic 6]
ReadOnly Property IsEmpty As Boolean

[Delphi]
{только для чтения} property IsEmpty: WordBool

Смотри также

Class GeodesyAngle, Group Геодезия


GeodesyAngle.Minus (свойство)

Признак того, что угол является отрицательным (при этом для отрицательных углов градусы, минуты и секунды задаются положительными)

Синтаксис

[Visual Basic 6]
Property Minus As Boolean

[Delphi]
property Minus: WordBool

Смотри также

Class GeodesyAngle, Group Геодезия


GeodesyAngle.Minutes (свойство)

Минуты (всегда неотрицательное целое число. Если угол отрицательный, то это отмечено в свойстве Minus)

Синтаксис

[Visual Basic 6]
Property Minutes As Long

[Delphi]
property Minutes: Integer

Смотри также

Class GeodesyAngle, Group Геодезия


GeodesyAngle.Radians (свойство)

Значение угла в радианах

Синтаксис

[Visual Basic 6]
Property Radians As Double

[Delphi]
property Radians: Double

Смотри также

Class GeodesyAngle, Group Геодезия


GeodesyAngle.Seconds (свойство)

Секунды (всегда неотрицательное вещественное число. Если угол отрицательный, то это отмечено в свойстве Minus)

Синтаксис

[Visual Basic 6]
Property Seconds As Double

[Delphi]
property Seconds: Double

Смотри также

Class GeodesyAngle, Group Геодезия


GeodesyAngle.Text (свойство)

Значение угла в виде строки

Синтаксис

[Visual Basic 6]
Property Text As String

[Delphi]
property Text: WideString

Смотри также

Class GeodesyAngle, Group Геодезия


Класс GeodesyBook

Геодезический редактор

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.GeodesyBook

ClassID = {6601001A-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property FieldTraverseCount (только для чтения) | Количество теодолитных ходов в журнале
Property FieldTraverses (только для чтения) | Массив теодолитных ходов
Property FileName (только для чтения) | Имя файла геодезического журнала
Property Handle (только для чтения) | Handle объекта
Property Modified | Изменён ли журнал

Методы класса

Имя | Описание
Method AddFieldTraverse | Добавить теодолитный ход в журнал
Method DeleteFieldTraverse | Удалить теодолитный ход по номеру
Method FieldTraverseByName | Найти теодолитный ход по имени
Method LoadFromFile | Загрузить журнал из файла (если Filename = '', то откроется диалог открытия файла)
Method OpenEditor | Открыть журнал в окне редактора
Method Recalculate | Пересчитать точки хода
Method RemoveFieldTraverse | Удалить теодолитный ход
Method SaveToFile | Сохранить журнал в файле (если Filename = '', то откроется диалог выбора имени файла)

Где используется

Класс | Член класса
Class SurveyEditor | Property GeodesyBook (свойство)

Смотри также

Class FieldTraverse, Group Геодезия


GeodesyBook.FieldTraverseCount (свойство)

Количество теодолитных ходов в журнале

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldTraverseCount As Long

[Delphi]
{только для чтения} property FieldTraverseCount: Integer

Смотри также

Class GeodesyBook, Group Геодезия


GeodesyBook.FieldTraverses (свойство)

Массив теодолитных ходов

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldTraverses As FieldTraverse

[Delphi]
{только для чтения} property FieldTraverses: FieldTraverse

Смотри также

Class FieldTraverse, Class GeodesyBook, Group Геодезия


GeodesyBook.FileName (свойство)

Имя файла геодезического журнала

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class GeodesyBook, Group Геодезия


GeodesyBook.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class GeodesyBook, Group Геодезия


GeodesyBook.Modified (свойство)

Изменён ли журнал

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class GeodesyBook, Group Геодезия


GeodesyBook.AddFieldTraverse (метод)

Добавить теодолитный ход в журнал

Синтаксис

[Visual Basic 6]
Function AddFieldTraverse As FieldTraverse

[Delphi]
function AddFieldTraverse: FieldTraverse

Возвращаемое значение

Возвращает добавленный в журнал теодолитный ход

Смотри также

Class FieldTraverse, Class GeodesyBook, Group Геодезия


GeodesyBook.DeleteFieldTraverse (метод)

Удалить теодолитный ход по номеру

Синтаксис

[Visual Basic 6]
Sub DeleteFieldTraverse ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteFieldTraverse(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемого хода (нумерация идёт от 0 до FieldTraverseCount-1)

Смотри также

Class GeodesyBook, Group Геодезия


GeodesyBook.FieldTraverseByName (метод)

Найти теодолитный ход по имени

Синтаксис

[Visual Basic 6]
Function FieldTraverseByName ( _
   ByVal Name As String _
) As FieldTraverse

[Delphi]
function FieldTraverseByName(
   const Name: WideString
): FieldTraverse

Описание параметров

Name
[in] Имя хода

Возвращаемое значение

Возвращает теодолитный ход для указанного имени или возвратит Nothing, если хода с таким именем не найдено

Смотри также

Class FieldTraverse, Class GeodesyBook, Group Геодезия


GeodesyBook.LoadFromFile (метод)

Загрузить журнал из файла (если Filename = '', то откроется диалог открытия файла)

Синтаксис

[Visual Basic 6]
Sub LoadFromFile ( _
   [ByVal FileName As String = ""] _
)

[Delphi]
procedure LoadFromFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла журнала с расширением GGB

Смотри также

Class GeodesyBook, Group Геодезия


GeodesyBook.OpenEditor (метод)

Открыть журнал в окне редактора

Синтаксис

[Visual Basic 6]
Function OpenEditor ( _
   [ByVal Modal As Boolean = False] _
) As SurveyEditor

[Delphi]
function OpenEditor(
   const Modal: WordBool
): SurveyEditor

Описание параметров

Modal
[in] Открыть окно в модальном режиме

Возвращаемое значение

Возвращает геодезический редактор

Смотри также

Class GeodesyBook, Class SurveyEditor, Group Геодезия


GeodesyBook.Recalculate (метод)

Пересчитать точки хода

Синтаксис

[Visual Basic 6]
Sub Recalculate

[Delphi]
procedure Recalculate

Смотри также

Class GeodesyBook, Group Геодезия


GeodesyBook.RemoveFieldTraverse (метод)

Удалить теодолитный ход

Синтаксис

[Visual Basic 6]
Sub RemoveFieldTraverse ( _
   ByVal FieldTraverse As FieldTraverse _
)

[Delphi]
procedure RemoveFieldTraverse(
   const FieldTraverse: FieldTraverse
)

Описание параметров

FieldTraverse
[in] Удаляемый ход

Смотри также

Class FieldTraverse, Class GeodesyBook, Group Геодезия


GeodesyBook.SaveToFile (метод)

Сохранить журнал в файле (если Filename = '', то откроется диалог выбора имени файла)

Синтаксис

[Visual Basic 6]
Sub SaveToFile ( _
   [ByVal FileName As String = ""] _
)

[Delphi]
procedure SaveToFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла журнала с расширением GGB

Смотри также

Class GeodesyBook, Group Геодезия


Класс Grid

Сетка, покрывающая весь проект с шагом 10 см

Наследование

BaseObject Class Grid

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Color | Цвет отображения сетки
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Project (только для чтения) | Проект, к которому относится объект
Property ShowCaptions | Отображаются ли подписи узлов сетки
Property Size | Длина штриха сетки в миллиметрах
Property Visible | Отображается ли сетка в плане
Property Width | Толщина штриха сетки в миллиметрах

Методы класса

Имя | Описание
Method AddCaption | Добавить подписывание координат узла сетки
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method CorrectCoordinates | Корректирует указанные координаты до координат ближайшего узла сетки
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method InvertCaption | Изменить подписывание координат узла сетки на противоположное значение
Method RemoveCaption | Удалить подписывание координат узла сетки

Где используется

Класс | Член класса
Class Project | Property Grid (свойство)

Смотри также

Class Application, Group Проекты


Grid.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class Grid, Group Проекты


Grid.Color (свойство)

Цвет отображения сетки

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Grid, Group Проекты


Grid.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Grid, Group Проекты


Grid.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Grid, Group Проекты


Grid.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Grid, Class Project, Group Проекты


Grid.ShowCaptions (свойство)

Отображаются ли подписи узлов сетки

Синтаксис

[Visual Basic 6]
Property ShowCaptions As Boolean

[Delphi]
property ShowCaptions: WordBool

Смотри также

Class Grid, Group Проекты


Grid.Size (свойство)

Длина штриха сетки в миллиметрах

Синтаксис

[Visual Basic 6]
Property Size As Double

[Delphi]
property Size: Double

Смотри также

Class Grid, Group Проекты


Grid.Visible (свойство)

Отображается ли сетка в плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Grid, Group Проекты


Grid.Width (свойство)

Толщина штриха сетки в миллиметрах

Синтаксис

[Visual Basic 6]
Property Width As Double

[Delphi]
property Width: Double

Смотри также

Class Grid, Group Проекты


Grid.AddCaption (метод)

Добавить подписывание координат узла сетки

Синтаксис

[Visual Basic 6]
Function AddCaption ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
) As Boolean

[Delphi]
function AddCaption(
   const ModelX: Double;
   const ModelY: Double
): WordBool

Описание параметров

ModelX
[in] X-координата узла сетки, для которого выполняется действие
ModelY
[in] Y-координата узла сетки, для которого выполняется действие

Возвращаемое значение

Результат операции: True - подпись узла добавлена, False - узел уже был подписан, либо указаны координаты, где нет узла сетки

Смотри также

Class Grid, Group Проекты


Grid.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Grid, Group Проекты


Grid.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Grid, Group Проекты


Grid.CorrectCoordinates (метод)

Корректирует указанные координаты до координат ближайшего узла сетки

Синтаксис

[Visual Basic 6]
Sub CorrectCoordinates ( _
   ModelX As Double, _
   ModelY As Double _
)

[Delphi]
procedure CorrectCoordinates(
   var ModelX: Double;
   var ModelY: Double
)

Описание параметров

ModelX
[in, out] X-координата, для которого выполняется действие
ModelY
[in, out] Y-координата, для которого выполняется действие

Смотри также

Class Grid, Group Проекты


Grid.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Grid, Group Проекты


Grid.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Grid, Group Проекты


Grid.InvertCaption (метод)

Изменить подписывание координат узла сетки на противоположное значение

Синтаксис

[Visual Basic 6]
Function InvertCaption ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
) As Boolean

[Delphi]
function InvertCaption(
   const ModelX: Double;
   const ModelY: Double
): WordBool

Описание параметров

ModelX
[in] X-координата узла сетки, для которого выполняется действие
ModelY
[in] Y-координата узла сетки, для которого выполняется действие

Возвращаемое значение

Результат операции: True - операция выполнена успешно, False - указаны координаты, где нет узла сетки

Смотри также

Class Grid, Group Проекты


Grid.RemoveCaption (метод)

Удалить подписывание координат узла сетки

Синтаксис

[Visual Basic 6]
Function RemoveCaption ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
) As Boolean

[Delphi]
function RemoveCaption(
   const ModelX: Double;
   const ModelY: Double
): WordBool

Описание параметров

ModelX
[in] X-координата узла сетки, для которого выполняется действие
ModelY
[in] Y-координата узла сетки, для которого выполняется действие

Возвращаемое значение

Результат операции: True - подпись узла удалена, False - узел не был подписан, либо указаны координаты, где нет узла сетки

Смотри также

Class Grid, Group Проекты


Класс HotLink

Параметры горячей связи

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AttrName | Имя атрибута горячей связи
Property DefaultCode | Код действия по умолчанию
Property DefID | Уникальный идентификатор элементов слоя
Property Enabled | Разрешена ли горячая связь
Property Params | Дополнительные параметры

Методы класса

Имя | Описание
Method Execute | Выполнить действие горячей связи

Где используется

Класс | Член класса
Class VectorLayer | Property HotLink (свойство)

Смотри также

Class CustomContainer, Group Карты


HotLink.AttrName (свойство)

Имя атрибута горячей связи

Синтаксис

[Visual Basic 6]
Property AttrName As String

[Delphi]
property AttrName: WideString

Смотри также

Class HotLink, Group Карты


HotLink.DefaultCode (свойство)

Код действия по умолчанию

Синтаксис

[Visual Basic 6]
Property DefaultCode As String

[Delphi]
property DefaultCode: WideString

Смотри также

Class HotLink, Group Карты


HotLink.DefID (свойство)

Уникальный идентификатор элементов слоя

Синтаксис

[Visual Basic 6]
Property DefID As Long

[Delphi]
property DefID: Integer

Смотри также

Class HotLink, Group Карты


HotLink.Enabled (свойство)

Разрешена ли горячая связь

Синтаксис

[Visual Basic 6]
Property Enabled As Boolean

[Delphi]
property Enabled: WordBool

Смотри также

Class HotLink, Group Карты


HotLink.Params (свойство)

Дополнительные параметры

Синтаксис

[Visual Basic 6]
Property Params As String

[Delphi]
property Params: WideString

Смотри также

Class HotLink, Group Карты


HotLink.Execute (метод)

Выполнить действие горячей связи

Синтаксис

[Visual Basic 6]
Sub Execute ( _
   ByVal Container As CustomContainer, _
   ByVal AttrValue As String _
)

[Delphi]
procedure Execute(
   const Container: CustomContainer;
   const AttrValue: WideString
)

Описание параметров

Container
[in] Контейнер, в котором нужно выполнить горячую связь
AttrValue
[in] Значение атрибута горячей связи

Смотри также

Class CustomContainer, Class HotLink, Group Карты


Класс Images

Стандартный набор картинок

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество стандартных изображений
Property Handle (только для чтения) | HImageList списка изображений

Методы класса

Имя | Описание
Method Add | Добавить новую иконку, если такая ещё не добавлена в список
Method AddBitmap | Добавить новую иконку, заданную в виде HBitmap, если такая ещё не добавлена в список
Method AddIcon | Добавить новую иконку, заданную в виде HIcon, если такая ещё не добавлена в список
Method AddResource | Добавить новую иконку, заданную в виде ресурса в формате иконки или картинки, если такая ещё не добавлена в список
Method Draw | Рисует заданную иконку
Method Find | Найти по Id номер пользовательской иконки
Method Replace | Заменяет старую иконку новой
Method ReplaceBitmap | Заменяет старую иконку новой, заданной в виде HBitmap
Method ReplaceIcon | Заменяет старую иконку новой, заданной в виде HIcon
Method ReplaceResource | Заменяет старую иконку новой, заданной в виде ресурса в формате иконки или картинки

Где используется

Класс | Член класса
Class Application | Property Images (свойство)
Class ICommonApplication | Property Images (свойство)

Смотри также

PictureDisp, Group Пользовательский интерфейс


Images.Count (свойство)

Количество стандартных изображений

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class Images, Group Пользовательский интерфейс


Images.Handle (свойство)

HImageList списка изображений

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, Group Пользовательский интерфейс


Images.Add (метод)

Добавить новую иконку, если такая ещё не добавлена в список

Синтаксис

[Visual Basic 6]
Function Add ( _
   ByVal Picture As PictureDisp, _
   [ByVal ID As String = ""], _
   [ByVal MaskColor As OLE_COLOR = -1] _
) As Long

[Delphi]
function Add(
   const Picture: PictureDisp;
   const ID: WideString;
   const MaskColor: OLE_COLOR
): Integer

Описание параметров

Picture
[in] Картинка (растр или иконка)
ID
[in] Идентификатор картинки (может не задаваться)
MaskColor
[in] Цвет, используемый для обозначения прозрачных мест на растре

Возвращаемое значение

Возвращает номер добавленной картинки

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, PictureDisp, Group Пользовательский интерфейс


Images.AddBitmap (метод)

Добавить новую иконку, заданную в виде HBitmap, если такая ещё не добавлена в список

Синтаксис

[Visual Basic 6]
Function AddBitmap ( _
   ByVal HBitmap As OLE_HANDLE, _
   [ByVal ID As String = ""], _
   [ByVal MaskColor As OLE_COLOR = -1] _
) As Long

[Delphi]
function AddBitmap(
   const HBitmap: OLE_HANDLE;
   const ID: WideString;
   const MaskColor: OLE_COLOR
): Integer

Описание параметров

HBitmap
[in] HBitmap добавляемого растрового изображения
ID
[in] Идентификатор картинки (может не задаваться)
MaskColor
[in] Цвет, используемый для обозначения прозрачных мест на растре

Возвращаемое значение

Возвращает номер добавленной картинки

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, Group Пользовательский интерфейс


Images.AddIcon (метод)

Добавить новую иконку, заданную в виде HIcon, если такая ещё не добавлена в список

Синтаксис

[Visual Basic 6]
Function AddIcon ( _
   ByVal HIcon As OLE_HANDLE, _
   [ByVal ID As String = ""] _
) As Long

[Delphi]
function AddIcon(
   const HIcon: OLE_HANDLE;
   const ID: WideString
): Integer

Описание параметров

HIcon
[in] HIcon добавляемой иконки
ID
[in] Идентификатор картинки (может не задаваться)

Возвращаемое значение

Возвращает номер добавленной картинки

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, Group Пользовательский интерфейс


Images.AddResource (метод)

Добавить новую иконку, заданную в виде ресурса в формате иконки или картинки, если такая ещё не добавлена в список

Синтаксис

[Visual Basic 6]
Function AddResource ( _
   ByVal HInstance As OLE_HANDLE, _
   ByVal ResourceName As String, _
   [ByVal ID As String = ""], _
   [ByVal MaskColor As OLE_COLOR = -1] _
) As Long

[Delphi]
function AddResource(
   const HInstance: OLE_HANDLE;
   const ResourceName: WideString;
   const ID: WideString;
   const MaskColor: OLE_COLOR
): Integer

Описание параметров

HInstance
[in] HInstance динамической библиотеки, в которой находится ресурс с иконкой или картинкой
ResourceName
[in] Имя ресурса
ID
[in] Идентификатор картинки (может не задаваться)
MaskColor
[in] Цвет, используемый для обозначения прозрачных мест на растре. Параметр используется только в случае, если в ресурсе лежит растр, а не иконка

Возвращаемое значение

Возвращает номер добавленной картинки

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, Group Пользовательский интерфейс


Images.Draw (метод)

Рисует заданную иконку

Синтаксис

[Visual Basic 6]
Sub Draw ( _
   ByVal HDC As OLE_HANDLE, _
   ByVal X As Long, _
   ByVal Y As Long, _
   ByVal Index As Long, _
   [ByVal Enabled As Boolean = True] _
)

[Delphi]
procedure Draw(
   const HDC: OLE_HANDLE;
   const X: Integer;
   const Y: Integer;
   const Index: Integer;
   const Enabled: WordBool
)

Описание параметров

HDC
[in] HDC устройства вывода
X
[in] Координата X на устройстве вывода
Y
[in] Координата Y на устройстве вывода
Index
[in] Номер иконки из набора
Enabled
[in] Если Enabled=False, то иконка будет рисоваться запрещённой (серой), иначе как обычно

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, Group Пользовательский интерфейс


Images.Find (метод)

Найти по Id номер пользовательской иконки

Синтаксис

[Visual Basic 6]
Function Find ( _
   ByVal ID As String _
) As Long

[Delphi]
function Find(
   const ID: WideString
): Integer

Описание параметров

ID
[in] Идентификатор картинки

Возвращаемое значение

Возвращает по заданному идентификатору номер картинки или -1, если указанный идентификатор не найден

Смотри также

Class Images, Group Пользовательский интерфейс


Images.Replace (метод)

Заменяет старую иконку новой

Синтаксис

[Visual Basic 6]
Function Replace ( _
   ByVal Index As Long, _
   ByVal Picture As PictureDisp, _
   [ByVal MaskColor As OLE_COLOR = -1] _
) As Boolean

[Delphi]
function Replace(
   const Index: Integer;
   const Picture: PictureDisp;
   const MaskColor: OLE_COLOR
): WordBool

Описание параметров

Index
[in] Номер иконки (нумерация идёт от 0 до Count-1)
Picture
[in] Картинка (растр или иконка)
MaskColor
[in] Цвет, используемый для обозначения прозрачных мест на растре

Возвращаемое значение

Возвращает True, если картинка успешно заменена

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, PictureDisp, Group Пользовательский интерфейс


Images.ReplaceBitmap (метод)

Заменяет старую иконку новой, заданной в виде HBitmap

Синтаксис

[Visual Basic 6]
Function ReplaceBitmap ( _
   ByVal Index As Long, _
   ByVal HBitmap As OLE_HANDLE, _
   [ByVal MaskColor As OLE_COLOR = -1] _
) As Boolean

[Delphi]
function ReplaceBitmap(
   const Index: Integer;
   const HBitmap: OLE_HANDLE;
   const MaskColor: OLE_COLOR
): WordBool

Описание параметров

Index
[in] Номер иконки (нумерация идёт от 0 до Count-1)
HBitmap
[in] HBitmap нового добавляемого растрового изображения
MaskColor
[in] Цвет, используемый для обозначения прозрачных мест на растре

Возвращаемое значение

Возвращает True, если картинка успешно заменена

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, Group Пользовательский интерфейс


Images.ReplaceIcon (метод)

Заменяет старую иконку новой, заданной в виде HIcon

Синтаксис

[Visual Basic 6]
Function ReplaceIcon ( _
   ByVal Index As Long, _
   ByVal HIcon As OLE_HANDLE _
) As Boolean

[Delphi]
function ReplaceIcon(
   const Index: Integer;
   const HIcon: OLE_HANDLE
): WordBool

Описание параметров

Index
[in] Номер иконки (нумерация идёт от 0 до Count-1)
HIcon
[in] HIcon новой добавляемой иконки

Возвращаемое значение

Возвращает True, если картинка успешно заменена

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, Group Пользовательский интерфейс


Images.ReplaceResource (метод)

Заменяет старую иконку новой, заданной в виде ресурса в формате иконки или картинки

Синтаксис

[Visual Basic 6]
Function ReplaceResource ( _
   ByVal Index As Long, _
   ByVal HInstance As OLE_HANDLE, _
   ByVal ResourceName As String, _
   [ByVal MaskColor As OLE_COLOR = -1] _
) As Boolean

[Delphi]
function ReplaceResource(
   const Index: Integer;
   const HInstance: OLE_HANDLE;
   const ResourceName: WideString;
   const MaskColor: OLE_COLOR
): WordBool

Описание параметров

Index
[in] Номер иконки (нумерация идёт от 0 до Count-1)
HInstance
[in] HInstance динамической библиотеки, в которой находится ресурс с иконкой или картинкой
ResourceName
[in] Имя ресурса
MaskColor
[in] Цвет, используемый для обозначения прозрачных мест на растре. Параметр используется только в случае, если в ресурсе лежит растр, а не иконка

Возвращаемое значение

Возвращает True, если картинка успешно заменена

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Images, Group Пользовательский интерфейс


Класс IntegerCollection

Коллекция целых чисел

Наследование

CustomCollection Class IntegerCollection

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.IntegerCollection

ClassID = {60020008-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество объектов списке
Property Items | Массив элементов коллекции

Методы класса

Имя | Описание
Method Add | Добавить новое число в коллекцию
Method AddItems | Добавить несколько чисел в коллекцию
Method Clear | Удаляет все элементы из коллекции
Method Delete | Удаляет элемент из коллекции
Method Invert | Меняет порядок элементов в коллекции на обратный
Method Sort | Выполнить сортировку чисел по возрастанию

Где используется

Класс | Член класса
Class CADTriangulation | Method ExtractTriangles (метод) Method ExtractVoronoi (метод)
Class Lines | Method CreateLine (метод)
Class Route | Method GetCodedLines (метод)
Class Triangulation | Method ExtractTriangles (метод) Method ExtractVoronoi (метод)
Class TrnTools | Method MakeBufferAreas (метод)

Смотри также

Group Хранилища объектов


IntegerCollection.Count (свойство)

Количество объектов списке

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class IntegerCollection, Group Хранилища объектов


IntegerCollection.Items (свойство)

Массив элементов коллекции

Синтаксис

[Visual Basic 6]
Property Items As Long

[Delphi]
property Items: Integer

Смотри также

Class IntegerCollection, Group Хранилища объектов


IntegerCollection.Add (метод)

Добавить новое число в коллекцию

Синтаксис

[Visual Basic 6]
Sub Add ( _
   ByVal Number As Long _
)

[Delphi]
procedure Add(
   const Number: Integer
)

Описание параметров

Number
[in] Добавляемое в коллекцию число

Смотри также

Class IntegerCollection, Group Хранилища объектов


IntegerCollection.AddItems (метод)

Добавить несколько чисел в коллекцию

Синтаксис

[Visual Basic 6]
Sub AddItems ( _
   ParamArray Numbers() As Variant _
)

[Delphi]
procedure AddItems(
   const Numbers: PSafeArray
)

Описание параметров

Numbers
[in] Добавляемые в коллекцию числа

Смотри также

Class IntegerCollection, Group Хранилища объектов


IntegerCollection.Clear (метод)

Удаляет все элементы из коллекции

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class IntegerCollection, Group Хранилища объектов


IntegerCollection.Delete (метод)

Удаляет элемент из коллекции

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер элемента в коллекции

Смотри также

Class IntegerCollection, Group Хранилища объектов


IntegerCollection.Invert (метод)

Меняет порядок элементов в коллекции на обратный

Синтаксис

[Visual Basic 6]
Sub Invert

[Delphi]
procedure Invert

Смотри также

Class IntegerCollection, Group Хранилища объектов


IntegerCollection.Sort (метод)

Выполнить сортировку чисел по возрастанию

Синтаксис

[Visual Basic 6]
Sub Sort

[Delphi]
procedure Sort

Смотри также

Class IntegerCollection, Group Хранилища объектов


Класс InterfaceCollection

Коллекция интерфейсов

Наследование

CustomCollection Class InterfaceCollection

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.InterfaceCollection

ClassID = {6002000E-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество объектов списке
Property Items | Массив элементов коллекции

Методы класса

Имя | Описание
Method Add | Добавить новое число в коллекцию
Method AddItems | Добавить несколько чисел в коллекцию
Method Clear | Удаляет все элементы из коллекции
Method Delete | Удаляет элемент из коллекции
Method Invert | Меняет порядок элементов в коллекции на обратный

Смотри также

Group Хранилища объектов


InterfaceCollection.Count (свойство)

Количество объектов списке

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class InterfaceCollection, Group Хранилища объектов


InterfaceCollection.Items (свойство)

Массив элементов коллекции

Синтаксис

[Visual Basic 6]
Property Items As IUnknown

[Delphi]
property Items: IUnknown

Смотри также

Class InterfaceCollection, Group Хранилища объектов


InterfaceCollection.Add (метод)

Добавить новое число в коллекцию

Синтаксис

[Visual Basic 6]
Sub Add ( _
   ByVal Object As IUnknown _
)

[Delphi]
procedure Add(
   const Object: IUnknown
)

Описание параметров

Object
[in] Добавляемое в коллекцию число

Смотри также

Class InterfaceCollection, Group Хранилища объектов


InterfaceCollection.AddItems (метод)

Добавить несколько чисел в коллекцию

Синтаксис

[Visual Basic 6]
Sub AddItems ( _
   ParamArray Objects() As Variant _
)

[Delphi]
procedure AddItems(
   const Objects: PSafeArray
)

Описание параметров

Objects
[in] Добавляемые в коллекцию числа

Смотри также

Class InterfaceCollection, Group Хранилища объектов


InterfaceCollection.Clear (метод)

Удаляет все элементы из коллекции

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class InterfaceCollection, Group Хранилища объектов


InterfaceCollection.Delete (метод)

Удаляет элемент из коллекции

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер элемента в коллекции

Смотри также

Class InterfaceCollection, Group Хранилища объектов


InterfaceCollection.Invert (метод)

Меняет порядок элементов в коллекции на обратный

Синтаксис

[Visual Basic 6]
Sub Invert

[Delphi]
procedure Invert

Смотри также

Class InterfaceCollection, Group Хранилища объектов


Класс IntersectionAdditionalPoint

Засечки

Наследование

GeoPoint Class AdditionalPoint Class RangeAdditionalPoint Class IntersectionAdditionalPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AdditionalParam | Дополнительный параметр
Property AdditionalPointType (только для чтения) | Тип засечки
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Number | Номер (описание) точки
Property Param1 | Первый параметр (определяется типом засечки)
Property Param2 | Второй параметр (определяется типом засечки)
Property Position | Положение точки
Property RangeLinkToPoints | Массив ссылок створных точек на другие точки
Property RangePointCount (только для чтения) | Количество створных (опорных) точек
Property RangePoints | Массив координат створных точек

Замечания

AdditionalParam - не используется.

Смотри также

Class GeoPoint, Enum IntersectionConstants, Class ModelPoint, Group Геодезия


IntersectionAdditionalPoint.AdditionalParam (свойство)

Дополнительный параметр

Синтаксис

[Visual Basic 6]
Property AdditionalParam As Long

[Delphi]
property AdditionalParam: Integer

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.AdditionalPointType (свойство)

Тип засечки

Синтаксис

[Visual Basic 6]
ReadOnly Property AdditionalPointType As IntersectionConstants

[Delphi]
{только для чтения} property AdditionalPointType: IntersectionConstants

Смотри также

Class IntersectionAdditionalPoint, Enum IntersectionConstants, Group Геодезия


IntersectionAdditionalPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.Param1 (свойство)

Первый параметр (определяется типом засечки)

Синтаксис

[Visual Basic 6]
Property Param1 As Double

[Delphi]
property Param1: Double

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.Param2 (свойство)

Второй параметр (определяется типом засечки)

Синтаксис

[Visual Basic 6]
Property Param2 As Double

[Delphi]
property Param2: Double

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class IntersectionAdditionalPoint, Class ModelPoint, Group Геодезия


IntersectionAdditionalPoint.RangeLinkToPoints (свойство)

Массив ссылок створных точек на другие точки

Синтаксис

[Visual Basic 6]
Property RangeLinkToPoints As GeoPoint

[Delphi]
property RangeLinkToPoints: GeoPoint

Смотри также

Class GeoPoint, Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.RangePointCount (свойство)

Количество створных (опорных) точек

Синтаксис

[Visual Basic 6]
ReadOnly Property RangePointCount As Long

[Delphi]
{только для чтения} property RangePointCount: Integer

Смотри также

Class IntersectionAdditionalPoint, Group Геодезия


IntersectionAdditionalPoint.RangePoints (свойство)

Массив координат створных точек

Синтаксис

[Visual Basic 6]
Property RangePoints As ModelPoint

[Delphi]
property RangePoints: ModelPoint

Смотри также

Class IntersectionAdditionalPoint, Class ModelPoint, Group Геодезия


Класс KnownAdditionalPoint

Точка с известными координатами

Наследование

GeoPoint Class AdditionalPoint Class KnownAdditionalPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AdditionalPointType (только для чтения) | Тип засечки
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Number | Номер (описание) точки
Property Position | Положение точки

Смотри также

Enum IntersectionConstants, Class ModelPoint, Group Геодезия


KnownAdditionalPoint.AdditionalPointType (свойство)

Тип засечки

Синтаксис

[Visual Basic 6]
ReadOnly Property AdditionalPointType As IntersectionConstants

[Delphi]
{только для чтения} property AdditionalPointType: IntersectionConstants

Смотри также

Enum IntersectionConstants, Class KnownAdditionalPoint, Group Геодезия


KnownAdditionalPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class KnownAdditionalPoint, Group Геодезия


KnownAdditionalPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class KnownAdditionalPoint, Group Геодезия


KnownAdditionalPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class KnownAdditionalPoint, Group Геодезия


KnownAdditionalPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class KnownAdditionalPoint, Group Геодезия


KnownAdditionalPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class KnownAdditionalPoint, Group Геодезия


KnownAdditionalPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class KnownAdditionalPoint, Class ModelPoint, Group Геодезия


Класс Layer

Слой цифровой модели

Наследование

BaseObject Class Aggregate Class Layer

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property CrossectionsColor | Цвет отображения в поперечных сечениях
Property CrossectionsDrawWidth | Толщина линий при экспорте поперечных профилей, мм
Property CrossectionsPenWidth | Толщина линий при отображении в поперечных сечениях в пикселях
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Возвращает подэлемент по его сингатуре (ветвь дерева)
Property Layers (только для чтения) | Список слоёв, которому принадлежит объект
Property Lines (только для чтения) | Набор линий и полигонов (рельефных и ситуационных)
Property Locked (только для чтения) | Заблокирован ли слой от изменений
Property Name | Имя слоя (отображается в дереве структуры проекта)
Property Options (только для чтения) | Настройки cлоя
Property Point (только для чтения) | Массив точек в слое (нумерация идёт от 0 до PointCount-1)
Property PointCount (только для чтения) | Количество точек в слое
Property Points (только для чтения) | Набор точек (рельефных и ситуационных)
Property Project (только для чтения) | Проект, к которому относится объект
Property ShowInCrossections | Отображается ли слой на поперечных сечениях
Property SurfacePainters (только для чтения) | Список элементов закраски поверхности
Property Triangulation (только для чтения) | Триангуляция слоя
Property Visible | Отображается ли слой и все его подобъекты в плане

Методы класса

Имя | Описание
Method AddPoint | Создаёт точку поверхности с указанными координатами
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method CalculateZbyXY | Возвращает Z-отметку в указанных модельных координатах
Method Changed | Информирует объект о том, что произошли изменения. SetModifiedFlag=True - объекту выставляется признак "Модифицирована". NeedRepaint=True - необходимо перерисовать план. OptionsChanged=True - изменились невизуальные свойства объекта
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetNearestPointIndex | Возвращает индекс точки поверхности, ближайшей к указанным координатам в заданной окрестности
Method GetNormalAt | Возвращает единичный вектор нормали к поверхности в точке с заданными координатами
Method GetPointXYZ | Возвращает координаты точки с указанным индексом
Method InvalidCrossectionsData | Вызывается подобъектами, если их данные, которые могут отображаться в сечениях, изменились
Method InvalidSurface | Вызывается, когда необходимо перестроить поверхность
Method Lock | Заблокировать слой от изменений (установить защиту)
Method MakeTreeStructure | Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта
Method TreeStructureChanged | Информирует объект о том, что необходимо перерисовать либо перестроить дерево структуры проекта
Method Unlock | Разблокировать слой (снять защиту)

Где используется

Класс | Член класса
Class ICADAssignableWithLayerObject | Method AppendDataToAnotherLayer (метод)
Class IProjectEvents | Method LayerDeleteQuery (метод) Method LayerDeleting (метод) Method LayerSurfaceInvalidated (метод)
Class Layers | Property ActiveLayer (свойство) Property Layers (свойство) Method AddLayer (метод) Method GetLayerByName (метод)
Class Project | Event LayerDeleteQuery (событие) Event LayerDeleting (событие) Event LayerSurfaceInvalidated (событие)
Class Route | Method PutDataToLayer (метод) Method RemoveDataFromLayer (метод)
Class SurfaceDifference | Property BottomLayer (свойство) Property TopLayer (свойство)
Class SurfaceDifferences | Method AddDifference (метод)

Смотри также

Class Application, Class CADTriangulation, Interface ICADObject, Interface IDocTreeHandler, Class LayerOptions, Class LayerPoint, Class LayerPoints, Class Lines, Class SurfacePainters, Group Поверхности


Layer.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class Layer, Group Поверхности


Layer.CrossectionsColor (свойство)

Цвет отображения в поперечных сечениях

Синтаксис

[Visual Basic 6]
Property CrossectionsColor As OLE_COLOR

[Delphi]
property CrossectionsColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Layer, Group Поверхности


Layer.CrossectionsDrawWidth (свойство)

Толщина линий при экспорте поперечных профилей, мм

Синтаксис

[Visual Basic 6]
Property CrossectionsDrawWidth As Double

[Delphi]
property CrossectionsDrawWidth: Double

Смотри также

Class Layer, Group Поверхности


Layer.CrossectionsPenWidth (свойство)

Толщина линий при отображении в поперечных сечениях в пикселях

Синтаксис

[Visual Basic 6]
Property CrossectionsPenWidth As Long

[Delphi]
property CrossectionsPenWidth: Integer

Смотри также

Class Layer, Group Поверхности


Layer.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Layer, Group Поверхности


Layer.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Layer, Group Поверхности


Layer.Items (свойство)

Возвращает подэлемент по его сингатуре (ветвь дерева)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As ICADObject

[Delphi]
{только для чтения} property Items: ICADObject

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface ICADObject, Class Layer, Group Поверхности


Layer.Layers (свойство)

Список слоёв, которому принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Layers As Layers

[Delphi]
{только для чтения} property Layers: Layers

Смотри также

Class Layer, Class Layers, Group Поверхности


Layer.Lines (свойство)

Набор линий и полигонов (рельефных и ситуационных)

Синтаксис

[Visual Basic 6]
ReadOnly Property Lines As Lines

[Delphi]
{только для чтения} property Lines: Lines

Смотри также

Class Layer, Class Lines, Group Поверхности


Layer.Locked (свойство)

Заблокирован ли слой от изменений

Синтаксис

[Visual Basic 6]
ReadOnly Property Locked As Boolean

[Delphi]
{только для чтения} property Locked: WordBool

Смотри также

Class Layer, Group Поверхности


Layer.Name (свойство)

Имя слоя (отображается в дереве структуры проекта)

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class Layer, Group Поверхности


Layer.Options (свойство)

Настройки cлоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Options As LayerOptions

[Delphi]
{только для чтения} property Options: LayerOptions

Смотри также

Class Layer, Class LayerOptions, Group Поверхности


Layer.Point (свойство)

Массив точек в слое (нумерация идёт от 0 до PointCount-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Point As LayerPoint

[Delphi]
{только для чтения} property Point: LayerPoint

Смотри также

Class Layer, Class LayerPoint, Group Поверхности


Layer.PointCount (свойство)

Количество точек в слое

Синтаксис

[Visual Basic 6]
ReadOnly Property PointCount As Long

[Delphi]
{только для чтения} property PointCount: Integer

Смотри также

Class Layer, Group Поверхности


Layer.Points (свойство)

Набор точек (рельефных и ситуационных)

Синтаксис

[Visual Basic 6]
ReadOnly Property Points As LayerPoints

[Delphi]
{только для чтения} property Points: LayerPoints

Смотри также

Class Layer, Class LayerPoints, Group Поверхности


Layer.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Layer, Class Project, Group Поверхности


Layer.ShowInCrossections (свойство)

Отображается ли слой на поперечных сечениях

Синтаксис

[Visual Basic 6]
Property ShowInCrossections As Boolean

[Delphi]
property ShowInCrossections: WordBool

Смотри также

Class Layer, Group Поверхности


Layer.SurfacePainters (свойство)

Список элементов закраски поверхности

Синтаксис

[Visual Basic 6]
ReadOnly Property SurfacePainters As SurfacePainters

[Delphi]
{только для чтения} property SurfacePainters: SurfacePainters

Смотри также

Class Layer, Class SurfacePainters, Group Поверхности


Layer.Triangulation (свойство)

Триангуляция слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As CADTriangulation

[Delphi]
{только для чтения} property Triangulation: CADTriangulation

Смотри также

Class CADTriangulation, Class Layer, Group Поверхности


Layer.Visible (свойство)

Отображается ли слой и все его подобъекты в плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Layer, Group Поверхности


Layer.AddPoint (метод)

Создаёт точку поверхности с указанными координатами

Синтаксис

[Visual Basic 6]
Function AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal Situation As Boolean _
) As LayerPoint

[Delphi]
function AddPoint(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const Situation: WordBool
): LayerPoint

Описание параметров

X
[in] Модельная X-координата создаваемой точки
Y
[in] Модельная Y-координата создаваемой точки
Z
[in] Модельная Z-координата создаваемой точки
Situation
[in] True - созданная точка будет ситуационной (не участвует в формировании поверхности), False - рельефной

Возвращаемое значение

Индекс созданной точки

Смотри также

Class Layer, Class LayerPoint, Group Поверхности


Layer.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Layer, Group Поверхности


Layer.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Layer, Group Поверхности


Layer.CalculateZbyXY (метод)

Возвращает Z-отметку в указанных модельных координатах

Синтаксис

[Visual Basic 6]
Function CalculateZbyXY ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   ByVal DefaultValue As Double, _
   ByVal ForceBuild As Boolean _
) As Double

[Delphi]
function CalculateZbyXY(
   const ModelX: Double;
   const ModelY: Double;
   const DefaultValue: Double;
   const ForceBuild: WordBool
): Double

Описание параметров

ModelX
[in] Модельная X-координата точки, в которой требуется вычислить Z-отметку
ModelY
[in] Модельная X-координата точки, в которой требуется вычислить Z-отметку
DefaultValue
[in] Значение, которое будет возвращено, если нет возможности вычислить Z-отметку
ForceBuild
[in] True - построить поверхность, если она ещё не построена, False - возвратить DefaultValue, если поверхность не построена

Возвращаемое значение

Вычисленная координата Z в указанной точке, либо DefaultValue, если вычислить значение невозможно

Смотри также

Class Layer, Group Поверхности


Layer.Changed (метод)

Информирует объект о том, что произошли изменения. SetModifiedFlag=True - объекту выставляется признак "Модифицирована". NeedRepaint=True - необходимо перерисовать план. OptionsChanged=True - изменились невизуальные свойства объекта

Синтаксис

[Visual Basic 6]
Sub Changed ( _
   ByVal SetModifiedFlag As Boolean, _
   ByVal NeedRepaint As Boolean, _
   ByVal OptionsChanged As Boolean _
)

[Delphi]
procedure Changed(
   const SetModifiedFlag: WordBool;
   const NeedRepaint: WordBool;
   const OptionsChanged: WordBool
)

Описание параметров

SetModifiedFlag
[in] True - необходимо установить у объекта признак "модифицирован"
NeedRepaint
[in] True - необходимо перерисовать план
OptionsChanged
[in] True - изменились невизуальные свойства объекта

Смотри также

Class Layer, Group Поверхности


Layer.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Layer, Group Поверхности


Layer.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Layer, Group Поверхности


Layer.GetNearestPointIndex (метод)

Возвращает индекс точки поверхности, ближайшей к указанным координатам в заданной окрестности

Синтаксис

[Visual Basic 6]
Function GetNearestPointIndex ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Eps As Double _
) As Long

[Delphi]
function GetNearestPointIndex(
   const X: Double;
   const Y: Double;
   const Eps: Double
): Integer

Описание параметров

X
[in] Модельная X-координата точки, в окрестности которой ищется точка поверхности
Y
[in] Модельная X-координата точки, в окрестности которой ищется точка поверхности
Eps
[in] Окрестность (радиус окружности в метрах), в которой ищется ближайшая точка

Возвращаемое значение

Индекс ближайшей найденой точки, либо "-1" в случае неудачи при поиске

Смотри также

Class Layer, Group Поверхности


Layer.GetNormalAt (метод)

Возвращает единичный вектор нормали к поверхности в точке с заданными координатами

Синтаксис

[Visual Basic 6]
Function GetNormalAt ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   NormalX As Double, _
   NormalY As Double, _
   NormalZ As Double _
) As Boolean

[Delphi]
function GetNormalAt(
   const ModelX: Double;
   const ModelY: Double;
   out NormalX: Double;
   out NormalY: Double;
   out NormalZ: Double
): WordBool

Описание параметров

ModelX
[in] Модельная X-координата точки, в которой необходимо вычислить нормаль к поверхности
ModelY
[in] Модельная X-координата точки, в которой необходимо вычислить нормаль к поверхности
NormalX
[out] X-составляющая вектора нормали
NormalY
[out] Y-составляющая вектора нормали
NormalZ
[out] Z-составляющая вектора нормали

Возвращаемое значение

True - если удалось вычислить значение нормали в точке, False - в случае ошибки

Смотри также

Class Layer, Group Поверхности


Layer.GetPointXYZ (метод)

Возвращает координаты точки с указанным индексом

Синтаксис

[Visual Basic 6]
Function GetPointXYZ ( _
   ByVal Index As Long, _
   X As Double, _
   Y As Double, _
   Z As Double _
) As Boolean

[Delphi]
function GetPointXYZ(
   const Index: Integer;
   out X: Double;
   out Y: Double;
   out Z: Double
): WordBool

Описание параметров

Index
[in] Индекс запрашиваемой точки
X
[out] Возвращаемая модельная X-координата точки
Y
[out] Возвращаемая модельная Y-координата точки
Z
[out] Возвращаемая модельная Z-координата точки

Возвращаемое значение

Результат операции: True - координаты возвращены успешно, False - ошибка

Смотри также

Class Layer, Group Поверхности


Layer.InvalidCrossectionsData (метод)

Вызывается подобъектами, если их данные, которые могут отображаться в сечениях, изменились

Синтаксис

[Visual Basic 6]
Sub InvalidCrossectionsData ( _
   ByVal StructureChanged As Boolean _
)

[Delphi]
procedure InvalidCrossectionsData(
   const StructureChanged: WordBool
)

Описание параметров

StructureChanged
[in] True - необходимо только перерисовать сечения, False - изменилась структура данных и необходимо перестроить список профильных объектов

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Layer, Group Поверхности


Layer.InvalidSurface (метод)

Вызывается, когда необходимо перестроить поверхность

Синтаксис

[Visual Basic 6]
Sub InvalidSurface ( _
   ByVal NeedRebuild As Boolean, _
   ByVal NeedReanalyse As Boolean _
)

[Delphi]
procedure InvalidSurface(
   const NeedRebuild: WordBool;
   const NeedReanalyse: WordBool
)

Описание параметров

NeedRebuild
[in] True - изменились данные для построения модели поверхности
NeedReanalyse
[in] True - изменились данные для анализа треугольников

Смотри также

Class Layer, Group Поверхности


Layer.Lock (метод)

Заблокировать слой от изменений (установить защиту)

Синтаксис

[Visual Basic 6]
Function Lock ( _
   ByVal Password As String _
) As Boolean

[Delphi]
function Lock(
   const Password: WideString
): WordBool

Описание параметров

Password
[in] Пароль для последующей разблокировки слоя

Возвращаемое значение

Результат операции: True - слой успешно заблокирован; False - ошибка

Смотри также

Class Layer, Group Поверхности


Layer.MakeTreeStructure (метод)

Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта

Синтаксис

[Visual Basic 6]
Sub MakeTreeStructure ( _
   ByVal Handler As IDocTreeHandler, _
   ByVal ParentID As Long, _
   ByVal Reason As Long, _
   ByVal IncludeHidden As Boolean _
)

[Delphi]
procedure MakeTreeStructure(
   const Handler: IDocTreeHandler;
   const ParentID: Integer;
   const Reason: Integer;
   const IncludeHidden: WordBool
)

Описание параметров

Handler
[in] Объект, которому будут поочерёдно передаваться все объекты, содержащиеся в проекте
ParentID
[in] Некий идентификатор родительского узла (обычно "0")
Reason
[in] Значение, которое будет передаваться в Handler при добавлении объектов. По нему Handler, принимающий перечисляемые объекты, может определить, что с ними делать
IncludeHidden
[in] Некоторые объекты могут не перечислять себя, если они не содержат подобъектов. Если IncludeHidden установлен в True, то объект должен перечислить себя в любом случае

Смотри также

Interface IDocTreeHandler, Class Layer, Group Поверхности


Layer.TreeStructureChanged (метод)

Информирует объект о том, что необходимо перерисовать либо перестроить дерево структуры проекта

Синтаксис

[Visual Basic 6]
Sub TreeStructureChanged ( _
   ByVal Rescan As Boolean _
)

[Delphi]
procedure TreeStructureChanged(
   const Rescan: WordBool
)

Описание параметров

Rescan
[in] True - дерево полностью будет перестроено, False - только перерисовано

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Layer, Group Поверхности


Layer.Unlock (метод)

Разблокировать слой (снять защиту)

Синтаксис

[Visual Basic 6]
Function Unlock ( _
   ByVal Password As String _
) As Boolean

[Delphi]
function Unlock(
   const Password: WideString
): WordBool

Описание параметров

Password
[in] Пароль, которым слой был заблокирован

Возвращаемое значение

Результат операции: True - слой успешно разблокирован; False - ошибка

Смотри также

Class Layer, Group Поверхности


Класс LayerCalculator

Калькулятор для векторного слоя карты

Наследование

Calculator Class LayerCalculator

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.LayerCalculator

ClassID = {60040041-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property DefID (только для записи) | DefId элементов слоя на которые работает запрос
Property ErrorMessage (только для чтения) | Соощение об ошибке
Property ErrorPosition (только для чтения) | Позиция, где найдена ошибка
Property Expression | Выражение, подлежащее вычислению
Property Figure (только для записи) | Фигура, из которой будут браться атрибуты
Property Layer (только для записи) | Слой карты, которому принадлежит фигура
Property ResultKind (только для чтения) | Тип результата
Property Value (только для чтения) | Результат в виде варианта

Методы класса

Имя | Описание
Method BuildExpression | Построить выражение запроса в специальном диалоге
Method Calculate | Вычисляет выражение
Method SyntaxCheck | Проверка синтаксиса входной строки

Смотри также

Enum CalculatorResultConstants, Class Figure, Class LayeredComposition, Class VectorLayer, Group Карты


LayerCalculator.DefID (свойство)

DefId элементов слоя на которые работает запрос

Синтаксис

[Visual Basic 6]
WriteOnly Property DefID As Long

[Delphi]
{только для записи} property DefID: Integer

Смотри также

Class LayerCalculator, Group Карты


LayerCalculator.ErrorMessage (свойство)

Соощение об ошибке

Синтаксис

[Visual Basic 6]
ReadOnly Property ErrorMessage As String

[Delphi]
{только для чтения} property ErrorMessage: WideString

Смотри также

Class LayerCalculator, Group Карты


LayerCalculator.ErrorPosition (свойство)

Позиция, где найдена ошибка

Синтаксис

[Visual Basic 6]
ReadOnly Property ErrorPosition As Long

[Delphi]
{только для чтения} property ErrorPosition: Integer

Смотри также

Class LayerCalculator, Group Карты


LayerCalculator.Expression (свойство)

Выражение, подлежащее вычислению

Синтаксис

[Visual Basic 6]
Property Expression As String

[Delphi]
property Expression: WideString

Смотри также

Class LayerCalculator, Group Карты


LayerCalculator.Figure (свойство)

Фигура, из которой будут браться атрибуты

Синтаксис

[Visual Basic 6]
WriteOnly Property Figure As Figure

[Delphi]
{только для записи} property Figure: Figure

Смотри также

Class Figure, Class LayerCalculator, Group Карты


LayerCalculator.Layer (свойство)

Слой карты, которому принадлежит фигура

Синтаксис

[Visual Basic 6]
WriteOnly Property Layer As VectorLayer

[Delphi]
{только для записи} property Layer: VectorLayer

Смотри также

Class LayerCalculator, Class VectorLayer, Group Карты


LayerCalculator.ResultKind (свойство)

Тип результата

Синтаксис

[Visual Basic 6]
ReadOnly Property ResultKind As CalculatorResultConstants

[Delphi]
{только для чтения} property ResultKind: CalculatorResultConstants

Смотри также

Enum CalculatorResultConstants, Class LayerCalculator, Group Карты


LayerCalculator.Value (свойство)

Результат в виде варианта

Синтаксис

[Visual Basic 6]
ReadOnly Property Value

[Delphi]
{только для чтения} property Value

Смотри также

Class LayerCalculator, Group Карты


LayerCalculator.BuildExpression (метод)

Построить выражение запроса в специальном диалоге

Синтаксис

[Visual Basic 6]
Sub BuildExpression ( _
   ByVal Composition As LayeredComposition _
)

[Delphi]
procedure BuildExpression(
   const Composition: LayeredComposition
)

Описание параметров

Composition
[in] Карта, для которой будет определено выражение

Смотри также

Class LayerCalculator, Class LayeredComposition, Group Карты


LayerCalculator.Calculate (метод)

Вычисляет выражение

Синтаксис

[Visual Basic 6]
Sub Calculate

[Delphi]
procedure Calculate

Смотри также

Class LayerCalculator, Group Карты


LayerCalculator.SyntaxCheck (метод)

Проверка синтаксиса входной строки

Синтаксис

[Visual Basic 6]
Function SyntaxCheck As Boolean

[Delphi]
function SyntaxCheck: WordBool

Возвращаемое значение

Возвращает True, если синтаксис верен

Смотри также

Class LayerCalculator, Group Карты


Класс LayerDataset

Набор данных слоя

Наследование

Dataset Class LayerDataset

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.LayerDataset

ClassID = {60040036-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Active | Открыт ли набор данных в настоящее время
Property AloneFigure | Если не 0, то открыть слой только на эту одну фигуру
Property BOF (только для чтения) | Курсор находится на начале набора данных
Property Bookmark | Закладка текущего положения в наборе данных
Property BrowserItems (только для чтения) | Элементы просмотра, используемые при открытии набора данных
Property CanModify (только для чтения) | Возможно ли изменение набора данных
Property DefID | Тип графических данных слоя
Property EOF (только для чтения) | Последняя запись набора данных
Property FieldCount (только для чтения) | Количество полей в наборе данных
Property Fields (только для чтения) | Массив полей набора данных
Property FieldStatus (только для чтения) | Статус подключения поля
Property FieldValids (только для чтения) | Доступно ли поле (установлена ли соответствующая связь)
Property Figure | Текущая фигура слоя
Property Filter | Фильтр на записи
Property Filtered | Включен ли фильтр
Property FilterText | Текст фильтра
Property Index | Текущий индекс набора данных
Property Indexes (только для чтения) | Все индексы набора данных
Property IsEmpty (только для чтения) | Пуст ли набор данных (т.е. нет записей)
Property IsFiltered | Включен ли фильтр
Property IsSequenced (только для чтения) | Можно использовать порядковые номера записей для перемещения по набору данных
Property Layer | Слой векторных данных
Property MainBrowserItems | Элементы просмотра главных полей набора данных
Property MainFieldCount (только для чтения) | Количество главных полей
Property Mode | Тип множества элементов в наборе данных слоя
Property NoLinks | Не подключать подключаемые наборы данных
Property RecNo | Номер текущей записи
Property RecordCount (только для чтения) | Количество записей в наборе данных
Property VirtualFieldOffset (только для чтения) | Номер первого виртуального поля

Методы класса

Имя | Описание
Method Append | Добавить в набор данных новую запись
Method Cancel | Отменить результаты редактирования
Method CheckBrowseMode | Перейти в режим просмотра
Method ClearFields | Очистить значения всех полей
Method Close | Закрыть набор данных
Method Delete | Удалить текущую запись
Method DisableControls | Запретить отображений изменений в визуальных элементах
Method Edit | Начать редактировать текущую запись
Method EnableControls | Разрешить отображений изменений в визуальных элементах
Method ExcludeNonSelected | Скрыть из набора данных все невыделенные записи
Method ExcludeSelected | Скрыть из набора данных все выделенные записи
Method FieldByDisplayName | Получить поле по отображаемому имени
Method FieldByName | Получить поле по его имени
Method First | Перейти к первой записи набора данных
Method Insert | Вставить новую запись в набор данных
Method Last | Перейти к последней записи набора данных
Method Locate | Перейти к записи с заданными значениями ключевых полей
Method MoveBy | Переместиться по набору данных на заданное количество записей вперед или назад
Method Next | Перейти к следующей записи
Method Open | Открыть набор данных
Method Post | Сохранить результаты редактирования в наборе данных
Method Prior | Перейти к предыдущей записи
Method Refresh | Перечитать записи набора данных
Method SelectAll | Выделить все фигуры в наборе данных
Method SelectInvert | Инвертировать выделение в наборе данных
Method SelectNone | Снять выделение с фигур набора данных
Method SortRecords | Отсортировать записи по указанному полю по возрастанию/убыванию

Где используется

Класс | Член класса
Class VectorLayer | Method GetLayerDataset (метод)

Смотри также

Class BrowserItems, Enum DatasetLinkingStatusConstants, Class Field, Class Figure, Enum LayerDatasetModeConstants, Group Карты


LayerDataset.Active (свойство)

Открыт ли набор данных в настоящее время

Синтаксис

[Visual Basic 6]
Property Active As Boolean

[Delphi]
property Active: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.AloneFigure (свойство)

Если не 0, то открыть слой только на эту одну фигуру

Синтаксис

[Visual Basic 6]
Property AloneFigure As Figure

[Delphi]
property AloneFigure: Figure

Смотри также

Class Figure, Class LayerDataset, Group Карты


LayerDataset.BOF (свойство)

Курсор находится на начале набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property BOF As Boolean

[Delphi]
{только для чтения} property BOF: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Bookmark (свойство)

Закладка текущего положения в наборе данных

Синтаксис

[Visual Basic 6]
Property Bookmark As String

[Delphi]
property Bookmark: WideString

Смотри также

Class LayerDataset, Group Карты


LayerDataset.BrowserItems (свойство)

Элементы просмотра, используемые при открытии набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property BrowserItems As BrowserItems

[Delphi]
{только для чтения} property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LayerDataset, Group Карты


LayerDataset.CanModify (свойство)

Возможно ли изменение набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property CanModify As Boolean

[Delphi]
{только для чтения} property CanModify: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.DefID (свойство)

Тип графических данных слоя

Синтаксис

[Visual Basic 6]
Property DefID As Long

[Delphi]
property DefID: Integer

Смотри также

Class LayerDataset, Group Карты


LayerDataset.EOF (свойство)

Последняя запись набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property EOF As Boolean

[Delphi]
{только для чтения} property EOF: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.FieldCount (свойство)

Количество полей в наборе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldCount As Long

[Delphi]
{только для чтения} property FieldCount: Integer

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Fields (свойство)

Массив полей набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Fields As Field

[Delphi]
{только для чтения} property Fields: Field

Смотри также

Class Field, Class LayerDataset, Group Карты


LayerDataset.FieldStatus (свойство)

Статус подключения поля

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldStatus As DatasetLinkingStatusConstants

[Delphi]
{только для чтения} property FieldStatus: DatasetLinkingStatusConstants

Смотри также

Enum DatasetLinkingStatusConstants, Class LayerDataset, Group Карты


LayerDataset.FieldValids (свойство)

Доступно ли поле (установлена ли соответствующая связь)

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldValids As Boolean

[Delphi]
{только для чтения} property FieldValids: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Figure (свойство)

Текущая фигура слоя

Синтаксис

[Visual Basic 6]
Property Figure As Figure

[Delphi]
property Figure: Figure

Смотри также

Class Figure, Class LayerDataset, Group Карты


LayerDataset.Filter (свойство)

Фильтр на записи

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Filtered (свойство)

Включен ли фильтр

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.FilterText (свойство)

Текст фильтра

Синтаксис

[Visual Basic 6]
Property FilterText As String

[Delphi]
property FilterText: WideString

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Index (свойство)

Текущий индекс набора данных

Синтаксис

[Visual Basic 6]
Property Index As String

[Delphi]
property Index: WideString

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Indexes (свойство)

Все индексы набора данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Indexes As String

[Delphi]
{только для чтения} property Indexes: WideString

Смотри также

Class LayerDataset, Group Карты


LayerDataset.IsEmpty (свойство)

Пуст ли набор данных (т.е. нет записей)

Синтаксис

[Visual Basic 6]
ReadOnly Property IsEmpty As Boolean

[Delphi]
{только для чтения} property IsEmpty: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.IsFiltered (свойство)

Включен ли фильтр

Синтаксис

[Visual Basic 6]
Property IsFiltered As Boolean

[Delphi]
property IsFiltered: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.IsSequenced (свойство)

Можно использовать порядковые номера записей для перемещения по набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property IsSequenced As Boolean

[Delphi]
{только для чтения} property IsSequenced: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Layer (свойство)

Слой векторных данных

Синтаксис

[Visual Basic 6]
Property Layer As VectorLayer

[Delphi]
property Layer: VectorLayer

Смотри также

Class LayerDataset, Class VectorLayer, Group Карты


LayerDataset.MainBrowserItems (свойство)

Элементы просмотра главных полей набора данных

Синтаксис

[Visual Basic 6]
Property MainBrowserItems As BrowserItems

[Delphi]
property MainBrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LayerDataset, Group Карты


LayerDataset.MainFieldCount (свойство)

Количество главных полей

Синтаксис

[Visual Basic 6]
ReadOnly Property MainFieldCount As Long

[Delphi]
{только для чтения} property MainFieldCount: Integer

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Mode (свойство)

Тип множества элементов в наборе данных слоя

Синтаксис

[Visual Basic 6]
Property Mode As LayerDatasetModeConstants

[Delphi]
property Mode: LayerDatasetModeConstants

Смотри также

Class LayerDataset, Enum LayerDatasetModeConstants, Group Карты


LayerDataset.NoLinks (свойство)

Не подключать подключаемые наборы данных

Синтаксис

[Visual Basic 6]
Property NoLinks As Boolean

[Delphi]
property NoLinks: WordBool

Смотри также

Class LayerDataset, Group Карты


LayerDataset.RecNo (свойство)

Номер текущей записи

Синтаксис

[Visual Basic 6]
Property RecNo As Long

[Delphi]
property RecNo: Integer

Смотри также

Class LayerDataset, Group Карты


LayerDataset.RecordCount (свойство)

Количество записей в наборе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property RecordCount As Long

[Delphi]
{только для чтения} property RecordCount: Integer

Смотри также

Class LayerDataset, Group Карты


LayerDataset.VirtualFieldOffset (свойство)

Номер первого виртуального поля

Синтаксис

[Visual Basic 6]
ReadOnly Property VirtualFieldOffset As Long

[Delphi]
{только для чтения} property VirtualFieldOffset: Integer

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Append (метод)

Добавить в набор данных новую запись

Синтаксис

[Visual Basic 6]
Sub Append

[Delphi]
procedure Append

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Cancel (метод)

Отменить результаты редактирования

Синтаксис

[Visual Basic 6]
Sub Cancel

[Delphi]
procedure Cancel

Смотри также

Class LayerDataset, Group Карты


LayerDataset.CheckBrowseMode (метод)

Перейти в режим просмотра

Синтаксис

[Visual Basic 6]
Sub CheckBrowseMode

[Delphi]
procedure CheckBrowseMode

Смотри также

Class LayerDataset, Group Карты


LayerDataset.ClearFields (метод)

Очистить значения всех полей

Синтаксис

[Visual Basic 6]
Sub ClearFields

[Delphi]
procedure ClearFields

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Close (метод)

Закрыть набор данных

Синтаксис

[Visual Basic 6]
Sub Close

[Delphi]
procedure Close

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Delete (метод)

Удалить текущую запись

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class LayerDataset, Group Карты


LayerDataset.DisableControls (метод)

Запретить отображений изменений в визуальных элементах

Синтаксис

[Visual Basic 6]
Sub DisableControls

[Delphi]
procedure DisableControls

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Edit (метод)

Начать редактировать текущую запись

Синтаксис

[Visual Basic 6]
Sub Edit

[Delphi]
procedure Edit

Смотри также

Class LayerDataset, Group Карты


LayerDataset.EnableControls (метод)

Разрешить отображений изменений в визуальных элементах

Синтаксис

[Visual Basic 6]
Sub EnableControls

[Delphi]
procedure EnableControls

Смотри также

Class LayerDataset, Group Карты


LayerDataset.ExcludeNonSelected (метод)

Скрыть из набора данных все невыделенные записи

Синтаксис

[Visual Basic 6]
Sub ExcludeNonSelected

[Delphi]
procedure ExcludeNonSelected

Смотри также

Class LayerDataset, Group Карты


LayerDataset.ExcludeSelected (метод)

Скрыть из набора данных все выделенные записи

Синтаксис

[Visual Basic 6]
Sub ExcludeSelected

[Delphi]
procedure ExcludeSelected

Смотри также

Class LayerDataset, Group Карты


LayerDataset.FieldByDisplayName (метод)

Получить поле по отображаемому имени

Синтаксис

[Visual Basic 6]
Function FieldByDisplayName ( _
   ByVal DisplayName As String _
) As Field

[Delphi]
function FieldByDisplayName(
   const DisplayName: WideString
): Field

Описание параметров

DisplayName
[in] Отображаемое название поля

Возвращаемое значение

Возвращает поле с указанным отображаемым назанием полем, либо Nothing, если поля с таким названием не существует

Смотри также

Class Field, Class LayerDataset, Group Карты


LayerDataset.FieldByName (метод)

Получить поле по его имени

Синтаксис

[Visual Basic 6]
Function FieldByName ( _
   ByVal FieldName As String _
) As Field

[Delphi]
function FieldByName(
   const FieldName: WideString
): Field

Описание параметров

FieldName
[in] Имя поля

Возвращаемое значение

Возвращает поле с указанным именем, либо Nothing, если поля с таким именем не существует

Смотри также

Class Field, Class LayerDataset, Group Карты


LayerDataset.First (метод)

Перейти к первой записи набора данных

Синтаксис

[Visual Basic 6]
Sub First

[Delphi]
procedure First

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Insert (метод)

Вставить новую запись в набор данных

Синтаксис

[Visual Basic 6]
Sub Insert

[Delphi]
procedure Insert

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Last (метод)

Перейти к последней записи набора данных

Синтаксис

[Visual Basic 6]
Sub Last

[Delphi]
procedure Last

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Locate (метод)

Перейти к записи с заданными значениями ключевых полей

Синтаксис

[Visual Basic 6]
Function Locate ( _
   ByVal KeyFields As String, _
   ByVal KeyValues As Variant, _
   [ByVal CaseInsensitive As Boolean = False], _
   [ByVal PartialKey As Boolean = False] _
) As Boolean

[Delphi]
function Locate(
   const KeyFields: WideString;
   const KeyValues: Variant;
   const CaseInsensitive: WordBool;
   const PartialKey: WordBool
): WordBool

Описание параметров

KeyFields
[in] Список ключевых полей, разделенных точками с запятой
KeyValues
[in] Значение ключевого поля или массив значений ключевых полей
CaseInsensitive
[in] Если True, то при сравнении значений игнорировать различия в регистре букв
PartialKey
[in] Если True, то при сравнении достаточно, чтобы найденная запись хотя бы начиналась с заданного в KeyValues значения

Возвращаемое значение

Возвращает True, если запись с указанными значениями ключевым полей успешно найдена

Смотри также

Class LayerDataset, Group Карты


LayerDataset.MoveBy (метод)

Переместиться по набору данных на заданное количество записей вперед или назад

Синтаксис

[Visual Basic 6]
Sub MoveBy ( _
   ByVal Distance As Long _
)

[Delphi]
procedure MoveBy(
   const Distance: Integer
)

Описание параметров

Distance
[in] Количество записей, на котороые надо переместиться в наборе данных

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Next (метод)

Перейти к следующей записи

Синтаксис

[Visual Basic 6]
Sub Next

[Delphi]
procedure Next

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Open (метод)

Открыть набор данных

Синтаксис

[Visual Basic 6]
Sub Open

[Delphi]
procedure Open

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Post (метод)

Сохранить результаты редактирования в наборе данных

Синтаксис

[Visual Basic 6]
Sub Post

[Delphi]
procedure Post

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Prior (метод)

Перейти к предыдущей записи

Синтаксис

[Visual Basic 6]
Sub Prior

[Delphi]
procedure Prior

Смотри также

Class LayerDataset, Group Карты


LayerDataset.Refresh (метод)

Перечитать записи набора данных

Синтаксис

[Visual Basic 6]
Sub Refresh

[Delphi]
procedure Refresh

Смотри также

Class LayerDataset, Group Карты


LayerDataset.SelectAll (метод)

Выделить все фигуры в наборе данных

Синтаксис

[Visual Basic 6]
Function SelectAll As Boolean

[Delphi]
function SelectAll: WordBool

Возвращаемое значение

Возвращает True, если была выделена хотя бы одна фигура

Смотри также

Class LayerDataset, Group Карты


LayerDataset.SelectInvert (метод)

Инвертировать выделение в наборе данных

Синтаксис

[Visual Basic 6]
Function SelectInvert As Boolean

[Delphi]
function SelectInvert: WordBool

Возвращаемое значение

Возвращает True, если было инвертировано выделение хотя бы одной фигуры

Смотри также

Class LayerDataset, Group Карты


LayerDataset.SelectNone (метод)

Снять выделение с фигур набора данных

Синтаксис

[Visual Basic 6]
Function SelectNone As Boolean

[Delphi]
function SelectNone: WordBool

Возвращаемое значение

Возвращает True, если было снято выделение хотя бы с одной фигуры

Смотри также

Class LayerDataset, Group Карты


LayerDataset.SortRecords (метод)

Отсортировать записи по указанному полю по возрастанию/убыванию

Синтаксис

[Visual Basic 6]
Sub SortRecords ( _
   ByVal Field1 As String, _
   [ByVal Fields2 As String = ""], _
   [ByVal Fields3 As String = ""], _
   [ByVal Ascending1 As Boolean = False], _
   [ByVal Ascending2 As Boolean = False], _
   [ByVal Ascending3 As Boolean = False] _
)

[Delphi]
procedure SortRecords(
   const Field1: WideString;
   const Fields2: WideString;
   const Fields3: WideString;
   const Ascending1: WordBool;
   const Ascending2: WordBool;
   const Ascending3: WordBool
)

Описание параметров

Field1
[in] Имя первого поля для сортировки
Fields2
[in] Необязательное имя второго поля для сортировки
Fields3
[in] Необязательное имя третьего поля для сортировки
Ascending1
[in] Признак того, что по первому полю надо сортировать по возрастанию значений
Ascending2
[in] Признак того, что по второму полю надо сортировать по возрастанию значений
Ascending3
[in] Признак того, что по третьему полю надо сортировать по возрастанию значений

Смотри также

Class LayerDataset, Group Карты


Класс LayerOptions

Настройки слоя

Наследование

CustomOptions Class LayerOptions

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property CustomValueName (только для чтения) | Массив имён пользовательских значений
Property CustomValuesCount (только для чтения) | Количество пользовательских значений

Методы класса

Имя | Описание
Method DeleteCustomValue | Удалить из настроек пользовательское значение
Method GetCustomValue | Получить из настроек пользовательское значение
Method SetCustomValue | Запомнить в настройках пользовательское значение

Где используется

Класс | Член класса
Class Layer | Property Options (свойство)

Смотри также

Group Поверхности


LayerOptions.CustomValueName (свойство)

Массив имён пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValueName As String

[Delphi]
{только для чтения} property CustomValueName: WideString

Смотри также

Class LayerOptions, Group Поверхности


LayerOptions.CustomValuesCount (свойство)

Количество пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValuesCount As Long

[Delphi]
{только для чтения} property CustomValuesCount: Integer

Смотри также

Class LayerOptions, Group Поверхности


LayerOptions.DeleteCustomValue (метод)

Удалить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Function DeleteCustomValue ( _
   ByVal Name As String _
) As Boolean

[Delphi]
function DeleteCustomValue(
   const Name: WideString
): WordBool

Описание параметров

Name
[in] Имя значения, подлежащего удалению

Возвращаемое значение

True - значение удалено, False - не найдено значения с указанным именем

Смотри также

Class LayerOptions, Group Поверхности


LayerOptions.GetCustomValue (метод)

Получить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Sub GetCustomValue ( _
   ByVal Name As String, _
   ByVal DefaultValue As Variant _
)

[Delphi]
procedure GetCustomValue(
   const Name: WideString;
   const DefaultValue: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
DefaultValue
[in] Значение, которое будет возвращено, если в настройках не содержится ассоциациированного с указанным именем значения

Смотри также

Class LayerOptions, Group Поверхности


LayerOptions.SetCustomValue (метод)

Запомнить в настройках пользовательское значение

Синтаксис

[Visual Basic 6]
Sub SetCustomValue ( _
   ByVal Name As String, _
   ByVal Value As Variant _
)

[Delphi]
procedure SetCustomValue(
   const Name: WideString;
   const Value: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
Value
[in] Значение, ассоциируемое с указанным именем

Смотри также

Class LayerOptions, Group Поверхности


Класс LayerPoint

Точка поверхности

Наследование

BaseObject Class LayerPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property CaptionAngle | Угол подписи точки в плане, в радианах
Property CaptionOffset | Отступ подписи от точки в плане, мм
Property CaptionOffsetV | Отступ подписи от точки (по нормали к углу подписи) в плане, мм
Property Comment | Комментарий, заданный точке
Property DrawCaption | Как отображать подпись точки в плане
Property Handle (только для чтения) | Handle объекта
Property Hidden | Отображается ли точка в плане
Property ID (только для чтения) | ID объекта
Property Name | Имя точки
Property Project (только для чтения) | Проект, к которому относится объект
Property Selected | Выделена ли точка
Property SignCount (только для чтения) | Количество знаков, назначенных точке
Property Situation | Является ли точка ситуационной
Property Tag | Произвольное целое число
Property X | X-координата точки
Property Y | Y-координата точки
Property Z | Z-координата точки

Методы класса

Имя | Описание
Method AddSign | Добавить знак точке
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetSign | Получить знак, назначенный точке

Где используется

Класс | Член класса
Class Layer | Property Point (свойство) Method AddPoint (метод)
Class LayerPoints | Property Points (свойство)
Class Line | Property Point (свойство)

Смотри также

Class Application, Enum DrawPointCaption, Class Project, Group Поверхности


LayerPoint.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class LayerPoint, Group Поверхности


LayerPoint.CaptionAngle (свойство)

Угол подписи точки в плане, в радианах

Синтаксис

[Visual Basic 6]
Property CaptionAngle As Double

[Delphi]
property CaptionAngle: Double

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.CaptionOffset (свойство)

Отступ подписи от точки в плане, мм

Синтаксис

[Visual Basic 6]
Property CaptionOffset As Double

[Delphi]
property CaptionOffset: Double

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.CaptionOffsetV (свойство)

Отступ подписи от точки (по нормали к углу подписи) в плане, мм

Синтаксис

[Visual Basic 6]
Property CaptionOffsetV As Double

[Delphi]
property CaptionOffsetV: Double

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.Comment (свойство)

Комментарий, заданный точке

Синтаксис

[Visual Basic 6]
Property Comment As String

[Delphi]
property Comment: WideString

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.DrawCaption (свойство)

Как отображать подпись точки в плане

Синтаксис

[Visual Basic 6]
Property DrawCaption As DrawPointCaption

[Delphi]
property DrawCaption: DrawPointCaption

Смотри также

Enum DrawPointCaption, Class LayerPoint, Group Поверхности


LayerPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.Hidden (свойство)

Отображается ли точка в плане

Синтаксис

[Visual Basic 6]
Property Hidden As Boolean

[Delphi]
property Hidden: WordBool

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.Name (свойство)

Имя точки

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class LayerPoint, Class Project, Group Поверхности


LayerPoint.Selected (свойство)

Выделена ли точка

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.SignCount (свойство)

Количество знаков, назначенных точке

Синтаксис

[Visual Basic 6]
ReadOnly Property SignCount As Long

[Delphi]
{только для чтения} property SignCount: Integer

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.Situation (свойство)

Является ли точка ситуационной

Синтаксис

[Visual Basic 6]
Property Situation As Boolean

[Delphi]
property Situation: WordBool

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.Tag (свойство)

Произвольное целое число

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.X (свойство)

X-координата точки

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.Y (свойство)

Y-координата точки

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.Z (свойство)

Z-координата точки

Синтаксис

[Visual Basic 6]
Property Z As Double

[Delphi]
property Z: Double

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.AddSign (метод)

Добавить знак точке

Синтаксис

[Visual Basic 6]
Sub AddSign ( _
   ByVal Sign As Long, _
   ByVal Angle As Double, _
   ByVal Color As OLE_COLOR, _
   ByVal Scale As Double _
)

[Delphi]
procedure AddSign(
   const Sign: Integer;
   const Angle: Double;
   const Color: OLE_COLOR;
   const Scale: Double
)

Описание параметров

Sign
[in] Код символа, назначаемого точке
Angle
[in] Значение угла в радианах, на который будет повёрнут символ при отрисовке
Color
[in] Цвет отображения символа
Scale
[in] Изменение масштаба символа (значение может быть в диапазоне от 1 до 10000)

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class LayerPoint, Group Поверхности


LayerPoint.GetSign (метод)

Получить знак, назначенный точке

Синтаксис

[Visual Basic 6]
Function GetSign ( _
   ByVal Index As Long, _
   Sign As Long, _
   Color As OLE_COLOR, _
   Angle As Double, _
   Scale As Double _
) As Boolean

[Delphi]
function GetSign(
   const Index: Integer;
   out Sign: Integer;
   out Color: OLE_COLOR;
   out Angle: Double;
   out Scale: Double
): WordBool

Описание параметров

Index
[in] Индекс запрашиваемого симовла (нумерация идёт от 0 до SignCount-1)
Sign
[out] Возвращаемый код символа
Color
[out] Возвращаемый цвет символа
Angle
[out] Возвращаемое значение угла в радианах, под которым отображается символ
Scale
[out] Возвращаемое значение масштаба символа относительно стандартного (значение в диапазоне от 1 до 10000)

Возвращаемое значение

Результат операции: True - значения успешно возвращены, False - ошибка

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LayerPoint, Group Поверхности


Класс LayerPoints

Набор точек (рельефных и ситуационных)

Наследование

BaseObject Class LayerPoints

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property CaptionColor | Цвет, которым отображается подпись к точке
Property CaptionFontName | Шрифт, которым отображается подпись к точке
Property CaptionFontSize | Размер шрифта, которым отображается подпись к точке в миллиметрах
Property Color | Цвет, которым отображаются рельефные точки
Property Count (только для чтения) | Количество объектов, которое содержит в себе данный объект
Property DefaultCaptionAngle | Угол наклона подписей к точкам по умолчанию в радианах
Property DefaultCaptionOffset | Расстояние подписи от точки по умолчанию в миллиметрах чертежа
Property DrawAsCircle | Форма отображения точек: True - окружность, False - крест
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Массив объектов (нумерация идёт от 0 до Count-1)
Property Points (только для чтения) | Массив точек
Property Project (только для чтения) | Проект, к которому относится объект
Property ShowCaptions | Показывать ли подписи у точек
Property ShowCaptionsForAll | Перекрывать ли собственные настройки отображения подписей точек
Property ShowSigns | Отображать ли условные знаки, назначенные точкам
Property SituationColor | Цвет, которым отображаются ситуационные точки
Property Size | Размер точки в миллиметрах
Property Visible | Отображаются ли точки в плане
Property Width | Толщина линий при отрисовке точек в миллиметрах

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Clear | Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект
Method Delete | Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Где используется

Класс | Член класса
Class Layer | Property Points (свойство)

Смотри также

Class Application, Class BaseObject, Enum DrawPointCaption, Class LayerPoint, Class Project, Group Поверхности


LayerPoints.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class LayerPoints, Group Поверхности


LayerPoints.CaptionColor (свойство)

Цвет, которым отображается подпись к точке

Синтаксис

[Visual Basic 6]
Property CaptionColor As OLE_COLOR

[Delphi]
property CaptionColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.CaptionFontName (свойство)

Шрифт, которым отображается подпись к точке

Синтаксис

[Visual Basic 6]
Property CaptionFontName As String

[Delphi]
property CaptionFontName: WideString

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.CaptionFontSize (свойство)

Размер шрифта, которым отображается подпись к точке в миллиметрах

Синтаксис

[Visual Basic 6]
Property CaptionFontSize As Double

[Delphi]
property CaptionFontSize: Double

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Color (свойство)

Цвет, которым отображаются рельефные точки

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Count (свойство)

Количество объектов, которое содержит в себе данный объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.DefaultCaptionAngle (свойство)

Угол наклона подписей к точкам по умолчанию в радианах

Синтаксис

[Visual Basic 6]
Property DefaultCaptionAngle As Double

[Delphi]
property DefaultCaptionAngle: Double

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.DefaultCaptionOffset (свойство)

Расстояние подписи от точки по умолчанию в миллиметрах чертежа

Синтаксис

[Visual Basic 6]
Property DefaultCaptionOffset As Double

[Delphi]
property DefaultCaptionOffset: Double

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.DrawAsCircle (свойство)

Форма отображения точек: True - окружность, False - крест

Синтаксис

[Visual Basic 6]
Property DrawAsCircle As Boolean

[Delphi]
property DrawAsCircle: WordBool

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Items (свойство)

Массив объектов (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BaseObject

[Delphi]
{только для чтения} property Items: BaseObject

Смотри также

Class BaseObject, Class LayerPoints, Group Поверхности


LayerPoints.Points (свойство)

Массив точек

Синтаксис

[Visual Basic 6]
ReadOnly Property Points As LayerPoint

[Delphi]
{только для чтения} property Points: LayerPoint

Смотри также

Class LayerPoint, Class LayerPoints, Group Поверхности


LayerPoints.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class LayerPoints, Class Project, Group Поверхности


LayerPoints.ShowCaptions (свойство)

Показывать ли подписи у точек

Синтаксис

[Visual Basic 6]
Property ShowCaptions As DrawPointCaption

[Delphi]
property ShowCaptions: DrawPointCaption

Смотри также

Enum DrawPointCaption, Class LayerPoints, Group Поверхности


LayerPoints.ShowCaptionsForAll (свойство)

Перекрывать ли собственные настройки отображения подписей точек

Синтаксис

[Visual Basic 6]
Property ShowCaptionsForAll As Boolean

[Delphi]
property ShowCaptionsForAll: WordBool

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.ShowSigns (свойство)

Отображать ли условные знаки, назначенные точкам

Синтаксис

[Visual Basic 6]
Property ShowSigns As Boolean

[Delphi]
property ShowSigns: WordBool

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.SituationColor (свойство)

Цвет, которым отображаются ситуационные точки

Синтаксис

[Visual Basic 6]
Property SituationColor As OLE_COLOR

[Delphi]
property SituationColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Size (свойство)

Размер точки в миллиметрах

Синтаксис

[Visual Basic 6]
Property Size As Double

[Delphi]
property Size: Double

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Visible (свойство)

Отображаются ли точки в плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Width (свойство)

Толщина линий при отрисовке точек в миллиметрах

Синтаксис

[Visual Basic 6]
Property Width As Double

[Delphi]
property Width: Double

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Clear (метод)

Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.Delete (метод)

Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс объекта (нумерация идёт от 0 до Count-1)

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class LayerPoints, Group Поверхности


LayerPoints.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class LayerPoints, Group Поверхности


Класс LayerRequest

Запрос к карте

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property DefID | Тип элементов
Property Description | Описание запроса
Property Expression | Выражение запроса
Property LayerSeqId | Номер слоя
Property ShortCut | Горячая клавиша
Property Style | Стиль запроса
Property VariableCount (только для чтения) | Количество переменных, подлежащих вводу в диалоге
Property Variables (только для чтения) | Массив переменных, подлежащих вводу в диалоге

Методы класса

Имя | Описание
Method Execute | Выполнить запрос

Где используется

Класс | Член класса
Class RequestVariable | Property LayerRequest (свойство)

Смотри также

Enum LayerRequestConstants, Class VectorContainer, Group Карты


LayerRequest.DefID (свойство)

Тип элементов

Синтаксис

[Visual Basic 6]
Property DefID As Long

[Delphi]
property DefID: Integer

Смотри также

Class LayerRequest, Group Карты


LayerRequest.Description (свойство)

Описание запроса

Синтаксис

[Visual Basic 6]
Property Description As String

[Delphi]
property Description: WideString

Смотри также

Class LayerRequest, Group Карты


LayerRequest.Expression (свойство)

Выражение запроса

Синтаксис

[Visual Basic 6]
Property Expression As String

[Delphi]
property Expression: WideString

Смотри также

Class LayerRequest, Group Карты


LayerRequest.LayerSeqId (свойство)

Номер слоя

Синтаксис

[Visual Basic 6]
Property LayerSeqId As Long

[Delphi]
property LayerSeqId: Integer

Смотри также

Class LayerRequest, Group Карты


LayerRequest.ShortCut (свойство)

Горячая клавиша

Синтаксис

[Visual Basic 6]
Property ShortCut As Long

[Delphi]
property ShortCut: Integer

Смотри также

Class LayerRequest, Group Карты


LayerRequest.Style (свойство)

Стиль запроса

Синтаксис

[Visual Basic 6]
Property Style As LayerRequestConstants

[Delphi]
property Style: LayerRequestConstants

Смотри также

Class LayerRequest, Enum LayerRequestConstants, Group Карты


LayerRequest.VariableCount (свойство)

Количество переменных, подлежащих вводу в диалоге

Синтаксис

[Visual Basic 6]
ReadOnly Property VariableCount As Long

[Delphi]
{только для чтения} property VariableCount: Integer

Смотри также

Class LayerRequest, Group Карты


LayerRequest.Variables (свойство)

Массив переменных, подлежащих вводу в диалоге

Синтаксис

[Visual Basic 6]
ReadOnly Property Variables As RequestVariable

[Delphi]
{только для чтения} property Variables: RequestVariable

Смотри также

Class LayerRequest, Class RequestVariable, Group Карты


LayerRequest.Execute (метод)

Выполнить запрос

Синтаксис

[Visual Basic 6]
Function Execute ( _
   ByVal Container As VectorContainer, _
   ByVal UseVariables As Boolean, _
   [ByVal NeedRefreshImage As Boolean = True] _
) As Boolean

[Delphi]
function Execute(
   const Container: VectorContainer;
   const UseVariables: WordBool;
   const NeedRefreshImage: WordBool
): WordBool

Описание параметров

Container
[in] Контейнер, в котором нужно выполнить запрос
UseVariables
[in] Запрашивать ли значения переменных в диалоге у пользователя
NeedRefreshImage
[in] Обновить ли изображение по сле выполнения запроса

Возвращаемое значение

Возвращает True, если запрос был успешно выполнен

Смотри также

Class LayerRequest, Class VectorContainer, Group Карты


Класс LayeredComposition

Композиция со слоями

Наследование

Composition Class LayeredComposition

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Assemblies (только для чтения) | Массив собраний слоёв в композиции
Property AssemblyCount (только для чтения) | Общее количество собраний слоёв в композиции
Property Author | Автор композиции
Property BackColor | Цвет фона композиции
Property BookmarkCount (только для чтения) | Количество закладок на композиции
Property Bookmarks (только для чтения) | Массив закладок композиции
Property Caption | Название композиции
Property Company | Учреждение, где выполнена работа
Property ContainerCount (только для чтения) | Количество контейнеров, отображающих данную композицию
Property Containers (только для чтения) | Массив контейнеров, отображающих данную композицию
Property Depository (только для чтения) | Хранилище переменных
Property Description | Описание композиции
Property DistanceUnit | Единицы измерения расстояний
Property FileName (только для чтения) | Имя файла с композицией
Property Layers (только для чтения) | Коллекция слоёв композиции
Property MainContainer (только для чтения) | Главный контейнер, отображающий карту
Property MaxScale | Максимальный доступный MaxDevScale контейнера при отрисовке
Property MinScale | Минимальный доступный MapDevScale контейнера при отрисовке
Property ModelUnit | Исходные единицы модели
Property Modified | Признак модификации композиции
Property Projection (только для чтения) | Картографическая проекция композиция
Property RootPath (только для чтения) | Возвращает путь, относительно которого должны сохраняться параметры композиции и её слоёв
Property ShowScrollBars | Показывать ли полосы скроллинга в главном контейнере
Property SquareUnit | Единицы измерения площадей на композиции
Property StandardScaleCount (только для чтения) | Количество стандартных масштабов композиции
Property StandardScales (только для чтения) | Массив стандартных масштабов композиции
Property SystemAxes | Ориентация осей координат (по умолчанию SystemAxesXright_Yup)
Property SystemAxesRotation | Поворот системы координат
Property ValidCaption (только для чтения) | Название композиции (если Caption не задано, то используется имя файла)

Методы класса

Имя | Описание
Method AddAssembly | Добавить новое собрание слоёв
Method AddBookmark | Добавить новую закладку
Method AddLayer | Добавить слой из файла
Method AddNewLayer | Создать новый слой
Method AddStandardScale | Добавить стандартный масштаб
Method DeleteAllBookmarks | Удалить все закладки
Method DeleteAssembly | Удалить собрание слоёв с указанным номером
Method DeleteBookmark | Удалить закладку
Method DeleteStandardScale | Удалить стандартный масштаб
Method GotoBookmark | Перейти по заданной закладке
Method InvalidateContainers | Перерисовать все связанные контейнеры
Method LayerByName | Найти слой по его имени
Method LayerBySeqID | Найти слой по его коду
Method MoveAssembly | Переместить собрание слоёв в списке с одной позиции в другую
Method Paint | Отрисовка карты в заданную позицию
Method Print | Распечатать на принтере на одной странице видимую часть карты
Method PrintPages | Распечатать на принтере заданную часть карты (возможно на нескольких страницах)
Method PrintRect | Распечатать на принтере на одной странице видимую часть карты
Method RefreshContainers | Обновить изображение во всех связанных контейнерах

Где используется

Класс | Член класса
Class Assembly | Property Composition (свойство) Method WillChange (метод)
Class LayerCalculator | Method BuildExpression (метод)

Смотри также

Class CompositionLayer, Class ContainerBookmark, Class CustomContainer, Class Depository, Class FlatPoint, Class FolderLayer, Enum ModelUnitConstants, Class Projection, Class Rect, Class StandardScale, Enum SystemAxesConstants, Group Карты


LayeredComposition.Assemblies (свойство)

Массив собраний слоёв в композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property Assemblies As Assembly

[Delphi]
{только для чтения} property Assemblies: Assembly

Смотри также

Class Assembly, Class LayeredComposition, Group Карты


LayeredComposition.AssemblyCount (свойство)

Общее количество собраний слоёв в композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property AssemblyCount As Long

[Delphi]
{только для чтения} property AssemblyCount: Integer

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.Author (свойство)

Автор композиции

Синтаксис

[Visual Basic 6]
Property Author As String

[Delphi]
property Author: WideString

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.BackColor (свойство)

Цвет фона композиции

Синтаксис

[Visual Basic 6]
Property BackColor As OLE_COLOR

[Delphi]
property BackColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.BookmarkCount (свойство)

Количество закладок на композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property BookmarkCount As Long

[Delphi]
{только для чтения} property BookmarkCount: Integer

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.Bookmarks (свойство)

Массив закладок композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property Bookmarks As ContainerBookmark

[Delphi]
{только для чтения} property Bookmarks: ContainerBookmark

Смотри также

Class ContainerBookmark, Class LayeredComposition, Group Карты


LayeredComposition.Caption (свойство)

Название композиции

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.Company (свойство)

Учреждение, где выполнена работа

Синтаксис

[Visual Basic 6]
Property Company As String

[Delphi]
property Company: WideString

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.ContainerCount (свойство)

Количество контейнеров, отображающих данную композицию

Синтаксис

[Visual Basic 6]
ReadOnly Property ContainerCount As Long

[Delphi]
{только для чтения} property ContainerCount: Integer

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.Containers (свойство)

Массив контейнеров, отображающих данную композицию

Синтаксис

[Visual Basic 6]
ReadOnly Property Containers As CustomContainer

[Delphi]
{только для чтения} property Containers: CustomContainer

Смотри также

Class CustomContainer, Class LayeredComposition, Group Карты


LayeredComposition.Depository (свойство)

Хранилище переменных

Синтаксис

[Visual Basic 6]
ReadOnly Property Depository As Depository

[Delphi]
{только для чтения} property Depository: Depository

Смотри также

Class Depository, Class LayeredComposition, Group Карты


LayeredComposition.Description (свойство)

Описание композиции

Синтаксис

[Visual Basic 6]
Property Description As String

[Delphi]
property Description: WideString

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.DistanceUnit (свойство)

Единицы измерения расстояний

Синтаксис

[Visual Basic 6]
Property DistanceUnit As ModelUnitConstants

[Delphi]
property DistanceUnit: ModelUnitConstants

Смотри также

Class LayeredComposition, Enum ModelUnitConstants, Group Карты


LayeredComposition.FileName (свойство)

Имя файла с композицией

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.Layers (свойство)

Коллекция слоёв композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property Layers As FolderLayer

[Delphi]
{только для чтения} property Layers: FolderLayer

Смотри также

Class FolderLayer, Class LayeredComposition, Group Карты


LayeredComposition.MainContainer (свойство)

Главный контейнер, отображающий карту

Синтаксис

[Visual Basic 6]
ReadOnly Property MainContainer As CustomContainer

[Delphi]
{только для чтения} property MainContainer: CustomContainer

Смотри также

Class CustomContainer, Class LayeredComposition, Group Карты


LayeredComposition.MaxScale (свойство)

Максимальный доступный MaxDevScale контейнера при отрисовке

Синтаксис

[Visual Basic 6]
Property MaxScale As Double

[Delphi]
property MaxScale: Double

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.MinScale (свойство)

Минимальный доступный MapDevScale контейнера при отрисовке

Синтаксис

[Visual Basic 6]
Property MinScale As Double

[Delphi]
property MinScale: Double

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.ModelUnit (свойство)

Исходные единицы модели

Синтаксис

[Visual Basic 6]
Property ModelUnit As ModelUnitConstants

[Delphi]
property ModelUnit: ModelUnitConstants

Смотри также

Class LayeredComposition, Enum ModelUnitConstants, Group Карты


LayeredComposition.Modified (свойство)

Признак модификации композиции

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.Projection (свойство)

Картографическая проекция композиция

Синтаксис

[Visual Basic 6]
ReadOnly Property Projection As Projection

[Delphi]
{только для чтения} property Projection: Projection

Смотри также

Class LayeredComposition, Class Projection, Group Карты


LayeredComposition.RootPath (свойство)

Возвращает путь, относительно которого должны сохраняться параметры композиции и её слоёв

Синтаксис

[Visual Basic 6]
ReadOnly Property RootPath As String

[Delphi]
{только для чтения} property RootPath: WideString

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.ShowScrollBars (свойство)

Показывать ли полосы скроллинга в главном контейнере

Синтаксис

[Visual Basic 6]
Property ShowScrollBars As Boolean

[Delphi]
property ShowScrollBars: WordBool

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.SquareUnit (свойство)

Единицы измерения площадей на композиции

Синтаксис

[Visual Basic 6]
Property SquareUnit As ModelUnitConstants

[Delphi]
property SquareUnit: ModelUnitConstants

Смотри также

Class LayeredComposition, Enum ModelUnitConstants, Group Карты


LayeredComposition.StandardScaleCount (свойство)

Количество стандартных масштабов композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property StandardScaleCount As Long

[Delphi]
{только для чтения} property StandardScaleCount: Integer

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.StandardScales (свойство)

Массив стандартных масштабов композиции

Синтаксис

[Visual Basic 6]
ReadOnly Property StandardScales As StandardScale

[Delphi]
{только для чтения} property StandardScales: StandardScale

Смотри также

Class LayeredComposition, Class StandardScale, Group Карты


LayeredComposition.SystemAxes (свойство)

Ориентация осей координат (по умолчанию SystemAxesXright_Yup)

Синтаксис

[Visual Basic 6]
Property SystemAxes As SystemAxesConstants

[Delphi]
property SystemAxes: SystemAxesConstants

Смотри также

Class LayeredComposition, Enum SystemAxesConstants, Group Карты


LayeredComposition.SystemAxesRotation (свойство)

Поворот системы координат

Синтаксис

[Visual Basic 6]
Property SystemAxesRotation As Double

[Delphi]
property SystemAxesRotation: Double

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.ValidCaption (свойство)

Название композиции (если Caption не задано, то используется имя файла)

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidCaption As String

[Delphi]
{только для чтения} property ValidCaption: WideString

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.AddAssembly (метод)

Добавить новое собрание слоёв

Синтаксис

[Visual Basic 6]
Function AddAssembly As Assembly

[Delphi]
function AddAssembly: Assembly

Возвращаемое значение

Возвращает новое собрание слоёв

Смотри также

Class Assembly, Class LayeredComposition, Group Карты


LayeredComposition.AddBookmark (метод)

Добавить новую закладку

Синтаксис

[Visual Basic 6]
Function AddBookmark ( _
   ByVal Container As CustomContainer _
) As ContainerBookmark

[Delphi]
function AddBookmark(
   const Container: CustomContainer
): ContainerBookmark

Описание параметров

Container
[in] Контейнер, из которого необходимо запомнить текущую видимую область

Возвращаемое значение

Возвращает новую закладку

Смотри также

Class ContainerBookmark, Class CustomContainer, Class LayeredComposition, Group Карты


LayeredComposition.AddLayer (метод)

Добавить слой из файла

Синтаксис

[Visual Basic 6]
Function AddLayer ( _
   ByVal FileName As String _
) As CompositionLayer

[Delphi]
function AddLayer(
   const FileName: WideString
): CompositionLayer

Описание параметров

FileName
[in] Имя файла

Возвращаемое значение

Возвращает созданный слой

Смотри также

Class CompositionLayer, Class LayeredComposition, Group Карты


LayeredComposition.AddNewLayer (метод)

Создать новый слой

Синтаксис

[Visual Basic 6]
Function AddNewLayer ( _
   ByVal MapLayerClassName As String, _
   [ByVal Parent As FolderLayer = 0], _
   [ByVal CreateVariant As Long = 0], _
   [ByVal ShowDlg As Boolean = False], _
   [ByVal Params As String = ""] _
) As CompositionLayer

[Delphi]
function AddNewLayer(
   const MapLayerClassName: WideString;
   const Parent: FolderLayer;
   const CreateVariant: Integer;
   const ShowDlg: WordBool;
   const Params: WideString
): CompositionLayer

Описание параметров

MapLayerClassName
[in] Имя класса нового слоя (стандартно доступны "FolderLayer", "ShapeLayer", "CoverageLayer", "GraphicLayer", "TriangleLayer", "NetworkLayer", "FrameLayer", "GridLayer", "ToolLayer" и "ImageLayer")
Parent
[in] Папка, внутри которой должен быть создан новый слой. Если папка не будет задана (здесь будет передан Nothing), то слой будет создан на верхнем уровне иерархии слоёв карты
CreateVariant
[in] Вариант создания нового слоя
ShowDlg
[in] Следует ли вызывать диалог задания параметров нового слоя
Params
[in] Дополнительные параметры создаваемого слоя

Возвращаемое значение

Возвращает созданный слой

Смотри также

Class CompositionLayer, Class FolderLayer, Class LayeredComposition, Group Карты


LayeredComposition.AddStandardScale (метод)

Добавить стандартный масштаб

Синтаксис

[Visual Basic 6]
Function AddStandardScale As StandardScale

[Delphi]
function AddStandardScale: StandardScale

Возвращаемое значение

Новый стандартный масштаб

Смотри также

Class LayeredComposition, Class StandardScale, Group Карты


LayeredComposition.DeleteAllBookmarks (метод)

Удалить все закладки

Синтаксис

[Visual Basic 6]
Sub DeleteAllBookmarks

[Delphi]
procedure DeleteAllBookmarks

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.DeleteAssembly (метод)

Удалить собрание слоёв с указанным номером

Синтаксис

[Visual Basic 6]
Sub DeleteAssembly ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteAssembly(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемого собрания слоёв (нумерация идёт от 0 до AssemblyCount-1)

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.DeleteBookmark (метод)

Удалить закладку

Синтаксис

[Visual Basic 6]
Sub DeleteBookmark ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteBookmark(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемой закладки (нумерация идёт от 0 до BookmarkCount-1)

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.DeleteStandardScale (метод)

Удалить стандартный масштаб

Синтаксис

[Visual Basic 6]
Sub DeleteStandardScale ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteStandardScale(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемого стандартного масштаба композиции (нумерация идёт от 0 до StandardScaleCount-1)

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.GotoBookmark (метод)

Перейти по заданной закладке

Синтаксис

[Visual Basic 6]
Sub GotoBookmark ( _
   ByVal Container As CustomContainer, _
   ByVal Index As Long _
)

[Delphi]
procedure GotoBookmark(
   const Container: CustomContainer;
   const Index: Integer
)

Описание параметров

Container
[in] Контейнер, в котором нужно выполнить переход
Index
[in] Номер закладки, по которой необходимо выполнить переход

Смотри также

Class CustomContainer, Class LayeredComposition, Group Карты


LayeredComposition.InvalidateContainers (метод)

Перерисовать все связанные контейнеры

Синтаксис

[Visual Basic 6]
Sub InvalidateContainers

[Delphi]
procedure InvalidateContainers

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.LayerByName (метод)

Найти слой по его имени

Синтаксис

[Visual Basic 6]
Function LayerByName ( _
   ByVal Name As String _
) As CompositionLayer

[Delphi]
function LayerByName(
   const Name: WideString
): CompositionLayer

Описание параметров

Name
[in] Имя слоя

Возвращаемое значение

Найденный слой или Nothing, если слоя с таким именем не существует

Смотри также

Class CompositionLayer, Class LayeredComposition, Group Карты


LayeredComposition.LayerBySeqID (метод)

Найти слой по его коду

Синтаксис

[Visual Basic 6]
Function LayerBySeqID ( _
   ByVal SeqID As Long _
) As CompositionLayer

[Delphi]
function LayerBySeqID(
   const SeqID: Integer
): CompositionLayer

Описание параметров

SeqID
[in] Уникальный в пределах карты код слоя

Возвращаемое значение

Найденный слой или Nothing, если слоя с таким кодом не существует

Смотри также

Class CompositionLayer, Class LayeredComposition, Group Карты


LayeredComposition.MoveAssembly (метод)

Переместить собрание слоёв в списке с одной позиции в другую

Синтаксис

[Visual Basic 6]
Sub MoveAssembly ( _
   ByVal FromIndex As Long, _
   ByVal ToIndex As Long _
)

[Delphi]
procedure MoveAssembly(
   const FromIndex: Integer;
   const ToIndex: Integer
)

Описание параметров

FromIndex
[in] Номер перемещаемого собрания слоёв (нумерация идёт от 0 до AssemblyCount-1)
ToIndex
[in] Новая позиция перемещаемого собрания слоёв (нумерация идёт от 0 до AssemblyCount-1)

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.Paint (метод)

Отрисовка карты в заданную позицию

Синтаксис

[Visual Basic 6]
Sub Paint ( _
   ByVal HDC As OLE_HANDLE, _
   ByVal DestRect As Rect, _
   ByVal ViewOrigin As FlatPoint, _
   ByVal ViewScale As Double, _
   ByVal ScaleXY As Double, _
   [ByVal SizeFactor As Double = 1], _
   [ByVal SelectedOnly As Boolean = False], _
   [ByVal PaintDeselected As Boolean = False] _
)

[Delphi]
procedure Paint(
   const HDC: OLE_HANDLE;
   const DestRect: Rect;
   const ViewOrigin: FlatPoint;
   const ViewScale: Double;
   const ScaleXY: Double;
   const SizeFactor: Double;
   const SelectedOnly: WordBool;
   const PaintDeselected: WordBool
)

Описание параметров

HDC
[in] HDC устройства вывода
DestRect
[in] Прямоугольник на устройстве вывода, в который необходимо отрисовать карту
ViewOrigin
[in] Координата левого верхнего угла контейнера в системе координат контейнера
ViewScale
[in] Масштаб отображения
ScaleXY
[in] Соотношение масштабов по X и Y
SizeFactor
[in] Коэффициент увеличения толщины отображаемых фигур
SelectedOnly
[in] Отображать только выделенные фигуры
PaintDeselected
[in] Отображать выделенные фигуры как невыделенные

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class FlatPoint, Class LayeredComposition, Class Rect, Group Карты


LayeredComposition.Print (метод)

Распечатать на принтере на одной странице видимую часть карты

Синтаксис

[Visual Basic 6]
Sub Print ( _
   ByVal ATitle As String _
)

[Delphi]
procedure Print(
   const ATitle: WideString
)

Описание параметров

ATitle
[in] Заголовок задания для печати

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.PrintPages (метод)

Распечатать на принтере заданную часть карты (возможно на нескольких страницах)

Синтаксис

[Visual Basic 6]
Sub PrintPages ( _
   ByVal ATitle As String, _
   ByVal FlatXmin As Double, _
   ByVal FlatXmax As Double, _
   ByVal FlatYmin As Double, _
   ByVal FlatYmax As Double, _
   ByVal ViewScale As Double _
)

[Delphi]
procedure PrintPages(
   const ATitle: WideString;
   const FlatXmin: Double;
   const FlatXmax: Double;
   const FlatYmin: Double;
   const FlatYmax: Double;
   const ViewScale: Double
)

Описание параметров

ATitle
[in] Заголовок задания для печати
FlatXmin
[in] Левая граница области печати в плоской системе координат
FlatXmax
[in] Правая граница области печати в плоской системе координат
FlatYmin
[in] Нижняя граница области печати в плоской системе координат
FlatYmax
[in] Верхняя граница области печати в плоской системе координат
ViewScale
[in] Масштаб изображения при печати

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.PrintRect (метод)

Распечатать на принтере на одной странице видимую часть карты

Синтаксис

[Visual Basic 6]
Sub PrintRect ( _
   ByVal ATitle As String, _
   ByVal FlatXmin As Double, _
   ByVal FlatXmax As Double, _
   ByVal FlatYmin As Double, _
   ByVal FlatYmax As Double _
)

[Delphi]
procedure PrintRect(
   const ATitle: WideString;
   const FlatXmin: Double;
   const FlatXmax: Double;
   const FlatYmin: Double;
   const FlatYmax: Double
)

Описание параметров

ATitle
[in] Заголовок задания для печати
FlatXmin
[in] Левая граница области печати в плоской системе координат
FlatXmax
[in] Правая граница области печати в плоской системе координат
FlatYmin
[in] Нижняя граница области печати в плоской системе координат
FlatYmax
[in] Верхняя граница области печати в плоской системе координат

Смотри также

Class LayeredComposition, Group Карты


LayeredComposition.RefreshContainers (метод)

Обновить изображение во всех связанных контейнерах

Синтаксис

[Visual Basic 6]
Sub RefreshContainers

[Delphi]
procedure RefreshContainers

Смотри также

Class LayeredComposition, Group Карты


Класс Layers

Список слоёв в проекте

Наследование

BaseObject Class Layers

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ActiveLayer | Текущий (активный) слой
Property Application (только для чтения) | Приложение, в котором существует объект
Property Count (только для чтения) | Количество объектов, которое содержит в себе данный объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property ItemIndex | Индекс активного слоя
Property Items (только для чтения) | Массив объектов (нумерация идёт от 0 до Count-1)
Property Layers (только для чтения) | Массив слоёв (нумерация идёт от 0 до Count-1)
Property Project (только для чтения) | Проект, к которому относится объект

Методы класса

Имя | Описание
Method AddLayer | Создаёт и возвращает слой с указанным именем
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Clear | Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект
Method Delete | Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetLayerByName | Получить слой по имени

Где используется

Класс | Член класса
Class Layer | Property Layers (свойство)
Class Project | Property Layers (свойство)

Смотри также

Class Application, Class BaseObject, Group Поверхности


Layers.ActiveLayer (свойство)

Текущий (активный) слой

Синтаксис

[Visual Basic 6]
Property ActiveLayer As Layer

[Delphi]
property ActiveLayer: Layer

Смотри также

Class Layer, Class Layers, Group Поверхности


Layers.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class Layers, Group Поверхности


Layers.Count (свойство)

Количество объектов, которое содержит в себе данный объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class Layers, Group Поверхности


Layers.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Layers, Group Поверхности


Layers.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Layers, Group Поверхности


Layers.ItemIndex (свойство)

Индекс активного слоя

Синтаксис

[Visual Basic 6]
Property ItemIndex As Long

[Delphi]
property ItemIndex: Integer

Смотри также

Class Layers, Group Поверхности


Layers.Items (свойство)

Массив объектов (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BaseObject

[Delphi]
{только для чтения} property Items: BaseObject

Смотри также

Class BaseObject, Class Layers, Group Поверхности


Layers.Layers (свойство)

Массив слоёв (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Layers As Layer

[Delphi]
{только для чтения} property Layers: Layer

Смотри также

Class Layer, Class Layers, Group Поверхности


Layers.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Layers, Class Project, Group Поверхности


Layers.AddLayer (метод)

Создаёт и возвращает слой с указанным именем

Синтаксис

[Visual Basic 6]
Function AddLayer ( _
   ByVal Name As String, _
   ByVal Activate As Boolean _
) As Layer

[Delphi]
function AddLayer(
   const Name: WideString;
   const Activate: WordBool
): Layer

Описание параметров

Name
[in] Имя создаваемого слоя. Если слой с указанным именем уже существует, то новый слой не будет создан
Activate
[in] True - сделать созданный слой активным, False - созданный слой не станет активным

Возвращаемое значение

Созданный слой, либо существующий, если слуй с указанным именем уже существовал

Смотри также

Class Layer, Class Layers, Group Поверхности


Layers.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Layers, Group Поверхности


Layers.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Layers, Group Поверхности


Layers.Clear (метод)

Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class Layers, Group Поверхности


Layers.Delete (метод)

Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс объекта (нумерация идёт от 0 до Count-1)

Смотри также

Class Layers, Group Поверхности


Layers.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Layers, Group Поверхности


Layers.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Layers, Group Поверхности


Layers.GetLayerByName (метод)

Получить слой по имени

Синтаксис

[Visual Basic 6]
Function GetLayerByName ( _
   ByVal Name As String _
) As Layer

[Delphi]
function GetLayerByName(
   const Name: WideString
): Layer

Описание параметров

Name
[in] Имя запрашиваемого слоя

Возвращаемое значение

Функция возвращает значение типа Layer.

Смотри также

Class Layer, Class Layers, Group Поверхности


Класс Line

Структурная/ситуационная линия или полигон

Наследование

BaseObject Class Line

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Code | Код линии из набора имён линий
Property Comment | Комментарий, заданный линии
Property CurveFactor | Коэффициент сглаживания (учащения узлов в линии). Если = 1, то линия не сглаживается
Property CurveTension | Степень натяжения сплайна (Значение от 0.05 до 1.5)
Property Cycled | Замкнутая ли линия (является ли объект полигоном)
Property FillStyle (только для чтения) | Стиль заливки
Property GroupName | Получить имя группы
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Lines (только для чтения) | Коллекция линий, к которым относится данная линия
Property LineStyle (только для чтения) | Стиль линии
Property Name (только для чтения) | Тип линии (берётся из коллекции имён линий)
Property Point (только для чтения) | Точка линии
Property Project (только для чтения) | Проект, к которому относится объект
Property PtCount (только для чтения) | Количество точек, образующих линию/контур
Property SegmentCount (только для чтения) | Количество сегментов, образующих линию/контур
Property Selected | Выделена ли линия
Property Situation | Является ли линия ситуационной (ситуационные линии не исправляют поверхность)

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetNearestSegment | Возвращает индексы точек в линии, образующих ближайший к указанным координатам сегмент и расстояние до него

Где используется

Класс | Член класса
Class Lines | Property Lines (свойство) Method CreateLine (метод) Method GetNearestLine (метод)

Смотри также

Class Application, Class LayerPoint, Class Project, Class TopoFillStyle, Class TopoLineStyle, Group Поверхности


Line.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class Line, Group Поверхности


Line.Code (свойство)

Код линии из набора имён линий

Синтаксис

[Visual Basic 6]
Property Code As Long

[Delphi]
property Code: Integer

Смотри также

Class Line, Group Поверхности


Line.Comment (свойство)

Комментарий, заданный линии

Синтаксис

[Visual Basic 6]
Property Comment As String

[Delphi]
property Comment: WideString

Смотри также

Class Line, Group Поверхности


Line.CurveFactor (свойство)

Коэффициент сглаживания (учащения узлов в линии). Если = 1, то линия не сглаживается

Синтаксис

[Visual Basic 6]
Property CurveFactor As Long

[Delphi]
property CurveFactor: Integer

Смотри также

Class Line, Group Поверхности


Line.CurveTension (свойство)

Степень натяжения сплайна (Значение от 0.05 до 1.5)

Синтаксис

[Visual Basic 6]
Property CurveTension As Double

[Delphi]
property CurveTension: Double

Смотри также

Class Line, Group Поверхности


Line.Cycled (свойство)

Замкнутая ли линия (является ли объект полигоном)

Синтаксис

[Visual Basic 6]
Property Cycled As Boolean

[Delphi]
property Cycled: WordBool

Смотри также

Class Line, Group Поверхности


Line.FillStyle (свойство)

Стиль заливки

Синтаксис

[Visual Basic 6]
ReadOnly Property FillStyle As TopoFillStyle

[Delphi]
{только для чтения} property FillStyle: TopoFillStyle

Смотри также

Class Line, Class TopoFillStyle, Group Поверхности


Line.GroupName (свойство)

Получить имя группы

Синтаксис

[Visual Basic 6]
Property GroupName As String

[Delphi]
property GroupName: WideString

Смотри также

Class Line, Group Поверхности


Line.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Line, Group Поверхности


Line.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Line, Group Поверхности


Line.Lines (свойство)

Коллекция линий, к которым относится данная линия

Синтаксис

[Visual Basic 6]
ReadOnly Property Lines As Lines

[Delphi]
{только для чтения} property Lines: Lines

Смотри также

Class Line, Class Lines, Group Поверхности


Line.LineStyle (свойство)

Стиль линии

Синтаксис

[Visual Basic 6]
ReadOnly Property LineStyle As TopoLineStyle

[Delphi]
{только для чтения} property LineStyle: TopoLineStyle

Смотри также

Class Line, Class TopoLineStyle, Group Поверхности


Line.Name (свойство)

Тип линии (берётся из коллекции имён линий)

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class Line, Group Поверхности


Line.Point (свойство)

Точка линии

Синтаксис

[Visual Basic 6]
ReadOnly Property Point As LayerPoint

[Delphi]
{только для чтения} property Point: LayerPoint

Смотри также

Class LayerPoint, Class Line, Group Поверхности


Line.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Line, Class Project, Group Поверхности


Line.PtCount (свойство)

Количество точек, образующих линию/контур

Синтаксис

[Visual Basic 6]
ReadOnly Property PtCount As Long

[Delphi]
{только для чтения} property PtCount: Integer

Смотри также

Class Line, Group Поверхности


Line.SegmentCount (свойство)

Количество сегментов, образующих линию/контур

Синтаксис

[Visual Basic 6]
ReadOnly Property SegmentCount As Long

[Delphi]
{только для чтения} property SegmentCount: Integer

Смотри также

Class Line, Group Поверхности


Line.Selected (свойство)

Выделена ли линия

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class Line, Group Поверхности


Line.Situation (свойство)

Является ли линия ситуационной (ситуационные линии не исправляют поверхность)

Синтаксис

[Visual Basic 6]
Property Situation As Boolean

[Delphi]
property Situation: WordBool

Смотри также

Class Line, Group Поверхности


Line.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Line, Group Поверхности


Line.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Line, Group Поверхности


Line.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Line, Group Поверхности


Line.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Line, Group Поверхности


Line.GetNearestSegment (метод)

Возвращает индексы точек в линии, образующих ближайший к указанным координатам сегмент и расстояние до него

Синтаксис

[Visual Basic 6]
Function GetNearestSegment ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   NodeIndex1 As Long, _
   NodeIndex2 As Long, _
   Distance As Double _
) As Boolean

[Delphi]
function GetNearestSegment(
   const ModelX: Double;
   const ModelY: Double;
   out NodeIndex1: Integer;
   out NodeIndex2: Integer;
   out Distance: Double
): WordBool

Описание параметров

ModelX
[in] Модельная X-координата точки, относительно которой производится поиск
ModelY
[in] Модельная Y-координата точки, относительно которой производится поиск
NodeIndex1
[out] Возвращаемый индекс точки начала найденного сегмента
NodeIndex2
[out] Возвращаемый индекс точки конца найденного сегмента
Distance
[out] Расстояние до найденного сегмента в метрах

Возвращаемое значение

Результат операции: True - сегмент найден и переменные заполнены корректными значениями, False - сегмент не найден либо ошибка

Смотри также

Class Line, Group Поверхности


Класс LineGroup

Группа линий/полигонов

Наследование

BaseObject Class LineGroup

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Name (только для чтения) | Имя группы
Property Project (только для чтения) | Проект, к которому относится объект
Property Visible | Включена ли группа для отображения в плане

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Где используется

Класс | Член класса
Class Lines | Property Groups (свойство) Property GroupsByName (свойство)

Смотри также

Class Application, Class Project, Group Поверхности


LineGroup.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class LineGroup, Group Поверхности


LineGroup.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LineGroup, Group Поверхности


LineGroup.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class LineGroup, Group Поверхности


LineGroup.Name (свойство)

Имя группы

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class LineGroup, Group Поверхности


LineGroup.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class LineGroup, Class Project, Group Поверхности


LineGroup.Visible (свойство)

Включена ли группа для отображения в плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class LineGroup, Group Поверхности


LineGroup.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class LineGroup, Group Поверхности


LineGroup.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class LineGroup, Group Поверхности


LineGroup.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class LineGroup, Group Поверхности


LineGroup.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class LineGroup, Group Поверхности


Класс Lines

Коллекция структурных/ситуационных линий слоя

Наследование

BaseObject Class Lines

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Count (только для чтения) | Количество объектов, которое содержит в себе данный объект
Property DefaultFillStyle (только для чтения) | Стиль заливки полигонов по умолчанию (для новых полигонов)
Property DefaultLineStyle (только для чтения) | Стиль линии по умолчанию (для новых линий)
Property GroupCount (только для чтения) | Количество групп, на которые поделены полигоны и линии
Property Groups (только для чтения) | Получить группу по индексу
Property GroupsByName (только для чтения) | Получить группу по индексу
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Массив объектов (нумерация идёт от 0 до Count-1)
Property Lines (только для чтения) | Массив линий и полигонов
Property Project (только для чтения) | Проект, к которому относится объект
Property SlopeHatchingStep | Шаг между штрихами в рисовке откосов в миллиметрах
Property SlopeHatchingWidth | Толщина штрихов откосов в миллиметрах
Property Visible | Отображаются ли полигоны/линии в плане
Property VisibleCount (только для чтения) | Количество отображаемых объектов (линий и полигонов)
Property VisibleRegionCount (только для чтения) | Количество отображаемых полигонов

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Clear | Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект
Method CreateLine | Создаёт новую линию/полигон, основанную на точках, индексы которых перечислены в PtIndices
Method Delete | Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetNearestLine | Возвращает ближайшую к указанной точке линию в окрестности Eps
Method SelectedCount | Возвращает количество выделенных линий и индекс первой из выделенных

Где используется

Класс | Член класса
Class Layer | Property Lines (свойство)
Class Line | Property Lines (свойство)

Смотри также

Class Application, Class BaseObject, Class IntegerCollection, Class LineGroup, Class Project, Class TopoFillStyle, Class TopoLineStyle, Group Поверхности


Lines.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class Lines, Group Поверхности


Lines.Count (свойство)

Количество объектов, которое содержит в себе данный объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class Lines, Group Поверхности


Lines.DefaultFillStyle (свойство)

Стиль заливки полигонов по умолчанию (для новых полигонов)

Синтаксис

[Visual Basic 6]
ReadOnly Property DefaultFillStyle As TopoFillStyle

[Delphi]
{только для чтения} property DefaultFillStyle: TopoFillStyle

Смотри также

Class Lines, Class TopoFillStyle, Group Поверхности


Lines.DefaultLineStyle (свойство)

Стиль линии по умолчанию (для новых линий)

Синтаксис

[Visual Basic 6]
ReadOnly Property DefaultLineStyle As TopoLineStyle

[Delphi]
{только для чтения} property DefaultLineStyle: TopoLineStyle

Смотри также

Class Lines, Class TopoLineStyle, Group Поверхности


Lines.GroupCount (свойство)

Количество групп, на которые поделены полигоны и линии

Синтаксис

[Visual Basic 6]
ReadOnly Property GroupCount As Long

[Delphi]
{только для чтения} property GroupCount: Integer

Смотри также

Class Lines, Group Поверхности


Lines.Groups (свойство)

Получить группу по индексу

Синтаксис

[Visual Basic 6]
ReadOnly Property Groups As LineGroup

[Delphi]
{только для чтения} property Groups: LineGroup

Смотри также

Class LineGroup, Class Lines, Group Поверхности


Lines.GroupsByName (свойство)

Получить группу по индексу

Синтаксис

[Visual Basic 6]
ReadOnly Property GroupsByName As LineGroup

[Delphi]
{только для чтения} property GroupsByName: LineGroup

Смотри также

Class LineGroup, Class Lines, Group Поверхности


Lines.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Lines, Group Поверхности


Lines.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Lines, Group Поверхности


Lines.Items (свойство)

Массив объектов (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BaseObject

[Delphi]
{только для чтения} property Items: BaseObject

Смотри также

Class BaseObject, Class Lines, Group Поверхности


Lines.Lines (свойство)

Массив линий и полигонов

Синтаксис

[Visual Basic 6]
ReadOnly Property Lines As Line

[Delphi]
{только для чтения} property Lines: Line

Смотри также

Class Line, Class Lines, Group Поверхности


Lines.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Lines, Class Project, Group Поверхности


Lines.SlopeHatchingStep (свойство)

Шаг между штрихами в рисовке откосов в миллиметрах

Синтаксис

[Visual Basic 6]
Property SlopeHatchingStep As Double

[Delphi]
property SlopeHatchingStep: Double

Смотри также

Class Lines, Group Поверхности


Lines.SlopeHatchingWidth (свойство)

Толщина штрихов откосов в миллиметрах

Синтаксис

[Visual Basic 6]
Property SlopeHatchingWidth As Double

[Delphi]
property SlopeHatchingWidth: Double

Смотри также

Class Lines, Group Поверхности


Lines.Visible (свойство)

Отображаются ли полигоны/линии в плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Lines, Group Поверхности


Lines.VisibleCount (свойство)

Количество отображаемых объектов (линий и полигонов)

Синтаксис

[Visual Basic 6]
ReadOnly Property VisibleCount As Long

[Delphi]
{только для чтения} property VisibleCount: Integer

Смотри также

Class Lines, Group Поверхности


Lines.VisibleRegionCount (свойство)

Количество отображаемых полигонов

Синтаксис

[Visual Basic 6]
ReadOnly Property VisibleRegionCount As Long

[Delphi]
{только для чтения} property VisibleRegionCount: Integer

Смотри также

Class Lines, Group Поверхности


Lines.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Lines, Group Поверхности


Lines.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Lines, Group Поверхности


Lines.Clear (метод)

Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class Lines, Group Поверхности


Lines.CreateLine (метод)

Создаёт новую линию/полигон, основанную на точках, индексы которых перечислены в PtIndices

Синтаксис

[Visual Basic 6]
Function CreateLine ( _
   ByVal PointIndices As IntegerCollection, _
   ByVal Cycled As Boolean, _
   ByVal Situation As Boolean _
) As Line

[Delphi]
function CreateLine(
   const PointIndices: IntegerCollection;
   const Cycled: WordBool;
   const Situation: WordBool
): Line

Описание параметров

PointIndices
[in] Коллекция целых чисел, содержащая индексы
Cycled
[in] Замкнутая ли будет линия. True - будет создан полигон, False - линия
Situation
[in] Ситуационная ли будет линия. True - ситуационная, False - рельефная

Возвращаемое значение

Созданная линия, либо Nothing в случае ошибки

Смотри также

Class IntegerCollection, Class Line, Class Lines, Group Поверхности


Lines.Delete (метод)

Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс объекта (нумерация идёт от 0 до Count-1)

Смотри также

Class Lines, Group Поверхности


Lines.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Lines, Group Поверхности


Lines.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Lines, Group Поверхности


Lines.GetNearestLine (метод)

Возвращает ближайшую к указанной точке линию в окрестности Eps

Синтаксис

[Visual Basic 6]
Function GetNearestLine ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   Eps As Double _
) As Line

[Delphi]
function GetNearestLine(
   const X: Double;
   const Y: Double;
   var Eps: Double
): Line

Описание параметров

X
[in] Модельная X-координата точки, в окрестности которой ищется линия
Y
[in] Модельная Y-координата точки, в окрестности которой ищется линия
Eps
[in, out] На входе: окрестность, в которой необходимо найти линию. На выходе: расстояние до найденной линии

Возвращаемое значение

Ближайшая найденная линия, либо Nothing, если в указанной окрестности не была найдена ни одна линия

Смотри также

Class Line, Class Lines, Group Поверхности


Lines.SelectedCount (метод)

Возвращает количество выделенных линий и индекс первой из выделенных

Синтаксис

[Visual Basic 6]
Function SelectedCount ( _
   FirstSelected As Long _
) As Long

[Delphi]
function SelectedCount(
   out FirstSelected: Integer
): Integer

Описание параметров

FirstSelected
[out] Переменная, в которую возвратится индекс первой из выделенных линий, либо "-1", если не выделено ни одной линии

Возвращаемое значение

Количество выделенных линий

Смотри также

Class Lines, Group Поверхности


Класс LinkedADOCustomDataset

Элемент интерфейса - набор данных для TLinkedADODatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedADOCustomDataset Class LinkedADODataset, LinkedADOQuery, LinkedADOStoredProc, LinkedADOTable

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property CacheSize | Размер кэша = 1..MaxInt
Property ClientCursor | Курсор размещен на клиентской стороне?
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property LockType | Тип блокировки ADO
Property MaxRecords | Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Enum ADOLockConstants, Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADOCustomDataset.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.CacheSize (свойство)

Размер кэша = 1..MaxInt

Синтаксис

[Visual Basic 6]
Property CacheSize As Long

[Delphi]
property CacheSize: Integer

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.ClientCursor (свойство)

Курсор размещен на клиентской стороне?

Синтаксис

[Visual Basic 6]
Property ClientCursor As Boolean

[Delphi]
property ClientCursor: WordBool

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedADOCustomDataset, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedADOCustomDataset.LockType (свойство)

Тип блокировки ADO

Синтаксис

[Visual Basic 6]
Property LockType As ADOLockConstants

[Delphi]
property LockType: ADOLockConstants

Смотри также

Enum ADOLockConstants, Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.MaxRecords (свойство)

Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt

Синтаксис

[Visual Basic 6]
Property MaxRecords As Long

[Delphi]
property MaxRecords: Integer

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedADOCustomDataset, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedADOCustomDataset.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedADOCustomDataset, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADOCustomDataset.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


LinkedADOCustomDataset.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedADOCustomDataset, Group Интерфейсы с базой данных


Класс LinkedADODatabase

База данных ADO

Наследование

LinkedDatabase Class LinkedADODatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property ConnectionString | Параметры соединения с сервером
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedADODatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.ConnectionString (свойство)

Параметры соединения с сервером

Синтаксис

[Visual Basic 6]
Property ConnectionString As String

[Delphi]
property ConnectionString: WideString

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedADODatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedADODatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Class LinkedADODatabase, Enum LinkedDatabaseStatusConstants, Group Интерфейсы с базой данных


LinkedADODatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedADODatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedADODatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedADODatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedADODatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedADODatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedADODatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedADODatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedADODatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedADODatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedADODatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedADODatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedADODatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


LinkedADODatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedADODatabase, Group Интерфейсы с базой данных


Класс LinkedADODataset

Элемент интерфейса - набор данных для TLinkedADODatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedADOCustomDataset Class LinkedADODataset

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property CacheSize | Размер кэша = 1..MaxInt
Property ClientCursor | Курсор размещен на клиентской стороне?
Property CommandTimeout | Таймаут при выполнении
Property CommandType | Тип команды
Property CommantText | Текст команды
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property LockType | Тип блокировки ADO
Property MaxRecords | Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Enum ADOCommandConstants, Enum ADOLockConstants, Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADODataset.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.CacheSize (свойство)

Размер кэша = 1..MaxInt

Синтаксис

[Visual Basic 6]
Property CacheSize As Long

[Delphi]
property CacheSize: Integer

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.ClientCursor (свойство)

Курсор размещен на клиентской стороне?

Синтаксис

[Visual Basic 6]
Property ClientCursor As Boolean

[Delphi]
property ClientCursor: WordBool

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.CommandTimeout (свойство)

Таймаут при выполнении

Синтаксис

[Visual Basic 6]
Property CommandTimeout As Long

[Delphi]
property CommandTimeout: Integer

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.CommandType (свойство)

Тип команды

Синтаксис

[Visual Basic 6]
Property CommandType As ADOCommandConstants

[Delphi]
property CommandType: ADOCommandConstants

Смотри также

Enum ADOCommandConstants, Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.CommantText (свойство)

Текст команды

Синтаксис

[Visual Basic 6]
Property CommantText As String

[Delphi]
property CommantText: WideString

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedADODataset, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedADODataset.LockType (свойство)

Тип блокировки ADO

Синтаксис

[Visual Basic 6]
Property LockType As ADOLockConstants

[Delphi]
property LockType: ADOLockConstants

Смотри также

Enum ADOLockConstants, Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.MaxRecords (свойство)

Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt

Синтаксис

[Visual Basic 6]
Property MaxRecords As Long

[Delphi]
property MaxRecords: Integer

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedADODataset, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedADODataset.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedADODataset, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADODataset.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedADODataset, Group Интерфейсы с базой данных


LinkedADODataset.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedADODataset, Group Интерфейсы с базой данных


Класс LinkedADOQuery

Элемент интерфейса - запрос для TLinkedADODatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedADOCustomDataset Class LinkedADOQuery

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property CacheSize | Размер кэша = 1..MaxInt
Property ClientCursor | Курсор размещен на клиентской стороне?
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property LinkedParams (только для чтения) | Параметры запроса
Property LockType | Тип блокировки ADO
Property MaxRecords | Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Enum ADOLockConstants, Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Class LinkedParams, Group Интерфейсы с базой данных


LinkedADOQuery.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.CacheSize (свойство)

Размер кэша = 1..MaxInt

Синтаксис

[Visual Basic 6]
Property CacheSize As Long

[Delphi]
property CacheSize: Integer

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.ClientCursor (свойство)

Курсор размещен на клиентской стороне?

Синтаксис

[Visual Basic 6]
Property ClientCursor As Boolean

[Delphi]
property ClientCursor: WordBool

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedADOQuery, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedADOQuery.LinkedParams (свойство)

Параметры запроса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedParams As LinkedParams

[Delphi]
{только для чтения} property LinkedParams: LinkedParams

Смотри также

Class LinkedADOQuery, Class LinkedParams, Group Интерфейсы с базой данных


LinkedADOQuery.LockType (свойство)

Тип блокировки ADO

Синтаксис

[Visual Basic 6]
Property LockType As ADOLockConstants

[Delphi]
property LockType: ADOLockConstants

Смотри также

Enum ADOLockConstants, Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.MaxRecords (свойство)

Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt

Синтаксис

[Visual Basic 6]
Property MaxRecords As Long

[Delphi]
property MaxRecords: Integer

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedADOQuery, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedADOQuery.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedADOQuery, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADOQuery.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedADOQuery, Group Интерфейсы с базой данных


LinkedADOQuery.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedADOQuery, Group Интерфейсы с базой данных


Класс LinkedADOStoredProc

Элемент интерфейса - хранимая процедура для TLinkedADODatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedADOCustomDataset Class LinkedADOStoredProc

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property CacheSize | Размер кэша = 1..MaxInt
Property ClientCursor | Курсор размещен на клиентской стороне?
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property LockType | Тип блокировки ADO
Property MaxRecords | Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property ProcedureName | Имя процедуры
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Enum ADOLockConstants, Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADOStoredProc.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.CacheSize (свойство)

Размер кэша = 1..MaxInt

Синтаксис

[Visual Basic 6]
Property CacheSize As Long

[Delphi]
property CacheSize: Integer

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.ClientCursor (свойство)

Курсор размещен на клиентской стороне?

Синтаксис

[Visual Basic 6]
Property ClientCursor As Boolean

[Delphi]
property ClientCursor: WordBool

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedADOStoredProc, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedADOStoredProc.LockType (свойство)

Тип блокировки ADO

Синтаксис

[Visual Basic 6]
Property LockType As ADOLockConstants

[Delphi]
property LockType: ADOLockConstants

Смотри также

Enum ADOLockConstants, Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.MaxRecords (свойство)

Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt

Синтаксис

[Visual Basic 6]
Property MaxRecords As Long

[Delphi]
property MaxRecords: Integer

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedADOStoredProc, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedADOStoredProc.ProcedureName (свойство)

Имя процедуры

Синтаксис

[Visual Basic 6]
Property ProcedureName As String

[Delphi]
property ProcedureName: WideString

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedADOStoredProc, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADOStoredProc.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedADOStoredProc, Group Интерфейсы с базой данных


LinkedADOStoredProc.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedADOStoredProc, Group Интерфейсы с базой данных


Класс LinkedADOTable

Элемент интерфейса - таблица для TLinkedADODatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedADOCustomDataset Class LinkedADOTable

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property CacheSize | Размер кэша = 1..MaxInt
Property ClientCursor | Курсор размещен на клиентской стороне?
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property LockType | Тип блокировки ADO
Property MaxRecords | Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property ReadOnly | Запрет на модификацию
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TableDirect | Прямой доступ к таблице, иначе через SELECT
Property TableName | Имя таблицы
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Enum ADOLockConstants, Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADOTable.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.CacheSize (свойство)

Размер кэша = 1..MaxInt

Синтаксис

[Visual Basic 6]
Property CacheSize As Long

[Delphi]
property CacheSize: Integer

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.ClientCursor (свойство)

Курсор размещен на клиентской стороне?

Синтаксис

[Visual Basic 6]
Property ClientCursor As Boolean

[Delphi]
property ClientCursor: WordBool

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedADOTable, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedADOTable.LockType (свойство)

Тип блокировки ADO

Синтаксис

[Visual Basic 6]
Property LockType As ADOLockConstants

[Delphi]
property LockType: ADOLockConstants

Смотри также

Enum ADOLockConstants, Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.MaxRecords (свойство)

Максимальное количество записей в запрашиваемом наборе данных = 0..MaxInt

Синтаксис

[Visual Basic 6]
Property MaxRecords As Long

[Delphi]
property MaxRecords: Integer

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedADOTable, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedADOTable.ReadOnly (свойство)

Запрет на модификацию

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedADOTable, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedADOTable.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.TableDirect (свойство)

Прямой доступ к таблице, иначе через SELECT

Синтаксис

[Visual Basic 6]
Property TableDirect As Boolean

[Delphi]
property TableDirect: WordBool

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.TableName (свойство)

Имя таблицы

Синтаксис

[Visual Basic 6]
Property TableName As String

[Delphi]
property TableName: WideString

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedADOTable, Group Интерфейсы с базой данных


LinkedADOTable.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedADOTable, Group Интерфейсы с базой данных


Класс LinkedBDEDatabase

База данных BDE

Наследование

LinkedDatabase Class LinkedBDEDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AliasName | Имя альяса
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property Directory | Путь к локальной базе
Property DriverName | Имя драйвера базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property Params | Дополнительные параметры в виде строки, разделенные точками с запятыми
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedBDEDatabase.AliasName (свойство)

Имя альяса

Синтаксис

[Visual Basic 6]
Property AliasName As String

[Delphi]
property AliasName: WideString

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.Directory (свойство)

Путь к локальной базе

Синтаксис

[Visual Basic 6]
Property Directory As String

[Delphi]
property Directory: WideString

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.DriverName (свойство)

Имя драйвера базы данных

Синтаксис

[Visual Basic 6]
Property DriverName As String

[Delphi]
property DriverName: WideString

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedBDEDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedBDEDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.Params (свойство)

Дополнительные параметры в виде строки, разделенные точками с запятыми

Синтаксис

[Visual Basic 6]
Property Params As String

[Delphi]
property Params: WideString

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Class LinkedBDEDatabase, Enum LinkedDatabaseStatusConstants, Group Интерфейсы с базой данных


LinkedBDEDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedBDEDatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedBDEDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedBDEDatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedBDEDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedBDEDatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedBDEDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedBDEDatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedBDEDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedBDEDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedBDEDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedBDEDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedBDEDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


LinkedBDEDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedBDEDatabase, Group Интерфейсы с базой данных


Класс LinkedBDEDataset

Элемент интерфейса - набор данных для TLinkedBDEDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedBDEDataset Class LinkedBDEQuery, LinkedBDEStoredProc, LinkedBDETable

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AutoRefresh | Автоматическое получение изменённых на сервере полей (типа автоинкремента)
Property BrowserItems | Элементы просмотра для Browser
Property CachedUpdates | Кэширование обновлений набора данных
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedBDEDataset.AutoRefresh (свойство)

Автоматическое получение изменённых на сервере полей (типа автоинкремента)

Синтаксис

[Visual Basic 6]
Property AutoRefresh As Boolean

[Delphi]
property AutoRefresh: WordBool

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.CachedUpdates (свойство)

Кэширование обновлений набора данных

Синтаксис

[Visual Basic 6]
Property CachedUpdates As Boolean

[Delphi]
property CachedUpdates: WordBool

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedBDEDataset, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedBDEDataset.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedBDEDataset, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedBDEDataset.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedBDEDataset, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedBDEDataset.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedBDEDataset, Group Интерфейсы с базой данных


LinkedBDEDataset.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedBDEDataset, Group Интерфейсы с базой данных


Класс LinkedBDEQuery

Элемент интерфейса - запрос BDE набор данных для TLinkedBDEDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedBDEDataset Class LinkedBDEQuery

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AutoRefresh | Автоматическое получение изменённых на сервере полей (типа автоинкремента)
Property BrowserItems | Элементы просмотра для Browser
Property CachedUpdates | Кэширование обновлений набора данных
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property LinkedParams (только для чтения) | Параметры запроса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property RequestLive | Желательно получение редактируемых данных
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Class LinkedParams, Group Интерфейсы с базой данных


LinkedBDEQuery.AutoRefresh (свойство)

Автоматическое получение изменённых на сервере полей (типа автоинкремента)

Синтаксис

[Visual Basic 6]
Property AutoRefresh As Boolean

[Delphi]
property AutoRefresh: WordBool

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.CachedUpdates (свойство)

Кэширование обновлений набора данных

Синтаксис

[Visual Basic 6]
Property CachedUpdates As Boolean

[Delphi]
property CachedUpdates: WordBool

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedBDEQuery, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedBDEQuery.LinkedParams (свойство)

Параметры запроса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedParams As LinkedParams

[Delphi]
{только для чтения} property LinkedParams: LinkedParams

Смотри также

Class LinkedBDEQuery, Class LinkedParams, Group Интерфейсы с базой данных


LinkedBDEQuery.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedBDEQuery, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedBDEQuery.RequestLive (свойство)

Желательно получение редактируемых данных

Синтаксис

[Visual Basic 6]
Property RequestLive As Boolean

[Delphi]
property RequestLive: WordBool

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedBDEQuery, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedBDEQuery.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedBDEQuery, Group Интерфейсы с базой данных


LinkedBDEQuery.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedBDEQuery, Group Интерфейсы с базой данных


Класс LinkedBDEStoredProc

Элемент интерфейса - хранимая процедура BDE набор данных для TLinkedBDEDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedBDEDataset Class LinkedBDEStoredProc

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AutoRefresh | Автоматическое получение изменённых на сервере полей (типа автоинкремента)
Property BrowserItems | Элементы просмотра для Browser
Property CachedUpdates | Кэширование обновлений набора данных
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property LinkedParams (только для чтения) | Параметры хранимой процедуры
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property ProcedureName | Имя хранимой процедуры
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Class LinkedParams, Group Интерфейсы с базой данных


LinkedBDEStoredProc.AutoRefresh (свойство)

Автоматическое получение изменённых на сервере полей (типа автоинкремента)

Синтаксис

[Visual Basic 6]
Property AutoRefresh As Boolean

[Delphi]
property AutoRefresh: WordBool

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.CachedUpdates (свойство)

Кэширование обновлений набора данных

Синтаксис

[Visual Basic 6]
Property CachedUpdates As Boolean

[Delphi]
property CachedUpdates: WordBool

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedBDEStoredProc, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedBDEStoredProc.LinkedParams (свойство)

Параметры хранимой процедуры

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedParams As LinkedParams

[Delphi]
{только для чтения} property LinkedParams: LinkedParams

Смотри также

Class LinkedBDEStoredProc, Class LinkedParams, Group Интерфейсы с базой данных


LinkedBDEStoredProc.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedBDEStoredProc, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedBDEStoredProc.ProcedureName (свойство)

Имя хранимой процедуры

Синтаксис

[Visual Basic 6]
Property ProcedureName As String

[Delphi]
property ProcedureName: WideString

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedBDEStoredProc, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedBDEStoredProc.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


LinkedBDEStoredProc.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedBDEStoredProc, Group Интерфейсы с базой данных


Класс LinkedBDETable

Элемент интерфейса - таблица BDE набор данных для TLinkedBDEDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedBDEDataset Class LinkedBDETable

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AutoRefresh | Автоматическое получение изменённых на сервере полей (типа автоинкремента)
Property BrowserItems | Элементы просмотра для Browser
Property CachedUpdates | Кэширование обновлений набора данных
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Exclusive | Монопольный доступ к таблице
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property ReadOnly | Режим "только для чтения"
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TableName | Имя таблицы
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedBDETable.AutoRefresh (свойство)

Автоматическое получение изменённых на сервере полей (типа автоинкремента)

Синтаксис

[Visual Basic 6]
Property AutoRefresh As Boolean

[Delphi]
property AutoRefresh: WordBool

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.CachedUpdates (свойство)

Кэширование обновлений набора данных

Синтаксис

[Visual Basic 6]
Property CachedUpdates As Boolean

[Delphi]
property CachedUpdates: WordBool

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.Exclusive (свойство)

Монопольный доступ к таблице

Синтаксис

[Visual Basic 6]
Property Exclusive As Boolean

[Delphi]
property Exclusive: WordBool

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedBDETable, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedBDETable.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedBDETable, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedBDETable.ReadOnly (свойство)

Режим "только для чтения"

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedBDETable, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedBDETable.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.TableName (свойство)

Имя таблицы

Синтаксис

[Visual Basic 6]
Property TableName As String

[Delphi]
property TableName: WideString

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedBDETable, Group Интерфейсы с базой данных


LinkedBDETable.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedBDETable, Group Интерфейсы с базой данных


Класс LinkedClientDataset

Элемент интерфейса - набор данных для TLinkedRemoteDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedClientDataset

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property CommandText | Текст команды для выполнения на сервере
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property ProviderName | Имя провайдера на сервере
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedClientDataset.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.CommandText (свойство)

Текст команды для выполнения на сервере

Синтаксис

[Visual Basic 6]
Property CommandText As String

[Delphi]
property CommandText: WideString

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedClientDataset, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedClientDataset.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedClientDataset, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedClientDataset.ProviderName (свойство)

Имя провайдера на сервере

Синтаксис

[Visual Basic 6]
Property ProviderName As String

[Delphi]
property ProviderName: WideString

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedClientDataset, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedClientDataset.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedClientDataset, Group Интерфейсы с базой данных


LinkedClientDataset.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedClientDataset, Group Интерфейсы с базой данных


Класс LinkedCorbaDatabase

База данных на удаленном сервере для ClientDataset(подключение через Corba)

Наследование

LinkedDatabase Class LinkedCorbaDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Cancelable | Быстрое прерывание связи
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property HostName | Имя компьютера с базой данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property ObjectName | Имя объекта сервера CORBA (может быть пусто)
Property RepositoryID | Id репозитория интерфейса модуля данных CORBA
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedCorbaDatabase.Cancelable (свойство)

Быстрое прерывание связи

Синтаксис

[Visual Basic 6]
Property Cancelable As Boolean

[Delphi]
property Cancelable: WordBool

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.HostName (свойство)

Имя компьютера с базой данных

Синтаксис

[Visual Basic 6]
Property HostName As String

[Delphi]
property HostName: WideString

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedCorbaDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedCorbaDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.ObjectName (свойство)

Имя объекта сервера CORBA (может быть пусто)

Синтаксис

[Visual Basic 6]
Property ObjectName As String

[Delphi]
property ObjectName: WideString

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.RepositoryID (свойство)

Id репозитория интерфейса модуля данных CORBA

Синтаксис

[Visual Basic 6]
Property RepositoryID As String

[Delphi]
property RepositoryID: WideString

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Class LinkedCorbaDatabase, Enum LinkedDatabaseStatusConstants, Group Интерфейсы с базой данных


LinkedCorbaDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedCorbaDatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedCorbaDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedCorbaDatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedCorbaDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedCorbaDatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedCorbaDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedCorbaDatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedCorbaDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedCorbaDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedCorbaDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedCorbaDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedCorbaDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


LinkedCorbaDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedCorbaDatabase, Group Интерфейсы с базой данных


Класс LinkedDCOMDatabase

База данных на удаленном сервере для ClientDataset(подключение через DCOM)

Наследование

LinkedDatabase Class LinkedRemoteDatabase Class LinkedDispatchDatabase Class LinkedDCOMDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AppServer (только для чтения) | Интерфейс IAppServer удаленного сервера
Property ComputerName | Имя компьютера с удаленным сервером данных
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property ServerGuid | GUID сервера
Property ServerName | Имя сервера
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDCOMDatabase.AppServer (свойство)

Интерфейс IAppServer удаленного сервера

Синтаксис

[Visual Basic 6]
ReadOnly Property AppServer As Object

[Delphi]
{только для чтения} property AppServer: IDispatch

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.ComputerName (свойство)

Имя компьютера с удаленным сервером данных

Синтаксис

[Visual Basic 6]
Property ComputerName As String

[Delphi]
property ComputerName: WideString

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.ServerGuid (свойство)

GUID сервера

Синтаксис

[Visual Basic 6]
Property ServerGuid As String

[Delphi]
property ServerGuid: WideString

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.ServerName (свойство)

Имя сервера

Синтаксис

[Visual Basic 6]
Property ServerName As String

[Delphi]
property ServerName: WideString

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


LinkedDCOMDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedDCOMDatabase, Group Интерфейсы с базой данных


Класс LinkedDatabase

База данных интерфейса

Наследование

LinkedDatabase Class LinkedADODatabase, LinkedBDEDatabase, LinkedCorbaDatabase, LinkedIBDatabase, LinkedRDSDatabase, LinkedRemoteDatabase, LinkedUniDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Где используется

Класс | Член класса
Class DatabaseInterface | Property Databases (свойство) Method FindDatabaseByID (метод) Method FindDatabaseByName (метод)
Class DatabaseInterfaces | Method FindDatabaseByIDs (метод) Method FindDatabaseByNames (метод)
Class LinkedADOCustomDataset | Property LinkedDatabase (свойство)
Class LinkedADODataset | Property LinkedDatabase (свойство)
Class LinkedADOQuery | Property LinkedDatabase (свойство)
Class LinkedADOStoredProc | Property LinkedDatabase (свойство)
Class LinkedADOTable | Property LinkedDatabase (свойство)
Class LinkedBDEDataset | Property LinkedDatabase (свойство)
Class LinkedBDEQuery | Property LinkedDatabase (свойство)
Class LinkedBDEStoredProc | Property LinkedDatabase (свойство)
Class LinkedBDETable | Property LinkedDatabase (свойство)
Class LinkedClientDataset | Property LinkedDatabase (свойство)
Class LinkedDatabaseFolder | Property LinkedDatabase (свойство)
Class LinkedDatabaseItem | Property LinkedDatabase (свойство)
Class LinkedDataset | Property LinkedDatabase (свойство)
Class LinkedIBDataset | Property LinkedDatabase (свойство)
Class LinkedIBQuery | Property LinkedDatabase (свойство)
Class LinkedIBStoredProc | Property LinkedDatabase (свойство)
Class LinkedIBTable | Property LinkedDatabase (свойство)
Class LinkedUniDataset | Property LinkedDatabase (свойство)
Class LinkedUniQuery | Property LinkedDatabase (свойство)
Class LinkedUniStoredProc | Property LinkedDatabase (свойство)
Class LinkedUniTable | Property LinkedDatabase (свойство)

Смотри также

Enum LinkedDatabaseStatusConstants, Group Интерфейсы с базой данных


LinkedDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Class LinkedDatabase, Enum LinkedDatabaseStatusConstants, Group Интерфейсы с базой данных


LinkedDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


LinkedDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedDatabase, Group Интерфейсы с базой данных


Класс LinkedDatabaseFolder

Элемент интерфейса - папка

Наследование

LinkedDatabaseItem Class LinkedDatabaseFolder

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property ItemCount (только для чтения) | Количество элементов базы данных верхнего уровня
Property Items (только для чтения) | Массив элементов базы данных
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CanPasteFromClipboard | Можно ли вставить из буфера
Method Clear | Очистить список элементов
Method CopyToClipboard | Скопировать содержимое в буфер
Method CreateFolder | Создать новыю папку в данной
Method PasteFromClipboard | Вставить из буфера

Где используется

Класс | Член класса
Class LinkedADOCustomDataset | Property Parent (свойство)
Class LinkedADODatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedADODataset | Property Parent (свойство)
Class LinkedADOQuery | Property Parent (свойство)
Class LinkedADOStoredProc | Property Parent (свойство)
Class LinkedADOTable | Property Parent (свойство)
Class LinkedBDEDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedBDEDataset | Property Parent (свойство)
Class LinkedBDEQuery | Property Parent (свойство)
Class LinkedBDEStoredProc | Property Parent (свойство)
Class LinkedBDETable | Property Parent (свойство)
Class LinkedClientDataset | Property Parent (свойство)
Class LinkedCorbaDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedDatabaseFolder | Property Parent (свойство) Method CreateFolder (метод)
Class LinkedDatabaseItem | Property Parent (свойство)
Class LinkedDataset | Property Parent (свойство)
Class LinkedDCOMDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedDispatchDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedIBDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedIBDataset | Property Parent (свойство)
Class LinkedIBQuery | Property Parent (свойство)
Class LinkedIBStoredProc | Property Parent (свойство)
Class LinkedIBTable | Property Parent (свойство)
Class LinkedOLEnterpriseDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedRDSDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedRemoteDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedSocketDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedUniDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)
Class LinkedUniDataset | Property Parent (свойство)
Class LinkedUniQuery | Property Parent (свойство)
Class LinkedUniStoredProc | Property Parent (свойство)
Class LinkedUniTable | Property Parent (свойство)
Class LinkedWebDatabase | Property Items (свойство) Method InsertItems (метод) Method InsertQueries (метод)

Смотри также

Group Интерфейсы с базой данных


LinkedDatabaseFolder.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.ItemCount (свойство)

Количество элементов базы данных верхнего уровня

Синтаксис

[Visual Basic 6]
ReadOnly Property ItemCount As Long

[Delphi]
{только для чтения} property ItemCount: Integer

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.Items (свойство)

Массив элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseItem

[Delphi]
{только для чтения} property Items: LinkedDatabaseItem

Смотри также

Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabaseFolder.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.CanPasteFromClipboard (метод)

Можно ли вставить из буфера

Синтаксис

[Visual Basic 6]
Function CanPasteFromClipboard As Boolean

[Delphi]
function CanPasteFromClipboard: WordBool

Возвращаемое значение

Возвращает True, если вставить из буфера можно

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.Clear (метод)

Очистить список элементов

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.CreateFolder (метод)

Создать новыю папку в данной

Синтаксис

[Visual Basic 6]
Function CreateFolder As LinkedDatabaseFolder

[Delphi]
function CreateFolder: LinkedDatabaseFolder

Возвращаемое значение

Возвращает новую созданную папку

Смотри также

Class LinkedDatabaseFolder, Group Интерфейсы с базой данных


LinkedDatabaseFolder.PasteFromClipboard (метод)

Вставить из буфера

Синтаксис

[Visual Basic 6]
Function PasteFromClipboard As LinkedDatabaseItem

[Delphi]
function PasteFromClipboard: LinkedDatabaseItem

Возвращаемое значение

Возвращает вставленную из буфера обмена папку

Смотри также

Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


Класс LinkedDatabaseItem

Элемент баз данных в интерфейсе

Наследование

LinkedDatabaseItem Class LinkedDatabaseFolder, LinkedDataset

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер

Где используется

Класс | Член класса
Class LinkedADODatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedBDEDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedCorbaDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedDatabaseFolder | Property Items (свойство) Method PasteFromClipboard (метод)
Class LinkedDCOMDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedDispatchDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedIBDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedOLEnterpriseDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedRDSDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedRemoteDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedSocketDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedUniDatabase | Method FindItemByID (метод) Method FindItemByName (метод)
Class LinkedWebDatabase | Method FindItemByID (метод) Method FindItemByName (метод)

Смотри также

Group Интерфейсы с базой данных


LinkedDatabaseItem.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabaseItem.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabaseItem.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabaseItem.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabaseItem.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabaseItem.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedDatabaseItem, Group Интерфейсы с базой данных


LinkedDatabaseItem.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedDatabaseItem, Group Интерфейсы с базой данных


Класс LinkedDataset

Элемент интерфейса - набор данных

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedADOCustomDataset, LinkedBDEDataset, LinkedClientDataset, LinkedIBDataset, LinkedUniDataset

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Где используется

Класс | Член класса
Class DatabaseInterfaces | Method FindDatasetByIDs (метод) Method FindDatasetByNames (метод)
Class DatasetLink | Method FindLinkedDataset (метод)
Class LinkedADODatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedBDEDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedCorbaDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedDCOMDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedDispatchDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedIBDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedOLEnterpriseDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedRDSDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedRemoteDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedSocketDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedUniDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)
Class LinkedWebDatabase | Method FindDatasetByID (метод) Method FindDatasetByName (метод)

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedDataset.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Class LinkedDataset, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedDataset.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDataset.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedDataset, Group Интерфейсы с базой данных


Класс LinkedDispatchDatabase

База данных на удаленном сервере для ClientDataset(подключение через TDispatchConnection)

Наследование

LinkedDatabase Class LinkedRemoteDatabase Class LinkedDispatchDatabase Class LinkedDCOMDatabase, LinkedOLEnterpriseDatabase, LinkedSocketDatabase, LinkedWebDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AppServer (только для чтения) | Интерфейс IAppServer удаленного сервера
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property ServerGuid | GUID сервера
Property ServerName | Имя сервера
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedDispatchDatabase.AppServer (свойство)

Интерфейс IAppServer удаленного сервера

Синтаксис

[Visual Basic 6]
ReadOnly Property AppServer As Object

[Delphi]
{только для чтения} property AppServer: IDispatch

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.ServerGuid (свойство)

GUID сервера

Синтаксис

[Visual Basic 6]
Property ServerGuid As String

[Delphi]
property ServerGuid: WideString

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.ServerName (свойство)

Имя сервера

Синтаксис

[Visual Basic 6]
Property ServerName As String

[Delphi]
property ServerName: WideString

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


LinkedDispatchDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedDispatchDatabase, Group Интерфейсы с базой данных


Класс LinkedGeoPoint

Точка хода с возможностью ссылки на другую точку

Наследование

GeoPoint Class LinkedGeoPoint Class CustomSurveyPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property LinkedPoint | Ссылка на другую точку
Property Number | Номер (описание) точки
Property Position | Положение точки

Где используется

Класс | Член класса
Class FieldTraverse | Property AimingBeginPoint (свойство) Property AimingEndPoint (свойство)

Смотри также

Class GeoPoint, Class ModelPoint, Group Геодезия


LinkedGeoPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class LinkedGeoPoint, Group Геодезия


LinkedGeoPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class LinkedGeoPoint, Group Геодезия


LinkedGeoPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class LinkedGeoPoint, Group Геодезия


LinkedGeoPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class LinkedGeoPoint, Group Геодезия


LinkedGeoPoint.LinkedPoint (свойство)

Ссылка на другую точку

Синтаксис

[Visual Basic 6]
Property LinkedPoint As GeoPoint

[Delphi]
property LinkedPoint: GeoPoint

Смотри также

Class GeoPoint, Class LinkedGeoPoint, Group Геодезия


LinkedGeoPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class LinkedGeoPoint, Group Геодезия


LinkedGeoPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class LinkedGeoPoint, Class ModelPoint, Group Геодезия


Класс LinkedIBDatabase

База данных Interbase

Наследование

LinkedDatabase Class LinkedIBDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property DatabaseName | Local InterBase: [File name], TCP/IP: [server_name]:[filename], NetBEUI: \\[server_name]\[filename], SPX: [server_name]@[filename]
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property IdleTimer | Время ожидания сервером, после чего соединение прерывается
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property Params | Дополнительные параметры в виде строки, разделенные точками с запятыми
Property SQLDialect | Тип диалекта SQL (1..MaxInt)
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedIBDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.DatabaseName (свойство)

Local InterBase: [File name], TCP/IP: [server_name]:[filename], NetBEUI: \\[server_name]\[filename], SPX: [server_name]@[filename]

Синтаксис

[Visual Basic 6]
Property DatabaseName As String

[Delphi]
property DatabaseName: WideString

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.IdleTimer (свойство)

Время ожидания сервером, после чего соединение прерывается

Синтаксис

[Visual Basic 6]
Property IdleTimer As Long

[Delphi]
property IdleTimer: Integer

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.Params (свойство)

Дополнительные параметры в виде строки, разделенные точками с запятыми

Синтаксис

[Visual Basic 6]
Property Params As String

[Delphi]
property Params: WideString

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.SQLDialect (свойство)

Тип диалекта SQL (1..MaxInt)

Синтаксис

[Visual Basic 6]
Property SQLDialect As Long

[Delphi]
property SQLDialect: Integer

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


LinkedIBDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedIBDatabase, Group Интерфейсы с базой данных


Класс LinkedIBDataset

Элемент интерфейса - набор данных для TLinkedIBDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedIBDataset Class LinkedIBQuery, LinkedIBStoredProc, LinkedIBTable

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedIBDataset.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Enum LinkedDatasetStatusConstants, Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedIBDataset, Group Интерфейсы с базой данных


LinkedIBDataset.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedIBDataset, Group Интерфейсы с базой данных


Класс LinkedIBQuery

Элемент интерфейса - запрос для TLinkedIBDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedIBDataset Class LinkedIBQuery

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedIBQuery.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Enum LinkedDatasetStatusConstants, Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedIBQuery, Group Интерфейсы с базой данных


LinkedIBQuery.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedIBQuery, Group Интерфейсы с базой данных


Класс LinkedIBStoredProc

Элемент интерфейса - хранимая процедура для TLinkedIBDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedIBDataset Class LinkedIBStoredProc

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property ProcedureName | Имя хранимой процедуры
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedIBStoredProc.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.ProcedureName (свойство)

Имя хранимой процедуры

Синтаксис

[Visual Basic 6]
Property ProcedureName As String

[Delphi]
property ProcedureName: WideString

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Enum LinkedDatasetStatusConstants, Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedIBStoredProc, Group Интерфейсы с базой данных


LinkedIBStoredProc.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedIBStoredProc, Group Интерфейсы с базой данных


Класс LinkedIBTable

Элемент интерфейса - таблица для TLinkedIBDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedIBDataset Class LinkedIBTable

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property ReadOnly | Запрет на модификацию
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TableName | Имя таблицы, вида или системной таблицы
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedIBTable.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.ReadOnly (свойство)

Запрет на модификацию

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Enum LinkedDatasetStatusConstants, Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.TableName (свойство)

Имя таблицы, вида или системной таблицы

Синтаксис

[Visual Basic 6]
Property TableName As String

[Delphi]
property TableName: WideString

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedIBTable, Group Интерфейсы с базой данных


LinkedIBTable.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedIBTable, Group Интерфейсы с базой данных


Класс LinkedOLEnterpriseDatabase

База данных на удаленном сервере для ClientDataset(подключение через OLEnterprise)

Наследование

LinkedDatabase Class LinkedRemoteDatabase Class LinkedDispatchDatabase Class LinkedOLEnterpriseDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AppServer (только для чтения) | Интерфейс IAppServer удаленного сервера
Property BrokerName | Имя объекта Business Object Broke
Property ComputerName | Имя компьютера с удаленным сервером данных
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property ServerGuid | GUID сервера
Property ServerName | Имя сервера
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.AppServer (свойство)

Интерфейс IAppServer удаленного сервера

Синтаксис

[Visual Basic 6]
ReadOnly Property AppServer As Object

[Delphi]
{только для чтения} property AppServer: IDispatch

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.BrokerName (свойство)

Имя объекта Business Object Broke

Синтаксис

[Visual Basic 6]
Property BrokerName As String

[Delphi]
property BrokerName: WideString

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.ComputerName (свойство)

Имя компьютера с удаленным сервером данных

Синтаксис

[Visual Basic 6]
Property ComputerName As String

[Delphi]
property ComputerName: WideString

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.ServerGuid (свойство)

GUID сервера

Синтаксис

[Visual Basic 6]
Property ServerGuid As String

[Delphi]
property ServerGuid: WideString

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.ServerName (свойство)

Имя сервера

Синтаксис

[Visual Basic 6]
Property ServerName As String

[Delphi]
property ServerName: WideString

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


LinkedOLEnterpriseDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedOLEnterpriseDatabase, Group Интерфейсы с базой данных


Класс LinkedParams

Набор параметров для запроса или хранимой процедуры

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ParamByName | Значения параметров по имени
Property ParamCount (только для чтения) | Количество параметров
Property Params | Массив значений параметров

Где используется

Класс | Член класса
Class LinkedADOQuery | Property LinkedParams (свойство)
Class LinkedBDEQuery | Property LinkedParams (свойство)
Class LinkedBDEStoredProc | Property LinkedParams (свойство)

Смотри также

Group Интерфейсы с базой данных


LinkedParams.ParamByName (свойство)

Значения параметров по имени

Синтаксис

[Visual Basic 6]
Property ParamByName

[Delphi]
property ParamByName

Смотри также

Class LinkedParams, Group Интерфейсы с базой данных


LinkedParams.ParamCount (свойство)

Количество параметров

Синтаксис

[Visual Basic 6]
ReadOnly Property ParamCount As Long

[Delphi]
{только для чтения} property ParamCount: Integer

Смотри также

Class LinkedParams, Group Интерфейсы с базой данных


LinkedParams.Params (свойство)

Массив значений параметров

Синтаксис

[Visual Basic 6]
Property Params

[Delphi]
property Params

Смотри также

Class LinkedParams, Group Интерфейсы с базой данных


Класс LinkedRDSDatabase

База данных RDS (удаленые наборы данных)

Наследование

LinkedDatabase Class LinkedRDSDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ComputerName | Имя компьютера с удаленным сервером данных
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property InternetTimeout | Время ожидания соединения по интернету
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property ServerName | Имя сервера данных в формате [RDSServer.DataFactory]
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedRDSDatabase.ComputerName (свойство)

Имя компьютера с удаленным сервером данных

Синтаксис

[Visual Basic 6]
Property ComputerName As String

[Delphi]
property ComputerName: WideString

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.InternetTimeout (свойство)

Время ожидания соединения по интернету

Синтаксис

[Visual Basic 6]
Property InternetTimeout As Long

[Delphi]
property InternetTimeout: Integer

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.ServerName (свойство)

Имя сервера данных в формате [RDSServer.DataFactory]

Синтаксис

[Visual Basic 6]
Property ServerName As String

[Delphi]
property ServerName: WideString

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


LinkedRDSDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedRDSDatabase, Group Интерфейсы с базой данных


Класс LinkedRemoteDatabase

База данных на удаленном сервере для ClientDataset

Наследование

LinkedDatabase Class LinkedRemoteDatabase Class LinkedDispatchDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AppServer (только для чтения) | Интерфейс IAppServer удаленного сервера
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedRemoteDatabase.AppServer (свойство)

Интерфейс IAppServer удаленного сервера

Синтаксис

[Visual Basic 6]
ReadOnly Property AppServer As Object

[Delphi]
{только для чтения} property AppServer: IDispatch

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


LinkedRemoteDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedRemoteDatabase, Group Интерфейсы с базой данных


Класс LinkedSocketDatabase

База данных на удаленном сервере для ClientDataset(подключение через Socket)

Наследование

LinkedDatabase Class LinkedRemoteDatabase Class LinkedDispatchDatabase Class LinkedSocketDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Address | IP-адрес сервера
Property AppServer (только для чтения) | Интерфейс IAppServer удаленного сервера
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property Host | Имя хоста с сервером
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property InterceptGuid | Идентификатор объекта для перехватывания сообщений
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property Port | Номер порта на сервере - по умолчанию используется 211
Property ServerGuid | GUID сервера
Property ServerName | Имя сервера
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedSocketDatabase.Address (свойство)

IP-адрес сервера

Синтаксис

[Visual Basic 6]
Property Address As String

[Delphi]
property Address: WideString

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.AppServer (свойство)

Интерфейс IAppServer удаленного сервера

Синтаксис

[Visual Basic 6]
ReadOnly Property AppServer As Object

[Delphi]
{только для чтения} property AppServer: IDispatch

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Host (свойство)

Имя хоста с сервером

Синтаксис

[Visual Basic 6]
Property Host As String

[Delphi]
property Host: WideString

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.InterceptGuid (свойство)

Идентификатор объекта для перехватывания сообщений

Синтаксис

[Visual Basic 6]
Property InterceptGuid As String

[Delphi]
property InterceptGuid: WideString

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Port (свойство)

Номер порта на сервере - по умолчанию используется 211

Синтаксис

[Visual Basic 6]
Property Port As Long

[Delphi]
property Port: Integer

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.ServerGuid (свойство)

GUID сервера

Синтаксис

[Visual Basic 6]
Property ServerGuid As String

[Delphi]
property ServerGuid: WideString

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.ServerName (свойство)

Имя сервера

Синтаксис

[Visual Basic 6]
Property ServerName As String

[Delphi]
property ServerName: WideString

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


LinkedSocketDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedSocketDatabase, Group Интерфейсы с базой данных


Класс LinkedUniDatabase

База данных UniDAC

Наследование

LinkedDatabase Class LinkedUniDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property ConnectionParameters (только для чтения) | Параметры соединения с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Class UniConnectionParameters, Group Интерфейсы с базой данных


LinkedUniDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.ConnectionParameters (свойство)

Параметры соединения с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ConnectionParameters As UniConnectionParameters

[Delphi]
{только для чтения} property ConnectionParameters: UniConnectionParameters

Смотри также

Class LinkedUniDatabase, Class UniConnectionParameters, Group Интерфейсы с базой данных


LinkedUniDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


LinkedUniDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedUniDatabase, Group Интерфейсы с базой данных


Класс LinkedUniDataset

Элемент интерфейса - набор данных для TLinkedUniDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedUniDataset Class LinkedUniQuery, LinkedUniStoredProc, LinkedUniTable

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedUniDataset.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Enum LinkedDatasetStatusConstants, Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedUniDataset, Group Интерфейсы с базой данных


LinkedUniDataset.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedUniDataset, Group Интерфейсы с базой данных


Класс LinkedUniQuery

Элемент интерфейса - запрос UniDAC набор данных для TLinkedUniDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedUniDataset Class LinkedUniQuery

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedUniQuery.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Enum LinkedDatasetStatusConstants, Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedUniQuery, Group Интерфейсы с базой данных


LinkedUniQuery.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedUniQuery, Group Интерфейсы с базой данных


Класс LinkedUniStoredProc

Элемент интерфейса - хранимая процедура UniDAC набор данных для TLinkedUniDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedUniDataset Class LinkedUniStoredProc

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedUniStoredProc.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Enum LinkedDatasetStatusConstants, Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedUniStoredProc, Group Интерфейсы с базой данных


LinkedUniStoredProc.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedUniStoredProc, Group Интерфейсы с базой данных


Класс LinkedUniTable

Элемент интерфейса - таблица UniDAC набор данных для TLinkedUniDatabase

Наследование

LinkedDatabaseItem Class LinkedDataset Class LinkedUniDataset Class LinkedUniTable

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems | Элементы просмотра для Browser
Property DatasetCount (только для чтения) | Количество подключенных наборов данных
Property Datasets (только для чтения) | Массив подключенных наборов данных
Property DetailOnly | Набор данных является подчиненным и не может редактироваться отдельно
Property Filter | Фильтр
Property FilterCaseInsens | Фильтр не чувствителен к регистру букв
Property Filtered | Фильтруется ли набор данных
Property FilterNoPartComp | Фильтр не допускает частичное сравнение
Property ID (только для чтения) | Уникальный код элемента в базе данных
Property ImageIndex (только для чтения) | Код картинки для отображения в дереве
Property IndexName | Имя используемого индекса для сортированного отображения
Property LinkedDatabase (только для чтения) | База данных интерфейса
Property Name | Название элемента базы данных
Property Parent (только для чтения) | Папка, в которой находится элемент
Property SQL | Текст запроса
Property Status (только для чтения) | Статус последнего подключения к набору данных
Property StatusString (только для чтения) | Статус подключения к набору данных в виде строки
Property TypeName (только для чтения) | Название типа элемента базы данных для появления в меню

Методы класса

Имя | Описание
Method CopyToClipboard | Скопировать содержимое в буфер
Method Open | Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Смотри также

Class BrowserItems, Class Dataset, Class LinkedDatabase, Class LinkedDatabaseFolder, Enum LinkedDatasetStatusConstants, Group Интерфейсы с базой данных


LinkedUniTable.BrowserItems (свойство)

Элементы просмотра для Browser

Синтаксис

[Visual Basic 6]
Property BrowserItems As BrowserItems

[Delphi]
property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.DatasetCount (свойство)

Количество подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetCount As Long

[Delphi]
{только для чтения} property DatasetCount: Integer

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.Datasets (свойство)

Массив подключенных наборов данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Datasets As Dataset

[Delphi]
{только для чтения} property Datasets: Dataset

Смотри также

Class Dataset, Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.DetailOnly (свойство)

Набор данных является подчиненным и не может редактироваться отдельно

Синтаксис

[Visual Basic 6]
Property DetailOnly As Boolean

[Delphi]
property DetailOnly: WordBool

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.Filter (свойство)

Фильтр

Синтаксис

[Visual Basic 6]
Property Filter As String

[Delphi]
property Filter: WideString

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.FilterCaseInsens (свойство)

Фильтр не чувствителен к регистру букв

Синтаксис

[Visual Basic 6]
Property FilterCaseInsens As Boolean

[Delphi]
property FilterCaseInsens: WordBool

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.Filtered (свойство)

Фильтруется ли набор данных

Синтаксис

[Visual Basic 6]
Property Filtered As Boolean

[Delphi]
property Filtered: WordBool

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.FilterNoPartComp (свойство)

Фильтр не допускает частичное сравнение

Синтаксис

[Visual Basic 6]
Property FilterNoPartComp As Boolean

[Delphi]
property FilterNoPartComp: WordBool

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.ID (свойство)

Уникальный код элемента в базе данных

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.ImageIndex (свойство)

Код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.IndexName (свойство)

Имя используемого индекса для сортированного отображения

Синтаксис

[Visual Basic 6]
Property IndexName As String

[Delphi]
property IndexName: WideString

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.LinkedDatabase (свойство)

База данных интерфейса

Синтаксис

[Visual Basic 6]
ReadOnly Property LinkedDatabase As LinkedDatabase

[Delphi]
{только для чтения} property LinkedDatabase: LinkedDatabase

Смотри также

Class LinkedDatabase, Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.Name (свойство)

Название элемента базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.Parent (свойство)

Папка, в которой находится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Parent: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.SQL (свойство)

Текст запроса

Синтаксис

[Visual Basic 6]
Property SQL As String

[Delphi]
property SQL: WideString

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.Status (свойство)

Статус последнего подключения к набору данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatasetStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatasetStatusConstants

Смотри также

Enum LinkedDatasetStatusConstants, Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.StatusString (свойство)

Статус подключения к набору данных в виде строки

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.TypeName (свойство)

Название типа элемента базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.CopyToClipboard (метод)

Скопировать содержимое в буфер

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedUniTable, Group Интерфейсы с базой данных


LinkedUniTable.Open (метод)

Подключение нового набора данных. Возвращает Nothing если неуспешно соединение

Синтаксис

[Visual Basic 6]
Function Open As Dataset

[Delphi]
function Open: Dataset

Возвращаемое значение

Возвращает открытый набор данных или Nothing, если соединение не удалось установить

Смотри также

Class Dataset, Class LinkedUniTable, Group Интерфейсы с базой данных


Класс LinkedWebDatabase

База данных на удаленном сервере для ClientDataset(подключение через Web)

Наследование

LinkedDatabase Class LinkedRemoteDatabase Class LinkedDispatchDatabase Class LinkedWebDatabase

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Agent | Имя агента для заголовков HTTP-сообщений на сервере
Property AppServer (только для чтения) | Интерфейс IAppServer удаленного сервера
Property Connected (только для чтения) | Установлено ли соединение с базой данных
Property DatabaseInterface (только для чтения) | Интерфейс базы данных
Property ID (только для чтения) | Уникальный идентификатор базы данных в интерфейсе
Property ImageIndex (только для чтения) | Получить код картинки для отображения в дереве
Property Index (только для чтения) | Номер в интерфейсе базы данных
Property Items (только для чтения) | Корневая папка элементов базы данных
Property KeepConnection | Удерживать соединение с базой данных, даже если все таблицы закрыты
Property LockCount (только для чтения) | Количество блокировок - использований базы данных
Property LoginPrompt | Выдавать ли диалог подключения к базе
Property Name | Имя базы данных
Property Password | Пароль доступа
Property Proxy | Список прокси-серверов
Property ProxyByPass | Список локальных серверов, не требующих прокси
Property ServerGuid | GUID сервера
Property ServerName | Имя сервера
Property Status (только для чтения) | Статус подключения к БД
Property StatusString (только для чтения) | Статус подключения к БД
Property TypeName (только для чтения) | Получить название типа базы данных для появления в меню
Property URL | URL ресурса, который разбирается в httpsrvr.dll
Property UserName | Имя пользователя

Методы класса

Имя | Описание
Method CheckConnected | Проверка установления соединения
Method CheckDisconnected | Проверка на рассоединение
Method CopyToClipboard | Скопировать содержимое в буфер обмена
Method FindDatasetByID | Найти набор данных по коду
Method FindDatasetByName | Найти набор данных по имени
Method FindItemByID | Найти элемент базы данных по коду
Method FindItemByName | Найти элемент базы данных по имени
Method InsertItems | Команда меню "Добавить..."
Method InsertQueries | Команда меню "Добавить запрос..."
Method Lock | Блокировка (установление соединения)
Method NeedConnected | Требование установления соединения, иначе исключение
Method Unlock | Разблокировка (разрыв соединения)

Смотри также

Class DatabaseInterface, Class LinkedDatabaseFolder, Class LinkedDatabaseItem, Enum LinkedDatabaseStatusConstants, Class LinkedDataset, Group Интерфейсы с базой данных


LinkedWebDatabase.Agent (свойство)

Имя агента для заголовков HTTP-сообщений на сервере

Синтаксис

[Visual Basic 6]
Property Agent As String

[Delphi]
property Agent: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.AppServer (свойство)

Интерфейс IAppServer удаленного сервера

Синтаксис

[Visual Basic 6]
ReadOnly Property AppServer As Object

[Delphi]
{только для чтения} property AppServer: IDispatch

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Connected (свойство)

Установлено ли соединение с базой данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Connected As Boolean

[Delphi]
{только для чтения} property Connected: WordBool

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.DatabaseInterface (свойство)

Интерфейс базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatabaseInterface As DatabaseInterface

[Delphi]
{только для чтения} property DatabaseInterface: DatabaseInterface

Смотри также

Class DatabaseInterface, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.ID (свойство)

Уникальный идентификатор базы данных в интерфейсе

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As Long

[Delphi]
{только для чтения} property ID: Integer

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.ImageIndex (свойство)

Получить код картинки для отображения в дереве

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Index (свойство)

Номер в интерфейсе базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Items (свойство)

Корневая папка элементов базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As LinkedDatabaseFolder

[Delphi]
{только для чтения} property Items: LinkedDatabaseFolder

Смотри также

Class LinkedDatabaseFolder, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.KeepConnection (свойство)

Удерживать соединение с базой данных, даже если все таблицы закрыты

Синтаксис

[Visual Basic 6]
Property KeepConnection As Boolean

[Delphi]
property KeepConnection: WordBool

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.LockCount (свойство)

Количество блокировок - использований базы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property LockCount As Long

[Delphi]
{только для чтения} property LockCount: Integer

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.LoginPrompt (свойство)

Выдавать ли диалог подключения к базе

Синтаксис

[Visual Basic 6]
Property LoginPrompt As Boolean

[Delphi]
property LoginPrompt: WordBool

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Name (свойство)

Имя базы данных

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Password (свойство)

Пароль доступа

Синтаксис

[Visual Basic 6]
Property Password As String

[Delphi]
property Password: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Proxy (свойство)

Список прокси-серверов

Синтаксис

[Visual Basic 6]
Property Proxy As String

[Delphi]
property Proxy: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.ProxyByPass (свойство)

Список локальных серверов, не требующих прокси

Синтаксис

[Visual Basic 6]
Property ProxyByPass As String

[Delphi]
property ProxyByPass: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.ServerGuid (свойство)

GUID сервера

Синтаксис

[Visual Basic 6]
Property ServerGuid As String

[Delphi]
property ServerGuid: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.ServerName (свойство)

Имя сервера

Синтаксис

[Visual Basic 6]
Property ServerName As String

[Delphi]
property ServerName: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Status (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property Status As LinkedDatabaseStatusConstants

[Delphi]
{только для чтения} property Status: LinkedDatabaseStatusConstants

Смотри также

Enum LinkedDatabaseStatusConstants, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.StatusString (свойство)

Статус подключения к БД

Синтаксис

[Visual Basic 6]
ReadOnly Property StatusString As String

[Delphi]
{только для чтения} property StatusString: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.TypeName (свойство)

Получить название типа базы данных для появления в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property TypeName As String

[Delphi]
{только для чтения} property TypeName: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.URL (свойство)

URL ресурса, который разбирается в httpsrvr.dll

Синтаксис

[Visual Basic 6]
Property URL As String

[Delphi]
property URL: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.UserName (свойство)

Имя пользователя

Синтаксис

[Visual Basic 6]
Property UserName As String

[Delphi]
property UserName: WideString

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.CheckConnected (метод)

Проверка установления соединения

Синтаксис

[Visual Basic 6]
Sub CheckConnected

[Delphi]
procedure CheckConnected

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.CheckDisconnected (метод)

Проверка на рассоединение

Синтаксис

[Visual Basic 6]
Sub CheckDisconnected

[Delphi]
procedure CheckDisconnected

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.CopyToClipboard (метод)

Скопировать содержимое в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.FindDatasetByID (метод)

Найти набор данных по коду

Синтаксис

[Visual Basic 6]
Function FindDatasetByID ( _
   ByVal DatasetID As Long _
) As LinkedDataset

[Delphi]
function FindDatasetByID(
   const DatasetID: Integer
): LinkedDataset

Описание параметров

DatasetID
[in] Код набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.FindDatasetByName (метод)

Найти набор данных по имени

Синтаксис

[Visual Basic 6]
Function FindDatasetByName ( _
   ByVal DatasetName As String _
) As LinkedDataset

[Delphi]
function FindDatasetByName(
   const DatasetName: WideString
): LinkedDataset

Описание параметров

DatasetName
[in] Имя набора данных базы данных

Возвращаемое значение

Возвращает найденный набор данных базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDataset, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.FindItemByID (метод)

Найти элемент базы данных по коду

Синтаксис

[Visual Basic 6]
Function FindItemByID ( _
   ByVal ItemID As Long _
) As LinkedDatabaseItem

[Delphi]
function FindItemByID(
   const ItemID: Integer
): LinkedDatabaseItem

Описание параметров

ItemID
[in] Код элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному коду или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.FindItemByName (метод)

Найти элемент базы данных по имени

Синтаксис

[Visual Basic 6]
Function FindItemByName ( _
   ByVal ItemName As String _
) As LinkedDatabaseItem

[Delphi]
function FindItemByName(
   const ItemName: WideString
): LinkedDatabaseItem

Описание параметров

ItemName
[in] Имя элемента базы данных

Возвращаемое значение

Возвращает найденный элемент базы данных по указанному имени или Nothing, если такового не найдено

Смотри также

Class LinkedDatabaseItem, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.InsertItems (метод)

Команда меню "Добавить..."

Синтаксис

[Visual Basic 6]
Function InsertItems ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertItems(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка новых элементов

Возвращаемое значение

Возвращает добавленный элемент

Смотри также

Class LinkedDatabaseFolder, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.InsertQueries (метод)

Команда меню "Добавить запрос..."

Синтаксис

[Visual Basic 6]
Function InsertQueries ( _
   ByVal ParentFolder As LinkedDatabaseFolder _
) As Boolean

[Delphi]
function InsertQueries(
   const ParentFolder: LinkedDatabaseFolder
): WordBool

Описание параметров

ParentFolder
[in] Папка, в которую будет выполнена вставка нового запроса

Возвращаемое значение

Возвращает добавленные запросы

Смотри также

Class LinkedDatabaseFolder, Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Lock (метод)

Блокировка (установление соединения)

Синтаксис

[Visual Basic 6]
Sub Lock

[Delphi]
procedure Lock

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.NeedConnected (метод)

Требование установления соединения, иначе исключение

Синтаксис

[Visual Basic 6]
Sub NeedConnected

[Delphi]
procedure NeedConnected

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


LinkedWebDatabase.Unlock (метод)

Разблокировка (разрыв соединения)

Синтаксис

[Visual Basic 6]
Sub Unlock

[Delphi]
procedure Unlock

Смотри также

Class LinkedWebDatabase, Group Интерфейсы с базой данных


Класс MeasureAdditionalPoint

Дополнительная точка, вычисленная по промерам

Наследование

GeoPoint Class AdditionalPoint Class RangeAdditionalPoint Class MeasureAdditionalPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AdditionalPointType (только для чтения) | Тип засечки
Property AimingDirAngle | Дирекционный угол на точку наведения
Property DirAngle | Дирекционный угол
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property HorzAngle | Измеренный горизонтальный угол
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Length | Измеренное расстояние
Property Number | Номер (описание) точки
Property Position | Положение точки
Property RangeLinkToPoints | Массив ссылок створных точек на другие точки
Property RangePointCount (только для чтения) | Количество створных (опорных) точек
Property RangePoints | Массив координат створных точек
Property VertAngle | Вертикальный угол

Смотри также

Class GeodesyAngle, Class GeoPoint, Enum IntersectionConstants, Class ModelPoint, Group Геодезия


MeasureAdditionalPoint.AdditionalPointType (свойство)

Тип засечки

Синтаксис

[Visual Basic 6]
ReadOnly Property AdditionalPointType As IntersectionConstants

[Delphi]
{только для чтения} property AdditionalPointType: IntersectionConstants

Смотри также

Enum IntersectionConstants, Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.AimingDirAngle (свойство)

Дирекционный угол на точку наведения

Синтаксис

[Visual Basic 6]
Property AimingDirAngle As GeodesyAngle

[Delphi]
property AimingDirAngle: GeodesyAngle

Смотри также

Class GeodesyAngle, Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.DirAngle (свойство)

Дирекционный угол

Синтаксис

[Visual Basic 6]
Property DirAngle As GeodesyAngle

[Delphi]
property DirAngle: GeodesyAngle

Смотри также

Class GeodesyAngle, Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.HorzAngle (свойство)

Измеренный горизонтальный угол

Синтаксис

[Visual Basic 6]
Property HorzAngle As GeodesyAngle

[Delphi]
property HorzAngle: GeodesyAngle

Смотри также

Class GeodesyAngle, Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.Length (свойство)

Измеренное расстояние

Синтаксис

[Visual Basic 6]
Property Length As Double

[Delphi]
property Length: Double

Смотри также

Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class MeasureAdditionalPoint, Class ModelPoint, Group Геодезия


MeasureAdditionalPoint.RangeLinkToPoints (свойство)

Массив ссылок створных точек на другие точки

Синтаксис

[Visual Basic 6]
Property RangeLinkToPoints As GeoPoint

[Delphi]
property RangeLinkToPoints: GeoPoint

Смотри также

Class GeoPoint, Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.RangePointCount (свойство)

Количество створных (опорных) точек

Синтаксис

[Visual Basic 6]
ReadOnly Property RangePointCount As Long

[Delphi]
{только для чтения} property RangePointCount: Integer

Смотри также

Class MeasureAdditionalPoint, Group Геодезия


MeasureAdditionalPoint.RangePoints (свойство)

Массив координат створных точек

Синтаксис

[Visual Basic 6]
Property RangePoints As ModelPoint

[Delphi]
property RangePoints: ModelPoint

Смотри также

Class MeasureAdditionalPoint, Class ModelPoint, Group Геодезия


MeasureAdditionalPoint.VertAngle (свойство)

Вертикальный угол

Синтаксис

[Visual Basic 6]
Property VertAngle As GeodesyAngle

[Delphi]
property VertAngle: GeodesyAngle

Смотри также

Class GeodesyAngle, Class MeasureAdditionalPoint, Group Геодезия


Класс Measuring

Абстрактная съёмка

Наследование

Measuring Class FieldTraverse, Survey

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AnglesAreLeft | Измеренные углы являются левыми (в противном случае - правыми)
Property Handle (только для чтения) | Handle объекта
Property HorzAngleCorrection | Поправка прибора для горизонтального угла
Property LengthCorrection | Поправка прибора для расстояний
Property Name | Наименование съёмки
Property VertAngleCorrection | Поправка прибора для вертикального угла
Property VertAnglesAreFromZenith | Вертикальный угол измеряется от зенита (в противном случае - от горизонта)
Property Visible | Видима ли съёмка на плане

Смотри также

Class GeodesyAngle, Group Геодезия


Measuring.AnglesAreLeft (свойство)

Измеренные углы являются левыми (в противном случае - правыми)

Синтаксис

[Visual Basic 6]
Property AnglesAreLeft As Boolean

[Delphi]
property AnglesAreLeft: WordBool

Смотри также

Class Measuring, Group Геодезия


Measuring.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Measuring, Group Геодезия


Measuring.HorzAngleCorrection (свойство)

Поправка прибора для горизонтального угла

Синтаксис

[Visual Basic 6]
Property HorzAngleCorrection As GeodesyAngle

[Delphi]
property HorzAngleCorrection: GeodesyAngle

Смотри также

Class GeodesyAngle, Class Measuring, Group Геодезия


Measuring.LengthCorrection (свойство)

Поправка прибора для расстояний

Синтаксис

[Visual Basic 6]
Property LengthCorrection As Double

[Delphi]
property LengthCorrection: Double

Смотри также

Class Measuring, Group Геодезия


Measuring.Name (свойство)

Наименование съёмки

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class Measuring, Group Геодезия


Measuring.VertAngleCorrection (свойство)

Поправка прибора для вертикального угла

Синтаксис

[Visual Basic 6]
Property VertAngleCorrection As GeodesyAngle

[Delphi]
property VertAngleCorrection: GeodesyAngle

Смотри также

Class GeodesyAngle, Class Measuring, Group Геодезия


Measuring.VertAnglesAreFromZenith (свойство)

Вертикальный угол измеряется от зенита (в противном случае - от горизонта)

Синтаксис

[Visual Basic 6]
Property VertAnglesAreFromZenith As Boolean

[Delphi]
property VertAnglesAreFromZenith: WordBool

Смотри также

Class Measuring, Group Геодезия


Measuring.Visible (свойство)

Видима ли съёмка на плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Measuring, Group Геодезия


Класс Menu

Описание меню окна

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество подменю в меню
Property Menus (только для чтения) | Массив подменю в меню

Методы класса

Имя | Описание
Method AddMenu | Добавить меню с заданным внутренним именем
Method DeleteMenu | Удалить меню с заданным внутренним именем
Method MenuByName | Получить меню по внутреннему имени (при необходимости создаёт новую)

Смотри также

Class MenuItem, Group Пользовательский интерфейс


Menu.Count (свойство)

Количество подменю в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class Menu, Group Пользовательский интерфейс


Menu.Menus (свойство)

Массив подменю в меню

Синтаксис

[Visual Basic 6]
ReadOnly Property Menus As MenuItem

[Delphi]
{только для чтения} property Menus: MenuItem

Смотри также

Class Menu, Class MenuItem, Group Пользовательский интерфейс


Menu.AddMenu (метод)

Добавить меню с заданным внутренним именем

Синтаксис

[Visual Basic 6]
Function AddMenu ( _
   [ByVal Name As String = ""] _
) As MenuItem

[Delphi]
function AddMenu(
   const Name: WideString
): MenuItem

Описание параметров

Name
[in] Имя нового элемента меню

Возвращаемое значение

Возвращает новый элемент меню

Смотри также

Class Menu, Class MenuItem, Group Пользовательский интерфейс


Menu.DeleteMenu (метод)

Удалить меню с заданным внутренним именем

Синтаксис

[Visual Basic 6]
Sub DeleteMenu ( _
   ByVal Name As String _
)

[Delphi]
procedure DeleteMenu(
   const Name: WideString
)

Описание параметров

Name
[in] Имя удаляемого элемента меню

Смотри также

Class Menu, Group Пользовательский интерфейс


Menu.MenuByName (метод)

Получить меню по внутреннему имени (при необходимости создаёт новую)

Синтаксис

[Visual Basic 6]
Function MenuByName ( _
   ByVal Name As String, _
   [ByVal CreateIfNotFound As Boolean = False] _
) As MenuItem

[Delphi]
function MenuByName(
   const Name: WideString;
   const CreateIfNotFound: WordBool
): MenuItem

Описание параметров

Name
[in] Имя элемента меню
CreateIfNotFound
[in] Следует ли создавать новый элемент меню, если с указанным именем элемента нет

Возвращаемое значение

Возвращает найденный элемент меню или Nothing, если таковой не существует

Смотри также

Class Menu, Class MenuItem, Group Пользовательский интерфейс


Класс MenuItem

Элемент меню

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ActionName | Имя выполняемого действия или макроса
Property ActionType | Тип выполняемого действия
Property Caption | Название пункта меню
Property Checked | Отмечен ли пункт меню
Property Count (только для чтения) | Количество подэлементов
Property Enabled | Доступен ли пункт меню
Property GroupIndex | Номер (радио)группы
Property ImageIndex | Код иконки
Property Items (только для чтения) | Массив подэлементов
Property Name (только для чтения) | Внутреннее имя элемента меню
Property RadioItem | Является радиоэлементом?
Property ShortCut | Код горячей клавиши
Property Visible | Видим ли пункт меню

Методы класса

Имя | Описание
Method AddItem | Добавить элемент меню с заданным внутренним именем. Если элемент с таким именем существует, то будет сгенерировано исключение
Method Delete | Удалить данный элемент меню
Method DeleteItem | Удалить элемент меню с заданным внутренним именем
Method ItemByName | Получить элемент меню по его внутреннему имени

Где используется

Класс | Член класса
Class Menu | Property Menus (свойство) Method AddMenu (метод) Method MenuByName (метод)
Class MenuItem | Property Items (свойство) Method AddItem (метод) Method ItemByName (метод)

Смотри также

Enum ActionTypeConstants, Group Пользовательский интерфейс


MenuItem.ActionName (свойство)

Имя выполняемого действия или макроса

Синтаксис

[Visual Basic 6]
Property ActionName As String

[Delphi]
property ActionName: WideString

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.ActionType (свойство)

Тип выполняемого действия

Синтаксис

[Visual Basic 6]
Property ActionType As ActionTypeConstants

[Delphi]
property ActionType: ActionTypeConstants

Смотри также

Enum ActionTypeConstants, Class MenuItem, Group Пользовательский интерфейс


MenuItem.Caption (свойство)

Название пункта меню

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.Checked (свойство)

Отмечен ли пункт меню

Синтаксис

[Visual Basic 6]
Property Checked As Boolean

[Delphi]
property Checked: WordBool

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.Count (свойство)

Количество подэлементов

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.Enabled (свойство)

Доступен ли пункт меню

Синтаксис

[Visual Basic 6]
Property Enabled As Boolean

[Delphi]
property Enabled: WordBool

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.GroupIndex (свойство)

Номер (радио)группы

Синтаксис

[Visual Basic 6]
Property GroupIndex As Long

[Delphi]
property GroupIndex: Integer

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.ImageIndex (свойство)

Код иконки

Синтаксис

[Visual Basic 6]
Property ImageIndex As Long

[Delphi]
property ImageIndex: Integer

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.Items (свойство)

Массив подэлементов

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As MenuItem

[Delphi]
{только для чтения} property Items: MenuItem

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.Name (свойство)

Внутреннее имя элемента меню

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.RadioItem (свойство)

Является радиоэлементом?

Синтаксис

[Visual Basic 6]
Property RadioItem As Boolean

[Delphi]
property RadioItem: WordBool

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.ShortCut (свойство)

Код горячей клавиши

Синтаксис

[Visual Basic 6]
Property ShortCut As Long

[Delphi]
property ShortCut: Integer

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.Visible (свойство)

Видим ли пункт меню

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.AddItem (метод)

Добавить элемент меню с заданным внутренним именем. Если элемент с таким именем существует, то будет сгенерировано исключение

Синтаксис

[Visual Basic 6]
Function AddItem ( _
   [ByVal Name As String = ""] _
) As MenuItem

[Delphi]
function AddItem(
   const Name: WideString
): MenuItem

Описание параметров

Name
[in] Имя нового элемента меню

Возвращаемое значение

Возвращает новый элемент меню

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.Delete (метод)

Удалить данный элемент меню

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.DeleteItem (метод)

Удалить элемент меню с заданным внутренним именем

Синтаксис

[Visual Basic 6]
Sub DeleteItem ( _
   ByVal Name As String _
)

[Delphi]
procedure DeleteItem(
   const Name: WideString
)

Описание параметров

Name
[in] Имя удаляемого элемента меню

Смотри также

Class MenuItem, Group Пользовательский интерфейс


MenuItem.ItemByName (метод)

Получить элемент меню по его внутреннему имени

Синтаксис

[Visual Basic 6]
Function ItemByName ( _
   ByVal Name As String, _
   [ByVal CreateIfNotFound As Boolean = False] _
) As MenuItem

[Delphi]
function ItemByName(
   const Name: WideString;
   const CreateIfNotFound: WordBool
): MenuItem

Описание параметров

Name
[in] Имя элемента меню
CreateIfNotFound
[in] Следует ли создавать новый элемент меню, если с указанным именем элемента нет

Возвращаемое значение

Возвращает элемент меню с указанным именем или Nothing, если таковой не найден

Смотри также

Class MenuItem, Group Пользовательский интерфейс


Класс MenuVerb

Описание пункта меню

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Caption (только для чтения) | Текст элемента меню
Property Checked (только для чтения) | Отметка пункта меню
Property Default (только для чтения) | По умолчанию (шрифт Bold)
Property Disabled (только для чтения) | Запрещен элемент меню
Property ImageIndex (только для чтения) | Индекс иконки в списке иконок приложения
Property RadioItem (только для чтения) | Тип отметки: радио или галочка
Property ShortCut (только для чтения) | Клавиша быстрого доступа
Property Visible (только для чтения) | Видимость пункта меню

Где используется

Класс | Член класса
Class CompositionLayer | Property Verbs (свойство)
Class FolderLayer | Property Verbs (свойство)
Class VectorLayer | Property Verbs (свойство) Method GetFigureVerb (метод)

Смотри также

Group Пользовательский интерфейс


MenuVerb.Caption (свойство)

Текст элемента меню

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class MenuVerb, Group Пользовательский интерфейс


MenuVerb.Checked (свойство)

Отметка пункта меню

Синтаксис

[Visual Basic 6]
ReadOnly Property Checked As Boolean

[Delphi]
{только для чтения} property Checked: WordBool

Смотри также

Class MenuVerb, Group Пользовательский интерфейс


MenuVerb.Default (свойство)

По умолчанию (шрифт Bold)

Синтаксис

[Visual Basic 6]
ReadOnly Property Default As Boolean

[Delphi]
{только для чтения} property Default: WordBool

Смотри также

Class MenuVerb, Group Пользовательский интерфейс


MenuVerb.Disabled (свойство)

Запрещен элемент меню

Синтаксис

[Visual Basic 6]
ReadOnly Property Disabled As Boolean

[Delphi]
{только для чтения} property Disabled: WordBool

Смотри также

Class MenuVerb, Group Пользовательский интерфейс


MenuVerb.ImageIndex (свойство)

Индекс иконки в списке иконок приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class MenuVerb, Group Пользовательский интерфейс


MenuVerb.RadioItem (свойство)

Тип отметки: радио или галочка

Синтаксис

[Visual Basic 6]
ReadOnly Property RadioItem As Boolean

[Delphi]
{только для чтения} property RadioItem: WordBool

Смотри также

Class MenuVerb, Group Пользовательский интерфейс


MenuVerb.ShortCut (свойство)

Клавиша быстрого доступа

Синтаксис

[Visual Basic 6]
ReadOnly Property ShortCut As Integer

[Delphi]
{только для чтения} property ShortCut: SmallInt

Смотри также

Class MenuVerb, Group Пользовательский интерфейс


MenuVerb.Visible (свойство)

Видимость пункта меню

Синтаксис

[Visual Basic 6]
ReadOnly Property Visible As Boolean

[Delphi]
{только для чтения} property Visible: WordBool

Смотри также

Class MenuVerb, Group Пользовательский интерфейс


Класс Options3D

Настройки отображения 3D-вида проекта

Наследование

CustomOptions Class Options3D

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BackgroundColor | Цвет фона при отрисовке 3D-вида (если не отображается небо)
Property CloudsEnabled | Включить/выключить облака в 3д-виде
Property CurrentDate | Дата (системная или заданная пользователем). Необходимо для астрономических расчётов
Property CustomValueName (только для чтения) | Массив имён пользовательских значений
Property CustomValuesCount (только для чтения) | Количество пользовательских значений
Property DrawCameraPosition | Отображается ли в плане положение камеры при открытом 3D-виде проекта
Property DrawGrid | Отображать ли сетку при отрисовке 3D-вида
Property DrawSky | Отображать ли небо при отрисовке 3D-вида
Property DrawTableland | Отображать ли плато при отрисовке 3D-вида
Property FogColor | Цвет тумана
Property FogEnabled | Используется ли туман при отрисовке сцены
Property FogEndDistance | Максимальная дистанция, на которой заканчивается туман и начинается мгла цвета FogColor. 0 - считать равной ZMax
Property FogStartDistance | Минимальная дистанция, на которой начинает действовать туман. 0 - считать равной ZMin
Property Smoothing | Сглаживать ли отображение поверхностей
Property TimeOfDay | Время суток (освещение). Значение от 0.0 до 1.0. 0=полночь, 0.5=полдень, 1=полночь
Property Turbidity | 'Мутность' атмосферы, которая влияет на цвет неба
Property ZMax | Максимальная координата (глубина) в Z-буфере
Property ZMin | Минимальная координата (глубина) в Z-буфере

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений
Method DeleteCustomValue | Удалить из настроек пользовательское значение
Method EndUpdate | Закончить серию изменений
Method GetCustomValue | Получить из настроек пользовательское значение
Method SetCustomValue | Запомнить в настройках пользовательское значение

Где используется

Класс | Член класса
Class Project | Property Options3D (свойство)

Смотри также

Group Трёхмерный вид


Options3D.BackgroundColor (свойство)

Цвет фона при отрисовке 3D-вида (если не отображается небо)

Синтаксис

[Visual Basic 6]
Property BackgroundColor As OLE_COLOR

[Delphi]
property BackgroundColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.CloudsEnabled (свойство)

Включить/выключить облака в 3д-виде

Синтаксис

[Visual Basic 6]
Property CloudsEnabled As Boolean

[Delphi]
property CloudsEnabled: WordBool

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.CurrentDate (свойство)

Дата (системная или заданная пользователем). Необходимо для астрономических расчётов

Синтаксис

[Visual Basic 6]
Property CurrentDate As Double

[Delphi]
property CurrentDate: Double

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.CustomValueName (свойство)

Массив имён пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValueName As String

[Delphi]
{только для чтения} property CustomValueName: WideString

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.CustomValuesCount (свойство)

Количество пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValuesCount As Long

[Delphi]
{только для чтения} property CustomValuesCount: Integer

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.DrawCameraPosition (свойство)

Отображается ли в плане положение камеры при открытом 3D-виде проекта

Синтаксис

[Visual Basic 6]
Property DrawCameraPosition As Boolean

[Delphi]
property DrawCameraPosition: WordBool

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.DrawGrid (свойство)

Отображать ли сетку при отрисовке 3D-вида

Синтаксис

[Visual Basic 6]
Property DrawGrid As Boolean

[Delphi]
property DrawGrid: WordBool

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.DrawSky (свойство)

Отображать ли небо при отрисовке 3D-вида

Синтаксис

[Visual Basic 6]
Property DrawSky As Boolean

[Delphi]
property DrawSky: WordBool

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.DrawTableland (свойство)

Отображать ли плато при отрисовке 3D-вида

Синтаксис

[Visual Basic 6]
Property DrawTableland As Boolean

[Delphi]
property DrawTableland: WordBool

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.FogColor (свойство)

Цвет тумана

Синтаксис

[Visual Basic 6]
Property FogColor As OLE_COLOR

[Delphi]
property FogColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.FogEnabled (свойство)

Используется ли туман при отрисовке сцены

Синтаксис

[Visual Basic 6]
Property FogEnabled As Boolean

[Delphi]
property FogEnabled: WordBool

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.FogEndDistance (свойство)

Максимальная дистанция, на которой заканчивается туман и начинается мгла цвета FogColor. 0 - считать равной ZMax

Синтаксис

[Visual Basic 6]
Property FogEndDistance As Double

[Delphi]
property FogEndDistance: Double

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.FogStartDistance (свойство)

Минимальная дистанция, на которой начинает действовать туман. 0 - считать равной ZMin

Синтаксис

[Visual Basic 6]
Property FogStartDistance As Double

[Delphi]
property FogStartDistance: Double

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.Smoothing (свойство)

Сглаживать ли отображение поверхностей

Синтаксис

[Visual Basic 6]
Property Smoothing As Boolean

[Delphi]
property Smoothing: WordBool

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.TimeOfDay (свойство)

Время суток (освещение). Значение от 0.0 до 1.0. 0=полночь, 0.5=полдень, 1=полночь

Синтаксис

[Visual Basic 6]
Property TimeOfDay As Double

[Delphi]
property TimeOfDay: Double

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.Turbidity (свойство)

'Мутность' атмосферы, которая влияет на цвет неба

Синтаксис

[Visual Basic 6]
Property Turbidity As Double

[Delphi]
property Turbidity: Double

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.ZMax (свойство)

Максимальная координата (глубина) в Z-буфере

Синтаксис

[Visual Basic 6]
Property ZMax As Double

[Delphi]
property ZMax: Double

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.ZMin (свойство)

Минимальная координата (глубина) в Z-буфере

Синтаксис

[Visual Basic 6]
Property ZMin As Double

[Delphi]
property ZMin: Double

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.BeginUpdate (метод)

Начать серию изменений

Синтаксис

[Visual Basic 6]
Sub BeginUpdate

[Delphi]
procedure BeginUpdate

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.DeleteCustomValue (метод)

Удалить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Function DeleteCustomValue ( _
   ByVal Name As String _
) As Boolean

[Delphi]
function DeleteCustomValue(
   const Name: WideString
): WordBool

Описание параметров

Name
[in] Имя значения, подлежащего удалению

Возвращаемое значение

True - значение удалено, False - не найдено значения с указанным именем

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.GetCustomValue (метод)

Получить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Sub GetCustomValue ( _
   ByVal Name As String, _
   ByVal DefaultValue As Variant _
)

[Delphi]
procedure GetCustomValue(
   const Name: WideString;
   const DefaultValue: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
DefaultValue
[in] Значение, которое будет возвращено, если в настройках не содержится ассоциациированного с указанным именем значения

Смотри также

Class Options3D, Group Трёхмерный вид


Options3D.SetCustomValue (метод)

Запомнить в настройках пользовательское значение

Синтаксис

[Visual Basic 6]
Sub SetCustomValue ( _
   ByVal Name As String, _
   ByVal Value As Variant _
)

[Delphi]
procedure SetCustomValue(
   const Name: WideString;
   const Value: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
Value
[in] Значение, ассоциируемое с указанным именем

Смотри также

Class Options3D, Group Трёхмерный вид


Класс PaintCanvas

Компонента, на которую осуществляется отрисовка

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrushColor | Цвет заливки
Property BrushStyle | Стиль заливки
Property DC | HDC устройства вывода
Property MaxZoom (только для чтения) | Максимальный (по X и по Y) текущий масштаб отображения на экране. Актуально только если пользователем выставлены разные масштабы по X и по Y
Property MinZoom (только для чтения) | Минимальный (по X и по Y) текущий масштаб отображения на экране. Актуально только если пользователем выставлены разные масштабы по X и по Y
Property PenColor | Цвет пера для отрисовки линейных объектов
Property PenStyle | Стиль отрисовки линейных объектов
Property PenWidth | Толщина пера в пикселях
Property PenWidthModel (только для записи) | Толщина пера в миллиметрах с учётом текущего масштаба проекта
Property PenXorMode | Признак режима, при котором отрисовка будет осуществляться таким образом, что двойная отрисовка объекта не произведёт измененй. По умолчанию False
Property Zoom (только для чтения) | Текущий масштаб отображения на экране (количество единиц в одном пикселе)
Property ZoomX (только для чтения) | Возвращает текущий масштаб отображения на экране по X-координате (количество единиц в одном пикселе)
Property ZoomY (только для чтения) | Возвращает текущий масштаб отображения на экране по Y-координате (количество единиц в одном пикселе)

Методы класса

Имя | Описание
Method Arc | Рисует дугу окружности с указанными параметрами
Method Circle | Рисует окружность с указанными параметрами
Method CircleFill | Рисует круг с указанными параметрами
Method DrawClothoidOffset | Рисует смещённую клотоиду
Method DrawExPoint | Рисует точечный Ex-символ
Method DrawPolygon | Рисует полигон
Method DrawPolyline | Рисует полилинию
Method FillRectInt | Рисует закрашенный прямоугольник с экранными координатами
Method GetUpdateRect | Получить прямоугольник, внутри которого необходимо перерисовать изображение
Method Line | Рисует линию от X1,Y1 в X2,Y2
Method LineTo | Проводит линию из текущей позиции в X,Y
Method ModelToScreen | Пересчитывает модельные координаты в экранные
Method ModelToScreenF | Пересчитывает модельные координаты в экранные
Method MoveTo | Переносит текущую позицию пера в точку X,Y
Method Rectangle | Рисует прямоугольник
Method RoundRect | Рисует прямоугольник со скруглёнными углами
Method ScreenToModel | Пересчитывает экранные координаты в модельные

Смотри также

Enum BrushStyleConstants, Enum PenStyleConstants, Group Рисование изображений


PaintCanvas.BrushColor (свойство)

Цвет заливки

Синтаксис

[Visual Basic 6]
Property BrushColor As OLE_COLOR

[Delphi]
property BrushColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.BrushStyle (свойство)

Стиль заливки

Синтаксис

[Visual Basic 6]
Property BrushStyle As BrushStyleConstants

[Delphi]
property BrushStyle: BrushStyleConstants

Смотри также

Enum BrushStyleConstants, Class PaintCanvas, Group Рисование изображений


PaintCanvas.DC (свойство)

HDC устройства вывода

Синтаксис

[Visual Basic 6]
Property DC As OLE_HANDLE

[Delphi]
property DC: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.MaxZoom (свойство)

Максимальный (по X и по Y) текущий масштаб отображения на экране. Актуально только если пользователем выставлены разные масштабы по X и по Y

Синтаксис

[Visual Basic 6]
ReadOnly Property MaxZoom As Double

[Delphi]
{только для чтения} property MaxZoom: Double

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.MinZoom (свойство)

Минимальный (по X и по Y) текущий масштаб отображения на экране. Актуально только если пользователем выставлены разные масштабы по X и по Y

Синтаксис

[Visual Basic 6]
ReadOnly Property MinZoom As Double

[Delphi]
{только для чтения} property MinZoom: Double

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.PenColor (свойство)

Цвет пера для отрисовки линейных объектов

Синтаксис

[Visual Basic 6]
Property PenColor As OLE_COLOR

[Delphi]
property PenColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.PenStyle (свойство)

Стиль отрисовки линейных объектов

Синтаксис

[Visual Basic 6]
Property PenStyle As PenStyleConstants

[Delphi]
property PenStyle: PenStyleConstants

Смотри также

Class PaintCanvas, Enum PenStyleConstants, Group Рисование изображений


PaintCanvas.PenWidth (свойство)

Толщина пера в пикселях

Синтаксис

[Visual Basic 6]
Property PenWidth As Long

[Delphi]
property PenWidth: Integer

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.PenWidthModel (свойство)

Толщина пера в миллиметрах с учётом текущего масштаба проекта

Синтаксис

[Visual Basic 6]
WriteOnly Property PenWidthModel As Double

[Delphi]
{только для записи} property PenWidthModel: Double

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.PenXorMode (свойство)

Признак режима, при котором отрисовка будет осуществляться таким образом, что двойная отрисовка объекта не произведёт измененй. По умолчанию False

Синтаксис

[Visual Basic 6]
Property PenXorMode As Boolean

[Delphi]
property PenXorMode: WordBool

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.Zoom (свойство)

Текущий масштаб отображения на экране (количество единиц в одном пикселе)

Синтаксис

[Visual Basic 6]
ReadOnly Property Zoom As Double

[Delphi]
{только для чтения} property Zoom: Double

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.ZoomX (свойство)

Возвращает текущий масштаб отображения на экране по X-координате (количество единиц в одном пикселе)

Синтаксис

[Visual Basic 6]
ReadOnly Property ZoomX As Double

[Delphi]
{только для чтения} property ZoomX: Double

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.ZoomY (свойство)

Возвращает текущий масштаб отображения на экране по Y-координате (количество единиц в одном пикселе)

Синтаксис

[Visual Basic 6]
ReadOnly Property ZoomY As Double

[Delphi]
{только для чтения} property ZoomY: Double

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.Arc (метод)

Рисует дугу окружности с указанными параметрами

Синтаксис

[Visual Basic 6]
Sub Arc ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Radius As Double, _
   ByVal Width As Double, _
   ByVal Color As OLE_COLOR, _
   ByVal StartAngle As Double, _
   ByVal EndAngle As Double, _
   ByVal Fill As Boolean _
)

[Delphi]
procedure Arc(
   const X: Double;
   const Y: Double;
   const Radius: Double;
   const Width: Double;
   const Color: OLE_COLOR;
   const StartAngle: Double;
   const EndAngle: Double;
   const Fill: WordBool
)

Описание параметров

X
[in] X-координата центра дуги окружности
Y
[in] Y-координата центра дуги окружности
Radius
[in] Радиус окружности в метрах
Width
[in] Толщина дуги окружности в метрах
Color
[in] Цвет дуги окружности
StartAngle
[in] Угол начала дуги окружности
EndAngle
[in] Угол конца дуги окружности
Fill
[in] Закрашивать ли сектор

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.Circle (метод)

Рисует окружность с указанными параметрами

Синтаксис

[Visual Basic 6]
Sub Circle ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Radius As Double, _
   ByVal Width As Double, _
   ByVal Color As OLE_COLOR _
)

[Delphi]
procedure Circle(
   const X: Double;
   const Y: Double;
   const Radius: Double;
   const Width: Double;
   const Color: OLE_COLOR
)

Описание параметров

X
[in] X-координата центра окружности
Y
[in] Y-координата центра окружности
Radius
[in] Радиус окружности в метрах
Width
[in] Толщина окружности в метрах
Color
[in] Цвет окружности

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.CircleFill (метод)

Рисует круг с указанными параметрами

Синтаксис

[Visual Basic 6]
Sub CircleFill ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Radius As Double, _
   ByVal Color As OLE_COLOR _
)

[Delphi]
procedure CircleFill(
   const X: Double;
   const Y: Double;
   const Radius: Double;
   const Color: OLE_COLOR
)

Описание параметров

X
[in] X-координата центра круга
Y
[in] Y-координата центра круга
Radius
[in] Кадиус круга в метрах
Color
[in] Цвет круга

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.DrawClothoidOffset (метод)

Рисует смещённую клотоиду

Синтаксис

[Visual Basic 6]
Sub DrawClothoidOffset ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal StartAngle As Double, _
   ByVal L As Double, _
   ByVal R As Double, _
   ByVal PixPerStep As Long, _
   ByVal Left As Boolean, _
   ByVal Delta As Double _
)

[Delphi]
procedure DrawClothoidOffset(
   const X: Double;
   const Y: Double;
   const StartAngle: Double;
   const L: Double;
   const R: Double;
   const PixPerStep: Integer;
   const Left: WordBool;
   const Delta: Double
)

Описание параметров

X
[in] X-координата начала клотоиды
Y
[in] Y-координата начала клотоиды
StartAngle
[in] Направление начала клотоиды
L
[in] Длина клотоиды
R
[in] Радиус конца клотоиды
PixPerStep
[in] Дискретизация отрисовки клотоиды. Чем меньше значение, тем медленнее (но качественнее) осуществляется отрисовка. Средние рекомендуемые значения 5..10
Left
[in] Клотоида поворачивает влево, False - клотоида поворачивает вправо
Delta
[in] Смещение клотоиды от истинного положения. Отрицательные значения - смещение влево, положительные - вправо

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.DrawExPoint (метод)

Рисует точечный Ex-символ

Синтаксис

[Visual Basic 6]
Sub DrawExPoint ( _
   ByVal Code As OLE_HANDLE, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Color As OLE_COLOR, _
   ByVal Angle As Double, _
   ByVal Scale As Double, _
   ByVal SelectedColor As OLE_COLOR _
)

[Delphi]
procedure DrawExPoint(
   const Code: OLE_HANDLE;
   const X: Double;
   const Y: Double;
   const Color: OLE_COLOR;
   const Angle: Double;
   const Scale: Double;
   const SelectedColor: OLE_COLOR
)

Описание параметров

Code
[in] Код Ex-символа, подлежащего отрисовке
X
[in] Модельная X-координата отрисовки символа
Y
[in] Модельная Y-координата отрисовки символа
Color
[in] Цвет отрисовки символа (может применяться не для всех символов)
Angle
[in] Угол поворота символа в радианах (обычно "0")
Scale
[in] Дополнительный масштаб отрисовки символа (обычно "1")
SelectedColor
[in] Цвет выделения при отрисовке символа (либо clNone, если выделение не нужно)

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.DrawPolygon (метод)

Рисует полигон

Синтаксис

[Visual Basic 6]
Sub DrawPolygon ( _
   ByVal Code As OLE_HANDLE, _
   ByVal Coordinates As OLE_HANDLE, _
   ByVal PointCount As Long, _
   ByVal BackgroundColor As OLE_COLOR, _
   ByVal Color As OLE_COLOR, _
   ByVal Scale As Double, _
   ByVal XShift As Double, _
   ByVal YShift As Double, _
   ByVal SelectedColor As OLE_COLOR _
)

[Delphi]
procedure DrawPolygon(
   const Code: OLE_HANDLE;
   const Coordinates: OLE_HANDLE;
   const PointCount: Integer;
   const BackgroundColor: OLE_COLOR;
   const Color: OLE_COLOR;
   const Scale: Double;
   const XShift: Double;
   const YShift: Double;
   const SelectedColor: OLE_COLOR
)

Описание параметров

Code
[in] Код Ex-символа, которым необходимо отрисовать полигон, либо 0, если требуется сплошная заливка
Coordinates
[in] Адрес первой точки в массиве модельных XY-координат полигона
PointCount
[in] Количество точек в массиве координат полигона
BackgroundColor
[in] Цвет фона в заливке (может применяться не для всех стилей)
Color
[in] Цвет элементов заливки (может применяться не для всех стилей). Игнорируется, если Code=0
Scale
[in] Дополнительный масштаб отрисовки символа (обычно "1"). Игнорируется, если Code=0
XShift
[in] Сдвиг заливки по координате X в десятых долях метра (обычно "0"). Игнорируется, если Code=0
YShift
[in] Сдвиг заливки по координате Y в десятых долях метра (обычно "0"). Игнорируется, если Code=0
SelectedColor
[in] Цвет выделения при отрисовке символа (либо clNone, если выделение не нужно)

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.DrawPolyline (метод)

Рисует полилинию

Синтаксис

[Visual Basic 6]
Sub DrawPolyline ( _
   ByVal Code As OLE_HANDLE, _
   ByVal Coordinates As OLE_HANDLE, _
   ByVal PointCount As Long, _
   ByVal IsPolygon As Boolean, _
   ByVal DrawEachSegment As Boolean, _
   ByVal Color As OLE_COLOR, _
   ByVal Scale As Double, _
   ByVal SelectedColor As OLE_COLOR _
)

[Delphi]
procedure DrawPolyline(
   const Code: OLE_HANDLE;
   const Coordinates: OLE_HANDLE;
   const PointCount: Integer;
   const IsPolygon: WordBool;
   const DrawEachSegment: WordBool;
   const Color: OLE_COLOR;
   const Scale: Double;
   const SelectedColor: OLE_COLOR
)

Описание параметров

Code
[in] Код Ex-символа, которым необходимо отрисовать линию, либо 0, если требуется отрисовать сплошную линию (Scale должен содержать толщину линии в миллиметрах)
Coordinates
[in] Адрес первой точки в массиве модельных XY-координат полилинии
PointCount
[in] Количество точек в массиве координат полилинии
IsPolygon
[in] Замыкать ли полилинию при отрисовке
DrawEachSegment
[in] Отрисовывать ли полилинию посегментно
Color
[in] Цвет отрисовки символа (может применяться не для всех стилей)
Scale
[in] Дополнительный масштаб отрисовки символа (обычно "1") или толщина линии в миллиметрах (если Code=0)
SelectedColor
[in] Цвет выделения при отрисовке символа (либо clNone, если выделение не нужно)

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.FillRectInt (метод)

Рисует закрашенный прямоугольник с экранными координатами

Синтаксис

[Visual Basic 6]
Sub FillRectInt ( _
   ByVal Xmin As Long, _
   ByVal Ymin As Long, _
   ByVal Xmax As Long, _
   ByVal Ymax As Long _
)

[Delphi]
procedure FillRectInt(
   const Xmin: Integer;
   const Ymin: Integer;
   const Xmax: Integer;
   const Ymax: Integer
)

Описание параметров

Xmin
[in] Минимальная X-координата отрисовываемого прямоугольника
Ymin
[in] Минимальная Y-координата отрисовываемого прямоугольника
Xmax
[in] Максимальная X-координата отрисовываемого прямоугольника
Ymax
[in] Максимальная Y-координата отрисовываемого прямоугольника

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.GetUpdateRect (метод)

Получить прямоугольник, внутри которого необходимо перерисовать изображение

Синтаксис

[Visual Basic 6]
Sub GetUpdateRect ( _
   Xmin As Double, _
   Ymin As Double, _
   Xmax As Double, _
   Ymax As Double _
)

[Delphi]
procedure GetUpdateRect(
   out Xmin: Double;
   out Ymin: Double;
   out Xmax: Double;
   out Ymax: Double
)

Описание параметров

Xmin
[out] Минимальная X-координата прямоугольника
Ymin
[out] Минимальная Y-координата прямоугольника
Xmax
[out] Максимальная X-координата прямоугольника
Ymax
[out] Максимальная Y-координата прямоугольника

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.Line (метод)

Рисует линию от X1,Y1 в X2,Y2

Синтаксис

[Visual Basic 6]
Sub Line ( _
   ByVal X1 As Double, _
   ByVal Y1 As Double, _
   ByVal X2 As Double, _
   ByVal Y2 As Double _
)

[Delphi]
procedure Line(
   const X1: Double;
   const Y1: Double;
   const X2: Double;
   const Y2: Double
)

Описание параметров

X1
[in] X-координата начала отрезка
Y1
[in] Y-координата начала отрезка
X2
[in] X-координата конца отрезка
Y2
[in] Y-координата конца отрезка

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.LineTo (метод)

Проводит линию из текущей позиции в X,Y

Синтаксис

[Visual Basic 6]
Sub LineTo ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure LineTo(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] X-координата конца линии
Y
[in] Y-координата конца линии

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.ModelToScreen (метод)

Пересчитывает модельные координаты в экранные

Синтаксис

[Visual Basic 6]
Sub ModelToScreen ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ScreenX As Long, _
   ScreenY As Long _
)

[Delphi]
procedure ModelToScreen(
   const X: Double;
   const Y: Double;
   out ScreenX: Integer;
   out ScreenY: Integer
)

Описание параметров

X
[in] Модельная X-координата
Y
[in] Модельная Y-координата
ScreenX
[out] Экранная X-координата
ScreenY
[out] Экранная Y-координата

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.ModelToScreenF (метод)

Пересчитывает модельные координаты в экранные

Синтаксис

[Visual Basic 6]
Sub ModelToScreenF ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ScreenX As Double, _
   ScreenY As Double _
)

[Delphi]
procedure ModelToScreenF(
   const X: Double;
   const Y: Double;
   out ScreenX: Double;
   out ScreenY: Double
)

Описание параметров

X
[in] Модельная X-координата
Y
[in] Модельная Y-координата
ScreenX
[out] Экранная X-координата
ScreenY
[out] Экранная Y-координата

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.MoveTo (метод)

Переносит текущую позицию пера в точку X,Y

Синтаксис

[Visual Basic 6]
Sub MoveTo ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure MoveTo(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] X-координата точки
Y
[in] Y-координата точки

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.Rectangle (метод)

Рисует прямоугольник

Синтаксис

[Visual Basic 6]
Sub Rectangle ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double, _
   ByVal Fill As Boolean _
)

[Delphi]
procedure Rectangle(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double;
   const Fill: WordBool
)

Описание параметров

Xmin
[in] Минимальная X-координата отрисовываемого прямоугольника
Ymin
[in] Минимальная Y-координата отрисовываемого прямоугольника
Xmax
[in] Максимальная X-координата отрисовываемого прямоугольника
Ymax
[in] Максимальная Y-координата отрисовываемого прямоугольника
Fill
[in] True - закрасить прямоугольник, False - отрисовать только контур

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.RoundRect (метод)

Рисует прямоугольник со скруглёнными углами

Синтаксис

[Visual Basic 6]
Sub RoundRect ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double, _
   ByVal Radius As Double _
)

[Delphi]
procedure RoundRect(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double;
   const Radius: Double
)

Описание параметров

Xmin
[in] Минимальная X-координата отрисовываемого прямоугольника
Ymin
[in] Минимальная Y-координата отрисовываемого прямоугольника
Xmax
[in] Максимальная X-координата отрисовываемого прямоугольника
Ymax
[in] Максимальная Y-координата отрисовываемого прямоугольника
Radius
[in] Радиус скругления углов прямоугольника

Смотри также

Class PaintCanvas, Group Рисование изображений


PaintCanvas.ScreenToModel (метод)

Пересчитывает экранные координаты в модельные

Синтаксис

[Visual Basic 6]
Sub ScreenToModel ( _
   ByVal X As Long, _
   ByVal Y As Long, _
   ModelX As Double, _
   ModelY As Double _
)

[Delphi]
procedure ScreenToModel(
   const X: Integer;
   const Y: Integer;
   out ModelX: Double;
   out ModelY: Double
)

Описание параметров

X
[in] Экранная X-координата
Y
[in] Экранная Y-координата
ModelX
[out] Модельная X-координата
ModelY
[out] Модельная Y-координата

Смотри также

Class PaintCanvas, Group Рисование изображений


Класс Plugin

Дополнительный модуль к системе

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Copyright (только для чтения) | Авторское право на дополнительный модуль
Property Description (только для чтения) | Описание дополнительного модуля
Property Enabled | Разрешен ли дополнительный модуль (следует ли его загружать)
Property Error (только для чтения) | Признак того, что модуль не может быть загружен (например, неверный формат модуля)
Property FileName (только для чтения) | Имя файла дополнительного модуля
Property ImageIndex (только для чтения) | Код иконки дополнительного модуля, если = -1, то берется по умолчанию
Property Instance (только для чтения) | Экземпляр dll с дополнительным модулем
Property InternalName (только для чтения) | Имя внутреннего модуля
Property Kind (только для чтения) | Тип модуля
Property Licensed (только для чтения) | Имеется ли лицензия на использование модуля (если не лицензирован, то его нельзя загружать)
Property LicenseId (только для чтения) | Уникальный идентификатор модуля (используется при определении того, разрешен ли модуль)
Property Name (только для чтения) | Имя дополнительного модуля

Методы класса

Имя | Описание
Method HasHelp | Возможно ли выдать помощь по дополнительному модулю
Method ShowAbout | Выдать окно "О модуле"
Method ShowHelp | Выдать помощь по дополнительному модулю

Где используется

Класс | Член класса
Class PluginManager | Property Plugins (свойство) Method PluginByFileName (метод) Method PluginByInternalName (метод) Method PluginByName (метод) Method RegisterFilePlugin (метод) Method RegisterInternalPlugin (метод)

Смотри также

Enum PluginKindConstants, Group Приложение


Plugin.Copyright (свойство)

Авторское право на дополнительный модуль

Синтаксис

[Visual Basic 6]
ReadOnly Property Copyright As String

[Delphi]
{только для чтения} property Copyright: WideString

Смотри также

Class Plugin, Group Приложение


Plugin.Description (свойство)

Описание дополнительного модуля

Синтаксис

[Visual Basic 6]
ReadOnly Property Description As String

[Delphi]
{только для чтения} property Description: WideString

Смотри также

Class Plugin, Group Приложение


Plugin.Enabled (свойство)

Разрешен ли дополнительный модуль (следует ли его загружать)

Синтаксис

[Visual Basic 6]
Property Enabled As Boolean

[Delphi]
property Enabled: WordBool

Смотри также

Class Plugin, Group Приложение


Plugin.Error (свойство)

Признак того, что модуль не может быть загружен (например, неверный формат модуля)

Синтаксис

[Visual Basic 6]
ReadOnly Property Error As Boolean

[Delphi]
{только для чтения} property Error: WordBool

Смотри также

Class Plugin, Group Приложение


Plugin.FileName (свойство)

Имя файла дополнительного модуля

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class Plugin, Group Приложение


Plugin.ImageIndex (свойство)

Код иконки дополнительного модуля, если = -1, то берется по умолчанию

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class Plugin, Group Приложение


Plugin.Instance (свойство)

Экземпляр dll с дополнительным модулем

Синтаксис

[Visual Basic 6]
ReadOnly Property Instance As OLE_HANDLE

[Delphi]
{только для чтения} property Instance: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Plugin, Group Приложение


Plugin.InternalName (свойство)

Имя внутреннего модуля

Синтаксис

[Visual Basic 6]
ReadOnly Property InternalName As String

[Delphi]
{только для чтения} property InternalName: WideString

Смотри также

Class Plugin, Group Приложение


Plugin.Kind (свойство)

Тип модуля

Синтаксис

[Visual Basic 6]
ReadOnly Property Kind As PluginKindConstants

[Delphi]
{только для чтения} property Kind: PluginKindConstants

Смотри также

Class Plugin, Enum PluginKindConstants, Group Приложение


Plugin.Licensed (свойство)

Имеется ли лицензия на использование модуля (если не лицензирован, то его нельзя загружать)

Синтаксис

[Visual Basic 6]
ReadOnly Property Licensed As Boolean

[Delphi]
{только для чтения} property Licensed: WordBool

Смотри также

Class Plugin, Group Приложение


Plugin.LicenseId (свойство)

Уникальный идентификатор модуля (используется при определении того, разрешен ли модуль)

Синтаксис

[Visual Basic 6]
ReadOnly Property LicenseId As String

[Delphi]
{только для чтения} property LicenseId: WideString

Смотри также

Class Plugin, Group Приложение


Plugin.Name (свойство)

Имя дополнительного модуля

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class Plugin, Group Приложение


Plugin.HasHelp (метод)

Возможно ли выдать помощь по дополнительному модулю

Синтаксис

[Visual Basic 6]
Function HasHelp As Boolean

[Delphi]
function HasHelp: WordBool

Возвращаемое значение

Возвращает True, если помощь по дополнительному модулю выдать можно

Смотри также

Class Plugin, Group Приложение


Plugin.ShowAbout (метод)

Выдать окно "О модуле"

Синтаксис

[Visual Basic 6]
Sub ShowAbout

[Delphi]
procedure ShowAbout

Смотри также

Class Plugin, Group Приложение


Plugin.ShowHelp (метод)

Выдать помощь по дополнительному модулю

Синтаксис

[Visual Basic 6]
Sub ShowHelp

[Delphi]
procedure ShowHelp

Смотри также

Class Plugin, Group Приложение


Класс PluginManager

Менеджер дополнительных модулей к системе

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ForbiddenPluginCount (только для чтения) | Количество имен дополнительных модулей, которые не должны запускаться и не должны быть видны в менеджере модулей
Property ForbiddenPlugins (только для чтения) | Массив имен дополнительных модулей, которые не должны запускаться и не должны быть видны в менеджере модулей
Property PluginCount (только для чтения) | Количество доступных дополнительных модулей к системе
Property PluginExtension (только для чтения) | Расширение файлов дополнительных модулей ('plg', 'plc' или 'pld')
Property Plugins (только для чтения) | Массив доступных дополнительных модулей к системе

Методы класса

Имя | Описание
Method ForbidPlugin | Запретить модуль с указанным именем (этот модуль не будет запускаться и не будет виден в менеджере модулей)
Method PluginByFileName | Найти дополнительный модуль по имени файла
Method PluginByInternalName | Найти дополнительный модуль по кодовому внутреннему имени
Method PluginByName | Найти дополнительный модуль по имени
Method RegisterFilePlugin | Зарегистрировать новый дополнительный модуль к системе с указанием имени файла с модулем
Method RegisterInternalPlugin | Зарегистрировать новый дополнительный модуль к системе с указанием имени файла с модулем

Где используется

Класс | Член класса
Class Application | Property Plugins (свойство)
Class ICommonApplication | Property Plugins (свойство)

Смотри также

Interface IPluginEvents, Class Plugin, Group Приложение


PluginManager.ForbiddenPluginCount (свойство)

Количество имен дополнительных модулей, которые не должны запускаться и не должны быть видны в менеджере модулей

Синтаксис

[Visual Basic 6]
ReadOnly Property ForbiddenPluginCount As Long

[Delphi]
{только для чтения} property ForbiddenPluginCount: Integer

Смотри также

Class PluginManager, Group Приложение


PluginManager.ForbiddenPlugins (свойство)

Массив имен дополнительных модулей, которые не должны запускаться и не должны быть видны в менеджере модулей

Синтаксис

[Visual Basic 6]
ReadOnly Property ForbiddenPlugins As String

[Delphi]
{только для чтения} property ForbiddenPlugins: WideString

Смотри также

Class PluginManager, Group Приложение


PluginManager.PluginCount (свойство)

Количество доступных дополнительных модулей к системе

Синтаксис

[Visual Basic 6]
ReadOnly Property PluginCount As Long

[Delphi]
{только для чтения} property PluginCount: Integer

Смотри также

Class PluginManager, Group Приложение


PluginManager.PluginExtension (свойство)

Расширение файлов дополнительных модулей ('plg', 'plc' или 'pld')

Синтаксис

[Visual Basic 6]
ReadOnly Property PluginExtension As String

[Delphi]
{только для чтения} property PluginExtension: WideString

Смотри также

Class PluginManager, Group Приложение


PluginManager.Plugins (свойство)

Массив доступных дополнительных модулей к системе

Синтаксис

[Visual Basic 6]
ReadOnly Property Plugins As Plugin

[Delphi]
{только для чтения} property Plugins: Plugin

Смотри также

Class Plugin, Class PluginManager, Group Приложение


PluginManager.ForbidPlugin (метод)

Запретить модуль с указанным именем (этот модуль не будет запускаться и не будет виден в менеджере модулей)

Синтаксис

[Visual Basic 6]
Sub ForbidPlugin ( _
   ByVal PluginName As String _
)

[Delphi]
procedure ForbidPlugin(
   const PluginName: WideString
)

Описание параметров

PluginName
[in] Имя запрещаемого дополнительного модуля

Смотри также

Class PluginManager, Group Приложение


PluginManager.PluginByFileName (метод)

Найти дополнительный модуль по имени файла

Синтаксис

[Visual Basic 6]
Function PluginByFileName ( _
   ByVal FileName As String _
) As Plugin

[Delphi]
function PluginByFileName(
   const FileName: WideString
): Plugin

Описание параметров

FileName
[in] Имя файла разыскиваемого дополнительного модуля

Возвращаемое значение

Возвращает найденный дополнительный модуль или Nothing, если таковой не найден

Смотри также

Class Plugin, Class PluginManager, Group Приложение


PluginManager.PluginByInternalName (метод)

Найти дополнительный модуль по кодовому внутреннему имени

Синтаксис

[Visual Basic 6]
Function PluginByInternalName ( _
   ByVal InternalName As String _
) As Plugin

[Delphi]
function PluginByInternalName(
   const InternalName: WideString
): Plugin

Описание параметров

InternalName
[in] Кодовое внутреннее имя разыскиваемого внутреннего дополнительного модуля

Возвращаемое значение

Возвращает найденный дополнительный модуль или Nothing, если таковой не найден

Смотри также

Class Plugin, Class PluginManager, Group Приложение


PluginManager.PluginByName (метод)

Найти дополнительный модуль по имени

Синтаксис

[Visual Basic 6]
Function PluginByName ( _
   ByVal Name As String _
) As Plugin

[Delphi]
function PluginByName(
   const Name: WideString
): Plugin

Описание параметров

Name
[in] Имя разыскиваемого дополнительного модуля

Возвращаемое значение

Возвращает найденный дополнительный модуль или Nothing, если таковой не найден

Смотри также

Class Plugin, Class PluginManager, Group Приложение


PluginManager.RegisterFilePlugin (метод)

Зарегистрировать новый дополнительный модуль к системе с указанием имени файла с модулем

Синтаксис

[Visual Basic 6]
Function RegisterFilePlugin ( _
   ByVal FileName As String _
) As Plugin

[Delphi]
function RegisterFilePlugin(
   const FileName: WideString
): Plugin

Описание параметров

FileName
[in] Имя файла с дополнительным модулем

Возвращаемое значение

Возвращает новый объект, отвечающий за взаимодействие с дополнительным модулем

Смотри также

Class Plugin, Class PluginManager, Group Приложение


PluginManager.RegisterInternalPlugin (метод)

Зарегистрировать новый дополнительный модуль к системе с указанием имени файла с модулем

Синтаксис

[Visual Basic 6]
Function RegisterInternalPlugin ( _
   ByVal InternalName As String, _
   ByVal PluginEvents As IPluginEvents _
) As Plugin

[Delphi]
function RegisterInternalPlugin(
   const InternalName: WideString;
   const PluginEvents: IPluginEvents
): Plugin

Описание параметров

InternalName
[in] Кодовое имя дополнительного модуля. Используется для запоминания в реестре текущего статуса загруженности модуля между сессиями
PluginEvents
[in] Обработчик событий дополнительного модуля

Возвращаемое значение

Возвращает новый объект, отвечающий за взаимодействие с дополнительным модулем

Смотри также

Interface IPluginEvents, Class Plugin, Class PluginManager, Group Приложение


Класс Project

Проект IndorCAD

Наследование

BaseObject Class Aggregate Class Project

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Container (только для чтения) | Контейнер изображения плана
Property CreationDate (только для чтения) | Дата и время создания проекта
Property DeltaModelPixels (только для чтения) | Значение в метрах, которое следует использовать при поиске ближайших объектов
Property DrawingSheets (только для чтения) | Листы чертежа плана
Property FileName | Имя файла проекта
Property Grid (только для чтения) | Сетка, покрывающая весь проект с шагом 10 см
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Возвращает подэлемент по его сингатуре (ветвь дерева)
Property Layers (только для чтения) | Список слоёв в проекте
Property Modified (только для чтения) | Изменялся ли проект с момента последнего сохранения
Property Options (только для чтения) | Настройки проекта
Property Options3D (только для чтения) | Настройки отображения 3D-вида проекта
Property Project (только для чтения) | Проект, к которому относится объект
Property ProjectCODE (только для чтения) | Шифр проекта
Property ProjectDescription | Описане проекта
Property ProjectGIP (только для чтения) | Главный инженер проекта
Property Routes (только для чтения) | Список трасс в проекте
Property StringNameCollection (только для чтения) | Набор имён линий
Property SurfaceDifferences (только для чтения) | Объект "Разности поверхностей"
Property UndoManager (только для чтения) | Менеджер откатов
Property ViewScale (только для чтения) | Количество пикселей в одном метре для окне плана

Методы класса

Имя | Описание
Method Advise | Подключиться к событиям проекта (возвращаемое число нужно впоследствии передать в Unadvise)
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Changed | Информирует объект о том, что произошли изменения. SetModifiedFlag=True - объекту выставляется признак "Модифицирована". NeedRepaint=True - необходимо перерисовать план. OptionsChanged=True - изменились невизуальные свойства объекта
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetBounds | Возвращает объемлющий проект прямоугольник в модельных координатах
Method InvalidCrossectionsData | Вызывается подобъектами, если их данные, которые могут отображаться в сечениях, изменились
Method IsCursorUnderPlan | Находится ли курсор мыши над планом проекта
Method MakeTreeStructure | Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта
Method Save | Сохранить проект
Method ScrollToMakeVisible | Обеспечивает видимость в плане места с указанными координатами
Method SelectsAddCircle | Добавить в выделения окружность с указанными параметрами
Method SelectsAddLine | Добавить в выделения отрезок с указанными координатами
Method SelectsAddPoint | Добавить в выделения точку с указанными параметрами
Method SelectsRemove | Удалить выделения с указанным именем
Method SetCursor | Устанавить в плане проекта указанный курсор
Method SetStatusText | Устанавить в строке статуса указанный текст
Method TrackRectangle | Начать выделение прямоугольником
Method TreeStructureChanged | Информирует объект о том, что необходимо перерисовать либо перестроить дерево структуры проекта
Method Unadvise | Отключиться от событий проекта (передаваемое число ранее должно быть получено от Advise)
Method VisualPointSearch | Обеспечивает видимость указанных координат в плане. Вызывает "сходящуюся" окружность в указанную точку для наглядности

События класса

Имя | Описание
Method ImportFinished | Вызывается после выполнения любого импорта для текущего проекта
Method LayerDeleteQuery | Вызывается как запрос на возможность удаления слоя Layer
Method LayerDeleting | Вызывается непосредственно перед удалением слоя Layer
Method LayerSurfaceInvalidated | Вызывается при удалении триангуляции вследствие её неактуальности
Method ProjectCreated | Вызывается непосредственно после создания нового проекта
Method ProjectDestroying | Вызывается непосредственно перед уничтожением проекта
Method ProjectLoaded | Вызывается непосредственно после загрузки проекта
Method ProjectModified | Вызывается при любом изменении проекта
Method ProjectOptionsChanged | Вызывается при изменении настроек проекта
Method ProjectSaved | Вызывается непосредственно после сохранения проекта
Method ProjectSaving | Вызывается непосредственно перед сохранением проекта
Method StringNamesChanged | Вызывается при изменении в наборе имён структурных линий

Где используется

Класс | Член класса
Class Aggregate | Property Project (свойство)
Class Application | Property ActiveProject (свойство) Property Projects (свойство) Method NewProject (метод) Method OpenProject (метод) Event ProjectActivated (событие) Event ProjectCreate (событие)
Class BaseObject | Property Project (свойство)
Class BaseObjectList | Property Project (свойство)
Class DrawingSheet | Property Project (свойство)
Class DrawingSheets | Property Project (свойство)
Class Grid | Property Project (свойство)
Class IApplicationEvents | Method ProjectActivated (метод) Method ProjectCreate (метод)
Class ICADDataCreator | Method CreateInstance (метод)
Class IProjectEvents | Method ImportFinished (метод) Method ProjectCreated (метод) Method ProjectDestroying (метод) Method ProjectLoaded (метод) Method ProjectModified (метод) Method ProjectOptionsChanged (метод) Method ProjectSaved (метод) Method ProjectSaving (метод) Method StringNamesChanged (метод)
Class Layer | Property Project (свойство)
Class LayerPoint | Property Project (свойство)
Class LayerPoints | Property Project (свойство)
Class Layers | Property Project (свойство)
Class Line | Property Project (свойство)
Class LineGroup | Property Project (свойство)
Class Lines | Property Project (свойство)
Class Project | Property Project (свойство) Event ImportFinished (событие) Event ProjectCreated (событие) Event ProjectDestroying (событие) Event ProjectLoaded (событие) Event ProjectModified (событие) Event ProjectOptionsChanged (событие) Event ProjectSaved (событие) Event ProjectSaving (событие) Event StringNamesChanged (событие)
Class Route | Property Project (свойство)
Class RouteElement | Property Project (свойство)
Class Routes | Property Project (свойство)
Class RouteVertex | Property Project (свойство)
Class StringName | Property Project (свойство)
Class StringNameCollection | Property Project (свойство)
Class StringNameGroup | Property Project (свойство)
Class SurfaceDifference | Property Project (свойство)
Class SurfaceDifferences | Property Project (свойство)
Class SurfacePainter | Property Project (свойство)
Class SurfacePainters | Property Project (свойство)

Смотри также

Enum CursorConstants, Class CustomContainer, Interface ICADObject, Interface IDocTreeHandler, Class Options3D, Class ProjectOptions, Enum SelectsConstants, Enum StatusPanelConstants, Class UndoManager, Group Проекты


Project.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class Project, Group Проекты


Project.Container (свойство)

Контейнер изображения плана

Синтаксис

[Visual Basic 6]
ReadOnly Property Container As CustomContainer

[Delphi]
{только для чтения} property Container: CustomContainer

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class CustomContainer, Class Project, Group Проекты


Project.CreationDate (свойство)

Дата и время создания проекта

Синтаксис

[Visual Basic 6]
ReadOnly Property CreationDate As Date

[Delphi]
{только для чтения} property CreationDate: TDateTime

Смотри также

Class Project, Group Проекты


Project.DeltaModelPixels (свойство)

Значение в метрах, которое следует использовать при поиске ближайших объектов

Синтаксис

[Visual Basic 6]
ReadOnly Property DeltaModelPixels As Double

[Delphi]
{только для чтения} property DeltaModelPixels: Double

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class Project, Group Проекты


Project.DrawingSheets (свойство)

Листы чертежа плана

Синтаксис

[Visual Basic 6]
ReadOnly Property DrawingSheets As DrawingSheets

[Delphi]
{только для чтения} property DrawingSheets: DrawingSheets

Смотри также

Class DrawingSheets, Class Project, Group Проекты


Project.FileName (свойство)

Имя файла проекта

Синтаксис

[Visual Basic 6]
Property FileName As String

[Delphi]
property FileName: WideString

Смотри также

Class Project, Group Проекты


Project.Grid (свойство)

Сетка, покрывающая весь проект с шагом 10 см

Синтаксис

[Visual Basic 6]
ReadOnly Property Grid As Grid

[Delphi]
{только для чтения} property Grid: Grid

Смотри также

Class Grid, Class Project, Group Проекты


Project.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Project, Group Проекты


Project.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Project, Group Проекты


Project.Items (свойство)

Возвращает подэлемент по его сингатуре (ветвь дерева)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As ICADObject

[Delphi]
{только для чтения} property Items: ICADObject

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface ICADObject, Class Project, Group Проекты


Project.Layers (свойство)

Список слоёв в проекте

Синтаксис

[Visual Basic 6]
ReadOnly Property Layers As Layers

[Delphi]
{только для чтения} property Layers: Layers

Смотри также

Class Layers, Class Project, Group Проекты


Project.Modified (свойство)

Изменялся ли проект с момента последнего сохранения

Синтаксис

[Visual Basic 6]
ReadOnly Property Modified As Boolean

[Delphi]
{только для чтения} property Modified: WordBool

Смотри также

Class Project, Group Проекты


Project.Options (свойство)

Настройки проекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Options As ProjectOptions

[Delphi]
{только для чтения} property Options: ProjectOptions

Смотри также

Class Project, Class ProjectOptions, Group Проекты


Project.Options3D (свойство)

Настройки отображения 3D-вида проекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Options3D As Options3D

[Delphi]
{только для чтения} property Options3D: Options3D

Смотри также

Class Options3D, Class Project, Group Проекты


Project.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Group Проекты


Project.ProjectCODE (свойство)

Шифр проекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ProjectCODE As String

[Delphi]
{только для чтения} property ProjectCODE: WideString

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Group Проекты


Project.ProjectDescription (свойство)

Описане проекта

Синтаксис

[Visual Basic 6]
Property ProjectDescription As String

[Delphi]
property ProjectDescription: WideString

Смотри также

Class Project, Group Проекты


Project.ProjectGIP (свойство)

Главный инженер проекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ProjectGIP As String

[Delphi]
{только для чтения} property ProjectGIP: WideString

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Group Проекты


Project.Routes (свойство)

Список трасс в проекте

Синтаксис

[Visual Basic 6]
ReadOnly Property Routes As Routes

[Delphi]
{только для чтения} property Routes: Routes

Смотри также

Class Project, Class Routes, Group Проекты


Project.StringNameCollection (свойство)

Набор имён линий

Синтаксис

[Visual Basic 6]
ReadOnly Property StringNameCollection As StringNameCollection

[Delphi]
{только для чтения} property StringNameCollection: StringNameCollection

Смотри также

Class Project, Class StringNameCollection, Group Проекты


Project.SurfaceDifferences (свойство)

Объект "Разности поверхностей"

Синтаксис

[Visual Basic 6]
ReadOnly Property SurfaceDifferences As SurfaceDifferences

[Delphi]
{только для чтения} property SurfaceDifferences: SurfaceDifferences

Смотри также

Class Project, Class SurfaceDifferences, Group Проекты


Project.UndoManager (свойство)

Менеджер откатов

Синтаксис

[Visual Basic 6]
ReadOnly Property UndoManager As UndoManager

[Delphi]
{только для чтения} property UndoManager: UndoManager

Смотри также

Class Project, Class UndoManager, Group Проекты


Project.ViewScale (свойство)

Количество пикселей в одном метре для окне плана

Синтаксис

[Visual Basic 6]
ReadOnly Property ViewScale As Double

[Delphi]
{только для чтения} property ViewScale: Double

Смотри также

Class Project, Group Проекты


Project.Advise (метод)

Подключиться к событиям проекта (возвращаемое число нужно впоследствии передать в Unadvise)

Синтаксис

[Visual Basic 6]
Function Advise ( _
   ByVal EventHandler As IProjectEvents _
) As Long

[Delphi]
function Advise(
   const EventHandler: IProjectEvents
): Integer

Описание параметров

EventHandler
[in] Обработчик событий проекта

Возвращаемое значение

Возвращает код соединения, который нужно впоследствии передать в метод Unadvise

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


Project.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Project, Group Проекты


Project.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Project, Group Проекты


Project.Changed (метод)

Информирует объект о том, что произошли изменения. SetModifiedFlag=True - объекту выставляется признак "Модифицирована". NeedRepaint=True - необходимо перерисовать план. OptionsChanged=True - изменились невизуальные свойства объекта

Синтаксис

[Visual Basic 6]
Sub Changed ( _
   ByVal SetModifiedFlag As Boolean, _
   ByVal NeedRepaint As Boolean, _
   ByVal OptionsChanged As Boolean _
)

[Delphi]
procedure Changed(
   const SetModifiedFlag: WordBool;
   const NeedRepaint: WordBool;
   const OptionsChanged: WordBool
)

Описание параметров

SetModifiedFlag
[in] True - необходимо установить у объекта признак "модифицирован"
NeedRepaint
[in] True - необходимо перерисовать план
OptionsChanged
[in] True - изменились невизуальные свойства объекта

Смотри также

Class Project, Group Проекты


Project.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Project, Group Проекты


Project.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Project, Group Проекты


Project.GetBounds (метод)

Возвращает объемлющий проект прямоугольник в модельных координатах

Синтаксис

[Visual Basic 6]
Function GetBounds ( _
   Xmin As Double, _
   Ymin As Double, _
   Xmax As Double, _
   Ymax As Double _
) As Boolean

[Delphi]
function GetBounds(
   out Xmin: Double;
   out Ymin: Double;
   out Xmax: Double;
   out Ymax: Double
): WordBool

Описание параметров

Xmin
[out] Возвращаемая минимальная X-координата объемлющего прямоугольника
Ymin
[out] Возвращаемая минимальная Y-координата объемлющего прямоугольника
Xmax
[out] Возвращаемая максимальная X-координата объемлющего прямоугольника
Ymax
[out] Возвращаемая максимальная Y-координата объемлющего прямоугольника

Возвращаемое значение

Результат операции: True - переменные содержат актуальные значения границ проекта, False - ошибка

Смотри также

Class Project, Group Проекты


Project.InvalidCrossectionsData (метод)

Вызывается подобъектами, если их данные, которые могут отображаться в сечениях, изменились

Синтаксис

[Visual Basic 6]
Sub InvalidCrossectionsData ( _
   ByVal StructureChanged As Boolean _
)

[Delphi]
procedure InvalidCrossectionsData(
   const StructureChanged: WordBool
)

Описание параметров

StructureChanged
[in] True - необходимо только перерисовать сечения, False - изменилась структура данных и необходимо перестроить список профильных объектов

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Group Проекты


Project.IsCursorUnderPlan (метод)

Находится ли курсор мыши над планом проекта

Синтаксис

[Visual Basic 6]
Function IsCursorUnderPlan As Boolean

[Delphi]
function IsCursorUnderPlan: WordBool

Возвращаемое значение

True - курсор мыши находится над окном плана, False - в противном случае

Смотри также

Class Project, Group Проекты


Project.MakeTreeStructure (метод)

Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта

Синтаксис

[Visual Basic 6]
Sub MakeTreeStructure ( _
   ByVal Handler As IDocTreeHandler, _
   ByVal ParentID As Long, _
   ByVal Reason As Long, _
   ByVal IncludeHidden As Boolean _
)

[Delphi]
procedure MakeTreeStructure(
   const Handler: IDocTreeHandler;
   const ParentID: Integer;
   const Reason: Integer;
   const IncludeHidden: WordBool
)

Описание параметров

Handler
[in] Объект, которому будут поочерёдно передаваться все объекты, содержащиеся в проекте
ParentID
[in] Некий идентификатор родительского узла (обычно "0")
Reason
[in] Значение, которое будет передаваться в Handler при добавлении объектов. По нему Handler, принимающий перечисляемые объекты, может определить, что с ними делать
IncludeHidden
[in] Некоторые объекты могут не перечислять себя, если они не содержат подобъектов. Если IncludeHidden установлен в True, то объект должен перечислить себя в любом случае

Смотри также

Interface IDocTreeHandler, Class Project, Group Проекты


Project.Save (метод)

Сохранить проект

Синтаксис

[Visual Basic 6]
Sub Save

[Delphi]
procedure Save

Смотри также

Class Project, Group Проекты


Project.ScrollToMakeVisible (метод)

Обеспечивает видимость в плане места с указанными координатами

Синтаксис

[Visual Basic 6]
Function ScrollToMakeVisible ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Boolean

[Delphi]
function ScrollToMakeVisible(
   const X: Double;
   const Y: Double
): WordBool

Описание параметров

X
[in] Модельная X-координата места в плане, видимость которого необходимо обеспечить
Y
[in] Модельная Y-координата места в плане, видимость которого необходимо обеспечить

Возвращаемое значение

True - указанная область уже была видна (ничего не сделано), False - указанная область стала видимой

Смотри также

Class Project, Group Проекты


Project.SelectsAddCircle (метод)

Добавить в выделения окружность с указанными параметрами

Синтаксис

[Visual Basic 6]
Sub SelectsAddCircle ( _
   ByVal Name As String, _
   ByVal Selects As SelectsConstants, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   ByVal Radius As Double, _
   ByVal StartAngle As Double, _
   ByVal EndAngle As Double _
)

[Delphi]
procedure SelectsAddCircle(
   const Name: WideString;
   const Selects: SelectsConstants;
   const ModelX: Double;
   const ModelY: Double;
   const Radius: Double;
   const StartAngle: Double;
   const EndAngle: Double
)

Описание параметров

Name
[in] Имя выделения. Несколько выделений могут иметь одинаковое имя. Необходимо задавать значения, которые не будут использоваться другими модулями
Selects
[in] Тип выделения
ModelX
[in] Модельная X-координата центра окружности
ModelY
[in] Модельная Y-координата центра окружности
Radius
[in] Радиус окружности
StartAngle
[in] Угол начала дуги окружности
EndAngle
[in] Угол конца дуги окружности

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Enum SelectsConstants, Group Проекты


Project.SelectsAddLine (метод)

Добавить в выделения отрезок с указанными координатами

Синтаксис

[Visual Basic 6]
Sub SelectsAddLine ( _
   ByVal Name As String, _
   ByVal Selects As SelectsConstants, _
   ByVal X1 As Double, _
   ByVal Y1 As Double, _
   ByVal X2 As Double, _
   ByVal Y2 As Double _
)

[Delphi]
procedure SelectsAddLine(
   const Name: WideString;
   const Selects: SelectsConstants;
   const X1: Double;
   const Y1: Double;
   const X2: Double;
   const Y2: Double
)

Описание параметров

Name
[in] Имя выделения. Несколько выделений могут иметь одинаковое имя. Необходимо задавать значения, которые не будут использоваться другими модулями
Selects
[in] Тип выделения
X1
[in] Модельная X-координата начала отрезка
Y1
[in] Модельная Y-координата начала отрезка
X2
[in] Модельная X-координата конца отрезка
Y2
[in] Модельная Y-координата конца отрезка

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Enum SelectsConstants, Group Проекты


Project.SelectsAddPoint (метод)

Добавить в выделения точку с указанными параметрами

Синтаксис

[Visual Basic 6]
Sub SelectsAddPoint ( _
   ByVal Name As String, _
   ByVal Selects As SelectsConstants, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure SelectsAddPoint(
   const Name: WideString;
   const Selects: SelectsConstants;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Name
[in] Имя выделения. Несколько выделений могут иметь одинаковое имя. Необходимо задавать значения, которые не будут использоваться другими модулями
Selects
[in] Тип выделения
ModelX
[in] Модельная X-координата точки
ModelY
[in] Модельная Y-координата точки

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Enum SelectsConstants, Group Проекты


Project.SelectsRemove (метод)

Удалить выделения с указанным именем

Синтаксис

[Visual Basic 6]
Sub SelectsRemove ( _
   ByVal Name As String _
)

[Delphi]
procedure SelectsRemove(
   const Name: WideString
)

Описание параметров

Name
[in] Имя удаляемых выделений. Если несколько выделений имеют указанное имя, все они будут удалены

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Group Проекты


Project.SetCursor (метод)

Устанавить в плане проекта указанный курсор

Синтаксис

[Visual Basic 6]
Sub SetCursor ( _
   ByVal Cursor As CursorConstants _
)

[Delphi]
procedure SetCursor(
   const Cursor: CursorConstants
)

Описание параметров

Cursor
[in] Константа, идентифицирующая устанавливаемый курсор

Смотри также

Enum CursorConstants, Class Project, Group Проекты


Project.SetStatusText (метод)

Устанавить в строке статуса указанный текст

Синтаксис

[Visual Basic 6]
Sub SetStatusText ( _
   ByVal Text As String, _
   ByVal StatusPanel As StatusPanelConstants _
)

[Delphi]
procedure SetStatusText(
   const Text: WideString;
   const StatusPanel: StatusPanelConstants
)

Описание параметров

Text
[in] Текст, который необходимо отобразить в строке статуса
StatusPanel
[in] Индекс панели в строке статуса, на которую бодет отображён указанный текст

Смотри также

Class Project, Enum StatusPanelConstants, Group Проекты


Project.TrackRectangle (метод)

Начать выделение прямоугольником

Синтаксис

[Visual Basic 6]
Function TrackRectangle ( _
   Xmin As Double, _
   Ymin As Double, _
   Xmax As Double, _
   Ymax As Double, _
   IsRectangle As Boolean _
) As Boolean

[Delphi]
function TrackRectangle(
   out Xmin: Double;
   out Ymin: Double;
   out Xmax: Double;
   out Ymax: Double;
   out IsRectangle: WordBool
): WordBool

Описание параметров

Xmin
[out] Минимальная модельная X-координата выделенной области
Ymin
[out] Минимальная модельная Y-координата выделенной области
Xmax
[out] Максимальная модельная X-координата выделенной области
Ymax
[out] Максимальная модельная Y-координата выделенной области
IsRectangle
[out] True - был выделен прямоугольник, False - был выполнен щелчок мышью (вызвращён прямоугольник нулевой ширины и высоты)

Возвращаемое значение

Результат операции: True - переменный заполнены информацией о выделенном прямоугольнике, False - действие было отменено пользователем

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Group Проекты


Project.TreeStructureChanged (метод)

Информирует объект о том, что необходимо перерисовать либо перестроить дерево структуры проекта

Синтаксис

[Visual Basic 6]
Sub TreeStructureChanged ( _
   ByVal Rescan As Boolean _
)

[Delphi]
procedure TreeStructureChanged(
   const Rescan: WordBool
)

Описание параметров

Rescan
[in] True - дерево полностью будет перестроено, False - только перерисовано

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Project, Group Проекты


Project.Unadvise (метод)

Отключиться от событий проекта (передаваемое число ранее должно быть получено от Advise)

Синтаксис

[Visual Basic 6]
Sub Unadvise ( _
   ByVal Cookie As Long _
)

[Delphi]
procedure Unadvise(
   const Cookie: Integer
)

Описание параметров

Cookie
[in] Код, возвращённый методом Advise)

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class Project, Group Проекты


Project.VisualPointSearch (метод)

Обеспечивает видимость указанных координат в плане. Вызывает "сходящуюся" окружность в указанную точку для наглядности

Синтаксис

[Visual Basic 6]
Sub VisualPointSearch ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure VisualPointSearch(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Модельная X-координата искомой точки
Y
[in] Модельная Y-координата искомой точки

Смотри также

Class Project, Group Проекты


Project.ImportFinished (метод)

Вызывается после выполнения любого импорта для текущего проекта

Синтаксис

[Visual Basic 6]
Event ImportFinished ( _
   ByVal Project As Project _
)

[Delphi]
procedure ImportFinished(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого был произведён импорт каких-либо данных

Смотри также

Class Project, Group Проекты


Project.LayerDeleteQuery (метод)

Вызывается как запрос на возможность удаления слоя Layer

Синтаксис

[Visual Basic 6]
Event LayerDeleteQuery ( _
   ByVal Layer As Layer, _
   CanDelete As Boolean _
)

[Delphi]
procedure LayerDeleteQuery(
   const Layer: Layer;
   out CanDelete: WordBool
)

Описание параметров

Layer
[in] Слой, который предполагается удалить
CanDelete
[out] Если CanDelete присвоить False, то слой не будет удалён

Смотри также

Class Layer, Class Project, Group Проекты


Project.LayerDeleting (метод)

Вызывается непосредственно перед удалением слоя Layer

Синтаксис

[Visual Basic 6]
Event LayerDeleting ( _
   ByVal Layer As Layer _
)

[Delphi]
procedure LayerDeleting(
   const Layer: Layer
)

Описание параметров

Layer
[in] Слой, который будет удалён

Смотри также

Class Layer, Class Project, Group Проекты


Project.LayerSurfaceInvalidated (метод)

Вызывается при удалении триангуляции вследствие её неактуальности

Синтаксис

[Visual Basic 6]
Event LayerSurfaceInvalidated ( _
   ByVal Layer As Layer _
)

[Delphi]
procedure LayerSurfaceInvalidated(
   const Layer: Layer
)

Описание параметров

Layer
[in] Слой, поверхность которого объявлена неактуальной

Смотри также

Class Layer, Class Project, Group Проекты


Project.ProjectCreated (метод)

Вызывается непосредственно после создания нового проекта

Синтаксис

[Visual Basic 6]
Event ProjectCreated ( _
   ByVal Project As Project, _
   ByVal CreatedAsNew As Boolean _
)

[Delphi]
procedure ProjectCreated(
   const Project: Project;
   const CreatedAsNew: WordBool
)

Описание параметров

Project
[in] Проект, для которого вызвано событие
CreatedAsNew
[in] True - проект создан как новый. False - проект будет загружаться из файла

Смотри также

Class Project, Group Проекты


Project.ProjectDestroying (метод)

Вызывается непосредственно перед уничтожением проекта

Синтаксис

[Visual Basic 6]
Event ProjectDestroying ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectDestroying(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого вызвано событие

Смотри также

Class Project, Group Проекты


Project.ProjectLoaded (метод)

Вызывается непосредственно после загрузки проекта

Синтаксис

[Visual Basic 6]
Event ProjectLoaded ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectLoaded(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого вызвано событие

Смотри также

Class Project, Group Проекты


Project.ProjectModified (метод)

Вызывается при любом изменении проекта

Синтаксис

[Visual Basic 6]
Event ProjectModified ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectModified(
   const Project: Project
)

Описание параметров

Project
[in] Проект, в котором произошли изменения

Смотри также

Class Project, Group Проекты


Project.ProjectOptionsChanged (метод)

Вызывается при изменении настроек проекта

Синтаксис

[Visual Basic 6]
Event ProjectOptionsChanged ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectOptionsChanged(
   const Project: Project
)

Описание параметров

Project
[in] Проект, настройки которого были изменены

Смотри также

Class Project, Group Проекты


Project.ProjectSaved (метод)

Вызывается непосредственно после сохранения проекта

Синтаксис

[Visual Basic 6]
Event ProjectSaved ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectSaved(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого вызвано событие

Смотри также

Class Project, Group Проекты


Project.ProjectSaving (метод)

Вызывается непосредственно перед сохранением проекта

Синтаксис

[Visual Basic 6]
Event ProjectSaving ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectSaving(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого вызвано событие

Смотри также

Class Project, Group Проекты


Project.StringNamesChanged (метод)

Вызывается при изменении в наборе имён структурных линий

Синтаксис

[Visual Basic 6]
Event StringNamesChanged ( _
   ByVal Project As Project _
)

[Delphi]
procedure StringNamesChanged(
   const Project: Project
)

Описание параметров

Project
[in] Проект, в котором измененился набор имён структурных линий

Смотри также

Class Project, Group Проекты


Класс ProjectOptions

Настройки проекта

Наследование

CustomOptions Class ProjectOptions

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BackgroundColor | Цвет фона проекта
Property CustomValueName (только для чтения) | Массив имён пользовательских значений
Property CustomValuesCount (только для чтения) | Количество пользовательских значений
Property DistancePrecision | Точность представления расстояний, задаваемая в виде числа знаков после запятой
Property FullSaving | Сохранять проект полностью (включая те объекты, которые могут быть вычислены автоматически)
Property InclinePrecision | Точность представления уклонов, задаваемая в виде числа знаков после запятой
Property LightAzimuth | Азимут "источника освещения" проекта в градусах. Значение "0" соответствует северу
Property LightVerticalAngle | Высота "источника освещения" проекта над горизонтом в градусах. Значение "90" соответствует зениту
Property LocalPlanetableLeft (только для чтения) | Положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (X-координата)
Property LocalPlanetableLeftInternal | (Возможно отключенное) положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (X-координата)
Property LocalPlanetableTop (только для чтения) | Положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (Y-координата)
Property LocalPlanetableTopInternal | (Возможно отключенное) положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (Y-координата)
Property NorthPointerAngle | Отклонение стрелки указателя на север от севера (в радианах)
Property NorthPointerIndex | Индекс стрелки указателя на север. "0" означает отсутствие указателя
Property OverrideDefaultPlanetableSettings | Перекрывать ли настройки планшетов по умолчанию (Application)
Property PicketsPrecision | Точность представления пикетов, задаваемая в виде числа знаков после запятой
Property Scale | Задает масштаб выполняемого проекта в формате 1:XXX (значение 500 соответствует масштабу 1:500)
Property StatePlanetableLeft (только для чтения) | Положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат (Y-координата)
Property StatePlanetableLeftInternal | (Возможно отключенное) положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат (Y-координата)
Property StatePlanetableTop (только для чтения) | Положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат (X-координата)
Property StatePlanetableTopInternal | (Возможно отключенное) положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат (X-координата)
Property ZPrecision | Точность представления Z-отметок, задаваемая в виде числа знаков после запятой

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений
Method DeleteCustomValue | Удалить из настроек пользовательское значение
Method EndUpdate | Закончить серию изменений
Method GetCustomValue | Получить из настроек пользовательское значение
Method SetCustomValue | Запомнить в настройках пользовательское значение

Где используется

Класс | Член класса
Class Project | Property Options (свойство)

Смотри также

Group Проекты


ProjectOptions.BackgroundColor (свойство)

Цвет фона проекта

Синтаксис

[Visual Basic 6]
Property BackgroundColor As OLE_COLOR

[Delphi]
property BackgroundColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.CustomValueName (свойство)

Массив имён пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValueName As String

[Delphi]
{только для чтения} property CustomValueName: WideString

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.CustomValuesCount (свойство)

Количество пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValuesCount As Long

[Delphi]
{только для чтения} property CustomValuesCount: Integer

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.DistancePrecision (свойство)

Точность представления расстояний, задаваемая в виде числа знаков после запятой

Синтаксис

[Visual Basic 6]
Property DistancePrecision As Long

[Delphi]
property DistancePrecision: Integer

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.FullSaving (свойство)

Сохранять проект полностью (включая те объекты, которые могут быть вычислены автоматически)

Синтаксис

[Visual Basic 6]
Property FullSaving As Boolean

[Delphi]
property FullSaving: WordBool

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.InclinePrecision (свойство)

Точность представления уклонов, задаваемая в виде числа знаков после запятой

Синтаксис

[Visual Basic 6]
Property InclinePrecision As Long

[Delphi]
property InclinePrecision: Integer

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.LightAzimuth (свойство)

Азимут "источника освещения" проекта в градусах. Значение "0" соответствует северу

Синтаксис

[Visual Basic 6]
Property LightAzimuth As Double

[Delphi]
property LightAzimuth: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.LightVerticalAngle (свойство)

Высота "источника освещения" проекта над горизонтом в градусах. Значение "90" соответствует зениту

Синтаксис

[Visual Basic 6]
Property LightVerticalAngle As Double

[Delphi]
property LightVerticalAngle: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.LocalPlanetableLeft (свойство)

Положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (X-координата)

Синтаксис

[Visual Basic 6]
ReadOnly Property LocalPlanetableLeft As Double

[Delphi]
{только для чтения} property LocalPlanetableLeft: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.LocalPlanetableLeftInternal (свойство)

(Возможно отключенное) положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (X-координата)

Синтаксис

[Visual Basic 6]
Property LocalPlanetableLeftInternal As Double

[Delphi]
property LocalPlanetableLeftInternal: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.LocalPlanetableTop (свойство)

Положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (Y-координата)

Синтаксис

[Visual Basic 6]
ReadOnly Property LocalPlanetableTop As Double

[Delphi]
{только для чтения} property LocalPlanetableTop: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.LocalPlanetableTopInternal (свойство)

(Возможно отключенное) положение планшета A-1 масштаба 1:2000 городской номенклатуры в местной системе координат (Y-координата)

Синтаксис

[Visual Basic 6]
Property LocalPlanetableTopInternal As Double

[Delphi]
property LocalPlanetableTopInternal: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.NorthPointerAngle (свойство)

Отклонение стрелки указателя на север от севера (в радианах)

Синтаксис

[Visual Basic 6]
Property NorthPointerAngle As Double

[Delphi]
property NorthPointerAngle: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.NorthPointerIndex (свойство)

Индекс стрелки указателя на север. "0" означает отсутствие указателя

Синтаксис

[Visual Basic 6]
Property NorthPointerIndex As Long

[Delphi]
property NorthPointerIndex: Integer

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.OverrideDefaultPlanetableSettings (свойство)

Перекрывать ли настройки планшетов по умолчанию (Application)

Синтаксис

[Visual Basic 6]
Property OverrideDefaultPlanetableSettings As Boolean

[Delphi]
property OverrideDefaultPlanetableSettings: WordBool

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.PicketsPrecision (свойство)

Точность представления пикетов, задаваемая в виде числа знаков после запятой

Синтаксис

[Visual Basic 6]
Property PicketsPrecision As Long

[Delphi]
property PicketsPrecision: Integer

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.Scale (свойство)

Задает масштаб выполняемого проекта в формате 1:XXX (значение 500 соответствует масштабу 1:500)

Синтаксис

[Visual Basic 6]
Property Scale As Long

[Delphi]
property Scale: Integer

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.StatePlanetableLeft (свойство)

Положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат (Y-координата)

Синтаксис

[Visual Basic 6]
ReadOnly Property StatePlanetableLeft As Double

[Delphi]
{только для чтения} property StatePlanetableLeft: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.StatePlanetableLeftInternal (свойство)

(Возможно отключенное) положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат (Y-координата)

Синтаксис

[Visual Basic 6]
Property StatePlanetableLeftInternal As Double

[Delphi]
property StatePlanetableLeftInternal: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.StatePlanetableTop (свойство)

Положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат (X-координата)

Синтаксис

[Visual Basic 6]
ReadOnly Property StatePlanetableTop As Double

[Delphi]
{только для чтения} property StatePlanetableTop: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.StatePlanetableTopInternal (свойство)

(Возможно отключенное) положение планшета 1 масштаба 1:5000 государственной номенклатуры в местной системе координат (X-координата)

Синтаксис

[Visual Basic 6]
Property StatePlanetableTopInternal As Double

[Delphi]
property StatePlanetableTopInternal: Double

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.ZPrecision (свойство)

Точность представления Z-отметок, задаваемая в виде числа знаков после запятой

Синтаксис

[Visual Basic 6]
Property ZPrecision As Long

[Delphi]
property ZPrecision: Integer

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.BeginUpdate (метод)

Начать серию изменений

Синтаксис

[Visual Basic 6]
Sub BeginUpdate

[Delphi]
procedure BeginUpdate

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.DeleteCustomValue (метод)

Удалить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Function DeleteCustomValue ( _
   ByVal Name As String _
) As Boolean

[Delphi]
function DeleteCustomValue(
   const Name: WideString
): WordBool

Описание параметров

Name
[in] Имя значения, подлежащего удалению

Возвращаемое значение

True - значение удалено, False - не найдено значения с указанным именем

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.GetCustomValue (метод)

Получить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Sub GetCustomValue ( _
   ByVal Name As String, _
   ByVal DefaultValue As Variant _
)

[Delphi]
procedure GetCustomValue(
   const Name: WideString;
   const DefaultValue: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
DefaultValue
[in] Значение, которое будет возвращено, если в настройках не содержится ассоциациированного с указанным именем значения

Смотри также

Class ProjectOptions, Group Проекты


ProjectOptions.SetCustomValue (метод)

Запомнить в настройках пользовательское значение

Синтаксис

[Visual Basic 6]
Sub SetCustomValue ( _
   ByVal Name As String, _
   ByVal Value As Variant _
)

[Delphi]
procedure SetCustomValue(
   const Name: WideString;
   const Value: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
Value
[in] Значение, ассоциируемое с указанным именем

Смотри также

Class ProjectOptions, Group Проекты


Класс Projection

Картографическая проекция

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property CanFlatToModel (только для чтения) | Определено ли преобразование FlatToMap
Property Description (только для чтения) | Полное описание проекции
Property HasPreview (только для чтения) | Определена ли процедура отрисовки картинки предварительного просмотра
Property ImageIndex (только для чтения) | Индекс картинки
Property MainScale (только для чтения) | Получить главный масштабный коэффициент по отношению к исходным единицам измерения
Property MapUnit (только для чтения) | Получить исходные единицы карты (если muUnknown, то может быть любым)
Property Name (только для чтения) | Название проекции
Property OriginX | Смещение начала координат по X
Property OriginY | Смещение начала координат по Y
Property ProjectionClass (только для чтения) | Класс проекции
Property ProjectionProps (только для чтения) | Класс проекции
Property ProjectionType (только для чтения) | Тип проекции

Методы класса

Имя | Описание
Method GetDirectionAt | Получить изменение направления в заданной точке
Method GetFlatUnit | Получить результирующие единицы карты (если muUnknown, то может быть любым)
Method GetHorzScaleAt | Получить горизонтальный масштаб в заданной точке
Method GetScaleAt | Получить масштаб в заданной точке
Method GetVertScaleAt | Получить вертикальный масштаб в заданной точке
Method PointProject | Преобразовать точку из координат модели в плоские координаты
Method PointUnproject | Преобразовать точку из плоских координат в координаты карты

Где используется

Класс | Член класса
Class AssemblyLayerState | Property Projection (свойство)
Class CompositionLayer | Property Projection (свойство) Property ValidProjection (свойство)
Class FolderLayer | Property Projection (свойство) Property ValidProjection (свойство)
Class LayeredComposition | Property Projection (свойство)
Class VectorLayer | Property Projection (свойство) Property ValidProjection (свойство)

Смотри также

Class ModelPoint, Enum ModelUnitConstants, Group Карты


Projection.CanFlatToModel (свойство)

Определено ли преобразование FlatToMap

Синтаксис

[Visual Basic 6]
ReadOnly Property CanFlatToModel As Boolean

[Delphi]
{только для чтения} property CanFlatToModel: WordBool

Смотри также

Class Projection, Group Карты


Projection.Description (свойство)

Полное описание проекции

Синтаксис

[Visual Basic 6]
ReadOnly Property Description As String

[Delphi]
{только для чтения} property Description: WideString

Смотри также

Class Projection, Group Карты


Projection.HasPreview (свойство)

Определена ли процедура отрисовки картинки предварительного просмотра

Синтаксис

[Visual Basic 6]
ReadOnly Property HasPreview As Boolean

[Delphi]
{только для чтения} property HasPreview: WordBool

Смотри также

Class Projection, Group Карты


Projection.ImageIndex (свойство)

Индекс картинки

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageIndex As Long

[Delphi]
{только для чтения} property ImageIndex: Integer

Смотри также

Class Projection, Group Карты


Projection.MainScale (свойство)

Получить главный масштабный коэффициент по отношению к исходным единицам измерения

Синтаксис

[Visual Basic 6]
ReadOnly Property MainScale As Double

[Delphi]
{только для чтения} property MainScale: Double

Смотри также

Class Projection, Group Карты


Projection.MapUnit (свойство)

Получить исходные единицы карты (если muUnknown, то может быть любым)

Синтаксис

[Visual Basic 6]
ReadOnly Property MapUnit As ModelUnitConstants

[Delphi]
{только для чтения} property MapUnit: ModelUnitConstants

Смотри также

Enum ModelUnitConstants, Class Projection, Group Карты


Projection.Name (свойство)

Название проекции

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class Projection, Group Карты


Projection.OriginX (свойство)

Смещение начала координат по X

Синтаксис

[Visual Basic 6]
Property OriginX As Double

[Delphi]
property OriginX: Double

Смотри также

Class Projection, Group Карты


Projection.OriginY (свойство)

Смещение начала координат по Y

Синтаксис

[Visual Basic 6]
Property OriginY As Double

[Delphi]
property OriginY: Double

Смотри также

Class Projection, Group Карты


Projection.ProjectionClass (свойство)

Класс проекции

Синтаксис

[Visual Basic 6]
ReadOnly Property ProjectionClass As String

[Delphi]
{только для чтения} property ProjectionClass: WideString

Смотри также

Class Projection, Group Карты


Projection.ProjectionProps (свойство)

Класс проекции

Синтаксис

[Visual Basic 6]
ReadOnly Property ProjectionProps As String

[Delphi]
{только для чтения} property ProjectionProps: WideString

Смотри также

Class Projection, Group Карты


Projection.ProjectionType (свойство)

Тип проекции

Синтаксис

[Visual Basic 6]
ReadOnly Property ProjectionType As String

[Delphi]
{только для чтения} property ProjectionType: WideString

Смотри также

Class Projection, Group Карты


Projection.GetDirectionAt (метод)

Получить изменение направления в заданной точке

Синтаксис

[Visual Basic 6]
Function GetDirectionAt ( _
   ByVal ModelPoint As ModelPoint _
) As Double

[Delphi]
function GetDirectionAt(
   const ModelPoint: ModelPoint
): Double

Описание параметров

ModelPoint
[in] Точка на карте в модельной системе координат

Возвращаемое значение

Возвращает угол в радианах изменения направления системы кординат в заданной модельной точке карты

Смотри также

Class ModelPoint, Class Projection, Group Карты


Projection.GetFlatUnit (метод)

Получить результирующие единицы карты (если muUnknown, то может быть любым)

Синтаксис

[Visual Basic 6]
Function GetFlatUnit ( _
   ByVal MapUnit As ModelUnitConstants _
) As ModelUnitConstants

[Delphi]
function GetFlatUnit(
   const MapUnit: ModelUnitConstants
): ModelUnitConstants

Описание параметров

MapUnit
[in] Единица измерения на карте

Возвращаемое значение

Результирующие единицы измерения

Смотри также

Enum ModelUnitConstants, Class Projection, Group Карты


Projection.GetHorzScaleAt (метод)

Получить горизонтальный масштаб в заданной точке

Синтаксис

[Visual Basic 6]
Function GetHorzScaleAt ( _
   ByVal MapPoint As ModelPoint _
) As Double

[Delphi]
function GetHorzScaleAt(
   const MapPoint: ModelPoint
): Double

Описание параметров

MapPoint
[in] Точка на карте в модельной системе координат

Возвращаемое значение

Возвращает горизонтальный масштаб проекции в заданной точке карты

Смотри также

Class ModelPoint, Class Projection, Group Карты


Projection.GetScaleAt (метод)

Получить масштаб в заданной точке

Синтаксис

[Visual Basic 6]
Function GetScaleAt ( _
   ByVal ModelPoint As ModelPoint _
) As Double

[Delphi]
function GetScaleAt(
   const ModelPoint: ModelPoint
): Double

Описание параметров

ModelPoint
[in] Точка на карте в модельной системе координат

Возвращаемое значение

Возвращает масштаб проекции в заданной точке карты

Смотри также

Class ModelPoint, Class Projection, Group Карты


Projection.GetVertScaleAt (метод)

Получить вертикальный масштаб в заданной точке

Синтаксис

[Visual Basic 6]
Function GetVertScaleAt ( _
   ByVal MapPoint As ModelPoint _
) As Double

[Delphi]
function GetVertScaleAt(
   const MapPoint: ModelPoint
): Double

Описание параметров

MapPoint
[in] Точка на карте в модельной системе координат

Возвращаемое значение

Возвращает вертикальный масштаб проекции в заданной точке карты

Смотри также

Class ModelPoint, Class Projection, Group Карты


Projection.PointProject (метод)

Преобразовать точку из координат модели в плоские координаты

Синтаксис

[Visual Basic 6]
Function PointProject ( _
   ByVal ModelPoint As ModelPoint _
) As ModelPoint

[Delphi]
function PointProject(
   const ModelPoint: ModelPoint
): ModelPoint

Описание параметров

ModelPoint
[in] Исходная точка в системе координат модели

Возвращаемое значение

Вычисленная точка в плоской системе координат контейнера

Смотри также

Class ModelPoint, Class Projection, Group Карты


Projection.PointUnproject (метод)

Преобразовать точку из плоских координат в координаты карты

Синтаксис

[Visual Basic 6]
Function PointUnproject ( _
   ByVal FlatPoint As ModelPoint _
) As ModelPoint

[Delphi]
function PointUnproject(
   const FlatPoint: ModelPoint
): ModelPoint

Описание параметров

FlatPoint
[in] Исходная точка в плоской системе координат контейнера

Возвращаемое значение

Вычисленная точка в системе координат модели

Смотри также

Class ModelPoint, Class Projection, Group Карты


Класс PropertyStream

Объект для записи и чтения данных из потока

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Count (только для чтения) | Получить количество элементов в текущем каталоге

Методы класса

Имя | Описание
Method Clear | Очищает полностью хранилище данных
Method Close | Закрыть текущий каталог
Method CreateDir | Создать каталог
Method GetItemInfo | Получить информацию об элементе
Method GetItemSize | Получить размер элемента каталога в байтах
Method OpenDir | Открыть каталог
Method OpenRoot | Перейти в корневой каталог
Method ReadBinary | Прочитать фрагмент памяти
Method ReadBoolean | Прочитать значение типа boolean
Method ReadDate | Прочитать значение типа TDateTime
Method ReadDouble | Прочитать значение типа double
Method ReadGUID | Прочитать значение типа GUID
Method ReadIdXY | Прочитать плоские (X,Y) координаты с целочисленным идентификатором
Method ReadIdXYZ | Прочитать трёхменрые (X,Y,Z) координаты с целочисленным идентификатором
Method ReadIdXYZM | Прочитать четырёхмерные (X,Y,Z,M) координаты с целочисленным идентификатором
Method ReadInteger | Прочитать значение типа integer
Method ReadString | Прочитать строковое значение
Method ReadXY | Прочитать плоские (X,Y) координаты
Method ReadXYint | Записать плоские (X,Y) целочисленные координаты
Method ReadXYZ | Прочитать трёхменрые (X,Y,Z) координаты
Method ReadXYZM | Прочитать четырёхмерные (X,Y,Z,M) координаты
Method WriteBinary | Записать фрагмент памяти
Method WriteBoolean | Записать значение типа boolean
Method WriteDate | Записать значение типа TDateTime
Method WriteDouble | Записать значение типа double
Method WriteDoubleDirect | Записать значение типа double
Method WriteGUID | Записать значение типа GUID
Method WriteIdXY | Записать плоские (X,Y) координаты с целочисленным идентификатором
Method WriteIdXYZ | Записать трёхменрые (X,Y,Z) координаты с целочисленным идентификатором
Method WriteIdXYZM | Записать четырёхмерные (X,Y,Z,M) координаты с целочисленным идентификатором
Method WriteInteger | Записать значение типа integer
Method WriteString | Записать строковое значение
Method WriteXY | Записать плоские (X,Y) координаты
Method WriteXYint | Записать плоские (X,Y) целочисленные координаты
Method WriteXYZ | Записать трёхменрые (X,Y,Z) координаты
Method WriteXYZM | Записать четырёхмерные (X,Y,Z,M) координаты

Где используется

Класс | Член класса
Class IPropertyStreamed | Method LoadFrom (метод) Method SaveTo (метод)

Смотри также

Enum PropertyStreamConstants


PropertyStream.Count (свойство)

Получить количество элементов в текущем каталоге

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class PropertyStream


PropertyStream.Clear (метод)

Очищает полностью хранилище данных

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class PropertyStream


PropertyStream.Close (метод)

Закрыть текущий каталог

Синтаксис

[Visual Basic 6]
Function Close As Boolean

[Delphi]
function Close: WordBool

Возвращаемое значение

True - текущий каталог закрыт, False - не удалось закрыть текущий каталог, потому что текущий каталог является корневым

Смотри также

Class PropertyStream


PropertyStream.CreateDir (метод)

Создать каталог

Синтаксис

[Visual Basic 6]
Sub CreateDir ( _
   ByVal Name As String _
)

[Delphi]
procedure CreateDir(
   const Name: WideString
)

Описание параметров

Name
[in] Имя создаваемого каталога. Должно быть уникальным в текущем каталоге

Замечания

Если данная функция выполнилась успешно, то созданный каталог становится текущим. Не забывайте закрывать созданный каталог методом Close

Смотри также

Class PropertyStream


PropertyStream.GetItemInfo (метод)

Получить информацию об элементе

Синтаксис

[Visual Basic 6]
Function GetItemInfo ( _
   ByVal Index As Long, _
   DataType As PropertyStreamConstants, _
   Name As String _
) As Boolean

[Delphi]
function GetItemInfo(
   const Index: Integer;
   out DataType: PropertyStreamConstants;
   out Name: WideString
): WordBool

Описание параметров

Index
[in] Номер элемента каталога, о котором запрашивается информация (нумерация идёт от 0 до Count-1)
DataType
[out] Тип значения
Name
[out] Имя значения

Возвращаемое значение

True - информация возвращена успешно, False - произошла ошибка, возможно запрошенный номер больше или равен количеству элементов в текущем каталоге

Смотри также

Class PropertyStream, Enum PropertyStreamConstants


PropertyStream.GetItemSize (метод)

Получить размер элемента каталога в байтах

Синтаксис

[Visual Basic 6]
Function GetItemSize ( _
   ByVal Name As String _
) As Long

[Delphi]
function GetItemSize(
   const Name: WideString
): Integer

Описание параметров

Name
[in] Имя значения, размер которого необходимо получить

Возвращаемое значение

Размер запрошенног элемента в байтах, либо 0, если элемента не существует

Смотри также

Class PropertyStream


PropertyStream.OpenDir (метод)

Открыть каталог

Синтаксис

[Visual Basic 6]
Function OpenDir ( _
   ByVal Name As String _
) As Boolean

[Delphi]
function OpenDir(
   const Name: WideString
): WordBool

Описание параметров

Name
[in] Имя открываемого каталога

Возвращаемое значение

True - каталог успешно открыт и стал текущим, False - не удалось открыть каталог, возможно он не существует

Замечания

Если данная функция выполнилась успешно, то открытый каталог становится текущим. Не забывайте закрывать открытый каталог методом Close

Смотри также

Class PropertyStream


PropertyStream.OpenRoot (метод)

Перейти в корневой каталог

Синтаксис

[Visual Basic 6]
Sub OpenRoot

[Delphi]
procedure OpenRoot

Смотри также

Class PropertyStream


PropertyStream.ReadBinary (метод)

Прочитать фрагмент памяти

Синтаксис

[Visual Basic 6]
Function ReadBinary ( _
   ByVal Name As String, _
   ByVal Buffer As OLE_HANDLE, _
   ByVal Size As Long _
) As Boolean

[Delphi]
function ReadBinary(
   const Name: WideString;
   const Buffer: OLE_HANDLE;
   const Size: Integer
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
Buffer
[in] Адрес первого байта буфера, который необходимо прочитать
Size
[in] Размер буфера в байтах

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если не найдено запрошенное имя, либо размер указанного буфера меньше требуемого

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PropertyStream


PropertyStream.ReadBoolean (метод)

Прочитать значение типа boolean

Синтаксис

[Visual Basic 6]
Function ReadBoolean ( _
   ByVal Name As String, _
   ByVal DefaultValue As Boolean _
) As Boolean

[Delphi]
function ReadBoolean(
   const Name: WideString;
   const DefaultValue: WordBool
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
DefaultValue
[in] Значение, возвращаемое в случае отсутствия в текущем каталоге указанного имени

Возвращаемое значение

Возвращает прочитанное значение, либо DefaultValue, если в текущем каталоге отсутствует значение с указанным именем

Смотри также

Class PropertyStream


PropertyStream.ReadDate (метод)

Прочитать значение типа TDateTime

Синтаксис

[Visual Basic 6]
Function ReadDate ( _
   ByVal Name As String, _
   ByVal Default As Date _
) As Date

[Delphi]
function ReadDate(
   const Name: WideString;
   const Default: TDateTime
): TDateTime

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
Default
[in] Значение, возвращаемое в случае отсутствия в текущем каталоге указанного имени

Возвращаемое значение

Возвращает прочитанное значение, либо DefaultValue, если в текущем каталоге отсутствует значение с указанным именем

Смотри также

Class PropertyStream


PropertyStream.ReadDouble (метод)

Прочитать значение типа double

Синтаксис

[Visual Basic 6]
Function ReadDouble ( _
   ByVal Name As String, _
   ByVal Default As Double _
) As Double

[Delphi]
function ReadDouble(
   const Name: WideString;
   const Default: Double
): Double

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
Default
[in] Значение, возвращаемое в случае отсутствия в текущем каталоге указанного имени

Возвращаемое значение

Возвращает прочитанное значение, либо DefaultValue, если в текущем каталоге отсутствует значение с указанным именем

Смотри также

Class PropertyStream


PropertyStream.ReadGUID (метод)

Прочитать значение типа GUID

Синтаксис

[Visual Basic 6]
Function ReadGUID ( _
   ByVal Name As String, _
   Value As String _
) As Boolean

[Delphi]
function ReadGUID(
   const Name: WideString;
   out Value: WideString
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
Value
[out] Строка, в которую необходимо прочитать GUID

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если значение не прочитано, и в этом случае Value содержит строку "{00000000-0000-0000-0000-000000000000}"

Смотри также

Class PropertyStream


PropertyStream.ReadIdXY (метод)

Прочитать плоские (X,Y) координаты с целочисленным идентификатором

Синтаксис

[Visual Basic 6]
Function ReadIdXY ( _
   ByVal Name As String, _
   ID As Long, _
   X As Double, _
   Y As Double _
) As Boolean

[Delphi]
function ReadIdXY(
   const Name: WideString;
   var ID: Integer;
   var X: Double;
   var Y: Double
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
ID
[in, out] Переменная, в которую необходимо прочитать целочисленный идентификатор
X
[in, out] Переменная, в которую необходимо прочитать X-координату
Y
[in, out] Переменная, в которую необходимо прочитать Y-координату

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если значения, переданные в Id,X,Y не изменены

Смотри также

Class PropertyStream


PropertyStream.ReadIdXYZ (метод)

Прочитать трёхменрые (X,Y,Z) координаты с целочисленным идентификатором

Синтаксис

[Visual Basic 6]
Function ReadIdXYZ ( _
   ByVal Name As String, _
   ID As Long, _
   X As Double, _
   Y As Double, _
   Z As Double _
) As Boolean

[Delphi]
function ReadIdXYZ(
   const Name: WideString;
   var ID: Integer;
   var X: Double;
   var Y: Double;
   var Z: Double
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
ID
[in, out] Переменная, в которую необходимо прочитать целочисленный идентификатор
X
[in, out] Переменная, в которую необходимо прочитать X-координату
Y
[in, out] Переменная, в которую необходимо прочитать Y-координату
Z
[in, out] Переменная, в которую необходимо прочитать Z-координату

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если значения, переданные в Id,X,Y,Z не изменены

Смотри также

Class PropertyStream


PropertyStream.ReadIdXYZM (метод)

Прочитать четырёхмерные (X,Y,Z,M) координаты с целочисленным идентификатором

Синтаксис

[Visual Basic 6]
Function ReadIdXYZM ( _
   ByVal Name As String, _
   ID As Long, _
   X As Double, _
   Y As Double, _
   Z As Double, _
   M As Double _
) As Boolean

[Delphi]
function ReadIdXYZM(
   const Name: WideString;
   var ID: Integer;
   var X: Double;
   var Y: Double;
   var Z: Double;
   var M: Double
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
ID
[in, out] Переменная, в которую необходимо прочитать целочисленный идентификатор
X
[in, out] Переменная, в которую необходимо прочитать X-координату
Y
[in, out] Переменная, в которую необходимо прочитать Y-координату
Z
[in, out] Переменная, в которую необходимо прочитать Z-координату
M
[in, out] Переменная, в которую необходимо прочитать M-координату

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если значения, переданные в Id,X,Y,Z,M не изменены

Смотри также

Class PropertyStream


PropertyStream.ReadInteger (метод)

Прочитать значение типа integer

Синтаксис

[Visual Basic 6]
Function ReadInteger ( _
   ByVal Name As String, _
   ByVal DefaultValue As Long _
) As Long

[Delphi]
function ReadInteger(
   const Name: WideString;
   const DefaultValue: Integer
): Integer

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
DefaultValue
[in] Значение, возвращаемое в случае отсутствия в текущем каталоге указанного имени

Возвращаемое значение

Возвращает прочитанное значение, либо DefaultValue, если в текущем каталоге отсутствует значение с указанным именем

Смотри также

Class PropertyStream


PropertyStream.ReadString (метод)

Прочитать строковое значение

Синтаксис

[Visual Basic 6]
Function ReadString ( _
   ByVal Name As String, _
   ByVal Default As String _
) As String

[Delphi]
function ReadString(
   const Name: WideString;
   const Default: WideString
): WideString

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
Default
[in] Значение, возвращаемое в случае отсутствия в текущем каталоге указанного имени

Возвращаемое значение

Возвращает прочитанное значение, либо DefaultValue, если в текущем каталоге отсутствует значение с указанным именем

Смотри также

Class PropertyStream


PropertyStream.ReadXY (метод)

Прочитать плоские (X,Y) координаты

Синтаксис

[Visual Basic 6]
Function ReadXY ( _
   ByVal Name As String, _
   X As Double, _
   Y As Double _
) As Boolean

[Delphi]
function ReadXY(
   const Name: WideString;
   var X: Double;
   var Y: Double
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
X
[in, out] Переменная, в которую необходимо прочитать X-координату
Y
[in, out] Переменная, в которую необходимо прочитать Y-координату

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если значения, переданные в X,Y не изменены

Смотри также

Class PropertyStream


PropertyStream.ReadXYint (метод)

Записать плоские (X,Y) целочисленные координаты

Синтаксис

[Visual Basic 6]
Function ReadXYint ( _
   ByVal Name As String, _
   X As Long, _
   Y As Long _
) As Boolean

[Delphi]
function ReadXYint(
   const Name: WideString;
   var X: Integer;
   var Y: Integer
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
X
[in, out] Переменная, в которую необходимо прочитать X-координату
Y
[in, out] Переменная, в которую необходимо прочитать Y-координату

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если значения, переданные в X,Y не изменены

Смотри также

Class PropertyStream


PropertyStream.ReadXYZ (метод)

Прочитать трёхменрые (X,Y,Z) координаты

Синтаксис

[Visual Basic 6]
Function ReadXYZ ( _
   ByVal Name As String, _
   X As Double, _
   Y As Double, _
   Z As Double _
) As Boolean

[Delphi]
function ReadXYZ(
   const Name: WideString;
   var X: Double;
   var Y: Double;
   var Z: Double
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
X
[in, out] Переменная, в которую необходимо прочитать X-координату
Y
[in, out] Переменная, в которую необходимо прочитать Y-координату
Z
[in, out] Переменная, в которую необходимо прочитать Z-координату

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если значения, переданные в X,Y,Z не изменены

Смотри также

Class PropertyStream


PropertyStream.ReadXYZM (метод)

Прочитать четырёхмерные (X,Y,Z,M) координаты

Синтаксис

[Visual Basic 6]
Function ReadXYZM ( _
   ByVal Name As String, _
   X As Double, _
   Y As Double, _
   Z As Double, _
   M As Double _
) As Boolean

[Delphi]
function ReadXYZM(
   const Name: WideString;
   var X: Double;
   var Y: Double;
   var Z: Double;
   var M: Double
): WordBool

Описание параметров

Name
[in] Имя значения, которое необходимо прочитать
X
[in, out] Переменная, в которую необходимо прочитать X-координату
Y
[in, out] Переменная, в которую необходимо прочитать Y-координату
Z
[in, out] Переменная, в которую необходимо прочитать Z-координату
M
[in, out] Переменная, в которую необходимо прочитать M-координату

Возвращаемое значение

Возвращает True, если координаты прочитаны успешно, иначе возвращает False, если значения, переданные в X,Y,Z,M не изменены

Смотри также

Class PropertyStream


PropertyStream.WriteBinary (метод)

Записать фрагмент памяти

Синтаксис

[Visual Basic 6]
Sub WriteBinary ( _
   ByVal Name As String, _
   ByVal Buffer As OLE_HANDLE, _
   ByVal Size As Long _
)

[Delphi]
procedure WriteBinary(
   const Name: WideString;
   const Buffer: OLE_HANDLE;
   const Size: Integer
)

Описание параметров

Name
[in] Имя, под которым записывается фрагмент памяти. Должно быть уникально в текущем каталоге
Buffer
[in] Адрес первого байта буфера, который необходимо сохранить
Size
[in] Размер буфера в байтах

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class PropertyStream


PropertyStream.WriteBoolean (метод)

Записать значение типа boolean

Синтаксис

[Visual Basic 6]
Sub WriteBoolean ( _
   ByVal Name As String, _
   ByVal Value As Boolean, _
   ByVal DefaultValue As Boolean _
)

[Delphi]
procedure WriteBoolean(
   const Name: WideString;
   const Value: WordBool;
   const DefaultValue: WordBool
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
Value
[in] Сохраняемое значение
DefaultValue
[in] Значение по умолчанию. Если Value=DefaultValue, то запись не производится

Смотри также

Class PropertyStream


PropertyStream.WriteDate (метод)

Записать значение типа TDateTime

Синтаксис

[Visual Basic 6]
Sub WriteDate ( _
   ByVal Name As String, _
   ByVal Value As Date, _
   ByVal DefaultValue As Date _
)

[Delphi]
procedure WriteDate(
   const Name: WideString;
   const Value: TDateTime;
   const DefaultValue: TDateTime
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
Value
[in] Сохраняемое значение
DefaultValue
[in] Значение по умолчанию. Если Value=DefaultValue, то запись не производится

Смотри также

Class PropertyStream


PropertyStream.WriteDouble (метод)

Записать значение типа double

Синтаксис

[Visual Basic 6]
Sub WriteDouble ( _
   ByVal Name As String, _
   ByVal Value As Double, _
   ByVal DefaultValue As Double _
)

[Delphi]
procedure WriteDouble(
   const Name: WideString;
   const Value: Double;
   const DefaultValue: Double
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
Value
[in] Сохраняемое значение
DefaultValue
[in] Значение по умолчанию. Если Value=DefaultValue, то запись не производится

Смотри также

Class PropertyStream


PropertyStream.WriteDoubleDirect (метод)

Записать значение типа double

Синтаксис

[Visual Basic 6]
Sub WriteDoubleDirect ( _
   ByVal Name As String, _
   ByVal Value As Double _
)

[Delphi]
procedure WriteDoubleDirect(
   const Name: WideString;
   const Value: Double
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
Value
[in] Сохраняемое значение

Смотри также

Class PropertyStream


PropertyStream.WriteGUID (метод)

Записать значение типа GUID

Синтаксис

[Visual Basic 6]
Sub WriteGUID ( _
   ByVal Name As String, _
   ByVal Value As String _
)

[Delphi]
procedure WriteGUID(
   const Name: WideString;
   const Value: WideString
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
Value
[in] Сохраняемое значение в виде строки

Смотри также

Class PropertyStream


PropertyStream.WriteIdXY (метод)

Записать плоские (X,Y) координаты с целочисленным идентификатором

Синтаксис

[Visual Basic 6]
Sub WriteIdXY ( _
   ByVal Name As String, _
   ByVal ID As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure WriteIdXY(
   const Name: WideString;
   const ID: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
ID
[in] Сохраняемый целочисленный идентификатор
X
[in] Сохраняемая X-координата
Y
[in] Сохраняемая Y-координата

Смотри также

Class PropertyStream


PropertyStream.WriteIdXYZ (метод)

Записать трёхменрые (X,Y,Z) координаты с целочисленным идентификатором

Синтаксис

[Visual Basic 6]
Sub WriteIdXYZ ( _
   ByVal Name As String, _
   ByVal ID As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
)

[Delphi]
procedure WriteIdXYZ(
   const Name: WideString;
   const ID: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
ID
[in] Сохраняемый целочисленный идентификатор
X
[in] Сохраняемая X-координата
Y
[in] Сохраняемая Y-координата
Z
[in] Сохраняемая Z-координата

Смотри также

Class PropertyStream


PropertyStream.WriteIdXYZM (метод)

Записать четырёхмерные (X,Y,Z,M) координаты с целочисленным идентификатором

Синтаксис

[Visual Basic 6]
Sub WriteIdXYZM ( _
   ByVal Name As String, _
   ByVal ID As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure WriteIdXYZM(
   const Name: WideString;
   const ID: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
ID
[in] Сохраняемый целочисленный идентификатор
X
[in] Сохраняемая X-координата
Y
[in] Сохраняемая Y-координата
Z
[in] Сохраняемая Z-координата
M
[in] Сохраняемая M-координата

Смотри также

Class PropertyStream


PropertyStream.WriteInteger (метод)

Записать значение типа integer

Синтаксис

[Visual Basic 6]
Sub WriteInteger ( _
   ByVal Name As String, _
   ByVal Value As Long, _
   ByVal DefaultValue As Long _
)

[Delphi]
procedure WriteInteger(
   const Name: WideString;
   const Value: Integer;
   const DefaultValue: Integer
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
Value
[in] Сохраняемое значение
DefaultValue
[in] Значение по умолчанию. Если Value=DefaultValue, то запись не производится

Смотри также

Class PropertyStream


PropertyStream.WriteString (метод)

Записать строковое значение

Синтаксис

[Visual Basic 6]
Sub WriteString ( _
   ByVal Name As String, _
   ByVal Value As String, _
   ByVal DefaultValue As String _
)

[Delphi]
procedure WriteString(
   const Name: WideString;
   const Value: WideString;
   const DefaultValue: WideString
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
Value
[in] Сохраняемое значение
DefaultValue
[in] Значение по умолчанию. Если Value=DefaultValue, то запись не производится

Смотри также

Class PropertyStream


PropertyStream.WriteXY (метод)

Записать плоские (X,Y) координаты

Синтаксис

[Visual Basic 6]
Sub WriteXY ( _
   ByVal Name As String, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure WriteXY(
   const Name: WideString;
   const X: Double;
   const Y: Double
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
X
[in] Сохраняемая X-координата
Y
[in] Сохраняемая Y-координата

Смотри также

Class PropertyStream


PropertyStream.WriteXYint (метод)

Записать плоские (X,Y) целочисленные координаты

Синтаксис

[Visual Basic 6]
Sub WriteXYint ( _
   ByVal Name As String, _
   ByVal X As Long, _
   ByVal Y As Long _
)

[Delphi]
procedure WriteXYint(
   const Name: WideString;
   const X: Integer;
   const Y: Integer
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
X
[in] Сохраняемая X-координата
Y
[in] Сохраняемая Y-координата

Смотри также

Class PropertyStream


PropertyStream.WriteXYZ (метод)

Записать трёхменрые (X,Y,Z) координаты

Синтаксис

[Visual Basic 6]
Sub WriteXYZ ( _
   ByVal Name As String, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
)

[Delphi]
procedure WriteXYZ(
   const Name: WideString;
   const X: Double;
   const Y: Double;
   const Z: Double
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
X
[in] Сохраняемая X-координата
Y
[in] Сохраняемая Y-координата
Z
[in] Сохраняемая Z-координата

Смотри также

Class PropertyStream


PropertyStream.WriteXYZM (метод)

Записать четырёхмерные (X,Y,Z,M) координаты

Синтаксис

[Visual Basic 6]
Sub WriteXYZM ( _
   ByVal Name As String, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure WriteXYZM(
   const Name: WideString;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

Name
[in] Имя, под которым записывается значение. Должно быть уникально в текущем каталоге
X
[in] Сохраняемая X-координата
Y
[in] Сохраняемая Y-координата
Z
[in] Сохраняемая Z-координата
M
[in] Сохраняемая M-координата

Смотри также

Class PropertyStream


Класс RangeAdditionalPoint

Абстрактная дополнительная точка со створом

Наследование

GeoPoint Class AdditionalPoint Class RangeAdditionalPoint Class By3PointAdditionalPoint, IntersectionAdditionalPoint, MeasureAdditionalPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AdditionalPointType (только для чтения) | Тип засечки
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Number | Номер (описание) точки
Property Position | Положение точки
Property RangeLinkToPoints | Массив ссылок створных точек на другие точки
Property RangePointCount (только для чтения) | Количество створных (опорных) точек
Property RangePoints | Массив координат створных точек

Смотри также

Class GeoPoint, Enum IntersectionConstants, Class ModelPoint, Group Геодезия


RangeAdditionalPoint.AdditionalPointType (свойство)

Тип засечки

Синтаксис

[Visual Basic 6]
ReadOnly Property AdditionalPointType As IntersectionConstants

[Delphi]
{только для чтения} property AdditionalPointType: IntersectionConstants

Смотри также

Enum IntersectionConstants, Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class ModelPoint, Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.RangeLinkToPoints (свойство)

Массив ссылок створных точек на другие точки

Синтаксис

[Visual Basic 6]
Property RangeLinkToPoints As GeoPoint

[Delphi]
property RangeLinkToPoints: GeoPoint

Смотри также

Class GeoPoint, Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.RangePointCount (свойство)

Количество створных (опорных) точек

Синтаксис

[Visual Basic 6]
ReadOnly Property RangePointCount As Long

[Delphi]
{только для чтения} property RangePointCount: Integer

Смотри также

Class RangeAdditionalPoint, Group Геодезия


RangeAdditionalPoint.RangePoints (свойство)

Массив координат створных точек

Синтаксис

[Visual Basic 6]
Property RangePoints As ModelPoint

[Delphi]
property RangePoints: ModelPoint

Смотри также

Class ModelPoint, Class RangeAdditionalPoint, Group Геодезия


Класс RequestVariable

Описание переменных в запросе LayerRequest

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Items | Список возможных значений
Property Kind | Тип результата
Property LayerRequest (только для чтения) | Указатель на запрос к слою
Property LookupAttrib | Атрибут другой таблицы
Property LookupLayerDefId | Тип элемента в слое с другой таблицей
Property LookupLayerSeqId | Номер слоя с другой таблицей
Property Name | Имя переменной
Property Prompt | Приглашение для ввода значения
Property Style | Стиль ввода переменной
Property Value | Значение по умолчанию

Методы класса

Имя | Описание
Method InputValue | Запросить значение

Где используется

Класс | Член класса
Class LayerRequest | Property Variables (свойство)

Смотри также

Enum CalculatorResultConstants, Enum RequestVariableConstants, Class VectorContainer, Group Карты


RequestVariable.Items (свойство)

Список возможных значений

Синтаксис

[Visual Basic 6]
Property Items As String

[Delphi]
property Items: WideString

Смотри также

Class RequestVariable, Group Карты


RequestVariable.Kind (свойство)

Тип результата

Синтаксис

[Visual Basic 6]
Property Kind As CalculatorResultConstants

[Delphi]
property Kind: CalculatorResultConstants

Смотри также

Enum CalculatorResultConstants, Class RequestVariable, Group Карты


RequestVariable.LayerRequest (свойство)

Указатель на запрос к слою

Синтаксис

[Visual Basic 6]
ReadOnly Property LayerRequest As LayerRequest

[Delphi]
{только для чтения} property LayerRequest: LayerRequest

Смотри также

Class LayerRequest, Class RequestVariable, Group Карты


RequestVariable.LookupAttrib (свойство)

Атрибут другой таблицы

Синтаксис

[Visual Basic 6]
Property LookupAttrib As String

[Delphi]
property LookupAttrib: WideString

Смотри также

Class RequestVariable, Group Карты


RequestVariable.LookupLayerDefId (свойство)

Тип элемента в слое с другой таблицей

Синтаксис

[Visual Basic 6]
Property LookupLayerDefId As Long

[Delphi]
property LookupLayerDefId: Integer

Смотри также

Class RequestVariable, Group Карты


RequestVariable.LookupLayerSeqId (свойство)

Номер слоя с другой таблицей

Синтаксис

[Visual Basic 6]
Property LookupLayerSeqId As Long

[Delphi]
property LookupLayerSeqId: Integer

Смотри также

Class RequestVariable, Group Карты


RequestVariable.Name (свойство)

Имя переменной

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class RequestVariable, Group Карты


RequestVariable.Prompt (свойство)

Приглашение для ввода значения

Синтаксис

[Visual Basic 6]
Property Prompt As String

[Delphi]
property Prompt: WideString

Смотри также

Class RequestVariable, Group Карты


RequestVariable.Style (свойство)

Стиль ввода переменной

Синтаксис

[Visual Basic 6]
Property Style As RequestVariableConstants

[Delphi]
property Style: RequestVariableConstants

Смотри также

Class RequestVariable, Enum RequestVariableConstants, Group Карты


RequestVariable.Value (свойство)

Значение по умолчанию

Синтаксис

[Visual Basic 6]
Property Value As String

[Delphi]
property Value: WideString

Смотри также

Class RequestVariable, Group Карты


RequestVariable.InputValue (метод)

Запросить значение

Синтаксис

[Visual Basic 6]
Function InputValue ( _
   ByVal Container As VectorContainer, _
   ByVal Params As Long _
) As Boolean

[Delphi]
function InputValue(
   const Container: VectorContainer;
   const Params: Integer
): WordBool

Описание параметров

Container
[in] Контейнер, в котором выполняется сейчас запрос
Params
[in] Различные флаги выполнения ввода значения (rpNoMoveMap = 1, rpZoomToSelected = 2, rpMoveToSelectesd = 4, rpAttrToAllVar = 8, rpAutoAttrToVar = 16, rpFistToVar = 32, rbAttrSelectedToVar = 64, rbAttrVisibleToVar = 128)

Возвращаемое значение

Возвращает True, если значение введено пользователем

Смотри также

Class RequestVariable, Class VectorContainer, Group Карты


Класс Ribbon

Лента инструментов

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property TabCount (только для чтения) | Количество закладок
Property Tabs (только для чтения) | Массив закладок

Методы класса

Имя | Описание
Method CreateNewTab | Создать новую закладку с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method TabByName | Получить закладку по внутреннему имени

Смотри также

Class RibbonTab, Group Пользовательский интерфейс


Ribbon.TabCount (свойство)

Количество закладок

Синтаксис

[Visual Basic 6]
ReadOnly Property TabCount As Long

[Delphi]
{только для чтения} property TabCount: Integer

Смотри также

Class Ribbon, Group Пользовательский интерфейс


Ribbon.Tabs (свойство)

Массив закладок

Синтаксис

[Visual Basic 6]
ReadOnly Property Tabs As RibbonTab

[Delphi]
{только для чтения} property Tabs: RibbonTab

Смотри также

Class Ribbon, Class RibbonTab, Group Пользовательский интерфейс


Ribbon.CreateNewTab (метод)

Создать новую закладку с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewTab ( _
   [ByVal Name As String = ""] _
) As RibbonTab

[Delphi]
function CreateNewTab(
   const Name: WideString
): RibbonTab

Описание параметров

Name
[in] Имя новой закладки виде

Возвращаемое значение

Возвращает новую закладку

Смотри также

Class Ribbon, Class RibbonTab, Group Пользовательский интерфейс


Ribbon.TabByName (метод)

Получить закладку по внутреннему имени

Синтаксис

[Visual Basic 6]
Function TabByName ( _
   ByVal Name As String _
) As RibbonTab

[Delphi]
function TabByName(
   const Name: WideString
): RibbonTab

Описание параметров

Name
[in] Имя закладки

Возвращаемое значение

Возвращает закладку по указанному имени или Nothing, если таковой не существует

Смотри также

Class Ribbon, Class RibbonTab, Group Пользовательский интерфейс


Класс RibbonTab

Закладка на ленте инструментов

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Caption | Название закладки
Property GroupCount (только для чтения) | Количество групп на закладке
Property Groups (только для чтения) | Массив групп на закладке
Property KeyTip | Цепочка горячих клавиш
Property Name (только для чтения) | Уникальное имя в виде
Property Visible | Видна ли закладка

Методы класса

Имя | Описание
Method CreateNewGroup | Создать новую группу с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка
Method Delete | Удалить закладку

Где используется

Класс | Член класса
Class Ribbon | Property Tabs (свойство) Method CreateNewTab (метод) Method TabByName (метод)

Смотри также

Class RibbonTabGroup, Group Пользовательский интерфейс


RibbonTab.Caption (свойство)

Название закладки

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class RibbonTab, Group Пользовательский интерфейс


RibbonTab.GroupCount (свойство)

Количество групп на закладке

Синтаксис

[Visual Basic 6]
ReadOnly Property GroupCount As Long

[Delphi]
{только для чтения} property GroupCount: Integer

Смотри также

Class RibbonTab, Group Пользовательский интерфейс


RibbonTab.Groups (свойство)

Массив групп на закладке

Синтаксис

[Visual Basic 6]
ReadOnly Property Groups As RibbonTabGroup

[Delphi]
{только для чтения} property Groups: RibbonTabGroup

Смотри также

Class RibbonTab, Class RibbonTabGroup, Group Пользовательский интерфейс


RibbonTab.KeyTip (свойство)

Цепочка горячих клавиш

Синтаксис

[Visual Basic 6]
Property KeyTip As String

[Delphi]
property KeyTip: WideString

Смотри также

Class RibbonTab, Group Пользовательский интерфейс


RibbonTab.Name (свойство)

Уникальное имя в виде

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class RibbonTab, Group Пользовательский интерфейс


RibbonTab.Visible (свойство)

Видна ли закладка

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class RibbonTab, Group Пользовательский интерфейс


RibbonTab.CreateNewGroup (метод)

Создать новую группу с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNewGroup ( _
   [ByVal Name As String = ""] _
) As RibbonTabGroup

[Delphi]
function CreateNewGroup(
   const Name: WideString
): RibbonTabGroup

Описание параметров

Name
[in] Имя новой группы на закладке в виде

Возвращаемое значение

Возвращает новую группу на закладке

Смотри также

Class RibbonTab, Class RibbonTabGroup, Group Пользовательский интерфейс


RibbonTab.Delete (метод)

Удалить закладку

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class RibbonTab, Group Пользовательский интерфейс


Класс RibbonTabGroup

Группа действий на ленте инструментов

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bar | Связанная с группой панель инструментов

Методы класса

Имя | Описание
Method Delete | Удалить группу на закладке

Где используется

Класс | Член класса
Class RibbonTab | Property Groups (свойство) Method CreateNewGroup (метод)

Смотри также

Class Bar, Group Пользовательский интерфейс


RibbonTabGroup.Bar (свойство)

Связанная с группой панель инструментов

Синтаксис

[Visual Basic 6]
Property Bar As Bar

[Delphi]
property Bar: Bar

Смотри также

Class Bar, Class RibbonTabGroup, Group Пользовательский интерфейс


RibbonTabGroup.Delete (метод)

Удалить группу на закладке

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class RibbonTabGroup, Group Пользовательский интерфейс


Класс Route

Трасса

Наследование

BaseObject Class Aggregate Class Route

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ActiveElement (только для чтения) | Текущий поперечый профиль. Для неразбитой трассы Nothing
Property ActiveElementIndex (только для чтения) | Номер текущего поперечного профиля. Для неразбитой трассы "-1"
Property ActiveVertex (только для чтения) | Возвращает текущая (выделенная) вершина трассы
Property Application (только для чтения) | Приложение, в котором существует объект
Property BaseLayerID | ID слоя "чёрной" земли
Property DefaultSpeed | Расчётная скорость движения автомобиля
Property ElementCount (только для чтения) | Количество поперечных профилей, на которое разбита трасса
Property Elements (только для чтения) | Элементы разбивки (поперечные профили). Нумерация идёт от 0 до ElementsCount-1
Property EnableSurfaceBuilding | Разрешить ли формировать поверхность в слой LayerID
Property FirstVertex (только для чтения) | Вершина начала трассы
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property InternalID (только для чтения) | Внутренний ID трассы. Используется при построения цифровой модели проекта
Property Items (только для чтения) | Возвращает подэлемент по его сингатуре (ветвь дерева)
Property LastVertex (только для чтения) | Вершина конца трассы
Property LayerID | ID слоя, в котором трасса автоматически формирует поверхность
Property Name | Имя трассы
Property Options (только для чтения) | Параметры трассы
Property PKEnd (только для чтения) | Пикет конца трассы
Property PKStart (только для чтения) | Пикет начала трассы
Property Project (только для чтения) | Проект, к которому относится объект
Property Routes (только для чтения) | Список трасс, которому принадлежит трасса
Property SpacedOut (только для чтения) | Разбита ли трасса на поперечные профили
Property VertexCount (только для чтения) | Количество вершин в трассе
Property Vertices (только для чтения) | Массив вершин (нумерация идёт от 0 до VertexCount-1)
Property Visible | Включено ли отображение трассы в плане

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method CanDeleteVertex | Проверяет, можно ли удалить указанную вершину угла трассы
Method Changed | Информирует объект о том, что произошли изменения. SetModifiedFlag=True - объекту выставляется признак "Модифицирована". NeedRepaint=True - необходимо перерисовать план. OptionsChanged=True - изменились невизуальные свойства объекта
Method Clone | Создать клон (абсолютную копию) трассы и добавить его к списку трасс
Method DeleteElement | Удаляет указанный поперечный профиль
Method DeleteVertex | Удаляет указанную вершину угла трассы
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method FindCrossPoints | Найти точки пересечения отрезка с осевой линией трассы. Возвращает пикетажные положения пересечений в Pickets, и количество пересечений в качестве результата
Method GetCodedLines | Получить список используемых в трассе кодов линий из наборной модели
Method GetDesignSpeed | Расчётная скорость движения автомобиля в указанном пикете
Method GetElementBounds | Получить границы проектного поперечного профиля
Method GetJKrAngle | Получить кривизну, касательную в точке на оси
Method GetXYZ | Получить координаты точки на оси
Method InsertElement | Добавляет поперечный профиль с указанным пикетажным положением
Method InsertVertex | Добавляет новую вершину в трассу перед вершиной с указанным номером
Method InvalidCrossectionsData | Вызывается подобъектами, если их данные, которые могут отображаться в сечениях, изменились
Method InvalidSurface | Вызывается, когда необходимо перестроить модель поверхности
Method MakeTreeStructure | Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта
Method PkOffsetToXY | Преобразовать координаты из системы координат трассы (пикет, смещение) в модельную систему координат
Method PutDataToLayer | Сформировать проектную поверхность в виде точек и линий в указанном слое
Method RemoveDataFromLayer | Удалить ранее сформированную проектную поверхность из указанного слоя
Method RemoveSpaceOut | Удалить разбивку трассы
Method RepresentCodedLineAsPolyline | Представить линию из наборной модели трассы в виде ломаной (массив чисел: (PK [, X, Y] [, Z]))
Method SelectVertex | Устанавливает указанную вершину как текущую (выделенную)
Method ShowSetupDialog | Вызывает диалог свойств трассы
Method SpaceOut | Разбить участок трассы с указанным шагом
Method TreeStructureChanged | Информирует объект о том, что необходимо перерисовать либо перестроить дерево структуры проекта
Method XYtoPkOffset | Преобразовать координаты из модельной системы координат в систему координат трассы (пикет, смещение)

Где используется

Класс | Член класса
Class IRoutesEvents | Method AnalogModelChanged (метод) Method CrossectionDeleted (метод) Method CrossectionDeleting (метод) Method CrossectionInserted (метод) Method CrossectionInserting (метод) Method DigitalModelChanged (метод) Method NewRoute (метод) Method RouteActivate (метод) Method RouteCloned (метод) Method RouteDeleting (метод) Method RouteParamsChanged (метод) Method SelectionChanged (метод) Method SpacedOut (метод) Method SurfaceModified (метод) Method UnSpacedOut (метод) Method VertexSelected (метод)
Class Route | Method Clone (метод)
Class Routes | Property ActiveRoute (свойство) Property Routes (свойство) Method CreateRoute (метод) Method GetNearestRoute (метод) Method GetRouteByName (метод) Event AnalogModelChanged (событие) Event CrossectionDeleted (событие) Event CrossectionDeleting (событие) Event CrossectionInserted (событие) Event CrossectionInserting (событие) Event DigitalModelChanged (событие) Event NewRoute (событие) Event RouteActivate (событие) Event RouteCloned (событие) Event RouteDeleting (событие) Event RouteParamsChanged (событие) Event SelectionChanged (событие) Event SpacedOut (событие) Event SurfaceModified (событие) Event UnSpacedOut (событие) Event VertexSelected (событие)

Смотри также

Class Application, Class DoubleCollection, Interface ICADObject, Interface IDocTreeHandler, Class IntegerCollection, Class Layer, Class Project, Enum RepresentLineConstants, Class RouteElement, Class RouteOptions, Class RouteVertex, Group Трассы


Route.ActiveElement (свойство)

Текущий поперечый профиль. Для неразбитой трассы Nothing

Синтаксис

[Visual Basic 6]
ReadOnly Property ActiveElement As RouteElement

[Delphi]
{только для чтения} property ActiveElement: RouteElement

Смотри также

Class Route, Class RouteElement, Group Трассы


Route.ActiveElementIndex (свойство)

Номер текущего поперечного профиля. Для неразбитой трассы "-1"

Синтаксис

[Visual Basic 6]
ReadOnly Property ActiveElementIndex As Long

[Delphi]
{только для чтения} property ActiveElementIndex: Integer

Смотри также

Class Route, Group Трассы


Route.ActiveVertex (свойство)

Возвращает текущая (выделенная) вершина трассы

Синтаксис

[Visual Basic 6]
ReadOnly Property ActiveVertex As RouteVertex

[Delphi]
{только для чтения} property ActiveVertex: RouteVertex

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Route, Class RouteVertex, Group Трассы


Route.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class Route, Group Трассы


Route.BaseLayerID (свойство)

ID слоя "чёрной" земли

Синтаксис

[Visual Basic 6]
Property BaseLayerID As String

[Delphi]
property BaseLayerID: WideString

Смотри также

Class Route, Group Трассы


Route.DefaultSpeed (свойство)

Расчётная скорость движения автомобиля

Синтаксис

[Visual Basic 6]
Property DefaultSpeed As Double

[Delphi]
property DefaultSpeed: Double

Смотри также

Class Route, Group Трассы


Route.ElementCount (свойство)

Количество поперечных профилей, на которое разбита трасса

Синтаксис

[Visual Basic 6]
ReadOnly Property ElementCount As Long

[Delphi]
{только для чтения} property ElementCount: Integer

Смотри также

Class Route, Group Трассы


Route.Elements (свойство)

Элементы разбивки (поперечные профили). Нумерация идёт от 0 до ElementsCount-1

Синтаксис

[Visual Basic 6]
ReadOnly Property Elements As RouteElement

[Delphi]
{только для чтения} property Elements: RouteElement

Смотри также

Class Route, Class RouteElement, Group Трассы


Route.EnableSurfaceBuilding (свойство)

Разрешить ли формировать поверхность в слой LayerID

Синтаксис

[Visual Basic 6]
Property EnableSurfaceBuilding As Boolean

[Delphi]
property EnableSurfaceBuilding: WordBool

Смотри также

Class Route, Group Трассы


Route.FirstVertex (свойство)

Вершина начала трассы

Синтаксис

[Visual Basic 6]
ReadOnly Property FirstVertex As RouteVertex

[Delphi]
{только для чтения} property FirstVertex: RouteVertex

Смотри также

Class Route, Class RouteVertex, Group Трассы


Route.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Route, Group Трассы


Route.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Route, Group Трассы


Route.InternalID (свойство)

Внутренний ID трассы. Используется при построения цифровой модели проекта

Синтаксис

[Visual Basic 6]
ReadOnly Property InternalID As Long

[Delphi]
{только для чтения} property InternalID: Integer

Смотри также

Class Route, Group Трассы


Route.Items (свойство)

Возвращает подэлемент по его сингатуре (ветвь дерева)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As ICADObject

[Delphi]
{только для чтения} property Items: ICADObject

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface ICADObject, Class Route, Group Трассы


Route.LastVertex (свойство)

Вершина конца трассы

Синтаксис

[Visual Basic 6]
ReadOnly Property LastVertex As RouteVertex

[Delphi]
{только для чтения} property LastVertex: RouteVertex

Смотри также

Class Route, Class RouteVertex, Group Трассы


Route.LayerID (свойство)

ID слоя, в котором трасса автоматически формирует поверхность

Синтаксис

[Visual Basic 6]
Property LayerID As String

[Delphi]
property LayerID: WideString

Смотри также

Class Route, Group Трассы


Route.Name (свойство)

Имя трассы

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class Route, Group Трассы


Route.Options (свойство)

Параметры трассы

Синтаксис

[Visual Basic 6]
ReadOnly Property Options As RouteOptions

[Delphi]
{только для чтения} property Options: RouteOptions

Смотри также

Class Route, Class RouteOptions, Group Трассы


Route.PKEnd (свойство)

Пикет конца трассы

Синтаксис

[Visual Basic 6]
ReadOnly Property PKEnd As Double

[Delphi]
{только для чтения} property PKEnd: Double

Смотри также

Class Route, Group Трассы


Route.PKStart (свойство)

Пикет начала трассы

Синтаксис

[Visual Basic 6]
ReadOnly Property PKStart As Double

[Delphi]
{только для чтения} property PKStart: Double

Смотри также

Class Route, Group Трассы


Route.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class Route, Group Трассы


Route.Routes (свойство)

Список трасс, которому принадлежит трасса

Синтаксис

[Visual Basic 6]
ReadOnly Property Routes As Routes

[Delphi]
{только для чтения} property Routes: Routes

Смотри также

Class Route, Class Routes, Group Трассы


Route.SpacedOut (свойство)

Разбита ли трасса на поперечные профили

Синтаксис

[Visual Basic 6]
ReadOnly Property SpacedOut As Boolean

[Delphi]
{только для чтения} property SpacedOut: WordBool

Смотри также

Class Route, Group Трассы


Route.VertexCount (свойство)

Количество вершин в трассе

Синтаксис

[Visual Basic 6]
ReadOnly Property VertexCount As Long

[Delphi]
{только для чтения} property VertexCount: Integer

Смотри также

Class Route, Group Трассы


Route.Vertices (свойство)

Массив вершин (нумерация идёт от 0 до VertexCount-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Vertices As RouteVertex

[Delphi]
{только для чтения} property Vertices: RouteVertex

Смотри также

Class Route, Class RouteVertex, Group Трассы


Route.Visible (свойство)

Включено ли отображение трассы в плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Route, Group Трассы


Route.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Route, Group Трассы


Route.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Route, Group Трассы


Route.CanDeleteVertex (метод)

Проверяет, можно ли удалить указанную вершину угла трассы

Синтаксис

[Visual Basic 6]
Function CanDeleteVertex ( _
   ByVal Vertex As RouteVertex _
) As Boolean

[Delphi]
function CanDeleteVertex(
   const Vertex: RouteVertex
): WordBool

Описание параметров

Vertex
[in] Вершина трассы, для которой проводится проверка на возможность удаления

Возвращаемое значение

Результат проверки: True - вершину можно удалить, False - нельзя

Смотри также

Class Route, Class RouteVertex, Group Трассы


Route.Changed (метод)

Информирует объект о том, что произошли изменения. SetModifiedFlag=True - объекту выставляется признак "Модифицирована". NeedRepaint=True - необходимо перерисовать план. OptionsChanged=True - изменились невизуальные свойства объекта

Синтаксис

[Visual Basic 6]
Sub Changed ( _
   ByVal SetModifiedFlag As Boolean, _
   ByVal NeedRepaint As Boolean, _
   ByVal OptionsChanged As Boolean _
)

[Delphi]
procedure Changed(
   const SetModifiedFlag: WordBool;
   const NeedRepaint: WordBool;
   const OptionsChanged: WordBool
)

Описание параметров

SetModifiedFlag
[in] True - необходимо установить у объекта признак "модифицирован"
NeedRepaint
[in] True - необходимо перерисовать план
OptionsChanged
[in] True - изменились невизуальные свойства объекта

Смотри также

Class Route, Group Трассы


Route.Clone (метод)

Создать клон (абсолютную копию) трассы и добавить его к списку трасс

Синтаксис

[Visual Basic 6]
Function Clone As Route

[Delphi]
function Clone: Route

Возвращаемое значение

Созданная трасса, являющаяся копией исходной трассы. Созданная трасса добавляется в список трасс после исходной трассы

Смотри также

Class Route, Group Трассы


Route.DeleteElement (метод)

Удаляет указанный поперечный профиль

Синтаксис

[Visual Basic 6]
Function DeleteElement ( _
   ByVal ElementIndex As Long, _
   ByVal ShowConfirmDialog As Boolean _
) As Boolean

[Delphi]
function DeleteElement(
   const ElementIndex: Integer;
   const ShowConfirmDialog: WordBool
): WordBool

Описание параметров

ElementIndex
[in] Индекс поперечного профиля, который необходимо удалить
ShowConfirmDialog
[in] Отображать ли диалог подтверждения удаления поперечного профиля

Возвращаемое значение

Результат операции: True - поперечный профиль успешно удалён, False - профиль не был удалён в результате ошибки или отмены действия пользователем

Смотри также

Class Route, Group Трассы


Route.DeleteVertex (метод)

Удаляет указанную вершину угла трассы

Синтаксис

[Visual Basic 6]
Function DeleteVertex ( _
   ByVal Vertex As RouteVertex _
) As Boolean

[Delphi]
function DeleteVertex(
   const Vertex: RouteVertex
): WordBool

Описание параметров

Vertex
[in] Вершина, которую необходимо удалить

Возвращаемое значение

Результат операции: True - вершина успешено удалена, False - ошибка

Смотри также

Class Route, Class RouteVertex, Group Трассы


Route.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Route, Group Трассы


Route.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Route, Group Трассы


Route.FindCrossPoints (метод)

Найти точки пересечения отрезка с осевой линией трассы. Возвращает пикетажные положения пересечений в Pickets, и количество пересечений в качестве результата

Синтаксис

[Visual Basic 6]
Function FindCrossPoints ( _
   ByVal X1 As Double, _
   ByVal Y1 As Double, _
   ByVal X2 As Double, _
   ByVal Y2 As Double, _
   ByVal Pickets As DoubleCollection _
) As Long

[Delphi]
function FindCrossPoints(
   const X1: Double;
   const Y1: Double;
   const X2: Double;
   const Y2: Double;
   const Pickets: DoubleCollection
): Integer

Описание параметров

X1
[in] Модельная X-координата начала отрезка
Y1
[in] Модельная Y-координата начала отрезка
X2
[in] Модельная X-координата конца отрезка
Y2
[in] Модельная Y-координата конца отрезка
Pickets
[in] Коллекция вещественных чисел, в которую будут возвращены пикетажные положения точек пересечения

Возвращаемое значение

Количество найденных пересечений отрезка с осевой линией трассы

Смотри также

Class DoubleCollection, Class Route, Group Трассы


Route.GetCodedLines (метод)

Получить список используемых в трассе кодов линий из наборной модели

Синтаксис

[Visual Basic 6]
Function GetCodedLines ( _
   ByVal SubgradeOnly As Boolean, _
   ByVal Codes As IntegerCollection _
) As Boolean

[Delphi]
function GetCodedLines(
   const SubgradeOnly: WordBool;
   const Codes: IntegerCollection
): WordBool

Описание параметров

SubgradeOnly
[in] True - возвращать коды только элемента верха земляного полотна, False - все используемые элементы
Codes
[in] Коллекция целых чисел, в которую необходимо сохранить коды используемых в наборной модели трассы линий

Возвращаемое значение

Результат операции: True - данные успешно возвращены, False - ошибка

Замечания

Если трасса не разбита, то возвращён будет только код оси трассы

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class IntegerCollection, Class Route, Group Трассы


Route.GetDesignSpeed (метод)

Расчётная скорость движения автомобиля в указанном пикете

Синтаксис

[Visual Basic 6]
Function GetDesignSpeed ( _
   ByVal Picket As Double, _
   ByVal IsForward As Boolean _
) As Double

[Delphi]
function GetDesignSpeed(
   const Picket: Double;
   const IsForward: WordBool
): Double

Описание параметров

Picket
[in] Пикетажное положение участка, для которого требуется получить расчётную скорость движения автомобиля в км/ч
IsForward
[in] True - в движении по ходу роста пикетажа, False - в противоположном направлении

Возвращаемое значение

Возвращаемое значение расчётной скорости движения автомобиля в км/ч

Смотри также

Class Route, Group Трассы


Route.GetElementBounds (метод)

Получить границы проектного поперечного профиля

Синтаксис

[Visual Basic 6]
Function GetElementBounds ( _
   ByVal ElementIndex As Long, _
   Left As Double, _
   Right As Double _
) As Boolean

[Delphi]
function GetElementBounds(
   const ElementIndex: Integer;
   out Left: Double;
   out Right: Double
): WordBool

Описание параметров

ElementIndex
[in] Индекс профиля, границы которого необходимо получить
Left
[out] Левая граница в метрах от оси
Right
[out] Правая граница в метрах от оси

Возвращаемое значение

Результат операции: True - значения успешно возвращены, False - ошибка

Смотри также

Class Route, Group Трассы


Route.GetJKrAngle (метод)

Получить кривизну, касательную в точке на оси

Синтаксис

[Visual Basic 6]
Function GetJKrAngle ( _
   ByVal Picket As Double, _
   J As Double, _
   Kr As Double, _
   Angle As Double _
) As Boolean

[Delphi]
function GetJKrAngle(
   const Picket: Double;
   out J: Double;
   out Kr: Double;
   out Angle: Double
): WordBool

Описание параметров

Picket
[in] Пикетажное положение точки на оси, для которой необходимо рассчитать параметры
J
[out] Скорость изменения кривизны в точке
Kr
[out] Значение кривизны в точке
Angle
[out] Касательная в точке

Возвращаемое значение

Результат операции: True - значения успешно возвращены, False - ошибка

Смотри также

Class Route, Group Трассы


Route.GetXYZ (метод)

Получить координаты точки на оси

Синтаксис

[Visual Basic 6]
Function GetXYZ ( _
   ByVal Picket As Double, _
   X As Double, _
   Y As Double, _
   Z As Double _
) As Boolean

[Delphi]
function GetXYZ(
   const Picket: Double;
   out X: Double;
   out Y: Double;
   out Z: Double
): WordBool

Описание параметров

Picket
[in] Пикетажное положение точки на оси, координаты которой необходимо получить
X
[out] Возвращаемая модельная X-координата точки на оси
Y
[out] Возвращаемая модельная Y-координата точки на оси
Z
[out] Возвращаемая модельная Z-координата точки на оси

Возвращаемое значение

Результат операции: True - значения успешно возвращены, False - ошибка

Смотри также

Class Route, Group Трассы


Route.InsertElement (метод)

Добавляет поперечный профиль с указанным пикетажным положением

Синтаксис

[Visual Basic 6]
Function InsertElement ( _
   ByVal Picket As Double, _
   ByVal ShowCorrectPKDialog As Boolean _
) As Long

[Delphi]
function InsertElement(
   const Picket: Double;
   const ShowCorrectPKDialog: WordBool
): Integer

Описание параметров

Picket
[in] Пикетажное положение поперечного профиля, который необходимо добавить
ShowCorrectPKDialog
[in] Отображать ли диалог, в котором пользователь может скорректировать пикетажное положение

Возвращаемое значение

Индекс добавленного поперечного профиля, либо "-1" в случае ошибки или отмены действия пользователем

Смотри также

Class Route, Group Трассы


Route.InsertVertex (метод)

Добавляет новую вершину в трассу перед вершиной с указанным номером

Синтаксис

[Visual Basic 6]
Function InsertVertex ( _
   ByVal VertexIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
) As RouteVertex

[Delphi]
function InsertVertex(
   const VertexIndex: Integer;
   const X: Double;
   const Y: Double
): RouteVertex

Описание параметров

VertexIndex
[in] Индекс вершины, перед которой будет добавлена новая вершина
X
[in] Модельная X-координата добавляемой вершины
Y
[in] Модельная Y-координата добавляемой вершины

Возвращаемое значение

Возвращается добавленная вершина, либо Nothing в случае ошибки

Смотри также

Class Route, Class RouteVertex, Group Трассы


Route.InvalidCrossectionsData (метод)

Вызывается подобъектами, если их данные, которые могут отображаться в сечениях, изменились

Синтаксис

[Visual Basic 6]
Sub InvalidCrossectionsData ( _
   ByVal StructureChanged As Boolean _
)

[Delphi]
procedure InvalidCrossectionsData(
   const StructureChanged: WordBool
)

Описание параметров

StructureChanged
[in] True - необходимо только перерисовать сечения, False - изменилась структура данных и необходимо перестроить список профильных объектов

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Route, Group Трассы


Route.InvalidSurface (метод)

Вызывается, когда необходимо перестроить модель поверхности

Синтаксис

[Visual Basic 6]
Sub InvalidSurface ( _
   ByVal NeedRebuild As Boolean, _
   ByVal NeedReanalyse As Boolean _
)

[Delphi]
procedure InvalidSurface(
   const NeedRebuild: WordBool;
   const NeedReanalyse: WordBool
)

Описание параметров

NeedRebuild
[in] True - изменились данные для построения модели поверхности
NeedReanalyse
[in] True - изменились данные для анализа треугольников

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Route, Group Трассы


Route.MakeTreeStructure (метод)

Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта

Синтаксис

[Visual Basic 6]
Sub MakeTreeStructure ( _
   ByVal Handler As IDocTreeHandler, _
   ByVal ParentID As Long, _
   ByVal Reason As Long, _
   ByVal IncludeHidden As Boolean _
)

[Delphi]
procedure MakeTreeStructure(
   const Handler: IDocTreeHandler;
   const ParentID: Integer;
   const Reason: Integer;
   const IncludeHidden: WordBool
)

Описание параметров

Handler
[in] Объект, которому будут поочерёдно передаваться все объекты, содержащиеся в проекте
ParentID
[in] Некий идентификатор родительского узла (обычно "0")
Reason
[in] Значение, которое будет передаваться в Handler при добавлении объектов. По нему Handler, принимающий перечисляемые объекты, может определить, что с ними делать
IncludeHidden
[in] Некоторые объекты могут не перечислять себя, если они не содержат подобъектов. Если IncludeHidden установлен в True, то объект должен перечислить себя в любом случае

Смотри также

Interface IDocTreeHandler, Class Route, Group Трассы


Route.PkOffsetToXY (метод)

Преобразовать координаты из системы координат трассы (пикет, смещение) в модельную систему координат

Синтаксис

[Visual Basic 6]
Function PkOffsetToXY ( _
   ByVal Picket As Double, _
   ByVal Offset As Double, _
   ModelX As Double, _
   ModelY As Double _
) As Boolean

[Delphi]
function PkOffsetToXY(
   const Picket: Double;
   const Offset: Double;
   out ModelX: Double;
   out ModelY: Double
): WordBool

Описание параметров

Picket
[in] Пикетажное положение точки
Offset
[in] Смещение точки от оси (отрицательные значения - влево, положительные - вправо)
ModelX
[out] Возвращаемая модельная X-координата
ModelY
[out] Возвращаемая модельная Y-координата

Возвращаемое значение

Результат операции: True - значения успешно возвращены, False - ошибка

Смотри также

Class Route, Group Трассы


Route.PutDataToLayer (метод)

Сформировать проектную поверхность в виде точек и линий в указанном слое

Синтаксис

[Visual Basic 6]
Sub PutDataToLayer ( _
   ByVal Layer As Layer _
)

[Delphi]
procedure PutDataToLayer(
   const Layer: Layer
)

Описание параметров

Layer
[in] Слой, в котором должна быть сформирована проектная поверхность

Смотри также

Class Layer, Class Route, Group Трассы


Route.RemoveDataFromLayer (метод)

Удалить ранее сформированную проектную поверхность из указанного слоя

Синтаксис

[Visual Basic 6]
Sub RemoveDataFromLayer ( _
   ByVal Layer As Layer _
)

[Delphi]
procedure RemoveDataFromLayer(
   const Layer: Layer
)

Описание параметров

Layer
[in] Слой, из которого должна быть удалена проектная поверхность, относящаяся к данной трассе

Смотри также

Class Layer, Class Route, Group Трассы


Route.RemoveSpaceOut (метод)

Удалить разбивку трассы

Синтаксис

[Visual Basic 6]
Sub RemoveSpaceOut

[Delphi]
procedure RemoveSpaceOut

Смотри также

Class Route, Group Трассы


Route.RepresentCodedLineAsPolyline (метод)

Представить линию из наборной модели трассы в виде ломаной (массив чисел: (PK [, X, Y] [, Z]))

Синтаксис

[Visual Basic 6]
Function RepresentCodedLineAsPolyline ( _
   ByVal LineCode As Long, _
   ByVal Data As DoubleCollection, _
   ByVal RepresentLine As RepresentLineConstants _
) As Boolean

[Delphi]
function RepresentCodedLineAsPolyline(
   const LineCode: Integer;
   const Data: DoubleCollection;
   const RepresentLine: RepresentLineConstants
): WordBool

Описание параметров

LineCode
[in] Код запрашиваемой линии из наборной модели трассы
Data
[in] Коллекция вещественных чисел, в которую необходимо сохранить запрашиваемую информацию
RepresentLine
[in] Комбинация флагов, описывающая содержание запрашиваемой информации

Возвращаемое значение

Результат операции: True - данные успешно возвращены, False - ошибка

Замечания

Получить список используемых в данной трассе линий можно с помощью метода GetCodedLines. Некоторые линии могут быть прерывистые! В этом случае в возвращённых координатах X,Y,Z будет EmptyDouble. Содержание возвращаемых данных зависит от параметра RepresentLine. В случае, если параметр был равен "0", метод возвращает пустую коллекцию чисел, в противном случае коллекция чисел Data содержит последовательность значений: Пикет (если был выставлен флаг RepresentLinePicket), пару координат X, Y (если был выставлен флаг RepresentLineXY) и Z (если был выставлен флаг RepresentLineZ)

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class DoubleCollection, Enum RepresentLineConstants, Class Route, Group Трассы


Route.SelectVertex (метод)

Устанавливает указанную вершину как текущую (выделенную)

Синтаксис

[Visual Basic 6]
Sub SelectVertex ( _
   ByVal Index As Long _
)

[Delphi]
procedure SelectVertex(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс вершины, которую необходимо сделать текущей

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Route, Group Трассы


Route.ShowSetupDialog (метод)

Вызывает диалог свойств трассы

Синтаксис

[Visual Basic 6]
Function ShowSetupDialog As Boolean

[Delphi]
function ShowSetupDialog: WordBool

Возвращаемое значение

Результат операции: True - пользователь завершил диалог нажатием кнопки "OK", False - ошибка, либо пользователь завершил диалог нажатием ктопки "Отмена"

Смотри также

Class Route, Group Трассы


Route.SpaceOut (метод)

Разбить участок трассы с указанным шагом

Синтаксис

[Visual Basic 6]
Function SpaceOut ( _
   ByVal PKStart As Double, _
   ByVal PKEnd As Double, _
   ByVal Step As Double, _
   ByVal IncludeBasePoints As Boolean _
) As Long

[Delphi]
function SpaceOut(
   const PKStart: Double;
   const PKEnd: Double;
   const Step: Double;
   const IncludeBasePoints: WordBool
): Integer

Описание параметров

PKStart
[in] Пикет начала разбивки
PKEnd
[in] Пикет конца разбивки
Step
[in] Шаг разбивки трассы
IncludeBasePoints
[in] Добавлять ли ключевые поперечные профили (начала/концы переходных кривых)

Возвращаемое значение

Возвращает количество ошибок при разбивке

Смотри также

Class Route, Group Трассы


Route.TreeStructureChanged (метод)

Информирует объект о том, что необходимо перерисовать либо перестроить дерево структуры проекта

Синтаксис

[Visual Basic 6]
Sub TreeStructureChanged ( _
   ByVal Rescan As Boolean _
)

[Delphi]
procedure TreeStructureChanged(
   const Rescan: WordBool
)

Описание параметров

Rescan
[in] True - дерево полностью будет перестроено, False - только перерисовано

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Смотри также

Class Route, Group Трассы


Route.XYtoPkOffset (метод)

Преобразовать координаты из модельной системы координат в систему координат трассы (пикет, смещение)

Синтаксис

[Visual Basic 6]
Function XYtoPkOffset ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   Picket As Double, _
   Offset As Double _
) As Boolean

[Delphi]
function XYtoPkOffset(
   const ModelX: Double;
   const ModelY: Double;
   out Picket: Double;
   out Offset: Double
): WordBool

Описание параметров

ModelX
[in] Модельная X-координата точки
ModelY
[in] Модельная Y-координата точки
Picket
[out] Возвращаемое пикетажное положение точки
Offset
[out] Возвращаемое смещение точки от оси (отрицательные значения - слева, положительные - справа)

Возвращаемое значение

Результат операции: True - значения успешно возвращены, False - ошибка

Смотри также

Class Route, Group Трассы


Класс RouteElement

Элемент разбивки трассы (поперечник)

Наследование

BaseObject Class RouteElement

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Angle (только для чтения) | Касательная к трассе в точке оси
Property Application (только для чтения) | Приложение, в котором существует объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property InterpolatedZ (только для чтения) | Значение "интерполированной" земли в точке оси
Property PK (только для чтения) | Пикетажное положение элемента
Property Project (только для чтения) | Проект, к которому относится объект
Property SurfaceZ (только для чтения) | Значение "чёрной" земли в точке оси
Property X (только для чтения) | X-координата оси
Property Y (только для чтения) | Y-координата оси
Property Z | Z-координата оси

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Где используется

Класс | Член класса
Class IRoutesEvents | Method CrossectionInserted (метод) Method CrossectionInserting (метод)
Class Route | Property ActiveElement (свойство) Property Elements (свойство)
Class Routes | Event CrossectionInserted (событие) Event CrossectionInserting (событие)

Смотри также

Class Application, Class Project, Group Трассы


RouteElement.Angle (свойство)

Касательная к трассе в точке оси

Синтаксис

[Visual Basic 6]
ReadOnly Property Angle As Double

[Delphi]
{только для чтения} property Angle: Double

Смотри также

Class RouteElement, Group Трассы


RouteElement.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class RouteElement, Group Трассы


RouteElement.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class RouteElement, Group Трассы


RouteElement.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class RouteElement, Group Трассы


RouteElement.InterpolatedZ (свойство)

Значение "интерполированной" земли в точке оси

Синтаксис

[Visual Basic 6]
ReadOnly Property InterpolatedZ As Double

[Delphi]
{только для чтения} property InterpolatedZ: Double

Смотри также

Class RouteElement, Group Трассы


RouteElement.PK (свойство)

Пикетажное положение элемента

Синтаксис

[Visual Basic 6]
ReadOnly Property PK As Double

[Delphi]
{только для чтения} property PK: Double

Смотри также

Class RouteElement, Group Трассы


RouteElement.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class RouteElement, Group Трассы


RouteElement.SurfaceZ (свойство)

Значение "чёрной" земли в точке оси

Синтаксис

[Visual Basic 6]
ReadOnly Property SurfaceZ As Double

[Delphi]
{только для чтения} property SurfaceZ: Double

Смотри также

Class RouteElement, Group Трассы


RouteElement.X (свойство)

X-координата оси

Синтаксис

[Visual Basic 6]
ReadOnly Property X As Double

[Delphi]
{только для чтения} property X: Double

Смотри также

Class RouteElement, Group Трассы


RouteElement.Y (свойство)

Y-координата оси

Синтаксис

[Visual Basic 6]
ReadOnly Property Y As Double

[Delphi]
{только для чтения} property Y: Double

Смотри также

Class RouteElement, Group Трассы


RouteElement.Z (свойство)

Z-координата оси

Синтаксис

[Visual Basic 6]
Property Z As Double

[Delphi]
property Z: Double

Смотри также

Class RouteElement, Group Трассы


RouteElement.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class RouteElement, Group Трассы


RouteElement.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class RouteElement, Group Трассы


RouteElement.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class RouteElement, Group Трассы


RouteElement.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class RouteElement, Group Трассы


Класс RouteOptions

Параметры трассы

Наследование

CustomOptions Class RouteOptions

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property CarriagewayWidth | Ширина верха земляного полотна
Property Category (только для чтения) | Категория автомобильной дороги [1..5]
Property Color | Цвет отображения трассы в плане
Property CustomValueName (только для чтения) | Массив имён пользовательских значений
Property CustomValuesCount (только для чтения) | Количество пользовательских значений
Property PKStart | Пикет начала трассы
Property ShowStaticRightOfWay | Отображать ли в плане постоянную полосу отвода
Property ShowTemporaryRightOfWay | Отображать ли в плане временную полосу отвода
Property TrafficBackwardEnabled | Разрешено ли движение автомобилей в обратном направлении
Property TrafficForwardEnabled | Разрешено ли движение автомобилей в прямом направлении

Методы класса

Имя | Описание
Method DeleteCustomValue | Удалить из настроек пользовательское значение
Method GetCustomValue | Получить из настроек пользовательское значение
Method SetCustomValue | Запомнить в настройках пользовательское значение

Где используется

Класс | Член класса
Class Route | Property Options (свойство)

Смотри также

Group Трассы


RouteOptions.CarriagewayWidth (свойство)

Ширина верха земляного полотна

Синтаксис

[Visual Basic 6]
Property CarriagewayWidth As Double

[Delphi]
property CarriagewayWidth: Double

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.Category (свойство)

Категория автомобильной дороги [1..5]

Синтаксис

[Visual Basic 6]
ReadOnly Property Category As Long

[Delphi]
{только для чтения} property Category: Integer

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.Color (свойство)

Цвет отображения трассы в плане

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.CustomValueName (свойство)

Массив имён пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValueName As String

[Delphi]
{только для чтения} property CustomValueName: WideString

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.CustomValuesCount (свойство)

Количество пользовательских значений

Синтаксис

[Visual Basic 6]
ReadOnly Property CustomValuesCount As Long

[Delphi]
{только для чтения} property CustomValuesCount: Integer

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.PKStart (свойство)

Пикет начала трассы

Синтаксис

[Visual Basic 6]
Property PKStart As Double

[Delphi]
property PKStart: Double

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.ShowStaticRightOfWay (свойство)

Отображать ли в плане постоянную полосу отвода

Синтаксис

[Visual Basic 6]
Property ShowStaticRightOfWay As Boolean

[Delphi]
property ShowStaticRightOfWay: WordBool

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.ShowTemporaryRightOfWay (свойство)

Отображать ли в плане временную полосу отвода

Синтаксис

[Visual Basic 6]
Property ShowTemporaryRightOfWay As Boolean

[Delphi]
property ShowTemporaryRightOfWay: WordBool

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.TrafficBackwardEnabled (свойство)

Разрешено ли движение автомобилей в обратном направлении

Синтаксис

[Visual Basic 6]
Property TrafficBackwardEnabled As Boolean

[Delphi]
property TrafficBackwardEnabled: WordBool

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.TrafficForwardEnabled (свойство)

Разрешено ли движение автомобилей в прямом направлении

Синтаксис

[Visual Basic 6]
Property TrafficForwardEnabled As Boolean

[Delphi]
property TrafficForwardEnabled: WordBool

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.DeleteCustomValue (метод)

Удалить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Function DeleteCustomValue ( _
   ByVal Name As String _
) As Boolean

[Delphi]
function DeleteCustomValue(
   const Name: WideString
): WordBool

Описание параметров

Name
[in] Имя значения, подлежащего удалению

Возвращаемое значение

True - значение удалено, False - не найдено значения с указанным именем

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.GetCustomValue (метод)

Получить из настроек пользовательское значение

Синтаксис

[Visual Basic 6]
Sub GetCustomValue ( _
   ByVal Name As String, _
   ByVal DefaultValue As Variant _
)

[Delphi]
procedure GetCustomValue(
   const Name: WideString;
   const DefaultValue: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
DefaultValue
[in] Значение, которое будет возвращено, если в настройках не содержится ассоциациированного с указанным именем значения

Смотри также

Class RouteOptions, Group Трассы


RouteOptions.SetCustomValue (метод)

Запомнить в настройках пользовательское значение

Синтаксис

[Visual Basic 6]
Sub SetCustomValue ( _
   ByVal Name As String, _
   ByVal Value As Variant _
)

[Delphi]
procedure SetCustomValue(
   const Name: WideString;
   const Value: Variant
)

Описание параметров

Name
[in] Имя пользовательского значения
Value
[in] Значение, ассоциируемое с указанным именем

Смотри также

Class RouteOptions, Group Трассы


Класс RouteVertex

Вершина трассы

Наследование

BaseObject Class RouteVertex

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Angle | Угол поворота трассы в данной вершине (знаковый). Для начала и конца трассы значение азимута направления трассы
Property AngleToNext (только для чтения) | Направление на следующую вершину
Property AngleToPrev (только для чтения) | Направление на предыдущую вершину
Property Application (только для чтения) | Приложение, в котором существует объект
Property CurveBegin (только для чтения) | Пикет начала кривой с учётом начала трассы
Property CurveEnd (только для чтения) | Пикет конца кривой с учётом начала трассы
Property DistanceToNext | Расстояние до следующей вершины угла
Property DistanceToPrevious | Расстояние до предыдущей вершины угла
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Name (только для чтения) | Имя вершины угла
Property NextVertex (только для чтения) | Следующая вершина угла в трассе, либо Nothing, если вершина последняя
Property Parameter | Параметр вершины
Property PrevVertex (только для чтения) | Предыдущая вершина угла в трассе, либо Nothing, если вершина первая
Property Project (только для чтения) | Проект, к которому относится объект
Property T1 | Входящий тангенс вершины
Property T2 | Исходящий тангенс вершины
Property VertexClass | Класс вершины угла (Classic | Bezier3 | Bezier5)
Property X | X-координата вершины
Property Y | Y-координата вершины

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method ResetToSimple | Сбрасывает все параметры вершины так, чтобы длина кривой стала равной нулю

Где используется

Класс | Член класса
Class IRoutesEvents | Method VertexSelected (метод)
Class Route | Property ActiveVertex (свойство) Property FirstVertex (свойство) Property LastVertex (свойство) Property Vertices (свойство) Method CanDeleteVertex (метод) Method DeleteVertex (метод) Method InsertVertex (метод)
Class Routes | Event VertexSelected (событие)
Class RouteVertex | Property NextVertex (свойство) Property PrevVertex (свойство)

Смотри также

Class Application, Class Project, Group Трассы


RouteVertex.Angle (свойство)

Угол поворота трассы в данной вершине (знаковый). Для начала и конца трассы значение азимута направления трассы

Синтаксис

[Visual Basic 6]
Property Angle As Double

[Delphi]
property Angle: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.AngleToNext (свойство)

Направление на следующую вершину

Синтаксис

[Visual Basic 6]
ReadOnly Property AngleToNext As Double

[Delphi]
{только для чтения} property AngleToNext: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.AngleToPrev (свойство)

Направление на предыдущую вершину

Синтаксис

[Visual Basic 6]
ReadOnly Property AngleToPrev As Double

[Delphi]
{только для чтения} property AngleToPrev: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class RouteVertex, Group Трассы


RouteVertex.CurveBegin (свойство)

Пикет начала кривой с учётом начала трассы

Синтаксис

[Visual Basic 6]
ReadOnly Property CurveBegin As Double

[Delphi]
{только для чтения} property CurveBegin: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.CurveEnd (свойство)

Пикет конца кривой с учётом начала трассы

Синтаксис

[Visual Basic 6]
ReadOnly Property CurveEnd As Double

[Delphi]
{только для чтения} property CurveEnd: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.DistanceToNext (свойство)

Расстояние до следующей вершины угла

Синтаксис

[Visual Basic 6]
Property DistanceToNext As Double

[Delphi]
property DistanceToNext: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.DistanceToPrevious (свойство)

Расстояние до предыдущей вершины угла

Синтаксис

[Visual Basic 6]
Property DistanceToPrevious As Double

[Delphi]
property DistanceToPrevious: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.Name (свойство)

Имя вершины угла

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.NextVertex (свойство)

Следующая вершина угла в трассе, либо Nothing, если вершина последняя

Синтаксис

[Visual Basic 6]
ReadOnly Property NextVertex As RouteVertex

[Delphi]
{только для чтения} property NextVertex: RouteVertex

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.Parameter (свойство)

Параметр вершины

Синтаксис

[Visual Basic 6]
Property Parameter As Double

[Delphi]
property Parameter: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.PrevVertex (свойство)

Предыдущая вершина угла в трассе, либо Nothing, если вершина первая

Синтаксис

[Visual Basic 6]
ReadOnly Property PrevVertex As RouteVertex

[Delphi]
{только для чтения} property PrevVertex: RouteVertex

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class RouteVertex, Group Трассы


RouteVertex.T1 (свойство)

Входящий тангенс вершины

Синтаксис

[Visual Basic 6]
Property T1 As Double

[Delphi]
property T1: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.T2 (свойство)

Исходящий тангенс вершины

Синтаксис

[Visual Basic 6]
Property T2 As Double

[Delphi]
property T2: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.VertexClass (свойство)

Класс вершины угла (Classic | Bezier3 | Bezier5)

Синтаксис

[Visual Basic 6]
Property VertexClass As String

[Delphi]
property VertexClass: WideString

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.X (свойство)

X-координата вершины

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.Y (свойство)

Y-координата вершины

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class RouteVertex, Group Трассы


RouteVertex.ResetToSimple (метод)

Сбрасывает все параметры вершины так, чтобы длина кривой стала равной нулю

Синтаксис

[Visual Basic 6]
Sub ResetToSimple

[Delphi]
procedure ResetToSimple

Смотри также

Class RouteVertex, Group Трассы


Класс Routes

Список трасс в проекте

Наследование

BaseObject Class Routes

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ActiveRoute | Активная (текущая) трасса
Property Application (только для чтения) | Приложение, в котором существует объект
Property Count (только для чтения) | Количество объектов, которое содержит в себе данный объект
Property Handle (только для чтения) | Handle объекта
Property HighlightActivePicket | Подсвечивать ли активный поперечный профиль в плане
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Массив объектов (нумерация идёт от 0 до Count-1)
Property Project (только для чтения) | Проект, к которому относится объект
Property Routes (только для чтения) | Массив трасс (нумерация идёт от 0 до Count-1)
Property ShowVertexCaptions | Отображать ли подписи вершин углов на плане
Property Visible | Отображаются ли в данный момент трассы на плане

Методы класса

Имя | Описание
Method Advise | Подключиться к событиям списка трасс (возвращаемое число нужно впоследствии передать в Unadvise)
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Clear | Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект
Method CreateRoute | Создаёт новую трассу с заданными координатами начала/конца трассы, добавляет её в список и возвращает указатель на неё
Method Delete | Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetNearestRoute | Возвращает трассу, ближайшую к заданным координатам
Method GetRouteByName | Получить трассу по имени или ID
Method Unadvise | Отключиться от событий списка трасс (передаваемое число ранее должно быть получено от Advise)

События класса

Имя | Описание
Method AnalogModelChanged | Событие при изменении геометрии тассы в плане
Method CrossectionDeleted | Событие, вызываемое после удаления элемента из трассы
Method CrossectionDeleting | Событие, вызываемое непосредственно перед удалением элемента из трассы
Method CrossectionInserted | Событие, вызываемое после добавления элемента в трассу
Method CrossectionInserting | Событие, вызываемое перед добавлением элемента в трассу
Method DigitalModelChanged | Событие при изменении цифровой модели трассы
Method NewRoute | Событие при создании новой трассы
Method RouteActivate | Событие при активизации трассы
Method RouteCloned | Событие вызываемое при клонировании трассы
Method RouteDeleting | Событие вызываемое непосредственно перед удалением трассы
Method RouteParamsChanged | Событие вызываемое при изменении параметров трассы
Method SelectionChanged | Событие, вызываемое при изменении активного элемента трассы на трассе, либо при изменении выделенного диапазона
Method SpacedOut | Событие, вызываемое после разбивки трассы
Method SurfaceModified | Событие, вызываемое при изменении поверхности, назначенной как существующая для данной трассы
Method UnSpacedOut | Событие, вызываемое после удаления разбивки
Method VertexSelected | Событие, вызываемое при изменении активной вершины трассы

Где используется

Класс | Член класса
Class Project | Property Routes (свойство)
Class Route | Property Routes (свойство)

Смотри также

Class Application, Class BaseObject, Interface IRoutesEvents, Class RouteElement, Enum RouteModelModifiedConstants, Class RouteVertex, Group Трассы


Routes.ActiveRoute (свойство)

Активная (текущая) трасса

Синтаксис

[Visual Basic 6]
Property ActiveRoute As Route

[Delphi]
property ActiveRoute: Route

Смотри также

Class Route, Class Routes, Group Трассы


Routes.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class Routes, Group Трассы


Routes.Count (свойство)

Количество объектов, которое содержит в себе данный объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class Routes, Group Трассы


Routes.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Routes, Group Трассы


Routes.HighlightActivePicket (свойство)

Подсвечивать ли активный поперечный профиль в плане

Синтаксис

[Visual Basic 6]
Property HighlightActivePicket As Boolean

[Delphi]
property HighlightActivePicket: WordBool

Смотри также

Class Routes, Group Трассы


Routes.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class Routes, Group Трассы


Routes.Items (свойство)

Массив объектов (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BaseObject

[Delphi]
{только для чтения} property Items: BaseObject

Смотри также

Class BaseObject, Class Routes, Group Трассы


Routes.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class Routes, Group Трассы


Routes.Routes (свойство)

Массив трасс (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Routes As Route

[Delphi]
{только для чтения} property Routes: Route

Смотри также

Class Route, Class Routes, Group Трассы


Routes.ShowVertexCaptions (свойство)

Отображать ли подписи вершин углов на плане

Синтаксис

[Visual Basic 6]
Property ShowVertexCaptions As Boolean

[Delphi]
property ShowVertexCaptions: WordBool

Смотри также

Class Routes, Group Трассы


Routes.Visible (свойство)

Отображаются ли в данный момент трассы на плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Routes, Group Трассы


Routes.Advise (метод)

Подключиться к событиям списка трасс (возвращаемое число нужно впоследствии передать в Unadvise)

Синтаксис

[Visual Basic 6]
Function Advise ( _
   ByVal EventHandler As IRoutesEvents _
) As Long

[Delphi]
function Advise(
   const EventHandler: IRoutesEvents
): Integer

Описание параметров

EventHandler
[in] Обработчик событий списка трасс

Возвращаемое значение

Возвращает код соединения, который нужно впоследствии передать в метод Unadvise

Смотри также

Interface IRoutesEvents, Class Routes, Group Трассы


Routes.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class Routes, Group Трассы


Routes.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class Routes, Group Трассы


Routes.Clear (метод)

Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class Routes, Group Трассы


Routes.CreateRoute (метод)

Создаёт новую трассу с заданными координатами начала/конца трассы, добавляет её в список и возвращает указатель на неё

Синтаксис

[Visual Basic 6]
Function CreateRoute ( _
   ByVal RouteName As String, _
   ByVal StartX As Double, _
   ByVal StartY As Double, _
   ByVal EndX As Double, _
   ByVal EndY As Double _
) As Route

[Delphi]
function CreateRoute(
   const RouteName: WideString;
   const StartX: Double;
   const StartY: Double;
   const EndX: Double;
   const EndY: Double
): Route

Описание параметров

RouteName
[in] Имя создаваемой трассы
StartX
[in] X-координата начала трассы
StartY
[in] Y-координата начала трассы
EndX
[in] X-координата конца трассы
EndY
[in] Y-координата конца трассы

Возвращаемое значение

Созданная трасса, либо Nothing в случае ошибки

Смотри также

Class Route, Class Routes, Group Трассы


Routes.Delete (метод)

Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс объекта (нумерация идёт от 0 до Count-1)

Смотри также

Class Routes, Group Трассы


Routes.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class Routes, Group Трассы


Routes.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class Routes, Group Трассы


Routes.GetNearestRoute (метод)

Возвращает трассу, ближайшую к заданным координатам

Синтаксис

[Visual Basic 6]
Function GetNearestRoute ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Route

[Delphi]
function GetNearestRoute(
   const X: Double;
   const Y: Double
): Route

Описание параметров

X
[in] X-координана точки, для которой необходимо найти ближайшую трассу
Y
[in] Y-координана точки, для которой необходимо найти ближайшую трассу

Возвращаемое значение

Трасса, ближайшая к указанной точке, либо Nothing, если такой не было найдено

Смотри также

Class Route, Class Routes, Group Трассы


Routes.GetRouteByName (метод)

Получить трассу по имени или ID

Синтаксис

[Visual Basic 6]
Function GetRouteByName ( _
   ByVal Name As String _
) As Route

[Delphi]
function GetRouteByName(
   const Name: WideString
): Route

Описание параметров

Name
[in] Имя или ID запрашиваемой трассы

Возвращаемое значение

Функция возвращает значение типа Route.

Смотри также

Class Route, Class Routes, Group Трассы


Routes.Unadvise (метод)

Отключиться от событий списка трасс (передаваемое число ранее должно быть получено от Advise)

Синтаксис

[Visual Basic 6]
Sub Unadvise ( _
   ByVal Cookie As Long _
)

[Delphi]
procedure Unadvise(
   const Cookie: Integer
)

Описание параметров

Cookie
[in] Код, возвращённый методом Advise)

Смотри также

Class Routes, Group Трассы


Routes.AnalogModelChanged (метод)

Событие при изменении геометрии тассы в плане

Синтаксис

[Visual Basic 6]
Event AnalogModelChanged ( _
   ByVal Route As Route _
)

[Delphi]
procedure AnalogModelChanged(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, у которой изменилась геометрия в плане

Смотри также

Class Route, Class Routes, Group Трассы


Routes.CrossectionDeleted (метод)

Событие, вызываемое после удаления элемента из трассы

Синтаксис

[Visual Basic 6]
Event CrossectionDeleted ( _
   ByVal Route As Route, _
   ByVal Index As Long _
)

[Delphi]
procedure CrossectionDeleted(
   const Route: Route;
   const Index: Integer
)

Описание параметров

Route
[in] Трасса, элемент которой был удалён
Index
[in] Индекс удалённого элемента трассы

Смотри также

Class Route, Class Routes, Group Трассы


Routes.CrossectionDeleting (метод)

Событие, вызываемое непосредственно перед удалением элемента из трассы

Синтаксис

[Visual Basic 6]
Event CrossectionDeleting ( _
   ByVal Route As Route, _
   ByVal Index As Long _
)

[Delphi]
procedure CrossectionDeleting(
   const Route: Route;
   const Index: Integer
)

Описание параметров

Route
[in] Трасса, элемент которой будет удалён
Index
[in] Индекс элемента трассы, подлежащего удалению

Смотри также

Class Route, Class Routes, Group Трассы


Routes.CrossectionInserted (метод)

Событие, вызываемое после добавления элемента в трассу

Синтаксис

[Visual Basic 6]
Event CrossectionInserted ( _
   ByVal Route As Route, _
   ByVal Element As RouteElement, _
   ByVal Index As Long _
)

[Delphi]
procedure CrossectionInserted(
   const Route: Route;
   const Element: RouteElement;
   const Index: Integer
)

Описание параметров

Route
[in] Трасса, в модель которой добавлен элемент разбивки
Element
[in] Элемент, добавленный в массив элементов
Index
[in] Порядковый номер в массиве элементов, который имеет добавленный элемент

Смотри также

Class Route, Class RouteElement, Class Routes, Group Трассы


Routes.CrossectionInserting (метод)

Событие, вызываемое перед добавлением элемента в трассу

Синтаксис

[Visual Basic 6]
Event CrossectionInserting ( _
   ByVal Route As Route, _
   ByVal Element As RouteElement, _
   ByVal Index As Long, _
   ByVal InterpolateParams As Boolean _
)

[Delphi]
procedure CrossectionInserting(
   const Route: Route;
   const Element: RouteElement;
   const Index: Integer;
   const InterpolateParams: WordBool
)

Описание параметров

Route
[in] Трасса, в модель которой добавляется элемент разбивки
Element
[in] Добавляемый элемент разбивки
Index
[in] Порядковый номер в массиве элементов, который будет иметь добавляемый элемент
InterpolateParams
[in] True- Параметры данного элемента необходимо интерполировать между соседними элементами, False - параметры нужно выставить в значения по умолчанию

Смотри также

Class Route, Class RouteElement, Class Routes, Group Трассы


Routes.DigitalModelChanged (метод)

Событие при изменении цифровой модели трассы

Синтаксис

[Visual Basic 6]
Event DigitalModelChanged ( _
   ByVal Route As Route, _
   ByVal ChangedFrom As Long, _
   ByVal ChangedTo As Long, _
   ByVal Flags As RouteModelModifiedConstants _
)

[Delphi]
procedure DigitalModelChanged(
   const Route: Route;
   const ChangedFrom: Integer;
   const ChangedTo: Integer;
   const Flags: RouteModelModifiedConstants
)

Описание параметров

Route
[in] Трасса, цифровая модель которой изменилась
ChangedFrom
[in] Индекс начального из изменённых элементов трассы
ChangedTo
[in] Индекс конечного из изменённых элементов трассы
Flags
[in] Комбинация флагов, по которой можно определить, что изменилось в элементах трассы

Смотри также

Class Route, Enum RouteModelModifiedConstants, Class Routes, Group Трассы


Routes.NewRoute (метод)

Событие при создании новой трассы

Синтаксис

[Visual Basic 6]
Event NewRoute ( _
   ByVal Route As Route _
)

[Delphi]
procedure NewRoute(
   const Route: Route
)

Описание параметров

Route
[in] Созданная трасса

Смотри также

Class Route, Class Routes, Group Трассы


Routes.RouteActivate (метод)

Событие при активизации трассы

Синтаксис

[Visual Basic 6]
Event RouteActivate ( _
   ByVal Route As Route _
)

[Delphi]
procedure RouteActivate(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, ставшая активной

Смотри также

Class Route, Class Routes, Group Трассы


Routes.RouteCloned (метод)

Событие вызываемое при клонировании трассы

Синтаксис

[Visual Basic 6]
Event RouteCloned ( _
   ByVal Route As Route _
)

[Delphi]
procedure RouteCloned(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, полученная в результате клонирования

Смотри также

Class Route, Class Routes, Group Трассы


Routes.RouteDeleting (метод)

Событие вызываемое непосредственно перед удалением трассы

Синтаксис

[Visual Basic 6]
Event RouteDeleting ( _
   ByVal Route As Route _
)

[Delphi]
procedure RouteDeleting(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, которая будет удалена

Смотри также

Class Route, Class Routes, Group Трассы


Routes.RouteParamsChanged (метод)

Событие вызываемое при изменении параметров трассы

Синтаксис

[Visual Basic 6]
Event RouteParamsChanged ( _
   ByVal Route As Route _
)

[Delphi]
procedure RouteParamsChanged(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, параметры которой были изменены

Смотри также

Class Route, Class Routes, Group Трассы


Routes.SelectionChanged (метод)

Событие, вызываемое при изменении активного элемента трассы на трассе, либо при изменении выделенного диапазона

Синтаксис

[Visual Basic 6]
Event SelectionChanged ( _
   ByVal Route As Route, _
   ByVal SelectedFrom As Long, _
   ByVal SelectedTo As Long, _
   ByVal ActiveElementIndex As Long _
)

[Delphi]
procedure SelectionChanged(
   const Route: Route;
   const SelectedFrom: Integer;
   const SelectedTo: Integer;
   const ActiveElementIndex: Integer
)

Описание параметров

Route
[in] Трасса, для которой вызывается событие
SelectedFrom
[in] Индекс начального элемента трассы среди выделенных
SelectedTo
[in] Индекс конечного элемента трассы среди выделенных
ActiveElementIndex
[in] Индекс выделенного элемента трассы

Смотри также

Class Route, Class Routes, Group Трассы


Routes.SpacedOut (метод)

Событие, вызываемое после разбивки трассы

Синтаксис

[Visual Basic 6]
Event SpacedOut ( _
   ByVal Route As Route _
)

[Delphi]
procedure SpacedOut(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, которая была разбита на поперечные профили

Смотри также

Class Route, Class Routes, Group Трассы


Routes.SurfaceModified (метод)

Событие, вызываемое при изменении поверхности, назначенной как существующая для данной трассы

Синтаксис

[Visual Basic 6]
Event SurfaceModified ( _
   ByVal Route As Route _
)

[Delphi]
procedure SurfaceModified(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, для которой вызывается событие

Смотри также

Class Route, Class Routes, Group Трассы


Routes.UnSpacedOut (метод)

Событие, вызываемое после удаления разбивки

Синтаксис

[Visual Basic 6]
Event UnSpacedOut ( _
   ByVal Route As Route _
)

[Delphi]
procedure UnSpacedOut(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, разбивка которой была уничтожена

Смотри также

Class Route, Class Routes, Group Трассы


Routes.VertexSelected (метод)

Событие, вызываемое при изменении активной вершины трассы

Синтаксис

[Visual Basic 6]
Event VertexSelected ( _
   ByVal Route As Route, _
   ByVal RouteVertex As RouteVertex _
)

[Delphi]
procedure VertexSelected(
   const Route: Route;
   const RouteVertex: RouteVertex
)

Описание параметров

Route
[in] Трасса, у которой изменилась активная вершина угла
RouteVertex
[in] Вершина трассы, ставшая активной

Смотри также

Class Route, Class Routes, Class RouteVertex, Group Трассы


Класс ShapeField

Атрибут текущей записи шейп-файла

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AsBoolean | Значение атрибута в виде логического значения
Property AsDate | Значение атрибута в виде даты
Property AsDouble | Значение атрибута в виде вещественного числа
Property AsInteger | Значение атрибута в виде целого числа
Property AsRaw | Значение атрибута в том виде, как оно хранится в DBF-файле
Property AsString | Значение атрибута в виде строки
Property FieldKind (только для чтения) | Тип поля
Property Name (только для чтения) | Название атрибута
Property Offset (только для чтения) | Смещение атрибута в записи DBF
Property Scale (только для чтения) | Число цифр после запятой для вещественных чисел
Property Size (только для чтения) | Размер атрибута в записи DBF (это же число цифр числа)

Где используется

Класс | Член класса
Class ShapeFile | Property Fields (свойство) Method FieldByName (метод)

Смотри также

Enum ShapeFieldConstants, Group Шейп-файлы


ShapeField.AsBoolean (свойство)

Значение атрибута в виде логического значения

Синтаксис

[Visual Basic 6]
Property AsBoolean As Boolean

[Delphi]
property AsBoolean: WordBool

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.AsDate (свойство)

Значение атрибута в виде даты

Синтаксис

[Visual Basic 6]
Property AsDate As Date

[Delphi]
property AsDate: TDateTime

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.AsDouble (свойство)

Значение атрибута в виде вещественного числа

Синтаксис

[Visual Basic 6]
Property AsDouble As Double

[Delphi]
property AsDouble: Double

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.AsInteger (свойство)

Значение атрибута в виде целого числа

Синтаксис

[Visual Basic 6]
Property AsInteger As Long

[Delphi]
property AsInteger: Integer

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.AsRaw (свойство)

Значение атрибута в том виде, как оно хранится в DBF-файле

Синтаксис

[Visual Basic 6]
Property AsRaw As String

[Delphi]
property AsRaw: WideString

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.AsString (свойство)

Значение атрибута в виде строки

Синтаксис

[Visual Basic 6]
Property AsString As String

[Delphi]
property AsString: WideString

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.FieldKind (свойство)

Тип поля

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldKind As ShapeFieldConstants

[Delphi]
{только для чтения} property FieldKind: ShapeFieldConstants

Смотри также

Class ShapeField, Enum ShapeFieldConstants, Group Шейп-файлы


ShapeField.Name (свойство)

Название атрибута

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.Offset (свойство)

Смещение атрибута в записи DBF

Синтаксис

[Visual Basic 6]
ReadOnly Property Offset As Long

[Delphi]
{только для чтения} property Offset: Integer

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.Scale (свойство)

Число цифр после запятой для вещественных чисел

Синтаксис

[Visual Basic 6]
ReadOnly Property Scale As Byte

[Delphi]
{только для чтения} property Scale: Byte

Смотри также

Class ShapeField, Group Шейп-файлы


ShapeField.Size (свойство)

Размер атрибута в записи DBF (это же число цифр числа)

Синтаксис

[Visual Basic 6]
ReadOnly Property Size As Long

[Delphi]
{только для чтения} property Size: Integer

Смотри также

Class ShapeField, Group Шейп-файлы


Класс ShapeFigure

Фигура шейп-файла

Наследование

Figure Class ShapeFigure Class ShapeMultipart, ShapeMultipoint, ShapeMultipointM, ShapeMultipointZ, ShapePoint, ShapePointM, ShapePointZ, ShapePolygon, ShapePolygonM, ShapePolygonZ, ShapePolyline, ShapePolylineM, ShapePolylineZ

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Owner (только для чтения) | Список-владелец данной фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class ShapeFigure | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapeFile | Property Shape (свойство) Method CreateEmptyShape (метод)
Class ShapeMultipart | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapeMultipoint | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapeMultipointM | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapeMultipointZ | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePoint | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePointM | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePointZ | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePolygon | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePolygonM | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePolygonZ | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePolyline | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePolylineM | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)
Class ShapePolylineZ | Method CloneShape (метод) Method DistanceToShape (метод) Method IsInsideShape (метод) Method IsIntersectedWith (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Enum ShapeTypeConstants, Group Фигуры


ShapeFigure.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapeFigure, Group Фигуры


ShapeFigure.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapeFigure, Group Фигуры


ShapeFigure.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapeFigure.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapeFigure, Group Фигуры


ShapeFigure.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapeFigure, Group Фигуры


ShapeFigure.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapeFigure, Group Фигуры


ShapeFigure.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapeFigure, Group Фигуры


ShapeFigure.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapeFigure, Group Фигуры


ShapeFigure.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapeFigure, Group Фигуры


ShapeFigure.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapeFigure, Group Фигуры


ShapeFigure.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapeFigure, Group Фигуры


ShapeFigure.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapeFigure, Group Фигуры


ShapeFigure.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapeFigure, Group Фигуры


Класс ShapeFile

Шейп-файл

Наследование

FigureBase Class ShapeFile

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapeFile

ClassID = {6010001A-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий все фигуры прямоугольник
Property Caption (только для чтения) | Название базы фигур
Property Current | Номер текущей записи в главном шейп-файле
Property FieldCount (только для чтения) | Число атрибутов в DBF-файле
Property Fields (только для чтения) | Поля текщуей записи шейп-файла
Property FigureSetCount (только для чтения) | Количество наборов фигур в базе
Property FigureSets (только для чтения) | Массив наборов фигур в базе (наборы фигур рисуются от последнего к первому) (индексы должны иметь номера от 0 до FigureSetCount-1)
Property FileName (только для чтения) | Имя шейп-файла
Property LastOpenErrorCount (только для чтения) | Количество ошибок при последнем открытии шейп-файла
Property Modified | Произошли ли какие-либо изменения фигур
Property Multipoint (только для чтения) | Текущая фигура как мультиточка
Property Point (только для чтения) | Текущая фигура как точка
Property Polygon (только для чтения) | Текущая фигура как полигон
Property Polyline (только для чтения) | Текущая фигура как линия
Property Shape | Текущая фигура
Property ShapeType (только для чтения) | Тип примитивов в шейп-файле
Property SimpleType (только для чтения) | Тип примитивов в шейп-файле, приведённый к двумерным (без меры и высотных отметок)
Property UseIndexFile | Игнорировать ли при открытии шейп-файла ошибки и использовать ли индекс

Методы класса

Имя | Описание
Method Append | Добавить новую запись
Method Clear | Удалить все записи
Method Close | Закрыть шейп-файл
Method ConvertToFile | Конвертировать в другой тип шейп-файла и записать копию в новый файл
Method CreateEmptyShape | Создаёт новую пустую фигуру, но пока не добавляет её в шейп-файл
Method CreateNew | Создать новый шейп-файл указанного типа в указанном файле
Method CreateNewField | Создать в DBF-файле новый атрибут
Method CreateNewLike | Создать новый шейп со структурой, взятой у другого шейп-файла
Method CreateNewTemporal | Создать новый шейп-файл указанного типа в памяти
Method Delete | Удалить текущую запись
Method DeleteAllFields | Удалить в DBF-файле все атрибуты
Method FieldByName | Получение поля по его имени (если нет, то пусто)
Method HasM | Имеет ли фигуры шейп-файла меру M
Method HasZ | Имеет ли фигуры шейп-файла координату Z
Method OpenFromFile | Открыть существующий шейп-файл
Method Save | Сохраниться в старый файл
Method SaveAsToFile | Сохраниться в новый файл
Method SaveCopyToFile | Сохранить копию в файл (поле FileName шейп-файла не изменяется)

Где используется

Класс | Член класса
Class ShapeFile | Method CreateNewLike (метод)

Смотри также

Class FigureSet, Class ModelRect, Class ShapeField, Enum ShapeFieldConstants, Class ShapeFigure, Class ShapeMultipoint, Class ShapePoint, Class ShapePolygon, Class ShapePolyline, Enum ShapeTypeConstants, Group Шейп-файлы


ShapeFile.Bounds (свойство)

Минимальный объемлющий все фигуры прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapeFile, Group Шейп-файлы


ShapeFile.Caption (свойство)

Название базы фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.Current (свойство)

Номер текущей записи в главном шейп-файле

Синтаксис

[Visual Basic 6]
Property Current As Long

[Delphi]
property Current: Integer

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.FieldCount (свойство)

Число атрибутов в DBF-файле

Синтаксис

[Visual Basic 6]
ReadOnly Property FieldCount As Long

[Delphi]
{только для чтения} property FieldCount: Integer

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.Fields (свойство)

Поля текщуей записи шейп-файла

Синтаксис

[Visual Basic 6]
ReadOnly Property Fields As ShapeField

[Delphi]
{только для чтения} property Fields: ShapeField

Смотри также

Class ShapeField, Class ShapeFile, Group Шейп-файлы


ShapeFile.FigureSetCount (свойство)

Количество наборов фигур в базе

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureSetCount As Long

[Delphi]
{только для чтения} property FigureSetCount: Integer

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.FigureSets (свойство)

Массив наборов фигур в базе (наборы фигур рисуются от последнего к первому) (индексы должны иметь номера от 0 до FigureSetCount-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureSets As FigureSet

[Delphi]
{только для чтения} property FigureSets: FigureSet

Смотри также

Class FigureSet, Class ShapeFile, Group Шейп-файлы


ShapeFile.FileName (свойство)

Имя шейп-файла

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.LastOpenErrorCount (свойство)

Количество ошибок при последнем открытии шейп-файла

Синтаксис

[Visual Basic 6]
ReadOnly Property LastOpenErrorCount As Long

[Delphi]
{только для чтения} property LastOpenErrorCount: Integer

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.Modified (свойство)

Произошли ли какие-либо изменения фигур

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.Multipoint (свойство)

Текущая фигура как мультиточка

Синтаксис

[Visual Basic 6]
ReadOnly Property Multipoint As ShapeMultipoint

[Delphi]
{только для чтения} property Multipoint: ShapeMultipoint

Смотри также

Class ShapeFile, Class ShapeMultipoint, Group Шейп-файлы


ShapeFile.Point (свойство)

Текущая фигура как точка

Синтаксис

[Visual Basic 6]
ReadOnly Property Point As ShapePoint

[Delphi]
{только для чтения} property Point: ShapePoint

Смотри также

Class ShapeFile, Class ShapePoint, Group Шейп-файлы


ShapeFile.Polygon (свойство)

Текущая фигура как полигон

Синтаксис

[Visual Basic 6]
ReadOnly Property Polygon As ShapePolygon

[Delphi]
{только для чтения} property Polygon: ShapePolygon

Смотри также

Class ShapeFile, Class ShapePolygon, Group Шейп-файлы


ShapeFile.Polyline (свойство)

Текущая фигура как линия

Синтаксис

[Visual Basic 6]
ReadOnly Property Polyline As ShapePolyline

[Delphi]
{только для чтения} property Polyline: ShapePolyline

Смотри также

Class ShapeFile, Class ShapePolyline, Group Шейп-файлы


ShapeFile.Shape (свойство)

Текущая фигура

Синтаксис

[Visual Basic 6]
Property Shape As ShapeFigure

[Delphi]
property Shape: ShapeFigure

Смотри также

Class ShapeFigure, Class ShapeFile, Group Шейп-файлы


ShapeFile.ShapeType (свойство)

Тип примитивов в шейп-файле

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapeFile, Enum ShapeTypeConstants, Group Шейп-файлы


ShapeFile.SimpleType (свойство)

Тип примитивов в шейп-файле, приведённый к двумерным (без меры и высотных отметок)

Синтаксис

[Visual Basic 6]
ReadOnly Property SimpleType As ShapeTypeConstants

[Delphi]
{только для чтения} property SimpleType: ShapeTypeConstants

Смотри также

Class ShapeFile, Enum ShapeTypeConstants, Group Шейп-файлы


ShapeFile.UseIndexFile (свойство)

Игнорировать ли при открытии шейп-файла ошибки и использовать ли индекс

Синтаксис

[Visual Basic 6]
Property UseIndexFile As Boolean

[Delphi]
property UseIndexFile: WordBool

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.Append (метод)

Добавить новую запись

Синтаксис

[Visual Basic 6]
Sub Append

[Delphi]
procedure Append

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.Clear (метод)

Удалить все записи

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.Close (метод)

Закрыть шейп-файл

Синтаксис

[Visual Basic 6]
Sub Close

[Delphi]
procedure Close

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.ConvertToFile (метод)

Конвертировать в другой тип шейп-файла и записать копию в новый файл

Синтаксис

[Visual Basic 6]
Sub ConvertToFile ( _
   ByVal NewShapeType As ShapeTypeConstants, _
   ByVal NewFileName As String _
)

[Delphi]
procedure ConvertToFile(
   const NewShapeType: ShapeTypeConstants;
   const NewFileName: WideString
)

Описание параметров

NewShapeType
[in] Тип нового шейп-файла
NewFileName
[in] Имя файла

Смотри также

Class ShapeFile, Enum ShapeTypeConstants, Group Шейп-файлы


ShapeFile.CreateEmptyShape (метод)

Создаёт новую пустую фигуру, но пока не добавляет её в шейп-файл

Синтаксис

[Visual Basic 6]
Function CreateEmptyShape As ShapeFigure

[Delphi]
function CreateEmptyShape: ShapeFigure

Возвращаемое значение

Возвращает новую пустую шейп-фигуру

Смотри также

Class ShapeFigure, Class ShapeFile, Group Шейп-файлы


ShapeFile.CreateNew (метод)

Создать новый шейп-файл указанного типа в указанном файле

Синтаксис

[Visual Basic 6]
Sub CreateNew ( _
   ByVal FileName As String, _
   ByVal ShapeType As ShapeTypeConstants _
)

[Delphi]
procedure CreateNew(
   const FileName: WideString;
   const ShapeType: ShapeTypeConstants
)

Описание параметров

FileName
[in] Имя создаваемого файла
ShapeType
[in] Тип создаваемого шейп-файла

Смотри также

Class ShapeFile, Enum ShapeTypeConstants, Group Шейп-файлы


ShapeFile.CreateNewField (метод)

Создать в DBF-файле новый атрибут

Синтаксис

[Visual Basic 6]
Sub CreateNewField ( _
   ByVal FieldName As String, _
   [ByVal FieldKind As ShapeFieldConstants = 2], _
   [ByVal Size As Long = 16], _
   [ByVal Scale As Long = 0] _
)

[Delphi]
procedure CreateNewField(
   const FieldName: WideString;
   const FieldKind: ShapeFieldConstants;
   const Size: Integer;
   const Scale: Integer
)

Описание параметров

FieldName
[in] Имя поля шейп-файла
FieldKind
[in] Тип поля шейп-файла
Size
[in] Размер поля шейп-файла
Scale
[in] Количество цифр после запятой для вещественных чисел в поле шейп-файла

Смотри также

Enum ShapeFieldConstants, Class ShapeFile, Group Шейп-файлы


ShapeFile.CreateNewLike (метод)

Создать новый шейп со структурой, взятой у другого шейп-файла

Синтаксис

[Visual Basic 6]
Sub CreateNewLike ( _
   ByVal ShapeType As ShapeTypeConstants, _
   ByVal SourceShapeFile As ShapeFile _
)

[Delphi]
procedure CreateNewLike(
   const ShapeType: ShapeTypeConstants;
   const SourceShapeFile: ShapeFile
)

Описание параметров

ShapeType
[in] Тип создаваемого шейп-файла
SourceShapeFile
[in] Шейп-файл, из которого копируются список атрибутов

Смотри также

Class ShapeFile, Enum ShapeTypeConstants, Group Шейп-файлы


ShapeFile.CreateNewTemporal (метод)

Создать новый шейп-файл указанного типа в памяти

Синтаксис

[Visual Basic 6]
Sub CreateNewTemporal ( _
   ByVal ShapeType As ShapeTypeConstants _
)

[Delphi]
procedure CreateNewTemporal(
   const ShapeType: ShapeTypeConstants
)

Описание параметров

ShapeType
[in] Тип создаваемого шейп-файла

Смотри также

Class ShapeFile, Enum ShapeTypeConstants, Group Шейп-файлы


ShapeFile.Delete (метод)

Удалить текущую запись

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.DeleteAllFields (метод)

Удалить в DBF-файле все атрибуты

Синтаксис

[Visual Basic 6]
Sub DeleteAllFields

[Delphi]
procedure DeleteAllFields

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.FieldByName (метод)

Получение поля по его имени (если нет, то пусто)

Синтаксис

[Visual Basic 6]
Function FieldByName ( _
   ByVal FieldName As String _
) As ShapeField

[Delphi]
function FieldByName(
   const FieldName: WideString
): ShapeField

Описание параметров

FieldName
[in] Имя поля

Возвращаемое значение

Возвращает поле шейп-файла для указанного имени, либо Nothing, если такого поля не существует

Смотри также

Class ShapeField, Class ShapeFile, Group Шейп-файлы


ShapeFile.HasM (метод)

Имеет ли фигуры шейп-файла меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигуры шейп-файла имеют меру M

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.HasZ (метод)

Имеет ли фигуры шейп-файла координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигуры шейп-файла имеют координаты Z

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.OpenFromFile (метод)

Открыть существующий шейп-файл

Синтаксис

[Visual Basic 6]
Sub OpenFromFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure OpenFromFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя открываемого файла

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.Save (метод)

Сохраниться в старый файл

Синтаксис

[Visual Basic 6]
Sub Save

[Delphi]
procedure Save

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.SaveAsToFile (метод)

Сохраниться в новый файл

Синтаксис

[Visual Basic 6]
Sub SaveAsToFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveAsToFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла

Смотри также

Class ShapeFile, Group Шейп-файлы


ShapeFile.SaveCopyToFile (метод)

Сохранить копию в файл (поле FileName шейп-файла не изменяется)

Синтаксис

[Visual Basic 6]
Sub SaveCopyToFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveCopyToFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла

Смотри также

Class ShapeFile, Group Шейп-файлы


Класс ShapeMultipart

Шейп-фигура с несколькими контурами

Наследование

Figure Class ShapeMultipart Class ShapePolygon, ShapePolygonM, ShapePolygonZ, ShapePolyline, ShapePolylineM, ShapePolylineZ

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PartCounts | Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры
Property PartNumber | Число независимых частей, из которых состоит фигура
Property PointNumber (только для чтения) | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в последний контур фигуры
Method AddPointM | Добавить дополнительную точку с мерой в последний контур фигуры
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetPartPoints | Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetParts | Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapeMultipart.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapeMultipart, Group Фигуры


ShapeMultipart.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapeMultipart, Group Фигуры


ShapeMultipart.PartCounts (свойство)

Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры

Синтаксис

[Visual Basic 6]
Property PartCounts As Long

[Delphi]
property PartCounts: Integer

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.PartNumber (свойство)

Число независимых частей, из которых состоит фигура

Синтаксис

[Visual Basic 6]
Property PartNumber As Long

[Delphi]
property PartNumber: Integer

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
ReadOnly Property PointNumber As Long

[Delphi]
{только для чтения} property PointNumber: Integer

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapeMultipart, Group Фигуры


ShapeMultipart.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapeMultipart, Enum ShapeTypeConstants, Group Фигуры


ShapeMultipart.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.AddPoint (метод)

Добавить дополнительную точку в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.AddPointM (метод)

Добавить дополнительную точку с мерой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapeMultipart, Group Фигуры


ShapeMultipart.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapeMultipart, Group Фигуры


ShapeMultipart.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapeMultipart, Group Фигуры


ShapeMultipart.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapeMultipart, Group Фигуры


ShapeMultipart.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapeMultipart, Group Фигуры


ShapeMultipart.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapeMultipart, Group Фигуры


ShapeMultipart.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapeMultipart, Group Фигуры


ShapeMultipart.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapeMultipart, Group Фигуры


ShapeMultipart.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapeMultipart, Group Фигуры


ShapeMultipart.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapeMultipart, Group Фигуры


ShapeMultipart.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapeMultipart, Group Фигуры


ShapeMultipart.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapeMultipart, Group Фигуры


ShapeMultipart.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.SetPartPoints (метод)

Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetPartPoints ( _
   ByVal PartIndex As Long, _
   ByVal Points() As Double _
)

[Delphi]
procedure SetPartPoints(
   const PartIndex: Integer;
   const Points: PSafeArray
)

Описание параметров

PartIndex
[in] Номер части фигуры (нумерация идёт от 0 до PartCount-1)
Points
[in] Массив координат точек в указанной части фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.SetParts (метод)

Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber

Синтаксис

[Visual Basic 6]
Sub SetParts ( _
   ByVal Parts() As Long _
)

[Delphi]
procedure SetParts(
   const Parts: PSafeArray
)

Описание параметров

Parts
[in] Массив количеств точек во всех независимых частях фигуры

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapeMultipart, Group Фигуры


ShapeMultipart.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapeMultipart, Group Фигуры


Класс ShapeMultipoint

Шейп-фигура "мультиточка"

Наследование

Figure Class ShapeMultipoint

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapeMultipoint

ClassID = {6010000A-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PointNumber | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в фигуру
Method AddPointM | Добавить дополнительную точку с мерой в фигуру
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в фигуру
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Количество точек в фигуре устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CustomContainer | Method TrackFlatMultipoint (метод) Method TrackModelMultipoint (метод)
Class ShapeFile | Property Multipoint (свойство)
Class VectorContainer | Method TrackFlatMultipoint (метод) Method TrackModelMultipoint (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapeMultipoint.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
Property PointNumber As Long

[Delphi]
property PointNumber: Integer

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapeMultipoint, Enum ShapeTypeConstants, Group Фигуры


ShapeMultipoint.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.AddPoint (метод)

Добавить дополнительную точку в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.AddPointM (метод)

Добавить дополнительную точку с мерой в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Количество точек в фигуре устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapeMultipoint, Group Фигуры


ShapeMultipoint.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapeMultipoint, Group Фигуры


Класс ShapeMultipointM

Шейп-фигура "мультиточка" с мерой

Наследование

Figure Class ShapeMultipointM

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapeMultipointM

ClassID = {6010000B-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PointNumber | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в фигуру
Method AddPointM | Добавить дополнительную точку с мерой в фигуру
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в фигуру
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Количество точек в фигуре устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapeMultipointM.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
Property PointNumber As Long

[Delphi]
property PointNumber: Integer

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapeMultipointM, Enum ShapeTypeConstants, Group Фигуры


ShapeMultipointM.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.AddPoint (метод)

Добавить дополнительную точку в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.AddPointM (метод)

Добавить дополнительную точку с мерой в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Количество точек в фигуре устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapeMultipointM, Group Фигуры


ShapeMultipointM.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapeMultipointM, Group Фигуры


Класс ShapeMultipointZ

Шейп-фигура "мультиточка" с мерой и Z-координатой

Наследование

Figure Class ShapeMultipointZ

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapeMultipointZ

ClassID = {6010000C-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PointNumber | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в фигуру
Method AddPointM | Добавить дополнительную точку с мерой в фигуру
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в фигуру
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Количество точек в фигуре устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapeMultipointZ.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
Property PointNumber As Long

[Delphi]
property PointNumber: Integer

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapeMultipointZ, Enum ShapeTypeConstants, Group Фигуры


ShapeMultipointZ.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.AddPoint (метод)

Добавить дополнительную точку в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.AddPointM (метод)

Добавить дополнительную точку с мерой в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в фигуру

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PointIndex
[in] Номер вставляемой точки
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Количество точек в фигуре устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapeMultipointZ, Group Фигуры


ShapeMultipointZ.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapeMultipointZ, Group Фигуры


Класс ShapePoint

Шейп-фигура "точка"

Наследование

Figure Class ShapePoint

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePoint

ClassID = {60100006-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property M | Мера M точки
Property Owner (только для чтения) | Список-владелец данной фигуры
Property Point | Вещественная точка
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property X | Координата X точки
Property Y | Координата Y точки
Property Z | Координата Z точки

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class ShapeFile | Property Point (свойство)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePoint.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePoint, Group Фигуры


ShapePoint.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.M (свойство)

Мера M точки

Синтаксис

[Visual Basic 6]
Property M As Double

[Delphi]
property M: Double

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePoint, Group Фигуры


ShapePoint.Point (свойство)

Вещественная точка

Синтаксис

[Visual Basic 6]
Property Point As ModelPoint

[Delphi]
property Point: ModelPoint

Смотри также

Class ModelPoint, Class ShapePoint, Group Фигуры


ShapePoint.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePoint, Enum ShapeTypeConstants, Group Фигуры


ShapePoint.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.Z (свойство)

Координата Z точки

Синтаксис

[Visual Basic 6]
Property Z As Double

[Delphi]
property Z: Double

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePoint, Group Фигуры


ShapePoint.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePoint, Group Фигуры


ShapePoint.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePoint, Group Фигуры


ShapePoint.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePoint, Group Фигуры


ShapePoint.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePoint, Group Фигуры


ShapePoint.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePoint, Group Фигуры


ShapePoint.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePoint, Group Фигуры


ShapePoint.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePoint, Group Фигуры


ShapePoint.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePoint, Group Фигуры


ShapePoint.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePoint, Group Фигуры


ShapePoint.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePoint, Group Фигуры


ShapePoint.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePoint, Group Фигуры


ShapePoint.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePoint, Group Фигуры


ShapePoint.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePoint, Group Фигуры


Класс ShapePointM

Шейп-фигура "точка" с мерой

Наследование

Figure Class ShapePointM

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePointM

ClassID = {60100007-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property M | Мера M точки
Property Owner (только для чтения) | Список-владелец данной фигуры
Property Point | Вещественная точка
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property X | Координата X точки
Property Y | Координата Y точки
Property Z | Координата Z точки

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePointM.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePointM, Group Фигуры


ShapePointM.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.M (свойство)

Мера M точки

Синтаксис

[Visual Basic 6]
Property M As Double

[Delphi]
property M: Double

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePointM, Group Фигуры


ShapePointM.Point (свойство)

Вещественная точка

Синтаксис

[Visual Basic 6]
Property Point As ModelPoint

[Delphi]
property Point: ModelPoint

Смотри также

Class ModelPoint, Class ShapePointM, Group Фигуры


ShapePointM.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePointM, Enum ShapeTypeConstants, Group Фигуры


ShapePointM.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.Z (свойство)

Координата Z точки

Синтаксис

[Visual Basic 6]
Property Z As Double

[Delphi]
property Z: Double

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePointM, Group Фигуры


ShapePointM.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePointM, Group Фигуры


ShapePointM.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePointM, Group Фигуры


ShapePointM.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePointM, Group Фигуры


ShapePointM.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePointM, Group Фигуры


ShapePointM.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePointM, Group Фигуры


ShapePointM.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePointM, Group Фигуры


ShapePointM.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePointM, Group Фигуры


ShapePointM.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePointM, Group Фигуры


ShapePointM.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePointM, Group Фигуры


ShapePointM.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePointM, Group Фигуры


ShapePointM.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePointM, Group Фигуры


ShapePointM.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePointM, Group Фигуры


ShapePointM.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePointM, Group Фигуры


Класс ShapePointZ

Шейп-фигура "точка" с мерой и Z-координатой

Наследование

Figure Class ShapePointZ

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePointZ

ClassID = {60100008-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property M | Мера M точки
Property Owner (только для чтения) | Список-владелец данной фигуры
Property Point | Вещественная точка
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property X | Координата X точки
Property Y | Координата Y точки
Property Z | Координата Z точки

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePointZ.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePointZ, Group Фигуры


ShapePointZ.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.M (свойство)

Мера M точки

Синтаксис

[Visual Basic 6]
Property M As Double

[Delphi]
property M: Double

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePointZ, Group Фигуры


ShapePointZ.Point (свойство)

Вещественная точка

Синтаксис

[Visual Basic 6]
Property Point As ModelPoint

[Delphi]
property Point: ModelPoint

Смотри также

Class ModelPoint, Class ShapePointZ, Group Фигуры


ShapePointZ.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePointZ, Enum ShapeTypeConstants, Group Фигуры


ShapePointZ.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.Z (свойство)

Координата Z точки

Синтаксис

[Visual Basic 6]
Property Z As Double

[Delphi]
property Z: Double

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePointZ, Group Фигуры


ShapePointZ.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePointZ, Group Фигуры


ShapePointZ.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePointZ, Group Фигуры


ShapePointZ.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePointZ, Group Фигуры


ShapePointZ.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePointZ, Group Фигуры


ShapePointZ.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePointZ, Group Фигуры


ShapePointZ.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePointZ, Group Фигуры


ShapePointZ.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePointZ, Group Фигуры


ShapePointZ.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePointZ, Group Фигуры


ShapePointZ.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePointZ, Group Фигуры


ShapePointZ.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePointZ, Group Фигуры


ShapePointZ.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePointZ, Group Фигуры


ShapePointZ.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePointZ, Group Фигуры


ShapePointZ.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePointZ, Group Фигуры


Класс ShapePolygon

Шейп-фигура "полигон"

Наследование

Figure Class ShapePolygon

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePolygon

ClassID = {60100014-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PartCounts | Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры
Property PartNumber | Число независимых частей, из которых состоит фигура
Property PointNumber (только для чтения) | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в последний контур фигуры
Method AddPointM | Добавить дополнительную точку с мерой в последний контур фигуры
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method Perimeter | Вычисление периметра полигона
Method Perimeter3D | Вычисление периметра полигона в пространстве с учетом координаты Z
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetPartPoints | Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetParts | Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber
Method Simplify | Убирает в фигуре самопересечения и нормализует порядок обхода точек в контурах (внешние контуры делает по часовой стрелке, внутренние - против)
Method Square | Вычисление площади полигона
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Method AddPolygonShape (метод) Method CalcHashInPolygon (метод) Method CalcSimpleHashInPolygon (метод) Method CutByPolygon (метод) Method ExtractBorder (метод) Method ExtractPolygon (метод) Method IncrementalAddBoundaryShape (метод) Method PolygonSquare (метод) Method SurfaceDifference (метод) Method SurfaceEarthVolume (метод)
Class ClipRegion | Property Region (свойство)
Class CustomContainer | Method TrackFlatFillPolygon (метод) Method TrackFlatPolygon (метод) Method TrackModelFillCircle (метод) Method TrackModelFillEllipse (метод) Method TrackModelFillPolygon (метод) Method TrackModelFillRectangle (метод) Method TrackModelPolygon (метод)
Class ShapeFile | Property Polygon (свойство)
Class Triangulation | Method AddPolygonShape (метод) Method CalcHashInPolygon (метод) Method CalcSimpleHashInPolygon (метод) Method CutByPolygon (метод) Method ExtractBorder (метод) Method ExtractPolygon (метод) Method IncrementalAddBoundaryShape (метод) Method PolygonSquare (метод) Method SurfaceDifference (метод) Method SurfaceEarthVolume (метод)
Class TrnTools | Method SplitStripPicket (метод)
Class VectorContainer | Method TrackFlatFillPolygon (метод) Method TrackFlatPolygon (метод) Method TrackModelFillCircle (метод) Method TrackModelFillEllipse (метод) Method TrackModelFillPolygon (метод) Method TrackModelFillRectangle (метод) Method TrackModelPolygon (метод)
Class VectorLayer | Method GetFiguresAtPolygon (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePolygon.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePolygon, Group Фигуры


ShapePolygon.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePolygon, Group Фигуры


ShapePolygon.PartCounts (свойство)

Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры

Синтаксис

[Visual Basic 6]
Property PartCounts As Long

[Delphi]
property PartCounts: Integer

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.PartNumber (свойство)

Число независимых частей, из которых состоит фигура

Синтаксис

[Visual Basic 6]
Property PartNumber As Long

[Delphi]
property PartNumber: Integer

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
ReadOnly Property PointNumber As Long

[Delphi]
{только для чтения} property PointNumber: Integer

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapePolygon, Group Фигуры


ShapePolygon.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePolygon, Enum ShapeTypeConstants, Group Фигуры


ShapePolygon.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.AddPoint (метод)

Добавить дополнительную точку в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.AddPointM (метод)

Добавить дополнительную точку с мерой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePolygon, Group Фигуры


ShapePolygon.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePolygon, Group Фигуры


ShapePolygon.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePolygon, Group Фигуры


ShapePolygon.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePolygon, Group Фигуры


ShapePolygon.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePolygon, Group Фигуры


ShapePolygon.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePolygon, Group Фигуры


ShapePolygon.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePolygon, Group Фигуры


ShapePolygon.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePolygon, Group Фигуры


ShapePolygon.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePolygon, Group Фигуры


ShapePolygon.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePolygon, Group Фигуры


ShapePolygon.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePolygon, Group Фигуры


ShapePolygon.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePolygon, Group Фигуры


ShapePolygon.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Perimeter (метод)

Вычисление периметра полигона

Синтаксис

[Visual Basic 6]
Function Perimeter As Double

[Delphi]
function Perimeter: Double

Возвращаемое значение

Возвращает вычисленный периметр полигона

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Perimeter3D (метод)

Вычисление периметра полигона в пространстве с учетом координаты Z

Синтаксис

[Visual Basic 6]
Function Perimeter3D As Double

[Delphi]
function Perimeter3D: Double

Возвращаемое значение

Возвращает вычисленный периметр полигона в пространстве

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.SetPartPoints (метод)

Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetPartPoints ( _
   ByVal PartIndex As Long, _
   ByVal Points() As Double _
)

[Delphi]
procedure SetPartPoints(
   const PartIndex: Integer;
   const Points: PSafeArray
)

Описание параметров

PartIndex
[in] Номер части фигуры (нумерация идёт от 0 до PartCount-1)
Points
[in] Массив координат точек в указанной части фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.SetParts (метод)

Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber

Синтаксис

[Visual Basic 6]
Sub SetParts ( _
   ByVal Parts() As Long _
)

[Delphi]
procedure SetParts(
   const Parts: PSafeArray
)

Описание параметров

Parts
[in] Массив количеств точек во всех независимых частях фигуры

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Simplify (метод)

Убирает в фигуре самопересечения и нормализует порядок обхода точек в контурах (внешние контуры делает по часовой стрелке, внутренние - против)

Синтаксис

[Visual Basic 6]
Function Simplify As Boolean

[Delphi]
function Simplify: WordBool

Возвращаемое значение

Возвращает True, если фигура была исправлена

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.Square (метод)

Вычисление площади полигона

Синтаксис

[Visual Basic 6]
Function Square As Double

[Delphi]
function Square: Double

Возвращаемое значение

Возвращает вычисленную площадь полигона

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePolygon, Group Фигуры


ShapePolygon.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePolygon, Group Фигуры


Класс ShapePolygonM

Шейп-фигура "полигон" с мерой

Наследование

Figure Class ShapePolygonM

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePolygonM

ClassID = {60100015-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PartCounts | Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры
Property PartNumber | Число независимых частей, из которых состоит фигура
Property PointNumber (только для чтения) | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в последний контур фигуры
Method AddPointM | Добавить дополнительную точку с мерой в последний контур фигуры
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method Perimeter | Вычисление периметра полигона
Method Perimeter3D | Вычисление периметра полигона в пространстве с учетом координаты Z
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetPartPoints | Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetParts | Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber
Method Simplify | Убирает в фигуре самопересечения и нормализует порядок обхода точек в контурах (внешние контуры делает по часовой стрелке, внутренние - против)
Method Square | Вычисление площади полигона
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePolygonM.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePolygonM, Group Фигуры


ShapePolygonM.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePolygonM, Group Фигуры


ShapePolygonM.PartCounts (свойство)

Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры

Синтаксис

[Visual Basic 6]
Property PartCounts As Long

[Delphi]
property PartCounts: Integer

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.PartNumber (свойство)

Число независимых частей, из которых состоит фигура

Синтаксис

[Visual Basic 6]
Property PartNumber As Long

[Delphi]
property PartNumber: Integer

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
ReadOnly Property PointNumber As Long

[Delphi]
{только для чтения} property PointNumber: Integer

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapePolygonM, Group Фигуры


ShapePolygonM.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePolygonM, Enum ShapeTypeConstants, Group Фигуры


ShapePolygonM.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.AddPoint (метод)

Добавить дополнительную точку в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.AddPointM (метод)

Добавить дополнительную точку с мерой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePolygonM, Group Фигуры


ShapePolygonM.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePolygonM, Group Фигуры


ShapePolygonM.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePolygonM, Group Фигуры


ShapePolygonM.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePolygonM, Group Фигуры


ShapePolygonM.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePolygonM, Group Фигуры


ShapePolygonM.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePolygonM, Group Фигуры


ShapePolygonM.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePolygonM, Group Фигуры


ShapePolygonM.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePolygonM, Group Фигуры


ShapePolygonM.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePolygonM, Group Фигуры


ShapePolygonM.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePolygonM, Group Фигуры


ShapePolygonM.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePolygonM, Group Фигуры


ShapePolygonM.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePolygonM, Group Фигуры


ShapePolygonM.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Perimeter (метод)

Вычисление периметра полигона

Синтаксис

[Visual Basic 6]
Function Perimeter As Double

[Delphi]
function Perimeter: Double

Возвращаемое значение

Возвращает вычисленный периметр полигона

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Perimeter3D (метод)

Вычисление периметра полигона в пространстве с учетом координаты Z

Синтаксис

[Visual Basic 6]
Function Perimeter3D As Double

[Delphi]
function Perimeter3D: Double

Возвращаемое значение

Возвращает вычисленный периметр полигона в пространстве

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.SetPartPoints (метод)

Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetPartPoints ( _
   ByVal PartIndex As Long, _
   ByVal Points() As Double _
)

[Delphi]
procedure SetPartPoints(
   const PartIndex: Integer;
   const Points: PSafeArray
)

Описание параметров

PartIndex
[in] Номер части фигуры (нумерация идёт от 0 до PartCount-1)
Points
[in] Массив координат точек в указанной части фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.SetParts (метод)

Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber

Синтаксис

[Visual Basic 6]
Sub SetParts ( _
   ByVal Parts() As Long _
)

[Delphi]
procedure SetParts(
   const Parts: PSafeArray
)

Описание параметров

Parts
[in] Массив количеств точек во всех независимых частях фигуры

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Simplify (метод)

Убирает в фигуре самопересечения и нормализует порядок обхода точек в контурах (внешние контуры делает по часовой стрелке, внутренние - против)

Синтаксис

[Visual Basic 6]
Function Simplify As Boolean

[Delphi]
function Simplify: WordBool

Возвращаемое значение

Возвращает True, если фигура была исправлена

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.Square (метод)

Вычисление площади полигона

Синтаксис

[Visual Basic 6]
Function Square As Double

[Delphi]
function Square: Double

Возвращаемое значение

Возвращает вычисленную площадь полигона

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePolygonM, Group Фигуры


ShapePolygonM.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePolygonM, Group Фигуры


Класс ShapePolygonZ

Шейп-фигура "полигон" с мерой и Z-координатой

Наследование

Figure Class ShapePolygonZ

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePolygonZ

ClassID = {60100016-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PartCounts | Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры
Property PartNumber | Число независимых частей, из которых состоит фигура
Property PointNumber (только для чтения) | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в последний контур фигуры
Method AddPointM | Добавить дополнительную точку с мерой в последний контур фигуры
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method Perimeter | Вычисление периметра полигона
Method Perimeter3D | Вычисление периметра полигона в пространстве с учетом координаты Z
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetPartPoints | Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetParts | Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber
Method Simplify | Убирает в фигуре самопересечения и нормализует порядок обхода точек в контурах (внешние контуры делает по часовой стрелке, внутренние - против)
Method Square | Вычисление площади полигона
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePolygonZ.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.PartCounts (свойство)

Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры

Синтаксис

[Visual Basic 6]
Property PartCounts As Long

[Delphi]
property PartCounts: Integer

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.PartNumber (свойство)

Число независимых частей, из которых состоит фигура

Синтаксис

[Visual Basic 6]
Property PartNumber As Long

[Delphi]
property PartNumber: Integer

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
ReadOnly Property PointNumber As Long

[Delphi]
{только для чтения} property PointNumber: Integer

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePolygonZ, Enum ShapeTypeConstants, Group Фигуры


ShapePolygonZ.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.AddPoint (метод)

Добавить дополнительную точку в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.AddPointM (метод)

Добавить дополнительную точку с мерой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Perimeter (метод)

Вычисление периметра полигона

Синтаксис

[Visual Basic 6]
Function Perimeter As Double

[Delphi]
function Perimeter: Double

Возвращаемое значение

Возвращает вычисленный периметр полигона

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Perimeter3D (метод)

Вычисление периметра полигона в пространстве с учетом координаты Z

Синтаксис

[Visual Basic 6]
Function Perimeter3D As Double

[Delphi]
function Perimeter3D: Double

Возвращаемое значение

Возвращает вычисленный периметр полигона в пространстве

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.SetPartPoints (метод)

Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetPartPoints ( _
   ByVal PartIndex As Long, _
   ByVal Points() As Double _
)

[Delphi]
procedure SetPartPoints(
   const PartIndex: Integer;
   const Points: PSafeArray
)

Описание параметров

PartIndex
[in] Номер части фигуры (нумерация идёт от 0 до PartCount-1)
Points
[in] Массив координат точек в указанной части фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.SetParts (метод)

Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber

Синтаксис

[Visual Basic 6]
Sub SetParts ( _
   ByVal Parts() As Long _
)

[Delphi]
procedure SetParts(
   const Parts: PSafeArray
)

Описание параметров

Parts
[in] Массив количеств точек во всех независимых частях фигуры

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Simplify (метод)

Убирает в фигуре самопересечения и нормализует порядок обхода точек в контурах (внешние контуры делает по часовой стрелке, внутренние - против)

Синтаксис

[Visual Basic 6]
Function Simplify As Boolean

[Delphi]
function Simplify: WordBool

Возвращаемое значение

Возвращает True, если фигура была исправлена

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.Square (метод)

Вычисление площади полигона

Синтаксис

[Visual Basic 6]
Function Square As Double

[Delphi]
function Square: Double

Возвращаемое значение

Возвращает вычисленную площадь полигона

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePolygonZ, Group Фигуры


ShapePolygonZ.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePolygonZ, Group Фигуры


Класс ShapePolyline

Шейп-фигура "полилиния"

Наследование

Figure Class ShapePolyline

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePolyline

ClassID = {60100010-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PartCounts | Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры
Property PartNumber | Число независимых частей, из которых состоит фигура
Property PointNumber (только для чтения) | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в последний контур фигуры
Method AddPointM | Добавить дополнительную точку с мерой в последний контур фигуры
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method Length | Вычисление длины полилинии
Method Length3D | Вычисление длины полилинии в пространстве с учетом координаты Z
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetPartPoints | Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetParts | Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Method AddModifierShape (метод) Method AddPolylineShape (метод) Method BuildIsoline (метод) Method CalcSimpleAlongPolyline (метод) Method GetProfile (метод)
Class CustomContainer | Method TrackFlatPolyline (метод) Method TrackFlatSegment (метод) Method TrackModelCircle (метод) Method TrackModelEllipse (метод) Method TrackModelPolyline (метод) Method TrackModelRectangle (метод) Method TrackModelSegment (метод)
Class ShapeFile | Property Polyline (свойство)
Class Triangulation | Method AddModifierShape (метод) Method AddPolylineShape (метод) Method BuildIsoline (метод) Method CalcSimpleAlongPolyline (метод)
Class TrnTools | Method SplitStripPicket (метод)
Class VectorContainer | Method TrackFlatPolyline (метод) Method TrackFlatSegment (метод) Method TrackModelCircle (метод) Method TrackModelEllipse (метод) Method TrackModelPolyline (метод) Method TrackModelRectangle (метод) Method TrackModelSegment (метод)
Class VectorLayer | Method GetFiguresAtPolyline (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePolyline.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePolyline, Group Фигуры


ShapePolyline.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePolyline, Group Фигуры


ShapePolyline.PartCounts (свойство)

Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры

Синтаксис

[Visual Basic 6]
Property PartCounts As Long

[Delphi]
property PartCounts: Integer

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.PartNumber (свойство)

Число независимых частей, из которых состоит фигура

Синтаксис

[Visual Basic 6]
Property PartNumber As Long

[Delphi]
property PartNumber: Integer

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
ReadOnly Property PointNumber As Long

[Delphi]
{только для чтения} property PointNumber: Integer

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapePolyline, Group Фигуры


ShapePolyline.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePolyline, Enum ShapeTypeConstants, Group Фигуры


ShapePolyline.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.AddPoint (метод)

Добавить дополнительную точку в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.AddPointM (метод)

Добавить дополнительную точку с мерой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePolyline, Group Фигуры


ShapePolyline.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePolyline, Group Фигуры


ShapePolyline.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePolyline, Group Фигуры


ShapePolyline.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePolyline, Group Фигуры


ShapePolyline.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePolyline, Group Фигуры


ShapePolyline.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePolyline, Group Фигуры


ShapePolyline.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePolyline, Group Фигуры


ShapePolyline.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePolyline, Group Фигуры


ShapePolyline.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePolyline, Group Фигуры


ShapePolyline.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePolyline, Group Фигуры


ShapePolyline.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePolyline, Group Фигуры


ShapePolyline.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePolyline, Group Фигуры


ShapePolyline.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Length (метод)

Вычисление длины полилинии

Синтаксис

[Visual Basic 6]
Function Length As Double

[Delphi]
function Length: Double

Возвращаемое значение

Возвращает вычисленную длину полилинии

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.Length3D (метод)

Вычисление длины полилинии в пространстве с учетом координаты Z

Синтаксис

[Visual Basic 6]
Function Length3D As Double

[Delphi]
function Length3D: Double

Возвращаемое значение

Возвращает вычисленную длину полилинии в пространстве

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.SetPartPoints (метод)

Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetPartPoints ( _
   ByVal PartIndex As Long, _
   ByVal Points() As Double _
)

[Delphi]
procedure SetPartPoints(
   const PartIndex: Integer;
   const Points: PSafeArray
)

Описание параметров

PartIndex
[in] Номер части фигуры (нумерация идёт от 0 до PartCount-1)
Points
[in] Массив координат точек в указанной части фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.SetParts (метод)

Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber

Синтаксис

[Visual Basic 6]
Sub SetParts ( _
   ByVal Parts() As Long _
)

[Delphi]
procedure SetParts(
   const Parts: PSafeArray
)

Описание параметров

Parts
[in] Массив количеств точек во всех независимых частях фигуры

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePolyline, Group Фигуры


ShapePolyline.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePolyline, Group Фигуры


Класс ShapePolylineM

Шейп-фигура "полилиния" с мерой

Наследование

Figure Class ShapePolylineM

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePolylineM

ClassID = {60100011-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PartCounts | Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры
Property PartNumber | Число независимых частей, из которых состоит фигура
Property PointNumber (только для чтения) | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в последний контур фигуры
Method AddPointM | Добавить дополнительную точку с мерой в последний контур фигуры
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method Length | Вычисление длины полилинии
Method Length3D | Вычисление длины полилинии в пространстве с учетом координаты Z
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetPartPoints | Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetParts | Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePolylineM.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePolylineM, Group Фигуры


ShapePolylineM.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePolylineM, Group Фигуры


ShapePolylineM.PartCounts (свойство)

Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры

Синтаксис

[Visual Basic 6]
Property PartCounts As Long

[Delphi]
property PartCounts: Integer

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.PartNumber (свойство)

Число независимых частей, из которых состоит фигура

Синтаксис

[Visual Basic 6]
Property PartNumber As Long

[Delphi]
property PartNumber: Integer

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
ReadOnly Property PointNumber As Long

[Delphi]
{только для чтения} property PointNumber: Integer

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapePolylineM, Group Фигуры


ShapePolylineM.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePolylineM, Enum ShapeTypeConstants, Group Фигуры


ShapePolylineM.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.AddPoint (метод)

Добавить дополнительную точку в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.AddPointM (метод)

Добавить дополнительную точку с мерой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePolylineM, Group Фигуры


ShapePolylineM.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePolylineM, Group Фигуры


ShapePolylineM.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePolylineM, Group Фигуры


ShapePolylineM.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePolylineM, Group Фигуры


ShapePolylineM.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePolylineM, Group Фигуры


ShapePolylineM.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePolylineM, Group Фигуры


ShapePolylineM.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePolylineM, Group Фигуры


ShapePolylineM.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePolylineM, Group Фигуры


ShapePolylineM.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePolylineM, Group Фигуры


ShapePolylineM.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePolylineM, Group Фигуры


ShapePolylineM.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePolylineM, Group Фигуры


ShapePolylineM.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePolylineM, Group Фигуры


ShapePolylineM.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Length (метод)

Вычисление длины полилинии

Синтаксис

[Visual Basic 6]
Function Length As Double

[Delphi]
function Length: Double

Возвращаемое значение

Возвращает вычисленную длину полилинии

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.Length3D (метод)

Вычисление длины полилинии в пространстве с учетом координаты Z

Синтаксис

[Visual Basic 6]
Function Length3D As Double

[Delphi]
function Length3D: Double

Возвращаемое значение

Возвращает вычисленную длину полилинии в пространстве

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.SetPartPoints (метод)

Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetPartPoints ( _
   ByVal PartIndex As Long, _
   ByVal Points() As Double _
)

[Delphi]
procedure SetPartPoints(
   const PartIndex: Integer;
   const Points: PSafeArray
)

Описание параметров

PartIndex
[in] Номер части фигуры (нумерация идёт от 0 до PartCount-1)
Points
[in] Массив координат точек в указанной части фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.SetParts (метод)

Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber

Синтаксис

[Visual Basic 6]
Sub SetParts ( _
   ByVal Parts() As Long _
)

[Delphi]
procedure SetParts(
   const Parts: PSafeArray
)

Описание параметров

Parts
[in] Массив количеств точек во всех независимых частях фигуры

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePolylineM, Group Фигуры


ShapePolylineM.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePolylineM, Group Фигуры


Класс ShapePolylineZ

Шейп-фигура "полилиния" с мерой и Z-координатой

Наследование

Figure Class ShapePolylineZ

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ShapePolylineZ

ClassID = {60100012-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Ms | Массив мер M фигуры
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PartCounts | Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры
Property PartNumber | Число независимых частей, из которых состоит фигура
Property PointNumber (только для чтения) | Количество точек в фигуре
Property Points | Массив точек фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property ShapeType (только для чтения) | Тип фигуры
Property Tag | Поле для свободного использования
Property Visible | Видима ли фигура
Property Zs | Массив координат Z фигуры

Методы класса

Имя | Описание
Method AddPoint | Добавить дополнительную точку в последний контур фигуры
Method AddPointM | Добавить дополнительную точку с мерой в последний контур фигуры
Method AddPointZ | Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Center | Получить центр фигуры (центр объемлющего прямоугольника)
Method Centroid | Получить центроид фигуры (среднее арифметическое координат, центр масс)
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method CloneShape | Создать копию фигуры
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method DistanceToShape | Расстояние от одной Фигуры до другой
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method HasM | Имеет ли фигура меру M
Method HasZ | Имеет ли фигура координату Z
Method InsertPoint | Вставить в заданное место фигуры дополнительную точку
Method InsertPointM | Вставить в заданное место фигуры дополнительную точку с мерой
Method InsertPointZ | Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой
Method IsInsideShape | Размещается ли одна шейп-фигура внутри другой
Method IsIntersectedWith | Пересекает ли данная шейп-фигура другую
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method Length | Вычисление длины полилинии
Method Length3D | Вычисление длины полилинии в пространстве с учетом координаты Z
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SetAllPoints | Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetPartPoints | Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента
Method SetParts | Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class ShapeFigure, Enum ShapeTypeConstants, Group Фигуры


ShapePolylineZ.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Ms (свойство)

Массив мер M фигуры

Синтаксис

[Visual Basic 6]
Property Ms As Double

[Delphi]
property Ms: Double

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.PartCounts (свойство)

Массив количеств точек в независимых частях. При изменении этого свойства для одноконтурных полилиний и полигонов автоматически меняется общее число точек фигуры

Синтаксис

[Visual Basic 6]
Property PartCounts As Long

[Delphi]
property PartCounts: Integer

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.PartNumber (свойство)

Число независимых частей, из которых состоит фигура

Синтаксис

[Visual Basic 6]
Property PartNumber As Long

[Delphi]
property PartNumber: Integer

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.PointNumber (свойство)

Количество точек в фигуре

Синтаксис

[Visual Basic 6]
ReadOnly Property PointNumber As Long

[Delphi]
{только для чтения} property PointNumber: Integer

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Points (свойство)

Массив точек фигуры

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.ShapeType (свойство)

Тип фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property ShapeType As ShapeTypeConstants

[Delphi]
{только для чтения} property ShapeType: ShapeTypeConstants

Смотри также

Class ShapePolylineZ, Enum ShapeTypeConstants, Group Фигуры


ShapePolylineZ.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Zs (свойство)

Массив координат Z фигуры

Синтаксис

[Visual Basic 6]
Property Zs As Double

[Delphi]
property Zs: Double

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.AddPoint (метод)

Добавить дополнительную точку в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPoint ( _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure AddPoint(
   const X: Double;
   const Y: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.AddPointM (метод)

Добавить дополнительную точку с мерой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointM ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointM(
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.AddPointZ (метод)

Добавить дополнительную точку с мерой и высотной отметкой в последний контур фигуры

Синтаксис

[Visual Basic 6]
Sub AddPointZ ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure AddPointZ(
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Center (метод)

Получить центр фигуры (центр объемлющего прямоугольника)

Синтаксис

[Visual Basic 6]
Function Center As ModelPoint

[Delphi]
function Center: ModelPoint

Возвращаемое значение

Возвращает координаты центра фигуры

Смотри также

Class ModelPoint, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Centroid (метод)

Получить центроид фигуры (среднее арифметическое координат, центр масс)

Синтаксис

[Visual Basic 6]
Function Centroid As ModelPoint

[Delphi]
function Centroid: ModelPoint

Возвращаемое значение

Возвращает координаты центроида фигуры

Смотри также

Class ModelPoint, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.CloneShape (метод)

Создать копию фигуры

Синтаксис

[Visual Basic 6]
Function CloneShape As ShapeFigure

[Delphi]
function CloneShape: ShapeFigure

Возвращаемое значение

Возвращает копию текущей фигуры

Смотри также

Class ShapeFigure, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.DistanceToShape (метод)

Расстояние от одной Фигуры до другой

Синтаксис

[Visual Basic 6]
Function DistanceToShape ( _
   ByVal ShapeFigure As ShapeFigure _
) As Double

[Delphi]
function DistanceToShape(
   const ShapeFigure: ShapeFigure
): Double

Описание параметров

ShapeFigure
[in] Шейп-фигура, до которой вычисляется расстояние

Возвращаемое значение

Возвращает расстояние от данной Фигуры до указанной

Смотри также

Class ShapeFigure, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.HasM (метод)

Имеет ли фигура меру M

Синтаксис

[Visual Basic 6]
Function HasM As Boolean

[Delphi]
function HasM: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет меру M

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.HasZ (метод)

Имеет ли фигура координату Z

Синтаксис

[Visual Basic 6]
Function HasZ As Boolean

[Delphi]
function HasZ: WordBool

Возвращаемое значение

Возвращает Z, если фигура имеет координату Z

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.InsertPoint (метод)

Вставить в заданное место фигуры дополнительную точку

Синтаксис

[Visual Basic 6]
Sub InsertPoint ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double _
)

[Delphi]
procedure InsertPoint(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.InsertPointM (метод)

Вставить в заданное место фигуры дополнительную точку с мерой

Синтаксис

[Visual Basic 6]
Sub InsertPointM ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointM(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.InsertPointZ (метод)

Вставить в заданное место фигуры дополнительную точку с мерой и высотной отметкой

Синтаксис

[Visual Basic 6]
Sub InsertPointZ ( _
   ByVal PartIndex As Long, _
   ByVal PointIndex As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal M As Double _
)

[Delphi]
procedure InsertPointZ(
   const PartIndex: Integer;
   const PointIndex: Integer;
   const X: Double;
   const Y: Double;
   const Z: Double;
   const M: Double
)

Описание параметров

PartIndex
[in] Номер конутра, в который необходимо вставить точку
PointIndex
[in] Номер вставляемой точки в контуре
X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки
M
[in] Мера M добавляемой точки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.IsInsideShape (метод)

Размещается ли одна шейп-фигура внутри другой

Синтаксис

[Visual Basic 6]
Function IsInsideShape ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsInsideShape(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, внутрь которой проверяется попадание данного объекта
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если данная шейп-фигура размещается внутри указанной

Смотри также

Class ShapeFigure, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.IsIntersectedWith (метод)

Пересекает ли данная шейп-фигура другую

Синтаксис

[Visual Basic 6]
Function IsIntersectedWith ( _
   ByVal ShapeFigure As ShapeFigure, _
   ByVal Delta As Double _
) As Boolean

[Delphi]
function IsIntersectedWith(
   const ShapeFigure: ShapeFigure;
   const Delta: Double
): WordBool

Описание параметров

ShapeFigure
[in] Шейп-фигура, с которой проверяется пересечение
Delta
[in] Максимальное допустимое отклонение при проверке

Возвращаемое значение

Возвращает True, если шейп-фигура пересекается с указанной

Смотри также

Class ShapeFigure, Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Length (метод)

Вычисление длины полилинии

Синтаксис

[Visual Basic 6]
Function Length As Double

[Delphi]
function Length: Double

Возвращаемое значение

Возвращает вычисленную длину полилинии

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.Length3D (метод)

Вычисление длины полилинии в пространстве с учетом координаты Z

Синтаксис

[Visual Basic 6]
Function Length3D As Double

[Delphi]
function Length3D: Double

Возвращаемое значение

Возвращает вычисленную длину полилинии в пространстве

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.SetAllPoints (метод)

Устанавливает сразу все точки фигуры. Число частей делается равным 1, а количество точек в нулевой части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetAllPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure SetAllPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат точек фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.SetPartPoints (метод)

Устанавливает сразу все точки в указанной части фигуры. Количество точек в части устанавливается равным половине размера массива, передаваемого в качестве аргумента

Синтаксис

[Visual Basic 6]
Sub SetPartPoints ( _
   ByVal PartIndex As Long, _
   ByVal Points() As Double _
)

[Delphi]
procedure SetPartPoints(
   const PartIndex: Integer;
   const Points: PSafeArray
)

Описание параметров

PartIndex
[in] Номер части фигуры (нумерация идёт от 0 до PartCount-1)
Points
[in] Массив координат точек в указанной части фигуры (координаты точек передаются последовательно: X0,Y1,X2,Y2,...)

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.SetParts (метод)

Устанавливает количества точек во всех независимых частях сразу. Количество частей устанавливается равным размеру массива, передаваемого в качестве аргумента. Суммарное число этих точек сохраняется в PointNumber

Синтаксис

[Visual Basic 6]
Sub SetParts ( _
   ByVal Parts() As Long _
)

[Delphi]
procedure SetParts(
   const Parts: PSafeArray
)

Описание параметров

Parts
[in] Массив количеств точек во всех независимых частях фигуры

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class ShapePolylineZ, Group Фигуры


ShapePolylineZ.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class ShapePolylineZ, Group Фигуры


Класс StandardScale

Стандартный масштаб отображения

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Description (только для чтения) | Описание пункта меню
Property Key (только для чтения) | Клавиша быстрого доступа
Property KeyIndex | Индекс в массиве MapStandardKeys
Property Scale | Масштаб

Где используется

Класс | Член класса
Class Composition | Property StandardScales (свойство) Method AddStandardScale (метод)
Class LayeredComposition | Property StandardScales (свойство) Method AddStandardScale (метод)

Смотри также

Group Контейнеры изображений


StandardScale.Description (свойство)

Описание пункта меню

Синтаксис

[Visual Basic 6]
ReadOnly Property Description As String

[Delphi]
{только для чтения} property Description: WideString

Смотри также

Class StandardScale, Group Контейнеры изображений


StandardScale.Key (свойство)

Клавиша быстрого доступа

Синтаксис

[Visual Basic 6]
ReadOnly Property Key As Long

[Delphi]
{только для чтения} property Key: Integer

Смотри также

Class StandardScale, Group Контейнеры изображений


StandardScale.KeyIndex (свойство)

Индекс в массиве MapStandardKeys

Синтаксис

[Visual Basic 6]
Property KeyIndex As Long

[Delphi]
property KeyIndex: Integer

Смотри также

Class StandardScale, Group Контейнеры изображений


StandardScale.Scale (свойство)

Масштаб

Синтаксис

[Visual Basic 6]
Property Scale As Double

[Delphi]
property Scale: Double

Смотри также

Class StandardScale, Group Контейнеры изображений


Класс StringCollection

Коллекция строк

Наследование

CustomCollection Class StringCollection

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.StringCollection

ClassID = {6002000C-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Count (только для чтения) | Количество объектов списке
Property Items | Массив элементов коллекции

Методы класса

Имя | Описание
Method Add | Добавить новое число в коллекцию
Method AddItems | Добавить несколько строк в коллекцию
Method Clear | Удаляет все элементы из коллекции
Method Delete | Удаляет элемент из коллекции
Method Invert | Меняет порядок элементов в коллекции на обратный
Method Sort | Выполнить сортировку строк по возрастанию

Смотри также

Group Хранилища объектов


StringCollection.Count (свойство)

Количество объектов списке

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class StringCollection, Group Хранилища объектов


StringCollection.Items (свойство)

Массив элементов коллекции

Синтаксис

[Visual Basic 6]
Property Items As String

[Delphi]
property Items: WideString

Смотри также

Class StringCollection, Group Хранилища объектов


StringCollection.Add (метод)

Добавить новое число в коллекцию

Синтаксис

[Visual Basic 6]
Sub Add ( _
   ByVal Number As String _
)

[Delphi]
procedure Add(
   const Number: WideString
)

Описание параметров

Number
[in] Добавляемое в коллекцию строка

Смотри также

Class StringCollection, Group Хранилища объектов


StringCollection.AddItems (метод)

Добавить несколько строк в коллекцию

Синтаксис

[Visual Basic 6]
Sub AddItems ( _
   ParamArray Strings() As Variant _
)

[Delphi]
procedure AddItems(
   const Strings: PSafeArray
)

Описание параметров

Strings
[in] Добавляемые в коллекцию строки

Смотри также

Class StringCollection, Group Хранилища объектов


StringCollection.Clear (метод)

Удаляет все элементы из коллекции

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class StringCollection, Group Хранилища объектов


StringCollection.Delete (метод)

Удаляет элемент из коллекции

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Номер элемента в коллекции

Смотри также

Class StringCollection, Group Хранилища объектов


StringCollection.Invert (метод)

Меняет порядок элементов в коллекции на обратный

Синтаксис

[Visual Basic 6]
Sub Invert

[Delphi]
procedure Invert

Смотри также

Class StringCollection, Group Хранилища объектов


StringCollection.Sort (метод)

Выполнить сортировку строк по возрастанию

Синтаксис

[Visual Basic 6]
Sub Sort

[Delphi]
procedure Sort

Смотри также

Class StringCollection, Group Хранилища объектов


Класс StringName

Имя линии

Наследование

BaseObject Class StringName

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property ElementID (только для чтения) | ID элемента. Используется для ссылки на элемент другими объектами
Property Group | Группа, которой принадлежит элемент
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Index | Порядковый номер элемента в группе
Property IsSystem (только для чтения) | Признак системного элемента. Его нельзя удалить. (Например, Ось)
Property Name | Имя линии, образованой элементом. Уникально в проекте
Property Project (только для чтения) | Проект, к которому относится объект
Property StringNameCollection (только для чтения) | Набор имён линий, к которому относится элемент
Property UseCount (только для чтения) | Количество ссылок другими объектами на элемента. Пока количество ссылок больше нуля, элемент нельзя удалить

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method InvalidateUseCount | Вызывается внешними модулями при изменении количества использований элемента

Где используется

Класс | Член класса
Class StringNameCollection | Method AddElement (метод) Method GetElementByID (метод) Method GetElementByName (метод)
Class StringNameGroup | Property Elements (свойство) Property ElementsByName (свойство) Method AddElement (метод)

Смотри также

Class Application, Class Project


StringName.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class StringName


StringName.ElementID (свойство)

ID элемента. Используется для ссылки на элемент другими объектами

Синтаксис

[Visual Basic 6]
ReadOnly Property ElementID As Long

[Delphi]
{только для чтения} property ElementID: Integer

Смотри также

Class StringName


StringName.Group (свойство)

Группа, которой принадлежит элемент

Синтаксис

[Visual Basic 6]
Property Group As StringNameGroup

[Delphi]
property Group: StringNameGroup

Смотри также

Class StringName, Class StringNameGroup


StringName.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class StringName


StringName.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class StringName


StringName.Index (свойство)

Порядковый номер элемента в группе

Синтаксис

[Visual Basic 6]
Property Index As Long

[Delphi]
property Index: Integer

Смотри также

Class StringName


StringName.IsSystem (свойство)

Признак системного элемента. Его нельзя удалить. (Например, Ось)

Синтаксис

[Visual Basic 6]
ReadOnly Property IsSystem As Boolean

[Delphi]
{только для чтения} property IsSystem: WordBool

Смотри также

Class StringName


StringName.Name (свойство)

Имя линии, образованой элементом. Уникально в проекте

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class StringName


StringName.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class StringName


StringName.StringNameCollection (свойство)

Набор имён линий, к которому относится элемент

Синтаксис

[Visual Basic 6]
ReadOnly Property StringNameCollection As StringNameCollection

[Delphi]
{только для чтения} property StringNameCollection: StringNameCollection

Смотри также

Class StringName, Class StringNameCollection


StringName.UseCount (свойство)

Количество ссылок другими объектами на элемента. Пока количество ссылок больше нуля, элемент нельзя удалить

Синтаксис

[Visual Basic 6]
ReadOnly Property UseCount As Long

[Delphi]
{только для чтения} property UseCount: Integer

Смотри также

Class StringName


StringName.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class StringName


StringName.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class StringName


StringName.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class StringName


StringName.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class StringName


StringName.InvalidateUseCount (метод)

Вызывается внешними модулями при изменении количества использований элемента

Синтаксис

[Visual Basic 6]
Sub InvalidateUseCount

[Delphi]
procedure InvalidateUseCount

Смотри также

Class StringName


Класс StringNameCollection

Набор имён линий

Наследование

BaseObject Class StringNameCollection

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property All (только для чтения) | Виртуальная группа, в которую включены все элементы
Property Application (только для чтения) | Приложение, в котором существует объект
Property ElementsCount (только для чтения) | Общее количество элементов в наборе имён
Property GroupCount (только для чтения) | Количество групп имён линий
Property Groups (только для чтения) | Массив групп имён линий (нумерация идёт от 0 до Count-1)
Property GroupsByName (только для чтения) | Получить группу по имени
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Project (только для чтения) | Проект, к которому относится объект

Методы класса

Имя | Описание
Method AddElement | Возвращает элемент с указанным именем
Method AddGroup | Создаёт и возвращает группу с заданным именем
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method DeleteGroup | Удаляет пустую группу. В качестве параметра передаётся индекс группы
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetElementByID | Возвращает элемент по его ID
Method GetElementByName | Возвращает элемент по его имени
Method GetUniqueName | Возвращает допустимое новое имя элемента
Method InvalidateUseCount | Вызывается внешними модулями при изменении количества использований какого-либо элемента

Где используется

Класс | Член класса
Class Project | Property StringNameCollection (свойство)
Class StringName | Property StringNameCollection (свойство)
Class StringNameGroup | Property StringNameCollection (свойство)

Смотри также

Class Application


StringNameCollection.All (свойство)

Виртуальная группа, в которую включены все элементы

Синтаксис

[Visual Basic 6]
ReadOnly Property All As StringNameGroup

[Delphi]
{только для чтения} property All: StringNameGroup

Смотри также

Class StringNameCollection, Class StringNameGroup


StringNameCollection.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class StringNameCollection


StringNameCollection.ElementsCount (свойство)

Общее количество элементов в наборе имён

Синтаксис

[Visual Basic 6]
ReadOnly Property ElementsCount As Long

[Delphi]
{только для чтения} property ElementsCount: Integer

Смотри также

Class StringNameCollection


StringNameCollection.GroupCount (свойство)

Количество групп имён линий

Синтаксис

[Visual Basic 6]
ReadOnly Property GroupCount As Long

[Delphi]
{только для чтения} property GroupCount: Integer

Смотри также

Class StringNameCollection


StringNameCollection.Groups (свойство)

Массив групп имён линий (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Groups As StringNameGroup

[Delphi]
{только для чтения} property Groups: StringNameGroup

Смотри также

Class StringNameCollection, Class StringNameGroup


StringNameCollection.GroupsByName (свойство)

Получить группу по имени

Синтаксис

[Visual Basic 6]
ReadOnly Property GroupsByName As StringNameGroup

[Delphi]
{только для чтения} property GroupsByName: StringNameGroup

Смотри также

Class StringNameCollection, Class StringNameGroup


StringNameCollection.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class StringNameCollection


StringNameCollection.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class StringNameCollection


StringNameCollection.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class StringNameCollection


StringNameCollection.AddElement (метод)

Возвращает элемент с указанным именем

Синтаксис

[Visual Basic 6]
Function AddElement ( _
   ByVal ElementName As String, _
   ByVal GroupName As String _
) As StringName

[Delphi]
function AddElement(
   const ElementName: WideString;
   const GroupName: WideString
): StringName

Описание параметров

ElementName
[in] Имя запрошенного элемента
GroupName
[in] Имя группы, в которую будеть добавлен элемент в случае его отсутствия

Возвращаемое значение

Созданный либо существующий элемент, либо Nothing в случае ошибки

Смотри также

Class StringName, Class StringNameCollection


StringNameCollection.AddGroup (метод)

Создаёт и возвращает группу с заданным именем

Синтаксис

[Visual Basic 6]
Function AddGroup ( _
   ByVal Name As String _
) As StringNameGroup

[Delphi]
function AddGroup(
   const Name: WideString
): StringNameGroup

Описание параметров

Name
[in] Имя группы

Возвращаемое значение

Созданная либо существующая группа, либо Nothing в случае ошибки

Смотри также

Class StringNameCollection, Class StringNameGroup


StringNameCollection.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class StringNameCollection


StringNameCollection.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class StringNameCollection


StringNameCollection.DeleteGroup (метод)

Удаляет пустую группу. В качестве параметра передаётся индекс группы

Синтаксис

[Visual Basic 6]
Function DeleteGroup ( _
   ByVal Index As Long _
) As Boolean

[Delphi]
function DeleteGroup(
   const Index: Integer
): WordBool

Описание параметров

Index
[in] Индекс группы (нумерация идёт от 0 до Count-1)

Возвращаемое значение

Результат операции: True - группа успешно удалена, False - ошибка

Смотри также

Class StringNameCollection


StringNameCollection.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class StringNameCollection


StringNameCollection.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class StringNameCollection


StringNameCollection.GetElementByID (метод)

Возвращает элемент по его ID

Синтаксис

[Visual Basic 6]
Function GetElementByID ( _
   ByVal ElementID As Long _
) As StringName

[Delphi]
function GetElementByID(
   const ElementID: Integer
): StringName

Описание параметров

ElementID
[in] ID запрашиваемого элемента

Возвращаемое значение

Возвращаемый элемент, либо Nothing в случае ошибки

Смотри также

Class StringName, Class StringNameCollection


StringNameCollection.GetElementByName (метод)

Возвращает элемент по его имени

Синтаксис

[Visual Basic 6]
Function GetElementByName ( _
   ByVal Name As String _
) As StringName

[Delphi]
function GetElementByName(
   const Name: WideString
): StringName

Описание параметров

Name
[in] Имя запрашиваемого элемента

Возвращаемое значение

Возвращаемый элемент, либо Nothing в случае ошибки

Смотри также

Class StringName, Class StringNameCollection


StringNameCollection.GetUniqueName (метод)

Возвращает допустимое новое имя элемента

Синтаксис

[Visual Basic 6]
Function GetUniqueName ( _
   Name As String _
) As Boolean

[Delphi]
function GetUniqueName(
   var Name: WideString
): WordBool

Описание параметров

Name
[in, out] Имя, которое будет проверено на существование. Если такого имени не существует, то функция возвратит True и не изменит значение Name. Если элемент с указанным именем существует, то к указанному имени последовательно будут подставляться натуральные числа до получения уникального имени. Найденное уникальное имя возвратится в Name

Возвращаемое значение

Результат операции: True - уникальное имя возвращено, False - ошибка

Смотри также

Class StringNameCollection


StringNameCollection.InvalidateUseCount (метод)

Вызывается внешними модулями при изменении количества использований какого-либо элемента

Синтаксис

[Visual Basic 6]
Sub InvalidateUseCount

[Delphi]
procedure InvalidateUseCount

Смотри также

Class StringNameCollection


Класс StringNameGroup

Группа имён линий

Наследование

BaseObject Class StringNameGroup

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Count (только для чтения) | Количество элементов в группе
Property Elements (только для чтения) | Массив элементов группы (нумерация идёт от 0 до Count-1)
Property ElementsByName (только для чтения) | Элементы группы. Доступ осуществляется по имени
Property GroupID (только для чтения) | ID (целое число) группы
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Index | Порядковый номер группы в списке
Property IsSystem (только для чтения) | Является ли группа "системной". Системную группу невозможно удалить, даже если она пуста
Property IsVirtual (только для чтения) | Является ли группа "виртуальной". "Виртуальной" является группа All
Property Name | Имя группы
Property Project (только для чтения) | Проект, к которому относится объект
Property StringNameCollection (только для чтения) | Набор имён, к которому относится группа

Методы класса

Имя | Описание
Method AddElement | Добавить в группу элемент с указанным именем
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method DeleteElement | Удалить указанный элемент
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Где используется

Класс | Член класса
Class StringName | Property Group (свойство)
Class StringNameCollection | Property All (свойство) Property Groups (свойство) Property GroupsByName (свойство) Method AddGroup (метод)

Смотри также

Class Application, Class Project


StringNameGroup.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class StringNameGroup


StringNameGroup.Count (свойство)

Количество элементов в группе

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class StringNameGroup


StringNameGroup.Elements (свойство)

Массив элементов группы (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Elements As StringName

[Delphi]
{только для чтения} property Elements: StringName

Смотри также

Class StringName, Class StringNameGroup


StringNameGroup.ElementsByName (свойство)

Элементы группы. Доступ осуществляется по имени

Синтаксис

[Visual Basic 6]
ReadOnly Property ElementsByName As StringName

[Delphi]
{только для чтения} property ElementsByName: StringName

Смотри также

Class StringName, Class StringNameGroup


StringNameGroup.GroupID (свойство)

ID (целое число) группы

Синтаксис

[Visual Basic 6]
ReadOnly Property GroupID As Long

[Delphi]
{только для чтения} property GroupID: Integer

Смотри также

Class StringNameGroup


StringNameGroup.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class StringNameGroup


StringNameGroup.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class StringNameGroup


StringNameGroup.Index (свойство)

Порядковый номер группы в списке

Синтаксис

[Visual Basic 6]
Property Index As Long

[Delphi]
property Index: Integer

Смотри также

Class StringNameGroup


StringNameGroup.IsSystem (свойство)

Является ли группа "системной". Системную группу невозможно удалить, даже если она пуста

Синтаксис

[Visual Basic 6]
ReadOnly Property IsSystem As Boolean

[Delphi]
{только для чтения} property IsSystem: WordBool

Смотри также

Class StringNameGroup


StringNameGroup.IsVirtual (свойство)

Является ли группа "виртуальной". "Виртуальной" является группа All

Синтаксис

[Visual Basic 6]
ReadOnly Property IsVirtual As Boolean

[Delphi]
{только для чтения} property IsVirtual: WordBool

Смотри также

Class StringNameGroup


StringNameGroup.Name (свойство)

Имя группы

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class StringNameGroup


StringNameGroup.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class StringNameGroup


StringNameGroup.StringNameCollection (свойство)

Набор имён, к которому относится группа

Синтаксис

[Visual Basic 6]
ReadOnly Property StringNameCollection As StringNameCollection

[Delphi]
{только для чтения} property StringNameCollection: StringNameCollection

Смотри также

Class StringNameCollection, Class StringNameGroup


StringNameGroup.AddElement (метод)

Добавить в группу элемент с указанным именем

Синтаксис

[Visual Basic 6]
Function AddElement ( _
   ByVal Name As String _
) As StringName

[Delphi]
function AddElement(
   const Name: WideString
): StringName

Описание параметров

Name
[in] Имя элемента, которое необходимо добавить в группу

Возвращаемое значение

Созданный элемент, либо Nothing в случае ошибки

Смотри также

Class StringName, Class StringNameGroup


StringNameGroup.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class StringNameGroup


StringNameGroup.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class StringNameGroup


StringNameGroup.DeleteElement (метод)

Удалить указанный элемент

Синтаксис

[Visual Basic 6]
Function DeleteElement ( _
   ByVal Index As Long _
) As Boolean

[Delphi]
function DeleteElement(
   const Index: Integer
): WordBool

Описание параметров

Index
[in] Индекс элемента, который необходимо удалить

Возвращаемое значение

Результат операции: True - элемент успешно удалён, False - ошибка, либо элемент нельзя удалить

Смотри также

Class StringNameGroup


StringNameGroup.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class StringNameGroup


StringNameGroup.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class StringNameGroup


Класс SubSystem3D

Подсистема 3D-вида

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bank | Крен камеры относительно вертикального положения в радианах
Property Controller | Текущий контроллер 3D-вида
Property ControllerCount (только для чтения) | Количество 3D-контроллеров, зарегистрированных в системе
Property Controllers (только для чтения) | Массив контроллеров 3D-вида (нумерация идёт от 0 до ControllerCount-1)
Property DeltaTime (только для чтения) | Время в секундах с момента отрисовки предыдущего кадра
Property Enabled | Включен ли в данный момент времени 3D-вид
Property GlobalTimeMs | Глобальное время, в миллисекундах. Служит для синхронизации сцен. Если не изменять вручную, то равно GetTickCount
Property Handle (только для чтения) | Handle подсистемы 3D-вида
Property HorizAngle | Горизонтальный угол направления взгляда камеры в радианах
Property Meshes | Массив объектов типа ID3DXMesh
Property Recording (только для чтения) | Записывается ли в данный момент видео
Property RenderToScreen | Вывод в окно или в поверхность. Вывод в поверхность нужен в очень редких случаях
Property Smoothing (только для чтения) | Включен ли режим сглаживания
Property StencilSupported (только для чтения) | Поддерживается ли Stencil-буфер
Property Textures | Массив текстур типа IDirect3DTexture9
Property TimeOfDay | Время суток (освещение). Значение от 0.0 до 1.0. 0=полночь, 0.5=полдень, 1=полночь
Property UnsafeInterfaces | Массив интерфейсов, которые будут автоматически уничтожаться при Device.Reset
Property VertAngle | Вертикальный угол направления взгляда камеры в радианах
Property ZoomFactor | Эффект оптического изменения масштаба изображения (в норме = 1.0)

Методы класса

Имя | Описание
Method AddInfo | Добавить текстовое сообщение на экран 3D вида на указанное время
Method BeginUpdate | Начать серию изменений
Method EndUpdate | Закончить серию изменений
Method GenerateLightIndex | Генерирует и возвращает индекс источника света, который можно использовать для установки дополнительного источника освещения
Method GetEyePosition | Возвращает позицию камеры
Method GetPerspectiveParams | Получить параметры матрицы перспективы
Method GetPositionAndVector | Возвращает позицию и направление взгляда камеры
Method GetWidthHeight | Получить ширину и высоту изображения в окне 3D-вида
Method RecordStart | Начать запись траектории пролёта в файл
Method RecordStop | Завершить запись траектории пролёта в файл
Method RegisterController | Регистрирует контроллер 3D-вида в системе
Method Reset | Переинициализирует сцену в 3D-виде (все объекты возвращаются в "исходное" состояние)
Method SetDeltaTime | Устанавливает значение, которое потом вернёт свойство DeltaTime при отрисовке следующего кадра. Метод необходим для отображения не в реальном времени (покадрового или записи AVI)
Method SetEyePosition | Устанавливает позицию камеры
Method SetWidthHeight | Установить ширину и высоту изображения в окне 3D-вида
Method UnRegisterController | Аннулирует регистрацию контроллера 3D-вида в системе

Где используется

Класс | Член класса
Class Application | Property SubSystem3D (свойство)
Class IView3DController | Method AfterRenderScene (метод) Method UpdatePosition (метод)

Смотри также

Group Трёхмерный вид


SubSystem3D.Bank (свойство)

Крен камеры относительно вертикального положения в радианах

Синтаксис

[Visual Basic 6]
Property Bank As Double

[Delphi]
property Bank: Double

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Controller (свойство)

Текущий контроллер 3D-вида

Синтаксис

[Visual Basic 6]
Property Controller As IView3DController

[Delphi]
property Controller: IView3DController

Смотри также

Interface IView3DController, Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.ControllerCount (свойство)

Количество 3D-контроллеров, зарегистрированных в системе

Синтаксис

[Visual Basic 6]
ReadOnly Property ControllerCount As Long

[Delphi]
{только для чтения} property ControllerCount: Integer

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Controllers (свойство)

Массив контроллеров 3D-вида (нумерация идёт от 0 до ControllerCount-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Controllers As IView3DController

[Delphi]
{только для чтения} property Controllers: IView3DController

Смотри также

Interface IView3DController, Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.DeltaTime (свойство)

Время в секундах с момента отрисовки предыдущего кадра

Синтаксис

[Visual Basic 6]
ReadOnly Property DeltaTime As Long

[Delphi]
{только для чтения} property DeltaTime: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Enabled (свойство)

Включен ли в данный момент времени 3D-вид

Синтаксис

[Visual Basic 6]
Property Enabled As Boolean

[Delphi]
property Enabled: WordBool

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.GlobalTimeMs (свойство)

Глобальное время, в миллисекундах. Служит для синхронизации сцен. Если не изменять вручную, то равно GetTickCount

Синтаксис

[Visual Basic 6]
Property GlobalTimeMs As Long

[Delphi]
property GlobalTimeMs: Integer

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Handle (свойство)

Handle подсистемы 3D-вида

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса является скрытым, т.е. не предназначенным для общего применения. Это обычно связано с тем, что он используется только внутри программы, либо он устарел и оставлен в классе только для обеспечения совместимости с ранее написанным кодом.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.HorizAngle (свойство)

Горизонтальный угол направления взгляда камеры в радианах

Синтаксис

[Visual Basic 6]
Property HorizAngle As Double

[Delphi]
property HorizAngle: Double

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Meshes (свойство)

Массив объектов типа ID3DXMesh

Синтаксис

[Visual Basic 6]
Property Meshes As Long

[Delphi]
property Meshes: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Recording (свойство)

Записывается ли в данный момент видео

Синтаксис

[Visual Basic 6]
ReadOnly Property Recording As Boolean

[Delphi]
{только для чтения} property Recording: WordBool

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.RenderToScreen (свойство)

Вывод в окно или в поверхность. Вывод в поверхность нужен в очень редких случаях

Синтаксис

[Visual Basic 6]
Property RenderToScreen As Boolean

[Delphi]
property RenderToScreen: WordBool

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Smoothing (свойство)

Включен ли режим сглаживания

Синтаксис

[Visual Basic 6]
ReadOnly Property Smoothing As Long

[Delphi]
{только для чтения} property Smoothing: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.StencilSupported (свойство)

Поддерживается ли Stencil-буфер

Синтаксис

[Visual Basic 6]
ReadOnly Property StencilSupported As Long

[Delphi]
{только для чтения} property StencilSupported: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Textures (свойство)

Массив текстур типа IDirect3DTexture9

Синтаксис

[Visual Basic 6]
Property Textures As Long

[Delphi]
property Textures: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.TimeOfDay (свойство)

Время суток (освещение). Значение от 0.0 до 1.0. 0=полночь, 0.5=полдень, 1=полночь

Синтаксис

[Visual Basic 6]
Property TimeOfDay As Long

[Delphi]
property TimeOfDay: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.UnsafeInterfaces (свойство)

Массив интерфейсов, которые будут автоматически уничтожаться при Device.Reset

Синтаксис

[Visual Basic 6]
Property UnsafeInterfaces As Long

[Delphi]
property UnsafeInterfaces: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.VertAngle (свойство)

Вертикальный угол направления взгляда камеры в радианах

Синтаксис

[Visual Basic 6]
Property VertAngle As Double

[Delphi]
property VertAngle: Double

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.ZoomFactor (свойство)

Эффект оптического изменения масштаба изображения (в норме = 1.0)

Синтаксис

[Visual Basic 6]
Property ZoomFactor As Double

[Delphi]
property ZoomFactor: Double

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.AddInfo (метод)

Добавить текстовое сообщение на экран 3D вида на указанное время

Синтаксис

[Visual Basic 6]
Sub AddInfo ( _
   ByVal MessageID As String, _
   ByVal Message As String, _
   ByVal Milliseconds As Long _
)

[Delphi]
procedure AddInfo(
   const MessageID: WideString;
   const Message: WideString;
   const Milliseconds: Cardinal
)

Описание параметров

MessageID
[in] Идентификатор сообщения. При добавлении нового сообщения с таким же идентификатором старое сообщение будет заменено
Message
[in] Текст сообщения. Указав пустую строку можно принудительно удалить сообщение
Milliseconds
[in] Время в миллисекундах, в течение которого сообщение должно оставаться на экране. Если указать "0", то сообщение не будет удалено

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.BeginUpdate (метод)

Начать серию изменений

Синтаксис

[Visual Basic 6]
Sub BeginUpdate

[Delphi]
procedure BeginUpdate

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.GenerateLightIndex (метод)

Генерирует и возвращает индекс источника света, который можно использовать для установки дополнительного источника освещения

Синтаксис

[Visual Basic 6]
Function GenerateLightIndex ( _
   NewLightIndex As Long _
) As Long

[Delphi]
function GenerateLightIndex(
   out NewLightIndex: Integer
): HResult

Описание параметров

NewLightIndex
[out] Возвращённый индекс источника освещения, либо -1 в случае ошибки

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.GetEyePosition (метод)

Возвращает позицию камеры

Синтаксис

[Visual Basic 6]
Function GetEyePosition ( _
   X As Double, _
   Y As Double, _
   Z As Double _
) As Long

[Delphi]
function GetEyePosition(
   out X: Double;
   out Y: Double;
   out Z: Double
): HResult

Описание параметров

X
[out] Возврвщаемая модельная X-координата позиции камеры
Y
[out] Возврвщаемая модельная Y-координата позиции камеры
Z
[out] Возврвщаемая модельная Z-координата позиции камеры

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.GetPerspectiveParams (метод)

Получить параметры матрицы перспективы

Синтаксис

[Visual Basic 6]
Sub GetPerspectiveParams ( _
   VOF As Double, _
   ZMin As Double, _
   ZMax As Double _
)

[Delphi]
procedure GetPerspectiveParams(
   out VOF: Double;
   out ZMin: Double;
   out ZMax: Double
)

Описание параметров

VOF
[out] Возвращаемый горизонтальный угол обзора в радианах
ZMin
[out] Возвращаемое минимальное значение видимой области
ZMax
[out] Возвращаемое максимальное значение видимой области

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.GetPositionAndVector (метод)

Возвращает позицию и направление взгляда камеры

Синтаксис

[Visual Basic 6]
Function GetPositionAndVector ( _
   X As Double, _
   Y As Double, _
   Z As Double, _
   HorizAngle As Double, _
   VertAngle As Double, _
   Bank As Double _
) As Long

[Delphi]
function GetPositionAndVector(
   out X: Double;
   out Y: Double;
   out Z: Double;
   out HorizAngle: Double;
   out VertAngle: Double;
   out Bank: Double
): HResult

Описание параметров

X
[out] Модельная X-координата позиции камеры
Y
[out] Модельная Y-координата позиции камеры
Z
[out] Модельная Z-координата позиции камеры
HorizAngle
[out] Горизонтальный угол направления взгляда камеры в радианах
VertAngle
[out] Вертикальный угол направления взгляда камеры в радианах
Bank
[out] Крен камеры относительно вертикального положения в радианах

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.GetWidthHeight (метод)

Получить ширину и высоту изображения в окне 3D-вида

Синтаксис

[Visual Basic 6]
Function GetWidthHeight ( _
   Width As Long, _
   Height As Long _
) As Boolean

[Delphi]
function GetWidthHeight(
   out Width: Integer;
   out Height: Integer
): WordBool

Описание параметров

Width
[out] Возвращаемая ширина изображения в окне 3D-вида в пикселях
Height
[out] Возвращаемая высота изображения в окне 3D-вида в пикселях

Возвращаемое значение

Результат операции: True - значения успешно возвращены, False - ошибка

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.RecordStart (метод)

Начать запись траектории пролёта в файл

Синтаксис

[Visual Basic 6]
Function RecordStart ( _
   FileName As String, _
   AccessCode As Long _
) As Boolean

[Delphi]
function RecordStart(
   var FileName: WideString;
   out AccessCode: Integer
): WordBool

Описание параметров

FileName
[in, out] Имя файла для записи траектории пролёта. Если передать пустую строку, то будет вызван диалог выбора файла, выбранный файл возвратится в FileName
AccessCode
[out] Возвращаемый код для прекращения и приостановки записи траектории пролёта

Возвращаемое значение

Результат операции: True - запись траектории начата, False - пользователь отменил операцию, либо ошибка

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.RecordStop (метод)

Завершить запись траектории пролёта в файл

Синтаксис

[Visual Basic 6]
Function RecordStop ( _
   ByVal AccessCode As Long _
) As Boolean

[Delphi]
function RecordStop(
   const AccessCode: Integer
): WordBool

Описание параметров

AccessCode
[in] Код, полученный при вызове метода RecordStart

Возвращаемое значение

Результат операции: True - запись успешно завершена, False - ошибка

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.RegisterController (метод)

Регистрирует контроллер 3D-вида в системе

Синтаксис

[Visual Basic 6]
Function RegisterController ( _
   ByVal Controller As IView3DController, _
   ByVal Signature As String _
) As Long

[Delphi]
function RegisterController(
   const Controller: IView3DController;
   const Signature: WideString
): Integer

Описание параметров

Controller
[in] Контроллер 3D-вида, который необходимо зарегистрировать
Signature
[in] Сигнатура контроллера 3D-вида, используется при сохранении/загрузки настроет

Возвращаемое значение

Код зарегистрированного контроллера. Возвращённое число может быть впоследствии передано при аннулировании регистрации контроллера

Смотри также

Interface IView3DController, Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.Reset (метод)

Переинициализирует сцену в 3D-виде (все объекты возвращаются в "исходное" состояние)

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.SetDeltaTime (метод)

Устанавливает значение, которое потом вернёт свойство DeltaTime при отрисовке следующего кадра. Метод необходим для отображения не в реальном времени (покадрового или записи AVI)

Синтаксис

[Visual Basic 6]
Sub SetDeltaTime ( _
   ByVal Value As Double _
)

[Delphi]
procedure SetDeltaTime(
   const Value: Double
)

Описание параметров

Value
[in] Устанавливаемое значение времени в секундах, прошедшее с момента отрисовки предыдущего кадра

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.SetEyePosition (метод)

Устанавливает позицию камеры

Синтаксис

[Visual Basic 6]
Sub SetEyePosition ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
)

[Delphi]
procedure SetEyePosition(
   const X: Double;
   const Y: Double;
   const Z: Double
)

Описание параметров

X
[in] Модельная X-координата позиции камеры
Y
[in] Модельная Y-координата позиции камеры
Z
[in] Модельная Z-координата позиции камеры

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.SetWidthHeight (метод)

Установить ширину и высоту изображения в окне 3D-вида

Синтаксис

[Visual Basic 6]
Function SetWidthHeight ( _
   ByVal Width As Long, _
   ByVal Height As Long _
) As Boolean

[Delphi]
function SetWidthHeight(
   const Width: Integer;
   const Height: Integer
): WordBool

Описание параметров

Width
[in] Ширина изображения в окне 3D-вида в пикселях
Height
[in] Высота изображения в окне 3D-вида в пикселях

Возвращаемое значение

Результат операции: True - значения успешно установлены, False - ошибка

Смотри также

Class SubSystem3D, Group Трёхмерный вид


SubSystem3D.UnRegisterController (метод)

Аннулирует регистрацию контроллера 3D-вида в системе

Синтаксис

[Visual Basic 6]
Sub UnRegisterController ( _
   ByVal Cookie As Long _
)

[Delphi]
procedure UnRegisterController(
   const Cookie: Integer
)

Описание параметров

Cookie
[in] Код, возвращённый методом RegisterController

Смотри также

Class SubSystem3D, Group Трёхмерный вид


Класс SurfaceDifference

Разность поверхностей

Наследование

BaseObject Class SurfaceDifference

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property BottomLayer (только для чтения) | Нижний слой, образующий разность
Property CaptionsAngle | Угол поворота подписей в градусах для отображения отметок
Property CaptionsColor | Цвет отображения отметок
Property CaptionsFontName | Имя шрифта для отображения отметок
Property CaptionsFontSize | Размер шрифта в миллиметрах для отображения отметок
Property CaptionsOffset | Отступ отметок от точки в миллиметрах
Property ColorRowIndex | Цветовой ряд, используемый для отображения изоконтуров (при фиксированном шаге)
Property Differences (только для чтения) | Родитель - Набор разностей поверхностей
Property DrawCaptions | Отображать ли отметки разности поверхностей
Property Expanded | Раскрыта ли ветвь дерева объекта
Property FixedStep | Используется ли фиксированный шаг построения изоконтуров
Property FixedStepValue | Значение фиксированного шага построения изоконтуров
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Name (только для чтения) | Имя разности поверхностей
Property PointSize | Размер точки при отображении подписей в разности поверхностей
Property Project (только для чтения) | Проект, к которому относится объект
Property ProjectionKind | Отметки каких проекций будут отображаться в плане
Property SimpleDraw | Рисуются ли изоконтуры упрощённо (без заливок)
Property TopLayer (только для чтения) | Верхний слой, образующий разность
Property Triangulation (только для чтения) | Триангуляция, являющаяся разностью поверхностей в заданном регионе
Property Visible | Отображается ли объект в плане

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Где используется

Класс | Член класса
Class SurfaceDifferences | Method AddDifference (метод)

Смотри также

Class Application, Class Layer, Class Project, Enum SurfaceDifferenceProjectionConstants, Class Triangulation, Group Поверхности


SurfaceDifference.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class SurfaceDifference, Group Поверхности


SurfaceDifference.BottomLayer (свойство)

Нижний слой, образующий разность

Синтаксис

[Visual Basic 6]
ReadOnly Property BottomLayer As Layer

[Delphi]
{только для чтения} property BottomLayer: Layer

Смотри также

Class Layer, Class SurfaceDifference, Group Поверхности


SurfaceDifference.CaptionsAngle (свойство)

Угол поворота подписей в градусах для отображения отметок

Синтаксис

[Visual Basic 6]
Property CaptionsAngle As Double

[Delphi]
property CaptionsAngle: Double

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.CaptionsColor (свойство)

Цвет отображения отметок

Синтаксис

[Visual Basic 6]
Property CaptionsColor As OLE_COLOR

[Delphi]
property CaptionsColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.CaptionsFontName (свойство)

Имя шрифта для отображения отметок

Синтаксис

[Visual Basic 6]
Property CaptionsFontName As String

[Delphi]
property CaptionsFontName: WideString

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.CaptionsFontSize (свойство)

Размер шрифта в миллиметрах для отображения отметок

Синтаксис

[Visual Basic 6]
Property CaptionsFontSize As Double

[Delphi]
property CaptionsFontSize: Double

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.CaptionsOffset (свойство)

Отступ отметок от точки в миллиметрах

Синтаксис

[Visual Basic 6]
Property CaptionsOffset As Double

[Delphi]
property CaptionsOffset: Double

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.ColorRowIndex (свойство)

Цветовой ряд, используемый для отображения изоконтуров (при фиксированном шаге)

Синтаксис

[Visual Basic 6]
Property ColorRowIndex As Long

[Delphi]
property ColorRowIndex: Integer

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.Differences (свойство)

Родитель - Набор разностей поверхностей

Синтаксис

[Visual Basic 6]
ReadOnly Property Differences As SurfaceDifferences

[Delphi]
{только для чтения} property Differences: SurfaceDifferences

Смотри также

Class SurfaceDifference, Class SurfaceDifferences, Group Поверхности


SurfaceDifference.DrawCaptions (свойство)

Отображать ли отметки разности поверхностей

Синтаксис

[Visual Basic 6]
Property DrawCaptions As Boolean

[Delphi]
property DrawCaptions: WordBool

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.Expanded (свойство)

Раскрыта ли ветвь дерева объекта

Синтаксис

[Visual Basic 6]
Property Expanded As Boolean

[Delphi]
property Expanded: WordBool

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.FixedStep (свойство)

Используется ли фиксированный шаг построения изоконтуров

Синтаксис

[Visual Basic 6]
Property FixedStep As Boolean

[Delphi]
property FixedStep: WordBool

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.FixedStepValue (свойство)

Значение фиксированного шага построения изоконтуров

Синтаксис

[Visual Basic 6]
Property FixedStepValue As Double

[Delphi]
property FixedStepValue: Double

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.Name (свойство)

Имя разности поверхностей

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.PointSize (свойство)

Размер точки при отображении подписей в разности поверхностей

Синтаксис

[Visual Basic 6]
Property PointSize As Double

[Delphi]
property PointSize: Double

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class SurfaceDifference, Group Поверхности


SurfaceDifference.ProjectionKind (свойство)

Отметки каких проекций будут отображаться в плане

Синтаксис

[Visual Basic 6]
Property ProjectionKind As SurfaceDifferenceProjectionConstants

[Delphi]
property ProjectionKind: SurfaceDifferenceProjectionConstants

Смотри также

Class SurfaceDifference, Enum SurfaceDifferenceProjectionConstants, Group Поверхности


SurfaceDifference.SimpleDraw (свойство)

Рисуются ли изоконтуры упрощённо (без заливок)

Синтаксис

[Visual Basic 6]
Property SimpleDraw As Boolean

[Delphi]
property SimpleDraw: WordBool

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.TopLayer (свойство)

Верхний слой, образующий разность

Синтаксис

[Visual Basic 6]
ReadOnly Property TopLayer As Layer

[Delphi]
{только для чтения} property TopLayer: Layer

Смотри также

Class Layer, Class SurfaceDifference, Group Поверхности


SurfaceDifference.Triangulation (свойство)

Триангуляция, являющаяся разностью поверхностей в заданном регионе

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class SurfaceDifference, Class Triangulation, Group Поверхности


SurfaceDifference.Visible (свойство)

Отображается ли объект в плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class SurfaceDifference, Group Поверхности


SurfaceDifference.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class SurfaceDifference, Group Поверхности


Класс SurfaceDifferences

Набор разностей поверхностей

Наследование

BaseObject Class SurfaceDifferences

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Count (только для чтения) | Количество объектов, которое содержит в себе данный объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Массив объектов (нумерация идёт от 0 до Count-1)
Property Project (только для чтения) | Проект, к которому относится объект

Методы класса

Имя | Описание
Method AddDifference | Создать разность поверхностей
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Clear | Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект
Method Delete | Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo

Где используется

Класс | Член класса
Class Project | Property SurfaceDifferences (свойство)
Class SurfaceDifference | Property Differences (свойство)

Смотри также

Class Application, Class BaseObject, Class Layer, Group Поверхности


SurfaceDifferences.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.Count (свойство)

Количество объектов, которое содержит в себе данный объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.Items (свойство)

Массив объектов (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BaseObject

[Delphi]
{только для чтения} property Items: BaseObject

Смотри также

Class BaseObject, Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.AddDifference (метод)

Создать разность поверхностей

Синтаксис

[Visual Basic 6]
Function AddDifference ( _
   ByVal Top As Layer, _
   ByVal Bottom As Layer _
) As SurfaceDifference

[Delphi]
function AddDifference(
   const Top: Layer;
   const Bottom: Layer
): SurfaceDifference

Описание параметров

Top
[in] Слой, который является верхним при построении разности поверохностей
Bottom
[in] Слой, который является нижним при построении разности поверохностей

Возвращаемое значение

Возвращаемый объект "Разность поверхностей", либо Nothing в случае обшибки

Смотри также

Class Layer, Class SurfaceDifference, Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.Clear (метод)

Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.Delete (метод)

Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс объекта (нумерация идёт от 0 до Count-1)

Смотри также

Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class SurfaceDifferences, Group Поверхности


SurfaceDifferences.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class SurfaceDifferences, Group Поверхности


Класс SurfacePainter

Элемент закраски поверхности в слое

Наследование

BaseObject Class SurfacePainter

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Color | Цвет, которым элемент окрашивает поверхность
Property Count (только для чтения) | Количество узлов объекта
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Painters (только для чтения) | Список элементов закраски поверхности, которому принадлежит объект
Property Project (только для чтения) | Проект, к которому относится объект
Property Selected | Признак того, что элемент выделен
Property TextureID | Код текстуры для закраски поверхности в 3D-виде (0 - нет текстуры)

Методы класса

Имя | Описание
Method AddNode | Добавить узел к концу списка узлов
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Delete | Удалить узел с указанным индексом
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method GetNode | Получить координаты указанного узла
Method InsertNode | Вставить узел в указанную позицию списка узлов
Method SetNode | Установить координаты указанного узла

Где используется

Класс | Член класса
Class SurfacePainters | Method CreateNew (метод) Method Move (метод)

Смотри также

Class Application, Class Project, Group Поверхности


SurfacePainter.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class SurfacePainter, Group Поверхности


SurfacePainter.Color (свойство)

Цвет, которым элемент окрашивает поверхность

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.Count (свойство)

Количество узлов объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.Painters (свойство)

Список элементов закраски поверхности, которому принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Painters As SurfacePainters

[Delphi]
{только для чтения} property Painters: SurfacePainters

Смотри также

Class SurfacePainter, Class SurfacePainters, Group Поверхности


SurfacePainter.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class SurfacePainter, Group Поверхности


SurfacePainter.Selected (свойство)

Признак того, что элемент выделен

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.TextureID (свойство)

Код текстуры для закраски поверхности в 3D-виде (0 - нет текстуры)

Синтаксис

[Visual Basic 6]
Property TextureID As Long

[Delphi]
property TextureID: Integer

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.AddNode (метод)

Добавить узел к концу списка узлов

Синтаксис

[Visual Basic 6]
Function AddNode ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
) As Long

[Delphi]
function AddNode(
   const ModelX: Double;
   const ModelY: Double
): Integer

Описание параметров

ModelX
[in] Модельная X-координата добавляемого узла
ModelY
[in] Модельная Y-координата добавляемого узла

Возвращаемое значение

Индекс добавленного узла

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.Delete (метод)

Удалить узел с указанным индексом

Синтаксис

[Visual Basic 6]
Function Delete ( _
   ByVal Index As Long _
) As Boolean

[Delphi]
function Delete(
   const Index: Integer
): WordBool

Описание параметров

Index
[in] Индекс удаляемого узла

Возвращаемое значение

Результат операции: True - узел успешно удалён, False - ошибка

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.GetNode (метод)

Получить координаты указанного узла

Синтаксис

[Visual Basic 6]
Function GetNode ( _
   ByVal Index As Long, _
   ModelX As Double, _
   ModelY As Double _
) As Boolean

[Delphi]
function GetNode(
   const Index: Integer;
   out ModelX: Double;
   out ModelY: Double
): WordBool

Описание параметров

Index
[in] Индекс запрашиваемого узла
ModelX
[out] Возвращаемая модельная X-координата узла
ModelY
[out] Возвращаемая модельная Y-координата узла

Возвращаемое значение

Результат операции: True - значения возвращены успешно, False - ошибка

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.InsertNode (метод)

Вставить узел в указанную позицию списка узлов

Синтаксис

[Visual Basic 6]
Function InsertNode ( _
   ByVal Index As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
) As Boolean

[Delphi]
function InsertNode(
   const Index: Integer;
   const ModelX: Double;
   const ModelY: Double
): WordBool

Описание параметров

Index
[in] Позиция, в которую необходимо вставить узел
ModelX
[in] Модельная X-координата добавляемого узла
ModelY
[in] Модельная Y-координата добавляемого узла

Возвращаемое значение

Результат операции: True - успешно, False - ошибка

Смотри также

Class SurfacePainter, Group Поверхности


SurfacePainter.SetNode (метод)

Установить координаты указанного узла

Синтаксис

[Visual Basic 6]
Function SetNode ( _
   ByVal Index As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
) As Boolean

[Delphi]
function SetNode(
   const Index: Integer;
   const ModelX: Double;
   const ModelY: Double
): WordBool

Описание параметров

Index
[in] Индекс запрашиваемого узла
ModelX
[in] Новая модельная X-координата узла
ModelY
[in] Новая модельная Y-координата узла

Возвращаемое значение

Результат операции: True - значения установлены успешно, False - ошибка

Смотри также

Class SurfacePainter, Group Поверхности


Класс SurfacePainters

Список элементов закраски поверхности в слое

Наследование

BaseObject Class SurfacePainters

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Application (только для чтения) | Приложение, в котором существует объект
Property Count (только для чтения) | Количество объектов, которое содержит в себе данный объект
Property Handle (только для чтения) | Handle объекта
Property ID (только для чтения) | ID объекта
Property Items (только для чтения) | Массив объектов (нумерация идёт от 0 до Count-1)
Property Project (только для чтения) | Проект, к которому относится объект

Методы класса

Имя | Описание
Method BeginUpdate | Начать серию изменений объекта
Method BeginUpdateLocked | Начать серию изменений объекта с блокировкой Undo/Redo
Method Clear | Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект
Method CreateNew | Создаёт новый элемент закраски с указанными координатами
Method Delete | Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён
Method EndUpdate | Закончить серию изменений
Method EndUpdateLocked | Закончить серию изменений объекта с блокировкой Undo/Redo
Method Move | Перемещает указанный элемент закраски в другую позицию в списке

Где используется

Класс | Член класса
Class Layer | Property SurfacePainters (свойство)
Class SurfacePainter | Property Painters (свойство)

Смотри также

Class Application, Class BaseObject, Class Project, Group Поверхности


SurfacePainters.Application (свойство)

Приложение, в котором существует объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Application As Application

[Delphi]
{только для чтения} property Application: Application

Смотри также

Class Application, Class SurfacePainters, Group Поверхности


SurfacePainters.Count (свойство)

Количество объектов, которое содержит в себе данный объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.ID (свойство)

ID объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ID As String

[Delphi]
{только для чтения} property ID: WideString

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.Items (свойство)

Массив объектов (нумерация идёт от 0 до Count-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As BaseObject

[Delphi]
{только для чтения} property Items: BaseObject

Смотри также

Class BaseObject, Class SurfacePainters, Group Поверхности


SurfacePainters.Project (свойство)

Проект, к которому относится объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Project As Project

[Delphi]
{только для чтения} property Project: Project

Смотри также

Class Project, Class SurfacePainters, Group Поверхности


SurfacePainters.BeginUpdate (метод)

Начать серию изменений объекта

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   ByVal Message As String _
)

[Delphi]
procedure BeginUpdate(
   const Message: WideString
)

Описание параметров

Message
[in] Описание изменений (используется для Undo/Redo)

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.BeginUpdateLocked (метод)

Начать серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub BeginUpdateLocked

[Delphi]
procedure BeginUpdateLocked

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.Clear (метод)

Удалить все объекты, которые содержит данный объект. В случае, если хотя бы один объект обязан существовать, после выполнения метода останется один объект

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.CreateNew (метод)

Создаёт новый элемент закраски с указанными координатами

Синтаксис

[Visual Basic 6]
Function CreateNew ( _
   ByVal StartX As Double, _
   ByVal StartY As Double, _
   ByVal EndX As Double, _
   ByVal EndY As Double _
) As SurfacePainter

[Delphi]
function CreateNew(
   const StartX: Double;
   const StartY: Double;
   const EndX: Double;
   const EndY: Double
): SurfacePainter

Описание параметров

StartX
[in] Модельная X-координата первого узла элемента
StartY
[in] Модельная Y-координата первого узла элемента
EndX
[in] Модельная X-координата последнего узла элемента
EndY
[in] Модельная Y-координата последнего узла элемента

Возвращаемое значение

Созданный элемент закраски, либо Nothing в случае ошибки

Смотри также

Class SurfacePainter, Class SurfacePainters, Group Поверхности


SurfacePainters.Delete (метод)

Удалить объект из списка. В случае, если остался один объект, и он обязан существовать, то он не будет удалён

Синтаксис

[Visual Basic 6]
Sub Delete ( _
   ByVal Index As Long _
)

[Delphi]
procedure Delete(
   const Index: Integer
)

Описание параметров

Index
[in] Индекс объекта (нумерация идёт от 0 до Count-1)

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.EndUpdate (метод)

Закончить серию изменений

Синтаксис

[Visual Basic 6]
Sub EndUpdate ( _
   [ByVal Abort As Boolean = False] _
)

[Delphi]
procedure EndUpdate(
   const Abort: WordBool
)

Описание параметров

Abort
[in] True - отменить все действия, выполненные после соответствующего вызова BeginUpdate

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.EndUpdateLocked (метод)

Закончить серию изменений объекта с блокировкой Undo/Redo

Синтаксис

[Visual Basic 6]
Sub EndUpdateLocked

[Delphi]
procedure EndUpdateLocked

Смотри также

Class SurfacePainters, Group Поверхности


SurfacePainters.Move (метод)

Перемещает указанный элемент закраски в другую позицию в списке

Синтаксис

[Visual Basic 6]
Function Move ( _
   ByVal SurfacePainter As SurfacePainter, _
   ByVal NewIndex As Long _
) As Boolean

[Delphi]
function Move(
   const SurfacePainter: SurfacePainter;
   const NewIndex: Integer
): WordBool

Описание параметров

SurfacePainter
[in] Элемент, который необходимо переместить
NewIndex
[in] Позиция в списке, на которую необходимо переместить элемент (нумерация идёт от 0 до Count-1)

Возвращаемое значение

Результат операции: True - успешно, False - ошибка

Смотри также

Class SurfacePainter, Class SurfacePainters, Group Поверхности


Класс Survey

Пикетажная съёмка

Наследование

Measuring Class Survey

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AimingStation | Точка наведения
Property AnglesAreLeft | Измеренные углы являются левыми (в противном случае - правыми)
Property FromStation | Точка стояния
Property Handle (только для чтения) | Handle объекта
Property HorzAngleCorrection | Поправка прибора для горизонтального угла
Property InstrumentHeight | Высота прибора при съёмке пикетов
Property LengthCorrection | Поправка прибора для расстояний
Property Limb | Установка лимба
Property Name | Наименование съёмки
Property SurveyPointCount (только для чтения) | Количество съёмочных точек
Property SurveyPoints (только для чтения) | Массив съёмочных точек
Property VertAngleCorrection | Поправка прибора для вертикального угла
Property VertAnglesAreFromZenith | Вертикальный угол измеряется от зенита (в противном случае - от горизонта)
Property Visible | Видима ли съёмка на плане

Методы класса

Имя | Описание
Method AddSurveyPoint | Добавить точку в съёмку
Method DeleteSurveyPoint | Удалить точку из съёмки

Где используется

Класс | Член класса
Class FieldTraverse | Property Surveys (свойство) Method AddSurvey (метод) Method RemoveSurvey (метод) Method SurveyByName (метод)
Class SurveyEditor | Property ActiveSurvey (свойство)
Class SurveyPoint | Property Survey (свойство)

Смотри также

Class GeodesyAngle, Class GeoPoint, Group Геодезия


Survey.AimingStation (свойство)

Точка наведения

Синтаксис

[Visual Basic 6]
Property AimingStation As GeoPoint

[Delphi]
property AimingStation: GeoPoint

Смотри также

Class GeoPoint, Class Survey, Group Геодезия


Survey.AnglesAreLeft (свойство)

Измеренные углы являются левыми (в противном случае - правыми)

Синтаксис

[Visual Basic 6]
Property AnglesAreLeft As Boolean

[Delphi]
property AnglesAreLeft: WordBool

Смотри также

Class Survey, Group Геодезия


Survey.FromStation (свойство)

Точка стояния

Синтаксис

[Visual Basic 6]
Property FromStation As GeoPoint

[Delphi]
property FromStation: GeoPoint

Смотри также

Class GeoPoint, Class Survey, Group Геодезия


Survey.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Survey, Group Геодезия


Survey.HorzAngleCorrection (свойство)

Поправка прибора для горизонтального угла

Синтаксис

[Visual Basic 6]
Property HorzAngleCorrection As GeodesyAngle

[Delphi]
property HorzAngleCorrection: GeodesyAngle

Смотри также

Class GeodesyAngle, Class Survey, Group Геодезия


Survey.InstrumentHeight (свойство)

Высота прибора при съёмке пикетов

Синтаксис

[Visual Basic 6]
Property InstrumentHeight As Double

[Delphi]
property InstrumentHeight: Double

Смотри также

Class Survey, Group Геодезия


Survey.LengthCorrection (свойство)

Поправка прибора для расстояний

Синтаксис

[Visual Basic 6]
Property LengthCorrection As Double

[Delphi]
property LengthCorrection: Double

Смотри также

Class Survey, Group Геодезия


Survey.Limb (свойство)

Установка лимба

Синтаксис

[Visual Basic 6]
Property Limb As Double

[Delphi]
property Limb: Double

Смотри также

Class Survey, Group Геодезия


Survey.Name (свойство)

Наименование съёмки

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Class Survey, Group Геодезия


Survey.SurveyPointCount (свойство)

Количество съёмочных точек

Синтаксис

[Visual Basic 6]
ReadOnly Property SurveyPointCount As Long

[Delphi]
{только для чтения} property SurveyPointCount: Integer

Смотри также

Class Survey, Group Геодезия


Survey.SurveyPoints (свойство)

Массив съёмочных точек

Синтаксис

[Visual Basic 6]
ReadOnly Property SurveyPoints As SurveyPoint

[Delphi]
{только для чтения} property SurveyPoints: SurveyPoint

Смотри также

Class Survey, Class SurveyPoint, Group Геодезия


Survey.VertAngleCorrection (свойство)

Поправка прибора для вертикального угла

Синтаксис

[Visual Basic 6]
Property VertAngleCorrection As GeodesyAngle

[Delphi]
property VertAngleCorrection: GeodesyAngle

Смотри также

Class GeodesyAngle, Class Survey, Group Геодезия


Survey.VertAnglesAreFromZenith (свойство)

Вертикальный угол измеряется от зенита (в противном случае - от горизонта)

Синтаксис

[Visual Basic 6]
Property VertAnglesAreFromZenith As Boolean

[Delphi]
property VertAnglesAreFromZenith: WordBool

Смотри также

Class Survey, Group Геодезия


Survey.Visible (свойство)

Видима ли съёмка на плане

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Survey, Group Геодезия


Survey.AddSurveyPoint (метод)

Добавить точку в съёмку

Синтаксис

[Visual Basic 6]
Function AddSurveyPoint As SurveyPoint

[Delphi]
function AddSurveyPoint: SurveyPoint

Возвращаемое значение

Возвращает новую точку в съёмке

Смотри также

Class Survey, Class SurveyPoint, Group Геодезия


Survey.DeleteSurveyPoint (метод)

Удалить точку из съёмки

Синтаксис

[Visual Basic 6]
Sub DeleteSurveyPoint ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteSurveyPoint(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемой точки (нумерация точек идёт от 0 до SurveyPointCount(-1)

Смотри также

Class Survey, Group Геодезия


Класс SurveyEditor

Геодезический редактор

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ActiveAdditionalPoint | Текущая дополнительная точка (засечка)
Property ActiveFieldTraverse | Текущий теодолитный ход
Property ActiveFieldTraversePoint | Текущая точка теодолитного хода
Property ActivePage | Активная страница редактора
Property ActiveSurvey | Текущая пикетажная съёмка
Property ActiveSurveyPoint | Текущая точка пикетажной съёмки
Property AngleMode | Точность отображения углов
Property ApplicationHandle (только для чтения) | Handle окна редактора
Property GeodesyBook | Геодезический журнал
Property NumberPrecision | Количество знаков после запятой в записи чисел

Методы класса

Имя | Описание
Method AddExportTask | Добавить команду экспорта
Method AddImportTask | Добавить команду импорта
Method AddTask | Добавить команду
Method Close | Закрыть окно геодезического редактора
Method Open | Открыть окно геодезического редактора
Method Update | Обновить содержимое окна геодезического редактора
Method ZoomToAll | Вписать все точки в окно плана

Где используется

Класс | Член класса
Class Application | Property SurveyEditor (свойство)
Class GeodesyBook | Method OpenEditor (метод)

Смотри также

Class AdditionalPoint, Enum AngleModeConstants, Class FieldTraverse, Class GeoPoint, Class Survey, Enum SurveyEditorPageConstants, Class SurveyPoint, Group Геодезия


SurveyEditor.ActiveAdditionalPoint (свойство)

Текущая дополнительная точка (засечка)

Синтаксис

[Visual Basic 6]
Property ActiveAdditionalPoint As AdditionalPoint

[Delphi]
property ActiveAdditionalPoint: AdditionalPoint

Смотри также

Class AdditionalPoint, Class SurveyEditor, Group Геодезия


SurveyEditor.ActiveFieldTraverse (свойство)

Текущий теодолитный ход

Синтаксис

[Visual Basic 6]
Property ActiveFieldTraverse As FieldTraverse

[Delphi]
property ActiveFieldTraverse: FieldTraverse

Смотри также

Class FieldTraverse, Class SurveyEditor, Group Геодезия


SurveyEditor.ActiveFieldTraversePoint (свойство)

Текущая точка теодолитного хода

Синтаксис

[Visual Basic 6]
Property ActiveFieldTraversePoint As GeoPoint

[Delphi]
property ActiveFieldTraversePoint: GeoPoint

Смотри также

Class GeoPoint, Class SurveyEditor, Group Геодезия


SurveyEditor.ActivePage (свойство)

Активная страница редактора

Синтаксис

[Visual Basic 6]
Property ActivePage As SurveyEditorPageConstants

[Delphi]
property ActivePage: SurveyEditorPageConstants

Смотри также

Class SurveyEditor, Enum SurveyEditorPageConstants, Group Геодезия


SurveyEditor.ActiveSurvey (свойство)

Текущая пикетажная съёмка

Синтаксис

[Visual Basic 6]
Property ActiveSurvey As Survey

[Delphi]
property ActiveSurvey: Survey

Смотри также

Class Survey, Class SurveyEditor, Group Геодезия


SurveyEditor.ActiveSurveyPoint (свойство)

Текущая точка пикетажной съёмки

Синтаксис

[Visual Basic 6]
Property ActiveSurveyPoint As SurveyPoint

[Delphi]
property ActiveSurveyPoint: SurveyPoint

Смотри также

Class SurveyEditor, Class SurveyPoint, Group Геодезия


SurveyEditor.AngleMode (свойство)

Точность отображения углов

Синтаксис

[Visual Basic 6]
Property AngleMode As AngleModeConstants

[Delphi]
property AngleMode: AngleModeConstants

Смотри также

Enum AngleModeConstants, Class SurveyEditor, Group Геодезия


SurveyEditor.ApplicationHandle (свойство)

Handle окна редактора

Синтаксис

[Visual Basic 6]
ReadOnly Property ApplicationHandle As OLE_HANDLE

[Delphi]
{только для чтения} property ApplicationHandle: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurveyEditor, Group Геодезия


SurveyEditor.GeodesyBook (свойство)

Геодезический журнал

Синтаксис

[Visual Basic 6]
Property GeodesyBook As GeodesyBook

[Delphi]
property GeodesyBook: GeodesyBook

Смотри также

Class GeodesyBook, Class SurveyEditor, Group Геодезия


SurveyEditor.NumberPrecision (свойство)

Количество знаков после запятой в записи чисел

Синтаксис

[Visual Basic 6]
Property NumberPrecision As Long

[Delphi]
property NumberPrecision: Integer

Смотри также

Class SurveyEditor, Group Геодезия


SurveyEditor.AddExportTask (метод)

Добавить команду экспорта

Синтаксис

[Visual Basic 6]
Sub AddExportTask ( _
   ByVal Name As String, _
   ByVal CommandID As Long, _
   ByVal Instance As OLE_HANDLE _
)

[Delphi]
procedure AddExportTask(
   const Name: WideString;
   const CommandID: Integer;
   const Instance: OLE_HANDLE
)

Описание параметров

Name
[in] Наименование команды
CommandID
[in] Код команды
Instance
[in] Instance модуля

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurveyEditor, Group Геодезия


SurveyEditor.AddImportTask (метод)

Добавить команду импорта

Синтаксис

[Visual Basic 6]
Sub AddImportTask ( _
   ByVal Name As String, _
   ByVal CommandID As Long, _
   ByVal Instance As OLE_HANDLE _
)

[Delphi]
procedure AddImportTask(
   const Name: WideString;
   const CommandID: Integer;
   const Instance: OLE_HANDLE
)

Описание параметров

Name
[in] Наименование команды
CommandID
[in] Код команды
Instance
[in] Instance модуля

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurveyEditor, Group Геодезия


SurveyEditor.AddTask (метод)

Добавить команду

Синтаксис

[Visual Basic 6]
Sub AddTask ( _
   ByVal Name As String, _
   ByVal CommandID As Long, _
   ByVal Instance As OLE_HANDLE _
)

[Delphi]
procedure AddTask(
   const Name: WideString;
   const CommandID: Integer;
   const Instance: OLE_HANDLE
)

Описание параметров

Name
[in] Наименование команды
CommandID
[in] Код команды
Instance
[in] Instance модуля

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurveyEditor, Group Геодезия


SurveyEditor.Close (метод)

Закрыть окно геодезического редактора

Синтаксис

[Visual Basic 6]
Sub Close

[Delphi]
procedure Close

Смотри также

Class SurveyEditor, Group Геодезия


SurveyEditor.Open (метод)

Открыть окно геодезического редактора

Синтаксис

[Visual Basic 6]
Sub Open ( _
   [ByVal Modal As Boolean = False] _
)

[Delphi]
procedure Open(
   const Modal: WordBool
)

Описание параметров

Modal
[in] Открыть окно в модальном режиме

Смотри также

Class SurveyEditor, Group Геодезия


SurveyEditor.Update (метод)

Обновить содержимое окна геодезического редактора

Синтаксис

[Visual Basic 6]
Sub Update

[Delphi]
procedure Update

Смотри также

Class SurveyEditor, Group Геодезия


SurveyEditor.ZoomToAll (метод)

Вписать все точки в окно плана

Синтаксис

[Visual Basic 6]
Sub ZoomToAll

[Delphi]
procedure ZoomToAll

Смотри также

Class SurveyEditor, Group Геодезия


Класс SurveyPoint

Съёмочная точка

Наследование

GeoPoint Class LinkedGeoPoint Class CustomSurveyPoint Class SurveyPoint

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property DH | Приращение высоты (превышение)
Property DirAngle | Дирекционный угол
Property Handle (только для чтения) | Handle объекта
Property Height | Высота точки
Property HorzAngle | Измеренный горизонтальный угол
Property HorzLength | Горизонтальная длина (в проекции)
Property KindCode | Код типа точки
Property KindDescription | Описание типа точки
Property Length | Измеренное расстояние
Property LinkedPoint | Ссылка на другую точку
Property Number | Номер (описание) точки
Property Position | Положение точки
Property SourceStation (только для чтения) | Станция, с которой снята точка
Property Survey (только для чтения) | Съёмка, которой принадлежит точка
Property VaneHeight | Высота линейки (вешки)
Property VertAngle | Вертикальный угол

Где используется

Класс | Член класса
Class Survey | Property SurveyPoints (свойство) Method AddSurveyPoint (метод)
Class SurveyEditor | Property ActiveSurveyPoint (свойство)

Смотри также

Class GeodesyAngle, Class GeoPoint, Class ModelPoint, Group Геодезия


SurveyPoint.DH (свойство)

Приращение высоты (превышение)

Синтаксис

[Visual Basic 6]
Property DH As Double

[Delphi]
property DH: Double

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.DirAngle (свойство)

Дирекционный угол

Синтаксис

[Visual Basic 6]
Property DirAngle As GeodesyAngle

[Delphi]
property DirAngle: GeodesyAngle

Смотри также

Class GeodesyAngle, Class SurveyPoint, Group Геодезия


SurveyPoint.Handle (свойство)

Handle объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property Handle As OLE_HANDLE

[Delphi]
{только для чтения} property Handle: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.Height (свойство)

Высота точки

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.HorzAngle (свойство)

Измеренный горизонтальный угол

Синтаксис

[Visual Basic 6]
Property HorzAngle As GeodesyAngle

[Delphi]
property HorzAngle: GeodesyAngle

Смотри также

Class GeodesyAngle, Class SurveyPoint, Group Геодезия


SurveyPoint.HorzLength (свойство)

Горизонтальная длина (в проекции)

Синтаксис

[Visual Basic 6]
Property HorzLength As Double

[Delphi]
property HorzLength: Double

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.KindCode (свойство)

Код типа точки

Синтаксис

[Visual Basic 6]
Property KindCode As Long

[Delphi]
property KindCode: Integer

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.KindDescription (свойство)

Описание типа точки

Синтаксис

[Visual Basic 6]
Property KindDescription As String

[Delphi]
property KindDescription: WideString

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.Length (свойство)

Измеренное расстояние

Синтаксис

[Visual Basic 6]
Property Length As Double

[Delphi]
property Length: Double

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.LinkedPoint (свойство)

Ссылка на другую точку

Синтаксис

[Visual Basic 6]
Property LinkedPoint As GeoPoint

[Delphi]
property LinkedPoint: GeoPoint

Смотри также

Class GeoPoint, Class SurveyPoint, Group Геодезия


SurveyPoint.Number (свойство)

Номер (описание) точки

Синтаксис

[Visual Basic 6]
Property Number As String

[Delphi]
property Number: WideString

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
Property Position As ModelPoint

[Delphi]
property Position: ModelPoint

Смотри также

Class ModelPoint, Class SurveyPoint, Group Геодезия


SurveyPoint.SourceStation (свойство)

Станция, с которой снята точка

Синтаксис

[Visual Basic 6]
ReadOnly Property SourceStation As GeoPoint

[Delphi]
{только для чтения} property SourceStation: GeoPoint

Смотри также

Class GeoPoint, Class SurveyPoint, Group Геодезия


SurveyPoint.Survey (свойство)

Съёмка, которой принадлежит точка

Синтаксис

[Visual Basic 6]
ReadOnly Property Survey As Survey

[Delphi]
{только для чтения} property Survey: Survey

Смотри также

Class Survey, Class SurveyPoint, Group Геодезия


SurveyPoint.VaneHeight (свойство)

Высота линейки (вешки)

Синтаксис

[Visual Basic 6]
Property VaneHeight As Double

[Delphi]
property VaneHeight: Double

Смотри также

Class SurveyPoint, Group Геодезия


SurveyPoint.VertAngle (свойство)

Вертикальный угол

Синтаксис

[Visual Basic 6]
Property VertAngle As GeodesyAngle

[Delphi]
property VertAngle: GeodesyAngle

Смотри также

Class GeodesyAngle, Class SurveyPoint, Group Геодезия


Класс TopoArrowStyle

Стиль оформления стрелок

Наследование

TopoArrowStyle Class TopoDimensionStyle

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoArrowStyle

ClassID = {60170014-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property LineColor | Цвет стрелки или размерной линии (кроме текста)
Property LineWidth | Толщина линий
Property NotchKind | Тип засечек
Property NotchSize | Размер засечек

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другого стиля оформления стрелок
Method Reset | Сбросить все параметры в значения по умолчанию

Где используется

Класс | Член класса
Class TopoArrowStyle | Method Assign (метод)
Class TopoDimensionStyle | Method Assign (метод)

Смотри также

Enum NotchKindConstants, Group Условные знаки


TopoArrowStyle.LineColor (свойство)

Цвет стрелки или размерной линии (кроме текста)

Синтаксис

[Visual Basic 6]
Property LineColor As OLE_COLOR

[Delphi]
property LineColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoArrowStyle, Group Условные знаки


TopoArrowStyle.LineWidth (свойство)

Толщина линий

Синтаксис

[Visual Basic 6]
Property LineWidth As Double

[Delphi]
property LineWidth: Double

Смотри также

Class TopoArrowStyle, Group Условные знаки


TopoArrowStyle.NotchKind (свойство)

Тип засечек

Синтаксис

[Visual Basic 6]
Property NotchKind As NotchKindConstants

[Delphi]
property NotchKind: NotchKindConstants

Смотри также

Enum NotchKindConstants, Class TopoArrowStyle, Group Условные знаки


TopoArrowStyle.NotchSize (свойство)

Размер засечек

Синтаксис

[Visual Basic 6]
Property NotchSize As Double

[Delphi]
property NotchSize: Double

Смотри также

Class TopoArrowStyle, Group Условные знаки


TopoArrowStyle.Assign (метод)

Скопировать параметры из другого стиля оформления стрелок

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Source As TopoArrowStyle _
)

[Delphi]
procedure Assign(
   const Source: TopoArrowStyle
)

Описание параметров

Source
[in] Другой стиль оформления стрелок, из которого будут скопированы параметры

Смотри также

Class TopoArrowStyle, Group Условные знаки


TopoArrowStyle.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoArrowStyle, Group Условные знаки


Класс TopoDimensionStyle

Стиль оформления размерных линий

Наследование

TopoArrowStyle Class TopoDimensionStyle

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoDimensionStyle

ClassID = {60170016-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property LineColor | Цвет стрелки или размерной линии (кроме текста)
Property LineWidth | Толщина линий
Property NotchKind | Тип засечек
Property NotchSize | Размер засечек

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другого стиля оформления стрелок
Method Reset | Сбросить все параметры в значения по умолчанию

Смотри также

Enum NotchKindConstants, Class TopoArrowStyle, Group Условные знаки


TopoDimensionStyle.LineColor (свойство)

Цвет стрелки или размерной линии (кроме текста)

Синтаксис

[Visual Basic 6]
Property LineColor As OLE_COLOR

[Delphi]
property LineColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoDimensionStyle, Group Условные знаки


TopoDimensionStyle.LineWidth (свойство)

Толщина линий

Синтаксис

[Visual Basic 6]
Property LineWidth As Double

[Delphi]
property LineWidth: Double

Смотри также

Class TopoDimensionStyle, Group Условные знаки


TopoDimensionStyle.NotchKind (свойство)

Тип засечек

Синтаксис

[Visual Basic 6]
Property NotchKind As NotchKindConstants

[Delphi]
property NotchKind: NotchKindConstants

Смотри также

Enum NotchKindConstants, Class TopoDimensionStyle, Group Условные знаки


TopoDimensionStyle.NotchSize (свойство)

Размер засечек

Синтаксис

[Visual Basic 6]
Property NotchSize As Double

[Delphi]
property NotchSize: Double

Смотри также

Class TopoDimensionStyle, Group Условные знаки


TopoDimensionStyle.Assign (метод)

Скопировать параметры из другого стиля оформления стрелок

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Source As TopoArrowStyle _
)

[Delphi]
procedure Assign(
   const Source: TopoArrowStyle
)

Описание параметров

Source
[in] Другой стиль оформления стрелок, из которого будут скопированы параметры

Смотри также

Class TopoArrowStyle, Class TopoDimensionStyle, Group Условные знаки


TopoDimensionStyle.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoDimensionStyle, Group Условные знаки


Класс TopoFillStyle

Площадной условный знак

Наследование

TopoSignStyle Class TopoFillStyle

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoFillStyle

ClassID = {60170012-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property BackColor | Цвет сплошной фоновой заливки (для Kind=TopoFillKindSolid и Kind=TopoFillKindSignOverSolid)
Property Color | Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета
Property ColorCount (только для чтения) | Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3
Property Colors | Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]
Property IsColorUsed (только для чтения) | Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign
Property Kind | Тип площадного условного знака
Property Scale | Масштабный размер (в процентах) площадного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoFillKindSign и Kind=TopoFillKindSignOverSolid)
Property Sign | Код топографического условного знака
Property SignName (только для чтения) | Название топографического условного знака, заданного в Sign
Property TextCount (только для чтения) | Количество настраиваемых надписей символа с кодом Sign
Property Texts | Массив настраиваемых надписей символа с кодом Sign

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другого площадного условного знака
Method Reset | Сбросить все параметры в значения по умолчанию
Method SetSignOverSolidStyle | Установить стиль топографического площадного условного знака (с фоновой закраской)
Method SetSignStyle | Установить стиль топографического площадного условного знака (с прозрачным фоном)
Method SetSolidStyle | Установить стиль сплошного площадного условного знака
Method SetStyle | Установить сразу все параметры площадного условного знака

Где используется

Класс | Член класса
Class Line | Property FillStyle (свойство)
Class Lines | Property DefaultFillStyle (свойство)
Class TopoFillStyle | Method Assign (метод)

Смотри также

Enum TopoFillKindConstants, Group Условные знаки


TopoFillStyle.BackColor (свойство)

Цвет сплошной фоновой заливки (для Kind=TopoFillKindSolid и Kind=TopoFillKindSignOverSolid)

Синтаксис

[Visual Basic 6]
Property BackColor As OLE_COLOR

[Delphi]
property BackColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.Color (свойство)

Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.ColorCount (свойство)

Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3

Синтаксис

[Visual Basic 6]
ReadOnly Property ColorCount As Long

[Delphi]
{только для чтения} property ColorCount: Integer

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.Colors (свойство)

Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]

Синтаксис

[Visual Basic 6]
Property Colors As OLE_COLOR

[Delphi]
property Colors: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.IsColorUsed (свойство)

Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property IsColorUsed As Boolean

[Delphi]
{только для чтения} property IsColorUsed: WordBool

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.Kind (свойство)

Тип площадного условного знака

Синтаксис

[Visual Basic 6]
Property Kind As TopoFillKindConstants

[Delphi]
property Kind: TopoFillKindConstants

Смотри также

Enum TopoFillKindConstants, Class TopoFillStyle, Group Условные знаки


TopoFillStyle.Scale (свойство)

Масштабный размер (в процентах) площадного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoFillKindSign и Kind=TopoFillKindSignOverSolid)

Синтаксис

[Visual Basic 6]
Property Scale As Double

[Delphi]
property Scale: Double

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.Sign (свойство)

Код топографического условного знака

Синтаксис

[Visual Basic 6]
Property Sign As Long

[Delphi]
property Sign: Integer

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.SignName (свойство)

Название топографического условного знака, заданного в Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property SignName As String

[Delphi]
{только для чтения} property SignName: WideString

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.TextCount (свойство)

Количество настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property TextCount As Long

[Delphi]
{только для чтения} property TextCount: Integer

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.Texts (свойство)

Массив настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
Property Texts As String

[Delphi]
property Texts: WideString

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.Assign (метод)

Скопировать параметры из другого площадного условного знака

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Source As TopoFillStyle _
)

[Delphi]
procedure Assign(
   const Source: TopoFillStyle
)

Описание параметров

Source
[in] Другой площадной условный знак, из которого будут скопированы параметры

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.SetSignOverSolidStyle (метод)

Установить стиль топографического площадного условного знака (с фоновой закраской)

Синтаксис

[Visual Basic 6]
Sub SetSignOverSolidStyle ( _
   ByVal Sign As Long, _
   [ByVal BackColor As Long = 12632256], _
   [ByVal SignColor As Long = 0], _
   [ByVal Scale As Double = 100] _
)

[Delphi]
procedure SetSignOverSolidStyle(
   const Sign: Integer;
   const BackColor: Integer;
   const SignColor: Integer;
   const Scale: Double
)

Описание параметров

Sign
[in] Код топографических условных знаков заливки
BackColor
[in] Цвет сплошной фоновой заливки
SignColor
[in] Цвет условных знаков заливки
Scale
[in] Масштабный размер (в процентах) площадного условного знака (допустимы значения от 1% до 10000%)

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.SetSignStyle (метод)

Установить стиль топографического площадного условного знака (с прозрачным фоном)

Синтаксис

[Visual Basic 6]
Sub SetSignStyle ( _
   ByVal Sign As Long, _
   [ByVal SignColor As Long = 0], _
   [ByVal Scale As Double = 100] _
)

[Delphi]
procedure SetSignStyle(
   const Sign: Integer;
   const SignColor: Integer;
   const Scale: Double
)

Описание параметров

Sign
[in] Код топографических условных знаков заливки
SignColor
[in] Цвет условных знаков заливки
Scale
[in] Масштабный размер (в процентах) площадного условного знака (допустимы значения от 1% до 10000%

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.SetSolidStyle (метод)

Установить стиль сплошного площадного условного знака

Синтаксис

[Visual Basic 6]
Sub SetSolidStyle ( _
   [ByVal BackColor As Long = 12632256] _
)

[Delphi]
procedure SetSolidStyle(
   const BackColor: Integer
)

Описание параметров

BackColor
[in] Цвет сплошной фоновой заливки

Смотри также

Class TopoFillStyle, Group Условные знаки


TopoFillStyle.SetStyle (метод)

Установить сразу все параметры площадного условного знака

Синтаксис

[Visual Basic 6]
Sub SetStyle ( _
   ByVal Kind As TopoFillKindConstants, _
   ByVal Sign As Long, _
   [ByVal BackColor As Long = 12632256], _
   [ByVal SignColor As Long = 0], _
   [ByVal Scale As Double = 100] _
)

[Delphi]
procedure SetStyle(
   const Kind: TopoFillKindConstants;
   const Sign: Integer;
   const BackColor: Integer;
   const SignColor: Integer;
   const Scale: Double
)

Описание параметров

Kind
[in] Тип площадного условного знака
Sign
[in] Код топографических условных знаков заливки (для Kind=TopoFillKindSign и Kind=TopoFillKindSignOverSolid)
BackColor
[in] Цвет сплошной фоновой заливки (для Kind=TopoFillKindSolid и Kind=TopoFillKindSignOverSolid)
SignColor
[in] Цвет условных знаков заливки (для Kind=TopoFillKindSign и Kind=TopoFillKindSignOverSolid)
Scale
[in] Масштабный размер (в процентах) площадного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoFillKindSign и Kind=TopoFillKindSignOverSolid)

Смотри также

Enum TopoFillKindConstants, Class TopoFillStyle, Group Условные знаки


Класс TopoFontStyle

Параметры шрифта

Наследование

TopoFontStyle Class TopoTextStyle

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoFontStyle

ClassID = {6017000C-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bold | Жирный стиль шрифта
Property FontCharset | Набор символов шрифта
Property FontColor | Цвет символов
Property FontName | Имя шрифта
Property FontSize | Размер шрифта
Property FontStyle | Cтиль шрифта (битовая комбинация флагов FontStyleConstants)
Property Italic | Наклонный стиль шрифта
Property Strikeout | Зачеркнутый стиль шрифта
Property Underline | Подчеркнутый стиль шрифта

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из объекта типа TopoFontStyle или TopoTextStyle
Method Reset | Сбросить все параметры в значения по умолчанию
Method SetFontParameters | Установить сразу все параметры шрифта

Где используется

Класс | Член класса
Class TopoFontStyle | Method Assign (метод)
Class TopoTextStyle | Method Assign (метод)

Смотри также

Enum FontStyleConstants, Group Условные знаки


TopoFontStyle.Bold (свойство)

Жирный стиль шрифта

Синтаксис

[Visual Basic 6]
Property Bold As Boolean

[Delphi]
property Bold: WordBool

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.FontCharset (свойство)

Набор символов шрифта

Синтаксис

[Visual Basic 6]
Property FontCharset As Long

[Delphi]
property FontCharset: Integer

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.FontColor (свойство)

Цвет символов

Синтаксис

[Visual Basic 6]
Property FontColor As OLE_COLOR

[Delphi]
property FontColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.FontName (свойство)

Имя шрифта

Синтаксис

[Visual Basic 6]
Property FontName As String

[Delphi]
property FontName: WideString

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.FontSize (свойство)

Размер шрифта

Синтаксис

[Visual Basic 6]
Property FontSize As Double

[Delphi]
property FontSize: Double

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.FontStyle (свойство)

Cтиль шрифта (битовая комбинация флагов FontStyleConstants)

Синтаксис

[Visual Basic 6]
Property FontStyle As FontStyleConstants

[Delphi]
property FontStyle: FontStyleConstants

Смотри также

Enum FontStyleConstants, Class TopoFontStyle, Group Условные знаки


TopoFontStyle.Italic (свойство)

Наклонный стиль шрифта

Синтаксис

[Visual Basic 6]
Property Italic As Boolean

[Delphi]
property Italic: WordBool

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.Strikeout (свойство)

Зачеркнутый стиль шрифта

Синтаксис

[Visual Basic 6]
Property Strikeout As Boolean

[Delphi]
property Strikeout: WordBool

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.Underline (свойство)

Подчеркнутый стиль шрифта

Синтаксис

[Visual Basic 6]
Property Underline As Boolean

[Delphi]
property Underline: WordBool

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.Assign (метод)

Скопировать параметры из объекта типа TopoFontStyle или TopoTextStyle

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Source As TopoFontStyle _
)

[Delphi]
procedure Assign(
   const Source: TopoFontStyle
)

Описание параметров

Source
[in] Другой шрифт, из которого будут скопированы параметры

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoFontStyle, Group Условные знаки


TopoFontStyle.SetFontParameters (метод)

Установить сразу все параметры шрифта

Синтаксис

[Visual Basic 6]
Sub SetFontParameters ( _
   ByVal Name As String, _
   ByVal Size As Double, _
   [ByVal Color As OLE_COLOR = 0], _
   [ByVal Style As FontStyleConstants = 0], _
   [ByVal Charset As Long = 1] _
)

[Delphi]
procedure SetFontParameters(
   const Name: WideString;
   const Size: Double;
   const Color: OLE_COLOR;
   const Style: FontStyleConstants;
   const Charset: Integer
)

Описание параметров

Name
[in] Имя шрифта
Size
[in] Размер шрифта
Color
[in] Цвет символов
Style
[in] Стиль шрифта (битовая комбинация флагов FontStyleConstants)
Charset
[in] Набор символов шрифта

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Enum FontStyleConstants, Class TopoFontStyle, Group Условные знаки


Класс TopoLineStyle

Линейный условный знак

Наследование

TopoSignStyle Class TopoLineStyle

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoLineStyle

ClassID = {60170010-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Color | Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета
Property ColorCount (только для чтения) | Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3
Property Colors | Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]
Property DrawBySegments | Отрисовывать каждый отрезок полилинии по отдельности (только для Kind=TopoLineKindSign)
Property IsColorUsed (только для чтения) | Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign
Property Kind | Тип линейного условного знака
Property ReverseDraw | Отрисовывать полилинии в обратном направлении (только для Kind=TopoLineKindSign)
Property Scale | Масштабный размер (в процентах) линейного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoLineKindSign)
Property Sign | Код топографического условного знака
Property SignName (только для чтения) | Название топографического условного знака, заданного в Sign
Property TextCount (только для чтения) | Количество настраиваемых надписей символа с кодом Sign
Property Texts | Массив настраиваемых надписей символа с кодом Sign
Property Width | Толщина сплошной линии (только для Kind=TopoLineKindSolid)

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другого линейного условного знака
Method Reset | Сбросить все параметры в значения по умолчанию
Method SetSignStyle | Установить стиль топографического линейного условного знака
Method SetSolidStyle | Установить стиль сплошного линейного условного знака
Method SetStyle | Установить сразу все параметры линейного условного знака

Где используется

Класс | Член класса
Class Line | Property LineStyle (свойство)
Class Lines | Property DefaultLineStyle (свойство)
Class TopoLineStyle | Method Assign (метод)

Смотри также

Enum TopoLineKindConstants, Group Условные знаки


TopoLineStyle.Color (свойство)

Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.ColorCount (свойство)

Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3

Синтаксис

[Visual Basic 6]
ReadOnly Property ColorCount As Long

[Delphi]
{только для чтения} property ColorCount: Integer

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.Colors (свойство)

Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]

Синтаксис

[Visual Basic 6]
Property Colors As OLE_COLOR

[Delphi]
property Colors: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.DrawBySegments (свойство)

Отрисовывать каждый отрезок полилинии по отдельности (только для Kind=TopoLineKindSign)

Синтаксис

[Visual Basic 6]
Property DrawBySegments As Boolean

[Delphi]
property DrawBySegments: WordBool

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.IsColorUsed (свойство)

Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property IsColorUsed As Boolean

[Delphi]
{только для чтения} property IsColorUsed: WordBool

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.Kind (свойство)

Тип линейного условного знака

Синтаксис

[Visual Basic 6]
Property Kind As TopoLineKindConstants

[Delphi]
property Kind: TopoLineKindConstants

Смотри также

Enum TopoLineKindConstants, Class TopoLineStyle, Group Условные знаки


TopoLineStyle.ReverseDraw (свойство)

Отрисовывать полилинии в обратном направлении (только для Kind=TopoLineKindSign)

Синтаксис

[Visual Basic 6]
Property ReverseDraw As Boolean

[Delphi]
property ReverseDraw: WordBool

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.Scale (свойство)

Масштабный размер (в процентах) линейного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoLineKindSign)

Синтаксис

[Visual Basic 6]
Property Scale As Double

[Delphi]
property Scale: Double

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.Sign (свойство)

Код топографического условного знака

Синтаксис

[Visual Basic 6]
Property Sign As Long

[Delphi]
property Sign: Integer

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.SignName (свойство)

Название топографического условного знака, заданного в Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property SignName As String

[Delphi]
{только для чтения} property SignName: WideString

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.TextCount (свойство)

Количество настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property TextCount As Long

[Delphi]
{только для чтения} property TextCount: Integer

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.Texts (свойство)

Массив настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
Property Texts As String

[Delphi]
property Texts: WideString

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.Width (свойство)

Толщина сплошной линии (только для Kind=TopoLineKindSolid)

Синтаксис

[Visual Basic 6]
Property Width As Double

[Delphi]
property Width: Double

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.Assign (метод)

Скопировать параметры из другого линейного условного знака

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Source As TopoLineStyle _
)

[Delphi]
procedure Assign(
   const Source: TopoLineStyle
)

Описание параметров

Source
[in] Другой линейный условный знак, из которого будут скопированы параметры

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.SetSignStyle (метод)

Установить стиль топографического линейного условного знака

Синтаксис

[Visual Basic 6]
Sub SetSignStyle ( _
   ByVal Sign As Long, _
   [ByVal Color As Long = 0], _
   [ByVal Scale As Double = 100] _
)

[Delphi]
procedure SetSignStyle(
   const Sign: Integer;
   const Color: Integer;
   const Scale: Double
)

Описание параметров

Sign
[in] Код топографического условного знака
Color
[in] Цвет линии
Scale
[in] Масштабный размер (в процентах) линейного условного знака (допустимы значения от 1% до 10000%

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.SetSolidStyle (метод)

Установить стиль сплошного линейного условного знака

Синтаксис

[Visual Basic 6]
Sub SetSolidStyle ( _
   [ByVal Color As Long = 0], _
   [ByVal Width As Double = 1] _
)

[Delphi]
procedure SetSolidStyle(
   const Color: Integer;
   const Width: Double
)

Описание параметров

Color
[in] Цвет линии
Width
[in] Толщина сплошной линии

Смотри также

Class TopoLineStyle, Group Условные знаки


TopoLineStyle.SetStyle (метод)

Установить сразу все параметры линейного условного знака

Синтаксис

[Visual Basic 6]
Sub SetStyle ( _
   ByVal Kind As TopoLineKindConstants, _
   ByVal Sign As Long, _
   [ByVal Color As Long = 0], _
   [ByVal Width As Double = 1], _
   [ByVal Scale As Double = 100] _
)

[Delphi]
procedure SetStyle(
   const Kind: TopoLineKindConstants;
   const Sign: Integer;
   const Color: Integer;
   const Width: Double;
   const Scale: Double
)

Описание параметров

Kind
[in] Тип линейного условного знака
Sign
[in] Код топографического условного знака (только для Kind=TopoLineKindSign)
Color
[in] Цвет линии (для Kind=TopoLineKindSolid и Kind=TopoLineKindSign)
Width
[in] Толщина сплошной линии (только для Kind=TopoLineKindSolid)
Scale
[in] Масштабный размер (в процентах) линейного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoLineKindSign)

Смотри также

Enum TopoLineKindConstants, Class TopoLineStyle, Group Условные знаки


Класс TopoSignStyle

Условный знак

Наследование

TopoSignStyle Class TopoFillStyle, TopoLineStyle, TopoSymbolStyle, TopoSymbolStyleAux

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoSignStyle

ClassID = {60170006-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Color | Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета
Property ColorCount (только для чтения) | Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3
Property Colors | Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]
Property IsColorUsed (только для чтения) | Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign
Property Sign | Код топографического условного знака
Property SignName (только для чтения) | Название топографического условного знака, заданного в Sign
Property TextCount (только для чтения) | Количество настраиваемых надписей символа с кодом Sign
Property Texts | Массив настраиваемых надписей символа с кодом Sign

Методы класса

Имя | Описание
Method Reset | Сбросить все параметры в значения по умолчанию

Смотри также

Group Условные знаки


TopoSignStyle.Color (свойство)

Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoSignStyle, Group Условные знаки


TopoSignStyle.ColorCount (свойство)

Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3

Синтаксис

[Visual Basic 6]
ReadOnly Property ColorCount As Long

[Delphi]
{только для чтения} property ColorCount: Integer

Смотри также

Class TopoSignStyle, Group Условные знаки


TopoSignStyle.Colors (свойство)

Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]

Синтаксис

[Visual Basic 6]
Property Colors As OLE_COLOR

[Delphi]
property Colors: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoSignStyle, Group Условные знаки


TopoSignStyle.IsColorUsed (свойство)

Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property IsColorUsed As Boolean

[Delphi]
{только для чтения} property IsColorUsed: WordBool

Смотри также

Class TopoSignStyle, Group Условные знаки


TopoSignStyle.Sign (свойство)

Код топографического условного знака

Синтаксис

[Visual Basic 6]
Property Sign As Long

[Delphi]
property Sign: Integer

Смотри также

Class TopoSignStyle, Group Условные знаки


TopoSignStyle.SignName (свойство)

Название топографического условного знака, заданного в Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property SignName As String

[Delphi]
{только для чтения} property SignName: WideString

Смотри также

Class TopoSignStyle, Group Условные знаки


TopoSignStyle.TextCount (свойство)

Количество настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property TextCount As Long

[Delphi]
{только для чтения} property TextCount: Integer

Смотри также

Class TopoSignStyle, Group Условные знаки


TopoSignStyle.Texts (свойство)

Массив настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
Property Texts As String

[Delphi]
property Texts: WideString

Смотри также

Class TopoSignStyle, Group Условные знаки


TopoSignStyle.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoSignStyle, Group Условные знаки


Класс TopoSymbolStyle

Точечный условный знак

Наследование

TopoSignStyle Class TopoSymbolStyle Class TopoSymbolStyleAux

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoSymbolStyle

ClassID = {60170008-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Color | Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета
Property ColorCount (только для чтения) | Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3
Property Colors | Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]
Property IsColorUsed (только для чтения) | Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign
Property Rotation | Угол поворота символа в радианах против часовой стрелки (только для Kind=TopoSymbolKindSign)
Property Scale | Масштабный размер (в процентах) точечного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoSymbolKindSign)
Property Sign | Код топографического условного знака
Property SignName (только для чтения) | Название топографического условного знака, заданного в Sign
Property TextCount (только для чтения) | Количество настраиваемых надписей символа с кодом Sign
Property Texts | Массив настраиваемых надписей символа с кодом Sign

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другого точечного условного знака
Method Reset | Сбросить все параметры в значения по умолчанию
Method SetStyle | Установить сразу все параметры точечного условного знака

Где используется

Класс | Член класса
Class TopoSymbolStyle | Method Assign (метод)
Class TopoSymbolStyleAux | Method Assign (метод)

Смотри также

Group Условные знаки


TopoSymbolStyle.Color (свойство)

Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.ColorCount (свойство)

Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3

Синтаксис

[Visual Basic 6]
ReadOnly Property ColorCount As Long

[Delphi]
{только для чтения} property ColorCount: Integer

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.Colors (свойство)

Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]

Синтаксис

[Visual Basic 6]
Property Colors As OLE_COLOR

[Delphi]
property Colors: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.IsColorUsed (свойство)

Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property IsColorUsed As Boolean

[Delphi]
{только для чтения} property IsColorUsed: WordBool

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.Rotation (свойство)

Угол поворота символа в радианах против часовой стрелки (только для Kind=TopoSymbolKindSign)

Синтаксис

[Visual Basic 6]
Property Rotation As Double

[Delphi]
property Rotation: Double

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.Scale (свойство)

Масштабный размер (в процентах) точечного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoSymbolKindSign)

Синтаксис

[Visual Basic 6]
Property Scale As Double

[Delphi]
property Scale: Double

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.Sign (свойство)

Код топографического условного знака

Синтаксис

[Visual Basic 6]
Property Sign As Long

[Delphi]
property Sign: Integer

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.SignName (свойство)

Название топографического условного знака, заданного в Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property SignName As String

[Delphi]
{только для чтения} property SignName: WideString

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.TextCount (свойство)

Количество настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property TextCount As Long

[Delphi]
{только для чтения} property TextCount: Integer

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.Texts (свойство)

Массив настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
Property Texts As String

[Delphi]
property Texts: WideString

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.Assign (метод)

Скопировать параметры из другого точечного условного знака

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Source As TopoSymbolStyle _
)

[Delphi]
procedure Assign(
   const Source: TopoSymbolStyle
)

Описание параметров

Source
[in] Другой точечный условный знак, из которого будут скопированы параметры

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyle.SetStyle (метод)

Установить сразу все параметры точечного условного знака

Синтаксис

[Visual Basic 6]
Sub SetStyle ( _
   ByVal Sign As Long, _
   [ByVal Color As Long = 0], _
   [ByVal Rotation As Double = 0], _
   [ByVal Scale As Double = 100] _
)

[Delphi]
procedure SetStyle(
   const Sign: Integer;
   const Color: Integer;
   const Rotation: Double;
   const Scale: Double
)

Описание параметров

Sign
[in] Код топографического условного знака (только для Kind=TopoSymbolKindSign)
Color
[in] Цвет топографического условного знака (только для Kind=TopoSymbolKindSign)
Rotation
[in] Угол поворота символа в радианах против часовой стрелки (только для Kind=TopoSymbolKindSign)
Scale
[in] Масштабный размер (в процентах) точечного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoSymbolKindSign)

Смотри также

Class TopoSymbolStyle, Group Условные знаки


Класс TopoSymbolStyleAux

Отключаемый точечный условный знак

Наследование

TopoSignStyle Class TopoSymbolStyleAux

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoSymbolStyleAux

ClassID = {6017000A-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Color | Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета
Property ColorCount (только для чтения) | Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3
Property Colors | Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]
Property IsColorUsed (только для чтения) | Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign
Property Kind | Тип точечного условного знака
Property Rotation | Угол поворота символа в радианах против часовой стрелки (только для Kind=TopoSymbolKindSign)
Property Scale | Масштабный размер (в процентах) точечного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoSymbolKindSign)
Property Sign | Код топографического условного знака
Property SignName (только для чтения) | Название топографического условного знака, заданного в Sign
Property TextCount (только для чтения) | Количество настраиваемых надписей символа с кодом Sign
Property Texts | Массив настраиваемых надписей символа с кодом Sign

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другого точечного условного знака
Method Reset | Сбросить все параметры в значения по умолчанию
Method SetStyle | Установить сразу все параметры точечного условного знака

Смотри также

Enum TopoSymbolKindConstants, Class TopoSymbolStyle, Group Условные знаки


TopoSymbolStyleAux.Color (свойство)

Более удобное свойство, чем массив Colors, если всего имеется только 1 настраиваемый цвет. При записи свойства меняются сразу все 4 цвета

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.ColorCount (свойство)

Количество настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то ColorCount=1, иначе возвращается значение от 0 до 3

Синтаксис

[Visual Basic 6]
ReadOnly Property ColorCount As Long

[Delphi]
{только для чтения} property ColorCount: Integer

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.Colors (свойство)

Массив настраиваемых цветов элементов символа с кодом Sign. Если используется не топографический символ, то используется только Colors[0]

Синтаксис

[Visual Basic 6]
Property Colors As OLE_COLOR

[Delphi]
property Colors: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.IsColorUsed (свойство)

Проверить, используется ли настраиваемый цвет с указанным номером в символе с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property IsColorUsed As Boolean

[Delphi]
{только для чтения} property IsColorUsed: WordBool

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.Kind (свойство)

Тип точечного условного знака

Синтаксис

[Visual Basic 6]
Property Kind As TopoSymbolKindConstants

[Delphi]
property Kind: TopoSymbolKindConstants

Смотри также

Enum TopoSymbolKindConstants, Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.Rotation (свойство)

Угол поворота символа в радианах против часовой стрелки (только для Kind=TopoSymbolKindSign)

Синтаксис

[Visual Basic 6]
Property Rotation As Double

[Delphi]
property Rotation: Double

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.Scale (свойство)

Масштабный размер (в процентах) точечного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoSymbolKindSign)

Синтаксис

[Visual Basic 6]
Property Scale As Double

[Delphi]
property Scale: Double

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.Sign (свойство)

Код топографического условного знака

Синтаксис

[Visual Basic 6]
Property Sign As Long

[Delphi]
property Sign: Integer

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.SignName (свойство)

Название топографического условного знака, заданного в Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property SignName As String

[Delphi]
{только для чтения} property SignName: WideString

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.TextCount (свойство)

Количество настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
ReadOnly Property TextCount As Long

[Delphi]
{только для чтения} property TextCount: Integer

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.Texts (свойство)

Массив настраиваемых надписей символа с кодом Sign

Синтаксис

[Visual Basic 6]
Property Texts As String

[Delphi]
property Texts: WideString

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.Assign (метод)

Скопировать параметры из другого точечного условного знака

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Source As TopoSymbolStyle _
)

[Delphi]
procedure Assign(
   const Source: TopoSymbolStyle
)

Описание параметров

Source
[in] Другой точечный условный знак, из которого будут скопированы параметры

Смотри также

Class TopoSymbolStyle, Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


TopoSymbolStyleAux.SetStyle (метод)

Установить сразу все параметры точечного условного знака

Синтаксис

[Visual Basic 6]
Sub SetStyle ( _
   ByVal Sign As Long, _
   [ByVal Color As Long = 0], _
   [ByVal Rotation As Double = 0], _
   [ByVal Scale As Double = 100] _
)

[Delphi]
procedure SetStyle(
   const Sign: Integer;
   const Color: Integer;
   const Rotation: Double;
   const Scale: Double
)

Описание параметров

Sign
[in] Код топографического условного знака (только для Kind=TopoSymbolKindSign)
Color
[in] Цвет топографического условного знака (только для Kind=TopoSymbolKindSign)
Rotation
[in] Угол поворота символа в радианах против часовой стрелки (только для Kind=TopoSymbolKindSign)
Scale
[in] Масштабный размер (в процентах) точечного условного знака (допустимы значения от 1% до 10000%; для Kind=TopoSymbolKindSign)

Смотри также

Class TopoSymbolStyleAux, Group Условные знаки


Класс TopoTextStyle

Точечный условный знак

Наследование

TopoFontStyle Class TopoTextStyle

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TopoTextStyle

ClassID = {6017000E-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property BackColor | Цвет фона под текстом (не для всех видов текстовых надписей)
Property Bold | Жирный стиль шрифта
Property FontCharset | Набор символов шрифта
Property FontColor | Цвет символов
Property FontName | Имя шрифта
Property FontSize | Размер шрифта
Property FontStyle | Cтиль шрифта (битовая комбинация флагов FontStyleConstants)
Property Italic | Наклонный стиль шрифта
Property Placement | Размещение текста относительно точки привязки (только для текстов узлов и TextFigure)
Property RatioXY | Коэффициент сжатия текста по вертикали (только для текстов узлов и TextFigure)
Property Rotation | Угол поворота текста против часовой стрелки в радианах (только для текстов узлов и TextFigure)
Property Skew | Угол наклона текста по часовой стрелке в радианах - геометрический италик (только для текстов узлов и TextFigure)
Property Strikeout | Зачеркнутый стиль шрифта
Property Transparent | Прозрачность фона - отсутстие фона под текстом (не для всех видов текстовых надписей)
Property Underline | Подчеркнутый стиль шрифта

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из объекта типа TopoFontStyle или TopoTextStyle
Method Reset | Сбросить все параметры в значения по умолчанию
Method SetFontParameters | Установить сразу все параметры шрифта

Смотри также

Enum FontStyleConstants, Enum PointTextPlacementConstants, Class TopoFontStyle, Group Условные знаки


TopoTextStyle.BackColor (свойство)

Цвет фона под текстом (не для всех видов текстовых надписей)

Синтаксис

[Visual Basic 6]
Property BackColor As OLE_COLOR

[Delphi]
property BackColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Bold (свойство)

Жирный стиль шрифта

Синтаксис

[Visual Basic 6]
Property Bold As Boolean

[Delphi]
property Bold: WordBool

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.FontCharset (свойство)

Набор символов шрифта

Синтаксис

[Visual Basic 6]
Property FontCharset As Long

[Delphi]
property FontCharset: Integer

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.FontColor (свойство)

Цвет символов

Синтаксис

[Visual Basic 6]
Property FontColor As OLE_COLOR

[Delphi]
property FontColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.FontName (свойство)

Имя шрифта

Синтаксис

[Visual Basic 6]
Property FontName As String

[Delphi]
property FontName: WideString

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.FontSize (свойство)

Размер шрифта

Синтаксис

[Visual Basic 6]
Property FontSize As Double

[Delphi]
property FontSize: Double

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.FontStyle (свойство)

Cтиль шрифта (битовая комбинация флагов FontStyleConstants)

Синтаксис

[Visual Basic 6]
Property FontStyle As FontStyleConstants

[Delphi]
property FontStyle: FontStyleConstants

Смотри также

Enum FontStyleConstants, Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Italic (свойство)

Наклонный стиль шрифта

Синтаксис

[Visual Basic 6]
Property Italic As Boolean

[Delphi]
property Italic: WordBool

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Placement (свойство)

Размещение текста относительно точки привязки (только для текстов узлов и TextFigure)

Синтаксис

[Visual Basic 6]
Property Placement As PointTextPlacementConstants

[Delphi]
property Placement: PointTextPlacementConstants

Смотри также

Enum PointTextPlacementConstants, Class TopoTextStyle, Group Условные знаки


TopoTextStyle.RatioXY (свойство)

Коэффициент сжатия текста по вертикали (только для текстов узлов и TextFigure)

Синтаксис

[Visual Basic 6]
Property RatioXY As Double

[Delphi]
property RatioXY: Double

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Rotation (свойство)

Угол поворота текста против часовой стрелки в радианах (только для текстов узлов и TextFigure)

Синтаксис

[Visual Basic 6]
Property Rotation As Double

[Delphi]
property Rotation: Double

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Skew (свойство)

Угол наклона текста по часовой стрелке в радианах - геометрический италик (только для текстов узлов и TextFigure)

Синтаксис

[Visual Basic 6]
Property Skew As Double

[Delphi]
property Skew: Double

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Strikeout (свойство)

Зачеркнутый стиль шрифта

Синтаксис

[Visual Basic 6]
Property Strikeout As Boolean

[Delphi]
property Strikeout: WordBool

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Transparent (свойство)

Прозрачность фона - отсутстие фона под текстом (не для всех видов текстовых надписей)

Синтаксис

[Visual Basic 6]
Property Transparent As Boolean

[Delphi]
property Transparent: WordBool

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Underline (свойство)

Подчеркнутый стиль шрифта

Синтаксис

[Visual Basic 6]
Property Underline As Boolean

[Delphi]
property Underline: WordBool

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Assign (метод)

Скопировать параметры из объекта типа TopoFontStyle или TopoTextStyle

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Source As TopoFontStyle _
)

[Delphi]
procedure Assign(
   const Source: TopoFontStyle
)

Описание параметров

Source
[in] Другой шрифт, из которого будут скопированы параметры

Смотри также

Class TopoFontStyle, Class TopoTextStyle, Group Условные знаки


TopoTextStyle.Reset (метод)

Сбросить все параметры в значения по умолчанию

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class TopoTextStyle, Group Условные знаки


TopoTextStyle.SetFontParameters (метод)

Установить сразу все параметры шрифта

Синтаксис

[Visual Basic 6]
Sub SetFontParameters ( _
   ByVal Name As String, _
   ByVal Size As Double, _
   [ByVal Color As OLE_COLOR = 0], _
   [ByVal Style As FontStyleConstants = 0], _
   [ByVal Charset As Long = 1] _
)

[Delphi]
procedure SetFontParameters(
   const Name: WideString;
   const Size: Double;
   const Color: OLE_COLOR;
   const Style: FontStyleConstants;
   const Charset: Integer
)

Описание параметров

Name
[in] Имя шрифта
Size
[in] Размер шрифта
Color
[in] Цвет символов
Style
[in] Стиль шрифта (битовая комбинация флагов FontStyleConstants)
Charset
[in] Набор символов шрифта

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Enum FontStyleConstants, Class TopoTextStyle, Group Условные знаки


Класс Triangulation

Триангуляция

Наследование

FigureBase Class Triangulation Class CADTriangulation

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Triangulation

ClassID = {60130022-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property AllowNodeDuplicates | Разрешить генерацию дублирующихся узлов (при этом дубликаты не будут входить в структуру триангуляции, но будут в списке Duplicate узлов)
Property AreaCount | Количество регионов триангуляции (входные данные)
Property Areas (только для чтения) | Массив регионов триангуляции (входные данные)
Property Bounds (только для чтения) | Минимальный объемлющий все фигуры прямоугольник
Property BreakCount | Количество структурных линий триангуляции (входные данные)
Property Breaks (только для чтения) | Массив структурных линий триангуляции (входные данные)
Property BuildTime (только для чтения) | Время построения триангуляции в милисекундах
Property Built (только для чтения) | Построена ли триангуляция
Property Caption (только для чтения) | Название базы фигур
Property CompressionLevel | Способ сжатия данных при сохранении в поток
Property DataFormat | Тип исходных данных в триангуляции
Property DefaultColor | Цвет по умолчанию для отображения треугольников (входные данные)
Property FigureSetCount (только для чтения) | Количество наборов фигур в базе
Property FigureSets (только для чтения) | Массив наборов фигур в базе (наборы фигур рисуются от последнего к первому) (индексы должны иметь номера от 0 до FigureSetCount-1)
Property FileName (только для чтения) | Имя файла с триангуляцией
Property FlipCount | Количество перебросок рёбер (входные данные)
Property Flips (только для чтения) | Массив перебросок рёбер (входные данные)
Property IgnoreRibSourceLines | Запретить генерацию данных в структурных рёбрах об исходных структурных линиях (ускоряет процесс построения триангуляции)
Property Modified | Произошли ли какие-либо изменения фигур
Property ModifierCount | Количество красящих/отсекающих линий (входные данные)
Property Modifiers (только для чтения) | Массив красящих/отсекающих линий (входные данные)
Property NodeCount (только для чтения) | Количество узлов триангуляции (выходные данные)
Property Nodes (только для чтения) | Массив узлов
Property RibCount (только для чтения) | Количество рёбер триангуляции, входящих в состав структурных линий (выходные данные)
Property Ribs (только для чтения) | Количество рёбер триангуляции, входящих в состав структурных линий (выходные данные)
Property SourceCount | Количество точек триангуляции (входные данные)
Property Sources (только для чтения) | Массив исходных точек триангуляции (входные данные)
Property TriangleCount (только для чтения) | Количество треугольников триангуляции (выходные данные)
Property Triangles (только для чтения) | Количество треугольников триангуляции (выходные данные)
Property UseProgress | Показывать ли прогресс при загрузке/сохранении/построении?

Методы класса

Имя | Описание
Method AddModifier | Добавить новую красящую линию, заданную в виде последовательности точек
Method AddModifierShape | Добавить новую красящую линию, заданный в виде полилинии
Method AddPolygon | Добавить новый регион, заданный в виде последовательности точек, образующих один контур
Method AddPolygonShape | Добавить новый регион, заданный в виде полигона
Method AddPolyline | Добавить новую структурную линию, заданную в виде последовательности точек
Method AddPolylineShape | Добавить новую структурную линию, заданную в виде полилинии
Method AddSource | Добавить новую исходную точку
Method Build | Построить триангуляцию по указанным входным данных
Method BuildIsoexpos | Построить экспозиции (изонаправления) заданных разделителей направлений ExpoDelimiters и вернуть их в Isoexpos в виде полигонов (возможны Nothing в коллекции)
Method BuildIsoline | Построить изолинию заданного уровня Level и вернуть её в виде полиполилинии
Method BuildIsolines | Построить изолинии заданных уровней Levels и вернуть их в Isolines в виде полиполилиний или полигонов
Method BuildIsoslopes | Построить изоклины (изоуклоны) заданных наклонов Slopes и вернуть их в Isoslopes в виде полиполилиний или полигонов
Method BuildNoAreaClassify | Построить триангуляцию по указанным данных без классификации треугольников по регионам
Method BuildVisibilities | Построение зон и линий видимости из заданной точки
Method CalcHash | Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников. Используется для выявления факта различия разных триангуляций
Method CalcHashInPolygon | Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников в заданном регионе. Используется для выявления факта различия разных триангуляций
Method CalcHashInRect | Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников в заданном прямоугольнике. Используется для выявления факта различия разных триангуляций
Method CalcSimpleAlongPolyline | Вычислить значение простой хеш-функции по координатам узлов и топологии треугольников вдоль полилинии
Method CalcSimpleAlongSegment | Вычислить значение простой хеш-функции по координатам узлов и топологии треугольников вдоль полилинии
Method CalcSimpleHash | Вычислить значение хеш-функции по координатам узлов и топологии треугольников. Используется для выявления факта различия разных триангуляций
Method CalcSimpleHashInPolygon | Вычислить значение хеш-функции по координатам узлов и топологии треугольников в заданном регионе. Используется для выявления факта различия разных триангуляций
Method CalcSimpleHashInRect | Вычислить значение хеш-функции по координатам узлов и топологии треугольников в заданном прямоугольнике. Используется для выявления факта различия разных триангуляций
Method CalcSquare | Расчёт площади по всей видимой части триангуляции, возможно, только по треугольникам c Tag>0
Method CanFlipAtPoint | Проверить, возможно ли в указанной точке триангуляции выполнить переброску
Method Clear | Очистить триангуляцию
Method CustomBuild | Построить или достроить триангуляцию по указанным входным данных
Method CutByPolygon | Вырезать подтриангуляцию, попадающую внутрь полигона
Method CutByPolygons | Вырезать подтриангуляцию, попадающую внутрь списка полигонов
Method DeleteArea | Удалить регион по индексу
Method DeleteBreak | Удалить структурную линию по индексу
Method DeleteFlip | Удалить переброску рёбер по индексу
Method DeleteModifier | Удалить модификатор по индексу
Method DeleteSource | Удалить исходную точку по индексу
Method EarthVolume | Расчёт объёма земляных работ при выравнивании всей видимой части триангуляции до уровня Z=Level. AboveVolume - объём выше, BelowVolume - объём ниже уровня, AboveSquare - площадь участка, поверхность которого находится выше Level
Method EnumerateProfile | Построение профиля на отрезке Point1-Point2, на выходе отрезки профиля выдаются в EnumerateProfile.Register
Method EnumerateProfilePoints | Построение профиля на отрезке Point1-Point2, на выходе узловые точки профиля выдаются в EnumerateProfilePoints.Register
Method ExportToXmlFile | Сохранение в Xml-файл
Method ExportToXmlNode | Сохранение в узел Xml-файла
Method ExpositionAtPoint | Вычисление экспозиции (направления) склона в заданной точке триангуляции
Method ExtractBorder | Создать полигон по границе триангуляции
Method ExtractPolygon | Выделить из триангуляции все связанные области треугольников, имеющих поле положительное поле Tag. Результат возвращается в виде полиполигона
Method ExtractPolygons | Выделить из триангуляции все связанные области треугольников, имеющих положительное поле Tag. Результат возвращается в виде коллекции полигонов
Method ExtractTriangles | Выделить из триангуляции все области треугольников, имеющих поле Tag>0. В один полигон объединяются все треугольники с одинаковым Tag. Результат возвращается в виде коллекций полигонов и соответствующих им значений поля Tag
Method ExtractVoronoi | Построить диаграммы Вороного. Результат возвращается в виде коллекции полигонов. Результат возвращается в виде коллекций полигонов, образующих отдельные диаграммы Вороного, и соответствующих им значений поля Id узлов
Method FindHeightRange | Найти минимальную и максимальную высоту видимой части триангуляции
Method FindNode | Найти узел триангуляции в заданой точке
Method FindTriangle | Поиск треугольника для заданной точки
Method FindTriangles | Выделить все треугольники вдоль отрезка Point1-Point2. Все найденные треугольники будут помещены в коллекцию Triangles
Method FlipAtPoint | Выполнить переброску рёбер, если возможно в указанной точке триангуляции. Возвращает True, если переброска выполнена
Method GetObjectAtPoint | Получить объект в заданной позиции. Если там ничего нет, то возвращает Nothing
Method GetObjectsAtPoint | Получить все объекты в заданной позиции в виде коллекции объектов типа TrnFigure. Если там ничего нет, то возвращает Nothing
Method GetObjectsAtRect | Получить все объекты в заданном прямоугольнике в виде коллекции объектов типа TrnFigure. Если там ничего нет, то возвращает Nothing
Method GetSoftRibAtPoint | Найти в указанной точке триангуляции ребро в виде пары смежных треугольников. В переменных RibIndex1/2 возвращаются номера ссылок на парный треугольник, в HardRib - жёсткое ребро, если оно существует
Method HeightAtPoint | Вычисление высоты в заданной точке триангуляции
Method IncrementalAddBoundary | Перестроить структуру триангуляции, вставив туда регион (границу триангуляции), заданный в виде последовательности точек. При этом в список Areas регион не добавляется
Method IncrementalAddBoundaryShape | Перестроить структуру триангуляции, вставив туда регион (границу триангуляции), заданный в виде полигона. При этом в список Areas регион не добавляется
Method Invalidate | Разорвать связь исходных данных с построенными структурами
Method LoadFromFile | Загрузка триангуляции из файла
Method LoadFromStream | Загрузка триангуляции из файла потока
Method MakeCopy | Создать копию триангуляции (можно без копирования исходных данных)
Method NormalAtPoint | Вычисление интерполированного вектора нормали в заданной точке триангуляции
Method OptimizeFlips | По текущей триангуляции строит оптимальную структуру перебросок
Method PolygonSquare | Площадь полигона по поверхности видимой части триангуляции и в проекции
Method PolygonsSquare | Площадь внутри списка полигонов по поверхности видимой части триангуляции и в проекции
Method RemoveSources | Удалить исходные данные
Method Reset | Удалить построенные структуры, оставить только исходные данные
Method Save | Если FileName='', то запрашивается имя и вызывается SaveToFile(FileName)}
Method SaveAsToFile | Сохранение в заданный файл
Method SaveCopyTo | Сохранение копии в заданный файл
Method SaveToFile | Сохранение триангуляции в заданный файл
Method SaveToStream | Сохранение триангуляции в заданный поток
Method SetAllNodeTags | Выставить поля Tag для всех узлов триангуляции
Method SetAllTriangleTags | Выставить поля Tag для всех треугольников (можно только для всех видимых)
Method SlopeAtPoint | Вычисление уклона в заданной точке триангуляции
Method SurfaceDifference | Вычислить поверхность, полученную вычитанием другой поверхности из исходной
Method SurfaceEarthVolume | Расчёт объёма земляных работ при выравнивании всей видимой части триангуляции до другой триангуляции. Возвращает также регион, внутри которого выполнены измерения.
Method Thicken | Выполнить сгущение триангуляции до заданной точности представления поверхности или до максимального числа узлов триангуляции
Method TrnToBreakLines | Преобразовать текущую структуру триангуляции в структурные линии
Method TrnToSources | Преобразовать текущую структуру триангуляции в исходные точки, структурные линии и регионы
Method ValidateLevels | Отсортировать список уровней и удалить лишние уровни (которые выше или ниже всей триангуляции)
Method Verify | Проверить структуру триангуляции - для отладки
Method ZeroEarthVolumes | Расчёт объёмов земляных работ при выравнивании всей видимой триангуляции до уровня ZeroLevel, причём объёмы вычисляются отдельно для каждого интервала уровней высот. Всегда в массив интервалов заносится ZeroLevel. Размер выходного массива на 1 > входного.

Где используется

Класс | Член класса
Class CADTriangulation | Method CutByPolygon (метод) Method CutByPolygons (метод) Method MakeCopy (метод) Method SurfaceDifference (метод) Method SurfaceEarthVolume (метод)
Class SurfaceDifference | Property Triangulation (свойство)
Class Triangulation | Method CutByPolygon (метод) Method CutByPolygons (метод) Method MakeCopy (метод) Method SurfaceDifference (метод) Method SurfaceEarthVolume (метод)
Class TrnArea | Property Triangulation (свойство)
Class TrnBreak | Property Triangulation (свойство)
Class TrnFigure | Property Triangulation (свойство)
Class TrnFlip | Property Triangulation (свойство)
Class TrnModifier | Property Triangulation (свойство)
Class TrnNode | Property Triangulation (свойство)
Class TrnRib | Property Triangulation (свойство)
Class TrnSource | Property Triangulation (свойство)
Class TrnTriangle | Property Triangulation (свойство)

Смотри также

Enum BSplineEdgeConstants, Class Collection, Enum CompressionLevelConstants, Enum CurveKindConstants, Class DoubleCollection, Enum EdgeCurvatureConstants, Class FigureSet, Interface IEnumerateProfile, Interface IEnumerateProfilePoints, Class IntegerCollection, Interface ITrnFigureFilter, Class ModelPoint, Class ModelRect, Class Point3D, Class ShapePolygon, Class ShapePolyline, Enum SlopeModeConstants, Enum TriangulationFormatConstants, Enum TrnFlipAbilityConstants, Enum TrnModifierKindConstants, Enum TrnNodeWeightModeConstants, Enum TrnSaveModeConstants, Enum VolumeTypeConstants, Group Триангуляция


Triangulation.AllowNodeDuplicates (свойство)

Разрешить генерацию дублирующихся узлов (при этом дубликаты не будут входить в структуру триангуляции, но будут в списке Duplicate узлов)

Синтаксис

[Visual Basic 6]
Property AllowNodeDuplicates As Boolean

[Delphi]
property AllowNodeDuplicates: WordBool

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.AreaCount (свойство)

Количество регионов триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
Property AreaCount As Long

[Delphi]
property AreaCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Areas (свойство)

Массив регионов триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Areas As TrnArea

[Delphi]
{только для чтения} property Areas: TrnArea

Смотри также

Class Triangulation, Class TrnArea, Group Триангуляция


Triangulation.Bounds (свойство)

Минимальный объемлющий все фигуры прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class Triangulation, Group Триангуляция


Triangulation.BreakCount (свойство)

Количество структурных линий триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
Property BreakCount As Long

[Delphi]
property BreakCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Breaks (свойство)

Массив структурных линий триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Breaks As TrnBreak

[Delphi]
{только для чтения} property Breaks: TrnBreak

Смотри также

Class Triangulation, Class TrnBreak, Group Триангуляция


Triangulation.BuildTime (свойство)

Время построения триангуляции в милисекундах

Синтаксис

[Visual Basic 6]
ReadOnly Property BuildTime As Long

[Delphi]
{только для чтения} property BuildTime: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Built (свойство)

Построена ли триангуляция

Синтаксис

[Visual Basic 6]
ReadOnly Property Built As Boolean

[Delphi]
{только для чтения} property Built: WordBool

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Caption (свойство)

Название базы фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.CompressionLevel (свойство)

Способ сжатия данных при сохранении в поток

Синтаксис

[Visual Basic 6]
Property CompressionLevel As CompressionLevelConstants

[Delphi]
property CompressionLevel: CompressionLevelConstants

Смотри также

Enum CompressionLevelConstants, Class Triangulation, Group Триангуляция


Triangulation.DataFormat (свойство)

Тип исходных данных в триангуляции

Синтаксис

[Visual Basic 6]
Property DataFormat As TriangulationFormatConstants

[Delphi]
property DataFormat: TriangulationFormatConstants

Смотри также

Class Triangulation, Enum TriangulationFormatConstants, Group Триангуляция


Triangulation.DefaultColor (свойство)

Цвет по умолчанию для отображения треугольников (входные данные)

Синтаксис

[Visual Basic 6]
Property DefaultColor As OLE_COLOR

[Delphi]
property DefaultColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.FigureSetCount (свойство)

Количество наборов фигур в базе

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureSetCount As Long

[Delphi]
{только для чтения} property FigureSetCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.FigureSets (свойство)

Массив наборов фигур в базе (наборы фигур рисуются от последнего к первому) (индексы должны иметь номера от 0 до FigureSetCount-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureSets As FigureSet

[Delphi]
{только для чтения} property FigureSets: FigureSet

Смотри также

Class FigureSet, Class Triangulation, Group Триангуляция


Triangulation.FileName (свойство)

Имя файла с триангуляцией

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.FlipCount (свойство)

Количество перебросок рёбер (входные данные)

Синтаксис

[Visual Basic 6]
Property FlipCount As Long

[Delphi]
property FlipCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Flips (свойство)

Массив перебросок рёбер (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Flips As TrnFlip

[Delphi]
{только для чтения} property Flips: TrnFlip

Смотри также

Class Triangulation, Class TrnFlip, Group Триангуляция


Triangulation.IgnoreRibSourceLines (свойство)

Запретить генерацию данных в структурных рёбрах об исходных структурных линиях (ускоряет процесс построения триангуляции)

Синтаксис

[Visual Basic 6]
Property IgnoreRibSourceLines As Boolean

[Delphi]
property IgnoreRibSourceLines: WordBool

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Modified (свойство)

Произошли ли какие-либо изменения фигур

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.ModifierCount (свойство)

Количество красящих/отсекающих линий (входные данные)

Синтаксис

[Visual Basic 6]
Property ModifierCount As Long

[Delphi]
property ModifierCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Modifiers (свойство)

Массив красящих/отсекающих линий (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Modifiers As TrnModifier

[Delphi]
{только для чтения} property Modifiers: TrnModifier

Смотри также

Class Triangulation, Class TrnModifier, Group Триангуляция


Triangulation.NodeCount (свойство)

Количество узлов триангуляции (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property NodeCount As Long

[Delphi]
{только для чтения} property NodeCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Nodes (свойство)

Массив узлов

Синтаксис

[Visual Basic 6]
ReadOnly Property Nodes As TrnNode

[Delphi]
{только для чтения} property Nodes: TrnNode

Смотри также

Class Triangulation, Class TrnNode, Group Триангуляция


Triangulation.RibCount (свойство)

Количество рёбер триангуляции, входящих в состав структурных линий (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property RibCount As Long

[Delphi]
{только для чтения} property RibCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Ribs (свойство)

Количество рёбер триангуляции, входящих в состав структурных линий (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Ribs As TrnRib

[Delphi]
{только для чтения} property Ribs: TrnRib

Смотри также

Class Triangulation, Class TrnRib, Group Триангуляция


Triangulation.SourceCount (свойство)

Количество точек триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
Property SourceCount As Long

[Delphi]
property SourceCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Sources (свойство)

Массив исходных точек триангуляции (входные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Sources As TrnSource

[Delphi]
{только для чтения} property Sources: TrnSource

Смотри также

Class Triangulation, Class TrnSource, Group Триангуляция


Triangulation.TriangleCount (свойство)

Количество треугольников триангуляции (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property TriangleCount As Long

[Delphi]
{только для чтения} property TriangleCount: Integer

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Triangles (свойство)

Количество треугольников триангуляции (выходные данные)

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangles As TrnTriangle

[Delphi]
{только для чтения} property Triangles: TrnTriangle

Смотри также

Class Triangulation, Class TrnTriangle, Group Триангуляция


Triangulation.UseProgress (свойство)

Показывать ли прогресс при загрузке/сохранении/построении?

Синтаксис

[Visual Basic 6]
Property UseProgress As Boolean

[Delphi]
property UseProgress: WordBool

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.AddModifier (метод)

Добавить новую красящую линию, заданную в виде последовательности точек

Синтаксис

[Visual Basic 6]
Function AddModifier ( _
   ByVal Points As Collection, _
   [ByVal Kind As TrnModifierKindConstants = 0], _
   [ByVal Color As OLE_COLOR = 0] _
) As TrnModifier

[Delphi]
function AddModifier(
   const Points: Collection;
   const Kind: TrnModifierKindConstants;
   const Color: OLE_COLOR
): TrnModifier

Описание параметров

Points
[in] Коллекция точек типа ModelPoint, образующих модификатор
Kind
[in] Тип модификатора
Color
[in] Цвет окраски треугольников для модификаторов типа TrnModifierKindPainter (красители)

Возвращаемое значение

Возвращает новый модификатор

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Collection, Class Triangulation, Class TrnModifier, Enum TrnModifierKindConstants, Group Триангуляция


Triangulation.AddModifierShape (метод)

Добавить новую красящую линию, заданный в виде полилинии

Синтаксис

[Visual Basic 6]
Function AddModifierShape ( _
   ByVal Polyline As ShapePolyline, _
   [ByVal Kind As TrnModifierKindConstants = 0], _
   [ByVal Color As OLE_COLOR = 0] _
) As TrnModifier

[Delphi]
function AddModifierShape(
   const Polyline: ShapePolyline;
   const Kind: TrnModifierKindConstants;
   const Color: OLE_COLOR
): TrnModifier

Описание параметров

Polyline
[in] Полилиния, определяющая красящую линию
Kind
[in] Тип модификатора
Color
[in] Цвет окраски треугольников для модификаторов типа TrnModifierKindPainter (красители)

Возвращаемое значение

Возвращает новый модификатор

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ShapePolyline, Class Triangulation, Class TrnModifier, Enum TrnModifierKindConstants, Group Триангуляция


Triangulation.AddPolygon (метод)

Добавить новый регион, заданный в виде последовательности точек, образующих один контур

Синтаксис

[Visual Basic 6]
Function AddPolygon ( _
   ByVal Points As Collection, _
   [ByVal EqualZ As Double = 0] _
) As TrnArea

[Delphi]
function AddPolygon(
   const Points: Collection;
   const EqualZ: Double
): TrnArea

Описание параметров

Points
[in] Коллекция точек типа ModelPoint, образующих контур полигона
EqualZ
[in] Общая высота, задаваемая всем узлам полигона

Возвращаемое значение

Возвращает новый регион

Смотри также

Class Collection, Class Triangulation, Class TrnArea, Group Триангуляция


Triangulation.AddPolygonShape (метод)

Добавить новый регион, заданный в виде полигона

Синтаксис

[Visual Basic 6]
Function AddPolygonShape ( _
   ByVal Polygon As ShapePolygon, _
   [ByVal EqualZ As Double = 0] _
) As TrnArea

[Delphi]
function AddPolygonShape(
   const Polygon: ShapePolygon;
   const EqualZ: Double
): TrnArea

Описание параметров

Polygon
[in] Добавляемый полигон
EqualZ
[in] Общая высота, задаваемая всем узлам полигона

Возвращаемое значение

Возвращает новый регион

Смотри также

Class ShapePolygon, Class Triangulation, Class TrnArea, Group Триангуляция


Triangulation.AddPolyline (метод)

Добавить новую структурную линию, заданную в виде последовательности точек

Синтаксис

[Visual Basic 6]
Function AddPolyline ( _
   ByVal Points As Collection, _
   [ByVal Smooth As Boolean = False], _
   [ByVal EqualZ As Double = 0] _
) As TrnBreak

[Delphi]
function AddPolyline(
   const Points: Collection;
   const Smooth: WordBool;
   const EqualZ: Double
): TrnBreak

Описание параметров

Points
[in] Коллекция точек типа ModelPoint, образующих полилинию
Smooth
[in] Признак того, что добавляемая структурная линия не должна определять резкий излом модели поверхности, а определять гладкий перегиб
EqualZ
[in] Общая высота, задаваемая всем узлам полилинии

Возвращаемое значение

Возвращает новую структурную линию

Смотри также

Class Collection, Class Triangulation, Class TrnBreak, Group Триангуляция


Triangulation.AddPolylineShape (метод)

Добавить новую структурную линию, заданную в виде полилинии

Синтаксис

[Visual Basic 6]
Function AddPolylineShape ( _
   ByVal Polyline As ShapePolyline, _
   [ByVal Smooth As Boolean = False], _
   [ByVal EqualZ As Double = 0] _
) As TrnBreak

[Delphi]
function AddPolylineShape(
   const Polyline: ShapePolyline;
   const Smooth: WordBool;
   const EqualZ: Double
): TrnBreak

Описание параметров

Polyline
[in] Добавляемая полилиния
Smooth
[in] Признак того, что добавляемая структурная линия не должна определять резкий излом модели поверхности, а определять гладкий перегиб
EqualZ
[in] Общая высота, задаваемая всем узлам полилинии

Возвращаемое значение

Возвращает новую структурную линию

Смотри также

Class ShapePolyline, Class Triangulation, Class TrnBreak, Group Триангуляция


Triangulation.AddSource (метод)

Добавить новую исходную точку

Синтаксис

[Visual Basic 6]
Function AddSource ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
) As TrnSource

[Delphi]
function AddSource(
   const X: Double;
   const Y: Double;
   const Z: Double
): TrnSource

Описание параметров

X
[in] Координата X добавляемой точки
Y
[in] Координата Y добавляемой точки
Z
[in] Координата Z добавляемой точки

Возвращаемое значение

Возвращает новую исходную точку

Смотри также

Class Triangulation, Class TrnSource, Group Триангуляция


Triangulation.Build (метод)

Построить триангуляцию по указанным входным данных

Синтаксис

[Visual Basic 6]
Sub Build

[Delphi]
procedure Build

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.BuildIsoexpos (метод)

Построить экспозиции (изонаправления) заданных разделителей направлений ExpoDelimiters и вернуть их в Isoexpos в виде полигонов (возможны Nothing в коллекции)

Синтаксис

[Visual Basic 6]
Sub BuildIsoexpos ( _
   ByVal ExpoDelimiters As DoubleCollection, _
   Isoexpos As Collection, _
   ByVal MinSlope As Double, _
   [ByVal MinSlopeMode As SlopeModeConstants = 0] _
)

[Delphi]
procedure BuildIsoexpos(
   const ExpoDelimiters: DoubleCollection;
   var Isoexpos: Collection;
   const MinSlope: Double;
   const MinSlopeMode: SlopeModeConstants
)

Описание параметров

ExpoDelimiters
[in] Коллекция DoubleCollection заданных разделителей направлений
Isoexpos
[in, out] Возращает коллекцию Collection найденных полигонов PolygonShape
MinSlope
[in] Минимальный допустимый наклон. Если вычисленный наклон будет меньше этого, то функция возвратит False
MinSlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле

Смотри также

Class Collection, Class DoubleCollection, Enum SlopeModeConstants, Class Triangulation, Group Триангуляция


Triangulation.BuildIsoline (метод)

Построить изолинию заданного уровня Level и вернуть её в виде полиполилинии

Синтаксис

[Visual Basic 6]
Function BuildIsoline ( _
   ByVal Level As Double, _
   [ByVal CurveKind As CurveKindConstants = 0], _
   [ByVal Curvature As EdgeCurvatureConstants = 0], _
   [ByVal Tension As Double = 1], _
   [ByVal BSplineEdge As BSplineEdgeConstants = 0] _
) As ShapePolyline

[Delphi]
function BuildIsoline(
   const Level: Double;
   const CurveKind: CurveKindConstants;
   const Curvature: EdgeCurvatureConstants;
   const Tension: Double;
   const BSplineEdge: BSplineEdgeConstants
): ShapePolyline

Описание параметров

Level
[in] Уровень, на котором нужно построить изолинию
CurveKind
[in] Тип сглаживания (если CurveKindLine, то сглаживания нет и последующие параметры игнорируются)
Curvature
[in] Кривизна на концах полилинии для интерполяционных сплайнов
Tension
[in] Степень натяжения сплайнов
BSplineEdge
[in] Тип краевого ограничения для B-сплайнов

Возвращаемое значение

Возращает построенную изолинию или Nothing, если изолиния на таком уровне не может быть построена

Смотри также

Enum BSplineEdgeConstants, Enum CurveKindConstants, Enum EdgeCurvatureConstants, Class ShapePolyline, Class Triangulation, Group Триангуляция


Triangulation.BuildIsolines (метод)

Построить изолинии заданных уровней Levels и вернуть их в Isolines в виде полиполилиний или полигонов

Синтаксис

[Visual Basic 6]
Sub BuildIsolines ( _
   ByVal Levels As DoubleCollection, _
   Isolines As Collection, _
   [ByVal BuildBands As Boolean = False], _
   [ByVal CurveKind As CurveKindConstants = 0], _
   [ByVal Curvature As EdgeCurvatureConstants = 0], _
   [ByVal Tension As Double = 1], _
   [ByVal BSplineEdge As BSplineEdgeConstants = 0] _
)

[Delphi]
procedure BuildIsolines(
   const Levels: DoubleCollection;
   var Isolines: Collection;
   const BuildBands: WordBool;
   const CurveKind: CurveKindConstants;
   const Curvature: EdgeCurvatureConstants;
   const Tension: Double;
   const BSplineEdge: BSplineEdgeConstants
)

Описание параметров

Levels
[in] Коллекция DoubleCollection уровней
Isolines
[in, out] Возращает коллекцию Collection найденных полилиний PolylineShape (для BuildBands = False) или полигонов PolygonShape (для BuildBands = True)
BuildBands
[in] Строить ли изоконтуры? Иначе будут просто изолинии
CurveKind
[in] Тип сглаживания (если CurveKindLine, то сглаживания нет и последующие параметры игнорируются)
Curvature
[in] Кривизна на концах полилинии для интерполяционных сплайнов
Tension
[in] Степень натяжения сплайнов
BSplineEdge
[in] Тип краевого ограничения для B-сплайнов

Смотри также

Enum BSplineEdgeConstants, Class Collection, Enum CurveKindConstants, Class DoubleCollection, Enum EdgeCurvatureConstants, Class Triangulation, Group Триангуляция


Triangulation.BuildIsoslopes (метод)

Построить изоклины (изоуклоны) заданных наклонов Slopes и вернуть их в Isoslopes в виде полиполилиний или полигонов

Синтаксис

[Visual Basic 6]
Sub BuildIsoslopes ( _
   ByVal Slopes As DoubleCollection, _
   Isoslopes As Collection, _
   [ByVal SlopeMode As SlopeModeConstants = 0], _
   [ByVal BuildBands As Boolean = False], _
   [ByVal CurveKind As CurveKindConstants = 0], _
   [ByVal Curvature As EdgeCurvatureConstants = 0], _
   [ByVal Tension As Double = 1], _
   [ByVal BSplineEdge As BSplineEdgeConstants = 0] _
)

[Delphi]
procedure BuildIsoslopes(
   const Slopes: DoubleCollection;
   var Isoslopes: Collection;
   const SlopeMode: SlopeModeConstants;
   const BuildBands: WordBool;
   const CurveKind: CurveKindConstants;
   const Curvature: EdgeCurvatureConstants;
   const Tension: Double;
   const BSplineEdge: BSplineEdgeConstants
)

Описание параметров

Slopes
[in] Коллекция DoubleCollection уровней уклонов
Isoslopes
[in, out] Возращает коллекцию Collection найденных полилиний PolylineShape (для BuildBands = False) или полигонов PolygonShape (для BuildBands = True)
SlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле
BuildBands
[in] Строить ли изоконтуры? Иначе будут просто изолинии
CurveKind
[in] Тип сглаживания (если CurveKindLine, то сглаживания нет и последующие параметры игнорируются)
Curvature
[in] Кривизна на концах полилинии для интерполяционных сплайнов
Tension
[in] Степень натяжения сплайнов
BSplineEdge
[in] Тип краевого ограничения для B-сплайнов

Смотри также

Enum BSplineEdgeConstants, Class Collection, Enum CurveKindConstants, Class DoubleCollection, Enum EdgeCurvatureConstants, Enum SlopeModeConstants, Class Triangulation, Group Триангуляция


Triangulation.BuildNoAreaClassify (метод)

Построить триангуляцию по указанным данных без классификации треугольников по регионам

Синтаксис

[Visual Basic 6]
Sub BuildNoAreaClassify

[Delphi]
procedure BuildNoAreaClassify

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.BuildVisibilities (метод)

Построение зон и линий видимости из заданной точки

Синтаксис

[Visual Basic 6]
Sub BuildVisibilities ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   VisibleAreas As Collection, _
   UnvisibleAreas As Collection, _
   VisibleLines As Collection, _
   UnvisibleLines As Collection, _
   ByVal ZOverSurface As Boolean _
)

[Delphi]
procedure BuildVisibilities(
   const X: Double;
   const Y: Double;
   const Z: Double;
   var VisibleAreas: Collection;
   var UnvisibleAreas: Collection;
   var VisibleLines: Collection;
   var UnvisibleLines: Collection;
   const ZOverSurface: WordBool
)

Описание параметров

X
[in] Координата X точки наблюдения
Y
[in] Координата Y точки наблюдения
Z
[in] Координата Z точки наблюдения
VisibleAreas
[in, out] Возращает коллекцию Collection полигонов, показывающих видимую часть триангуляции
UnvisibleAreas
[in, out] Возращает коллекцию Collection полигонов, показывающих невидимую часть триангуляции
VisibleLines
[in, out] Возращает коллекцию Collection радиальных полилиний, показывающих видимую части триангуляции
UnvisibleLines
[in, out] Возращает коллекцию Collection радиальных полилиний, показывающих видимую части триангуляции
ZOverSurface
[in] Если True, то заданная координата Z определяет возвышение точки наблюдения над поверхностью, иначе Z - это абсолютная координата

Смотри также

Class Collection, Class Triangulation, Group Триангуляция


Triangulation.CalcHash (метод)

Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcHash ( _
   [ByVal UseZ As Boolean = True], _
   [ByVal UseIsolines As Boolean = True], _
   [ByVal UseHidden As Boolean = True], _
   [ByVal UseColors As Boolean = True] _
) As String

[Delphi]
function CalcHash(
   const UseZ: WordBool;
   const UseIsolines: WordBool;
   const UseHidden: WordBool;
   const UseColors: WordBool
): WideString

Описание параметров

UseZ
[in] Использовать ли для вычисления хеша координату Z узлов
UseIsolines
[in] Использовать ли для вычисления хеша признак NoIsolines треугольников
UseHidden
[in] Использовать ли для вычисления хеша признак Hidden треугольников
UseColors
[in] Использовать ли для вычисления хеша цвет треугольников

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.CalcHashInPolygon (метод)

Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников в заданном регионе. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcHashInPolygon ( _
   ByVal Polygon As ShapePolygon, _
   [ByVal UseZ As Boolean = True], _
   [ByVal UseIsolines As Boolean = True], _
   [ByVal UseHidden As Boolean = True], _
   [ByVal UseColors As Boolean = True] _
) As String

[Delphi]
function CalcHashInPolygon(
   const Polygon: ShapePolygon;
   const UseZ: WordBool;
   const UseIsolines: WordBool;
   const UseHidden: WordBool;
   const UseColors: WordBool
): WideString

Описание параметров

Polygon
[in] Полигон, внутри которого нужно расчитать хеш
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов
UseIsolines
[in] Использовать ли для вычисления хеша признак NoIsolines треугольников
UseHidden
[in] Использовать ли для вычисления хеша признак Hidden треугольников
UseColors
[in] Использовать ли для вычисления хеша цвет треугольников

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.CalcHashInRect (метод)

Вычислить значение хеш-функции по координатам узлов с учетом различных признаков треугольников в заданном прямоугольнике. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcHashInRect ( _
   ByVal Rect As ModelRect, _
   [ByVal UseZ As Boolean = True], _
   [ByVal UseIsolines As Boolean = True], _
   [ByVal UseHidden As Boolean = True], _
   [ByVal UseColors As Boolean = True] _
) As String

[Delphi]
function CalcHashInRect(
   const Rect: ModelRect;
   const UseZ: WordBool;
   const UseIsolines: WordBool;
   const UseHidden: WordBool;
   const UseColors: WordBool
): WideString

Описание параметров

Rect
[in] Прямоугольник, внутри которого нужно расчитать хеш
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов
UseIsolines
[in] Использовать ли для вычисления хеша признак NoIsolines треугольников
UseHidden
[in] Использовать ли для вычисления хеша признак Hidden треугольников
UseColors
[in] Использовать ли для вычисления хеша цвет треугольников

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class ModelRect, Class Triangulation, Group Триангуляция


Triangulation.CalcSimpleAlongPolyline (метод)

Вычислить значение простой хеш-функции по координатам узлов и топологии треугольников вдоль полилинии

Синтаксис

[Visual Basic 6]
Function CalcSimpleAlongPolyline ( _
   ByVal Polyline As ShapePolyline _
) As Double

[Delphi]
function CalcSimpleAlongPolyline(
   const Polyline: ShapePolyline
): Double

Описание параметров

Polyline
[in] Полилиния, вдоль которой нужно расчитать хеш

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class ShapePolyline, Class Triangulation, Group Триангуляция


Triangulation.CalcSimpleAlongSegment (метод)

Вычислить значение простой хеш-функции по координатам узлов и топологии треугольников вдоль полилинии

Синтаксис

[Visual Basic 6]
Function CalcSimpleAlongSegment ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint _
) As Double

[Delphi]
function CalcSimpleAlongSegment(
   const Point1: ModelPoint;
   const Point2: ModelPoint
): Double

Описание параметров

Point1
[in] Первая точка отрезка, вдоль которого нужно расчитать хеш
Point2
[in] Вторая точка отрезка, вдоль которого нужно расчитать хеш

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class ModelPoint, Class Triangulation, Group Триангуляция


Triangulation.CalcSimpleHash (метод)

Вычислить значение хеш-функции по координатам узлов и топологии треугольников. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcSimpleHash ( _
   [ByVal UseGeometry As Boolean = True], _
   [ByVal UseZ As Boolean = True] _
) As Double

[Delphi]
function CalcSimpleHash(
   const UseGeometry: WordBool;
   const UseZ: WordBool
): Double

Описание параметров

UseGeometry
[in] Использовать ли для вычисления хеша координаты узлов
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.CalcSimpleHashInPolygon (метод)

Вычислить значение хеш-функции по координатам узлов и топологии треугольников в заданном регионе. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcSimpleHashInPolygon ( _
   ByVal Polygon As ShapePolygon, _
   [ByVal UseGeometry As Boolean = True], _
   [ByVal UseZ As Boolean = True] _
) As Double

[Delphi]
function CalcSimpleHashInPolygon(
   const Polygon: ShapePolygon;
   const UseGeometry: WordBool;
   const UseZ: WordBool
): Double

Описание параметров

Polygon
[in] Полигон, внутри которого нужно расчитать хеш
UseGeometry
[in] Использовать ли для вычисления хеша координаты узлов
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.CalcSimpleHashInRect (метод)

Вычислить значение хеш-функции по координатам узлов и топологии треугольников в заданном прямоугольнике. Используется для выявления факта различия разных триангуляций

Синтаксис

[Visual Basic 6]
Function CalcSimpleHashInRect ( _
   ByVal Rect As ModelRect, _
   [ByVal UseGeometry As Boolean = True], _
   [ByVal UseZ As Boolean = True] _
) As Double

[Delphi]
function CalcSimpleHashInRect(
   const Rect: ModelRect;
   const UseGeometry: WordBool;
   const UseZ: WordBool
): Double

Описание параметров

Rect
[in] Прямоугольник, внутри которого нужно расчитать хеш
UseGeometry
[in] Использовать ли для вычисления хеша координаты узлов
UseZ
[in] Использовать ли для вычисления хеша координату Z узлов

Возвращаемое значение

Возвращает значение хеш-функции

Смотри также

Class ModelRect, Class Triangulation, Group Триангуляция


Triangulation.CalcSquare (метод)

Расчёт площади по всей видимой части триангуляции, возможно, только по треугольникам c Tag>0

Синтаксис

[Visual Basic 6]
Sub CalcSquare ( _
   FlatSquare As Double, _
   SpatialSquare As Double, _
   [ByVal UsePositiveTag As Boolean = False] _
)

[Delphi]
procedure CalcSquare(
   out FlatSquare: Double;
   out SpatialSquare: Double;
   const UsePositiveTag: WordBool
)

Описание параметров

FlatSquare
[out] Площадь триангуляции в проекции на плоскость
SpatialSquare
[out] Площадь поверхности триангуляции
UsePositiveTag
[in] В случае указания True в данном параметре, то вычисление площадей будет выполняться только по тем треугольникам, у которых свойство Tag>0

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.CanFlipAtPoint (метод)

Проверить, возможно ли в указанной точке триангуляции выполнить переброску

Синтаксис

[Visual Basic 6]
Function CanFlipAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Precision As Double _
) As TrnFlipAbilityConstants

[Delphi]
function CanFlipAtPoint(
   const X: Double;
   const Y: Double;
   const Precision: Double
): TrnFlipAbilityConstants

Описание параметров

X
[in] Координата X точки на плоскости, в которой необходимо найти ребро триангуляции, пригодное для выполнения переброски
Y
[in] Координата Y точки на плоскости, в которой необходимо найти ребро триангуляции, пригодное для выполнения переброски
Precision
[in] Максимальный радиус поиска подходящих ребер триангуляции для переброски в указанной точке плоскости

Возвращаемое значение

Возвращает вариант выполнения переброски в указанной точки триангуляции

Смотри также

Class Triangulation, Enum TrnFlipAbilityConstants, Group Триангуляция


Triangulation.Clear (метод)

Очистить триангуляцию

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.CustomBuild (метод)

Построить или достроить триангуляцию по указанным входным данных

Синтаксис

[Visual Basic 6]
Sub CustomBuild ( _
   [ByVal New As Boolean = True], _
   [ByVal NoDeloneTest As Boolean = False], _
   [ByVal NeedProgress As Boolean = False], _
   [ByVal AllRibHard As Boolean = False], _
   [ByVal NoAreaClassify As Boolean = False], _
   [ByVal WorkSources As Collection = 0], _
   [ByVal WorkLines As Collection = 0], _
   [ByVal WorkAreas As Collection = 0], _
   [ByVal WorkFlips As Collection = 0], _
   [ByVal WorkModifiers As Collection = 0] _
)

[Delphi]
procedure CustomBuild(
   const New: WordBool;
   const NoDeloneTest: WordBool;
   const NeedProgress: WordBool;
   const AllRibHard: WordBool;
   const NoAreaClassify: WordBool;
   const WorkSources: Collection;
   const WorkLines: Collection;
   const WorkAreas: Collection;
   const WorkFlips: Collection;
   const WorkModifiers: Collection
)

Описание параметров

New
[in] Построить триангуляцию с нуля (иначе добавить к старым структурам)
NoDeloneTest
[in] Не выполнять перестроения Делоне
NeedProgress
[in] Отображать ли прогресс
AllRibHard
[in] Трактовать все пересекаемые ребра как жёсткие
NoAreaClassify
[in] Не выполнять классификацию регионов
WorkSources
[in] Список исходных точек или Nothing
WorkLines
[in] Список структурных линий или Nothing
WorkAreas
[in] Список регионов или Nothing
WorkFlips
[in] Список перебросок рёбер или Nothing
WorkModifiers
[in] Список модификаторов или Nothing

Смотри также

Class Collection, Class Triangulation, Group Триангуляция


Triangulation.CutByPolygon (метод)

Вырезать подтриангуляцию, попадающую внутрь полигона

Синтаксис

[Visual Basic 6]
Function CutByPolygon ( _
   ByVal Polygon As ShapePolygon _
) As Triangulation

[Delphi]
function CutByPolygon(
   const Polygon: ShapePolygon
): Triangulation

Описание параметров

Polygon
[in] Полигон, в пределах которого нужно обрезать подтриангуляцию

Возвращаемое значение

Возвращает новую обрезанную триангуляцию

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.CutByPolygons (метод)

Вырезать подтриангуляцию, попадающую внутрь списка полигонов

Синтаксис

[Visual Basic 6]
Function CutByPolygons ( _
   ByVal Polygons As Collection _
) As Triangulation

[Delphi]
function CutByPolygons(
   const Polygons: Collection
): Triangulation

Описание параметров

Polygons
[in] Список полигонов PolygonShape, в пределах которых нужно обрезать подтриангуляцию

Возвращаемое значение

Возвращает новую обрезанную триангуляцию

Смотри также

Class Collection, Class Triangulation, Group Триангуляция


Triangulation.DeleteArea (метод)

Удалить регион по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteArea ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteArea(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемого региона (нумерация идёт от 0 до AreaCount-1)

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.DeleteBreak (метод)

Удалить структурную линию по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteBreak ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteBreak(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемой структурной линии (нумерация идёт от 0 до LineCount-1)

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.DeleteFlip (метод)

Удалить переброску рёбер по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteFlip ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteFlip(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемой переброски рёбер (нумерация идёт от 0 до FlipCount-1)

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.DeleteModifier (метод)

Удалить модификатор по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteModifier ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteModifier(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемого модификатора (нумерация идёт от 0 до ModifierCount-1)

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.DeleteSource (метод)

Удалить исходную точку по индексу

Синтаксис

[Visual Basic 6]
Sub DeleteSource ( _
   ByVal Index As Long _
)

[Delphi]
procedure DeleteSource(
   const Index: Integer
)

Описание параметров

Index
[in] Номер исходной удаляемой точки (нумерация идёт от 0 до SourceCount-1)

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.EarthVolume (метод)

Расчёт объёма земляных работ при выравнивании всей видимой части триангуляции до уровня Z=Level. AboveVolume - объём выше, BelowVolume - объём ниже уровня, AboveSquare - площадь участка, поверхность которого находится выше Level

Синтаксис

[Visual Basic 6]
Sub EarthVolume ( _
   ByVal Level As Double, _
   BelowVolume As Double, _
   BelowSquare As Double, _
   AboveVolume As Double, _
   AboveSquare As Double _
)

[Delphi]
procedure EarthVolume(
   const Level: Double;
   out BelowVolume: Double;
   out BelowSquare: Double;
   out AboveVolume: Double;
   out AboveSquare: Double
)

Описание параметров

Level
[in] Уровень выравнивания
BelowVolume
[out] Вычисленный объём земляных работ ниже указанной плоскости
BelowSquare
[out] Площадь участка, поверхность которого ниже указанной плоскости
AboveVolume
[out] Вычисленный объём земляных работ выше указанной плоскости
AboveSquare
[out] Площадь участка, поверхность которого выше указанной плоскости

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.EnumerateProfile (метод)

Построение профиля на отрезке Point1-Point2, на выходе отрезки профиля выдаются в EnumerateProfile.Register

Синтаксис

[Visual Basic 6]
Function EnumerateProfile ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint, _
   ByVal EnumerateProfileInterface As IEnumerateProfile _
) As Boolean

[Delphi]
function EnumerateProfile(
   const Point1: ModelPoint;
   const Point2: ModelPoint;
   const EnumerateProfileInterface: IEnumerateProfile
): WordBool

Описание параметров

Point1
[in] Первая точка отрезка
Point2
[in] Вторая точка отрезка
EnumerateProfileInterface
[in] Интерфейс, у которого будет вызван метод Register, в который будут переданы все найденные отрезки

Возвращаемое значение

Возвращает True, если профиль успешно найден

Смотри также

Interface IEnumerateProfile, Class ModelPoint, Class Triangulation, Group Триангуляция


Triangulation.EnumerateProfilePoints (метод)

Построение профиля на отрезке Point1-Point2, на выходе узловые точки профиля выдаются в EnumerateProfilePoints.Register

Синтаксис

[Visual Basic 6]
Function EnumerateProfilePoints ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint, _
   ByVal EnumerateProfilePointsInterface As IEnumerateProfilePoints _
) As Boolean

[Delphi]
function EnumerateProfilePoints(
   const Point1: ModelPoint;
   const Point2: ModelPoint;
   const EnumerateProfilePointsInterface: IEnumerateProfilePoints
): WordBool

Описание параметров

Point1
[in] Первая точка отрезка
Point2
[in] Вторая точка отрезка
EnumerateProfilePointsInterface
[in] Интерфейс, у которого будет вызван метод Register, в который будут переданы все найденные точки профиля

Возвращаемое значение

Возвращает True, если узловые точки профиля успешно найдены

Смотри также

Interface IEnumerateProfilePoints, Class ModelPoint, Class Triangulation, Group Триангуляция


Triangulation.ExportToXmlFile (метод)

Сохранение в Xml-файл

Синтаксис

[Visual Basic 6]
Sub ExportToXmlFile ( _
   ByVal FileName As String, _
   [ByVal SaveMode As TrnSaveModeConstants = 0], _
   [ByVal Format As Boolean = False] _
)

[Delphi]
procedure ExportToXmlFile(
   const FileName: WideString;
   const SaveMode: TrnSaveModeConstants;
   const Format: WordBool
)

Описание параметров

FileName
[in] Имя Xml-файла, в который необходимо выполнить сохранение триангуляции
SaveMode
[in] Режим сохранения триангуляции
Format
[in] Следует ли выполнять форматирование с отступами создаваемого xml-файла

Смотри также

Class Triangulation, Enum TrnSaveModeConstants, Group Триангуляция


Triangulation.ExportToXmlNode (метод)

Сохранение в узел Xml-файла

Синтаксис

[Visual Basic 6]
Sub ExportToXmlNode ( _
   ByVal IXMLNode As IUnknown, _
   [ByVal SaveMode As TrnSaveModeConstants = 0] _
)

[Delphi]
procedure ExportToXmlNode(
   const IXMLNode: IUnknown;
   const SaveMode: TrnSaveModeConstants
)

Описание параметров

IXMLNode
[in] Xml-узел, под которым необходимо выполнить сохранение триангуляции
SaveMode
[in] Режим сохранения триангуляции

Смотри также

Class Triangulation, Enum TrnSaveModeConstants, Group Триангуляция


Triangulation.ExpositionAtPoint (метод)

Вычисление экспозиции (направления) склона в заданной точке триангуляции

Синтаксис

[Visual Basic 6]
Function ExpositionAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal MinSlope As Double, _
   ByVal SlopeMode As SlopeModeConstants, _
   ByVal WeightMode As TrnNodeWeightModeConstants, _
   Exposition As Double _
) As Boolean

[Delphi]
function ExpositionAtPoint(
   const X: Double;
   const Y: Double;
   const MinSlope: Double;
   const SlopeMode: SlopeModeConstants;
   const WeightMode: TrnNodeWeightModeConstants;
   out Exposition: Double
): WordBool

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо вычислить экспозицию
Y
[in] Координата Y точки плоскости, в которой необходимо вычислить экспозицию
MinSlope
[in] Минимальное значение уклона, меньше которого участок рельефа считается горизонтальным
SlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников
Exposition
[out] Вычисленный экспозиция

Возвращаемое значение

Возвращает True, если в указанной точке экспозиция вычислена

Смотри также

Enum SlopeModeConstants, Class Triangulation, Enum TrnNodeWeightModeConstants, Group Триангуляция


Triangulation.ExtractBorder (метод)

Создать полигон по границе триангуляции

Синтаксис

[Visual Basic 6]
Function ExtractBorder ( _
   [ByVal WithZ As Boolean = False], _
   [ByVal VisibleOnly As Boolean = True] _
) As ShapePolygon

[Delphi]
function ExtractBorder(
   const WithZ: WordBool;
   const VisibleOnly: WordBool
): ShapePolygon

Описание параметров

WithZ
[in] Следует ли извлекать полигон вместе с координатой Z
VisibleOnly
[in] Следует ли извлекать полигон только по видимой части триангуляции

Возвращаемое значение

Возращает полигон, образующий границу триангуляции

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.ExtractPolygon (метод)

Выделить из триангуляции все связанные области треугольников, имеющих поле положительное поле Tag. Результат возвращается в виде полиполигона

Синтаксис

[Visual Basic 6]
Function ExtractPolygon ( _
   [ByVal WithZ As Boolean = False] _
) As ShapePolygon

[Delphi]
function ExtractPolygon(
   const WithZ: WordBool
): ShapePolygon

Описание параметров

WithZ
[in] Следует ли извлекать полигон вместе с координатой Z

Возвращаемое значение

Возращает найденный полиполигон

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.ExtractPolygons (метод)

Выделить из триангуляции все связанные области треугольников, имеющих положительное поле Tag. Результат возвращается в виде коллекции полигонов

Синтаксис

[Visual Basic 6]
Sub ExtractPolygons ( _
   FoundPolygons As Collection, _
   [ByVal WithZ As Boolean = False] _
)

[Delphi]
procedure ExtractPolygons(
   var FoundPolygons: Collection;
   const WithZ: WordBool
)

Описание параметров

FoundPolygons
[in, out] Возращает коллекцию Collection найденных полигонов PolygonShape
WithZ
[in] Следует ли извлекать полигоны вместе с координатой Z

Смотри также

Class Collection, Class Triangulation, Group Триангуляция


Triangulation.ExtractTriangles (метод)

Выделить из триангуляции все области треугольников, имеющих поле Tag>0. В один полигон объединяются все треугольники с одинаковым Tag. Результат возвращается в виде коллекций полигонов и соответствующих им значений поля Tag

Синтаксис

[Visual Basic 6]
Sub ExtractTriangles ( _
   ByVal WithZ As Boolean, _
   ByVal MakePolyPolygons As Boolean, _
   Polygons As Collection, _
   PolygonTags As IntegerCollection _
)

[Delphi]
procedure ExtractTriangles(
   const WithZ: WordBool;
   const MakePolyPolygons: WordBool;
   var Polygons: Collection;
   var PolygonTags: IntegerCollection
)

Описание параметров

WithZ
[in] Следует ли извлекать полигоны вместе с координатой Z
MakePolyPolygons
[in] Следует ли извлекать полигоны в виде полполигонов, объединяя несмежные области с одним значением Tag
Polygons
[in, out] Возращает коллекцию Collection найденных полигонов PolygonShape
PolygonTags
[in, out] Возращает коллекцию IntegerCollection значений поля Tag для каждого возвращённого в коллекции Polygons полигона

Смотри также

Class Collection, Class IntegerCollection, Class Triangulation, Group Триангуляция


Triangulation.ExtractVoronoi (метод)

Построить диаграммы Вороного. Результат возвращается в виде коллекции полигонов. Результат возвращается в виде коллекций полигонов, образующих отдельные диаграммы Вороного, и соответствующих им значений поля Id узлов

Синтаксис

[Visual Basic 6]
Sub ExtractVoronoi ( _
   NodePolygons As Collection, _
   PolygonNodeIds As IntegerCollection _
)

[Delphi]
procedure ExtractVoronoi(
   var NodePolygons: Collection;
   var PolygonNodeIds: IntegerCollection
)

Описание параметров

NodePolygons
[in, out] Возращает коллекцию Collection найденных полигонов PolygonShape, образующих отдельные диаграммы Вороного
PolygonNodeIds
[in, out] Возращает коллекцию IntegerCollection значений поля Id узла для каждого возвращённого в коллекции Polygons полигона (каждый полигон строится вокруг некоторого узла)

Смотри также

Class Collection, Class IntegerCollection, Class Triangulation, Group Триангуляция


Triangulation.FindHeightRange (метод)

Найти минимальную и максимальную высоту видимой части триангуляции

Синтаксис

[Visual Basic 6]
Function FindHeightRange ( _
   Min As Double, _
   Max As Double _
) As Boolean

[Delphi]
function FindHeightRange(
   out Min: Double;
   out Max: Double
): WordBool

Описание параметров

Min
[out] Минимальная высота триангуляции
Max
[out] Максимальная высота триангуляции

Возвращаемое значение

Возвращает True, если в триангуляции есть хотя бы один треугольник

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.FindNode (метод)

Найти узел триангуляции в заданой точке

Синтаксис

[Visual Basic 6]
Function FindNode ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As TrnNode

[Delphi]
function FindNode(
   const X: Double;
   const Y: Double
): TrnNode

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо найти узел
Y
[in] Координата Y точки плоскости, в которой необходимо найти узел

Возвращаемое значение

Возвращает узел в указанной точке плоскости или Nothing, если таковой не найден

Смотри также

Class Triangulation, Class TrnNode, Group Триангуляция


Triangulation.FindTriangle (метод)

Поиск треугольника для заданной точки

Синтаксис

[Visual Basic 6]
Function FindTriangle ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As TrnTriangle

[Delphi]
function FindTriangle(
   const X: Double;
   const Y: Double
): TrnTriangle

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо найти треугольник
Y
[in] Координата Y точки плоскости, в которой необходимо найти треугольник

Возвращаемое значение

Возвращает треугольник в указанной точке плоскости или Nothing, если таковой не найден

Смотри также

Class Triangulation, Class TrnTriangle, Group Триангуляция


Triangulation.FindTriangles (метод)

Выделить все треугольники вдоль отрезка Point1-Point2. Все найденные треугольники будут помещены в коллекцию Triangles

Синтаксис

[Visual Basic 6]
Function FindTriangles ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint, _
   Triangles As Collection, _
   [ByVal VisibleTrianglesOnly As Boolean = True] _
) As Boolean

[Delphi]
function FindTriangles(
   const Point1: ModelPoint;
   const Point2: ModelPoint;
   var Triangles: Collection;
   const VisibleTrianglesOnly: WordBool
): WordBool

Описание параметров

Point1
[in] Первая точка отрезка
Point2
[in] Вторая точка отрезка
Triangles
[in, out] Коллекция, в которую будут помещены все найденные пересекаемые отрезком треугольники
VisibleTrianglesOnly
[in] Если True, то будут искаться только видимые треугольники

Возвращаемое значение

Возвращает True, если треугольники успешно найдены

Смотри также

Class Collection, Class ModelPoint, Class Triangulation, Group Триангуляция


Triangulation.FlipAtPoint (метод)

Выполнить переброску рёбер, если возможно в указанной точке триангуляции. Возвращает True, если переброска выполнена

Синтаксис

[Visual Basic 6]
Function FlipAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Precision As Double, _
   ByVal ImmediatelyFlip As Boolean _
) As TrnFlip

[Delphi]
function FlipAtPoint(
   const X: Double;
   const Y: Double;
   const Precision: Double;
   const ImmediatelyFlip: WordBool
): TrnFlip

Описание параметров

X
[in] Координата X точки на плоскости, в которой необходимо найти ребро триангуляции и выполнить его переброску
Y
[in] Координата Y точки на плоскости, в которой необходимо найти ребро триангуляции и выполнить его переброску
Precision
[in] Максимальный радиус поиска подходящих ребер триангуляции для переброски в указанной точке плоскости
ImmediatelyFlip
[in] Необходимо ли немедленно выполнить переброску

Возвращаемое значение

Возвращает новую переброску

Смотри также

Class Triangulation, Class TrnFlip, Group Триангуляция


Triangulation.GetObjectAtPoint (метод)

Получить объект в заданной позиции. Если там ничего нет, то возвращает Nothing

Синтаксис

[Visual Basic 6]
Function GetObjectAtPoint ( _
   ByVal Point As ModelPoint, _
   ByVal Delta As Double, _
   ByVal GetSources As Boolean, _
   ByVal GetBreaks As Boolean, _
   ByVal GetAreas As Boolean, _
   ByVal GetFlips As Boolean, _
   ByVal GetModifiers As Boolean, _
   ByVal GetNodes As Boolean, _
   ByVal GetRibs As Boolean, _
   ByVal GetTriangles As Boolean, _
   ByVal GetCutted As Boolean, _
   [ByVal Filter As ITrnFigureFilter = 0] _
) As TrnFigure

[Delphi]
function GetObjectAtPoint(
   const Point: ModelPoint;
   const Delta: Double;
   const GetSources: WordBool;
   const GetBreaks: WordBool;
   const GetAreas: WordBool;
   const GetFlips: WordBool;
   const GetModifiers: WordBool;
   const GetNodes: WordBool;
   const GetRibs: WordBool;
   const GetTriangles: WordBool;
   const GetCutted: WordBool;
   const Filter: ITrnFigureFilter
): TrnFigure

Описание параметров

Point
[in] Точка на плоскости, в которой нужно получить объект
Delta
[in] Максимальное отклонение от указанной точки, в пределах которого нужно искать объекты
GetSources
[in] Следует ли искать исходные точки
GetBreaks
[in] Следует ли искать структурные линии
GetAreas
[in] Следует ли искать регионы
GetFlips
[in] Следует ли искать переброски рёбер
GetModifiers
[in] Следует ли искать модификаторы
GetNodes
[in] Следует ли искать узлы триангуляции
GetRibs
[in] Следует ли искать жёсткие рёбра триангуляции
GetTriangles
[in] Следует ли искать треугольники триангуляции
GetCutted
[in] Следует ли искать в невидимой части триангуяции
Filter
[in] Дополнительный фильтр разыскиваемых объектов, реализуемый пользователем. Метод IsValidObject интерфейса ITrnFigureFilter должен вернуть True, если указанный в аргументах метода IsValidObject объект является допустимым

Возвращаемое значение

Возращает найденный объект в указанной позиции или Nothing, если ничего не найдено

Смотри также

Interface ITrnFigureFilter, Class ModelPoint, Class Triangulation, Class TrnFigure, Group Триангуляция


Triangulation.GetObjectsAtPoint (метод)

Получить все объекты в заданной позиции в виде коллекции объектов типа TrnFigure. Если там ничего нет, то возвращает Nothing

Синтаксис

[Visual Basic 6]
Sub GetObjectsAtPoint ( _
   ByVal Point As ModelPoint, _
   ByVal Delta As Double, _
   FoundObjects As Collection, _
   [ByVal GetSources As Boolean = True], _
   [ByVal GetBreaks As Boolean = False], _
   [ByVal GetAreas As Boolean = False], _
   [ByVal GetFlips As Boolean = False], _
   [ByVal GetModifiers As Boolean = False], _
   [ByVal GetNodes As Boolean = False], _
   [ByVal GetRibs As Boolean = False], _
   [ByVal GetTriangles As Boolean = False], _
   [ByVal GetCutted As Boolean = False], _
   [ByVal Filter As ITrnFigureFilter = 0] _
)

[Delphi]
procedure GetObjectsAtPoint(
   const Point: ModelPoint;
   const Delta: Double;
   var FoundObjects: Collection;
   const GetSources: WordBool;
   const GetBreaks: WordBool;
   const GetAreas: WordBool;
   const GetFlips: WordBool;
   const GetModifiers: WordBool;
   const GetNodes: WordBool;
   const GetRibs: WordBool;
   const GetTriangles: WordBool;
   const GetCutted: WordBool;
   const Filter: ITrnFigureFilter
)

Описание параметров

Point
[in] Точка на плоскости, в которой нужно получить объекты
Delta
[in] Максимальное отклонение от указанной точки, в пределах которого нужно искать объекты
FoundObjects
[in, out] Возращает коллекцию Collection со всеми найденными объектами TrnFigure в указанной позиции или Nothing, если ничего не найдено
GetSources
[in] Следует ли искать исходные точки
GetBreaks
[in] Следует ли искать структурные линии
GetAreas
[in] Следует ли искать регионы
GetFlips
[in] Следует ли искать переброски рёбер
GetModifiers
[in] Следует ли искать модификаторы
GetNodes
[in] Следует ли искать узлы триангуляции
GetRibs
[in] Следует ли искать жёсткие рёбра триангуляции
GetTriangles
[in] Следует ли искать треугольники триангуляции
GetCutted
[in] Следует ли искать в невидимой части триангуяции
Filter
[in] Дополнительный фильтр разыскиваемых объектов, реализуемый пользователем. Метод IsValidObject интерфейса ITrnFigureFilter должен вернуть True, если указанный в аргументах метода IsValidObject объект является допустимым

Смотри также

Class Collection, Interface ITrnFigureFilter, Class ModelPoint, Class Triangulation, Group Триангуляция


Triangulation.GetObjectsAtRect (метод)

Получить все объекты в заданном прямоугольнике в виде коллекции объектов типа TrnFigure. Если там ничего нет, то возвращает Nothing

Синтаксис

[Visual Basic 6]
Sub GetObjectsAtRect ( _
   ByVal Rect As ModelRect, _
   FoundObjects As Collection, _
   [ByVal GetSources As Boolean = True], _
   [ByVal GetBreaks As Boolean = False], _
   [ByVal GetAreas As Boolean = False], _
   [ByVal GetFlips As Boolean = False], _
   [ByVal GetModifiers As Boolean = False], _
   [ByVal GetNodes As Boolean = False], _
   [ByVal GetRibs As Boolean = False], _
   [ByVal GetTriangles As Boolean = False], _
   [ByVal GetCutted As Boolean = False], _
   [ByVal Filter As ITrnFigureFilter = 0] _
)

[Delphi]
procedure GetObjectsAtRect(
   const Rect: ModelRect;
   var FoundObjects: Collection;
   const GetSources: WordBool;
   const GetBreaks: WordBool;
   const GetAreas: WordBool;
   const GetFlips: WordBool;
   const GetModifiers: WordBool;
   const GetNodes: WordBool;
   const GetRibs: WordBool;
   const GetTriangles: WordBool;
   const GetCutted: WordBool;
   const Filter: ITrnFigureFilter
)

Описание параметров

Rect
[in] Прямоугольник на плоскости, в котором нужно получить объект
FoundObjects
[in, out] Возращает коллекцию Collection со всеми найденными объектами TrnFigure в указанном прямоугольнике или Nothing, если ничего не найдено
GetSources
[in] Следует ли искать исходные точки
GetBreaks
[in] Следует ли искать структурные линии
GetAreas
[in] Следует ли искать регионы
GetFlips
[in] Следует ли искать переброски рёбер
GetModifiers
[in] Следует ли искать модификаторы
GetNodes
[in] Следует ли искать узлы триангуляции
GetRibs
[in] Следует ли искать жёсткие рёбра триангуляции
GetTriangles
[in] Следует ли искать треугольники триангуляции
GetCutted
[in] Следует ли искать в невидимой части триангуяции
Filter
[in] Дополнительный фильтр разыскиваемых объектов, реализуемый пользователем. Метод IsValidObject интерфейса ITrnFigureFilter должен вернуть True, если указанный в аргументах метода IsValidObject объект является допустимым

Смотри также

Class Collection, Interface ITrnFigureFilter, Class ModelRect, Class Triangulation, Group Триангуляция


Triangulation.GetSoftRibAtPoint (метод)

Найти в указанной точке триангуляции ребро в виде пары смежных треугольников. В переменных RibIndex1/2 возвращаются номера ссылок на парный треугольник, в HardRib - жёсткое ребро, если оно существует

Синтаксис

[Visual Basic 6]
Sub GetSoftRibAtPoint ( _
   ByVal Point As ModelPoint, _
   ByVal Delta As Double, _
   Triangle1 As TrnTriangle, _
   Triangle2 As TrnTriangle, _
   RibIndex1 As Long, _
   RibIndex2 As Long, _
   HardRib As TrnRib _
)

[Delphi]
procedure GetSoftRibAtPoint(
   const Point: ModelPoint;
   const Delta: Double;
   out Triangle1: TrnTriangle;
   out Triangle2: TrnTriangle;
   out RibIndex1: Integer;
   out RibIndex2: Integer;
   out HardRib: TrnRib
)

Описание параметров

Point
[in] Точка на плоскости, в которой нужно получить ребро
Delta
[in] Максимальное отклонение от указанной точки, в пределах которого нужно искать ребро
Triangle1
[out] Первый треугольник, смежный с найденным ребром, или Nothing, если ребро не найдено
Triangle2
[out] Второй треугольник, смежный с найденным ребром, или Nothing, если ребро не найдено
RibIndex1
[out] Номер найденного ребра в первом треугольнике, или -1, если ребро не найдено
RibIndex2
[out] Номер найденного ребра во втором треугольнике, или -1, если ребро не найдено
HardRib
[out] Найденное жёсткое ребро или Nothing, если жёсткого ребра в данной позиции нет

Смотри также

Class ModelPoint, Class Triangulation, Class TrnRib, Class TrnTriangle, Group Триангуляция


Triangulation.HeightAtPoint (метод)

Вычисление высоты в заданной точке триангуляции

Синтаксис

[Visual Basic 6]
Function HeightAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   Height As Double, _
   [ByVal DefaultHeight As Double = 0] _
) As Boolean

[Delphi]
function HeightAtPoint(
   const X: Double;
   const Y: Double;
   out Height: Double;
   const DefaultHeight: Double
): WordBool

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо вычислить высоту
Y
[in] Координата Y точки плоскости, в которой необходимо вычислить высоту
Height
[out] Вычисленная высота
DefaultHeight
[in] Возвращаемое значение для случая, если указанная точка выйдет за видимую границу триангуляции

Возвращаемое значение

Возвращает True, если в указанной точке высота вычислена

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.IncrementalAddBoundary (метод)

Перестроить структуру триангуляции, вставив туда регион (границу триангуляции), заданный в виде последовательности точек. При этом в список Areas регион не добавляется

Синтаксис

[Visual Basic 6]
Sub IncrementalAddBoundary ( _
   ByVal Points As Collection _
)

[Delphi]
procedure IncrementalAddBoundary(
   const Points: Collection
)

Описание параметров

Points
[in] Коллекция точек типа ModelPoint, образующих контур полигона

Смотри также

Class Collection, Class Triangulation, Group Триангуляция


Triangulation.IncrementalAddBoundaryShape (метод)

Перестроить структуру триангуляции, вставив туда регион (границу триангуляции), заданный в виде полигона. При этом в список Areas регион не добавляется

Синтаксис

[Visual Basic 6]
Sub IncrementalAddBoundaryShape ( _
   ByVal Polygon As ShapePolygon _
)

[Delphi]
procedure IncrementalAddBoundaryShape(
   const Polygon: ShapePolygon
)

Описание параметров

Polygon
[in] Добавляемый полигон

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.Invalidate (метод)

Разорвать связь исходных данных с построенными структурами

Синтаксис

[Visual Basic 6]
Sub Invalidate

[Delphi]
procedure Invalidate

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.LoadFromFile (метод)

Загрузка триангуляции из файла

Синтаксис

[Visual Basic 6]
Sub LoadFromFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure LoadFromFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла, из которого необходимо загрузить триангуляцию

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.LoadFromStream (метод)

Загрузка триангуляции из файла потока

Синтаксис

[Visual Basic 6]
Sub LoadFromStream ( _
   ByVal IStream As IUnknown _
)

[Delphi]
procedure LoadFromStream(
   const IStream: IUnknown
)

Описание параметров

IStream
[in] Поток, из которого необходимо загрузить триангуляцию

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.MakeCopy (метод)

Создать копию триангуляции (можно без копирования исходных данных)

Синтаксис

[Visual Basic 6]
Function MakeCopy ( _
   [ByVal SaveMode As TrnSaveModeConstants = 0] _
) As Triangulation

[Delphi]
function MakeCopy(
   const SaveMode: TrnSaveModeConstants
): Triangulation

Описание параметров

SaveMode
[in] Режим копирования триангуляции

Возвращаемое значение

Возвращает копию триангуляции

Смотри также

Class Triangulation, Enum TrnSaveModeConstants, Group Триангуляция


Triangulation.NormalAtPoint (метод)

Вычисление интерполированного вектора нормали в заданной точке триангуляции

Синтаксис

[Visual Basic 6]
Function NormalAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   [ByVal WeightMode As TrnNodeWeightModeConstants = 0] _
) As Point3D

[Delphi]
function NormalAtPoint(
   const X: Double;
   const Y: Double;
   const WeightMode: TrnNodeWeightModeConstants
): Point3D

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо вычислить нормаль
Y
[in] Координата Y точки плоскости, в которой необходимо вычислить нормаль
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников

Возвращаемое значение

Возвращает нормаль в указанной точке плоскости или Nothing, если в данной точке триангуляция отсутствует

Смотри также

Class Point3D, Class Triangulation, Enum TrnNodeWeightModeConstants, Group Триангуляция


Triangulation.OptimizeFlips (метод)

По текущей триангуляции строит оптимальную структуру перебросок

Синтаксис

[Visual Basic 6]
Function OptimizeFlips As Boolean

[Delphi]
function OptimizeFlips: WordBool

Возвращаемое значение

Возвращает True, если оптимизация была успешно выполнена и дала эффект

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.PolygonSquare (метод)

Площадь полигона по поверхности видимой части триангуляции и в проекции

Синтаксис

[Visual Basic 6]
Sub PolygonSquare ( _
   ByVal Polygon As ShapePolygon, _
   FlatSquare As Double, _
   SpatialSquare As Double _
)

[Delphi]
procedure PolygonSquare(
   const Polygon: ShapePolygon;
   out FlatSquare: Double;
   out SpatialSquare: Double
)

Описание параметров

Polygon
[in] Полигон, в пределах которого необходимо вычислить площади
FlatSquare
[out] Вычисленная площадь поверхности в проекции в пределах полигона
SpatialSquare
[out] Вычисленная площадь поверхности в пределах полигона

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.PolygonsSquare (метод)

Площадь внутри списка полигонов по поверхности видимой части триангуляции и в проекции

Синтаксис

[Visual Basic 6]
Sub PolygonsSquare ( _
   ByVal Polygons As Collection, _
   FlatSquare As Double, _
   SpatialSquare As Double _
)

[Delphi]
procedure PolygonsSquare(
   const Polygons: Collection;
   out FlatSquare: Double;
   out SpatialSquare: Double
)

Описание параметров

Polygons
[in] Список полигонов PolygonShape, в пределах которых необходимо вычислить площади
FlatSquare
[out] Вычисленная площадь поверхности в проекции в пределах полигона
SpatialSquare
[out] Вычисленная площадь поверхности в пределах полигона

Смотри также

Class Collection, Class Triangulation, Group Триангуляция


Triangulation.RemoveSources (метод)

Удалить исходные данные

Синтаксис

[Visual Basic 6]
Sub RemoveSources

[Delphi]
procedure RemoveSources

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Reset (метод)

Удалить построенные структуры, оставить только исходные данные

Синтаксис

[Visual Basic 6]
Sub Reset

[Delphi]
procedure Reset

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.Save (метод)

Если FileName='', то запрашивается имя и вызывается SaveToFile(FileName)}

Синтаксис

[Visual Basic 6]
Sub Save

[Delphi]
procedure Save

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.SaveAsToFile (метод)

Сохранение в заданный файл

Синтаксис

[Visual Basic 6]
Sub SaveAsToFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveAsToFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла, в который необходимо выполнить сохранение триангуляции

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.SaveCopyTo (метод)

Сохранение копии в заданный файл

Синтаксис

[Visual Basic 6]
Sub SaveCopyTo ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveCopyTo(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла, в который необходимо выполнить сохранение копии триангуляции

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.SaveToFile (метод)

Сохранение триангуляции в заданный файл

Синтаксис

[Visual Basic 6]
Sub SaveToFile ( _
   ByVal FileName As String _
)

[Delphi]
procedure SaveToFile(
   const FileName: WideString
)

Описание параметров

FileName
[in] Имя файла, в который необходимо выполнить сохранение триангуляции

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.SaveToStream (метод)

Сохранение триангуляции в заданный поток

Синтаксис

[Visual Basic 6]
Sub SaveToStream ( _
   ByVal IStream As IUnknown, _
   [ByVal SaveMode As TrnSaveModeConstants = 0] _
)

[Delphi]
procedure SaveToStream(
   const IStream: IUnknown;
   const SaveMode: TrnSaveModeConstants
)

Описание параметров

IStream
[in] Поток, в который необходимо выполнить сохранение триангуляции
SaveMode
[in] Режим сохранения триангуляции

Смотри также

Class Triangulation, Enum TrnSaveModeConstants, Group Триангуляция


Triangulation.SetAllNodeTags (метод)

Выставить поля Tag для всех узлов триангуляции

Синтаксис

[Visual Basic 6]
Sub SetAllNodeTags ( _
   ByVal Tag As Long _
)

[Delphi]
procedure SetAllNodeTags(
   const Tag: Integer
)

Описание параметров

Tag
[in] Выставляемое значение Tag

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.SetAllTriangleTags (метод)

Выставить поля Tag для всех треугольников (можно только для всех видимых)

Синтаксис

[Visual Basic 6]
Sub SetAllTriangleTags ( _
   ByVal Tag As Long, _
   ByVal VisibleOnly As Boolean _
)

[Delphi]
procedure SetAllTriangleTags(
   const Tag: Integer;
   const VisibleOnly: WordBool
)

Описание параметров

Tag
[in] Выставляемое значение Tag
VisibleOnly
[in] Если True, то поле Tag будет изменено только для видимых треугольников

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.SlopeAtPoint (метод)

Вычисление уклона в заданной точке триангуляции

Синтаксис

[Visual Basic 6]
Function SlopeAtPoint ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal SlopeMode As SlopeModeConstants, _
   Slope As Double, _
   [ByVal WeightMode As TrnNodeWeightModeConstants = 0] _
) As Boolean

[Delphi]
function SlopeAtPoint(
   const X: Double;
   const Y: Double;
   const SlopeMode: SlopeModeConstants;
   out Slope: Double;
   const WeightMode: TrnNodeWeightModeConstants
): WordBool

Описание параметров

X
[in] Координата X точки плоскости, в которой необходимо вычислить уклон
Y
[in] Координата Y точки плоскости, в которой необходимо вычислить уклон
SlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле
Slope
[out] Вычисленный уклон
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников

Возвращаемое значение

Возвращает True, если в указанной точке уклон вычислен

Смотри также

Enum SlopeModeConstants, Class Triangulation, Enum TrnNodeWeightModeConstants, Group Триангуляция


Triangulation.SurfaceDifference (метод)

Вычислить поверхность, полученную вычитанием другой поверхности из исходной

Синтаксис

[Visual Basic 6]
Function SurfaceDifference ( _
   ByVal LevelingTriangulation As Triangulation, _
   [ByVal RegionOfInterest As ShapePolygon = 0] _
) As Triangulation

[Delphi]
function SurfaceDifference(
   const LevelingTriangulation: Triangulation;
   const RegionOfInterest: ShapePolygon
): Triangulation

Описание параметров

LevelingTriangulation
[in] Вторая (выравнивающая) триангуляция
RegionOfInterest
[in] Регион, внутри которого нужно расчитать разность или Nothing, если нужно считать везде

Возвращаемое значение

Возвращает новую поверхность, являющуюся разностью исходной и второй заданной триангуляции

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.SurfaceEarthVolume (метод)

Расчёт объёма земляных работ при выравнивании всей видимой части триангуляции до другой триангуляции. Возвращает также регион, внутри которого выполнены измерения.

Синтаксис

[Visual Basic 6]
Sub SurfaceEarthVolume ( _
   ByVal LevelingTriangulation As Triangulation, _
   ByVal RegionOfInterest As ShapePolygon, _
   BelowVolume As Double, _
   BelowSquare As Double, _
   AboveVolume As Double, _
   AboveSquare As Double, _
   RegionTotal As ShapePolygon, _
   RegionBelow As ShapePolygon, _
   RegionAbove As ShapePolygon _
)

[Delphi]
procedure SurfaceEarthVolume(
   const LevelingTriangulation: Triangulation;
   const RegionOfInterest: ShapePolygon;
   out BelowVolume: Double;
   out BelowSquare: Double;
   out AboveVolume: Double;
   out AboveSquare: Double;
   out RegionTotal: ShapePolygon;
   out RegionBelow: ShapePolygon;
   out RegionAbove: ShapePolygon
)

Описание параметров

LevelingTriangulation
[in] Вторая (выравнивающая) триангуляция
RegionOfInterest
[in] Регион, внутри которого нужно расчитать разность или Nothing, если нужно считать везде
BelowVolume
[out] Вычисленный объём ниже выравнивающей триангуляции
BelowSquare
[out] Вычисленная площадь территории, в пределах которой поверхность ниже выравнивающей триангуляции
AboveVolume
[out] Вычисленный объём выше выравнивающей триангуляции
AboveSquare
[out] Вычисленная площадь территории, в пределах которой поверхность выше выравнивающей триангуляции
RegionTotal
[out] Возвращает регион, в пределах которого произведены вычисления
RegionBelow
[out] Возвращает регион, в пределах которого вторая триангуляция ниже исходной
RegionAbove
[out] Возвращает регион, в пределах которого вторая триангуляция выше исходной

Смотри также

Class ShapePolygon, Class Triangulation, Group Триангуляция


Triangulation.Thicken (метод)

Выполнить сгущение триангуляции до заданной точности представления поверхности или до максимального числа узлов триангуляции

Синтаксис

[Visual Basic 6]
Function Thicken ( _
   ByVal HeightPrecision As Double, _
   ByVal MinRibLength As Double, _
   [ByVal MaxNodeCount As Long = 100000], _
   [ByVal MaxIterations As Long = 10], _
   [ByVal WeightMode As TrnNodeWeightModeConstants = 0], _
   [ByVal Tension As Double = 1] _
) As Point3D

[Delphi]
function Thicken(
   const HeightPrecision: Double;
   const MinRibLength: Double;
   const MaxNodeCount: Integer;
   const MaxIterations: Integer;
   const WeightMode: TrnNodeWeightModeConstants;
   const Tension: Double
): Point3D

Описание параметров

HeightPrecision
[in] Величина отклонения новых треугольников от старых, когда дальнейшее дробление треугольников на части не имеет смысла
MinRibLength
[in] Минимальная длина ребёр, которые будут разбиваться на части
MaxNodeCount
[in] Максимально допустимое количество узлов в триангуляции
MaxIterations
[in] Максиальное количество итераций
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников
Tension
[in] Степень натяжения сплайна, используемого для интерполяции

Возвращаемое значение

Возвращает трёхмерный вектор нормали к указанному узлу

Смотри также

Class Point3D, Class Triangulation, Enum TrnNodeWeightModeConstants, Group Триангуляция


Triangulation.TrnToBreakLines (метод)

Преобразовать текущую структуру триангуляции в структурные линии

Синтаксис

[Visual Basic 6]
Sub TrnToBreakLines ( _
   [ByVal VisibleOnly As Boolean = False] _
)

[Delphi]
procedure TrnToBreakLines(
   const VisibleOnly: WordBool
)

Описание параметров

VisibleOnly
[in] Если True, то преобразовывать только видимую часть триангуляции

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.TrnToSources (метод)

Преобразовать текущую структуру триангуляции в исходные точки, структурные линии и регионы

Синтаксис

[Visual Basic 6]
Sub TrnToSources

[Delphi]
procedure TrnToSources

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.ValidateLevels (метод)

Отсортировать список уровней и удалить лишние уровни (которые выше или ниже всей триангуляции)

Синтаксис

[Visual Basic 6]
Sub ValidateLevels ( _
   ByVal Levels As DoubleCollection, _
   [ByVal MinMaxCheck As Boolean = True] _
)

[Delphi]
procedure ValidateLevels(
   const Levels: DoubleCollection;
   const MinMaxCheck: WordBool
)

Описание параметров

Levels
[in] Коллекция DoubleCollection уровней
MinMaxCheck
[in] Следует ли проверять уровни на выход за минимальный и максимальный уровень высот, имеющийся сейчас в триангуляции

Смотри также

Class DoubleCollection, Class Triangulation, Group Триангуляция


Triangulation.Verify (метод)

Проверить структуру триангуляции - для отладки

Синтаксис

[Visual Basic 6]
Sub Verify

[Delphi]
procedure Verify

Смотри также

Class Triangulation, Group Триангуляция


Triangulation.ZeroEarthVolumes (метод)

Расчёт объёмов земляных работ при выравнивании всей видимой триангуляции до уровня ZeroLevel, причём объёмы вычисляются отдельно для каждого интервала уровней высот. Всегда в массив интервалов заносится ZeroLevel. Размер выходного массива на 1 > входного.

Синтаксис

[Visual Basic 6]
Sub ZeroEarthVolumes ( _
   ByVal ZeroLevel As Double, _
   ByVal Levels As DoubleCollection, _
   Volumes As DoubleCollection, _
   Squares As DoubleCollection, _
   [ByVal CoveringVolumeType As VolumeTypeConstants = 0], _
   [ByVal ClippingVolumeType As VolumeTypeConstants = 0] _
)

[Delphi]
procedure ZeroEarthVolumes(
   const ZeroLevel: Double;
   const Levels: DoubleCollection;
   var Volumes: DoubleCollection;
   var Squares: DoubleCollection;
   const CoveringVolumeType: VolumeTypeConstants;
   const ClippingVolumeType: VolumeTypeConstants
)

Описание параметров

ZeroLevel
[in] Эталонный (нулевой) уровень выравнивания
Levels
[in] Уровни, по которым нужно отдельно расчитать объёмы работ. При этом по выходу из этой процедуры в этом аргументе будут лежать отсортированный список уровней (включая ZeroLevel) без дубликатов, реально использованный в расчётах
Volumes
[in, out] Вычисленные объёмы по каждому промежутку между значениями Levels
Squares
[in, out] Вычисленные площади по каждому промежутку между значениями Levels
CoveringVolumeType
[in] Интерпретация объёмов засыпки задается в параметрах CoveringVolumeType
ClippingVolumeType
[in] Интерпретация объёмов срезки задается в параметрах ClippingVolumeType

Смотри также

Class DoubleCollection, Class Triangulation, Enum VolumeTypeConstants, Group Триангуляция


Класс TrnArea

Регион триагуляции

Наследование

Figure Class TrnArea

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Color | Цвет, присваеваемый треугольникам внутри данного региона (по умолчанию - clNone=&h1FFFFFFF, т.е. не присваивается)
Property CommonZ | Общее значение высоты (только для Kind=takEqualZ)
Property CutTriangles | Разрезать ли существующие треугольники триангуляции при вставке данной структурной линии (иначе треугольники будут перестраиваться в длинные и узкие)
Property ID | Исходно заданый код, может использоваться для привязки атрибутики
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Kind | Интерпретация в модели поверхности
Property NoIsolines | Признак того, что внутри данного региона построение изолиний производить не надо
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PartCounts | Число точек, составляющих контуры региона
Property PartNumber | Количество контуров в регионе
Property Points | Массив точек, составляющих линию
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Smooth | Сохраняется ли гладкость поверхности на границе региона
Property Tag | Поле для свободного использования
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Property Areas (свойство) Method AddPolygon (метод) Method AddPolygonShape (метод)
Class Triangulation | Property Areas (свойство) Method AddPolygon (метод) Method AddPolygonShape (метод)
Class TrnTriangle | Property Areas (свойство)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class Point3D, Enum TrnAreaConstants, Enum TrnFigureKindConstants, Group Триангуляция


TrnArea.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnArea, Group Триангуляция


TrnArea.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Color (свойство)

Цвет, присваеваемый треугольникам внутри данного региона (по умолчанию - clNone=&h1FFFFFFF, т.е. не присваивается)

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.CommonZ (свойство)

Общее значение высоты (только для Kind=takEqualZ)

Синтаксис

[Visual Basic 6]
Property CommonZ As Double

[Delphi]
property CommonZ: Double

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.CutTriangles (свойство)

Разрезать ли существующие треугольники триангуляции при вставке данной структурной линии (иначе треугольники будут перестраиваться в длинные и узкие)

Синтаксис

[Visual Basic 6]
Property CutTriangles As Boolean

[Delphi]
property CutTriangles: WordBool

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.ID (свойство)

Исходно заданый код, может использоваться для привязки атрибутики

Синтаксис

[Visual Basic 6]
Property ID As Long

[Delphi]
property ID: Integer

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Kind (свойство)

Интерпретация в модели поверхности

Синтаксис

[Visual Basic 6]
Property Kind As TrnAreaConstants

[Delphi]
property Kind: TrnAreaConstants

Смотри также

Class TrnArea, Enum TrnAreaConstants, Group Триангуляция


TrnArea.NoIsolines (свойство)

Признак того, что внутри данного региона построение изолиний производить не надо

Синтаксис

[Visual Basic 6]
Property NoIsolines As Boolean

[Delphi]
property NoIsolines: WordBool

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Class TrnArea, Enum TrnFigureKindConstants, Group Триангуляция


TrnArea.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnArea, Group Триангуляция


TrnArea.PartCounts (свойство)

Число точек, составляющих контуры региона

Синтаксис

[Visual Basic 6]
Property PartCounts As Long

[Delphi]
property PartCounts: Integer

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.PartNumber (свойство)

Количество контуров в регионе

Синтаксис

[Visual Basic 6]
Property PartNumber As Long

[Delphi]
property PartNumber: Integer

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Points (свойство)

Массив точек, составляющих линию

Синтаксис

[Visual Basic 6]
Property Points As Point3D

[Delphi]
property Points: Point3D

Смотри также

Class Point3D, Class TrnArea, Group Триангуляция


TrnArea.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Smooth (свойство)

Сохраняется ли гладкость поверхности на границе региона

Синтаксис

[Visual Basic 6]
Property Smooth As Boolean

[Delphi]
property Smooth: WordBool

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnArea, Group Триангуляция


TrnArea.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnArea, Group Триангуляция


TrnArea.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnArea, Group Триангуляция


TrnArea.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnArea, Group Триангуляция


TrnArea.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnArea, Group Триангуляция


TrnArea.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnArea, Group Триангуляция


TrnArea.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnArea, Group Триангуляция


TrnArea.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnArea, Group Триангуляция


TrnArea.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnArea, Group Триангуляция


Класс TrnBreak

Структурная линия триангуляции

Наследование

Figure Class TrnBreak

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property CutTriangles | Разрезать ли существующие треугольники триангуляции при вставке данной структурной линии (иначе треугольники будут перестраиваться в длинные и узкие)
Property ID | Исходно заданый код, может использоваться для привязки атрибутики
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PointNumber | Число точек, составляющих линию
Property Points | Массив точек, составляющих линию
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Smooth | Сохраняется ли гладкость поверхности на структурной линии
Property Tag | Поле для свободного использования
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура
Property WithoutZ | Высоты Z для точек линии не задается, а аппроксимируются по другим точкам триангуляции

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием
Method Validate | Удаляет пустые точки и нулевые отрезки

Где используется

Класс | Член класса
Class CADTriangulation | Property Breaks (свойство) Method AddPolyline (метод) Method AddPolylineShape (метод)
Class Triangulation | Property Breaks (свойство) Method AddPolyline (метод) Method AddPolylineShape (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class Point3D, Enum TrnFigureKindConstants, Group Триангуляция


TrnBreak.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnBreak, Group Триангуляция


TrnBreak.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.CutTriangles (свойство)

Разрезать ли существующие треугольники триангуляции при вставке данной структурной линии (иначе треугольники будут перестраиваться в длинные и узкие)

Синтаксис

[Visual Basic 6]
Property CutTriangles As Boolean

[Delphi]
property CutTriangles: WordBool

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.ID (свойство)

Исходно заданый код, может использоваться для привязки атрибутики

Синтаксис

[Visual Basic 6]
Property ID As Long

[Delphi]
property ID: Integer

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Class TrnBreak, Enum TrnFigureKindConstants, Group Триангуляция


TrnBreak.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnBreak, Group Триангуляция


TrnBreak.PointNumber (свойство)

Число точек, составляющих линию

Синтаксис

[Visual Basic 6]
Property PointNumber As Long

[Delphi]
property PointNumber: Integer

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.Points (свойство)

Массив точек, составляющих линию

Синтаксис

[Visual Basic 6]
Property Points As Point3D

[Delphi]
property Points: Point3D

Смотри также

Class Point3D, Class TrnBreak, Group Триангуляция


TrnBreak.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.Smooth (свойство)

Сохраняется ли гладкость поверхности на структурной линии

Синтаксис

[Visual Basic 6]
Property Smooth As Boolean

[Delphi]
property Smooth: WordBool

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnBreak, Group Триангуляция


TrnBreak.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.WithoutZ (свойство)

Высоты Z для точек линии не задается, а аппроксимируются по другим точкам триангуляции

Синтаксис

[Visual Basic 6]
Property WithoutZ As Boolean

[Delphi]
property WithoutZ: WordBool

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnBreak, Group Триангуляция


TrnBreak.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnBreak, Group Триангуляция


TrnBreak.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnBreak, Group Триангуляция


TrnBreak.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnBreak, Group Триангуляция


TrnBreak.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnBreak, Group Триангуляция


TrnBreak.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnBreak, Group Триангуляция


TrnBreak.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnBreak, Group Триангуляция


TrnBreak.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnBreak, Group Триангуляция


TrnBreak.Validate (метод)

Удаляет пустые точки и нулевые отрезки

Синтаксис

[Visual Basic 6]
Sub Validate

[Delphi]
procedure Validate

Смотри также

Class TrnBreak, Group Триангуляция


Класс TrnFigure

Исходная точка для построения триангуляции

Наследование

Figure Class TrnFigure Class TrnArea, TrnBreak, TrnFlip, TrnModifier, TrnNode, TrnRib, TrnSource, TrnTriangle

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Tag | Поле для свободного использования
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Method GetObjectAtPoint (метод)
Class ITrnFigureFilter | Method IsValidObject (метод)
Class Triangulation | Method GetObjectAtPoint (метод)
Class TrnRib | Property Structs (свойство)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Enum TrnFigureKindConstants, Group Триангуляция


TrnFigure.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnFigure, Group Триангуляция


TrnFigure.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Class TrnFigure, Enum TrnFigureKindConstants, Group Триангуляция


TrnFigure.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnFigure, Group Триангуляция


TrnFigure.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnFigure, Group Триангуляция


TrnFigure.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnFigure, Group Триангуляция


TrnFigure.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnFigure, Group Триангуляция


TrnFigure.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnFigure, Group Триангуляция


TrnFigure.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnFigure, Group Триангуляция


TrnFigure.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnFigure, Group Триангуляция


TrnFigure.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnFigure, Group Триангуляция


TrnFigure.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnFigure, Group Триангуляция


TrnFigure.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnFigure, Group Триангуляция


Класс TrnFlip

Дополнительная переброска рёбер триангуляции

Наследование

Figure Class TrnFlip

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Applied (только для чтения) | Выставляется в True после построения триангуляции, если переброска была применена
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property Points | Массив точек четырёхугольника для переброски ребра из Points[0-2] в ребро Points[1-3]
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Tag | Поле для свободного использования
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Property Flips (свойство) Method FlipAtPoint (метод)
Class Triangulation | Property Flips (свойство) Method FlipAtPoint (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Enum TrnFigureKindConstants, Group Триангуляция


TrnFlip.Applied (свойство)

Выставляется в True после построения триангуляции, если переброска была применена

Синтаксис

[Visual Basic 6]
ReadOnly Property Applied As Boolean

[Delphi]
{только для чтения} property Applied: WordBool

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnFlip, Group Триангуляция


TrnFlip.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Enum TrnFigureKindConstants, Class TrnFlip, Group Триангуляция


TrnFlip.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnFlip, Group Триангуляция


TrnFlip.Points (свойство)

Массив точек четырёхугольника для переброски ребра из Points[0-2] в ребро Points[1-3]

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class TrnFlip, Group Триангуляция


TrnFlip.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnFlip, Group Триангуляция


TrnFlip.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnFlip, Group Триангуляция


TrnFlip.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnFlip, Group Триангуляция


TrnFlip.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnFlip, Group Триангуляция


TrnFlip.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnFlip, Group Триангуляция


TrnFlip.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnFlip, Group Триангуляция


TrnFlip.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnFlip, Group Триангуляция


TrnFlip.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnFlip, Group Триангуляция


TrnFlip.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnFlip, Group Триангуляция


Класс TrnModifier

Красящие и отсекающие линии триангуляции

Наследование

Figure Class TrnModifier

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Color | Цвет, присваеваемый всем треугольникам, пересекаемым данной линией (по умолчанию - clBlack)
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Kind | Тип модификатора
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property PointCount | Количество точек в линии
Property Points | Массив точек
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Tag | Поле для свободного использования
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием
Method Validate | Удаляет пустые точки и нулевые отрезки

Где используется

Класс | Член класса
Class CADTriangulation | Property Modifiers (свойство) Method AddModifier (метод) Method AddModifierShape (метод)
Class Triangulation | Property Modifiers (свойство) Method AddModifier (метод) Method AddModifierShape (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Enum TrnFigureKindConstants, Enum TrnModifierKindConstants, Group Триангуляция


TrnModifier.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnModifier, Group Триангуляция


TrnModifier.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Color (свойство)

Цвет, присваеваемый всем треугольникам, пересекаемым данной линией (по умолчанию - clBlack)

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Kind (свойство)

Тип модификатора

Синтаксис

[Visual Basic 6]
Property Kind As TrnModifierKindConstants

[Delphi]
property Kind: TrnModifierKindConstants

Смотри также

Class TrnModifier, Enum TrnModifierKindConstants, Group Триангуляция


TrnModifier.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Enum TrnFigureKindConstants, Class TrnModifier, Group Триангуляция


TrnModifier.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnModifier, Group Триангуляция


TrnModifier.PointCount (свойство)

Количество точек в линии

Синтаксис

[Visual Basic 6]
Property PointCount As Long

[Delphi]
property PointCount: Integer

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Points (свойство)

Массив точек

Синтаксис

[Visual Basic 6]
Property Points As ModelPoint

[Delphi]
property Points: ModelPoint

Смотри также

Class ModelPoint, Class TrnModifier, Group Триангуляция


TrnModifier.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnModifier, Group Триангуляция


TrnModifier.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnModifier, Group Триангуляция


TrnModifier.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnModifier, Group Триангуляция


TrnModifier.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnModifier, Group Триангуляция


TrnModifier.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnModifier, Group Триангуляция


TrnModifier.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnModifier, Group Триангуляция


TrnModifier.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnModifier, Group Триангуляция


TrnModifier.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnModifier, Group Триангуляция


TrnModifier.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnModifier, Group Триангуляция


TrnModifier.Validate (метод)

Удаляет пустые точки и нулевые отрезки

Синтаксис

[Visual Basic 6]
Sub Validate

[Delphi]
procedure Validate

Смотри также

Class TrnModifier, Group Триангуляция


Класс TrnNode

Узел триангуляции

Наследование

Figure Class TrnNode

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Duplicate (только для чтения) | Указатель на точку - дубликат данной, либо Nothing
Property ID | Исходно заданый в TrnSource код Id (может использоваться для привязки атрибутики)
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Kind (только для чтения) | Тип узла
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property Position (только для чтения) | Положение точки
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Tag | Поле для свободного использования
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура
Property X (только для чтения) | Координата X точки
Property Y (только для чтения) | Координата Y точки
Property Z (только для чтения) | Координата Z точки

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method EnumerateNodes | Получить все узлы, которые смежны с заданным узлом. Все найденные узлы выдаются в EnumerateNodes.Register
Method EnumerateRibs | Получить все жёсткие рёбра, которые смежны с данным узлом. Все найденные ребра выдаются в EnumerateRibs.Register
Method EnumerateTriangles | Получить все треугольники, которые смежны с заданным узлом. Все найденные треугольники выдаются в EnumerateTriangles.Register
Method FindNodes | Получить все узлы, которые смежны с заданным узлом. Все найденные узлы выдаются в коллекцию Nodes
Method FindRibs | Получить все жёсткие рёбра, которые смежны с данным узлом. Все найденные ребра выдаются в коллекцию Ribs
Method FindTriangles | Получить все треугольники, которые смежны с заданным узлом. Все найденные треугольники выдаются в коллекцию Triangles
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Property Nodes (свойство) Method FindNode (метод)
Class IEnumerateNodes | Method Register (метод)
Class Triangulation | Property Nodes (свойство) Method FindNode (метод)
Class TrnNode | Property Duplicate (свойство)
Class TrnRib | Property Nodes (свойство)
Class TrnTriangle | Property Nodes (свойство)

Смотри также

Enum AdjustPointConstants, Class Collection, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Interface IEnumerateRibs, Interface IEnumerateTriangles, Class ModelPoint, Class ModelRect, Class Point3D, Enum TrnFigureKindConstants, Enum TrnNodeConstants, Group Триангуляция


TrnNode.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnNode, Group Триангуляция


TrnNode.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Duplicate (свойство)

Указатель на точку - дубликат данной, либо Nothing

Синтаксис

[Visual Basic 6]
ReadOnly Property Duplicate As TrnNode

[Delphi]
{только для чтения} property Duplicate: TrnNode

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.ID (свойство)

Исходно заданый в TrnSource код Id (может использоваться для привязки атрибутики)

Синтаксис

[Visual Basic 6]
Property ID As Long

[Delphi]
property ID: Integer

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Kind (свойство)

Тип узла

Синтаксис

[Visual Basic 6]
ReadOnly Property Kind As TrnNodeConstants

[Delphi]
{только для чтения} property Kind: TrnNodeConstants

Смотри также

Class TrnNode, Enum TrnNodeConstants, Group Триангуляция


TrnNode.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Enum TrnFigureKindConstants, Class TrnNode, Group Триангуляция


TrnNode.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnNode, Group Триангуляция


TrnNode.Position (свойство)

Положение точки

Синтаксис

[Visual Basic 6]
ReadOnly Property Position As Point3D

[Delphi]
{только для чтения} property Position: Point3D

Смотри также

Class Point3D, Class TrnNode, Group Триангуляция


TrnNode.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnNode, Group Триангуляция


TrnNode.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
ReadOnly Property X As Double

[Delphi]
{только для чтения} property X: Double

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
ReadOnly Property Y As Double

[Delphi]
{только для чтения} property Y: Double

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Z (свойство)

Координата Z точки

Синтаксис

[Visual Basic 6]
ReadOnly Property Z As Double

[Delphi]
{только для чтения} property Z: Double

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnNode, Group Триангуляция


TrnNode.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnNode, Group Триангуляция


TrnNode.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnNode, Group Триангуляция


TrnNode.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.EnumerateNodes (метод)

Получить все узлы, которые смежны с заданным узлом. Все найденные узлы выдаются в EnumerateNodes.Register

Синтаксис

[Visual Basic 6]
Function EnumerateNodes ( _
   ByVal EnumerateNodesInterface As IEnumerateNodes _
) As Boolean

[Delphi]
function EnumerateNodes(
   const EnumerateNodesInterface: IEnumerateNodes
): WordBool

Описание параметров

EnumerateNodesInterface
[in] Интерфейс, у которого будет вызван метод Register, в который будут переданы все найденные узлы

Возвращаемое значение

Возвращает True, если узлы успешно перечислены

Смотри также

Interface IEnumerateNodes, Class TrnNode, Group Триангуляция


TrnNode.EnumerateRibs (метод)

Получить все жёсткие рёбра, которые смежны с данным узлом. Все найденные ребра выдаются в EnumerateRibs.Register

Синтаксис

[Visual Basic 6]
Function EnumerateRibs ( _
   ByVal EnumerateRibsInterface As IEnumerateRibs _
) As Boolean

[Delphi]
function EnumerateRibs(
   const EnumerateRibsInterface: IEnumerateRibs
): WordBool

Описание параметров

EnumerateRibsInterface
[in] Интерфейс, у которого будет вызван метод Register, в который будут переданы все найденные рёбра

Возвращаемое значение

Возвращает True, если ребра успешно перечислены

Смотри также

Interface IEnumerateRibs, Class TrnNode, Group Триангуляция


TrnNode.EnumerateTriangles (метод)

Получить все треугольники, которые смежны с заданным узлом. Все найденные треугольники выдаются в EnumerateTriangles.Register

Синтаксис

[Visual Basic 6]
Function EnumerateTriangles ( _
   ByVal EnumerateTrianglesInterface As IEnumerateTriangles _
) As Boolean

[Delphi]
function EnumerateTriangles(
   const EnumerateTrianglesInterface: IEnumerateTriangles
): WordBool

Описание параметров

EnumerateTrianglesInterface
[in] Интерфейс, у которого будет вызван метод Register, в который будут переданы все найденные треугольники

Возвращаемое значение

Возвращает True, если треугольники успешно перечислены

Смотри также

Interface IEnumerateTriangles, Class TrnNode, Group Триангуляция


TrnNode.FindNodes (метод)

Получить все узлы, которые смежны с заданным узлом. Все найденные узлы выдаются в коллекцию Nodes

Синтаксис

[Visual Basic 6]
Function FindNodes ( _
   Nodes As Collection _
) As Boolean

[Delphi]
function FindNodes(
   var Nodes: Collection
): WordBool

Описание параметров

Nodes
[in, out] Коллекция, в которую будут переданы все найденные узлы

Возвращаемое значение

Возвращает True, если узлы успешно перечислены

Смотри также

Class Collection, Class TrnNode, Group Триангуляция


TrnNode.FindRibs (метод)

Получить все жёсткие рёбра, которые смежны с данным узлом. Все найденные ребра выдаются в коллекцию Ribs

Синтаксис

[Visual Basic 6]
Function FindRibs ( _
   Ribs As Collection _
) As Boolean

[Delphi]
function FindRibs(
   var Ribs: Collection
): WordBool

Описание параметров

Ribs
[in, out] Коллекция, в которую будут переданы все найденные рёбра

Возвращаемое значение

Возвращает True, если ребра успешно перечислены

Смотри также

Class Collection, Class TrnNode, Group Триангуляция


TrnNode.FindTriangles (метод)

Получить все треугольники, которые смежны с заданным узлом. Все найденные треугольники выдаются в коллекцию Triangles

Синтаксис

[Visual Basic 6]
Function FindTriangles ( _
   Triangles As Collection _
) As Boolean

[Delphi]
function FindTriangles(
   var Triangles: Collection
): WordBool

Описание параметров

Triangles
[in, out] Коллекция, в которую будут переданы все найденные треугольники

Возвращаемое значение

Возвращает True, если треугольники успешно найдены

Смотри также

Class Collection, Class TrnNode, Group Триангуляция


TrnNode.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnNode, Group Триангуляция


TrnNode.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnNode, Group Триангуляция


TrnNode.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnNode, Group Триангуляция


TrnNode.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnNode, Group Триангуляция


TrnNode.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnNode, Group Триангуляция


Класс TrnRib

Структурное неперестраиваемое ребро триангуляции

Наследование

Figure Class TrnRib

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Cutted | Ребро невидимо из-за внешнего или внутреннего отсечения
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Nodes (только для чтения) | Соединяемые точки триангуляции
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Smooth | Сохраняется ли гладкость поверхности на ребре
Property StructCount (только для чтения) | Количество структурных линий и регионов, проходящих через ребро
Property Structs (только для чтения) | Массив структурных линий и регионов, проходящих через ребро
Property Tag | Поле для свободного использования
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Property Ribs (свойство) Method GetSoftRibAtPoint (метод)
Class IEnumerateRibs | Method Register (метод)
Class Triangulation | Property Ribs (свойство) Method GetSoftRibAtPoint (метод)
Class TrnTriangle | Property Ribs (свойство)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class TrnFigure, Enum TrnFigureKindConstants, Class TrnNode, Group Триангуляция


TrnRib.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnRib, Group Триангуляция


TrnRib.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Cutted (свойство)

Ребро невидимо из-за внешнего или внутреннего отсечения

Синтаксис

[Visual Basic 6]
Property Cutted As Boolean

[Delphi]
property Cutted: WordBool

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Nodes (свойство)

Соединяемые точки триангуляции

Синтаксис

[Visual Basic 6]
ReadOnly Property Nodes As TrnNode

[Delphi]
{только для чтения} property Nodes: TrnNode

Смотри также

Class TrnNode, Class TrnRib, Group Триангуляция


TrnRib.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Enum TrnFigureKindConstants, Class TrnRib, Group Триангуляция


TrnRib.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnRib, Group Триангуляция


TrnRib.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Smooth (свойство)

Сохраняется ли гладкость поверхности на ребре

Синтаксис

[Visual Basic 6]
Property Smooth As Boolean

[Delphi]
property Smooth: WordBool

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.StructCount (свойство)

Количество структурных линий и регионов, проходящих через ребро

Синтаксис

[Visual Basic 6]
ReadOnly Property StructCount As Long

[Delphi]
{только для чтения} property StructCount: Integer

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Structs (свойство)

Массив структурных линий и регионов, проходящих через ребро

Синтаксис

[Visual Basic 6]
ReadOnly Property Structs As TrnFigure

[Delphi]
{только для чтения} property Structs: TrnFigure

Смотри также

Class TrnFigure, Class TrnRib, Group Триангуляция


TrnRib.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnRib, Group Триангуляция


TrnRib.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnRib, Group Триангуляция


TrnRib.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnRib, Group Триангуляция


TrnRib.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnRib, Group Триангуляция


TrnRib.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnRib, Group Триангуляция


TrnRib.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnRib, Group Триангуляция


TrnRib.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnRib, Group Триангуляция


TrnRib.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnRib, Group Триангуляция


TrnRib.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnRib, Group Триангуляция


Класс TrnSource

Исходная точка для построения триангуляции

Наследование

Figure Class TrnSource

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property ID | Исходно заданый код, может использоваться для привязки атрибутики
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property Position | Координаты точки
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Selected | Выделена ли фигура
Property Tag | Поле для свободного использования
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура
Property WithoutZ | Признак того, что координата Z не задана, а должна быть интерполирована по другим точкам триангуляции в процессе построения
Property X | Координата X точки
Property Y | Координата Y точки
Property Z | Высота Z точки

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Property Sources (свойство) Method AddSource (метод)
Class Triangulation | Property Sources (свойство) Method AddSource (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class Point3D, Enum TrnFigureKindConstants, Group Триангуляция


TrnSource.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnSource, Group Триангуляция


TrnSource.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.ID (свойство)

Исходно заданый код, может использоваться для привязки атрибутики

Синтаксис

[Visual Basic 6]
Property ID As Long

[Delphi]
property ID: Integer

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Enum TrnFigureKindConstants, Class TrnSource, Group Триангуляция


TrnSource.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnSource, Group Триангуляция


TrnSource.Position (свойство)

Координаты точки

Синтаксис

[Visual Basic 6]
Property Position As Point3D

[Delphi]
property Position: Point3D

Смотри также

Class Point3D, Class TrnSource, Group Триангуляция


TrnSource.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnSource, Group Триангуляция


TrnSource.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.WithoutZ (свойство)

Признак того, что координата Z не задана, а должна быть интерполирована по другим точкам триангуляции в процессе построения

Синтаксис

[Visual Basic 6]
Property WithoutZ As Boolean

[Delphi]
property WithoutZ: WordBool

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.Z (свойство)

Высота Z точки

Синтаксис

[Visual Basic 6]
Property Z As Double

[Delphi]
property Z: Double

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnSource, Group Триангуляция


TrnSource.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnSource, Group Триангуляция


TrnSource.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnSource, Group Триангуляция


TrnSource.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnSource, Group Триангуляция


TrnSource.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnSource, Group Триангуляция


TrnSource.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnSource, Group Триангуляция


TrnSource.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnSource, Group Триангуляция


TrnSource.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnSource, Group Триангуляция


Класс TrnTools

Объект для выполнения различных высокоуровневых операций с помощью триангуляции

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.TrnTools

ClassID = {6013002A-170B-11D7-A13A-0050BF5A903A}

Методы класса

Имя | Описание
Method BuildAccesibilyAreas | Построение зон достижимости к точкам Points с заданными весами PointWeights
Method BuildVoronoiAreas | Построение диаграмм Вороного - множеств ближайших точек к заданным точкам Points
Method MakeBufferAreas | Построить буферные зоны для заданных точечных, линейных или площадных фигур
Method MergePolygons | Объединение всех смежных полигонов
Method SplitStripPicket | Построение попикетажного разбиения полосовой области вдоль некоторой линии

Смотри также

Class Collection, Class DoubleCollection, Class IntegerCollection, Class ShapePolygon, Class ShapePolyline, Group Триангуляция


TrnTools.BuildAccesibilyAreas (метод)

Построение зон достижимости к точкам Points с заданными весами PointWeights

Синтаксис

[Visual Basic 6]
Sub BuildAccesibilyAreas ( _
   ByVal Points As Collection, _
   ByVal PointWeights As DoubleCollection, _
   Areas As Collection _
)

[Delphi]
procedure BuildAccesibilyAreas(
   const Points: Collection;
   const PointWeights: DoubleCollection;
   var Areas: Collection
)

Описание параметров

Points
[in] Коллекция исходных точек типа ModelPoint
PointWeights
[in] Коллекция весов исходных точек
Areas
[in, out] Возращает коллекцию полигонов типа PolygonShape, соответствующих зонам достижимости для каждой исходной точки

Смотри также

Class Collection, Class DoubleCollection, Class TrnTools, Group Триангуляция


TrnTools.BuildVoronoiAreas (метод)

Построение диаграмм Вороного - множеств ближайших точек к заданным точкам Points

Синтаксис

[Visual Basic 6]
Sub BuildVoronoiAreas ( _
   ByVal Points As Collection, _
   Areas As Collection _
)

[Delphi]
procedure BuildVoronoiAreas(
   const Points: Collection;
   var Areas: Collection
)

Описание параметров

Points
[in] Коллекция исходных точек типа ModelPoint
Areas
[in, out] Возращает коллекцию полигонов типа PolygonShape, соответствующих каждой исходной точки

Смотри также

Class Collection, Class TrnTools, Group Триангуляция


TrnTools.MakeBufferAreas (метод)

Построить буферные зоны для заданных точечных, линейных или площадных фигур

Синтаксис

[Visual Basic 6]
Sub MakeBufferAreas ( _
   ByVal SourceShapes As Collection, _
   ByVal Distance As Double, _
   Areas As Collection, _
   AreaNumbers As IntegerCollection, _
   [ByVal AreaCount As Long = 1], _
   [ByVal SegmentCount As Long = 32] _
)

[Delphi]
procedure MakeBufferAreas(
   const SourceShapes: Collection;
   const Distance: Double;
   var Areas: Collection;
   var AreaNumbers: IntegerCollection;
   const AreaCount: Integer;
   const SegmentCount: Integer
)

Описание параметров

SourceShapes
[in] Список исходных фигур типов PointShape, MultiPointShape, PolylineShape или PolygonShape
Distance
[in] Максимальное расстояние от исходных фигур, на котором нужно построить буферные зоны
Areas
[in, out] Возращает коллекцию полигонов типа PolygonShape, образующих соответствующие буферные зоны
AreaNumbers
[in, out] Возращает коллекцию номеров буферных для полигонов в коллекции Areas
AreaCount
[in] Количество буферных зон, которые нужно построить для каждой фигуры. В этого будут построены зоны, внутри которых все точки плоскости будут удалены от фигур на расстояния [Distance*I/AreaCount, Distance*(I+1)/AreaCount], где I = 0..AreaCount-1
SegmentCount
[in] Количество отрезков, которыми будут аппроксимироваться вруговые буферные зоны

Смотри также

Class Collection, Class IntegerCollection, Class TrnTools, Group Триангуляция


TrnTools.MergePolygons (метод)

Объединение всех смежных полигонов

Синтаксис

[Visual Basic 6]
Sub MergePolygons ( _
   ByVal SourcePolygons As Collection, _
   MergedPolygons As Collection _
)

[Delphi]
procedure MergePolygons(
   const SourcePolygons: Collection;
   var MergedPolygons: Collection
)

Описание параметров

SourcePolygons
[in] Список исходных полигонов типа PolygonShape
MergedPolygons
[in, out] Возращает коллекцию объединенных полигонов типа PolygonShape

Смотри также

Class Collection, Class TrnTools, Group Триангуляция


TrnTools.SplitStripPicket (метод)

Построение попикетажного разбиения полосовой области вдоль некоторой линии

Синтаксис

[Visual Basic 6]
Sub SplitStripPicket ( _
   ByVal Line As ShapePolyline, _
   ByVal Radius As Double, _
   ByVal Pickets As DoubleCollection, _
   Areas As Collection, _
   [ByVal AreaOfInterest As ShapePolygon = 0], _
   [ByVal UseLineMeasure As Boolean = False], _
   [ByVal LineStartPicket As Double = 0], _
   [ByVal LineFinishPicket As Double = 0], _
   [ByVal Precision As Double = 0] _
)

[Delphi]
procedure SplitStripPicket(
   const Line: ShapePolyline;
   const Radius: Double;
   const Pickets: DoubleCollection;
   var Areas: Collection;
   const AreaOfInterest: ShapePolygon;
   const UseLineMeasure: WordBool;
   const LineStartPicket: Double;
   const LineFinishPicket: Double;
   const Precision: Double
)

Описание параметров

Line
[in] Заданная линия, вдоль которой нужно выполнить попикетажное разбиение
Radius
[in] Смещение от осевой линии в разные стороны по перпендикуляру
Pickets
[in] Пикетажи, между которомы надо выполнить нарезку
Areas
[in, out] Список выходных полигонов попикетажного разбиения полосовой области
AreaOfInterest
[in] Область интересов
UseLineMeasure
[in] Использовать ли для кодирования меру в полилинии
LineStartPicket
[in] Пикетаж начала исходной линии, если не используется кодирование по мере
LineFinishPicket
[in] Пикетаж конца исходной линии, если не используется кодирование по мере
Precision
[in] Точность при автоматическом упрощении исходной полилинии

Смотри также

Class Collection, Class DoubleCollection, Class ShapePolygon, Class ShapePolyline, Class TrnTools, Group Триангуляция


Класс TrnTriangle

Треугольник триангуляции. Состоит из указателей на точки и соседние треугольники. Напротив i-й точки P[i] всегда задается i-й треугольник. Точки нумеруются по часовой стрелке

Наследование

Figure Class TrnTriangle

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property AreaCount (только для чтения) | Количество регионов с Kind=trkNormal, в которые входит треугольник
Property Areas (только для чтения) | Массив регионов с Kind=trkNormal, в которые входит треугольник (нумерация регионов идёт от 0 до AreaCount-1)
Property Bounds (только для чтения) | Минимальный объемлющий фигуру прямоугольник
Property Caption (только для чтения) | Название фигуры
Property Color | Цвет для отображения в триангуляции
Property Index (только для чтения) | Номер данной фигуры в списке-владельце фигур
Property Kind (только для чтения) | Тип треугольника
Property Nodes (только для чтения) | Массив вершин, образующих треугольников
Property ObjectKind (только для чтения) | Тип объекта
Property Owner (только для чтения) | Список-владелец данной фигуры
Property ReadOnly | Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)
Property Ribs (только для чтения) | Массив структурных неперестраиваемых рёбер или Nothing
Property Selected | Выделена ли фигура
Property Tag | Поле для свободного использования
Property Triangles (только для чтения) | Массив соседних треугольников или Nothing
Property Triangulation (только для чтения) | Триангуляция, которой принадлежит объект
Property Visible | Видима ли фигура

Методы класса

Имя | Описание
Method Assign | Скопировать параметры из другой фигуры
Method BeginUpdate | Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры
Method Centroid | Получить центроид треугольника
Method CircumCircle | Вычисление центра и радиуса описанной окружности
Method Clone | Создание копии данной фигуры
Method CloneEmpty | Создание новой фигуры того же типа, что и данная фигура
Method Delete | Удаление фигуры из набора фигур и уничтожение фигуры
Method Direction | Вычисляет в переменной Dir направление наклона треугольника (векторное произведение P[1]-P[0] и P[2]-P[0])
Method DistanceTo | Вычисление расстояния от фигуры до заданной точки
Method EndUpdate | Закончить изменение фигуры
Method Exposition | Вычисление экспозиции (направления) склона в единицах, опредеяемых параметром SlopeMode. Возвращает True, если треугольник не горизонтален
Method GetAdjustPointCount | Число точек настройки
Method GetAdjustPointCursor | Получить форму курсора в точке настройки
Method GetAdjustPointKind | Получить форму точки настройки
Method GetAdjustPointPos | Получить координаты точки настройки
Method GetContactCount | Определяет число контактов в элементе
Method GetContactPos | Определяет контакт с заданным номером
Method Intensity | Интенсивность освещения (величина в диапазоне [0..1])
Method InterpolateHeight | Возвращает линейно интерполированно по треугольнику значение Z
Method InterpolateRibCenter | Вычисляет 3D-координаты середины ребра по нормалям узлов и несколько смещает вертикальную координату по сравнению с линейной интерполяцией (используется для сгущения точек)
Method InterpolateWeights | Вычисляет нормированные на единицу веса близости до узлов для целей интерполяции (по сути вычсиляются барицентрические координаты точки в треугольнике)
Method IsAlmostSquareWith | Проверить, образуется ли выпуклый почти прямоугольный четырехугольник с заданным соседом (задается максимальное отклонение углов от 90 градусов)
Method IsBoundary | Лежит ли треугольник на границе
Method IsUpdating | Проверить, выполняется ли в настоящее время изменение фигуры
Method LineIntersection | Поиск пересечения вертикальной плоскости Point1-Point2 со сторонами треугольника
Method MoveAdjustPointTo | Переместить точку настройки в другую позицию (вызывает редактор карт)
Method MoveDelta | Перемещение фигуры на заданное расстояние
Method NodeNormal | Вычисляет нормаль в заданном узле как среднее взвешенное смежных треугольников
Method Normal | Вычисляет нормаль (векторное произведение векторов P[1]-P[0] и P[2]-P[0])
Method Perimeter | Периметр треугольника в проекции
Method Perpendicular | Вычислить перпендикуляр к стороне и получить точку на перепендикуляре на расстоянии Distance от ребра
Method PrismVolume | Возвращает объём неправильной треугольной призмы в проекции треугольника на плоскость Z=Level. AboveVolume/BelowVolume - объём выше/ниже уровня, AboveSquare/BelowSquare - площадь участка, поверхность которого выше/ниже Level
Method RibIntersection | Поиск пересечения вертикальной плоскости P1-P2 с прямой, проходящей по стороне треугольника
Method RibLength | Длина ребра в проекции
Method RollbackUpdate | Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения
Method SlopeAngle | Вычисляет угол наклона треугольника к горизонтали в радианах [0..Pi/2]
Method SlopePercent | Вычисляет наклон треугольника к горизонтали в процентах [0..Infinity]
Method SpaceAngle | Угол треугольника по поверхности в исходных единицах
Method SpaceCosAngle | Косинус угла треугольника по поверхности в исходных единицах
Method SpacePerimeter | Периметр треугольника в пространстве
Method SpaceRibLength | Длина ребра в пространстве
Method SpaceSquare | Площадь треугольника по поверхности
Method Square | Площадь треугольника
Method TransformAffine | Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)
Method TransformCoordinates | Преобразование координат фигуры заданным преобразованием

Где используется

Класс | Член класса
Class CADTriangulation | Property Triangles (свойство) Method FindTriangle (метод) Method GetSoftRibAtPoint (метод)
Class IEnumerateProfile | Method Register (метод)
Class IEnumerateProfilePoints | Method Register (метод)
Class IEnumerateTriangles | Method Register (метод)
Class Triangulation | Property Triangles (свойство) Method FindTriangle (метод) Method GetSoftRibAtPoint (метод)
Class TrnTriangle | Property Triangles (свойство) Method IsAlmostSquareWith (метод)

Смотри также

Enum AdjustPointConstants, Class Figure, Class FigureSet, Interface ICoordinateTransformer, Class ModelPoint, Class ModelRect, Class Point3D, Enum SlopeModeConstants, Class TrnArea, Enum TrnFigureKindConstants, Class TrnNode, Enum TrnNodeWeightModeConstants, Class TrnRib, Enum TrnTriangleConstants, Group Триангуляция


TrnTriangle.AreaCount (свойство)

Количество регионов с Kind=trkNormal, в которые входит треугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property AreaCount As Long

[Delphi]
{только для чтения} property AreaCount: Integer

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Areas (свойство)

Массив регионов с Kind=trkNormal, в которые входит треугольник (нумерация регионов идёт от 0 до AreaCount-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property Areas As TrnArea

[Delphi]
{только для чтения} property Areas: TrnArea

Смотри также

Class TrnArea, Class TrnTriangle, Group Триангуляция


TrnTriangle.Bounds (свойство)

Минимальный объемлющий фигуру прямоугольник

Синтаксис

[Visual Basic 6]
ReadOnly Property Bounds As ModelRect

[Delphi]
{только для чтения} property Bounds: ModelRect

Смотри также

Class ModelRect, Class TrnTriangle, Group Триангуляция


TrnTriangle.Caption (свойство)

Название фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Caption As String

[Delphi]
{только для чтения} property Caption: WideString

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Color (свойство)

Цвет для отображения в триангуляции

Синтаксис

[Visual Basic 6]
Property Color As OLE_COLOR

[Delphi]
property Color: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Index (свойство)

Номер данной фигуры в списке-владельце фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Kind (свойство)

Тип треугольника

Синтаксис

[Visual Basic 6]
ReadOnly Property Kind As TrnTriangleConstants

[Delphi]
{только для чтения} property Kind: TrnTriangleConstants

Смотри также

Class TrnTriangle, Enum TrnTriangleConstants, Group Триангуляция


TrnTriangle.Nodes (свойство)

Массив вершин, образующих треугольников

Синтаксис

[Visual Basic 6]
ReadOnly Property Nodes As TrnNode

[Delphi]
{только для чтения} property Nodes: TrnNode

Смотри также

Class TrnNode, Class TrnTriangle, Group Триангуляция


TrnTriangle.ObjectKind (свойство)

Тип объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectKind As TrnFigureKindConstants

[Delphi]
{только для чтения} property ObjectKind: TrnFigureKindConstants

Смотри также

Enum TrnFigureKindConstants, Class TrnTriangle, Group Триангуляция


TrnTriangle.Owner (свойство)

Список-владелец данной фигуры

Синтаксис

[Visual Basic 6]
ReadOnly Property Owner As FigureSet

[Delphi]
{только для чтения} property Owner: FigureSet

Смотри также

Class FigureSet, Class TrnTriangle, Group Триангуляция


TrnTriangle.ReadOnly (свойство)

Фигура заблокирована от изменений (можно только менять Selected, Visible, Tag)

Синтаксис

[Visual Basic 6]
Property ReadOnly As Boolean

[Delphi]
property ReadOnly: WordBool

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Ribs (свойство)

Массив структурных неперестраиваемых рёбер или Nothing

Синтаксис

[Visual Basic 6]
ReadOnly Property Ribs As TrnRib

[Delphi]
{только для чтения} property Ribs: TrnRib

Смотри также

Class TrnRib, Class TrnTriangle, Group Триангуляция


TrnTriangle.Selected (свойство)

Выделена ли фигура

Синтаксис

[Visual Basic 6]
Property Selected As Boolean

[Delphi]
property Selected: WordBool

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Tag (свойство)

Поле для свободного использования

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Triangles (свойство)

Массив соседних треугольников или Nothing

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangles As TrnTriangle

[Delphi]
{только для чтения} property Triangles: TrnTriangle

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Triangulation (свойство)

Триангуляция, которой принадлежит объект

Синтаксис

[Visual Basic 6]
ReadOnly Property Triangulation As Triangulation

[Delphi]
{только для чтения} property Triangulation: Triangulation

Смотри также

Class Triangulation, Class TrnTriangle, Group Триангуляция


TrnTriangle.Visible (свойство)

Видима ли фигура

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Assign (метод)

Скопировать параметры из другой фигуры

Синтаксис

[Visual Basic 6]
Sub Assign ( _
   ByVal Figure As Figure _
)

[Delphi]
procedure Assign(
   const Figure: Figure
)

Описание параметров

Figure
[in] Фигура, из которой необходимо скопировать параметры

Смотри также

Class Figure, Class TrnTriangle, Group Триангуляция


TrnTriangle.BeginUpdate (метод)

Начать изменение фигуры и при необходимости сразу запомнить все координаты фигуры

Синтаксис

[Visual Basic 6]
Sub BeginUpdate ( _
   [ByVal UndoCaption As String = ""] _
)

[Delphi]
procedure BeginUpdate(
   const UndoCaption: WideString
)

Описание параметров

UndoCaption
[in] Описание выполняемой операции

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Centroid (метод)

Получить центроид треугольника

Синтаксис

[Visual Basic 6]
Sub Centroid ( _
   X As Double, _
   Y As Double _
)

[Delphi]
procedure Centroid(
   out X: Double;
   out Y: Double
)

Описание параметров

X
[out] Вычисленная координата X центроида треугольника
Y
[out] Вычисленная координата Y центроида треугольника

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.CircumCircle (метод)

Вычисление центра и радиуса описанной окружности

Синтаксис

[Visual Basic 6]
Sub CircumCircle ( _
   X As Double, _
   Y As Double, _
   R As Double _
)

[Delphi]
procedure CircumCircle(
   out X: Double;
   out Y: Double;
   out R: Double
)

Описание параметров

X
[out] Вычисленная координата X центра описанной окружности
Y
[out] Вычисленная координата Y центра описанной окружности
R
[out] Вычисленный радиус описанной окружности

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Clone (метод)

Создание копии данной фигуры

Синтаксис

[Visual Basic 6]
Function Clone ( _
   [ByVal AddToFigures As Boolean = True] _
) As Figure

[Delphi]
function Clone(
   const AddToFigures: WordBool
): Figure

Описание параметров

AddToFigures
[in] Добавлять ли скопированную фигуру в родительский набор данных

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class TrnTriangle, Group Триангуляция


TrnTriangle.CloneEmpty (метод)

Создание новой фигуры того же типа, что и данная фигура

Синтаксис

[Visual Basic 6]
Function CloneEmpty ( _
   [ByVal NewOwner As FigureSet = 0] _
) As Figure

[Delphi]
function CloneEmpty(
   const NewOwner: FigureSet
): Figure

Описание параметров

NewOwner
[in] Владелец новой фигуры

Возвращаемое значение

Возвращает новую фигуру, созданую как копию данной фигуры

Смотри также

Class Figure, Class FigureSet, Class TrnTriangle, Group Триангуляция


TrnTriangle.Delete (метод)

Удаление фигуры из набора фигур и уничтожение фигуры

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Direction (метод)

Вычисляет в переменной Dir направление наклона треугольника (векторное произведение P[1]-P[0] и P[2]-P[0])

Синтаксис

[Visual Basic 6]
Function Direction ( _
   DirX As Double, _
   DirY As Double _
) As Boolean

[Delphi]
function Direction(
   out DirX: Double;
   out DirY: Double
): WordBool

Описание параметров

DirX
[out] Вычисленная компонента X вектора направление наклона треугольника
DirY
[out] Вычисленная компонента Y вектора направление наклона треугольника

Возвращаемое значение

Возвращает True, если направление наклона успешно вычислено

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.DistanceTo (метод)

Вычисление расстояния от фигуры до заданной точки

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const ModelX: Double;
   const ModelY: Double;
   const InsideDistance: Double
): Double

Описание параметров

ModelX
[in] Координата X точки в модельной системе координат
ModelY
[in] Координата Y точки в модельной системе координат
InsideDistance
[in] Значение, возращаемое в случае, если указанная точка находится строго внутри фигуры

Возвращаемое значение

Возвращает расстояние от фигуры до заданной точки

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.EndUpdate (метод)

Закончить изменение фигуры

Синтаксис

[Visual Basic 6]
Sub EndUpdate

[Delphi]
procedure EndUpdate

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Exposition (метод)

Вычисление экспозиции (направления) склона в единицах, опредеяемых параметром SlopeMode. Возвращает True, если треугольник не горизонтален

Синтаксис

[Visual Basic 6]
Function Exposition ( _
   Exp As Double, _
   ByVal MinSlope As Double, _
   [ByVal SlopeMode As SlopeModeConstants = 0] _
) As Boolean

[Delphi]
function Exposition(
   out Exp: Double;
   const MinSlope: Double;
   const SlopeMode: SlopeModeConstants
): WordBool

Описание параметров

Exp
[out] Вычисленная экспозиции (направления) склона в градусах
MinSlope
[in] Минимальный допустимый наклон. Если вычисленный наклон будет меньше этого, то функция возвратит False
SlopeMode
[in] Способ вычисление наклона поверхности к горизонтали: в градусах, радианах, процентах или промилле

Возвращаемое значение

Возвращает True, если экспозиция склона успешно вычислена

Смотри также

Enum SlopeModeConstants, Class TrnTriangle, Group Триангуляция


TrnTriangle.GetAdjustPointCount (метод)

Число точек настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointCount As Long

[Delphi]
function GetAdjustPointCount: Integer

Возвращаемое значение

Возвращает общее число точек настройки

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.GetAdjustPointCursor (метод)

Получить форму курсора в точке настройки

Синтаксис

[Visual Basic 6]
Sub GetAdjustPointCursor ( _
   ByVal Number As Long, _
   SnapingCursor As Long, _
   MovingCursor As Long _
)

[Delphi]
procedure GetAdjustPointCursor(
   const Number: Integer;
   out SnapingCursor: Integer;
   out MovingCursor: Integer
)

Описание параметров

Number
[in] Номер точки настройки
SnapingCursor
[out] Курсор, используемый при подтяжке точки настройка
MovingCursor
[out] Курсор, используемый при перемещении точки настройки

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.GetAdjustPointKind (метод)

Получить форму точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointKind ( _
   ByVal Number As Long _
) As AdjustPointConstants

[Delphi]
function GetAdjustPointKind(
   const Number: Integer
): AdjustPointConstants

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает форму точки настройки

Смотри также

Enum AdjustPointConstants, Class TrnTriangle, Group Триангуляция


TrnTriangle.GetAdjustPointPos (метод)

Получить координаты точки настройки

Синтаксис

[Visual Basic 6]
Function GetAdjustPointPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetAdjustPointPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер точки настройки

Возвращаемое значение

Возвращает координату точки настройки

Смотри также

Class ModelPoint, Class TrnTriangle, Group Триангуляция


TrnTriangle.GetContactCount (метод)

Определяет число контактов в элементе

Синтаксис

[Visual Basic 6]
Function GetContactCount As Long

[Delphi]
function GetContactCount: Integer

Возвращаемое значение

Возвращает число контактов в элементе

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.GetContactPos (метод)

Определяет контакт с заданным номером

Синтаксис

[Visual Basic 6]
Function GetContactPos ( _
   ByVal Number As Long _
) As ModelPoint

[Delphi]
function GetContactPos(
   const Number: Integer
): ModelPoint

Описание параметров

Number
[in] Номер контакта

Возвращаемое значение

Возвращает координаты контакта с заданным номером

Смотри также

Class ModelPoint, Class TrnTriangle, Group Триангуляция


TrnTriangle.Intensity (метод)

Интенсивность освещения (величина в диапазоне [0..1])

Синтаксис

[Visual Basic 6]
Function Intensity ( _
   [ByVal ZStretching As Double = 1] _
) As Double

[Delphi]
function Intensity(
   const ZStretching: Double
): Double

Описание параметров

ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением освещения

Возвращаемое значение

Возвращает интенсивность освещения

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.InterpolateHeight (метод)

Возвращает линейно интерполированно по треугольнику значение Z

Синтаксис

[Visual Basic 6]
Function InterpolateHeight ( _
   ByVal InterX As Double, _
   ByVal InterY As Double _
) As Double

[Delphi]
function InterpolateHeight(
   const InterX: Double;
   const InterY: Double
): Double

Описание параметров

InterX
[in] Координата X точки на плоскости, для которой будет выполняться интерполяция высоты
InterY
[in] Координата Y точки на плоскости, для которой будет выполняться интерполяция высоты

Возвращаемое значение

Возвращает линейно интерполированную высоту

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.InterpolateRibCenter (метод)

Вычисляет 3D-координаты середины ребра по нормалям узлов и несколько смещает вертикальную координату по сравнению с линейной интерполяцией (используется для сгущения точек)

Синтаксис

[Visual Basic 6]
Function InterpolateRibCenter ( _
   ByVal NodeIndex As Long, _
   [ByVal WeightMode As TrnNodeWeightModeConstants = 0], _
   [ByVal Tension As Double = 1], _
   [ByVal ZStretching As Double = 1] _
) As Point3D

[Delphi]
function InterpolateRibCenter(
   const NodeIndex: Integer;
   const WeightMode: TrnNodeWeightModeConstants;
   const Tension: Double;
   const ZStretching: Double
): Point3D

Описание параметров

NodeIndex
[in] Номер узла данного треугольника (нумерация узлов производится от 0 до 2)
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников
Tension
[in] Степень натяжения сплайна, используемого для интерполяции
ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением вектора нормали на поверхности

Возвращаемое значение

Возвращает трёхмерный вектор нормали к указанному узлу

Смотри также

Class Point3D, Enum TrnNodeWeightModeConstants, Class TrnTriangle, Group Триангуляция


TrnTriangle.InterpolateWeights (метод)

Вычисляет нормированные на единицу веса близости до узлов для целей интерполяции (по сути вычсиляются барицентрические координаты точки в треугольнике)

Синтаксис

[Visual Basic 6]
Sub InterpolateWeights ( _
   ByVal InterX As Double, _
   ByVal InterY As Double, _
   Weight0 As Double, _
   Weight1 As Double, _
   Weight2 As Double _
)

[Delphi]
procedure InterpolateWeights(
   const InterX: Double;
   const InterY: Double;
   out Weight0: Double;
   out Weight1: Double;
   out Weight2: Double
)

Описание параметров

InterX
[in] Координата X точки на плоскости, для которой будет выполняться интерполяция высоты
InterY
[in] Координата Y точки на плоскости, для которой будет выполняться интерполяция высоты
Weight0
[out] Вычисленный вес для узла треугольника с индексом 0
Weight1
[out] Вычисленный вес для узла треугольника с индексом 1
Weight2
[out] Вычисленный вес для узла треугольника с индексом 2

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.IsAlmostSquareWith (метод)

Проверить, образуется ли выпуклый почти прямоугольный четырехугольник с заданным соседом (задается максимальное отклонение углов от 90 градусов)

Синтаксис

[Visual Basic 6]
Function IsAlmostSquareWith ( _
   ByVal SecondTriangle As TrnTriangle, _
   Deviation As Double, _
   DirectTrnLink As Long, _
   BackTrnLink As Long, _
   [ByVal MaxAngleDeviation As Double = 15] _
) As Boolean

[Delphi]
function IsAlmostSquareWith(
   const SecondTriangle: TrnTriangle;
   out Deviation: Double;
   out DirectTrnLink: Integer;
   out BackTrnLink: Integer;
   const MaxAngleDeviation: Double
): WordBool

Описание параметров

SecondTriangle
[in] Второй треугольник, сосед данного
Deviation
[out] Найденное отклонение углов от 90 градусов
DirectTrnLink
[out] Номер треугольника SecondTriangle как ссылки внутри данного треугольника
BackTrnLink
[out] Номер данного треугольника как ссылки внутри треугольника SecondTriangle
MaxAngleDeviation
[in] Максимальное допустимое отклонение

Возвращаемое значение

Возвращает True, если образуется ли выпуклый почти прямоугольный четырехугольник с заданным соседом

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.IsBoundary (метод)

Лежит ли треугольник на границе

Синтаксис

[Visual Basic 6]
Function IsBoundary As Boolean

[Delphi]
function IsBoundary: WordBool

Возвращаемое значение

Возвращает True, если треугольник лежит на границе

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.IsUpdating (метод)

Проверить, выполняется ли в настоящее время изменение фигуры

Синтаксис

[Visual Basic 6]
Function IsUpdating As Boolean

[Delphi]
function IsUpdating: WordBool

Возвращаемое значение

Возвращает True, если сейчас выполняется изменение объекта (т.е. вызван метод BeginUpdate, но ещё не вызван EndUpdate)

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.LineIntersection (метод)

Поиск пересечения вертикальной плоскости Point1-Point2 со сторонами треугольника

Синтаксис

[Visual Basic 6]
Sub LineIntersection ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint, _
   IntersectionCount As Long, _
   Intersection1 As Point3D, _
   Intersection2 As Point3D, _
   RibIndex1 As Long, _
   RibIndex2 As Long _
)

[Delphi]
procedure LineIntersection(
   const Point1: ModelPoint;
   const Point2: ModelPoint;
   out IntersectionCount: Integer;
   out Intersection1: Point3D;
   out Intersection2: Point3D;
   out RibIndex1: Integer;
   out RibIndex2: Integer
)

Описание параметров

Point1
[in] Первая точка
Point2
[in] Вторая точка
IntersectionCount
[out] Найденное число пересечений
Intersection1
[out] Первая найденная точка пересечения или Nothing, если пересечений не найдено
Intersection2
[out] Вторая найденная точка пересечения или Nothing, если пересечений найдено меньше двух
RibIndex1
[out] Номер первого пересекаемого ребра или -1, если пересечений не найдено
RibIndex2
[out] Номер первого пересекаемого ребра или -1, если пересечений найдено меньше двух

Смотри также

Class ModelPoint, Class Point3D, Class TrnTriangle, Group Триангуляция


TrnTriangle.MoveAdjustPointTo (метод)

Переместить точку настройки в другую позицию (вызывает редактор карт)

Синтаксис

[Visual Basic 6]
Sub MoveAdjustPointTo ( _
   ByVal Number As Long, _
   ByVal ModelX As Double, _
   ByVal ModelY As Double _
)

[Delphi]
procedure MoveAdjustPointTo(
   const Number: Integer;
   const ModelX: Double;
   const ModelY: Double
)

Описание параметров

Number
[in] Номер точки настройки
ModelX
[in] Координата X нового положения точки настройки
ModelY
[in] Координата Y нового положения точки настройки

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.MoveDelta (метод)

Перемещение фигуры на заданное расстояние

Синтаксис

[Visual Basic 6]
Sub MoveDelta ( _
   ByVal DeltaX As Double, _
   ByVal DeltaY As Double _
)

[Delphi]
procedure MoveDelta(
   const DeltaX: Double;
   const DeltaY: Double
)

Описание параметров

DeltaX
[in] Сдвиг по координате X
DeltaY
[in] Сдвиг по координате Y

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.NodeNormal (метод)

Вычисляет нормаль в заданном узле как среднее взвешенное смежных треугольников

Синтаксис

[Visual Basic 6]
Function NodeNormal ( _
   ByVal NodeIndex As Long, _
   [ByVal WeightMode As TrnNodeWeightModeConstants = 0], _
   [ByVal ZStretching As Double = 1] _
) As Point3D

[Delphi]
function NodeNormal(
   const NodeIndex: Integer;
   const WeightMode: TrnNodeWeightModeConstants;
   const ZStretching: Double
): Point3D

Описание параметров

NodeIndex
[in] Номер узла данного треугольника (нумерация узлов производится от 0 до 2)
WeightMode
[in] Способ усреднения нормалей смежных к узлу треугольников
ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением вектора нормали на поверхности

Возвращаемое значение

Возвращает трёхмерный вектор нормали к указанному узлу

Смотри также

Class Point3D, Enum TrnNodeWeightModeConstants, Class TrnTriangle, Group Триангуляция


TrnTriangle.Normal (метод)

Вычисляет нормаль (векторное произведение векторов P[1]-P[0] и P[2]-P[0])

Синтаксис

[Visual Basic 6]
Sub Normal ( _
   X As Double, _
   Y As Double, _
   Z As Double, _
   [ByVal Normalize As Boolean = False], _
   [ByVal ZStretching As Double = 1] _
)

[Delphi]
procedure Normal(
   out X: Double;
   out Y: Double;
   out Z: Double;
   const Normalize: WordBool;
   const ZStretching: Double
)

Описание параметров

X
[out] Вычисленная компонента X вектора нормали
Y
[out] Вычисленная компонента Y вектора нормали
Z
[out] Вычисленная компонента Z вектора нормали
Normalize
[in] Следует ли выполнять нормализацию (приведение к единичной длине) вектора нормали
ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением нормали

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Perimeter (метод)

Периметр треугольника в проекции

Синтаксис

[Visual Basic 6]
Function Perimeter As Double

[Delphi]
function Perimeter: Double

Возвращаемое значение

Возвращает периметр треугольника в проекции

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Perpendicular (метод)

Вычислить перпендикуляр к стороне и получить точку на перепендикуляре на расстоянии Distance от ребра

Синтаксис

[Visual Basic 6]
Sub Perpendicular ( _
   ByVal RibIndex As Long, _
   ByVal Distance As Double, _
   PointX As Double, _
   PointY As Double _
)

[Delphi]
procedure Perpendicular(
   const RibIndex: Integer;
   const Distance: Double;
   out PointX: Double;
   out PointY: Double
)

Описание параметров

RibIndex
[in] Номер ребра треугольника (нумерация ребер идёт от 0 до 2)
Distance
[in] Расстояние от ребра
PointX
[out] Координата X вычисленной точки
PointY
[out] Координата Y вычисленной точки

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.PrismVolume (метод)

Возвращает объём неправильной треугольной призмы в проекции треугольника на плоскость Z=Level. AboveVolume/BelowVolume - объём выше/ниже уровня, AboveSquare/BelowSquare - площадь участка, поверхность которого выше/ниже Level

Синтаксис

[Visual Basic 6]
Sub PrismVolume ( _
   ByVal Level As Double, _
   BelowVolume As Double, _
   BelowSquare As Double, _
   AboveVolume As Double, _
   AboveSquare As Double _
)

[Delphi]
procedure PrismVolume(
   const Level: Double;
   out BelowVolume: Double;
   out BelowSquare: Double;
   out AboveVolume: Double;
   out AboveSquare: Double
)

Описание параметров

Level
[in] Уровень плоскости, на которую выполняется проекция
BelowVolume
[out] Вычисленный объём призмы ниже указанной плоскости
BelowSquare
[out] Площадь участка, поверхность которого ниже указанной плоскости
AboveVolume
[out] Вычисленный объём призмы выше указанной плоскости
AboveSquare
[out] Площадь участка, поверхность которого выше указанной плоскости

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.RibIntersection (метод)

Поиск пересечения вертикальной плоскости P1-P2 с прямой, проходящей по стороне треугольника

Синтаксис

[Visual Basic 6]
Function RibIntersection ( _
   ByVal Point1 As ModelPoint, _
   ByVal Point2 As ModelPoint, _
   ByVal RibIndex As Long, _
   Intersection As Point3D _
) As Boolean

[Delphi]
function RibIntersection(
   const Point1: ModelPoint;
   const Point2: ModelPoint;
   const RibIndex: Integer;
   out Intersection: Point3D
): WordBool

Описание параметров

Point1
[in] Первая точка
Point2
[in] Вторая точка
RibIndex
[in] Номер пересекаемого ребра
Intersection
[out] Найденная точка пересечения

Возвращаемое значение

Возвращает True, если точка пересечения найдена

Смотри также

Class ModelPoint, Class Point3D, Class TrnTriangle, Group Триангуляция


TrnTriangle.RibLength (метод)

Длина ребра в проекции

Синтаксис

[Visual Basic 6]
Function RibLength ( _
   ByVal RibIndex As Long _
) As Double

[Delphi]
function RibLength(
   const RibIndex: Integer
): Double

Описание параметров

RibIndex
[in] Номер ребра треугольника (нумерация ребер производится от 0 до 2)

Возвращаемое значение

Возвращает длину ребра в проекции

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.RollbackUpdate (метод)

Указать, что при вызове последнего вложенного EndUpdate надо будет откатить сделанные изменения

Синтаксис

[Visual Basic 6]
Sub RollbackUpdate

[Delphi]
procedure RollbackUpdate

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.SlopeAngle (метод)

Вычисляет угол наклона треугольника к горизонтали в радианах [0..Pi/2]

Синтаксис

[Visual Basic 6]
Function SlopeAngle As Double

[Delphi]
function SlopeAngle: Double

Возвращаемое значение

Возвращает угол наклона треугольника к горизонтали в радианах [0..Pi/2]

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.SlopePercent (метод)

Вычисляет наклон треугольника к горизонтали в процентах [0..Infinity]

Синтаксис

[Visual Basic 6]
Function SlopePercent As Double

[Delphi]
function SlopePercent: Double

Возвращаемое значение

Возвращает наклон треугольника к горизонтали в процентах [0..Infinity]

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.SpaceAngle (метод)

Угол треугольника по поверхности в исходных единицах

Синтаксис

[Visual Basic 6]
Function SpaceAngle ( _
   ByVal NodeIndex As Long, _
   [ByVal ZStretching As Double = 1] _
) As Double

[Delphi]
function SpaceAngle(
   const NodeIndex: Integer;
   const ZStretching: Double
): Double

Описание параметров

NodeIndex
[in] Номер узла треугольника, при котором необходимо вычислить угол
ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением угла на поверхности

Возвращаемое значение

Возвращает угол треугольника по поверхности

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.SpaceCosAngle (метод)

Косинус угла треугольника по поверхности в исходных единицах

Синтаксис

[Visual Basic 6]
Function SpaceCosAngle ( _
   ByVal NodeIndex As Long, _
   [ByVal ZStretching As Double = 1] _
) As Double

[Delphi]
function SpaceCosAngle(
   const NodeIndex: Integer;
   const ZStretching: Double
): Double

Описание параметров

NodeIndex
[in] Номер узла треугольника, при котором необходимо вычислить косинус угла
ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением косинуса угла на поверхности

Возвращаемое значение

Возвращает косинус угла треугольника по поверхности

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.SpacePerimeter (метод)

Периметр треугольника в пространстве

Синтаксис

[Visual Basic 6]
Function SpacePerimeter ( _
   [ByVal ZStretching As Double = 1] _
) As Double

[Delphi]
function SpacePerimeter(
   const ZStretching: Double
): Double

Описание параметров

ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением периметра треугольника

Возвращаемое значение

Возвращает периметр треугольника в пространстве

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.SpaceRibLength (метод)

Длина ребра в пространстве

Синтаксис

[Visual Basic 6]
Function SpaceRibLength ( _
   ByVal RibIndex As Long, _
   [ByVal ZStretching As Double = 1] _
) As Double

[Delphi]
function SpaceRibLength(
   const RibIndex: Integer;
   const ZStretching: Double
): Double

Описание параметров

RibIndex
[in] Номер ребра треугольника (нумерация ребер производится от 0 до 2)
ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением длины ребра

Возвращаемое значение

Возвращает длину ребра в пространстве

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.SpaceSquare (метод)

Площадь треугольника по поверхности

Синтаксис

[Visual Basic 6]
Function SpaceSquare ( _
   [ByVal ZStretching As Double = 1] _
) As Double

[Delphi]
function SpaceSquare(
   const ZStretching: Double
): Double

Описание параметров

ZStretching
[in] Дополнительное растяжение координат треугольника по вертикали перед вычислением пространственной площади треугольника

Возвращаемое значение

Возвращает площадь треугольника по поверхности

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.Square (метод)

Площадь треугольника

Синтаксис

[Visual Basic 6]
Function Square As Double

[Delphi]
function Square: Double

Возвращаемое значение

Возвращает площадь треугольника

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.TransformAffine (метод)

Аффинное преобразование координат фигуры матрицей (ABC|DEF|001)

Синтаксис

[Visual Basic 6]
Sub TransformAffine ( _
   ByVal A As Double, _
   ByVal B As Double, _
   ByVal C As Double, _
   ByVal D As Double, _
   ByVal E As Double, _
   ByVal F As Double _
)

[Delphi]
procedure TransformAffine(
   const A: Double;
   const B: Double;
   const C: Double;
   const D: Double;
   const E: Double;
   const F: Double
)

Описание параметров

A
[in] Параметр A афинного преобразования
B
[in] Параметр B афинного преобразования
C
[in] Параметр C афинного преобразования
D
[in] Параметр D афинного преобразования
E
[in] Параметр E афинного преобразования
F
[in] Параметр F афинного преобразования

Смотри также

Class TrnTriangle, Group Триангуляция


TrnTriangle.TransformCoordinates (метод)

Преобразование координат фигуры заданным преобразованием

Синтаксис

[Visual Basic 6]
Sub TransformCoordinates ( _
   ByVal Transformer As ICoordinateTransformer _
)

[Delphi]
procedure TransformCoordinates(
   const Transformer: ICoordinateTransformer
)

Описание параметров

Transformer
[in] Преобразователь координат

Смотри также

Interface ICoordinateTransformer, Class TrnTriangle, Group Триангуляция


Класс UndoManager

Менеджер откатов

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Enabled | Разрешено ли сохранение информации в Undo/Redo
Property GroupActions | Группировать ли в Undo/Redo операции с одинаковыми именами Caption
Property RedoCaptions (только для чтения) | Массив названий соответствующих доступных для возврата операций (нумерация идёт от 0 до UndoCount-1; наибольший индекс - это первая возвращаемая операция)
Property RedoCount (только для чтения) | Количество доступных для возвра операций
Property UndoCaptions (только для чтения) | Массив названий соответствующих доступных для отката операций (нумерация идёт от 0 до UndoCount-1; наибольший индекс - это последняя выполненная операция)
Property UndoCount (только для чтения) | Количество доступных для отката операций

Методы класса

Имя | Описание
Method CanRedo | Проверить, разрешена ли операции возврата выполненной операции
Method CanUndo | Проверить, разрешена ли операции отката выполненной операции
Method Clear | Очистить все буферы с информацией для отката и восстановления
Method Finish | Закончить запись блока данных. Этому вызову всегда должен предшествовать вызов Start
Method IsMarked | Проверить, помечены ли последние записанные команды маркером c указанным именем (вызовом метода Mark)
Method IsRestoring | Проверить, идёт ли в настоящее время откат (Undo) или возврат (Redo) действий
Method Mark | Пометить последние записанные команды маркером с указанным именем и временем жизни в милисекундах (вложенные вызовы не действуют)
Method Redo | Вернуть ранеее отмененную группу операций
Method RememberArray | Записать данные для Undo в виде массива с данными
Method RememberBoolean | Записать данные для Undo в виде логического значения
Method RememberBuffer | Записать данные для Undo в виде небезопасного буфера с данными
Method RememberDouble | Записать данные для Undo в виде вещественного значения
Method RememberInteger | Записать данные для Undo в виде целочисленное значения
Method RememberMethod | Записать данные для Undo в виде одного метода
Method RememberString | Записать данные для Undo в виде строкового значения
Method RememberUnknown | Записать данные для Undo в виде интерфейса некоторого объекта
Method Start | Начать запись блока данных. В конце записи обязательно должен быть вызов Finish
Method Undo | Отменить одну группу операций

Где используется

Класс | Член класса
Class Project | Property UndoManager (свойство)

Смотри также

Interface IUndoRestoreAfter, Interface IUndoRestoreArray, Interface IUndoRestoreBefore, Interface IUndoRestoreBoolean, Interface IUndoRestoreBuffer, Interface IUndoRestoreDouble, Interface IUndoRestoreInteger, Interface IUndoRestoreMethod, Interface IUndoRestoreString, Interface IUndoRestoreUnknown, Enum UndoFinishModeConstants, Group Менеджер откатов


UndoManager.Enabled (свойство)

Разрешено ли сохранение информации в Undo/Redo

Синтаксис

[Visual Basic 6]
Property Enabled As Boolean

[Delphi]
property Enabled: WordBool

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.GroupActions (свойство)

Группировать ли в Undo/Redo операции с одинаковыми именами Caption

Синтаксис

[Visual Basic 6]
Property GroupActions As Boolean

[Delphi]
property GroupActions: WordBool

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.RedoCaptions (свойство)

Массив названий соответствующих доступных для возврата операций (нумерация идёт от 0 до UndoCount-1; наибольший индекс - это первая возвращаемая операция)

Синтаксис

[Visual Basic 6]
ReadOnly Property RedoCaptions As String

[Delphi]
{только для чтения} property RedoCaptions: WideString

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.RedoCount (свойство)

Количество доступных для возвра операций

Синтаксис

[Visual Basic 6]
ReadOnly Property RedoCount As Long

[Delphi]
{только для чтения} property RedoCount: Integer

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.UndoCaptions (свойство)

Массив названий соответствующих доступных для отката операций (нумерация идёт от 0 до UndoCount-1; наибольший индекс - это последняя выполненная операция)

Синтаксис

[Visual Basic 6]
ReadOnly Property UndoCaptions As String

[Delphi]
{только для чтения} property UndoCaptions: WideString

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.UndoCount (свойство)

Количество доступных для отката операций

Синтаксис

[Visual Basic 6]
ReadOnly Property UndoCount As Long

[Delphi]
{только для чтения} property UndoCount: Integer

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.CanRedo (метод)

Проверить, разрешена ли операции возврата выполненной операции

Синтаксис

[Visual Basic 6]
Function CanRedo As Boolean

[Delphi]
function CanRedo: WordBool

Возвращаемое значение

Возвращает True, если операция возврата Redo в настоящее время разрешена

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.CanUndo (метод)

Проверить, разрешена ли операции отката выполненной операции

Синтаксис

[Visual Basic 6]
Function CanUndo As Boolean

[Delphi]
function CanUndo: WordBool

Возвращаемое значение

Возвращает True, если операция отката Undo в настоящее время разрешена

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.Clear (метод)

Очистить все буферы с информацией для отката и восстановления

Синтаксис

[Visual Basic 6]
Sub Clear

[Delphi]
procedure Clear

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.Finish (метод)

Закончить запись блока данных. Этому вызову всегда должен предшествовать вызов Start

Синтаксис

[Visual Basic 6]
Sub Finish ( _
   [ByVal Mode As UndoFinishModeConstants = 0], _
   [ByVal BeforeRestoreHandler As IUndoRestoreBefore = 0], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure Finish(
   const Mode: UndoFinishModeConstants;
   const BeforeRestoreHandler: IUndoRestoreBefore;
   const Cookie: Integer
)

Описание параметров

Mode
[in] Режим завершения записи блока данных
BeforeRestoreHandler
[in] Обработчик события, который будет вызван перед началом отката группы операций
Cookie
[in] Дополнительное значение, передаваемое обработчики события, вызываемого до начала отката группы операций

Смотри также

Interface IUndoRestoreBefore, Enum UndoFinishModeConstants, Class UndoManager, Group Менеджер откатов


UndoManager.IsMarked (метод)

Проверить, помечены ли последние записанные команды маркером c указанным именем (вызовом метода Mark)

Синтаксис

[Visual Basic 6]
Function IsMarked ( _
   ByVal MarkerName As String _
) As Boolean

[Delphi]
function IsMarked(
   const MarkerName: WideString
): WordBool

Описание параметров

MarkerName
[in] Проверяемое имя маркера

Возвращаемое значение

Возвращает True, если маркер с указанным именем ещё действует

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.IsRestoring (метод)

Проверить, идёт ли в настоящее время откат (Undo) или возврат (Redo) действий

Синтаксис

[Visual Basic 6]
Function IsRestoring As Boolean

[Delphi]
function IsRestoring: WordBool

Возвращаемое значение

Возвращает True, если в настоящее время производится откат (Undo) или возврат (Redo) действий

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.Mark (метод)

Пометить последние записанные команды маркером с указанным именем и временем жизни в милисекундах (вложенные вызовы не действуют)

Синтаксис

[Visual Basic 6]
Sub Mark ( _
   ByVal MarkerName As String, _
   [ByVal LifeTimeMSec As Long = 1000] _
)

[Delphi]
procedure Mark(
   const MarkerName: WideString;
   const LifeTimeMSec: Integer
)

Описание параметров

MarkerName
[in] Имя маркера (произвольная строка, выбирается программистом)
LifeTimeMSec
[in] Время действия маркера в милисекундах

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.Redo (метод)

Вернуть ранеее отмененную группу операций

Синтаксис

[Visual Basic 6]
Sub Redo ( _
   [ByVal GroupCount As Long = 1] _
)

[Delphi]
procedure Redo(
   const GroupCount: Integer
)

Описание параметров

GroupCount
[in] Количество групп операций, которые надо вернуть

Смотри также

Class UndoManager, Group Менеджер откатов


UndoManager.RememberArray (метод)

Записать данные для Undo в виде массива с данными

Синтаксис

[Visual Basic 6]
Sub RememberArray ( _
   ByVal RestoreArrayHandler As IUndoRestoreArray, _
   ByVal Data() As Variant, _
   [ByVal Caption As String = ""], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure RememberArray(
   const RestoreArrayHandler: IUndoRestoreArray;
   const Data: PSafeArray;
   const Caption: WideString;
   const Cookie: Integer
)

Описание параметров

RestoreArrayHandler
[in] Обработчик события восстановления объекта
Data
[in] Запоминаемый массив данных
Caption
[in] Название операции, которое будет появляться в выпадающем списке. Это название будет использоваться только в случае, если данный метод был вызван без предшествующего вызова Start
Cookie
[in] Дополнительное значение, используемое при откате и передаваемое обработчики события восстановления объекта

Смотри также

Interface IUndoRestoreArray, Class UndoManager, Group Менеджер откатов


UndoManager.RememberBoolean (метод)

Записать данные для Undo в виде логического значения

Синтаксис

[Visual Basic 6]
Sub RememberBoolean ( _
   ByVal RestoreBooleanHandler As IUndoRestoreBoolean, _
   ByVal Data As Boolean, _
   [ByVal Caption As String = ""], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure RememberBoolean(
   const RestoreBooleanHandler: IUndoRestoreBoolean;
   const Data: WordBool;
   const Caption: WideString;
   const Cookie: Integer
)

Описание параметров

RestoreBooleanHandler
[in] Обработчик события восстановления объекта
Data
[in] Запоминаемое логическое значение
Caption
[in] Название операции, которое будет появляться в выпадающем списке. Это название будет использоваться только в случае, если данный метод был вызван без предшествующего вызова Start
Cookie
[in] Дополнительное значение, используемое при откате и передаваемое обработчики события восстановления объекта

Смотри также

Interface IUndoRestoreBoolean, Class UndoManager, Group Менеджер откатов


UndoManager.RememberBuffer (метод)

Записать данные для Undo в виде небезопасного буфера с данными

Синтаксис

[Visual Basic 6]
Sub RememberBuffer ( _
   ByVal RestoreBufferHandler As IUndoRestoreBuffer, _
   ByVal DataPointer As OLE_HANDLE, _
   ByVal Size As Long, _
   [ByVal Caption As String = ""], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure RememberBuffer(
   const RestoreBufferHandler: IUndoRestoreBuffer;
   const DataPointer: OLE_HANDLE;
   const Size: Integer;
   const Caption: WideString;
   const Cookie: Integer
)

Описание параметров

RestoreBufferHandler
[in] Обработчик события восстановления объекта
DataPointer
[in] Небезопасный указатель на буфер с данными
Size
[in] Размер буфера с данными
Caption
[in] Название операции, которое будет появляться в выпадающем списке. Это название будет использоваться только в случае, если данный метод был вызван без предшествующего вызова Start
Cookie
[in] Дополнительное значение, используемое при откате и передаваемое обработчики события восстановления объекта

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Interface IUndoRestoreBuffer, Class UndoManager, Group Менеджер откатов


UndoManager.RememberDouble (метод)

Записать данные для Undo в виде вещественного значения

Синтаксис

[Visual Basic 6]
Sub RememberDouble ( _
   ByVal RestoreDoubleHandler As IUndoRestoreDouble, _
   ByVal Data As Double, _
   [ByVal Caption As String = ""], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure RememberDouble(
   const RestoreDoubleHandler: IUndoRestoreDouble;
   const Data: Double;
   const Caption: WideString;
   const Cookie: Integer
)

Описание параметров

RestoreDoubleHandler
[in] Обработчик события восстановления объекта
Data
[in] Запоминаемое вещественное значение
Caption
[in] Название операции, которое будет появляться в выпадающем списке. Это название будет использоваться только в случае, если данный метод был вызван без предшествующего вызова Start
Cookie
[in] Дополнительное значение, используемое при откате и передаваемое обработчики события восстановления объекта

Смотри также

Interface IUndoRestoreDouble, Class UndoManager, Group Менеджер откатов


UndoManager.RememberInteger (метод)

Записать данные для Undo в виде целочисленное значения

Синтаксис

[Visual Basic 6]
Sub RememberInteger ( _
   ByVal RestoreIntegerHandler As IUndoRestoreInteger, _
   ByVal Data As Long, _
   [ByVal Caption As String = ""], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure RememberInteger(
   const RestoreIntegerHandler: IUndoRestoreInteger;
   const Data: Integer;
   const Caption: WideString;
   const Cookie: Integer
)

Описание параметров

RestoreIntegerHandler
[in] Обработчик события восстановления объекта
Data
[in] Запоминаемое целочисленное значение
Caption
[in] Название операции, которое будет появляться в выпадающем списке. Это название будет использоваться только в случае, если данный метод был вызван без предшествующего вызова Start
Cookie
[in] Дополнительное значение, используемое при откате и передаваемое обработчики события восстановления объекта

Смотри также

Interface IUndoRestoreInteger, Class UndoManager, Group Менеджер откатов


UndoManager.RememberMethod (метод)

Записать данные для Undo в виде одного метода

Синтаксис

[Visual Basic 6]
Sub RememberMethod ( _
   [ByVal RestoreMethodHandler As IUndoRestoreMethod = 0], _
   [ByVal Caption As String = ""], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure RememberMethod(
   const RestoreMethodHandler: IUndoRestoreMethod;
   const Caption: WideString;
   const Cookie: Integer
)

Описание параметров

RestoreMethodHandler
[in] Обработчик события восстановления объекта
Caption
[in] Название операции, которое будет появляться в выпадающем списке. Это название будет использоваться только в случае, если данный метод был вызван без предшествующего вызова Start
Cookie
[in] Дополнительное значение, используемое при откате и передаваемое обработчики события восстановления объекта

Смотри также

Interface IUndoRestoreMethod, Class UndoManager, Group Менеджер откатов


UndoManager.RememberString (метод)

Записать данные для Undo в виде строкового значения

Синтаксис

[Visual Basic 6]
Sub RememberString ( _
   ByVal RestoreStringHandler As IUndoRestoreString, _
   ByVal Data As String, _
   [ByVal Caption As String = ""], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure RememberString(
   const RestoreStringHandler: IUndoRestoreString;
   const Data: WideString;
   const Caption: WideString;
   const Cookie: Integer
)

Описание параметров

RestoreStringHandler
[in] Обработчик события восстановления объекта
Data
[in] Запоминаемая строка
Caption
[in] Название операции, которое будет появляться в выпадающем списке. Это название будет использоваться только в случае, если данный метод был вызван без предшествующего вызова Start
Cookie
[in] Дополнительное значение, используемое при откате и передаваемое обработчики события восстановления объекта

Смотри также

Interface IUndoRestoreString, Class UndoManager, Group Менеджер откатов


UndoManager.RememberUnknown (метод)

Записать данные для Undo в виде интерфейса некоторого объекта

Синтаксис

[Visual Basic 6]
Sub RememberUnknown ( _
   ByVal RestoreUnknownHandler As IUndoRestoreUnknown, _
   ByVal Data As IUnknown, _
   [ByVal Caption As String = ""], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure RememberUnknown(
   const RestoreUnknownHandler: IUndoRestoreUnknown;
   const Data: IUnknown;
   const Caption: WideString;
   const Cookie: Integer
)

Описание параметров

RestoreUnknownHandler
[in] Обработчик события восстановления объекта
Data
[in] Запоминаемый интерфейс объекта
Caption
[in] Название операции, которое будет появляться в выпадающем списке. Это название будет использоваться только в случае, если данный метод был вызван без предшествующего вызова Start
Cookie
[in] Дополнительное значение, используемое при откате и передаваемое обработчики события восстановления объекта

Смотри также

Interface IUndoRestoreUnknown, Class UndoManager, Group Менеджер откатов


UndoManager.Start (метод)

Начать запись блока данных. В конце записи обязательно должен быть вызов Finish

Синтаксис

[Visual Basic 6]
Sub Start ( _
   ByVal Caption As String, _
   [ByVal AfterRestoreHandler As IUndoRestoreAfter = 0], _
   [ByVal Cookie As Long = 0] _
)

[Delphi]
procedure Start(
   const Caption: WideString;
   const AfterRestoreHandler: IUndoRestoreAfter;
   const Cookie: Integer
)

Описание параметров

Caption
[in] Название группы операций, которое будет появляться в выпадающем списке
AfterRestoreHandler
[in] Обработчик события, который будет вызван после окончания отката группы операций
Cookie
[in] Дополнительное значение, передаваемое обработчики события, вызываемого после окончания отката группы операций

Смотри также

Interface IUndoRestoreAfter, Class UndoManager, Group Менеджер откатов


UndoManager.Undo (метод)

Отменить одну группу операций

Синтаксис

[Visual Basic 6]
Sub Undo ( _
   [ByVal GroupCount As Long = 1] _
)

[Delphi]
procedure Undo(
   const GroupCount: Integer
)

Описание параметров

GroupCount
[in] Количество групп операций, которые надо отменить

Смотри также

Class UndoManager, Group Менеджер откатов


Класс UniConnection

Параметры подключения к абстрактной базе данных

Наследование

UniConnectionParameters Class UniConnection

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.UniConnection

ClassID = {601D0005-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property ConnectTimeout | Максимальное время ожидания соединения с базой данных в секундах (не доступно для InterBase и SQLite; входит в состав SpecificOptions как параметр "ConnectionTimeout = seconds")
Property DatabaseName | Имя базы данных (не имеет смысла Oracle, DB2 - там используется только имя сервера)
Property Password | Пароль (не используется для Microsoft SQL Server, если UseNTAuthorization = True)
Property SavePassword | Запоминать ли пароль в реестре для входе в базу при следующем запуске приложения
Property SaveUserName | Запоминать ли имя пользователя в реестре для входе в базу при следующем запуске приложения
Property ServerName | Имя сервера (не имеет смысла для SQLite)
Property ServerPort | Номер порта на сервере (имеет смысл только для PostgreSQL, MySQL и Sybase)
Property ServerType | Тип сервера данных и, соответственно, диалекта языка SQL (Microsoft SQL Server, Oracle, PostgreSQL...)
Property UseNTAuthorization | Использовать ли встроенную безопасность Windows NT при подключении к базе (только при подключении к Microsoft SQL Server; входит в состав SpecificOptions как параметр "Authentication = auWindows или auServer"
Property UserName | Имя пользователя (не используется для Microsoft SQL Server, если UseNTAuthorization = True)

Методы класса

Имя | Описание
Method Connect | Подключиться к базе данных. Ничего не будет происходить, если подключение уже было установлено
Method Disconnect | Отключиться от базы данных
Method SetupDialogCustom | Вызвать диалог настройки подключения к базе данных и изменить ConnectionString. Возвращает True, если были внесены изменения

Смотри также

Enum ServerTypeConstants


UniConnection.ConnectTimeout (свойство)

Максимальное время ожидания соединения с базой данных в секундах (не доступно для InterBase и SQLite; входит в состав SpecificOptions как параметр "ConnectionTimeout = seconds")

Синтаксис

[Visual Basic 6]
Property ConnectTimeout As Long

[Delphi]
property ConnectTimeout: Integer

Смотри также

Class UniConnection


UniConnection.DatabaseName (свойство)

Имя базы данных (не имеет смысла Oracle, DB2 - там используется только имя сервера)

Синтаксис

[Visual Basic 6]
Property DatabaseName As String

[Delphi]
property DatabaseName: WideString

Смотри также

Class UniConnection


UniConnection.Password (свойство)

Пароль (не используется для Microsoft SQL Server, если UseNTAuthorization = True)

Синтаксис

[Visual Basic 6]
Property Password As String

[Delphi]
property Password: WideString

Смотри также

Class UniConnection


UniConnection.SavePassword (свойство)

Запоминать ли пароль в реестре для входе в базу при следующем запуске приложения

Синтаксис

[Visual Basic 6]
Property SavePassword As Boolean

[Delphi]
property SavePassword: WordBool

Смотри также

Class UniConnection


UniConnection.SaveUserName (свойство)

Запоминать ли имя пользователя в реестре для входе в базу при следующем запуске приложения

Синтаксис

[Visual Basic 6]
Property SaveUserName As Boolean

[Delphi]
property SaveUserName: WordBool

Смотри также

Class UniConnection


UniConnection.ServerName (свойство)

Имя сервера (не имеет смысла для SQLite)

Синтаксис

[Visual Basic 6]
Property ServerName As String

[Delphi]
property ServerName: WideString

Смотри также

Class UniConnection


UniConnection.ServerPort (свойство)

Номер порта на сервере (имеет смысл только для PostgreSQL, MySQL и Sybase)

Синтаксис

[Visual Basic 6]
Property ServerPort As Long

[Delphi]
property ServerPort: Integer

Смотри также

Class UniConnection


UniConnection.ServerType (свойство)

Тип сервера данных и, соответственно, диалекта языка SQL (Microsoft SQL Server, Oracle, PostgreSQL...)

Синтаксис

[Visual Basic 6]
Property ServerType As ServerTypeConstants

[Delphi]
property ServerType: ServerTypeConstants

Смотри также

Enum ServerTypeConstants, Class UniConnection


UniConnection.UseNTAuthorization (свойство)

Использовать ли встроенную безопасность Windows NT при подключении к базе (только при подключении к Microsoft SQL Server; входит в состав SpecificOptions как параметр "Authentication = auWindows или auServer"

Синтаксис

[Visual Basic 6]
Property UseNTAuthorization As Boolean

[Delphi]
property UseNTAuthorization: WordBool

Смотри также

Class UniConnection


UniConnection.UserName (свойство)

Имя пользователя (не используется для Microsoft SQL Server, если UseNTAuthorization = True)

Синтаксис

[Visual Basic 6]
Property UserName As String

[Delphi]
property UserName: WideString

Смотри также

Class UniConnection


UniConnection.Connect (метод)

Подключиться к базе данных. Ничего не будет происходить, если подключение уже было установлено

Синтаксис

[Visual Basic 6]
Sub Connect

[Delphi]
procedure Connect

Смотри также

Class UniConnection


UniConnection.Disconnect (метод)

Отключиться от базы данных

Синтаксис

[Visual Basic 6]
Sub Disconnect

[Delphi]
procedure Disconnect

Смотри также

Class UniConnection


UniConnection.SetupDialogCustom (метод)

Вызвать диалог настройки подключения к базе данных и изменить ConnectionString. Возвращает True, если были внесены изменения

Синтаксис

[Visual Basic 6]
Function SetupDialogCustom ( _
   [ByVal DialogCaption As String = ""] _
) As Boolean

[Delphi]
function SetupDialogCustom(
   const DialogCaption: WideString
): WordBool

Описание параметров

DialogCaption
[in] Заголовок окна настройки подключения к базе данных

Возвращаемое значение

Функция возвращает значение типа Boolean.

Смотри также

Class UniConnection


Класс UniConnectionParameters

Параметры подключения к абстрактной базе данных

Наследование

UniConnectionParameters Class UniConnection

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.UniConnectionParameters

ClassID = {601D0003-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property ConnectTimeout | Максимальное время ожидания соединения с базой данных в секундах (не доступно для InterBase и SQLite; входит в состав SpecificOptions как параметр "ConnectionTimeout = seconds")
Property DatabaseName | Имя базы данных (не имеет смысла Oracle, DB2 - там используется только имя сервера)
Property Password | Пароль (не используется для Microsoft SQL Server, если UseNTAuthorization = True)
Property SavePassword | Запоминать ли пароль в реестре для входе в базу при следующем запуске приложения
Property SaveUserName | Запоминать ли имя пользователя в реестре для входе в базу при следующем запуске приложения
Property ServerName | Имя сервера (не имеет смысла для SQLite)
Property ServerPort | Номер порта на сервере (имеет смысл только для PostgreSQL, MySQL и Sybase)
Property ServerType | Тип сервера данных и, соответственно, диалекта языка SQL (Microsoft SQL Server, Oracle, PostgreSQL...)
Property UseNTAuthorization | Использовать ли встроенную безопасность Windows NT при подключении к базе (только при подключении к Microsoft SQL Server; входит в состав SpecificOptions как параметр "Authentication = auWindows или auServer"
Property UserName | Имя пользователя (не используется для Microsoft SQL Server, если UseNTAuthorization = True)

Методы класса

Имя | Описание
Method SetupDialogCustom | Вызвать диалог настройки подключения к базе данных и изменить ConnectionString. Возвращает True, если были внесены изменения

Где используется

Класс | Член класса
Class LinkedUniDatabase | Property ConnectionParameters (свойство)

Смотри также

Enum ServerTypeConstants


UniConnectionParameters.ConnectTimeout (свойство)

Максимальное время ожидания соединения с базой данных в секундах (не доступно для InterBase и SQLite; входит в состав SpecificOptions как параметр "ConnectionTimeout = seconds")

Синтаксис

[Visual Basic 6]
Property ConnectTimeout As Long

[Delphi]
property ConnectTimeout: Integer

Смотри также

Class UniConnectionParameters


UniConnectionParameters.DatabaseName (свойство)

Имя базы данных (не имеет смысла Oracle, DB2 - там используется только имя сервера)

Синтаксис

[Visual Basic 6]
Property DatabaseName As String

[Delphi]
property DatabaseName: WideString

Смотри также

Class UniConnectionParameters


UniConnectionParameters.Password (свойство)

Пароль (не используется для Microsoft SQL Server, если UseNTAuthorization = True)

Синтаксис

[Visual Basic 6]
Property Password As String

[Delphi]
property Password: WideString

Смотри также

Class UniConnectionParameters


UniConnectionParameters.SavePassword (свойство)

Запоминать ли пароль в реестре для входе в базу при следующем запуске приложения

Синтаксис

[Visual Basic 6]
Property SavePassword As Boolean

[Delphi]
property SavePassword: WordBool

Смотри также

Class UniConnectionParameters


UniConnectionParameters.SaveUserName (свойство)

Запоминать ли имя пользователя в реестре для входе в базу при следующем запуске приложения

Синтаксис

[Visual Basic 6]
Property SaveUserName As Boolean

[Delphi]
property SaveUserName: WordBool

Смотри также

Class UniConnectionParameters


UniConnectionParameters.ServerName (свойство)

Имя сервера (не имеет смысла для SQLite)

Синтаксис

[Visual Basic 6]
Property ServerName As String

[Delphi]
property ServerName: WideString

Смотри также

Class UniConnectionParameters


UniConnectionParameters.ServerPort (свойство)

Номер порта на сервере (имеет смысл только для PostgreSQL, MySQL и Sybase)

Синтаксис

[Visual Basic 6]
Property ServerPort As Long

[Delphi]
property ServerPort: Integer

Смотри также

Class UniConnectionParameters


UniConnectionParameters.ServerType (свойство)

Тип сервера данных и, соответственно, диалекта языка SQL (Microsoft SQL Server, Oracle, PostgreSQL...)

Синтаксис

[Visual Basic 6]
Property ServerType As ServerTypeConstants

[Delphi]
property ServerType: ServerTypeConstants

Смотри также

Enum ServerTypeConstants, Class UniConnectionParameters


UniConnectionParameters.UseNTAuthorization (свойство)

Использовать ли встроенную безопасность Windows NT при подключении к базе (только при подключении к Microsoft SQL Server; входит в состав SpecificOptions как параметр "Authentication = auWindows или auServer"

Синтаксис

[Visual Basic 6]
Property UseNTAuthorization As Boolean

[Delphi]
property UseNTAuthorization: WordBool

Смотри также

Class UniConnectionParameters


UniConnectionParameters.UserName (свойство)

Имя пользователя (не используется для Microsoft SQL Server, если UseNTAuthorization = True)

Синтаксис

[Visual Basic 6]
Property UserName As String

[Delphi]
property UserName: WideString

Смотри также

Class UniConnectionParameters


UniConnectionParameters.SetupDialogCustom (метод)

Вызвать диалог настройки подключения к базе данных и изменить ConnectionString. Возвращает True, если были внесены изменения

Синтаксис

[Visual Basic 6]
Function SetupDialogCustom ( _
   [ByVal DialogCaption As String = ""] _
) As Boolean

[Delphi]
function SetupDialogCustom(
   const DialogCaption: WideString
): WordBool

Описание параметров

DialogCaption
[in] Заголовок окна настройки подключения к базе данных

Возвращаемое значение

Функция возвращает значение типа Boolean.

Смотри также

Class UniConnectionParameters


Класс VectorContainer

Контейнер изображений с векторными элементами

Наследование

CustomContainer Class VectorContainer

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property ActiveMode | Текущий обработчик режима работы с контейнером
Property BitmapDC (только для чтения) | DC текущего изображения в контейнере
Property BitmapHandle (только для чтения) | HBitmap текущего изображения в контейнере
Property BitmapHeight (только для чтения) | Высота временного изображения
Property BitmapWidth (только для чтения) | Ширина временного изображения
Property BorderStyle | Тип рамки контейнера
Property ContentDeviceSurface (только для чтения) | Поверхность для рисования в памяти
Property ContentModelSurface (только для чтения) | Поверхность для рисования в памяти
Property CurrentLayer | Выбранный слой
Property CurrentPopupFigure (только для чтения) | Текущий подсвечиваемый элемент в локальном меню
Property CurrentPopupFigureLayer (только для чтения) | Слой текущего подсвечиваемого элемента в локальном меню
Property CurrentPopupPoint (только для чтения) | Точка вызова локального меню для текущего подсвечиваемого элемента
Property DrawGroupIndex (только для чтения) | Группа типов элементов при рисовании элементов
Property DrawItemIndex (только для чтения) | Индекс типа элемента в группе при рисовании элементов
Property EditedFigure | Текущий редактируемый элемент, = 0, если выделен не 1 элемент (0 или >1)
Property EditedFigures (только для чтения) | Массив текущих редактируемых фигур
Property EditedFiguresCount (только для чтения) | Количество текущих редактируемых элементов
Property EditedLayer | Редактируемый слой
Property EditPhase | Фаза режима редактирования контейнера
Property ForceCursor | Курсор, который должен обязательно выставляться в настоящий момент
Property GridColor | Цвет сетки (используется, если нет специальных установок в текущем слое)
Property GridSizeX | Размер сетки по X (используется, если нет специальных установок в текущем слое)
Property GridSizeY | Размер сетки по Y (используется, если нет специальных установок в текущем слое)
Property GridType | Тип сетки (используется, если нет специальных установок в текущем слое)
Property Height (только для чтения) | Высота контейнера карты на экране в пикселях
Property ImageFlatExtent (только для чтения) | Часть карты, отображаемая в памяти
Property LastViewOrg (только для чтения) | Последний левый верхний угол (=Nothing, если нет предыдущего положения)
Property LastViewScale (только для чтения) | Последний из масштабов (=0, если нет предыдущего положения)
Property MasterContainer | Главный контейнер по отношению к данному
Property MemoryDeviceSurface (только для чтения) | Поверхность для рисования на экране без мельтешения в событии BeforePaint
Property MemoryModelSurface (только для чтения) | Поверхность для рисования на экране без мельтешения в событии BeforePaint
Property MultiPointTracker | Символ, используемый для трассировки мультиточек
Property RegisteredModeCount (только для чтения) | Общее число зарегистрированных режимов работы контейнера
Property RegisteredModes (только для чтения) | Массив зарегистрированных режимов работы контейнера
Property ScreenDeviceSurface (только для чтения) | Поверхность для рисования сразу на экране
Property ScreenModelSurface (только для чтения) | Поверхность для рисования сразу на экране
Property ScrollTracking | Трэккинг скроллера изображением
Property SelectionExtent (только для чтения) | Получить размер прямоугольника выделенных фигур
Property ShowGrid | Показывать ли сетку
Property ShowScrollBars | Показывать полосы скроллинга
Property TrackStopMode | Способ остановки при трассировке полилиний, полигонов, мультиточек
Property UsedGridColor (только для чтения) | Реально используемый в настоящее время цвет сетки
Property UsedGridSizeX (только для чтения) | Реально используемый в настоящее время размер сетки по X
Property UsedGridSizeY (только для чтения) | Реально используемый в настоящее время размер сетки по Y
Property UsedGridType (только для чтения) | Реально используемый в настоящее время тип сетки
Property ViewOrigin | Плоские координаты верхнего окна карты, выводимого на экран
Property ViewScale | Масштаб вывода: отношение длины на карте к устройству
Property VisibleFlatCenter | Координаты видимого центра карты
Property VisibleFlatExtent | Часть карты, отображаемая на экране
Property Width (только для чтения) | Ширина контейнера карты на экране в пикселях
Property WindowDC (только для чтения) | DC контейнера карты
Property WindowHandle (только для чтения) | HWnd контейнера карты

Методы класса

Имя | Описание
Method CanLoadBlockFromFile | Возможность загрузки блока из файла
Method CanPaste | Можно ли вставить из буфера обмена
Method CanSaveBlockToFile | Возможность сохранения блока в файл
Method CheckInView | Убедиться, что прямоугольник карты попадает в область видимости
Method CopyToClipboard | Копировать выделенные объекты в буфер обмена
Method CutToClipboard | Вырезать выделенные объекты в буфер обмена
Method DeleteSelection | Удалить всё выделенный объекты
Method DisableRefresh | Запретить перерисовку изображения
Method EditSelected | Все элементы текущего слоя, помеченные как выделенные, поместить в список редактируемых
Method EnableRefresh | Разрешить перерисовку изображения
Method FlashDevicePoint | Подсвечивает миганием точку, заданную в целочисленной системе координат окна контейнера
Method FlashDevicePoints | Подсвечивает миганием массив точек, заданных в целочисленной системе координат окна контейнера
Method FlashFigure | Подмигнуть одну фигуру на одном слое
Method FlashFigures | Подмигнуть список фигур на одном слое
Method FlashFlatPoint | Подсвечивает миганием точку, заданную в вещественной плоской системе координат окна контейнера
Method FlashFlatPoints | Подсвечивает миганием массив точек, заданных в вещественной плоской системе координат окна контейнера
Method FlashModelPoint | Подсвечивает миганием точку, заданную в вещественной системе координат модели
Method FlashModelPoints | Подсвечивает миганием массив точек, заданных в вещественной системе координат модели
Method FlashSelected | Подсветить на карте все выделенные объекты всех слоев карты
Method FormatByExample | Сформатировать элементы по образцу текущего выделенного
Method HighlightDevicePoint | Показывает последовательностью сужающихся концентрических окружностей точку, заданную в целочисленной системе координат окна контейнера
Method HighlightFlatPoint | Показывает последовательностью сужающихся концентрических окружностей точку, заданную в вещественной плоской системе координат окна контейнера
Method HighlightModelPoint | Подсвечивает миганием точку, заданную в вещественной системе координат модели
Method Invalidate | Обновить изображение контейнера, как только появится свободное процессорное время
Method InvertSelected | Инвертировать выделение на текущем слое карты
Method LoadBlockFromFile | Загрузить блок из файла
Method LockRefresh | Заблокировать перерисовку изображения (после этого метода обязательно надо будет вызвать UnlockRefresh)
Method MasterPan | Панорамировать видимое изображение главного контейнера
Method MasterSelect | Выбрать видимое изображение главного контейнера
Method MouseCapture | Захват мыши
Method Pan | Панорамировать изображение с помощью руки
Method PanTo | Сдвинуть изображение в заданном направлении (LargeStep - с большим шагом)
Method PanToPoint | Немного сдвинуть изображение в направлении указанной точки. Реально данный метод вызывает метод PanTo с соответствующими параметрами
Method PasteFromClipboard | Вставить объекты из буфера обмена и сделать их текущими выделенными
Method PrintView | Распечатать на принтере на одной странице видимую часть изображения
Method RefreshContent | Указать, что надо перерисовать изображение в памяти
Method RegisterMode | Зарегистрировать новый режим работы контейнера с указанным обработчиком событий
Method Repaint | Обновить изображение контейнера немедленно
Method RestoreLastView | Восстановить последний запомненный масштаб из списка
Method SaveBlockToFile | Cохранить блок в файл
Method SaveCurrentView | Сохранить текущий масштаб в списке
Method SelectActiveMode | Выбрать текущий обработчик режима работы с контейнером
Method SelectActiveModeByName | Выбрать текущий обработчик режима работы с контейнером
Method SelectAll | Выделить все объекты на текущем слое карты
Method StopEdit | Прекратить редактирование элементов
Method SwitchAtLayer | Переключить состояние элемента заданного слоя чертежа в заданной точке карты
Method SwitchFigure | Переключить состояние элемента любого слоя чертежа в заданной точке карты
Method TrackFixedRect | Оттрасировать прямоугольник заданного размера на карте
Method TrackFlatCircle | Оттрасировать окружность на карте в плоских координатах
Method TrackFlatEllipse | Оттрасировать эллипс на карте в плоских координатах
Method TrackFlatFillCircle | Оттрасировать залитый круг на карте в плоских координатах
Method TrackFlatFillEllipse | Оттрасировать залитый эллипс на карте в плоских координатах
Method TrackFlatFillPolygon | Оттрасировать залитый полигон на карте в плоских координатах
Method TrackFlatFillRectangle | Оттрасировать залитый прямоугольник на карте в плоских координатах
Method TrackFlatMultipoint | Оттрасировать мультиточку на карте в плоских координатах
Method TrackFlatPoint | Оттрасировать точку на карте в плоских координатах
Method TrackFlatPolygon | Оттрасировать полигон на карте в плоских координатах
Method TrackFlatPolyline | Оттрасировать полилинию на карте в плоских координатах
Method TrackFlatRectangle | Оттрасировать прямоугольник на карте в плоских координатах
Method TrackFlatSegment | Оттрасировать отрезок на карте в плоских координатах
Method TrackModelCircle | Оттрасировать окружность на карте в модельных координатах
Method TrackModelEllipse | Оттрасировать эллипс на карте в модельных координатах
Method TrackModelFillCircle | Оттрасировать залитый круг на карте в модельных координатах
Method TrackModelFillEllipse | Оттрасировать залитый эллипс на карте в модельных координатах
Method TrackModelFillPolygon | Оттрасировать залитый полигон на карте в модельных координатах
Method TrackModelFillRectangle | Оттрасировать залитый прямоугольник на карте в модельных координатах
Method TrackModelMultipoint | Оттрасировать мультиточку на карте в модельных координатах
Method TrackModelPoint | Оттрасировать точку на карте в модельных координатах
Method TrackModelPolygon | Оттрасировать полигон на карте в модельных координатах
Method TrackModelPolyline | Оттрасировать полилинию на карте в модельных координатах
Method TrackModelRectangle | Оттрасировать прямоугольник на карте в модельных координатах
Method TrackModelSegment | Оттрасировать отрезок на карте в модельных координатах
Method TrackZoomIn | Укрупнить изображение с помощью трассировки прямоугольника
Method TrackZoomOut | Уменьшить изображение с помощью трассировки прямоугольника
Method TrackZoomRect | Оттрасировать прямоугольник, пропорциональный заданным высоте и ширине
Method TrackZoomRectangle | Оттрасировать прямоугольник, пропорциональный клиентскому размеру данного контейнера
Method UnlockRefresh | Разблокировать перерисовку изображения (обязательно вызывается после LockRefresh)
Method UnselectAll | Убрать выделение всех объектов на текущем слое карты
Method UpdateContentAll | Полностью обновить изображение
Method UpdateCursor | Обновить курсор
Method UpdateScrollbars | Обновить содержимое скроллеров
Method ZoomInCenter | Укрупнить изображение в центре в 5/4 раза
Method ZoomOutCenter | Уменьшить изображение в центре в 5/4 раза
Method ZoomToAll | Вписать в окно всю карту
Method ZoomToExtent | Вписать в окно заданный прямоугольник. Данный метод по сути эквивалентен методу ZoomToRect, у которого задана анимация изображения
Method ZoomToPoint | Смасштабировать в заданный масштаб с точкой в центре
Method ZoomToRect | Смасштабировать в заданное окно
Method ZoomToScale | Смасштабировать относительно центра окна до заданного масштаба
Method ZoomToView | Смасштабировать в заданное окно

Где используется

Класс | Член класса
Class LayerRequest | Method Execute (метод)
Class RequestVariable | Method InputValue (метод)
Class VectorLayer | Method ExecuteFigureVerb (метод) Method GetFigureVerb (метод) Method HotLinkAction (метод) Method HotLinkExists (метод)

Смотри также

Enum BorderConstants, Class Collection, Class CompositionLayer, Enum ContainerGridTypeConstants, Class ContainerModeHandler, Class ContainerSurface, Enum CursorConstants, Class CustomContainer, Enum EditPhaseConstants, Class Figure, Class FlatPoint, Class FlatRect, Interface IContainerModeEvents, Class ModelPoint, Class ModelRect, Enum PanDirectionConstants, Enum PasteFromClipboardConstants, Class Point, Class ShapeMultipoint, Class ShapePolygon, Class ShapePolyline, Enum ShapeTypeConstants, Enum SwitchItemStateConstants, Enum SwitchItemTypesConstants, Enum TrackerConstants, Enum TrackingStopConstants, Group Контейнеры изображений


VectorContainer.ActiveMode (свойство)

Текущий обработчик режима работы с контейнером

Синтаксис

[Visual Basic 6]
Property ActiveMode As ContainerModeHandler

[Delphi]
property ActiveMode: ContainerModeHandler

Смотри также

Class ContainerModeHandler, Class VectorContainer, Group Контейнеры изображений


VectorContainer.BitmapDC (свойство)

DC текущего изображения в контейнере

Синтаксис

[Visual Basic 6]
ReadOnly Property BitmapDC As OLE_HANDLE

[Delphi]
{только для чтения} property BitmapDC: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.BitmapHandle (свойство)

HBitmap текущего изображения в контейнере

Синтаксис

[Visual Basic 6]
ReadOnly Property BitmapHandle As OLE_HANDLE

[Delphi]
{только для чтения} property BitmapHandle: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.BitmapHeight (свойство)

Высота временного изображения

Синтаксис

[Visual Basic 6]
ReadOnly Property BitmapHeight As Long

[Delphi]
{только для чтения} property BitmapHeight: Integer

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.BitmapWidth (свойство)

Ширина временного изображения

Синтаксис

[Visual Basic 6]
ReadOnly Property BitmapWidth As Long

[Delphi]
{только для чтения} property BitmapWidth: Integer

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.BorderStyle (свойство)

Тип рамки контейнера

Синтаксис

[Visual Basic 6]
Property BorderStyle As BorderConstants

[Delphi]
property BorderStyle: BorderConstants

Смотри также

Enum BorderConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ContentDeviceSurface (свойство)

Поверхность для рисования в памяти

Синтаксис

[Visual Basic 6]
ReadOnly Property ContentDeviceSurface As ContainerSurface

[Delphi]
{только для чтения} property ContentDeviceSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ContentModelSurface (свойство)

Поверхность для рисования в памяти

Синтаксис

[Visual Basic 6]
ReadOnly Property ContentModelSurface As ContainerSurface

[Delphi]
{только для чтения} property ContentModelSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class VectorContainer, Group Контейнеры изображений


VectorContainer.CurrentLayer (свойство)

Выбранный слой

Синтаксис

[Visual Basic 6]
Property CurrentLayer As CompositionLayer

[Delphi]
property CurrentLayer: CompositionLayer

Смотри также

Class CompositionLayer, Class VectorContainer, Group Контейнеры изображений


VectorContainer.CurrentPopupFigure (свойство)

Текущий подсвечиваемый элемент в локальном меню

Синтаксис

[Visual Basic 6]
ReadOnly Property CurrentPopupFigure As Figure

[Delphi]
{только для чтения} property CurrentPopupFigure: Figure

Смотри также

Class Figure, Class VectorContainer, Group Контейнеры изображений


VectorContainer.CurrentPopupFigureLayer (свойство)

Слой текущего подсвечиваемого элемента в локальном меню

Синтаксис

[Visual Basic 6]
ReadOnly Property CurrentPopupFigureLayer As VectorLayer

[Delphi]
{только для чтения} property CurrentPopupFigureLayer: VectorLayer

Смотри также

Class VectorContainer, Class VectorLayer, Group Контейнеры изображений


VectorContainer.CurrentPopupPoint (свойство)

Точка вызова локального меню для текущего подсвечиваемого элемента

Синтаксис

[Visual Basic 6]
ReadOnly Property CurrentPopupPoint As Point

[Delphi]
{только для чтения} property CurrentPopupPoint: Point

Смотри также

Class Point, Class VectorContainer, Group Контейнеры изображений


VectorContainer.DrawGroupIndex (свойство)

Группа типов элементов при рисовании элементов

Синтаксис

[Visual Basic 6]
ReadOnly Property DrawGroupIndex As Long

[Delphi]
{только для чтения} property DrawGroupIndex: Integer

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.DrawItemIndex (свойство)

Индекс типа элемента в группе при рисовании элементов

Синтаксис

[Visual Basic 6]
ReadOnly Property DrawItemIndex As Long

[Delphi]
{только для чтения} property DrawItemIndex: Integer

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.EditedFigure (свойство)

Текущий редактируемый элемент, = 0, если выделен не 1 элемент (0 или >1)

Синтаксис

[Visual Basic 6]
Property EditedFigure As Figure

[Delphi]
property EditedFigure: Figure

Смотри также

Class Figure, Class VectorContainer, Group Контейнеры изображений


VectorContainer.EditedFigures (свойство)

Массив текущих редактируемых фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property EditedFigures As Figure

[Delphi]
{только для чтения} property EditedFigures: Figure

Смотри также

Class Figure, Class VectorContainer, Group Контейнеры изображений


VectorContainer.EditedFiguresCount (свойство)

Количество текущих редактируемых элементов

Синтаксис

[Visual Basic 6]
ReadOnly Property EditedFiguresCount As Long

[Delphi]
{только для чтения} property EditedFiguresCount: Integer

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.EditedLayer (свойство)

Редактируемый слой

Синтаксис

[Visual Basic 6]
Property EditedLayer As VectorLayer

[Delphi]
property EditedLayer: VectorLayer

Смотри также

Class VectorContainer, Class VectorLayer, Group Контейнеры изображений


VectorContainer.EditPhase (свойство)

Фаза режима редактирования контейнера

Синтаксис

[Visual Basic 6]
Property EditPhase As EditPhaseConstants

[Delphi]
property EditPhase: EditPhaseConstants

Смотри также

Enum EditPhaseConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ForceCursor (свойство)

Курсор, который должен обязательно выставляться в настоящий момент

Синтаксис

[Visual Basic 6]
Property ForceCursor As CursorConstants

[Delphi]
property ForceCursor: CursorConstants

Смотри также

Enum CursorConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.GridColor (свойство)

Цвет сетки (используется, если нет специальных установок в текущем слое)

Синтаксис

[Visual Basic 6]
Property GridColor As OLE_COLOR

[Delphi]
property GridColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.GridSizeX (свойство)

Размер сетки по X (используется, если нет специальных установок в текущем слое)

Синтаксис

[Visual Basic 6]
Property GridSizeX As Double

[Delphi]
property GridSizeX: Double

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.GridSizeY (свойство)

Размер сетки по Y (используется, если нет специальных установок в текущем слое)

Синтаксис

[Visual Basic 6]
Property GridSizeY As Double

[Delphi]
property GridSizeY: Double

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.GridType (свойство)

Тип сетки (используется, если нет специальных установок в текущем слое)

Синтаксис

[Visual Basic 6]
Property GridType As ContainerGridTypeConstants

[Delphi]
property GridType: ContainerGridTypeConstants

Смотри также

Enum ContainerGridTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.Height (свойство)

Высота контейнера карты на экране в пикселях

Синтаксис

[Visual Basic 6]
ReadOnly Property Height As Long

[Delphi]
{только для чтения} property Height: Integer

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.ImageFlatExtent (свойство)

Часть карты, отображаемая в памяти

Синтаксис

[Visual Basic 6]
ReadOnly Property ImageFlatExtent As FlatRect

[Delphi]
{только для чтения} property ImageFlatExtent: FlatRect

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.LastViewOrg (свойство)

Последний левый верхний угол (=Nothing, если нет предыдущего положения)

Синтаксис

[Visual Basic 6]
ReadOnly Property LastViewOrg As ModelPoint

[Delphi]
{только для чтения} property LastViewOrg: ModelPoint

Смотри также

Class ModelPoint, Class VectorContainer, Group Контейнеры изображений


VectorContainer.LastViewScale (свойство)

Последний из масштабов (=0, если нет предыдущего положения)

Синтаксис

[Visual Basic 6]
ReadOnly Property LastViewScale As Double

[Delphi]
{только для чтения} property LastViewScale: Double

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.MasterContainer (свойство)

Главный контейнер по отношению к данному

Синтаксис

[Visual Basic 6]
Property MasterContainer As CustomContainer

[Delphi]
property MasterContainer: CustomContainer

Смотри также

Class CustomContainer, Class VectorContainer, Group Контейнеры изображений


VectorContainer.MemoryDeviceSurface (свойство)

Поверхность для рисования на экране без мельтешения в событии BeforePaint

Синтаксис

[Visual Basic 6]
ReadOnly Property MemoryDeviceSurface As ContainerSurface

[Delphi]
{только для чтения} property MemoryDeviceSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class VectorContainer, Group Контейнеры изображений


VectorContainer.MemoryModelSurface (свойство)

Поверхность для рисования на экране без мельтешения в событии BeforePaint

Синтаксис

[Visual Basic 6]
ReadOnly Property MemoryModelSurface As ContainerSurface

[Delphi]
{только для чтения} property MemoryModelSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class VectorContainer, Group Контейнеры изображений


VectorContainer.MultiPointTracker (свойство)

Символ, используемый для трассировки мультиточек

Синтаксис

[Visual Basic 6]
Property MultiPointTracker As TrackerConstants

[Delphi]
property MultiPointTracker: TrackerConstants

Смотри также

Enum TrackerConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.RegisteredModeCount (свойство)

Общее число зарегистрированных режимов работы контейнера

Синтаксис

[Visual Basic 6]
ReadOnly Property RegisteredModeCount As Long

[Delphi]
{только для чтения} property RegisteredModeCount: Integer

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.RegisteredModes (свойство)

Массив зарегистрированных режимов работы контейнера

Синтаксис

[Visual Basic 6]
ReadOnly Property RegisteredModes As ContainerModeHandler

[Delphi]
{только для чтения} property RegisteredModes: ContainerModeHandler

Смотри также

Class ContainerModeHandler, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ScreenDeviceSurface (свойство)

Поверхность для рисования сразу на экране

Синтаксис

[Visual Basic 6]
ReadOnly Property ScreenDeviceSurface As ContainerSurface

[Delphi]
{только для чтения} property ScreenDeviceSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ScreenModelSurface (свойство)

Поверхность для рисования сразу на экране

Синтаксис

[Visual Basic 6]
ReadOnly Property ScreenModelSurface As ContainerSurface

[Delphi]
{только для чтения} property ScreenModelSurface: ContainerSurface

Смотри также

Class ContainerSurface, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ScrollTracking (свойство)

Трэккинг скроллера изображением

Синтаксис

[Visual Basic 6]
Property ScrollTracking As Boolean

[Delphi]
property ScrollTracking: WordBool

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.SelectionExtent (свойство)

Получить размер прямоугольника выделенных фигур

Синтаксис

[Visual Basic 6]
ReadOnly Property SelectionExtent As ModelRect

[Delphi]
{только для чтения} property SelectionExtent: ModelRect

Смотри также

Class ModelRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ShowGrid (свойство)

Показывать ли сетку

Синтаксис

[Visual Basic 6]
Property ShowGrid As Boolean

[Delphi]
property ShowGrid: WordBool

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.ShowScrollBars (свойство)

Показывать полосы скроллинга

Синтаксис

[Visual Basic 6]
Property ShowScrollBars As Boolean

[Delphi]
property ShowScrollBars: WordBool

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackStopMode (свойство)

Способ остановки при трассировке полилиний, полигонов, мультиточек

Синтаксис

[Visual Basic 6]
Property TrackStopMode As TrackingStopConstants

[Delphi]
property TrackStopMode: TrackingStopConstants

Смотри также

Enum TrackingStopConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.UsedGridColor (свойство)

Реально используемый в настоящее время цвет сетки

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedGridColor As OLE_COLOR

[Delphi]
{только для чтения} property UsedGridColor: OLE_COLOR

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.UsedGridSizeX (свойство)

Реально используемый в настоящее время размер сетки по X

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedGridSizeX As Double

[Delphi]
{только для чтения} property UsedGridSizeX: Double

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.UsedGridSizeY (свойство)

Реально используемый в настоящее время размер сетки по Y

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedGridSizeY As Double

[Delphi]
{только для чтения} property UsedGridSizeY: Double

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.UsedGridType (свойство)

Реально используемый в настоящее время тип сетки

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedGridType As ContainerGridTypeConstants

[Delphi]
{только для чтения} property UsedGridType: ContainerGridTypeConstants

Смотри также

Enum ContainerGridTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ViewOrigin (свойство)

Плоские координаты верхнего окна карты, выводимого на экран

Синтаксис

[Visual Basic 6]
Property ViewOrigin As FlatPoint

[Delphi]
property ViewOrigin: FlatPoint

Смотри также

Class FlatPoint, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ViewScale (свойство)

Масштаб вывода: отношение длины на карте к устройству

Синтаксис

[Visual Basic 6]
Property ViewScale As Double

[Delphi]
property ViewScale: Double

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.VisibleFlatCenter (свойство)

Координаты видимого центра карты

Синтаксис

[Visual Basic 6]
Property VisibleFlatCenter As FlatPoint

[Delphi]
property VisibleFlatCenter: FlatPoint

Смотри также

Class FlatPoint, Class VectorContainer, Group Контейнеры изображений


VectorContainer.VisibleFlatExtent (свойство)

Часть карты, отображаемая на экране

Синтаксис

[Visual Basic 6]
Property VisibleFlatExtent As FlatRect

[Delphi]
property VisibleFlatExtent: FlatRect

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.Width (свойство)

Ширина контейнера карты на экране в пикселях

Синтаксис

[Visual Basic 6]
ReadOnly Property Width As Long

[Delphi]
{только для чтения} property Width: Integer

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.WindowDC (свойство)

DC контейнера карты

Синтаксис

[Visual Basic 6]
ReadOnly Property WindowDC As OLE_HANDLE

[Delphi]
{только для чтения} property WindowDC: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.WindowHandle (свойство)

HWnd контейнера карты

Синтаксис

[Visual Basic 6]
ReadOnly Property WindowHandle As OLE_HANDLE

[Delphi]
{только для чтения} property WindowHandle: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.CanLoadBlockFromFile (метод)

Возможность загрузки блока из файла

Синтаксис

[Visual Basic 6]
Function CanLoadBlockFromFile As Boolean

[Delphi]
function CanLoadBlockFromFile: WordBool

Возвращаемое значение

Возвращает True, если в настоящее время можно загрузку данных из блока в текущий слой карты

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.CanPaste (метод)

Можно ли вставить из буфера обмена

Синтаксис

[Visual Basic 6]
Function CanPaste As Boolean

[Delphi]
function CanPaste: WordBool

Возвращаемое значение

Возвращает True, если в настоящее время можно вставить данные в текущий слой из буфера обмена

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.CanSaveBlockToFile (метод)

Возможность сохранения блока в файл

Синтаксис

[Visual Basic 6]
Function CanSaveBlockToFile As Boolean

[Delphi]
function CanSaveBlockToFile: WordBool

Возвращаемое значение

Возвращает True, если в настоящее время можно сохранить выделенные фигуры текущего слоя в виде блока в файл

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.CheckInView (метод)

Убедиться, что прямоугольник карты попадает в область видимости

Синтаксис

[Visual Basic 6]
Sub CheckInView ( _
   ByVal Rectangle As FlatRect, _
   [ByVal Animate As Boolean = False] _
)

[Delphi]
procedure CheckInView(
   const Rectangle: FlatRect;
   const Animate: WordBool
)

Описание параметров

Rectangle
[in] Прямоугольник, заданный в плоской системе координат контейнера
Animate
[in] Выполнять ли анимацию, если возникнет необходимость изменения видимой области изображения

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.CopyToClipboard (метод)

Копировать выделенные объекты в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CopyToClipboard

[Delphi]
procedure CopyToClipboard

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.CutToClipboard (метод)

Вырезать выделенные объекты в буфер обмена

Синтаксис

[Visual Basic 6]
Sub CutToClipboard

[Delphi]
procedure CutToClipboard

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.DeleteSelection (метод)

Удалить всё выделенный объекты

Синтаксис

[Visual Basic 6]
Sub DeleteSelection

[Delphi]
procedure DeleteSelection

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.DisableRefresh (метод)

Запретить перерисовку изображения

Синтаксис

[Visual Basic 6]
Sub DisableRefresh

[Delphi]
procedure DisableRefresh

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.EditSelected (метод)

Все элементы текущего слоя, помеченные как выделенные, поместить в список редактируемых

Синтаксис

[Visual Basic 6]
Sub EditSelected

[Delphi]
procedure EditSelected

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.EnableRefresh (метод)

Разрешить перерисовку изображения

Синтаксис

[Visual Basic 6]
Sub EnableRefresh

[Delphi]
procedure EnableRefresh

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.FlashDevicePoint (метод)

Подсвечивает миганием точку, заданную в целочисленной системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub FlashDevicePoint ( _
   ByVal X As Long, _
   ByVal Y As Long _
)

[Delphi]
procedure FlashDevicePoint(
   const X: Integer;
   const Y: Integer
)

Описание параметров

X
[in] Координата X подсвечиваемой точки в целочисленной системе координат окна контейнера
Y
[in] Координата Y подсвечиваемой точки в целочисленной системе координат окна контейнера

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.FlashDevicePoints (метод)

Подсвечивает миганием массив точек, заданных в целочисленной системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub FlashDevicePoints ( _
   ByVal Points() As Long _
)

[Delphi]
procedure FlashDevicePoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат подсвечиваемых точек в целочисленной системе координат окна контейнера. Точки в массиве задаются последовательно: X1,Y1,X2,Y2,...

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.FlashFigure (метод)

Подмигнуть одну фигуру на одном слое

Синтаксис

[Visual Basic 6]
Sub FlashFigure ( _
   ByVal Layer As VectorLayer, _
   ByVal Figure As Figure, _
   [ByVal CheckInView As Boolean = True], _
   [ByVal FlashNumber As Long = 2] _
)

[Delphi]
procedure FlashFigure(
   const Layer: VectorLayer;
   const Figure: Figure;
   const CheckInView: WordBool;
   const FlashNumber: Integer
)

Описание параметров

Layer
[in] Слой, в который входит фигура
Figure
[in] Подмигиваемая фигура
CheckInView
[in] Следует ли сдвинуть изображение, чтобы фигура оказалась целиком на экране
FlashNumber
[in] Количество подмигиваний

Смотри также

Class Figure, Class VectorContainer, Class VectorLayer, Group Контейнеры изображений


VectorContainer.FlashFigures (метод)

Подмигнуть список фигур на одном слое

Синтаксис

[Visual Basic 6]
Sub FlashFigures ( _
   ByVal Layer As VectorLayer, _
   ByVal Figures As Collection, _
   [ByVal CheckInView As Boolean = True], _
   [ByVal FlashNumber As Long = 2] _
)

[Delphi]
procedure FlashFigures(
   const Layer: VectorLayer;
   const Figures: Collection;
   const CheckInView: WordBool;
   const FlashNumber: Integer
)

Описание параметров

Layer
[in] Слой, в который входит фигура
Figures
[in] Список подмигиваемых фигур
CheckInView
[in] Следует ли сдвинуть изображение, чтобы все фигуры оказались на экране
FlashNumber
[in] Количество подмигиваний

Смотри также

Class Collection, Class VectorContainer, Class VectorLayer, Group Контейнеры изображений


VectorContainer.FlashFlatPoint (метод)

Подсвечивает миганием точку, заданную в вещественной плоской системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub FlashFlatPoint ( _
   ByVal FlatX As Double, _
   ByVal FlatY As Double _
)

[Delphi]
procedure FlashFlatPoint(
   const FlatX: Double;
   const FlatY: Double
)

Описание параметров

FlatX
[in] Координата X подсвечиваемой точки в вещественной плоской системе координат окна контейнера
FlatY
[in] Координата Y подсвечиваемой точки в вещественной плоской системе координат окна контейнера

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.FlashFlatPoints (метод)

Подсвечивает миганием массив точек, заданных в вещественной плоской системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub FlashFlatPoints ( _
   ByVal Points() As Double _
)

[Delphi]
procedure FlashFlatPoints(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив координат подсвечиваемых точек в вещественной плоской системе координат окна контейнера. Точки в массиве задаются последовательно: X1,Y1,X2,Y2,...

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.FlashModelPoint (метод)

Подсвечивает миганием точку, заданную в вещественной системе координат модели

Синтаксис

[Visual Basic 6]
Sub FlashModelPoint ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal Layer As Object = Nothing] _
)

[Delphi]
procedure FlashModelPoint(
   const ModelX: Double;
   const ModelY: Double;
   const Layer: IDispatch
)

Описание параметров

ModelX
[in] Координата X подсвечиваемой точки в вещественной системе координат модели
ModelY
[in] Координата Y подсвечиваемой точки в вещественной системе координат модели
Layer
[in] Текущий слой карты, в системе координат которого задаются координаты показываемой точки. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.FlashModelPoints (метод)

Подсвечивает миганием массив точек, заданных в вещественной системе координат модели

Синтаксис

[Visual Basic 6]
Sub FlashModelPoints ( _
   ByVal Points() As Double, _
   [ByVal Layer As Object = Nothing] _
)

[Delphi]
procedure FlashModelPoints(
   const Points: PSafeArray;
   const Layer: IDispatch
)

Описание параметров

Points
[in] Массив координат подсвечиваемых точек в вещественной плоской системе координат окна контейнера. Точки в массиве задаются последовательно: X1,Y1,X2,Y2,...
Layer
[in] Текущий слой карты, в системе координат которого задаются координаты показываемой точки. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.FlashSelected (метод)

Подсветить на карте все выделенные объекты всех слоев карты

Синтаксис

[Visual Basic 6]
Sub FlashSelected ( _
   [ByVal CheckInView As Boolean = False], _
   [ByVal FlashNumber As Long = 2] _
)

[Delphi]
procedure FlashSelected(
   const CheckInView: WordBool;
   const FlashNumber: Integer
)

Описание параметров

CheckInView
[in] Следует ли перед подмигиванием изменить текущую видимую область контейнера так, чтобы все выделенные объекты были видны
FlashNumber
[in] Количество подмигиваний

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.FormatByExample (метод)

Сформатировать элементы по образцу текущего выделенного

Синтаксис

[Visual Basic 6]
Sub FormatByExample

[Delphi]
procedure FormatByExample

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.HighlightDevicePoint (метод)

Показывает последовательностью сужающихся концентрических окружностей точку, заданную в целочисленной системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub HighlightDevicePoint ( _
   ByVal X As Long, _
   ByVal Y As Long _
)

[Delphi]
procedure HighlightDevicePoint(
   const X: Integer;
   const Y: Integer
)

Описание параметров

X
[in] Координата X показываемой точки на карте в целочисленной системе координат окна контейнера
Y
[in] Координата Y показываемой точки на карте в целочисленной системе координат окна контейнера

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.HighlightFlatPoint (метод)

Показывает последовательностью сужающихся концентрических окружностей точку, заданную в вещественной плоской системе координат окна контейнера

Синтаксис

[Visual Basic 6]
Sub HighlightFlatPoint ( _
   ByVal FlatX As Double, _
   ByVal FlatY As Double _
)

[Delphi]
procedure HighlightFlatPoint(
   const FlatX: Double;
   const FlatY: Double
)

Описание параметров

FlatX
[in] Координата X показываемой точки на карте в вещественной плоской системе координат окна контейнера
FlatY
[in] Координата Y показываемой точки на карте в вещественной плоской системе координат окна контейнера

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.HighlightModelPoint (метод)

Подсвечивает миганием точку, заданную в вещественной системе координат модели

Синтаксис

[Visual Basic 6]
Sub HighlightModelPoint ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   [ByVal Layer As Object = Nothing] _
)

[Delphi]
procedure HighlightModelPoint(
   const ModelX: Double;
   const ModelY: Double;
   const Layer: IDispatch
)

Описание параметров

ModelX
[in] Координата X показываемой точки на карте в вещественной системе координат модели
ModelY
[in] Координата Y показываемой точки на карте в вещественной системе координат модели
Layer
[in] Текущий слой карты, в системе координат которого задаются координаты показываемой точки. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.Invalidate (метод)

Обновить изображение контейнера, как только появится свободное процессорное время

Синтаксис

[Visual Basic 6]
Sub Invalidate

[Delphi]
procedure Invalidate

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.InvertSelected (метод)

Инвертировать выделение на текущем слое карты

Синтаксис

[Visual Basic 6]
Sub InvertSelected

[Delphi]
procedure InvertSelected

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.LoadBlockFromFile (метод)

Загрузить блок из файла

Синтаксис

[Visual Basic 6]
Sub LoadBlockFromFile

[Delphi]
procedure LoadBlockFromFile

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.LockRefresh (метод)

Заблокировать перерисовку изображения (после этого метода обязательно надо будет вызвать UnlockRefresh)

Синтаксис

[Visual Basic 6]
Sub LockRefresh

[Delphi]
procedure LockRefresh

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.MasterPan (метод)

Панорамировать видимое изображение главного контейнера

Синтаксис

[Visual Basic 6]
Sub MasterPan

[Delphi]
procedure MasterPan

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.MasterSelect (метод)

Выбрать видимое изображение главного контейнера

Синтаксис

[Visual Basic 6]
Sub MasterSelect

[Delphi]
procedure MasterSelect

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.MouseCapture (метод)

Захват мыши

Синтаксис

[Visual Basic 6]
Sub MouseCapture

[Delphi]
procedure MouseCapture

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.Pan (метод)

Панорамировать изображение с помощью руки

Синтаксис

[Visual Basic 6]
Function Pan As Boolean

[Delphi]
function Pan: WordBool

Возвращаемое значение

Возвращает True, если панорамирование было выполнено

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.PanTo (метод)

Сдвинуть изображение в заданном направлении (LargeStep - с большим шагом)

Синтаксис

[Visual Basic 6]
Sub PanTo ( _
   ByVal PanDirection As PanDirectionConstants, _
   ByVal LargeStep As Boolean _
)

[Delphi]
procedure PanTo(
   const PanDirection: PanDirectionConstants;
   const LargeStep: WordBool
)

Описание параметров

PanDirection
[in] Направление, в котором необходимо сдвинуть изображение
LargeStep
[in] Использовать ли большой шаг при сдвиге изображения

Смотри также

Enum PanDirectionConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.PanToPoint (метод)

Немного сдвинуть изображение в направлении указанной точки. Реально данный метод вызывает метод PanTo с соответствующими параметрами

Синтаксис

[Visual Basic 6]
Function PanToPoint ( _
   ByVal Point As Point _
) As Boolean

[Delphi]
function PanToPoint(
   const Point: Point
): WordBool

Описание параметров

Point
[in] Точка, в направлении которой необходимо выполнить сдвиг

Возвращаемое значение

Возвращает True, если сдвиг был выполнен

Смотри также

Class Point, Class VectorContainer, Group Контейнеры изображений


VectorContainer.PasteFromClipboard (метод)

Вставить объекты из буфера обмена и сделать их текущими выделенными

Синтаксис

[Visual Basic 6]
Sub PasteFromClipboard ( _
   [ByVal Mode As PasteFromClipboardConstants = 0] _
)

[Delphi]
procedure PasteFromClipboard(
   const Mode: PasteFromClipboardConstants
)

Описание параметров

Mode
[in] Режим вставки фигур из буфера

Смотри также

Enum PasteFromClipboardConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.PrintView (метод)

Распечатать на принтере на одной странице видимую часть изображения

Синтаксис

[Visual Basic 6]
Sub PrintView ( _
   ByVal Title As String _
)

[Delphi]
procedure PrintView(
   const Title: WideString
)

Описание параметров

Title
[in] Заголовок задания для печати

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.RefreshContent (метод)

Указать, что надо перерисовать изображение в памяти

Синтаксис

[Visual Basic 6]
Sub RefreshContent ( _
   [ByVal EraseBackground As Boolean = True] _
)

[Delphi]
procedure RefreshContent(
   const EraseBackground: WordBool
)

Описание параметров

EraseBackground
[in] Если EraseBackground=True, то фон изображения будет стерт и изображение в контейнере будет перерисовано полностью заново

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.RegisterMode (метод)

Зарегистрировать новый режим работы контейнера с указанным обработчиком событий

Синтаксис

[Visual Basic 6]
Function RegisterMode ( _
   ByVal Value As IContainerModeEvents _
) As ContainerModeHandler

[Delphi]
function RegisterMode(
   const Value: IContainerModeEvents
): ContainerModeHandler

Описание параметров

Value
[in] Обработчик событий, который будет реализовывать режим

Возвращаемое значение

Возвращает новый обработчик режима работы контейнера

Смотри также

Class ContainerModeHandler, Interface IContainerModeEvents, Class VectorContainer, Group Контейнеры изображений


VectorContainer.Repaint (метод)

Обновить изображение контейнера немедленно

Синтаксис

[Visual Basic 6]
Sub Repaint

[Delphi]
procedure Repaint

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.RestoreLastView (метод)

Восстановить последний запомненный масштаб из списка

Синтаксис

[Visual Basic 6]
Sub RestoreLastView

[Delphi]
procedure RestoreLastView

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.SaveBlockToFile (метод)

Cохранить блок в файл

Синтаксис

[Visual Basic 6]
Sub SaveBlockToFile

[Delphi]
procedure SaveBlockToFile

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.SaveCurrentView (метод)

Сохранить текущий масштаб в списке

Синтаксис

[Visual Basic 6]
Sub SaveCurrentView

[Delphi]
procedure SaveCurrentView

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.SelectActiveMode (метод)

Выбрать текущий обработчик режима работы с контейнером

Синтаксис

[Visual Basic 6]
Sub SelectActiveMode ( _
   ByVal Value As ContainerModeHandler, _
   [ByVal SubModeGroup As Long = -1], _
   [ByVal SubModeIndex As Long = -1] _
)

[Delphi]
procedure SelectActiveMode(
   const Value: ContainerModeHandler;
   const SubModeGroup: Integer;
   const SubModeIndex: Integer
)

Описание параметров

Value
[in] Обработчик режима работы
SubModeGroup
[in] Группа подрежимов, которая должна быть выбрана. Если будет задано -1, то текущая группа не будет изменена
SubModeIndex
[in] Номер подрежима в группе, который должна быть выбрана. Если будет задано -1, то текущий номер режима меняться не будет

Смотри также

Class ContainerModeHandler, Class VectorContainer, Group Контейнеры изображений


VectorContainer.SelectActiveModeByName (метод)

Выбрать текущий обработчик режима работы с контейнером

Синтаксис

[Visual Basic 6]
Sub SelectActiveModeByName ( _
   ByVal ContainerModeName As String, _
   [ByVal SubModeGroup As Long = -1], _
   [ByVal SubModeIndex As Long = -1] _
)

[Delphi]
procedure SelectActiveModeByName(
   const ContainerModeName: WideString;
   const SubModeGroup: Integer;
   const SubModeIndex: Integer
)

Описание параметров

ContainerModeName
[in] Имя класса обработчика режима работы
SubModeGroup
[in] Группа подрежимов, которая должна быть выбрана. Если будет задано -1, то текущая группа не будет изменена
SubModeIndex
[in] Номер подрежима в группе, который должна быть выбрана. Если будет задано -1, то текущий номер режима меняться не будет

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.SelectAll (метод)

Выделить все объекты на текущем слое карты

Синтаксис

[Visual Basic 6]
Sub SelectAll

[Delphi]
procedure SelectAll

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.StopEdit (метод)

Прекратить редактирование элементов

Синтаксис

[Visual Basic 6]
Sub StopEdit

[Delphi]
procedure StopEdit

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.SwitchAtLayer (метод)

Переключить состояние элемента заданного слоя чертежа в заданной точке карты

Синтаксис

[Visual Basic 6]
Function SwitchAtLayer ( _
   ByVal Layer As VectorLayer, _
   ByVal X As Long, _
   ByVal Y As Long, _
   ByVal State As SwitchItemStateConstants, _
   ByVal Mode As SwitchItemTypesConstants, _
   ParamArray DefIds() As Variant _
) As Boolean

[Delphi]
function SwitchAtLayer(
   const Layer: VectorLayer;
   const X: Integer;
   const Y: Integer;
   const State: SwitchItemStateConstants;
   const Mode: SwitchItemTypesConstants;
   const DefIds: PSafeArray
): WordBool

Описание параметров

Layer
[in] Слой чертежа, в котором нужно выполнить переключение состояния
X
[in] Координата X точки на карте в целочисленной системе координат окна контейнера
Y
[in] Координата Y точки на карте в целочисленной системе координат окна контейнера
State
[in] Требуемое состояние при переключении состояний элементов
Mode
[in] Допустимые типы переключаемых элементов чертежа
DefIds
[in] Список типов элементов чертежа, для которых возможно выполнение переключения

Возвращаемое значение

Возвращает True, если переключить состояние элемента удалось

Смотри также

Enum SwitchItemStateConstants, Enum SwitchItemTypesConstants, Class VectorContainer, Class VectorLayer, Group Контейнеры изображений


VectorContainer.SwitchFigure (метод)

Переключить состояние элемента любого слоя чертежа в заданной точке карты

Синтаксис

[Visual Basic 6]
Function SwitchFigure ( _
   ByVal X As Long, _
   ByVal Y As Long, _
   [ByVal State As SwitchItemStateConstants = 0], _
   [ByVal Mode As SwitchItemTypesConstants = 0] _
) As Boolean

[Delphi]
function SwitchFigure(
   const X: Integer;
   const Y: Integer;
   const State: SwitchItemStateConstants;
   const Mode: SwitchItemTypesConstants
): WordBool

Описание параметров

X
[in] Координата X точки на карте в целочисленной системе координат окна контейнера
Y
[in] Координата Y точки на карте в целочисленной системе координат окна контейнера
State
[in] Требуемое состояние при переключении состояний элементов
Mode
[in] Допустимые типы переключаемых элементов чертежа

Возвращаемое значение

Возвращает True, если переключить состояние элемента удалось

Смотри также

Enum SwitchItemStateConstants, Enum SwitchItemTypesConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFixedRect (метод)

Оттрасировать прямоугольник заданного размера на карте

Синтаксис

[Visual Basic 6]
Function TrackFixedRect ( _
   ByVal Size As FlatPoint, _
   [ByVal Snap As Boolean = False], _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFixedRect(
   const Size: FlatPoint;
   const Snap: WordBool;
   const Layer: IDispatch
): FlatRect

Описание параметров

Size
[in] Размер прямоугольника
Snap
[in] Выполнять ли подтяжку вводимого прямоугольника по сетке
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class FlatPoint, Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatCircle (метод)

Оттрасировать окружность на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatCircle ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatCircle(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную окружность в плоской системе координат контейнера

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatEllipse (метод)

Оттрасировать эллипс на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatEllipse ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatEllipse(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный эллипс в плоской системе координат контейнера

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatFillCircle (метод)

Оттрасировать залитый круг на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatFillCircle ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatFillCircle(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную окружность в плоской системе координат контейнера

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatFillEllipse (метод)

Оттрасировать залитый эллипс на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatFillEllipse ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatFillEllipse(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный эллипс в плоской системе координат контейнера

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatFillPolygon (метод)

Оттрасировать залитый полигон на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatFillPolygon ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackFlatFillPolygon(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный полигон в плоской системе координат контейнера

Смотри также

Class ShapePolygon, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatFillRectangle (метод)

Оттрасировать залитый прямоугольник на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatFillRectangle ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatFillRectangle(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatMultipoint (метод)

Оттрасировать мультиточку на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatMultipoint ( _
   [ByVal Layer As Object = Nothing] _
) As ShapeMultipoint

[Delphi]
function TrackFlatMultipoint(
   const Layer: IDispatch
): ShapeMultipoint

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную мультиточку в плоской системе координат контейнера

Смотри также

Class ShapeMultipoint, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatPoint (метод)

Оттрасировать точку на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatPoint ( _
   [ByVal Layer As Object = Nothing] _
) As FlatPoint

[Delphi]
function TrackFlatPoint(
   const Layer: IDispatch
): FlatPoint

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную точку в плоской системе координат контейнера

Смотри также

Class FlatPoint, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatPolygon (метод)

Оттрасировать полигон на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatPolygon ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackFlatPolygon(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный полигон в плоской системе координат контейнера

Смотри также

Class ShapePolygon, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatPolyline (метод)

Оттрасировать полилинию на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatPolyline ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackFlatPolyline(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную полилинию в плоской системе координат контейнера

Смотри также

Class ShapePolyline, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatRectangle (метод)

Оттрасировать прямоугольник на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatRectangle ( _
   [ByVal InternalLineCountX As Long = 0], _
   [ByVal InternalLineCountY As Long = 0], _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackFlatRectangle(
   const InternalLineCountX: Integer;
   const InternalLineCountY: Integer;
   const Layer: IDispatch
): FlatRect

Описание параметров

InternalLineCountX
[in] Количество промежуточных вертикальных линий у трассируемого прямоугольника
InternalLineCountY
[in] Количество промежуточных горизонтальных линий у трассируемого прямоугольника
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackFlatSegment (метод)

Оттрасировать отрезок на карте в плоских координатах

Синтаксис

[Visual Basic 6]
Function TrackFlatSegment ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackFlatSegment(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный отрезок в виде полилинии в плоской системе координат контейнера

Смотри также

Class ShapePolyline, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelCircle (метод)

Оттрасировать окружность на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelCircle ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelCircle(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную окружность в виде полилинии, заданной в системе координат модели

Смотри также

Class ShapePolyline, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelEllipse (метод)

Оттрасировать эллипс на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelEllipse ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelEllipse(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный эллипс в виде полилинии, заданной в системе координат модели

Смотри также

Class ShapePolyline, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelFillCircle (метод)

Оттрасировать залитый круг на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelFillCircle ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelFillCircle(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную окружность в виде полигона, заданного в системе координат модели

Смотри также

Class ShapePolygon, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelFillEllipse (метод)

Оттрасировать залитый эллипс на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelFillEllipse ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelFillEllipse(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный эллипс в виде полигона, заданного в системе координат модели

Смотри также

Class ShapePolygon, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelFillPolygon (метод)

Оттрасировать залитый полигон на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelFillPolygon ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelFillPolygon(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный полигон в системе координат модели

Смотри также

Class ShapePolygon, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelFillRectangle (метод)

Оттрасировать залитый прямоугольник на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelFillRectangle ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelFillRectangle(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в виде полигона, заданного в системе координат модели

Смотри также

Class ShapePolygon, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelMultipoint (метод)

Оттрасировать мультиточку на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelMultipoint ( _
   [ByVal Layer As Object = Nothing] _
) As ShapeMultipoint

[Delphi]
function TrackModelMultipoint(
   const Layer: IDispatch
): ShapeMultipoint

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную мультиточку в системе координат модели

Смотри также

Class ShapeMultipoint, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelPoint (метод)

Оттрасировать точку на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelPoint ( _
   [ByVal Layer As Object = Nothing] _
) As ModelPoint

[Delphi]
function TrackModelPoint(
   const Layer: IDispatch
): ModelPoint

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную мультиточку в системе координат модели

Смотри также

Class ModelPoint, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelPolygon (метод)

Оттрасировать полигон на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelPolygon ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolygon

[Delphi]
function TrackModelPolygon(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolygon

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный полигон в системе координат модели

Смотри также

Class ShapePolygon, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelPolyline (метод)

Оттрасировать полилинию на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelPolyline ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelPolyline(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированную полилинию в системе координат модели

Смотри также

Class ShapePolyline, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelRectangle (метод)

Оттрасировать прямоугольник на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelRectangle ( _
   [ByVal ShapeType As ShapeTypeConstants = 5], _
   [ByVal InternalLineCountX As Long = 0], _
   [ByVal InternalLineCountY As Long = 0], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelRectangle(
   const ShapeType: ShapeTypeConstants;
   const InternalLineCountX: Integer;
   const InternalLineCountY: Integer;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
InternalLineCountX
[in] Количество промежуточных вертикальных линий у трассируемого прямоугольника
InternalLineCountY
[in] Количество промежуточных горизонтальных линий у трассируемого прямоугольника
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в виде полилинии, заданной в системе координат модели

Смотри также

Class ShapePolyline, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackModelSegment (метод)

Оттрасировать отрезок на карте в модельных координатах

Синтаксис

[Visual Basic 6]
Function TrackModelSegment ( _
   [ByVal ShapeType As ShapeTypeConstants = 3], _
   [ByVal Layer As Object = Nothing] _
) As ShapePolyline

[Delphi]
function TrackModelSegment(
   const ShapeType: ShapeTypeConstants;
   const Layer: IDispatch
): ShapePolyline

Описание параметров

ShapeType
[in] Тип шейп-фигуры, который будет возвращен данным методом
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный отрезок в виде полилинии в системе координат модели

Смотри также

Class ShapePolyline, Enum ShapeTypeConstants, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackZoomIn (метод)

Укрупнить изображение с помощью трассировки прямоугольника

Синтаксис

[Visual Basic 6]
Sub TrackZoomIn

[Delphi]
procedure TrackZoomIn

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackZoomOut (метод)

Уменьшить изображение с помощью трассировки прямоугольника

Синтаксис

[Visual Basic 6]
Sub TrackZoomOut

[Delphi]
procedure TrackZoomOut

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackZoomRect (метод)

Оттрасировать прямоугольник, пропорциональный заданным высоте и ширине

Синтаксис

[Visual Basic 6]
Function TrackZoomRect ( _
   ByVal WidthAspect As Long, _
   ByVal HeightAspect As Long, _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackZoomRect(
   const WidthAspect: Integer;
   const HeightAspect: Integer;
   const Layer: IDispatch
): FlatRect

Описание параметров

WidthAspect
[in] Ширина прямоугольника, пропорционально которой будет выполняться трассировка
HeightAspect
[in] Высота прямоугольника, пропорционально которой будет выполняться трассировка
Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.TrackZoomRectangle (метод)

Оттрасировать прямоугольник, пропорциональный клиентскому размеру данного контейнера

Синтаксис

[Visual Basic 6]
Function TrackZoomRectangle ( _
   [ByVal Layer As Object = Nothing] _
) As FlatRect

[Delphi]
function TrackZoomRectangle(
   const Layer: IDispatch
): FlatRect

Описание параметров

Layer
[in] Текущий слой карты, для которого выполняется трассировка. Слой задавать не обязательн, тогда будет использована модельная система координат всего контейнера.

Возвращаемое значение

Возвращает оттрасированный прямоугольник в плоской системе координат контейнера

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.UnlockRefresh (метод)

Разблокировать перерисовку изображения (обязательно вызывается после LockRefresh)

Синтаксис

[Visual Basic 6]
Sub UnlockRefresh

[Delphi]
procedure UnlockRefresh

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.UnselectAll (метод)

Убрать выделение всех объектов на текущем слое карты

Синтаксис

[Visual Basic 6]
Sub UnselectAll

[Delphi]
procedure UnselectAll

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.UpdateContentAll (метод)

Полностью обновить изображение

Синтаксис

[Visual Basic 6]
Sub UpdateContentAll

[Delphi]
procedure UpdateContentAll

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.UpdateCursor (метод)

Обновить курсор

Синтаксис

[Visual Basic 6]
Sub UpdateCursor

[Delphi]
procedure UpdateCursor

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.UpdateScrollbars (метод)

Обновить содержимое скроллеров

Синтаксис

[Visual Basic 6]
Sub UpdateScrollbars

[Delphi]
procedure UpdateScrollbars

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.ZoomInCenter (метод)

Укрупнить изображение в центре в 5/4 раза

Синтаксис

[Visual Basic 6]
Sub ZoomInCenter

[Delphi]
procedure ZoomInCenter

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.ZoomOutCenter (метод)

Уменьшить изображение в центре в 5/4 раза

Синтаксис

[Visual Basic 6]
Sub ZoomOutCenter

[Delphi]
procedure ZoomOutCenter

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.ZoomToAll (метод)

Вписать в окно всю карту

Синтаксис

[Visual Basic 6]
Sub ZoomToAll

[Delphi]
procedure ZoomToAll

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.ZoomToExtent (метод)

Вписать в окно заданный прямоугольник. Данный метод по сути эквивалентен методу ZoomToRect, у которого задана анимация изображения

Синтаксис

[Visual Basic 6]
Sub ZoomToExtent ( _
   ByVal Extent As FlatRect _
)

[Delphi]
procedure ZoomToExtent(
   const Extent: FlatRect
)

Описание параметров

Extent
[in] Прямоугольная область, заданная в плоской системе координат контейнера, которая должна стать текущей видимой в контейнере

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ZoomToPoint (метод)

Смасштабировать в заданный масштаб с точкой в центре

Синтаксис

[Visual Basic 6]
Sub ZoomToPoint ( _
   ByVal Scale As Double, _
   ByVal ScaleXY As Double, _
   ByVal Center As FlatPoint, _
   ByVal Animate As Boolean _
)

[Delphi]
procedure ZoomToPoint(
   const Scale: Double;
   const ScaleXY: Double;
   const Center: FlatPoint;
   const Animate: WordBool
)

Описание параметров

Scale
[in] Масштаб отображения (соотношение размеров в целочисленной системе координат окна контейнера и вещественных размеров в плоской системе координат контейнера)
ScaleXY
[in] Соотношение масштабов отображения по осям X и Y
Center
[in] Координата центра видимой части изображения в плоской системе координат контейнера
Animate
[in] Выполнять ли анимацию процесса масштабирования

Смотри также

Class FlatPoint, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ZoomToRect (метод)

Смасштабировать в заданное окно

Синтаксис

[Visual Basic 6]
Sub ZoomToRect ( _
   ByVal FlatRect As FlatRect, _
   ByVal ScaleXY As Double, _
   ByVal Animate As Boolean _
)

[Delphi]
procedure ZoomToRect(
   const FlatRect: FlatRect;
   const ScaleXY: Double;
   const Animate: WordBool
)

Описание параметров

FlatRect
[in] Прямоугольная область, заданная в плоской системе координат контейнера, которая должна стать текущей видимой в контейнере
ScaleXY
[in] Соотношение масштабов отображения по осям X и Y
Animate
[in] Выполнять ли анимацию процесса масштабирования

Смотри также

Class FlatRect, Class VectorContainer, Group Контейнеры изображений


VectorContainer.ZoomToScale (метод)

Смасштабировать относительно центра окна до заданного масштаба

Синтаксис

[Visual Basic 6]
Sub ZoomToScale ( _
   ByVal Scale As Double, _
   ByVal ScaleXY As Double, _
   ByVal Animate As Boolean _
)

[Delphi]
procedure ZoomToScale(
   const Scale: Double;
   const ScaleXY: Double;
   const Animate: WordBool
)

Описание параметров

Scale
[in] Масштаб отображения (соотношение размеров в целочисленной системе координат окна контейнера и вещественных размеров в плоской системе координат контейнера)
ScaleXY
[in] Соотношение масштабов отображения по осям X и Y
Animate
[in] Выполнять ли анимацию процесса масштабирования

Смотри также

Class VectorContainer, Group Контейнеры изображений


VectorContainer.ZoomToView (метод)

Смасштабировать в заданное окно

Синтаксис

[Visual Basic 6]
Sub ZoomToView ( _
   ByVal Scale As Double, _
   ByVal ScaleXY As Double, _
   ByVal ViewOrigin As FlatPoint, _
   ByVal Animate As Boolean _
)

[Delphi]
procedure ZoomToView(
   const Scale: Double;
   const ScaleXY: Double;
   const ViewOrigin: FlatPoint;
   const Animate: WordBool
)

Описание параметров

Scale
[in] Масштаб отображения (соотношение размеров в целочисленной системе координат окна контейнера и вещественных размеров в плоской системе координат контейнера)
ScaleXY
[in] Соотношение масштабов отображения по осям X и Y
ViewOrigin
[in] Координата левого верхнего угла видимой части изображения в плоской системе координат контейнера
Animate
[in] Выполнять ли анимацию процесса масштабирования

Смотри также

Class FlatPoint, Class VectorContainer, Group Контейнеры изображений


Класс VectorLayer

Слой векторных данных

Наследование

CompositionLayer Class VectorLayer

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property BrowserItems (только для чтения) | Элементы просмотра главных полей для различных DefId (включая LayerDefId=-1)
Property Caption | Подпись слоя
Property ClipRegion (только для чтения) | Зона отсечения изображения слоя
Property DatasetLinks (только для чтения) | Получить общие подключенные наборы данных
Property DefIDCount (только для чтения) | Количество типов фигур на слое
Property DefIdDatasetLinks (только для чтения) | Получить подключенные наборы данных для элементов заданного типа
Property DefIds (только для чтения) | Массив типов фигур на слое
Property FigureCount (только для чтения) | Количество фигур слоя
Property Figures (только для чтения) | Массив фигур слоя
Property FileLocked | Файл с данными слоя заблокирован для записи
Property FileName (только для чтения) | Имя файла слоя
Property FullExtent (только для чтения) | Полный размер слоя
Property HotLink (только для чтения) | Описание горячей связи (если слой не поддерживает горячую связь, то HotLink = Nothing)
Property HotLinkSupported (только для чтения) | Поддержка горячей связи
Property Index (только для чтения) | Номер в списке родителя
Property IndividualProjection | Слой имеет индивидуальную проекцию
Property Kind (только для чтения) | Тип слоя
Property LegendOpen | Легенда развёрнута
Property MaxDrawScale | Максимальный масштаб отрисовки
Property MinDrawScale | Минимальный масштаб отрисовки
Property Modified | Изменён ли слой
Property Parent (только для чтения) | Папка, которой принадлежит слой
Property Projected | Проектировать ли слой?
Property Projection | Индивидуальная проекция слоя
Property ScaleCheck | Отрисовка в зависимости от масштаба
Property Selected (только для чтения) | Выделен ли слой в легенде
Property SeqID (только для чтения) | Уникальный идентификатор слоя на карте
Property SnapAfterDraw | Подтягивать автоматически после ввода
Property SnapAfterEdit | Подтягивать автоматически после ввода
Property SnapLayerCount (только для чтения) | Количество слоёв к которым разрешена подтяжка
Property SnapLayers (только для чтения) | Массив слоёв, к которым разрешена подтяжка
Property Tag | Можно использовать по своему усмотрению
Property Transparency | Значение прозрачности, с которой надо отображать слой (0 - непрозрачен, 255 - полностью прозрачен)
Property UsedTransparency (только для чтения) | Прозрачность, реально используемая при отрисовке слоя, с учетом прозрачности родительских папок (0 - непрозрачен, 255 - полностью прозрачен)
Property ValidProjected (только для чтения) | Реально проектировать ли слой
Property ValidProjection (только для чтения) | Реально используемая проекция слоя
Property VerbCount (только для чтения) | Количество доступных элементов локального меню
Property Verbs (только для чтения) | Массив пунктов локального меню слоя
Property Visible | Видим ли слой на карте
Property VisibleState (только для чтения) | Состояние отметки видимости слоя

Методы класса

Имя | Описание
Method AddSnapLayer | Добавить слой, к которому разрешена подтяжка
Method CanPaste | Можно ли вставить из буфера обмена
Method CanProjected | Можно ли отобразить сейчас слой в проекции
Method CanShow | Проверить, будет ли отображён слой на карте с учётом текущего масштаба
Method CopyToClipboard | Копировать выделение в буфер обмена
Method EditProperties | Редактирование свойств слоя
Method EditRenderer | Редактирование свойств отрисовки слоя
Method ExecuteFigureVerb | Вызывается при выполнении пункта локального меню
Method ExecuteVerb | Выполнить заданный пункт локального меню
Method FlashSelected | Подсветить на карте все выделенные фигуры слоя карты
Method GetAllFigures | Получить список всех фигур слоя
Method GetDefIdFigures | Получить список всех фигур слоя с указанным DefID. Для чертежей если DefId=LayerDeId=-1, то GetDefIDFigures = GetAllFigures
Method GetDescriptionAtPos | Получение краткой информации в заданной точке
Method GetFigureAtPos | Получить фигуру в заданной позиции, если там ничего нет, то Nothing
Method GetFigureDescription | Получить описание элемента, например "пр. Мира"
Method GetFigureName | Получить описание типа элемента, например "Линия", "Прямоугольник" или "Точка"
Method GetFiguresAtPolygon | Получить фигуры в заданном полигоне
Method GetFiguresAtPolyline | Получить фигуры, пересекающие заданную полилинию
Method GetFiguresAtPos | Получить фигуры (коллекцию объектов типа Figure) в заданном прямоугольнике
Method GetFiguresAtRect | Получить фигуры в заданном прямоугольнике
Method GetFigureVerb | Получение описания элемента локального меню
Method GetFigureVerbCount | Получение общего числа элементов локального меню
Method GetLayerDataset | Получить набор данных слоя с заданными параметрами
Method GetSelectedFigures | Получить список выделенных фигур слоя
Method GetSnapPoint | Получение координат точек на слое, к которой возможна подтяжка
Method GetSnapPointCount | Получение общего количества точек на слое, к которым возможна подтяжка
Method GetSnapSegment | Получение координат отрезков на слое, к которой возможна подтяжка
Method GetSnapSegmentCount | Получение количества отрезков на слое, к которым возможна подтяжка
Method HotLinkAction | Выполнение горячей связи
Method HotLinkExists | Проверка на возможность горячей связи в заданной точке карты
Method PasteFromClipboard | Вставить из буфера обмена
Method RemoveSnapLayer | Удалить слой, к которому разрешена подтяжка
Method Save | Сохранить содержимое слоя
Method SelectFigures | Выделить указанные фигуры слоя
Method SnapAllFigures | Подтяжка всего слоя
Method SnapFigure | Подтяжка элемента своего слоя
Method SupportsProjection | Поддерживается ли слоем отображение в проекции
Method UnselectAll | Снять выделение на слое

Где используется

Класс | Член класса
Class LayerCalculator | Property Layer (свойство)
Class LayerDataset | Property Layer (свойство)
Class VectorContainer | Property CurrentPopupFigureLayer (свойство) Property EditedLayer (свойство) Method FlashFigure (метод) Method FlashFigures (метод) Method SwitchAtLayer (метод)

Смотри также

Class BrowserItems, Enum CheckBoxConstants, Class ClipRegion, Class Collection, Class CompositionLayer, Enum CompositionLayerConstants, Class CustomContainer, Class DatasetLinks, Class Figure, Class FolderLayer, Class HotLink, Enum LayerDatasetModeConstants, Class MenuVerb, Class ModelPoint, Class ModelRect, Class Projection, Class ShapePolygon, Class ShapePolyline, Group Карты


VectorLayer.BrowserItems (свойство)

Элементы просмотра главных полей для различных DefId (включая LayerDefId=-1)

Синтаксис

[Visual Basic 6]
ReadOnly Property BrowserItems As BrowserItems

[Delphi]
{только для чтения} property BrowserItems: BrowserItems

Смотри также

Class BrowserItems, Class VectorLayer, Group Карты


VectorLayer.Caption (свойство)

Подпись слоя

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class VectorLayer, Group Карты


VectorLayer.ClipRegion (свойство)

Зона отсечения изображения слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property ClipRegion As ClipRegion

[Delphi]
{только для чтения} property ClipRegion: ClipRegion

Смотри также

Class ClipRegion, Class VectorLayer, Group Карты


VectorLayer.DatasetLinks (свойство)

Получить общие подключенные наборы данных

Синтаксис

[Visual Basic 6]
ReadOnly Property DatasetLinks As DatasetLinks

[Delphi]
{только для чтения} property DatasetLinks: DatasetLinks

Смотри также

Class DatasetLinks, Class VectorLayer, Group Карты


VectorLayer.DefIDCount (свойство)

Количество типов фигур на слое

Синтаксис

[Visual Basic 6]
ReadOnly Property DefIDCount As Long

[Delphi]
{только для чтения} property DefIDCount: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.DefIdDatasetLinks (свойство)

Получить подключенные наборы данных для элементов заданного типа

Синтаксис

[Visual Basic 6]
ReadOnly Property DefIdDatasetLinks As DatasetLinks

[Delphi]
{только для чтения} property DefIdDatasetLinks: DatasetLinks

Смотри также

Class DatasetLinks, Class VectorLayer, Group Карты


VectorLayer.DefIds (свойство)

Массив типов фигур на слое

Синтаксис

[Visual Basic 6]
ReadOnly Property DefIds As Long

[Delphi]
{только для чтения} property DefIds: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.FigureCount (свойство)

Количество фигур слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property FigureCount As Long

[Delphi]
{только для чтения} property FigureCount: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Figures (свойство)

Массив фигур слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Figures As Figure

[Delphi]
{только для чтения} property Figures: Figure

Смотри также

Class Figure, Class VectorLayer, Group Карты


VectorLayer.FileLocked (свойство)

Файл с данными слоя заблокирован для записи

Синтаксис

[Visual Basic 6]
Property FileLocked As Boolean

[Delphi]
property FileLocked: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.FileName (свойство)

Имя файла слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property FileName As String

[Delphi]
{только для чтения} property FileName: WideString

Смотри также

Class VectorLayer, Group Карты


VectorLayer.FullExtent (свойство)

Полный размер слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property FullExtent As ModelRect

[Delphi]
{только для чтения} property FullExtent: ModelRect

Смотри также

Class ModelRect, Class VectorLayer, Group Карты


VectorLayer.HotLink (свойство)

Описание горячей связи (если слой не поддерживает горячую связь, то HotLink = Nothing)

Синтаксис

[Visual Basic 6]
ReadOnly Property HotLink As HotLink

[Delphi]
{только для чтения} property HotLink: HotLink

Смотри также

Class HotLink, Class VectorLayer, Group Карты


VectorLayer.HotLinkSupported (свойство)

Поддержка горячей связи

Синтаксис

[Visual Basic 6]
ReadOnly Property HotLinkSupported As Boolean

[Delphi]
{только для чтения} property HotLinkSupported: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Index (свойство)

Номер в списке родителя

Синтаксис

[Visual Basic 6]
ReadOnly Property Index As Long

[Delphi]
{только для чтения} property Index: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.IndividualProjection (свойство)

Слой имеет индивидуальную проекцию

Синтаксис

[Visual Basic 6]
Property IndividualProjection As Boolean

[Delphi]
property IndividualProjection: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Kind (свойство)

Тип слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Kind As CompositionLayerConstants

[Delphi]
{только для чтения} property Kind: CompositionLayerConstants

Смотри также

Enum CompositionLayerConstants, Class VectorLayer, Group Карты


VectorLayer.LegendOpen (свойство)

Легенда развёрнута

Синтаксис

[Visual Basic 6]
Property LegendOpen As Boolean

[Delphi]
property LegendOpen: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.MaxDrawScale (свойство)

Максимальный масштаб отрисовки

Синтаксис

[Visual Basic 6]
Property MaxDrawScale As Double

[Delphi]
property MaxDrawScale: Double

Смотри также

Class VectorLayer, Group Карты


VectorLayer.MinDrawScale (свойство)

Минимальный масштаб отрисовки

Синтаксис

[Visual Basic 6]
Property MinDrawScale As Double

[Delphi]
property MinDrawScale: Double

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Modified (свойство)

Изменён ли слой

Синтаксис

[Visual Basic 6]
Property Modified As Boolean

[Delphi]
property Modified: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Parent (свойство)

Папка, которой принадлежит слой

Синтаксис

[Visual Basic 6]
ReadOnly Property Parent As FolderLayer

[Delphi]
{только для чтения} property Parent: FolderLayer

Смотри также

Class FolderLayer, Class VectorLayer, Group Карты


VectorLayer.Projected (свойство)

Проектировать ли слой?

Синтаксис

[Visual Basic 6]
Property Projected As Boolean

[Delphi]
property Projected: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Projection (свойство)

Индивидуальная проекция слоя

Синтаксис

[Visual Basic 6]
Property Projection As Projection

[Delphi]
property Projection: Projection

Смотри также

Class Projection, Class VectorLayer, Group Карты


VectorLayer.ScaleCheck (свойство)

Отрисовка в зависимости от масштаба

Синтаксис

[Visual Basic 6]
Property ScaleCheck As Boolean

[Delphi]
property ScaleCheck: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Selected (свойство)

Выделен ли слой в легенде

Синтаксис

[Visual Basic 6]
ReadOnly Property Selected As Boolean

[Delphi]
{только для чтения} property Selected: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.SeqID (свойство)

Уникальный идентификатор слоя на карте

Синтаксис

[Visual Basic 6]
ReadOnly Property SeqID As Long

[Delphi]
{только для чтения} property SeqID: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.SnapAfterDraw (свойство)

Подтягивать автоматически после ввода

Синтаксис

[Visual Basic 6]
Property SnapAfterDraw As Boolean

[Delphi]
property SnapAfterDraw: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.SnapAfterEdit (свойство)

Подтягивать автоматически после ввода

Синтаксис

[Visual Basic 6]
Property SnapAfterEdit As Boolean

[Delphi]
property SnapAfterEdit: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.SnapLayerCount (свойство)

Количество слоёв к которым разрешена подтяжка

Синтаксис

[Visual Basic 6]
ReadOnly Property SnapLayerCount As Long

[Delphi]
{только для чтения} property SnapLayerCount: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.SnapLayers (свойство)

Массив слоёв, к которым разрешена подтяжка

Синтаксис

[Visual Basic 6]
ReadOnly Property SnapLayers As CompositionLayer

[Delphi]
{только для чтения} property SnapLayers: CompositionLayer

Смотри также

Class CompositionLayer, Class VectorLayer, Group Карты


VectorLayer.Tag (свойство)

Можно использовать по своему усмотрению

Синтаксис

[Visual Basic 6]
Property Tag As Long

[Delphi]
property Tag: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Transparency (свойство)

Значение прозрачности, с которой надо отображать слой (0 - непрозрачен, 255 - полностью прозрачен)

Синтаксис

[Visual Basic 6]
Property Transparency As Long

[Delphi]
property Transparency: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.UsedTransparency (свойство)

Прозрачность, реально используемая при отрисовке слоя, с учетом прозрачности родительских папок (0 - непрозрачен, 255 - полностью прозрачен)

Синтаксис

[Visual Basic 6]
ReadOnly Property UsedTransparency As Long

[Delphi]
{только для чтения} property UsedTransparency: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.ValidProjected (свойство)

Реально проектировать ли слой

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidProjected As Boolean

[Delphi]
{только для чтения} property ValidProjected: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.ValidProjection (свойство)

Реально используемая проекция слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property ValidProjection As Projection

[Delphi]
{только для чтения} property ValidProjection: Projection

Смотри также

Class Projection, Class VectorLayer, Group Карты


VectorLayer.VerbCount (свойство)

Количество доступных элементов локального меню

Синтаксис

[Visual Basic 6]
ReadOnly Property VerbCount As Long

[Delphi]
{только для чтения} property VerbCount: Integer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Verbs (свойство)

Массив пунктов локального меню слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property Verbs As MenuVerb

[Delphi]
{только для чтения} property Verbs: MenuVerb

Смотри также

Class MenuVerb, Class VectorLayer, Group Карты


VectorLayer.Visible (свойство)

Видим ли слой на карте

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class VectorLayer, Group Карты


VectorLayer.VisibleState (свойство)

Состояние отметки видимости слоя

Синтаксис

[Visual Basic 6]
ReadOnly Property VisibleState As CheckBoxConstants

[Delphi]
{только для чтения} property VisibleState: CheckBoxConstants

Смотри также

Enum CheckBoxConstants, Class VectorLayer, Group Карты


VectorLayer.AddSnapLayer (метод)

Добавить слой, к которому разрешена подтяжка

Синтаксис

[Visual Basic 6]
Sub AddSnapLayer ( _
   ByVal Layer As CompositionLayer _
)

[Delphi]
procedure AddSnapLayer(
   const Layer: CompositionLayer
)

Описание параметров

Layer
[in] Добавляемый слой карты

Смотри также

Class CompositionLayer, Class VectorLayer, Group Карты


VectorLayer.CanPaste (метод)

Можно ли вставить из буфера обмена

Синтаксис

[Visual Basic 6]
Function CanPaste As Boolean

[Delphi]
function CanPaste: WordBool

Возвращаемое значение

Возвращает True, если из буфера обмена можно вставить фигуры в текущий слой

Смотри также

Class VectorLayer, Group Карты


VectorLayer.CanProjected (метод)

Можно ли отобразить сейчас слой в проекции

Синтаксис

[Visual Basic 6]
Function CanProjected As Boolean

[Delphi]
function CanProjected: WordBool

Возвращаемое значение

Возвращает True, если сейчас можно отобразить слой в проекции

Смотри также

Class VectorLayer, Group Карты


VectorLayer.CanShow (метод)

Проверить, будет ли отображён слой на карте с учётом текущего масштаба

Синтаксис

[Visual Basic 6]
Function CanShow ( _
   ByVal Container As CustomContainer _
) As Boolean

[Delphi]
function CanShow(
   const Container: CustomContainer
): WordBool

Описание параметров

Container
[in] Контейнер, в котором отображается текущий слой

Возвращаемое значение

Возвращает True, если отображение возможно

Смотри также

Class CustomContainer, Class VectorLayer, Group Карты


VectorLayer.CopyToClipboard (метод)

Копировать выделение в буфер обмена

Синтаксис

[Visual Basic 6]
Function CopyToClipboard As Boolean

[Delphi]
function CopyToClipboard: WordBool

Возвращаемое значение

Возвращает True, если копирование было успешно выполнено

Смотри также

Class VectorLayer, Group Карты


VectorLayer.EditProperties (метод)

Редактирование свойств слоя

Синтаксис

[Visual Basic 6]
Sub EditProperties

[Delphi]
procedure EditProperties

Смотри также

Class VectorLayer, Group Карты


VectorLayer.EditRenderer (метод)

Редактирование свойств отрисовки слоя

Синтаксис

[Visual Basic 6]
Sub EditRenderer

[Delphi]
procedure EditRenderer

Смотри также

Class VectorLayer, Group Карты


VectorLayer.ExecuteFigureVerb (метод)

Вызывается при выполнении пункта локального меню

Синтаксис

[Visual Basic 6]
Sub ExecuteFigureVerb ( _
   ByVal Figure As Figure, _
   ByVal Container As VectorContainer, _
   ByVal VerbIndex As Long, _
   ByVal MapPos As ModelPoint _
)

[Delphi]
procedure ExecuteFigureVerb(
   const Figure: Figure;
   const Container: VectorContainer;
   const VerbIndex: Integer;
   const MapPos: ModelPoint
)

Описание параметров

Figure
[in] Заданная фигура
Container
[in] Контейнер, в котором отображается сейчас фигура
VerbIndex
[in] Номер элемента локального меню (нумерация идёт от 0 до GetFigureVerbCount-1)
MapPos
[in] Точка на карте в модельной системе координат, в которой было вызвано локальное меню

Смотри также

Class Figure, Class ModelPoint, Class VectorContainer, Class VectorLayer, Group Карты


VectorLayer.ExecuteVerb (метод)

Выполнить заданный пункт локального меню

Синтаксис

[Visual Basic 6]
Sub ExecuteVerb ( _
   ByVal Index As Long _
)

[Delphi]
procedure ExecuteVerb(
   const Index: Integer
)

Описание параметров

Index
[in] Номер выполняемого пункта локального меню слоя (нумерация идёт от 0 до VerbCount-1)

Смотри также

Class VectorLayer, Group Карты


VectorLayer.FlashSelected (метод)

Подсветить на карте все выделенные фигуры слоя карты

Синтаксис

[Visual Basic 6]
Sub FlashSelected ( _
   [ByVal CheckInView As Boolean = False], _
   [ByVal FlashNumber As Long = 2] _
)

[Delphi]
procedure FlashSelected(
   const CheckInView: WordBool;
   const FlashNumber: Integer
)

Описание параметров

CheckInView
[in] Следует ли перед подмигиванием изменить текущую видимую область контейнера так, чтобы все выделенные объекты были видны
FlashNumber
[in] Количество подмигиваний

Смотри также

Class VectorLayer, Group Карты


VectorLayer.GetAllFigures (метод)

Получить список всех фигур слоя

Синтаксис

[Visual Basic 6]
Function GetAllFigures As Collection

[Delphi]
function GetAllFigures: Collection

Возвращаемое значение

Возращает список всех фигур слоя

Смотри также

Class Collection, Class VectorLayer, Group Карты


VectorLayer.GetDefIdFigures (метод)

Получить список всех фигур слоя с указанным DefID. Для чертежей если DefId=LayerDeId=-1, то GetDefIDFigures = GetAllFigures

Синтаксис

[Visual Basic 6]
Function GetDefIdFigures ( _
   ByVal DefID As Long _
) As Collection

[Delphi]
function GetDefIdFigures(
   const DefID: Integer
): Collection

Описание параметров

DefID
[in] Тип требуемых фигур

Возвращаемое значение

Возращает список фигур слоя указанного типа DefId

Смотри также

Class Collection, Class VectorLayer, Group Карты


VectorLayer.GetDescriptionAtPos (метод)

Получение краткой информации в заданной точке

Синтаксис

[Visual Basic 6]
Function GetDescriptionAtPos ( _
   ByVal Pos As ModelPoint, _
   ByVal Delta As Double _
) As String

[Delphi]
function GetDescriptionAtPos(
   const Pos: ModelPoint;
   const Delta: Double
): WideString

Описание параметров

Pos
[in] Точка на карте в модельной системе координат, для которой требуется получить краткю информацию
Delta
[in] Максимальное допустимое отклонение при поиске объектов, для которых выдается краткая информация

Возвращаемое значение

Возвращает текст краткой информации или пустую строку

Смотри также

Class ModelPoint, Class VectorLayer, Group Карты


VectorLayer.GetFigureAtPos (метод)

Получить фигуру в заданной позиции, если там ничего нет, то Nothing

Синтаксис

[Visual Basic 6]
Function GetFigureAtPos ( _
   ByVal ModelPoint As ModelPoint, _
   ByVal Delta As Double _
) As Figure

[Delphi]
function GetFigureAtPos(
   const ModelPoint: ModelPoint;
   const Delta: Double
): Figure

Описание параметров

ModelPoint
[in] Точка на карте в модельной системе координат, в которой надо найти фигуру
Delta
[in] Максимальное допустимое отклонение при поиске фигуры

Возвращаемое значение

фозвращает найденую фигуру или Nothing, если ничего не найдено

Смотри также

Class Figure, Class ModelPoint, Class VectorLayer, Group Карты


VectorLayer.GetFigureDescription (метод)

Получить описание элемента, например "пр. Мира"

Синтаксис

[Visual Basic 6]
Function GetFigureDescription ( _
   ByVal Figure As Figure _
) As String

[Delphi]
function GetFigureDescription(
   const Figure: Figure
): WideString

Описание параметров

Figure
[in] Заданная фигура

Возвращаемое значение

Возвращает описание элемента

Смотри также

Class Figure, Class VectorLayer, Group Карты


VectorLayer.GetFigureName (метод)

Получить описание типа элемента, например "Линия", "Прямоугольник" или "Точка"

Синтаксис

[Visual Basic 6]
Function GetFigureName ( _
   ByVal Figure As Figure _
) As String

[Delphi]
function GetFigureName(
   const Figure: Figure
): WideString

Описание параметров

Figure
[in] Заданная фигура

Возвращаемое значение

Возвращает описание типа элемента

Смотри также

Class Figure, Class VectorLayer, Group Карты


VectorLayer.GetFiguresAtPolygon (метод)

Получить фигуры в заданном полигоне

Синтаксис

[Visual Basic 6]
Function GetFiguresAtPolygon ( _
   ByVal PolygonFigure As ShapePolygon, _
   [ByVal OnlyInside As Boolean = False] _
) As Collection

[Delphi]
function GetFiguresAtPolygon(
   const PolygonFigure: ShapePolygon;
   const OnlyInside: WordBool
): Collection

Описание параметров

PolygonFigure
[in] Полигон, внутри которого нужно найти фигуры
OnlyInside
[in] Если OnlyInside=True, то будут найдены только те фигуры, которые находятся полностью внутри полигона, иначе будут найдены и те фигуры, которые только частично попадают внутрь заданного полигона

Возвращаемое значение

Возвращает коллекцию всех найденных объектов типа Figure

Смотри также

Class Collection, Class ShapePolygon, Class VectorLayer, Group Карты


VectorLayer.GetFiguresAtPolyline (метод)

Получить фигуры, пересекающие заданную полилинию

Синтаксис

[Visual Basic 6]
Function GetFiguresAtPolyline ( _
   ByVal PolylineFigure As ShapePolyline _
) As Collection

[Delphi]
function GetFiguresAtPolyline(
   const PolylineFigure: ShapePolyline
): Collection

Описание параметров

PolylineFigure
[in] Полилиния, по которой нужно найти пересекаемые фигуры

Возвращаемое значение

Возвращает коллекцию всех найденных объектов типа Figure

Смотри также

Class Collection, Class ShapePolyline, Class VectorLayer, Group Карты


VectorLayer.GetFiguresAtPos (метод)

Получить фигуры (коллекцию объектов типа Figure) в заданном прямоугольнике

Синтаксис

[Visual Basic 6]
Function GetFiguresAtPos ( _
   ByVal ModelPoint As ModelPoint, _
   ByVal Delta As Double _
) As Collection

[Delphi]
function GetFiguresAtPos(
   const ModelPoint: ModelPoint;
   const Delta: Double
): Collection

Описание параметров

ModelPoint
[in] Точка на карте в модельной системе координат, в которой надо найти фигуры
Delta
[in] Максимальное допустимое отклонение при поиске фигур

Возвращаемое значение

Возвращает коллекцию всех найденных объектов типа Figure

Смотри также

Class Collection, Class ModelPoint, Class VectorLayer, Group Карты


VectorLayer.GetFiguresAtRect (метод)

Получить фигуры в заданном прямоугольнике

Синтаксис

[Visual Basic 6]
Function GetFiguresAtRect ( _
   ByVal ModelRect As ModelRect, _
   [ByVal OnlyInside As Boolean = False] _
) As Collection

[Delphi]
function GetFiguresAtRect(
   const ModelRect: ModelRect;
   const OnlyInside: WordBool
): Collection

Описание параметров

ModelRect
[in] Прямоугольник в модельной системе координат, внутри которого нужно найти фигуры
OnlyInside
[in] Если OnlyInside=True, то будут найдены только те фигуры, которые находятся полностью внутри прямоугольника, иначе будут найдены и те фигуры, которые только частично попадают внутрь заданного прямоугольника

Возвращаемое значение

Возвращает коллекцию всех найденных объектов типа Figure

Смотри также

Class Collection, Class ModelRect, Class VectorLayer, Group Карты


VectorLayer.GetFigureVerb (метод)

Получение описания элемента локального меню

Синтаксис

[Visual Basic 6]
Function GetFigureVerb ( _
   ByVal Figure As Figure, _
   ByVal Container As VectorContainer, _
   ByVal VerbIndex As Long, _
   ByVal ModelPos As ModelPoint _
) As MenuVerb

[Delphi]
function GetFigureVerb(
   const Figure: Figure;
   const Container: VectorContainer;
   const VerbIndex: Integer;
   const ModelPos: ModelPoint
): MenuVerb

Описание параметров

Figure
[in] Заданная фигура
Container
[in] Контейнер, в котором отображается сейчас фигура
VerbIndex
[in] Номер элемента локального меню (нумерация идёт от 0 до GetFigureVerbCount-1)
ModelPos
[in] Точка на карте в модельной системе координат, в которой было вызвано локальное меню

Возвращаемое значение

Возвращает описание элемента локального меню

Смотри также

Class Figure, Class MenuVerb, Class ModelPoint, Class VectorContainer, Class VectorLayer, Group Карты


VectorLayer.GetFigureVerbCount (метод)

Получение общего числа элементов локального меню

Синтаксис

[Visual Basic 6]
Function GetFigureVerbCount ( _
   ByVal Figure As Figure _
) As Long

[Delphi]
function GetFigureVerbCount(
   const Figure: Figure
): Integer

Описание параметров

Figure
[in] Заданная фигура

Возвращаемое значение

Возвращает число элементов локального меню

Смотри также

Class Figure, Class VectorLayer, Group Карты


VectorLayer.GetLayerDataset (метод)

Получить набор данных слоя с заданными параметрами

Синтаксис

[Visual Basic 6]
Function GetLayerDataset ( _
   ByVal Mode As LayerDatasetModeConstants, _
   ByVal DefID As Long, _
   ByVal NoLinks As Boolean _
) As LayerDataset

[Delphi]
function GetLayerDataset(
   const Mode: LayerDatasetModeConstants;
   const DefID: Integer;
   const NoLinks: WordBool
): LayerDataset

Описание параметров

Mode
[in] Тип множества элементов в наборе данных слоя
DefID
[in] Тип элементов слоя (если на слое только один тип данных, то можно указать -1)
NoLinks
[in] Если NoLinks=True, то подключенные наборы данных не будут входит в набор данных слоя

Возвращаемое значение

Возвращает набор данных слоя

Смотри также

Class LayerDataset, Enum LayerDatasetModeConstants, Class VectorLayer, Group Карты


VectorLayer.GetSelectedFigures (метод)

Получить список выделенных фигур слоя

Синтаксис

[Visual Basic 6]
Function GetSelectedFigures As Collection

[Delphi]
function GetSelectedFigures: Collection

Возвращаемое значение

Возращает список выделенных фигур слоя

Смотри также

Class Collection, Class VectorLayer, Group Карты


VectorLayer.GetSnapPoint (метод)

Получение координат точек на слое, к которой возможна подтяжка

Синтаксис

[Visual Basic 6]
Function GetSnapPoint ( _
   ByVal Figure As Figure, _
   ByVal Index As Long _
) As ModelPoint

[Delphi]
function GetSnapPoint(
   const Figure: Figure;
   const Index: Integer
): ModelPoint

Описание параметров

Figure
[in] Заданная фигура
Index
[in] Номер точки (нумерация идёт от 0 до GetSnapPointCount-1)

Возвращаемое значение

Возвращает потенциальную точку потяжки

Смотри также

Class Figure, Class ModelPoint, Class VectorLayer, Group Карты


VectorLayer.GetSnapPointCount (метод)

Получение общего количества точек на слое, к которым возможна подтяжка

Синтаксис

[Visual Basic 6]
Function GetSnapPointCount ( _
   ByVal Figure As Figure _
) As Long

[Delphi]
function GetSnapPointCount(
   const Figure: Figure
): Integer

Описание параметров

Figure
[in] Заданная фигура

Возвращаемое значение

Возвращает общее количество точек на слое, к которым возможна подтяжка

Смотри также

Class Figure, Class VectorLayer, Group Карты


VectorLayer.GetSnapSegment (метод)

Получение координат отрезков на слое, к которой возможна подтяжка

Синтаксис

[Visual Basic 6]
Sub GetSnapSegment ( _
   ByVal Figure As Figure, _
   ByVal Index As Long, _
   AX As Double, _
   AY As Double, _
   BX As Double, _
   BY As Double _
)

[Delphi]
procedure GetSnapSegment(
   const Figure: Figure;
   const Index: Integer;
   out AX: Double;
   out AY: Double;
   out BX: Double;
   out BY: Double
)

Описание параметров

Figure
[in] Заданная фигура
Index
[in] Номер отрезка (нумерация идёт от 0 до GetSnapLineCount-1)
AX
[out] Возвращает координату X начальной точки отрезка, к которому выполняется подтяжка
AY
[out] Возвращает координату Y начальной точки отрезка, к которому выполняется подтяжка
BX
[out] Возвращает координату X конечной точки отрезка, к которому выполняется подтяжка
BY
[out] Возвращает координату Y конечной точки отрезка, к которому выполняется подтяжка

Смотри также

Class Figure, Class VectorLayer, Group Карты


VectorLayer.GetSnapSegmentCount (метод)

Получение количества отрезков на слое, к которым возможна подтяжка

Синтаксис

[Visual Basic 6]
Function GetSnapSegmentCount ( _
   ByVal Figure As Figure _
) As Long

[Delphi]
function GetSnapSegmentCount(
   const Figure: Figure
): Integer

Описание параметров

Figure
[in] Заданная фигура

Возвращаемое значение

Возвращает общее число отрезков на слое, к которым возможна подтяжка

Смотри также

Class Figure, Class VectorLayer, Group Карты


VectorLayer.HotLinkAction (метод)

Выполнение горячей связи

Синтаксис

[Visual Basic 6]
Sub HotLinkAction ( _
   ByVal Container As VectorContainer, _
   ByVal Figure As Figure, _
   ByVal AttrValue As String _
)

[Delphi]
procedure HotLinkAction(
   const Container: VectorContainer;
   const Figure: Figure;
   const AttrValue: WideString
)

Описание параметров

Container
[in] Контейнер, в котором выполняется горячая связь
Figure
[in] Фигура, для которой вызывается горячая связь
AttrValue
[in] Значение атрибута горячей связь фигуры

Смотри также

Class Figure, Class VectorContainer, Class VectorLayer, Group Карты


VectorLayer.HotLinkExists (метод)

Проверка на возможность горячей связи в заданной точке карты

Синтаксис

[Visual Basic 6]
Function HotLinkExists ( _
   ByVal Container As VectorContainer, _
   ByVal MapPos As ModelPoint _
) As Boolean

[Delphi]
function HotLinkExists(
   const Container: VectorContainer;
   const MapPos: ModelPoint
): WordBool

Описание параметров

Container
[in] Контейнер, в котором будет выполняться горячая связь
MapPos
[in] Точка карты в модельных координатах, в которой проверяется возможность выполнения горячей связи

Возвращаемое значение

Возвращает True, если выполнение возможно

Смотри также

Class ModelPoint, Class VectorContainer, Class VectorLayer, Group Карты


VectorLayer.PasteFromClipboard (метод)

Вставить из буфера обмена

Синтаксис

[Visual Basic 6]
Function PasteFromClipboard As Boolean

[Delphi]
function PasteFromClipboard: WordBool

Возвращаемое значение

Возвращает True, если вставка из буфера обмена была успешно выполнена

Смотри также

Class VectorLayer, Group Карты


VectorLayer.RemoveSnapLayer (метод)

Удалить слой, к которому разрешена подтяжка

Синтаксис

[Visual Basic 6]
Sub RemoveSnapLayer ( _
   ByVal Index As Long _
)

[Delphi]
procedure RemoveSnapLayer(
   const Index: Integer
)

Описание параметров

Index
[in] Номер удаляемого слоя

Смотри также

Class VectorLayer, Group Карты


VectorLayer.Save (метод)

Сохранить содержимое слоя

Синтаксис

[Visual Basic 6]
Sub Save

[Delphi]
procedure Save

Смотри также

Class VectorLayer, Group Карты


VectorLayer.SelectFigures (метод)

Выделить указанные фигуры слоя

Синтаксис

[Visual Basic 6]
Function SelectFigures ( _
   ByVal Figures As Collection _
) As Boolean

[Delphi]
function SelectFigures(
   const Figures: Collection
): WordBool

Описание параметров

Figures
[in] Список фигур, которые надо выделить

Возвращаемое значение

Возвращает True, если хотя бы одна фигура была выделена, и поэтому требуется перерисовка

Смотри также

Class Collection, Class VectorLayer, Group Карты


VectorLayer.SnapAllFigures (метод)

Подтяжка всего слоя

Синтаксис

[Visual Basic 6]
Function SnapAllFigures As Boolean

[Delphi]
function SnapAllFigures: WordBool

Возвращаемое значение

Возвращает True, если подтяжка была успешно выполнена

Смотри также

Class VectorLayer, Group Карты


VectorLayer.SnapFigure (метод)

Подтяжка элемента своего слоя

Синтаксис

[Visual Basic 6]
Function SnapFigure ( _
   ByVal Figure As Figure _
) As Boolean

[Delphi]
function SnapFigure(
   const Figure: Figure
): WordBool

Описание параметров

Figure
[in] Заданная фигура

Возвращаемое значение

Возвращает True, если подтяжка была успешно выполнена

Смотри также

Class Figure, Class VectorLayer, Group Карты


VectorLayer.SupportsProjection (метод)

Поддерживается ли слоем отображение в проекции

Синтаксис

[Visual Basic 6]
Function SupportsProjection As Boolean

[Delphi]
function SupportsProjection: WordBool

Возвращаемое значение

Возвращает True, если отображение в проекции поддерживается слоем

Смотри также

Class VectorLayer, Group Карты


VectorLayer.UnselectAll (метод)

Снять выделение на слое

Синтаксис

[Visual Basic 6]
Sub UnselectAll

[Delphi]
procedure UnselectAll

Смотри также

Class VectorLayer, Group Карты


Класс Version

Информация о версии приложения

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Version

ClassID = {60030014-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Build (только для чтения) | Номер сборки приложения
Property Day (только для чтения) | День выпуска версии
Property High (только для чтения) | Старшая часть версии
Property Low (только для чтения) | Младшая часть версии
Property Middle (только для чтения) | Средняя часть версии
Property Month (только для чтения) | Месяц выпуска версии
Property Year (только для чтения) | Год выпуска версии

Где используется

Класс | Член класса
Class Application | Property Version (свойство)
Class ICommonApplication | Property Version (свойство)

Смотри также

Group Приложение


Version.Build (свойство)

Номер сборки приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property Build As Long

[Delphi]
{только для чтения} property Build: Integer

Смотри также

Class Version, Group Приложение


Version.Day (свойство)

День выпуска версии

Синтаксис

[Visual Basic 6]
ReadOnly Property Day As Long

[Delphi]
{только для чтения} property Day: Integer

Смотри также

Class Version, Group Приложение


Version.High (свойство)

Старшая часть версии

Синтаксис

[Visual Basic 6]
ReadOnly Property High As Long

[Delphi]
{только для чтения} property High: Integer

Смотри также

Class Version, Group Приложение


Version.Low (свойство)

Младшая часть версии

Синтаксис

[Visual Basic 6]
ReadOnly Property Low As Long

[Delphi]
{только для чтения} property Low: Integer

Смотри также

Class Version, Group Приложение


Version.Middle (свойство)

Средняя часть версии

Синтаксис

[Visual Basic 6]
ReadOnly Property Middle As Long

[Delphi]
{только для чтения} property Middle: Integer

Смотри также

Class Version, Group Приложение


Version.Month (свойство)

Месяц выпуска версии

Синтаксис

[Visual Basic 6]
ReadOnly Property Month As Long

[Delphi]
{только для чтения} property Month: Integer

Смотри также

Class Version, Group Приложение


Version.Year (свойство)

Год выпуска версии

Синтаксис

[Visual Basic 6]
ReadOnly Property Year As Long

[Delphi]
{только для чтения} property Year: Integer

Смотри также

Class Version, Group Приложение


Класс VideoRowViewer

Объект "Просмотрщик видеорядов"

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.VideoRowViewer

ClassID = {777B1002-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Caption | Заголовок окна видеоряда
Property CurrentFrame | Получить текущий индекс кадра в видеоряде
Property FileName | Получить текущее имя файла видеоряда
Property FrameCount (только для чтения) | Количество кадров в текущем файле
Property LastError (только для чтения) |
Property ObjectID (только для чтения) | Идентификатор записанного объекта
Property PK | Значение пикета в текущем кадре
Property PKmax (только для чтения) | Максимальный пикет кадра в файле
Property PKmin (только для чтения) | Минимальный пикет кадра в файле
Property Playing | Проигрывается ли в данный момент видеоряд
Property RecordDate (только для чтения) | Дата и время создания видеоряда
Property SlideShowDelay |
Property WindowVisible | Получить состояние окна просмотра

Методы класса

Имя | Описание
Method Close | Закрыть файл (освобождается файл)
Method DrawFrameToDC | Отрисовать кадр видеоряда на указанный DC
Method FrameToPK | Получить значение пикета для указанного кадра
Method GetFrameParams | Получить параметры кадра видеоряда
Method Init | Инициализация (вызывать после создания объекта)
Method IsOpen | Открыт ли файл
Method Open | Открыть файл (считывается заголовок, файл блокируется)
Method OpenWithPK | Открыть файл (считывается заголовок, файл блокируется). Если PK<>MAXINT, то в качестве текущего кадра выставляется кадр, ближайший к указанному пикету, иначе - нулевой кадр
Method PKToFrame |
Method SelectFile | Вызывает диалог выбора файла видеоряда

Смотри также

Interface IVideoRowViewerHandler


VideoRowViewer.Caption (свойство)

Заголовок окна видеоряда

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class VideoRowViewer


VideoRowViewer.CurrentFrame (свойство)

Получить текущий индекс кадра в видеоряде

Синтаксис

[Visual Basic 6]
Property CurrentFrame As Long

[Delphi]
property CurrentFrame: Integer

Смотри также

Class VideoRowViewer


VideoRowViewer.FileName (свойство)

Получить текущее имя файла видеоряда

Синтаксис

[Visual Basic 6]
Property FileName As String

[Delphi]
property FileName: WideString

Смотри также

Class VideoRowViewer


VideoRowViewer.FrameCount (свойство)

Количество кадров в текущем файле

Синтаксис

[Visual Basic 6]
ReadOnly Property FrameCount As Long

[Delphi]
{только для чтения} property FrameCount: Integer

Смотри также

Class VideoRowViewer


VideoRowViewer.LastError (свойство)

Синтаксис

[Visual Basic 6]
ReadOnly Property LastError As String

[Delphi]
{только для чтения} property LastError: WideString

Смотри также

Class VideoRowViewer


VideoRowViewer.ObjectID (свойство)

Идентификатор записанного объекта

Синтаксис

[Visual Basic 6]
ReadOnly Property ObjectID As Long

[Delphi]
{только для чтения} property ObjectID: Cardinal

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class VideoRowViewer


VideoRowViewer.PK (свойство)

Значение пикета в текущем кадре

Синтаксис

[Visual Basic 6]
Property PK As Long

[Delphi]
property PK: Integer

Смотри также

Class VideoRowViewer


VideoRowViewer.PKmax (свойство)

Максимальный пикет кадра в файле

Синтаксис

[Visual Basic 6]
ReadOnly Property PKmax As Long

[Delphi]
{только для чтения} property PKmax: Integer

Смотри также

Class VideoRowViewer


VideoRowViewer.PKmin (свойство)

Минимальный пикет кадра в файле

Синтаксис

[Visual Basic 6]
ReadOnly Property PKmin As Long

[Delphi]
{только для чтения} property PKmin: Integer

Смотри также

Class VideoRowViewer


VideoRowViewer.Playing (свойство)

Проигрывается ли в данный момент видеоряд

Синтаксис

[Visual Basic 6]
Property Playing As Boolean

[Delphi]
property Playing: WordBool

Смотри также

Class VideoRowViewer


VideoRowViewer.RecordDate (свойство)

Дата и время создания видеоряда

Синтаксис

[Visual Basic 6]
ReadOnly Property RecordDate As Double

[Delphi]
{только для чтения} property RecordDate: Double

Смотри также

Class VideoRowViewer


VideoRowViewer.SlideShowDelay (свойство)

Синтаксис

[Visual Basic 6]
Property SlideShowDelay As Long

[Delphi]
property SlideShowDelay: Integer

Смотри также

Class VideoRowViewer


VideoRowViewer.WindowVisible (свойство)

Получить состояние окна просмотра

Синтаксис

[Visual Basic 6]
Property WindowVisible As Boolean

[Delphi]
property WindowVisible: WordBool

Смотри также

Class VideoRowViewer


VideoRowViewer.Close (метод)

Закрыть файл (освобождается файл)

Синтаксис

[Visual Basic 6]
Sub Close

[Delphi]
procedure Close

Смотри также

Class VideoRowViewer


VideoRowViewer.DrawFrameToDC (метод)

Отрисовать кадр видеоряда на указанный DC

Синтаксис

[Visual Basic 6]
Function DrawFrameToDC ( _
   ByVal Index As Long, _
   ByVal DC As Long _
) As Boolean

[Delphi]
function DrawFrameToDC(
   const Index: Integer;
   const DC: Integer
): WordBool

Описание параметров

Index
[in]
DC
[in]

Возвращаемое значение

Функция возвращает значение типа Boolean.

Смотри также

Class VideoRowViewer


VideoRowViewer.FrameToPK (метод)

Получить значение пикета для указанного кадра

Синтаксис

[Visual Basic 6]
Function FrameToPK ( _
   ByVal Index As Long _
) As Long

[Delphi]
function FrameToPK(
   const Index: Integer
): Integer

Описание параметров

Index
[in]

Возвращаемое значение

Функция возвращает значение типа Long.

Смотри также

Class VideoRowViewer


VideoRowViewer.GetFrameParams (метод)

Получить параметры кадра видеоряда

Синтаксис

[Visual Basic 6]
Function GetFrameParams ( _
   ByVal Index As Long, _
   Width As Long, _
   Height As Long, _
   PK As Long, _
   Evenness As Long, _
   DateTime As Double _
) As Boolean

[Delphi]
function GetFrameParams(
   const Index: Integer;
   out Width: Integer;
   out Height: Integer;
   out PK: Integer;
   out Evenness: Integer;
   out DateTime: Double
): WordBool

Описание параметров

Index
[in]
Width
[out]
Height
[out]
PK
[out]
Evenness
[out]
DateTime
[out]

Возвращаемое значение

Функция возвращает значение типа Boolean.

Смотри также

Class VideoRowViewer


VideoRowViewer.Init (метод)

Инициализация (вызывать после создания объекта)

Синтаксис

[Visual Basic 6]
Sub Init ( _
   ByVal AppHandle As Long, _
   ByVal Handler As IVideoRowViewerHandler _
)

[Delphi]
procedure Init(
   const AppHandle: Integer;
   const Handler: IVideoRowViewerHandler
)

Описание параметров

AppHandle
[in]
Handler
[in]

Смотри также

Interface IVideoRowViewerHandler, Class VideoRowViewer


VideoRowViewer.IsOpen (метод)

Открыт ли файл

Синтаксис

[Visual Basic 6]
Function IsOpen As Boolean

[Delphi]
function IsOpen: WordBool

Возвращаемое значение

Функция возвращает значение типа Boolean.

Смотри также

Class VideoRowViewer


VideoRowViewer.Open (метод)

Открыть файл (считывается заголовок, файл блокируется)

Синтаксис

[Visual Basic 6]
Function Open As Boolean

[Delphi]
function Open: WordBool

Возвращаемое значение

Функция возвращает значение типа Boolean.

Смотри также

Class VideoRowViewer


VideoRowViewer.OpenWithPK (метод)

Открыть файл (считывается заголовок, файл блокируется). Если PK<>MAXINT, то в качестве текущего кадра выставляется кадр, ближайший к указанному пикету, иначе - нулевой кадр

Синтаксис

[Visual Basic 6]
Function OpenWithPK ( _
   [ByVal PK As Long = 2147483647] _
) As Boolean

[Delphi]
function OpenWithPK(
   const PK: Integer
): WordBool

Описание параметров

PK
[in]

Возвращаемое значение

Функция возвращает значение типа Boolean.

Смотри также

Class VideoRowViewer


VideoRowViewer.PKToFrame (метод)

Синтаксис

[Visual Basic 6]
Function PKToFrame ( _
   ByVal PK As Long _
) As Long

[Delphi]
function PKToFrame(
   const PK: Integer
): Integer

Описание параметров

PK
[in]

Возвращаемое значение

Функция возвращает значение типа Long.

Смотри также

Class VideoRowViewer


VideoRowViewer.SelectFile (метод)

Вызывает диалог выбора файла видеоряда

Синтаксис

[Visual Basic 6]
Function SelectFile ( _
   FileName As String _
) As Boolean

[Delphi]
function SelectFile(
   var FileName: WideString
): WordBool

Описание параметров

FileName
[in, out]

Возвращаемое значение

Функция возвращает значение типа Boolean.

Смотри также

Class VideoRowViewer


Класс VideoRowWriter

Объект "Запись видеорядов"

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.VideoRowWriter

ClassID = {777B1004-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property DataSize (только для чтения) | Текущий размер всех данных в файле видеоряда

Методы класса

Имя | Описание
Method AddFrame | Добавить кадр из DC
Method AddFrameStream | Добавить кадр из потока
Method Close | Закрыть файл видеоряда
Method CreateNew | Создать файл видеоряда

Смотри также

Enum FrameFormatConstants


VideoRowWriter.DataSize (свойство)

Текущий размер всех данных в файле видеоряда

Синтаксис

[Visual Basic 6]
ReadOnly Property DataSize As Long

[Delphi]
{только для чтения} property DataSize: Cardinal

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class VideoRowWriter


VideoRowWriter.AddFrame (метод)

Добавить кадр из DC

Синтаксис

[Visual Basic 6]
Sub AddFrame ( _
   ByVal DC As Long, _
   ByVal Width As Long, _
   ByVal Height As Long, _
   ByVal FrameFormat As FrameFormatConstants, _
   ByVal Quality As Long, _
   ByVal PK As Long, _
   ByVal Evenness As Long, _
   ByVal Source As Long, _
   ByVal DateTime As Double _
)

[Delphi]
procedure AddFrame(
   const DC: Integer;
   const Width: Integer;
   const Height: Integer;
   const FrameFormat: FrameFormatConstants;
   const Quality: Integer;
   const PK: Integer;
   const Evenness: Integer;
   const Source: Integer;
   const DateTime: Double
)

Описание параметров

DC
[in]
Width
[in]
Height
[in]
FrameFormat
[in]
Quality
[in]
PK
[in]
Evenness
[in]
Source
[in]
DateTime
[in]

Смотри также

Enum FrameFormatConstants, Class VideoRowWriter


VideoRowWriter.AddFrameStream (метод)

Добавить кадр из потока

Синтаксис

[Visual Basic 6]
Sub AddFrameStream ( _
   ByVal Stream As IUnknown, _
   ByVal Width As Long, _
   ByVal Height As Long, _
   ByVal FrameFormat As FrameFormatConstants, _
   ByVal PK As Long, _
   ByVal Evenness As Long, _
   ByVal Source As Long, _
   ByVal DateTime As Double _
)

[Delphi]
procedure AddFrameStream(
   const Stream: IUnknown;
   const Width: Integer;
   const Height: Integer;
   const FrameFormat: FrameFormatConstants;
   const PK: Integer;
   const Evenness: Integer;
   const Source: Integer;
   const DateTime: Double
)

Описание параметров

Stream
[in]
Width
[in]
Height
[in]
FrameFormat
[in]
PK
[in]
Evenness
[in]
Source
[in]
DateTime
[in]

Смотри также

Enum FrameFormatConstants, Class VideoRowWriter


VideoRowWriter.Close (метод)

Закрыть файл видеоряда

Синтаксис

[Visual Basic 6]
Sub Close

[Delphi]
procedure Close

Смотри также

Class VideoRowWriter


VideoRowWriter.CreateNew (метод)

Создать файл видеоряда

Синтаксис

[Visual Basic 6]
Sub CreateNew ( _
   ByVal FileName As String _
)

[Delphi]
procedure CreateNew(
   const FileName: WideString
)

Описание параметров

FileName
[in]

Смотри также

Class VideoRowWriter


Класс Window

Любое экранное окно

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Height | Высота окна
Property Left | Координата левой стороны окна
Property Top | Координата верхней стороны окна
Property Width | Ширина окна
Property WindowHandle (только для чтения) | Handle окна

Смотри также

Group Пользовательский интерфейс


Window.Height (свойство)

Высота окна

Синтаксис

[Visual Basic 6]
Property Height As Long

[Delphi]
property Height: Integer

Смотри также

Class Window, Group Пользовательский интерфейс


Window.Left (свойство)

Координата левой стороны окна

Синтаксис

[Visual Basic 6]
Property Left As Long

[Delphi]
property Left: Integer

Смотри также

Class Window, Group Пользовательский интерфейс


Window.Top (свойство)

Координата верхней стороны окна

Синтаксис

[Visual Basic 6]
Property Top As Long

[Delphi]
property Top: Integer

Смотри также

Class Window, Group Пользовательский интерфейс


Window.Width (свойство)

Ширина окна

Синтаксис

[Visual Basic 6]
Property Width As Long

[Delphi]
property Width: Integer

Смотри также

Class Window, Group Пользовательский интерфейс


Window.WindowHandle (свойство)

Handle окна

Синтаксис

[Visual Basic 6]
ReadOnly Property WindowHandle As OLE_HANDLE

[Delphi]
{только для чтения} property WindowHandle: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class Window, Group Пользовательский интерфейс


Интерфейс IApplicationEvents

События системы IndorCAD

Наследование

IUnknown Class IApplicationEvents

Методы интерфейса

Имя | Описание
Method Idle | Вызывается при наличии свободного процессорного времени
Method ProjectActivated | Вызывается при активизации проекта
Method ProjectCreate | Вызывается при создании проекта

Где используется

Класс | Член класса
Class Application | Method Advise (метод)

Смотри также

Class Project, Group Приложение


IApplicationEvents.Idle (метод)

Вызывается при наличии свободного процессорного времени

Синтаксис

[Visual Basic 6]
Sub Idle ( _
   Done As Boolean _
)

[Delphi]
procedure Idle(
   var Done: WordBool
)

Описание параметров

Done
[in, out] Если обработчик данного события вернет Done=False, значит данный обботчик будет вызван повторно до тех пор, пока не будет возвращен Done=True

Смотри также

Interface IApplicationEvents, Group Приложение


IApplicationEvents.ProjectActivated (метод)

Вызывается при активизации проекта

Синтаксис

[Visual Basic 6]
Sub ProjectActivated ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectActivated(
   const Project: Project
)

Описание параметров

Project
[in] Проект, который стал текущим. Если Project=Nothing, значит нет активного проекта

Смотри также

Interface IApplicationEvents, Class Project, Group Приложение


IApplicationEvents.ProjectCreate (метод)

Вызывается при создании проекта

Синтаксис

[Visual Basic 6]
Sub ProjectCreate ( _
   ByVal Project As Project, _
   ByVal CreatedAsNew As Boolean _
)

[Delphi]
procedure ProjectCreate(
   const Project: Project;
   const CreatedAsNew: WordBool
)

Описание параметров

Project
[in] Вновь созданный проект
CreatedAsNew
[in] True - проект создан как новый. False - проект будет загружаться из файла

Смотри также

Interface IApplicationEvents, Class Project, Group Приложение


Интерфейс ICADAssignableWithLayerObject

Реализуется объектами IndorCAD, поддерживающими импорт своих данных из другого проекта или слоя

Наследование

IUnknown Class ICADAssignableWithLayerObject

Методы интерфейса

Имя | Описание
Method AppendDataToAnotherLayer | Добавляет свои подобъекты в другой слой
Method GetDescription | Возвращает описание объекта
Method GetObjectCount | Возвращает количество элементов, которое может быть скопировано в другой слой

Смотри также

Class Layer, Group Внешние модули


ICADAssignableWithLayerObject.AppendDataToAnotherLayer (метод)

Добавляет свои подобъекты в другой слой

Синтаксис

[Visual Basic 6]
Sub AppendDataToAnotherLayer ( _
   ByVal TargetLayer As Layer _
)

[Delphi]
procedure AppendDataToAnotherLayer(
   const TargetLayer: Layer
)

Описание параметров

TargetLayer
[in] Слой, в который объект должен скопировать свои данные

Замечания

Важно: объект должен не переместить данные, а полностью их скопировать в слой TargetLayer

Смотри также

Interface ICADAssignableWithLayerObject, Class Layer, Group Внешние модули


ICADAssignableWithLayerObject.GetDescription (метод)

Возвращает описание объекта

Синтаксис

[Visual Basic 6]
Sub GetDescription ( _
   Description As String _
)

[Delphi]
procedure GetDescription(
   out Description: WideString
)

Описание параметров

Description
[out] Объект должен вернуть своё описание, которое будет отображено в диалоге импорта. Возвращённое значение должно быть непустымы

Смотри также

Interface ICADAssignableWithLayerObject, Group Внешние модули


ICADAssignableWithLayerObject.GetObjectCount (метод)

Возвращает количество элементов, которое может быть скопировано в другой слой

Синтаксис

[Visual Basic 6]
Sub GetObjectCount ( _
   Count As Long _
)

[Delphi]
procedure GetObjectCount(
   out Count: Integer
)

Описание параметров

Count
[out] Объект должен вернуть количество подобъектов, которое может быть скопировано в другой слой (возвращённое количество отобразится в диалоге импорта)

Смотри также

Interface ICADAssignableWithLayerObject, Group Внешние модули


Интерфейс ICADDataCreator

Реализуется объектами, которые регистрируются в Application.RegisterData и умеют создавать экземпляры данных для IndorCAD

Наследование

IUnknown Class ICADDataCreator

Методы интерфейса

Имя | Описание
Method CreateInstance | Создаёт и возвращает экземпляр объекта
Method ReleaseInstance | Уничтожает ранее созданный экземпляр объекта

Замечания

Созданный объект должен быть интерфейсным объектом, т.е. автоматически уничтожаться, если на объект никто не ссылается

Смотри также

Class Aggregate, Interface ICADObject, Class Project, Group Внешние модули


ICADDataCreator.CreateInstance (метод)

Создаёт и возвращает экземпляр объекта

Синтаксис

[Visual Basic 6]
Sub CreateInstance ( _
   ByVal Context As Aggregate, _
   ByVal Project As Project, _
   ByVal UserData As Long, _
   CreatedObject As ICADObject _
)

[Delphi]
procedure CreateInstance(
   const Context: Aggregate;
   const Project: Project;
   const UserData: Integer;
   out CreatedObject: ICADObject
)

Описание параметров

Context
[in] Объект-родитель, для которого запрашивается создание подобъекта
Project
[in] Проект, в котором будет существовать объект
UserData
[in] Пользовательское значение, переданное при регистрации внешних данных
CreatedObject
[out] Возвращаемый созданный объект либо Nothing в случае неудачи

Смотри также

Class Aggregate, Interface ICADDataCreator, Interface ICADObject, Class Project, Group Внешние модули


ICADDataCreator.ReleaseInstance (метод)

Уничтожает ранее созданный экземпляр объекта

Синтаксис

[Visual Basic 6]
Sub ReleaseInstance ( _
   ByVal UserData As Long, _
   ObjectToRelease As ICADObject _
)

[Delphi]
procedure ReleaseInstance(
   const UserData: Integer;
   var ObjectToRelease: ICADObject
)

Описание параметров

UserData
[in] Пользовательское значение, переданное при регистрации внешних данных
ObjectToRelease
[in, out] Объект, подлежащий уничтожению

Замечания

Если созданный ранее объект не уничтожается автоматически при нулевом количестве ссылок на объект, то в этом методе необходимо присвоить ObjectToRelease значение Nothing и уничтожить объект. Если объект уничтожается автоматически, то можно оставить реализацию метода пустой

Смотри также

Interface ICADDataCreator, Interface ICADObject, Group Внешние модули


Интерфейс ICADObject

Интерфейс, который обязан реализовывать любой объект IndorCAD, встраивающийся в дерево объектов

Наследование

IUnknown Class ICADObject

Свойства интерфейса

Имя | Описание
Property Name | Имя объекта

Методы интерфейса

Имя | Описание
Method Attaching | Вызывается при присоединении объекта к проекту. Объект может подписаться на события и т.д.
Method GetHandle | Возвращает Handle объекта
Method GetObjectID | Уникальный идентификатор экземпляра объекта. Должен создаваться при создании объекта функцией CoCreateGUID, а так же сохраняться и загружаться с проектом
Method GetSignature | Уникальная строка, индентифицирующая класс объекта
Method MakeTreeStructure | Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта
Method MoveItem | Переместить подобъекты (либо дочерние объекты) относительно друг друга
Method UnAttaching | Вызывается при отсоединении объекта от проекта. Объект должен отписаться от подписаных событий и т.д. Но не уничтожать ни себя, ни своих детей

Где используется

Класс | Член класса
Class Aggregate | Property Items (свойство)
Class ICADDataCreator | Method CreateInstance (метод) Method ReleaseInstance (метод)
Class ICADObject | Method MoveItem (метод)
Class Layer | Property Items (свойство)
Class Project | Property Items (свойство)
Class Route | Property Items (свойство)

Смотри также

GUID, Interface IDocTreeHandler, Group Внешние модули


ICADObject.Name (свойство)

Имя объекта

Синтаксис

[Visual Basic 6]
Property Name As String

[Delphi]
property Name: WideString

Смотри также

Interface ICADObject, Group Внешние модули


ICADObject.Attaching (метод)

Вызывается при присоединении объекта к проекту. Объект может подписаться на события и т.д.

Синтаксис

[Visual Basic 6]
Sub Attaching

[Delphi]
procedure Attaching

Смотри также

Interface ICADObject, Group Внешние модули


ICADObject.GetHandle (метод)

Возвращает Handle объекта

Синтаксис

[Visual Basic 6]
Sub GetHandle ( _
   Handle As OLE_HANDLE _
)

[Delphi]
procedure GetHandle(
   out Handle: OLE_HANDLE
)

Описание параметров

Handle
[out] Handle объекта. Обычно является указателем на сам объект

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Interface ICADObject, Group Внешние модули


ICADObject.GetObjectID (метод)

Уникальный идентификатор экземпляра объекта. Должен создаваться при создании объекта функцией CoCreateGUID, а так же сохраняться и загружаться с проектом

Синтаксис

[Visual Basic 6]
Function GetObjectID As GUID

[Delphi]
function GetObjectID: GUID

Возвращаемое значение

Функция возвращает значение типа GUID.

Смотри также

GUID, Interface ICADObject, Group Внешние модули


ICADObject.GetSignature (метод)

Уникальная строка, индентифицирующая класс объекта

Синтаксис

[Visual Basic 6]
Sub GetSignature ( _
   Signature As String _
)

[Delphi]
procedure GetSignature(
   out Signature: WideString
)

Описание параметров

Signature
[out] Объект должен возвратить уникальную среди всех объектов IndorCAD строку. Возвращаемое значение не должно быть пустой строкой

Смотри также

Interface ICADObject, Group Внешние модули


ICADObject.MakeTreeStructure (метод)

Перечислить в DocTreeHandler всю иерархию подобъектов (в виде дерева), начиная с самого объекта

Синтаксис

[Visual Basic 6]
Sub MakeTreeStructure ( _
   ByVal Handler As IDocTreeHandler, _
   ByVal ParentID As Long, _
   ByVal Reason As Long, _
   ByVal IncludeHidden As Boolean _
)

[Delphi]
procedure MakeTreeStructure(
   const Handler: IDocTreeHandler;
   const ParentID: Integer;
   const Reason: Integer;
   const IncludeHidden: WordBool
)

Описание параметров

Handler
[in] Объект, которому будут поочерёдно передаваться все объекты, содержащиеся в проекте
ParentID
[in] Некий идентификатор родительского узла (обычно "0")
Reason
[in] Значение, которое будет передаваться в Handler при добавлении объектов. По нему Handler, принимающий перечисляемые объекты, может определить, что с ними делать
IncludeHidden
[in] Некоторые объекты могут не перечислять себя, если они не содержат подобъектов. Если IncludeHidden установлен в True, то объект должен перечислить себя в любом случае

Смотри также

Interface ICADObject, Interface IDocTreeHandler, Group Внешние модули


ICADObject.MoveItem (метод)

Переместить подобъекты (либо дочерние объекты) относительно друг друга

Синтаксис

[Visual Basic 6]
Sub MoveItem ( _
   ByVal ItemToMove As ICADObject, _
   ByVal Item2 As ICADObject, _
   ByVal TestOnly As Boolean, _
   ByVal PutBefore As Boolean, _
   Result As Boolean _
)

[Delphi]
procedure MoveItem(
   const ItemToMove: ICADObject;
   const Item2: ICADObject;
   const TestOnly: WordBool;
   const PutBefore: WordBool;
   out Result: WordBool
)

Описание параметров

ItemToMove
[in] Объект, который следует переместить
Item2
[in] Объект, к которому перемещается ItemToMove
TestOnly
[in] Если True, то не нужно выполнять перемещения, необходимо только вернуть потенциальную возможность выполнения перемещения
PutBefore
[in] True, если предполагается поместить объект ItemToMove перед Item2. False - если после
Result
[out] Возвращаемый результат выполнения операции. Если TestOnly=True, то необходимо возвратить потенциальную возможность выполнения перемещения. Если TestOnly=False, то необходимо возвратить результат операции перемещения

Смотри также

Interface ICADObject, Group Внешние модули


ICADObject.UnAttaching (метод)

Вызывается при отсоединении объекта от проекта. Объект должен отписаться от подписаных событий и т.д. Но не уничтожать ни себя, ни своих детей

Синтаксис

[Visual Basic 6]
Sub UnAttaching

[Delphi]
procedure UnAttaching

Смотри также

Interface ICADObject, Group Внешние модули


Интерфейс IContainerModeEvents

Обработчик режима работы контейнера

Наследование

IUnknown Class IContainerModeEvents

Методы интерфейса

Имя | Описание
Method Activate | Режим активирован
Method AfterContentDraw | Вызывается после прорисовки контенера в памяти
Method AfterMenuPopup | Вызывается после выпадения локального меню (здесь можно удалить элементы меню или стереть что-то на экране)
Method AfterPaint | Вызывается после прорисовки подготовленного в памяти изображения контенера на экране
Method BeforeContentDraw | Вызывается перед прорисовкой контенера в памяти
Method BeforeMenuPopup | Вызывается перед выпадение локального меню (здесь можно добавить новые элементы меню или нарисовать что-то на экране)
Method BeforePaint | Вызывается перед прорисовкой подготовленного в памяти изображения карты на экране. Здесь можно дополнительно нарисовать без мельтешения что-либо в Memory
Method Deactivate | Режим деактивирован
Method DoTrackedPos | Вызывается во время трассировки для поддержки геодезического редактора
Method DoTracking | Вызывается во время трассировки фигур
Method DrawSubModeExample | Рисование примера типа элемента в заданном месте и размера
Method GetCursor | Получить курсор в заданной точке контейнера
Method GetModeDefinition | Получить описание режима
Method GetSubModeDefinition | Получить описание элемента меню в подрежиме группы
Method GetSubModeGroupDefinition | Получить описание группы подрежимов в меню
Method GetSubModeGroupNumber | Получить количество групп подрежимов
Method Idle | Обновление состояния режима
Method IsSubModeOwnerDraw | Проверить, будет ли выполняться специальная отрисовка иконок режимов, не используя ImageIndex
Method KeyDown | Отработка нажатия клавиши на клавиатуре
Method KeyPress | Отработка ввода символа (нажатия символьной клавиши на клавиатуре)
Method KeyUp | Отработка отпускания клавиши на клавиатуре
Method MouseDown | Отработка нажатия кнопки мышки (возвращает True, если событие отработано)
Method MouseEnter | Возникает в момент, когда курсор мыши входит в окно контейнера
Method MouseLeave | Возникает в момент, когда курсор мыши покидает окно контейнера
Method MouseMove | Отработка перемещения курсора мышки
Method MouseUp | Отработка отпускания кнопки мышки (возвращает True, если событие отработано)
Method MouseWheel | Отработка вращения колеса мышки
Method Navigate | В контейнере произошло изменение текущей видимой области изображения
Method RecreateWindow | HWnd окна контейнера выделен заново (здесь можно провести какие-то переинициализации)
Method WndProc | Обработка произвольных событий, поступающих в контейнер

Где используется

Класс | Член класса
Class ContainerModeHandler | Property Handler (свойство)
Class CustomContainer | Method RegisterMode (метод)
Class VectorContainer | Method RegisterMode (метод)

Смотри также

Enum CursorConstants, Enum MouseButtonConstants, Enum ShiftStateConstants, Group Контейнеры изображений


IContainerModeEvents.Activate (метод)

Режим активирован

Синтаксис

[Visual Basic 6]
Sub Activate

[Delphi]
procedure Activate

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.AfterContentDraw (метод)

Вызывается после прорисовки контенера в памяти

Синтаксис

[Visual Basic 6]
Sub AfterContentDraw

[Delphi]
procedure AfterContentDraw

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.AfterMenuPopup (метод)

Вызывается после выпадения локального меню (здесь можно удалить элементы меню или стереть что-то на экране)

Синтаксис

[Visual Basic 6]
Sub AfterMenuPopup

[Delphi]
procedure AfterMenuPopup

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.AfterPaint (метод)

Вызывается после прорисовки подготовленного в памяти изображения контенера на экране

Синтаксис

[Visual Basic 6]
Sub AfterPaint

[Delphi]
procedure AfterPaint

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.BeforeContentDraw (метод)

Вызывается перед прорисовкой контенера в памяти

Синтаксис

[Visual Basic 6]
Sub BeforeContentDraw

[Delphi]
procedure BeforeContentDraw

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.BeforeMenuPopup (метод)

Вызывается перед выпадение локального меню (здесь можно добавить новые элементы меню или нарисовать что-то на экране)

Синтаксис

[Visual Basic 6]
Sub BeforeMenuPopup ( _
   ByVal X As Long, _
   ByVal Y As Long, _
   ByVal PopupMenu As OLE_HANDLE, _
   Handled As Boolean _
)

[Delphi]
procedure BeforeMenuPopup(
   const X: Integer;
   const Y: Integer;
   const PopupMenu: OLE_HANDLE;
   out Handled: WordBool
)

Описание параметров

X
[in] Координата X точки на контейнере, в которой было вызвано локальное меню
Y
[in] Координата Y точки на контейнере, в которой было вызвано локальное меню
PopupMenu
[in] Хендл TPopupMenu выпадающего меню
Handled
[out] В данном параметре необходимо вернуть True чтобы предотвратить появление стандартного всплывающего меню

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.BeforePaint (метод)

Вызывается перед прорисовкой подготовленного в памяти изображения карты на экране. Здесь можно дополнительно нарисовать без мельтешения что-либо в Memory

Синтаксис

[Visual Basic 6]
Sub BeforePaint

[Delphi]
procedure BeforePaint

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.Deactivate (метод)

Режим деактивирован

Синтаксис

[Visual Basic 6]
Sub Deactivate

[Delphi]
procedure Deactivate

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.DoTrackedPos (метод)

Вызывается во время трассировки для поддержки геодезического редактора

Синтаксис

[Visual Basic 6]
Sub DoTrackedPos ( _
   FlatX As Double, _
   FlatY As Double, _
   Continue As Boolean _
)

[Delphi]
procedure DoTrackedPos(
   var FlatX: Double;
   var FlatY: Double;
   var Continue: WordBool
)

Описание параметров

FlatX
[in, out] Координата X новой точки в плоской системе координат контейнера
FlatY
[in, out] Координата Y новой точки в плоской системе координат контейнера
Continue
[in, out] Продолжить ли трассировку дальше

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.DoTracking (метод)

Вызывается во время трассировки фигур

Синтаксис

[Visual Basic 6]
Sub DoTracking ( _
   ByVal PreviousX As Double, _
   ByVal PreviousY As Double, _
   CurrentX As Double, _
   CurrentY As Double _
)

[Delphi]
procedure DoTracking(
   const PreviousX: Double;
   const PreviousY: Double;
   var CurrentX: Double;
   var CurrentY: Double
)

Описание параметров

PreviousX
[in] Координата X предыдущего положения очередной вводимой точки в плоской системе координат контейнера
PreviousY
[in] Координата Y предыдущего положения очередной вводимой точки в плоской системе координат контейнера
CurrentX
[in, out] Координата X новой точки в плоской системе координат контейнера
CurrentY
[in, out] Координата Y новой точки в плоской системе координат контейнера

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.DrawSubModeExample (метод)

Рисование примера типа элемента в заданном месте и размера

Синтаксис

[Visual Basic 6]
Sub DrawSubModeExample ( _
   ByVal SubModeGroup As Long, _
   ByVal SubModeIndex As Long, _
   ByVal HDC As OLE_HANDLE, _
   ByVal Left As Long, _
   ByVal Top As Long, _
   ByVal Right As Long, _
   ByVal Bottom As Long _
)

[Delphi]
procedure DrawSubModeExample(
   const SubModeGroup: Integer;
   const SubModeIndex: Integer;
   const HDC: OLE_HANDLE;
   const Left: Integer;
   const Top: Integer;
   const Right: Integer;
   const Bottom: Integer
)

Описание параметров

SubModeGroup
[in] Номер группы подрежима
SubModeIndex
[in] Номер подрежима внутри группы
HDC
[in] HDC устройства вывода
Left
[in] Левая сторона области рисования примера
Top
[in] Верхняя сторона области рисования примера
Right
[in] Правая сторона области рисования примера
Bottom
[in] Нижняя сторона области рисования примера

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.GetCursor (метод)

Получить курсор в заданной точке контейнера

Синтаксис

[Visual Basic 6]
Sub GetCursor ( _
   ByVal CursorX As Long, _
   ByVal CursorY As Long, _
   Cursor As CursorConstants _
)

[Delphi]
procedure GetCursor(
   const CursorX: Integer;
   const CursorY: Integer;
   out Cursor: CursorConstants
)

Описание параметров

CursorX
[in] Координата X положения курсора в системе координат окна контейнера
CursorY
[in] Координата Y положения курсора в системе координат окна контейнера
Cursor
[out] Возвращается тип курсора

Смотри также

Enum CursorConstants, Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.GetModeDefinition (метод)

Получить описание режима

Синтаксис

[Visual Basic 6]
Sub GetModeDefinition ( _
   Caption As String, _
   Description As String, _
   Hint As String, _
   ImageIndex As Long, _
   Enabled As Boolean, _
   ShortCut As Long _
)

[Delphi]
procedure GetModeDefinition(
   out Caption: WideString;
   out Description: WideString;
   out Hint: WideString;
   out ImageIndex: Integer;
   out Enabled: WordBool;
   out ShortCut: Integer
)

Описание параметров

Caption
[out] Возвращается название для элемента меню
Description
[out] Возвращается описание режима, показываемое в строке статуса
Hint
[out] Возвращается всплывающая подсказка
ImageIndex
[out] Возвращается код иконки из набора картинок приложения
Enabled
[out] Возвращается True, если в настоящее время режим разрешен
ShortCut
[out] Возвращается горячая клавиша для выбора режима

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.GetSubModeDefinition (метод)

Получить описание элемента меню в подрежиме группы

Синтаксис

[Visual Basic 6]
Sub GetSubModeDefinition ( _
   ByVal SubModeGroup As Long, _
   ByVal SubModeIndex As Long, _
   Caption As String, _
   ImageIndex As Long, _
   Enabled As Boolean, _
   ShortCut As Long _
)

[Delphi]
procedure GetSubModeDefinition(
   const SubModeGroup: Integer;
   const SubModeIndex: Integer;
   out Caption: WideString;
   out ImageIndex: Integer;
   out Enabled: WordBool;
   out ShortCut: Integer
)

Описание параметров

SubModeGroup
[in] Номер группы подрежима
SubModeIndex
[in] Номер подрежима внутри группы
Caption
[out] Возвращается название, отображаемое в меню
ImageIndex
[out] Возвращается код иконки из набора картинок приложения
Enabled
[out] Возвращается True, если в настоящее время подрежим разрешен
ShortCut
[out] Возвращается горячая клавиша для выбора подрежима

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.GetSubModeGroupDefinition (метод)

Получить описание группы подрежимов в меню

Синтаксис

[Visual Basic 6]
Sub GetSubModeGroupDefinition ( _
   ByVal SubModeGroup As Long, _
   GroupName As String, _
   ItemNumber As Long _
)

[Delphi]
procedure GetSubModeGroupDefinition(
   const SubModeGroup: Integer;
   out GroupName: WideString;
   out ItemNumber: Integer
)

Описание параметров

SubModeGroup
[in] Номер группы подрежима
GroupName
[out] Возвращается название группы
ItemNumber
[out] Возвращается количество подрежимов в группе

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.GetSubModeGroupNumber (метод)

Получить количество групп подрежимов

Синтаксис

[Visual Basic 6]
Sub GetSubModeGroupNumber ( _
   GroupNumber As Long _
)

[Delphi]
procedure GetSubModeGroupNumber(
   out GroupNumber: Integer
)

Описание параметров

GroupNumber
[out] Возвращается количество групп подрежимов

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.Idle (метод)

Обновление состояния режима

Синтаксис

[Visual Basic 6]
Sub Idle

[Delphi]
procedure Idle

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.IsSubModeOwnerDraw (метод)

Проверить, будет ли выполняться специальная отрисовка иконок режимов, не используя ImageIndex

Синтаксис

[Visual Basic 6]
Sub IsSubModeOwnerDraw ( _
   OwnerDraw As Boolean _
)

[Delphi]
procedure IsSubModeOwnerDraw(
   out OwnerDraw: WordBool
)

Описание параметров

OwnerDraw
[out] Возвращается True, если будет выполняться специальная отрисовка, иначе будет отрисована стандартная картинка с номером ImageIndex из набора картинок приложения

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.KeyDown (метод)

Отработка нажатия клавиши на клавиатуре

Синтаксис

[Visual Basic 6]
Sub KeyDown ( _
   Key As Long, _
   ByVal ShiftState As ShiftStateConstants _
)

[Delphi]
procedure KeyDown(
   var Key: Integer;
   const ShiftState: ShiftStateConstants
)

Описание параметров

Key
[in, out] Нажатая клавиша. Если нажатие будет обработано, то значение Key необходимо установить в 0
ShiftState
[in] Состояние клавиш Ctrl, Alt, Shift, а также кнопок мышки

Смотри также

Interface IContainerModeEvents, Enum ShiftStateConstants, Group Контейнеры изображений


IContainerModeEvents.KeyPress (метод)

Отработка ввода символа (нажатия символьной клавиши на клавиатуре)

Синтаксис

[Visual Basic 6]
Sub KeyPress ( _
   Key As Long _
)

[Delphi]
procedure KeyPress(
   var Key: Integer
)

Описание параметров

Key
[in, out] Введённый символ. Если нажатие будет обработано, то значение Key необходимо установить в 0

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.KeyUp (метод)

Отработка отпускания клавиши на клавиатуре

Синтаксис

[Visual Basic 6]
Sub KeyUp ( _
   Key As Long, _
   ByVal ShiftState As ShiftStateConstants _
)

[Delphi]
procedure KeyUp(
   var Key: Integer;
   const ShiftState: ShiftStateConstants
)

Описание параметров

Key
[in, out] Отпущенная клавиша. Если нажатие будет обработано, то значение Key необходимо установить в 0
ShiftState
[in] Состояние клавиш Ctrl, Alt, Shift, а также кнопок мышки

Смотри также

Interface IContainerModeEvents, Enum ShiftStateConstants, Group Контейнеры изображений


IContainerModeEvents.MouseDown (метод)

Отработка нажатия кнопки мышки (возвращает True, если событие отработано)

Синтаксис

[Visual Basic 6]
Sub MouseDown ( _
   ByVal Button As MouseButtonConstants, _
   ByVal ShiftState As ShiftStateConstants, _
   ByVal X As Long, _
   ByVal Y As Long, _
   Done As Boolean _
)

[Delphi]
procedure MouseDown(
   const Button: MouseButtonConstants;
   const ShiftState: ShiftStateConstants;
   const X: Integer;
   const Y: Integer;
   out Done: WordBool
)

Описание параметров

Button
[in] Нажатая кпопка мышки
ShiftState
[in] Состояние клавиш Ctrl, Alt, Shift, а также кнопок мышки
X
[in] Координата X положения курсора в системе координат окна контейнера
Y
[in] Координата Y положения курсора в системе координат окна контейнера
Done
[out] Обработано ли событие. Если нет, то оно будет обработано стандартными средствами

Смотри также

Interface IContainerModeEvents, Enum MouseButtonConstants, Enum ShiftStateConstants, Group Контейнеры изображений


IContainerModeEvents.MouseEnter (метод)

Возникает в момент, когда курсор мыши входит в окно контейнера

Синтаксис

[Visual Basic 6]
Sub MouseEnter

[Delphi]
procedure MouseEnter

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.MouseLeave (метод)

Возникает в момент, когда курсор мыши покидает окно контейнера

Синтаксис

[Visual Basic 6]
Sub MouseLeave

[Delphi]
procedure MouseLeave

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.MouseMove (метод)

Отработка перемещения курсора мышки

Синтаксис

[Visual Basic 6]
Sub MouseMove ( _
   ByVal ShiftState As ShiftStateConstants, _
   ByVal X As Long, _
   ByVal Y As Long _
)

[Delphi]
procedure MouseMove(
   const ShiftState: ShiftStateConstants;
   const X: Integer;
   const Y: Integer
)

Описание параметров

ShiftState
[in] Состояние клавиш Ctrl, Alt, Shift, а также кнопок мышки
X
[in] Координата X положения курсора в системе координат окна контейнера
Y
[in] Координата Y положения курсора в системе координат окна контейнера

Смотри также

Interface IContainerModeEvents, Enum ShiftStateConstants, Group Контейнеры изображений


IContainerModeEvents.MouseUp (метод)

Отработка отпускания кнопки мышки (возвращает True, если событие отработано)

Синтаксис

[Visual Basic 6]
Sub MouseUp ( _
   ByVal Button As MouseButtonConstants, _
   ByVal ShiftState As ShiftStateConstants, _
   ByVal X As Long, _
   ByVal Y As Long, _
   Done As Boolean _
)

[Delphi]
procedure MouseUp(
   const Button: MouseButtonConstants;
   const ShiftState: ShiftStateConstants;
   const X: Integer;
   const Y: Integer;
   out Done: WordBool
)

Описание параметров

Button
[in] Отпущенная кпопка мышки
ShiftState
[in] Состояние клавиш Ctrl, Alt, Shift, а также кнопок мышки
X
[in] Координата X положения курсора в системе координат окна контейнера
Y
[in] Координата Y положения курсора в системе координат окна контейнера
Done
[out] Обработано ли событие. Если нет, то оно будет обработано стандартными средствами

Смотри также

Interface IContainerModeEvents, Enum MouseButtonConstants, Enum ShiftStateConstants, Group Контейнеры изображений


IContainerModeEvents.MouseWheel (метод)

Отработка вращения колеса мышки

Синтаксис

[Visual Basic 6]
Sub MouseWheel ( _
   ByVal ShiftState As ShiftStateConstants, _
   ByVal X As Long, _
   ByVal Y As Long, _
   ByVal Down As Boolean, _
   Done As Boolean _
)

[Delphi]
procedure MouseWheel(
   const ShiftState: ShiftStateConstants;
   const X: Integer;
   const Y: Integer;
   const Down: WordBool;
   out Done: WordBool
)

Описание параметров

ShiftState
[in] Состояние клавиш Ctrl, Alt, Shift, а также кнопок мышки
X
[in] Координата X положения курсора в системе координат окна контейнера
Y
[in] Координата Y положения курсора в системе координат окна контейнера
Down
[in] Признак того, что колесо вращается вниз, иначе вверх
Done
[out] Обработано ли событие. Если нет, то оно будет обработано стандартными средствами

Смотри также

Interface IContainerModeEvents, Enum ShiftStateConstants, Group Контейнеры изображений


IContainerModeEvents.Navigate (метод)

В контейнере произошло изменение текущей видимой области изображения

Синтаксис

[Visual Basic 6]
Sub Navigate

[Delphi]
procedure Navigate

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.RecreateWindow (метод)

HWnd окна контейнера выделен заново (здесь можно провести какие-то переинициализации)

Синтаксис

[Visual Basic 6]
Sub RecreateWindow

[Delphi]
procedure RecreateWindow

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


IContainerModeEvents.WndProc (метод)

Обработка произвольных событий, поступающих в контейнер

Синтаксис

[Visual Basic 6]
Sub WndProc ( _
   ByVal MessageMsg As Long, _
   ByVal MessageWParamLo As Long, _
   ByVal MessageWParamHi As Long, _
   ByVal MessageLParamLo As Long, _
   ByVal MessageLParamHi As Long, _
   MessageResultLo As Long, _
   MessageResultHi As Long, _
   Done As Boolean _
)

[Delphi]
procedure WndProc(
   const MessageMsg: Integer;
   const MessageWParamLo: Integer;
   const MessageWParamHi: Integer;
   const MessageLParamLo: Integer;
   const MessageLParamHi: Integer;
   var MessageResultLo: Integer;
   var MessageResultHi: Integer;
   out Done: WordBool
)

Описание параметров

MessageMsg
[in] Код сообщения Windows
MessageWParamLo
[in] Младшие 32 бита части WParam сообщения
MessageWParamHi
[in] Старшие 32 бита части WParam сообщения (используются только в 64-битных приложениях; для 32-битной платформы не имеют смысла)
MessageLParamLo
[in] Младшие 32 бита части LParam сообщения
MessageLParamHi
[in] Старшие 32 бита части LParam сообщения (используются только в 64-битных приложениях; для 32-битной платформы не имеют смысла)
MessageResultLo
[in, out] Младшие 32 бита части Result сообщения
MessageResultHi
[in, out] Старшие 32 бита части Result сообщения (используются только в 64-битных приложениях; для 32-битной платформы не имеют смысла)
Done
[out] Обработано ли сообщение, если нет, то оно будет обработано стандартными средствами

Смотри также

Interface IContainerModeEvents, Group Контейнеры изображений


Интерфейс ICoordinateTransformer

Преобразователь координат точек

Наследование

IUnknown Class ICoordinateTransformer

Методы интерфейса

Имя | Описание
Method Transform | Преобразование координат точки

Где используется

Класс | Член класса
Class Figure | Method TransformCoordinates (метод)
Class ShapeFigure | Method TransformCoordinates (метод)
Class ShapeMultipart | Method TransformCoordinates (метод)
Class ShapeMultipoint | Method TransformCoordinates (метод)
Class ShapeMultipointM | Method TransformCoordinates (метод)
Class ShapeMultipointZ | Method TransformCoordinates (метод)
Class ShapePoint | Method TransformCoordinates (метод)
Class ShapePointM | Method TransformCoordinates (метод)
Class ShapePointZ | Method TransformCoordinates (метод)
Class ShapePolygon | Method TransformCoordinates (метод)
Class ShapePolygonM | Method TransformCoordinates (метод)
Class ShapePolygonZ | Method TransformCoordinates (метод)
Class ShapePolyline | Method TransformCoordinates (метод)
Class ShapePolylineM | Method TransformCoordinates (метод)
Class ShapePolylineZ | Method TransformCoordinates (метод)
Class TrnArea | Method TransformCoordinates (метод)
Class TrnBreak | Method TransformCoordinates (метод)
Class TrnFigure | Method TransformCoordinates (метод)
Class TrnFlip | Method TransformCoordinates (метод)
Class TrnModifier | Method TransformCoordinates (метод)
Class TrnNode | Method TransformCoordinates (метод)
Class TrnRib | Method TransformCoordinates (метод)
Class TrnSource | Method TransformCoordinates (метод)
Class TrnTriangle | Method TransformCoordinates (метод)

Смотри также

Group фигуры


ICoordinateTransformer.Transform (метод)

Преобразование координат точки

Синтаксис

[Visual Basic 6]
Function Transform ( _
   ByVal InputX As Double, _
   ByVal InputY As Double, _
   OutputX As Double, _
   OutputY As Double _
) As Long

[Delphi]
function Transform(
   const InputX: Double;
   const InputY: Double;
   out OutputX: Double;
   out OutputY: Double
): HResult

Описание параметров

InputX
[in] Координата X исходной точки
InputY
[in] Координата Y исходной точки
OutputX
[out] Координата X результирующей точки
OutputY
[out] Координата Y результирующей точки

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface ICoordinateTransformer, Group фигуры


Интерфейс IDocTreeHandler

Обработчик "перечисления" объектов какой-либо ветви проекта

Наследование

IUnknown Class IDocTreeHandler

Методы интерфейса

Имя | Описание
Method AddNode | Добавить объект в дерево (список)

Где используется

Класс | Член класса
Class Aggregate | Method MakeTreeStructure (метод)
Class ICADObject | Method MakeTreeStructure (метод)
Class Layer | Method MakeTreeStructure (метод)
Class Project | Method MakeTreeStructure (метод)
Class Route | Method MakeTreeStructure (метод)

Смотри также

Group Внешние модули


IDocTreeHandler.AddNode (метод)

Добавить объект в дерево (список)

Синтаксис

[Visual Basic 6]
Function AddNode ( _
   ByVal ParentID As Long, _
   ByVal Object As IUnknown, _
   ByVal Reason As Long _
) As Long

[Delphi]
function AddNode(
   const ParentID: Integer;
   const Object: IUnknown;
   const Reason: Integer
): Integer

Описание параметров

ParentID
[in] Идентификатор родительского узла, полученный при вызове метода MakeTreeStructure
Object
[in] Объект, передаваемый обработчику перечисления
Reason
[in] Значение, полученное при вызове метода MakeTreeStructure. По нему обработчик, принимающий перечисляемые объекты, может определить, что с ними делать

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IDocTreeHandler, Group Внешние модули


Интерфейс IEnumerateNodes

Интерфейс, используемый в методе EnumerateNodes узла для получения всех узлов, смежных с данным узлом

Наследование

IUnknown Class IEnumerateNodes

Методы интерфейса

Имя | Описание
Method Register | Метод, который будет вызываться из метода EnumerateNodes объекта TrnNode

Где используется

Класс | Член класса
Class TrnNode | Method EnumerateNodes (метод)

Смотри также

Group Триангуляция


IEnumerateNodes.Register (метод)

Метод, который будет вызываться из метода EnumerateNodes объекта TrnNode

Синтаксис

[Visual Basic 6]
Sub Register ( _
   ByVal Node As TrnNode _
)

[Delphi]
procedure Register(
   const Node: TrnNode
)

Описание параметров

Node
[in] Найденный узел

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IEnumerateNodes, Class TrnNode, Group Триангуляция


Интерфейс IEnumerateProfile

Интерфейс, используемый в методе EnumerateProfile триангуляции для получения всех отрезков профиля вдоль заданного отрезка

Наследование

IUnknown Class IEnumerateProfile

Методы интерфейса

Имя | Описание
Method Register | Метод, который будет вызываться из метода EnumerateProfile триангуляции

Где используется

Класс | Член класса
Class CADTriangulation | Method EnumerateProfile (метод)
Class Triangulation | Method EnumerateProfile (метод)

Смотри также

Class Point3D, Enum ProfileSegmentTypeConstants, Class TrnTriangle, Group Триангуляция


IEnumerateProfile.Register (метод)

Метод, который будет вызываться из метода EnumerateProfile триангуляции

Синтаксис

[Visual Basic 6]
Sub Register ( _
   ByVal Point1 As Point3D, _
   ByVal Point2 As Point3D, _
   ByVal SegmentType As ProfileSegmentTypeConstants, _
   ByVal Triangle As TrnTriangle, _
   ByVal RibIndex1 As Long, _
   ByVal RibIndex2 As Long _
)

[Delphi]
procedure Register(
   const Point1: Point3D;
   const Point2: Point3D;
   const SegmentType: ProfileSegmentTypeConstants;
   const Triangle: TrnTriangle;
   const RibIndex1: Integer;
   const RibIndex2: Integer
)

Описание параметров

Point1
[in] Первая найденная точка отрезка
Point2
[in] Вторая найденная точка отрезка
SegmentType
[in] Тип найденного отрезка профиля
Triangle
[in] Найденный пересекаемый треугольник
RibIndex1
[in] Номер первого пересекаемого ребра внутри найденного пересекаемого треугольника или -1
RibIndex2
[in] Номер второго пересекаемого ребра внутри найденного пересекаемого треугольника или -1

Смотри также

Interface IEnumerateProfile, Class Point3D, Enum ProfileSegmentTypeConstants, Class TrnTriangle, Group Триангуляция


Интерфейс IEnumerateProfilePoints

Интерфейс, используемый в методе EnumerateProfilePoints триангуляции для получения всех точек профиля вдоль заданного отрезка

Наследование

IUnknown Class IEnumerateProfilePoints

Методы интерфейса

Имя | Описание
Method Register | Метод, который будет вызываться из метода EnumerateProfilePoints триангуляции

Где используется

Класс | Член класса
Class CADTriangulation | Method EnumerateProfilePoints (метод)
Class Triangulation | Method EnumerateProfilePoints (метод)

Смотри также

Class Point3D, Enum ProfilePointTypeConstants, Class TrnTriangle, Group Триангуляция


IEnumerateProfilePoints.Register (метод)

Метод, который будет вызываться из метода EnumerateProfilePoints триангуляции

Синтаксис

[Visual Basic 6]
Sub Register ( _
   ByVal Point As Point3D, _
   ByVal PointType As ProfilePointTypeConstants, _
   ByVal Triangle As TrnTriangle, _
   ByVal Index As Long _
)

[Delphi]
procedure Register(
   const Point: Point3D;
   const PointType: ProfilePointTypeConstants;
   const Triangle: TrnTriangle;
   const Index: Integer
)

Описание параметров

Point
[in] Найденная точка профиля
PointType
[in] Тип найденной точки профиля
Triangle
[in] Найденный пересекаемый треугольник
Index
[in] Номер пересекаемого узла и ребра внутри найденного пересекаемого треугольника или -1 (смысл аргумента зависит от значения PointType)

Смотри также

Interface IEnumerateProfilePoints, Class Point3D, Enum ProfilePointTypeConstants, Class TrnTriangle, Group Триангуляция


Интерфейс IEnumerateRibs

Интерфейс, используемый в методе EnumerateRibs узла для получения всех рёбер, смежных с данным узлом

Наследование

IUnknown Class IEnumerateRibs

Методы интерфейса

Имя | Описание
Method Register | Метод, который будет вызываться из метода EnumerateRibs объекта TrnNode

Где используется

Класс | Член класса
Class TrnNode | Method EnumerateRibs (метод)

Смотри также

Class TrnRib, Group Триангуляция


IEnumerateRibs.Register (метод)

Метод, который будет вызываться из метода EnumerateRibs объекта TrnNode

Синтаксис

[Visual Basic 6]
Sub Register ( _
   ByVal Rib As TrnRib _
)

[Delphi]
procedure Register(
   const Rib: TrnRib
)

Описание параметров

Rib
[in] Найденное ребро

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IEnumerateRibs, Class TrnRib, Group Триангуляция


Интерфейс IEnumerateTriangles

Интерфейс, используемый в методе EnumerateTriangles узла для получения всех треугольников, смежных с данным узлом

Наследование

IUnknown Class IEnumerateTriangles

Методы интерфейса

Имя | Описание
Method Register | Метод, который будет вызываться из метода EnumerateTriangles объекта TrnNode

Где используется

Класс | Член класса
Class TrnNode | Method EnumerateTriangles (метод)

Смотри также

Class TrnTriangle, Group Триангуляция


IEnumerateTriangles.Register (метод)

Метод, который будет вызываться из метода EnumerateTriangles объекта TrnNode

Синтаксис

[Visual Basic 6]
Sub Register ( _
   ByVal Triangle As TrnTriangle, _
   ByVal NodeIndexInTriangle As Long _
)

[Delphi]
procedure Register(
   const Triangle: TrnTriangle;
   const NodeIndexInTriangle: Integer
)

Описание параметров

Triangle
[in] Найденный треугольник
NodeIndexInTriangle
[in] Номер данного узла внутри найденного треугольника

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IEnumerateTriangles, Class TrnTriangle, Group Триангуляция


Интерфейс IExecutable

Интерфейс, предоставляющий метод Execute, вызываемый в основном потоке объекта

Наследование

IUnknown Class IExecutable

Методы интерфейса

Имя | Описание
Method Execute | Метод, который будет вызван в основном потоке объекта из метода ISynchronizable.Synchronize

Где используется

Класс | Член класса
Class CustomContainer | Method Synchronize (метод)

Смотри также

Group Многопоточность


IExecutable.Execute (метод)

Метод, который будет вызван в основном потоке объекта из метода ISynchronizable.Synchronize

Синтаксис

[Visual Basic 6]
Function Execute ( _
   Result As Boolean _
) As Long

[Delphi]
function Execute(
   out Result: WordBool
): HResult

Описание параметров

Result
[out] Возвращает True, если вызов выполнен успешно

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IExecutable, Group Многопоточность


Интерфейс IHotLinkHandler

Обработчик горячей связи

Наследование

IUnknown Class IHotLinkHandler

Методы интерфейса

Имя | Описание
Method EditProperties | Вызов диалога правки параметра горячей связи
Method Execute | Выполнение горячей связи

Смотри также

Class CustomContainer, Group Карты


IHotLinkHandler.EditProperties (метод)

Вызов диалога правки параметра горячей связи

Синтаксис

[Visual Basic 6]
Sub EditProperties ( _
   ByVal Container As CustomContainer, _
   HotLinkValue As String, _
   OK As Boolean _
)

[Delphi]
procedure EditProperties(
   const Container: CustomContainer;
   var HotLinkValue: WideString;
   out OK: WordBool
)

Описание параметров

Container
[in] Контейнер, в котором выполняется горячая всязь
HotLinkValue
[in, out] Значение атрибута горячей связи
OK
[out] Функция должна возвратить True, если параметр горячей связи был изменён

Смотри также

Class CustomContainer, Interface IHotLinkHandler, Group Карты


IHotLinkHandler.Execute (метод)

Выполнение горячей связи

Синтаксис

[Visual Basic 6]
Sub Execute ( _
   ByVal Container As CustomContainer, _
   ByVal AttrValue As String, _
   ByVal Params As String, _
   Successful As Boolean _
)

[Delphi]
procedure Execute(
   const Container: CustomContainer;
   const AttrValue: WideString;
   const Params: WideString;
   out Successful: WordBool
)

Описание параметров

Container
[in] Контейнер, в котором выполняется горячая всязь
AttrValue
[in] Значение атрибута горячей связи
Params
[in] Дополнительные параметры горячей связи
Successful
[out] Функция должна возвратить True, если горячая связь выполнена успешно

Смотри также

Class CustomContainer, Interface IHotLinkHandler, Group Карты


Интерфейс IImporter

Реализуется объектами, регистрируемыми в Application.RegisterImport, которые могут импортировать какие-либо данные из файла

Наследование

IUnknown Class IImporter

Методы интерфейса

Имя | Описание
Method Import | Выполнить импорт данных
Method IsImportEnabled | Разрешена ли процедура импорта

Где используется

Класс | Член класса
Class Application | Method RegisterImporter (метод)

Смотри также

Group Внешние модули


IImporter.Import (метод)

Выполнить импорт данных

Синтаксис

[Visual Basic 6]
Sub Import ( _
   ByVal FileName As String, _
   ByVal UserData As Long _
)

[Delphi]
procedure Import(
   const FileName: WideString;
   const UserData: Integer
)

Описание параметров

FileName
[in] Имя файла, из которого необходимо импортировать данные
UserData
[in] Произвольное число, ассоциируемое с процедурой импорта. Актуально, если один объект реализует несколько процедур импорта

Смотри также

Interface IImporter, Group Внешние модули


IImporter.IsImportEnabled (метод)

Разрешена ли процедура импорта

Синтаксис

[Visual Basic 6]
Sub IsImportEnabled ( _
   ByVal UserData As Long, _
   ImportEnabled As Boolean _
)

[Delphi]
procedure IsImportEnabled(
   const UserData: Integer;
   out ImportEnabled: WordBool
)

Описание параметров

UserData
[in] Произвольное число, ассоциируемое с процедурой импорта. Актуально, если один объект реализует несколько процедур импорта
ImportEnabled
[out] Объект должен возвратить True, если в данный момент времени импорт возможен (разрешён)

Смотри также

Interface IImporter, Group Внешние модули


Интерфейс IMultiPointGeometry

Геометрия мультиточек

Наследование

IUnknown Class IMultiPointGeometry

Свойства интерфейса

Имя | Описание
Property CommonZ (только для чтения) | Общая высота для всех узлов
Property PointNumber (только для чтения) | Число точек
Property Points (только для чтения) | Координаты узлов

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetMultiPointGeometry (метод)


IMultiPointGeometry.CommonZ (свойство)

Общая высота для всех узлов

Синтаксис

[Visual Basic 6]
ReadOnly Property CommonZ As Long

[Delphi]
{только для чтения} property CommonZ: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IMultiPointGeometry


IMultiPointGeometry.PointNumber (свойство)

Число точек

Синтаксис

[Visual Basic 6]
ReadOnly Property PointNumber As Long

[Delphi]
{только для чтения} property PointNumber: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IMultiPointGeometry


IMultiPointGeometry.Points (свойство)

Координаты узлов

Синтаксис

[Visual Basic 6]
ReadOnly Property Points As Long

[Delphi]
{только для чтения} property Points: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IMultiPointGeometry


Интерфейс IObject3D

Реализуется объектами, поддерживающими отрисовку себя (и своих подобъектов) в 3D-виде

Наследование

IUnknown Class IObject3D

Методы интерфейса

Имя | Описание
Method DrawToD3D | Вызывается при отрисовке 3D-сцены
Method FreeD3DResources | Вызывается при закрытии 3D-вида или при переинициализации устройства вывода. Объект должен освободить все ресурсы, связанные с выводом изображений в 3D-вид

Смотри также

SubSystem3DBase, Group Внешние модули, Group Трёхмерный вид


IObject3D.DrawToD3D (метод)

Вызывается при отрисовке 3D-сцены

Синтаксис

[Visual Basic 6]
Sub DrawToD3D ( _
   ByVal Direct3DDevice9 As IUnknown, _
   ByVal SS3D As SubSystem3DBase _
)

[Delphi]
procedure DrawToD3D(
   const Direct3DDevice9: IUnknown;
   const SS3D: SubSystem3DBase
)

Описание параметров

Direct3DDevice9
[in] Устройство вывода трёхмерной графики. У Direct3DDevice9 должен быть запрошен интерфейс IDirect3DDevice9 для отрисовки
SS3D
[in] Вспомогательный объект для работы с 3D-видом

Смотри также

Interface IObject3D, SubSystem3DBase, Group Внешние модули, Group Трёхмерный вид


IObject3D.FreeD3DResources (метод)

Вызывается при закрытии 3D-вида или при переинициализации устройства вывода. Объект должен освободить все ресурсы, связанные с выводом изображений в 3D-вид

Синтаксис

[Visual Basic 6]
Sub FreeD3DResources

[Delphi]
procedure FreeD3DResources

Смотри также

Interface IObject3D, Group Внешние модули, Group Трёхмерный вид


Интерфейс IObject3DLight

Реализуется объектами, которые выставляют дополнительные источники освещения

Наследование

IUnknown Class IObject3DLight

Методы интерфейса

Имя | Описание
Method SetupLight | установить элементы освещения

Смотри также

SubSystem3DBase, Group Внешние модули, Group Трёхмерный вид


IObject3DLight.SetupLight (метод)

установить элементы освещения

Синтаксис

[Visual Basic 6]
Sub SetupLight ( _
   ByVal Direct3DDevice9 As IUnknown, _
   ByVal SS3D As SubSystem3DBase _
)

[Delphi]
procedure SetupLight(
   const Direct3DDevice9: IUnknown;
   const SS3D: SubSystem3DBase
)

Описание параметров

Direct3DDevice9
[in] Устройство вывода DirectX для отрисовки 3D-объектов
SS3D
[in] Вспомогательный объект для работы с 3D-видом

Смотри также

Interface IObject3DLight, SubSystem3DBase, Group Внешние модули, Group Трёхмерный вид


Интерфейс IObject3DTransparent

Реализуется объектами, поддерживающими отрисовку себя (и своих подобъектов) в 3D-виде в полупрозрачном состоянии

Наследование

IUnknown Class IObject3DTransparent

Методы интерфейса

Имя | Описание
Method DrawToD3D | Вызывается при отрисовке каждого кадра в 3D-виде
Method FreeD3DResources | Вызывается при закрытии 3D-вида или при переинициализации устройства вывода. Объект должен освободить все ресурсы, связанные с выводом изображений в 3D-вид
Method GetDistanceTo | Метод вызывается для определения расстояния от камеры до объекта

Смотри также

SubSystem3DBase, Group Внешние модули, Group Трёхмерный вид


IObject3DTransparent.DrawToD3D (метод)

Вызывается при отрисовке каждого кадра в 3D-виде

Синтаксис

[Visual Basic 6]
Sub DrawToD3D ( _
   ByVal Index As Long, _
   ByVal Direct3DDevice9 As IUnknown, _
   ByVal SS3D As SubSystem3DBase _
)

[Delphi]
procedure DrawToD3D(
   const Index: Integer;
   const Direct3DDevice9: IUnknown;
   const SS3D: SubSystem3DBase
)

Описание параметров

Index
[in] Индекс элемента для отображения
Direct3DDevice9
[in] Устройство вывода трёхмерной графики. У Direct3DDevice9 должен быть запрошен интерфейс IDirect3DDevice9 для отрисовки
SS3D
[in] Вспомогательный объект для работы с 3D-видом

Смотри также

Interface IObject3DTransparent, SubSystem3DBase, Group Внешние модули, Group Трёхмерный вид


IObject3DTransparent.FreeD3DResources (метод)

Вызывается при закрытии 3D-вида или при переинициализации устройства вывода. Объект должен освободить все ресурсы, связанные с выводом изображений в 3D-вид

Синтаксис

[Visual Basic 6]
Sub FreeD3DResources

[Delphi]
procedure FreeD3DResources

Смотри также

Interface IObject3DTransparent, Group Внешние модули, Group Трёхмерный вид


IObject3DTransparent.GetDistanceTo (метод)

Метод вызывается для определения расстояния от камеры до объекта

Синтаксис

[Visual Basic 6]
Sub GetDistanceTo ( _
   ByVal Index As Long, _
   ByVal EyeX As Double, _
   ByVal EyeY As Double, _
   ByVal EyeZ As Double, _
   Distance As Double, _
   Handled As Boolean _
)

[Delphi]
procedure GetDistanceTo(
   const Index: Integer;
   const EyeX: Double;
   const EyeY: Double;
   const EyeZ: Double;
   out Distance: Double;
   out Handled: WordBool
)

Описание параметров

Index
[in] Индекс элемента для отображения
EyeX
[in] Модельная X-координата камеры в 3D-виде
EyeY
[in] Модельная Y-координата камеры в 3D-виде
EyeZ
[in] Модельная Z-координата камеры в 3D-виде
Distance
[out] Объект должен вернуть расстояния от камеры до себя в трёхмерном пространстве
Handled
[out] Объект должен вернуть True, если в Distance возвращается корректное значение, либо False

Смотри также

Interface IObject3DTransparent, Group Внешние модули, Group Трёхмерный вид


Интерфейс IPluginEvents

События, возникающие при создании дополнительного внутреннего модуля к системе

Наследование

IUnknown Class IPluginEvents

Методы интерфейса

Имя | Описание
Method About | Выдача окна "О модуле..."
Method Done | Финализация внутреннего модуля
Method Help | Выдача помощи по модулю
Method Info | Получение информации о внутреннем модуле
Method Init | Вызывается при инициализации внутреннего модуля

Где используется

Класс | Член класса
Class PluginManager | Method RegisterInternalPlugin (метод)

Смотри также

Enum PluginOptionConstants, Group Приложение


IPluginEvents.About (метод)

Выдача окна "О модуле..."

Синтаксис

[Visual Basic 6]
Sub About

[Delphi]
procedure About

Смотри также

Interface IPluginEvents, Group Приложение


IPluginEvents.Done (метод)

Финализация внутреннего модуля

Синтаксис

[Visual Basic 6]
Sub Done

[Delphi]
procedure Done

Смотри также

Interface IPluginEvents, Group Приложение


IPluginEvents.Help (метод)

Выдача помощи по модулю

Синтаксис

[Visual Basic 6]
Sub Help

[Delphi]
procedure Help

Смотри также

Interface IPluginEvents, Group Приложение


IPluginEvents.Info (метод)

Получение информации о внутреннем модуле

Синтаксис

[Visual Basic 6]
Sub Info ( _
   ID As String, _
   Name As String, _
   Description As String, _
   Copyright As String, _
   RequiredPlugins As String, _
   ImageIndex As Long, _
   Options As PluginOptionConstants, _
   SupportsHelp As Boolean, _
   SupportsAbout As Boolean _
)

[Delphi]
procedure Info(
   out ID: WideString;
   out Name: WideString;
   out Description: WideString;
   out Copyright: WideString;
   out RequiredPlugins: WideString;
   out ImageIndex: Integer;
   out Options: PluginOptionConstants;
   out SupportsHelp: WordBool;
   out SupportsAbout: WordBool
)

Описание параметров

ID
[out] Модуль должен возвратить в форме строки уникальный глобальный идентификатор модуля или пустая строка, если модуль не управляется через менеджер лицензий
Name
[out] Название модуля, появляющееся в окне менеджера дополнительных модулей
Description
[out] Краткое описание модуля
Copyright
[out] Авторское право на модуль
RequiredPlugins
[out] Список дополнительных модулей, необходимых для нормальной работы данного модуля, перечисленных через запятую
ImageIndex
[out] Номер иконки в наборе картинок приложения
Options
[out] Различные опции модуля (разрешен ли модуль по умолчанию, требуется ли перезапуск системы и пр.)
SupportsHelp
[out] Поддерживает ли модуль обработку события Help. Если поддерживает, то в меню "?" приложения появится пункт меню с командой выдачи помощи, при выборе которого будет сгенерировано событие Help
SupportsAbout
[out] Поддерживает ли модуль обработку события About. Если поддерживает, то в меню "?" приложения появится пункт меню с командой выдачи окна информации "О модуле...", при выборе которого будет сгенерировано событие About

Смотри также

Interface IPluginEvents, Enum PluginOptionConstants, Group Приложение


IPluginEvents.Init (метод)

Вызывается при инициализации внутреннего модуля

Синтаксис

[Visual Basic 6]
Sub Init ( _
   ByVal Application As Object _
)

[Delphi]
procedure Init(
   const Application: IDispatch
)

Описание параметров

Application
[in] Главный интерфейс приложения

Смотри также

Interface IPluginEvents, Group Приложение


Интерфейс IPolygonGeometry

Геометрия полигона

Наследование

IUnknown Class IPolygonGeometry

Свойства интерфейса

Имя | Описание
Property CommonZ (только для чтения) | Общая высота для всех узлов
Property PartCounts (только для чтения) | Число точек в контурах
Property PartNumber (только для чтения) | Число контуров
Property Points (только для чтения) | Координаты узлов
Property RoofPolyline (только для чтения) | Полилиния конька крыши

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetPolygonGeometry (метод)


IPolygonGeometry.CommonZ (свойство)

Общая высота для всех узлов

Синтаксис

[Visual Basic 6]
ReadOnly Property CommonZ As Long

[Delphi]
{только для чтения} property CommonZ: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolygonGeometry


IPolygonGeometry.PartCounts (свойство)

Число точек в контурах

Синтаксис

[Visual Basic 6]
ReadOnly Property PartCounts As Long

[Delphi]
{только для чтения} property PartCounts: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolygonGeometry


IPolygonGeometry.PartNumber (свойство)

Число контуров

Синтаксис

[Visual Basic 6]
ReadOnly Property PartNumber As Long

[Delphi]
{только для чтения} property PartNumber: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolygonGeometry


IPolygonGeometry.Points (свойство)

Координаты узлов

Синтаксис

[Visual Basic 6]
ReadOnly Property Points As Long

[Delphi]
{только для чтения} property Points: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolygonGeometry


IPolygonGeometry.RoofPolyline (свойство)

Полилиния конька крыши

Синтаксис

[Visual Basic 6]
ReadOnly Property RoofPolyline As Long

[Delphi]
{только для чтения} property RoofPolyline: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolygonGeometry


Интерфейс IPolylineGeometry

Геометрия полилинии

Наследование

IUnknown Class IPolylineGeometry

Свойства интерфейса

Имя | Описание
Property CommonZ (только для чтения) | Общая высота для всех узлов
Property IsClosed (только для чтения) | Замкнута ли линия
Property PartCounts (только для чтения) | Число точек в контурах
Property PartNumber (только для чтения) | Число контуров
Property Points (только для чтения) | Координаты узлов

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetPolylineGeometry (метод)


IPolylineGeometry.CommonZ (свойство)

Общая высота для всех узлов

Синтаксис

[Visual Basic 6]
ReadOnly Property CommonZ As Long

[Delphi]
{только для чтения} property CommonZ: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolylineGeometry


IPolylineGeometry.IsClosed (свойство)

Замкнута ли линия

Синтаксис

[Visual Basic 6]
ReadOnly Property IsClosed As Long

[Delphi]
{только для чтения} property IsClosed: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolylineGeometry


IPolylineGeometry.PartCounts (свойство)

Число точек в контурах

Синтаксис

[Visual Basic 6]
ReadOnly Property PartCounts As Long

[Delphi]
{только для чтения} property PartCounts: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolylineGeometry


IPolylineGeometry.PartNumber (свойство)

Число контуров

Синтаксис

[Visual Basic 6]
ReadOnly Property PartNumber As Long

[Delphi]
{только для чтения} property PartNumber: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolylineGeometry


IPolylineGeometry.Points (свойство)

Координаты узлов

Синтаксис

[Visual Basic 6]
ReadOnly Property Points As Long

[Delphi]
{только для чтения} property Points: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolylineGeometry


Интерфейс IProjectEvents

Наследование

IUnknown Class IProjectEvents

Методы интерфейса

Имя | Описание
Method ImportFinished | Вызывается после выполнения любого импорта для текущего проекта
Method LayerDeleteQuery | Вызывается как запрос на возможность удаления слоя Layer
Method LayerDeleting | Вызывается непосредственно перед удалением слоя Layer
Method LayerSurfaceInvalidated | Вызывается при удалении триангуляции вследствие её неактуальности
Method ProjectCreated | Вызывается непосредственно после создания нового проекта
Method ProjectDestroying | Вызывается непосредственно перед уничтожением проекта
Method ProjectLoaded | Вызывается непосредственно после загрузки проекта
Method ProjectModified | Вызывается при любом изменении проекта
Method ProjectOptionsChanged | Вызывается при изменении настроек проекта
Method ProjectSaved | Вызывается непосредственно после сохранения проекта
Method ProjectSaving | Вызывается непосредственно перед сохранением проекта
Method StringNamesChanged | Вызывается при изменении в наборе имён структурных линий

Где используется

Класс | Член класса
Class Project | Method Advise (метод)

Смотри также

Class Layer, Group Проекты


IProjectEvents.ImportFinished (метод)

Вызывается после выполнения любого импорта для текущего проекта

Синтаксис

[Visual Basic 6]
Sub ImportFinished ( _
   ByVal Project As Project _
)

[Delphi]
procedure ImportFinished(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого был произведён импорт каких-либо данных

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


IProjectEvents.LayerDeleteQuery (метод)

Вызывается как запрос на возможность удаления слоя Layer

Синтаксис

[Visual Basic 6]
Sub LayerDeleteQuery ( _
   ByVal Layer As Layer, _
   CanDelete As Boolean _
)

[Delphi]
procedure LayerDeleteQuery(
   const Layer: Layer;
   out CanDelete: WordBool
)

Описание параметров

Layer
[in] Слой, который предполагается удалить
CanDelete
[out] Если CanDelete присвоить False, то слой не будет удалён

Смотри также

Interface IProjectEvents, Class Layer, Group Проекты


IProjectEvents.LayerDeleting (метод)

Вызывается непосредственно перед удалением слоя Layer

Синтаксис

[Visual Basic 6]
Sub LayerDeleting ( _
   ByVal Layer As Layer _
)

[Delphi]
procedure LayerDeleting(
   const Layer: Layer
)

Описание параметров

Layer
[in] Слой, который будет удалён

Смотри также

Interface IProjectEvents, Class Layer, Group Проекты


IProjectEvents.LayerSurfaceInvalidated (метод)

Вызывается при удалении триангуляции вследствие её неактуальности

Синтаксис

[Visual Basic 6]
Sub LayerSurfaceInvalidated ( _
   ByVal Layer As Layer _
)

[Delphi]
procedure LayerSurfaceInvalidated(
   const Layer: Layer
)

Описание параметров

Layer
[in] Слой, поверхность которого объявлена неактуальной

Смотри также

Interface IProjectEvents, Class Layer, Group Проекты


IProjectEvents.ProjectCreated (метод)

Вызывается непосредственно после создания нового проекта

Синтаксис

[Visual Basic 6]
Sub ProjectCreated ( _
   ByVal Project As Project, _
   ByVal CreatedAsNew As Boolean _
)

[Delphi]
procedure ProjectCreated(
   const Project: Project;
   const CreatedAsNew: WordBool
)

Описание параметров

Project
[in] Проект, для которого вызвано событие
CreatedAsNew
[in] True - проект создан как новый. False - проект будет загружаться из файла

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


IProjectEvents.ProjectDestroying (метод)

Вызывается непосредственно перед уничтожением проекта

Синтаксис

[Visual Basic 6]
Sub ProjectDestroying ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectDestroying(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого вызвано событие

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


IProjectEvents.ProjectLoaded (метод)

Вызывается непосредственно после загрузки проекта

Синтаксис

[Visual Basic 6]
Sub ProjectLoaded ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectLoaded(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого вызвано событие

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


IProjectEvents.ProjectModified (метод)

Вызывается при любом изменении проекта

Синтаксис

[Visual Basic 6]
Sub ProjectModified ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectModified(
   const Project: Project
)

Описание параметров

Project
[in] Проект, в котором произошли изменения

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


IProjectEvents.ProjectOptionsChanged (метод)

Вызывается при изменении настроек проекта

Синтаксис

[Visual Basic 6]
Sub ProjectOptionsChanged ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectOptionsChanged(
   const Project: Project
)

Описание параметров

Project
[in] Проект, настройки которого были изменены

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


IProjectEvents.ProjectSaved (метод)

Вызывается непосредственно после сохранения проекта

Синтаксис

[Visual Basic 6]
Sub ProjectSaved ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectSaved(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого вызвано событие

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


IProjectEvents.ProjectSaving (метод)

Вызывается непосредственно перед сохранением проекта

Синтаксис

[Visual Basic 6]
Sub ProjectSaving ( _
   ByVal Project As Project _
)

[Delphi]
procedure ProjectSaving(
   const Project: Project
)

Описание параметров

Project
[in] Проект, для которого вызвано событие

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


IProjectEvents.StringNamesChanged (метод)

Вызывается при изменении в наборе имён структурных линий

Синтаксис

[Visual Basic 6]
Sub StringNamesChanged ( _
   ByVal Project As Project _
)

[Delphi]
procedure StringNamesChanged(
   const Project: Project
)

Описание параметров

Project
[in] Проект, в котором измененился набор имён структурных линий

Смотри также

Interface IProjectEvents, Class Project, Group Проекты


Интерфейс IPropertyStreamed

Объект, умеющий сохраняться/загружаться, используя IPropertyStream

Наследование

IUnknown Class IPropertyStreamed

Методы интерфейса

Имя | Описание
Method Dirty | Требуется ли сохранять объект
Method LoadFrom | Прочитать данные из указанного IPropertyStream
Method SaveTo | Сохранить данные в указанный IPropertyStream

Смотри также

Class PropertyStream


IPropertyStreamed.Dirty (метод)

Требуется ли сохранять объект

Синтаксис

[Visual Basic 6]
Sub Dirty ( _
   Value As Boolean _
)

[Delphi]
procedure Dirty(
   out Value: WordBool
)

Описание параметров

Value
[out] Value на входе = True. Eсли объект не менялся после загрузки или после последнего сохранения, он может вернуть False, в этом случае сохранение не будет вызвано

Смотри также

Interface IPropertyStreamed


IPropertyStreamed.LoadFrom (метод)

Прочитать данные из указанного IPropertyStream

Синтаксис

[Visual Basic 6]
Sub LoadFrom ( _
   ByVal SS As PropertyStream _
)

[Delphi]
procedure LoadFrom(
   const SS: PropertyStream
)

Описание параметров

SS
[in] PropertyStream, из которого объект будет читать данные

Смотри также

Interface IPropertyStreamed, Class PropertyStream


IPropertyStreamed.SaveTo (метод)

Сохранить данные в указанный IPropertyStream

Синтаксис

[Visual Basic 6]
Sub SaveTo ( _
   ByVal SS As PropertyStream _
)

[Delphi]
procedure SaveTo(
   const SS: PropertyStream
)

Описание параметров

SS
[in] PropertyStream, в который объект будет сохранять данные

Смотри также

Interface IPropertyStreamed, Class PropertyStream


Интерфейс IRenderAdapter3D

Интерфейс для передачи данных в 3D вид

Наследование

IUnknown Class IRenderAdapter3D

Методы интерфейса

Имя | Описание
Method GetCameraAzimuth | Получить горизонтальный угол камеры
Method GetCameraPosition | Получить положение камеры
Method GetCameraRollAngle | Получить наклон камеры
Method GetCameraVerticalAngle | Получить вертикальный угол камеры
Method GetData | Получить интерфейс связанный с элементом
Method GetItemCount | Число элементов
Method GetItemInfo | Получить информацию о типе элемента
Method GetLayerAlpha | Альфа канал слоя
Method GetLayerCount | Число сло?в
Method GetMultiPointGeometry | Получить геометрию мультиточках
Method GetMultiPointInfo | Получить информацию о мультиточках
Method GetPointGeometry | Получить геометрию точки
Method GetPointInfo | Получить информацию о точке
Method GetPolygonGeometry | Получить информацию о полигоне
Method GetPolygonInfo | Получить информацию о полигоне
Method GetPolylineGeometry | Получить информацию о полилинии
Method GetPolylineInfo | Получить информацию о полилинии
Method GetTextures | Получить текстуры объекта
Method GetTypeCount | Число типов
Method GetWorldBounds | Получить границы мира
Method SetData | Связать с элементом интерфейс

Смотри также

Interface IMultiPointGeometry, Interface IPolygonGeometry, Interface IPolylineGeometry, Interface ITextureIdContainer, Enum TObjectType, Record TPointGeometry, Record TPointInfo, Record TPolygonInfo, Record TPolylineInfo, Record TVector


IRenderAdapter3D.GetCameraAzimuth (метод)

Получить горизонтальный угол камеры

Синтаксис

[Visual Basic 6]
Function GetCameraAzimuth ( _
   Result As Double _
) As Long

[Delphi]
function GetCameraAzimuth(
   out Result: Double
): HResult

Описание параметров

Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


IRenderAdapter3D.GetCameraPosition (метод)

Получить положение камеры

Синтаксис

[Visual Basic 6]
Function GetCameraPosition ( _
   Result As TVector _
) As Long

[Delphi]
function GetCameraPosition(
   out Result: TVector
): HResult

Описание параметров

Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Record TVector


IRenderAdapter3D.GetCameraRollAngle (метод)

Получить наклон камеры

Синтаксис

[Visual Basic 6]
Function GetCameraRollAngle ( _
   Result As Double _
) As Long

[Delphi]
function GetCameraRollAngle(
   out Result: Double
): HResult

Описание параметров

Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


IRenderAdapter3D.GetCameraVerticalAngle (метод)

Получить вертикальный угол камеры

Синтаксис

[Visual Basic 6]
Function GetCameraVerticalAngle ( _
   Result As Double _
) As Long

[Delphi]
function GetCameraVerticalAngle(
   out Result: Double
): HResult

Описание параметров

Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


IRenderAdapter3D.GetData (метод)

Получить интерфейс связанный с элементом

Синтаксис

[Visual Basic 6]
Function GetData ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Data As IUnknown _
) As Long

[Delphi]
function GetData(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Data: IUnknown
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Data
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


IRenderAdapter3D.GetItemCount (метод)

Число элементов

Синтаксис

[Visual Basic 6]
Function GetItemCount ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   Result As Long _
) As Long

[Delphi]
function GetItemCount(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   out Result: Integer
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


IRenderAdapter3D.GetItemInfo (метод)

Получить информацию о типе элемента

Синтаксис

[Visual Basic 6]
Function GetItemInfo ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Result As TObjectType _
) As Long

[Delphi]
function GetItemInfo(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Result: TObjectType
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Enum TObjectType


IRenderAdapter3D.GetLayerAlpha (метод)

Альфа канал слоя

Синтаксис

[Visual Basic 6]
Function GetLayerAlpha ( _
   ByVal LayerIndex As Long, _
   Result As Long _
) As Long

[Delphi]
function GetLayerAlpha(
   const LayerIndex: Integer;
   out Result: Integer
): HResult

Описание параметров

LayerIndex
[in]
Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


IRenderAdapter3D.GetLayerCount (метод)

Число сло?в

Синтаксис

[Visual Basic 6]
Function GetLayerCount ( _
   Result As Long _
) As Long

[Delphi]
function GetLayerCount(
   out Result: Integer
): HResult

Описание параметров

Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


IRenderAdapter3D.GetMultiPointGeometry (метод)

Получить геометрию мультиточках

Синтаксис

[Visual Basic 6]
Function GetMultiPointGeometry ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Geometry As IMultiPointGeometry _
) As Long

[Delphi]
function GetMultiPointGeometry(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Geometry: IMultiPointGeometry
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Geometry
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IMultiPointGeometry, Interface IRenderAdapter3D


IRenderAdapter3D.GetMultiPointInfo (метод)

Получить информацию о мультиточках

Синтаксис

[Visual Basic 6]
Function GetMultiPointInfo ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Info As TPointInfo _
) As Long

[Delphi]
function GetMultiPointInfo(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Info: TPointInfo
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Info
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Record TPointInfo


IRenderAdapter3D.GetPointGeometry (метод)

Получить геометрию точки

Синтаксис

[Visual Basic 6]
Function GetPointGeometry ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Geometry As TPointGeometry _
) As Long

[Delphi]
function GetPointGeometry(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Geometry: TPointGeometry
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Geometry
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Record TPointGeometry


IRenderAdapter3D.GetPointInfo (метод)

Получить информацию о точке

Синтаксис

[Visual Basic 6]
Function GetPointInfo ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Info As TPointInfo _
) As Long

[Delphi]
function GetPointInfo(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Info: TPointInfo
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Info
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Record TPointInfo


IRenderAdapter3D.GetPolygonGeometry (метод)

Получить информацию о полигоне

Синтаксис

[Visual Basic 6]
Function GetPolygonGeometry ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Geometry As IPolygonGeometry _
) As Long

[Delphi]
function GetPolygonGeometry(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Geometry: IPolygonGeometry
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Geometry
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolygonGeometry, Interface IRenderAdapter3D


IRenderAdapter3D.GetPolygonInfo (метод)

Получить информацию о полигоне

Синтаксис

[Visual Basic 6]
Function GetPolygonInfo ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Info As TPolygonInfo _
) As Long

[Delphi]
function GetPolygonInfo(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Info: TPolygonInfo
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Info
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Record TPolygonInfo


IRenderAdapter3D.GetPolylineGeometry (метод)

Получить информацию о полилинии

Синтаксис

[Visual Basic 6]
Function GetPolylineGeometry ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Geometry As IPolylineGeometry _
) As Long

[Delphi]
function GetPolylineGeometry(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Geometry: IPolylineGeometry
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Geometry
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IPolylineGeometry, Interface IRenderAdapter3D


IRenderAdapter3D.GetPolylineInfo (метод)

Получить информацию о полилинии

Синтаксис

[Visual Basic 6]
Function GetPolylineInfo ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Info As TPolylineInfo _
) As Long

[Delphi]
function GetPolylineInfo(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Info: TPolylineInfo
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Info
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Record TPolylineInfo


IRenderAdapter3D.GetTextures (метод)

Получить текстуры объекта

Синтаксис

[Visual Basic 6]
Function GetTextures ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   Textures As ITextureIdContainer _
) As Long

[Delphi]
function GetTextures(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   out Textures: ITextureIdContainer
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Textures
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Interface ITextureIdContainer


IRenderAdapter3D.GetTypeCount (метод)

Число типов

Синтаксис

[Visual Basic 6]
Function GetTypeCount ( _
   ByVal LayerIndex As Long, _
   Result As Long _
) As Long

[Delphi]
function GetTypeCount(
   const LayerIndex: Integer;
   out Result: Integer
): HResult

Описание параметров

LayerIndex
[in]
Result
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


IRenderAdapter3D.GetWorldBounds (метод)

Получить границы мира

Синтаксис

[Visual Basic 6]
Function GetWorldBounds ( _
   MaxBound As TVector, _
   MinBound As TVector _
) As Long

[Delphi]
function GetWorldBounds(
   out MaxBound: TVector;
   out MinBound: TVector
): HResult

Описание параметров

MaxBound
[out]
MinBound
[out]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D, Record TVector


IRenderAdapter3D.SetData (метод)

Связать с элементом интерфейс

Синтаксис

[Visual Basic 6]
Function SetData ( _
   ByVal LayerIndex As Long, _
   ByVal TypeIndex As Long, _
   ByVal ItemIndex As Long, _
   ByVal Data As IUnknown _
) As Long

[Delphi]
function SetData(
   const LayerIndex: Integer;
   const TypeIndex: Integer;
   const ItemIndex: Integer;
   const Data: IUnknown
): HResult

Описание параметров

LayerIndex
[in]
TypeIndex
[in]
ItemIndex
[in]
Data
[in]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IRenderAdapter3D


Интерфейс IRoutesEvents

Наследование

IUnknown Class IRoutesEvents

Методы интерфейса

Имя | Описание
Method AnalogModelChanged | Событие при изменении геометрии тассы в плане
Method CrossectionDeleted | Событие, вызываемое после удаления элемента из трассы
Method CrossectionDeleting | Событие, вызываемое непосредственно перед удалением элемента из трассы
Method CrossectionInserted | Событие, вызываемое после добавления элемента в трассу
Method CrossectionInserting | Событие, вызываемое перед добавлением элемента в трассу
Method DigitalModelChanged | Событие при изменении цифровой модели трассы
Method NewRoute | Событие при создании новой трассы
Method RouteActivate | Событие при активизации трассы
Method RouteCloned | Событие вызываемое при клонировании трассы
Method RouteDeleting | Событие вызываемое непосредственно перед удалением трассы
Method RouteParamsChanged | Событие вызываемое при изменении параметров трассы
Method SelectionChanged | Событие, вызываемое при изменении активного элемента трассы на трассе, либо при изменении выделенного диапазона
Method SpacedOut | Событие, вызываемое после разбивки трассы
Method SurfaceModified | Событие, вызываемое при изменении поверхности, назначенной как существующая для данной трассы
Method UnSpacedOut | Событие, вызываемое после удаления разбивки
Method VertexSelected | Событие, вызываемое при изменении активной вершины трассы

Где используется

Класс | Член класса
Class Routes | Method Advise (метод)

Смотри также

Class Route, Class RouteElement, Enum RouteModelModifiedConstants, Class RouteVertex, Group Трассы


IRoutesEvents.AnalogModelChanged (метод)

Событие при изменении геометрии тассы в плане

Синтаксис

[Visual Basic 6]
Sub AnalogModelChanged ( _
   ByVal Route As Route _
)

[Delphi]
procedure AnalogModelChanged(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, у которой изменилась геометрия в плане

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.CrossectionDeleted (метод)

Событие, вызываемое после удаления элемента из трассы

Синтаксис

[Visual Basic 6]
Sub CrossectionDeleted ( _
   ByVal Route As Route, _
   ByVal Index As Long _
)

[Delphi]
procedure CrossectionDeleted(
   const Route: Route;
   const Index: Integer
)

Описание параметров

Route
[in] Трасса, элемент которой был удалён
Index
[in] Индекс удалённого элемента трассы

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.CrossectionDeleting (метод)

Событие, вызываемое непосредственно перед удалением элемента из трассы

Синтаксис

[Visual Basic 6]
Sub CrossectionDeleting ( _
   ByVal Route As Route, _
   ByVal Index As Long _
)

[Delphi]
procedure CrossectionDeleting(
   const Route: Route;
   const Index: Integer
)

Описание параметров

Route
[in] Трасса, элемент которой будет удалён
Index
[in] Индекс элемента трассы, подлежащего удалению

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.CrossectionInserted (метод)

Событие, вызываемое после добавления элемента в трассу

Синтаксис

[Visual Basic 6]
Sub CrossectionInserted ( _
   ByVal Route As Route, _
   ByVal Element As RouteElement, _
   ByVal Index As Long _
)

[Delphi]
procedure CrossectionInserted(
   const Route: Route;
   const Element: RouteElement;
   const Index: Integer
)

Описание параметров

Route
[in] Трасса, в модель которой добавлен элемент разбивки
Element
[in] Элемент, добавленный в массив элементов
Index
[in] Порядковый номер в массиве элементов, который имеет добавленный элемент

Смотри также

Interface IRoutesEvents, Class Route, Class RouteElement, Group Трассы


IRoutesEvents.CrossectionInserting (метод)

Событие, вызываемое перед добавлением элемента в трассу

Синтаксис

[Visual Basic 6]
Sub CrossectionInserting ( _
   ByVal Route As Route, _
   ByVal Element As RouteElement, _
   ByVal Index As Long, _
   ByVal InterpolateParams As Boolean _
)

[Delphi]
procedure CrossectionInserting(
   const Route: Route;
   const Element: RouteElement;
   const Index: Integer;
   const InterpolateParams: WordBool
)

Описание параметров

Route
[in] Трасса, в модель которой добавляется элемент разбивки
Element
[in] Добавляемый элемент разбивки
Index
[in] Порядковый номер в массиве элементов, который будет иметь добавляемый элемент
InterpolateParams
[in] True- Параметры данного элемента необходимо интерполировать между соседними элементами, False - параметры нужно выставить в значения по умолчанию

Смотри также

Interface IRoutesEvents, Class Route, Class RouteElement, Group Трассы


IRoutesEvents.DigitalModelChanged (метод)

Событие при изменении цифровой модели трассы

Синтаксис

[Visual Basic 6]
Sub DigitalModelChanged ( _
   ByVal Route As Route, _
   ByVal ChangedFrom As Long, _
   ByVal ChangedTo As Long, _
   ByVal Flags As RouteModelModifiedConstants _
)

[Delphi]
procedure DigitalModelChanged(
   const Route: Route;
   const ChangedFrom: Integer;
   const ChangedTo: Integer;
   const Flags: RouteModelModifiedConstants
)

Описание параметров

Route
[in] Трасса, цифровая модель которой изменилась
ChangedFrom
[in] Индекс начального из изменённых элементов трассы
ChangedTo
[in] Индекс конечного из изменённых элементов трассы
Flags
[in] Комбинация флагов, по которой можно определить, что изменилось в элементах трассы

Смотри также

Interface IRoutesEvents, Class Route, Enum RouteModelModifiedConstants, Group Трассы


IRoutesEvents.NewRoute (метод)

Событие при создании новой трассы

Синтаксис

[Visual Basic 6]
Sub NewRoute ( _
   ByVal Route As Route _
)

[Delphi]
procedure NewRoute(
   const Route: Route
)

Описание параметров

Route
[in] Созданная трасса

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.RouteActivate (метод)

Событие при активизации трассы

Синтаксис

[Visual Basic 6]
Sub RouteActivate ( _
   ByVal Route As Route _
)

[Delphi]
procedure RouteActivate(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, ставшая активной

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.RouteCloned (метод)

Событие вызываемое при клонировании трассы

Синтаксис

[Visual Basic 6]
Sub RouteCloned ( _
   ByVal Route As Route _
)

[Delphi]
procedure RouteCloned(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, полученная в результате клонирования

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.RouteDeleting (метод)

Событие вызываемое непосредственно перед удалением трассы

Синтаксис

[Visual Basic 6]
Sub RouteDeleting ( _
   ByVal Route As Route _
)

[Delphi]
procedure RouteDeleting(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, которая будет удалена

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.RouteParamsChanged (метод)

Событие вызываемое при изменении параметров трассы

Синтаксис

[Visual Basic 6]
Sub RouteParamsChanged ( _
   ByVal Route As Route _
)

[Delphi]
procedure RouteParamsChanged(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, параметры которой были изменены

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.SelectionChanged (метод)

Событие, вызываемое при изменении активного элемента трассы на трассе, либо при изменении выделенного диапазона

Синтаксис

[Visual Basic 6]
Sub SelectionChanged ( _
   ByVal Route As Route, _
   ByVal SelectedFrom As Long, _
   ByVal SelectedTo As Long, _
   ByVal ActiveElementIndex As Long _
)

[Delphi]
procedure SelectionChanged(
   const Route: Route;
   const SelectedFrom: Integer;
   const SelectedTo: Integer;
   const ActiveElementIndex: Integer
)

Описание параметров

Route
[in] Трасса, для которой вызывается событие
SelectedFrom
[in] Индекс начального элемента трассы среди выделенных
SelectedTo
[in] Индекс конечного элемента трассы среди выделенных
ActiveElementIndex
[in] Индекс выделенного элемента трассы

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.SpacedOut (метод)

Событие, вызываемое после разбивки трассы

Синтаксис

[Visual Basic 6]
Sub SpacedOut ( _
   ByVal Route As Route _
)

[Delphi]
procedure SpacedOut(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, которая была разбита на поперечные профили

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.SurfaceModified (метод)

Событие, вызываемое при изменении поверхности, назначенной как существующая для данной трассы

Синтаксис

[Visual Basic 6]
Sub SurfaceModified ( _
   ByVal Route As Route _
)

[Delphi]
procedure SurfaceModified(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, для которой вызывается событие

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.UnSpacedOut (метод)

Событие, вызываемое после удаления разбивки

Синтаксис

[Visual Basic 6]
Sub UnSpacedOut ( _
   ByVal Route As Route _
)

[Delphi]
procedure UnSpacedOut(
   const Route: Route
)

Описание параметров

Route
[in] Трасса, разбивка которой была уничтожена

Смотри также

Interface IRoutesEvents, Class Route, Group Трассы


IRoutesEvents.VertexSelected (метод)

Событие, вызываемое при изменении активной вершины трассы

Синтаксис

[Visual Basic 6]
Sub VertexSelected ( _
   ByVal Route As Route, _
   ByVal RouteVertex As RouteVertex _
)

[Delphi]
procedure VertexSelected(
   const Route: Route;
   const RouteVertex: RouteVertex
)

Описание параметров

Route
[in] Трасса, у которой изменилась активная вершина угла
RouteVertex
[in] Вершина трассы, ставшая активной

Смотри также

Interface IRoutesEvents, Class Route, Class RouteVertex, Group Трассы


Интерфейс ITextureIdContainer

Массив идентификаторов текстур

Наследование

IUnknown Class ITextureIdContainer

Свойства интерфейса

Имя | Описание
Property Count (только для чтения) | Число текстур
Property Items (только для чтения) | Идентификаторы текстур

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetTextures (метод)


ITextureIdContainer.Count (свойство)

Число текстур

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface ITextureIdContainer


ITextureIdContainer.Items (свойство)

Идентификаторы текстур

Синтаксис

[Visual Basic 6]
ReadOnly Property Items As Long

[Delphi]
{только для чтения} property Items: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface ITextureIdContainer


Интерфейс ITrnFigureFilter

Интерфейс, используемый в методах GetItem[s]AtPoint/GetItemsAtRect триангуляции для получения объектов в заданной точки плоскости

Наследование

IUnknown Class ITrnFigureFilter

Методы интерфейса

Имя | Описание
Method IsValidObject | Метод, который будет вызываться из метода GetItem[s]AtPoint/GetItemsAtRect триангуляции

Где используется

Класс | Член класса
Class CADTriangulation | Method GetObjectAtPoint (метод) Method GetObjectsAtPoint (метод) Method GetObjectsAtRect (метод)
Class Triangulation | Method GetObjectAtPoint (метод) Method GetObjectsAtPoint (метод) Method GetObjectsAtRect (метод)

Смотри также

Class TrnFigure, Group Триангуляция


ITrnFigureFilter.IsValidObject (метод)

Метод, который будет вызываться из метода GetItem[s]AtPoint/GetItemsAtRect триангуляции

Синтаксис

[Visual Basic 6]
Sub IsValidObject ( _
   ByVal TrnFigure As TrnFigure, _
   IsValid As Boolean _
)

[Delphi]
procedure IsValidObject(
   const TrnFigure: TrnFigure;
   out IsValid: WordBool
)

Описание параметров

TrnFigure
[in] Проверяемый объект триангуляции
IsValid
[out] Здесь необходимо вернуть True, если объект является правильным, т.е. допустим для возврата в качестве результата в GetItem[s]AtPoint/GetItemsAtRect

Смотри также

Interface ITrnFigureFilter, Class TrnFigure, Group Триангуляция


Интерфейс IUndoMemoryEstimator

Интерфейс для оценки занимаемой объектом памяти

Наследование

IUnknown Class IUndoMemoryEstimator

Методы интерфейса

Имя | Описание
Method EstimateMemory | Метод для получения оценки занимаемой объектом памяти

Смотри также

Group Менеджер откатов


IUndoMemoryEstimator.EstimateMemory (метод)

Метод для получения оценки занимаемой объектом памяти

Синтаксис

[Visual Basic 6]
Function EstimateMemory ( _
   Result As Long _
) As Long

[Delphi]
function EstimateMemory(
   out Result: Integer
): HResult

Описание параметров

Result
[out] Возвращает количество байт памяти, занимаемой объектов

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoMemoryEstimator, Group Менеджер откатов


Интерфейс IUndoRestoreAfter

Обработчик событий

Наследование

IUnknown Class IUndoRestoreAfter

Методы интерфейса

Имя | Описание
Method RestoreAfter | Метод, который вызывается менеджером откатов после выполнения отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method Start (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreAfter.RestoreAfter (метод)

Метод, который вызывается менеджером откатов после выполнения отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreAfter ( _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreAfter(
   const Cookie: Integer
): HResult

Описание параметров

Cookie
[in] Дополнительное значение, переданное методу Start

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreAfter, Group Менеджер откатов


Интерфейс IUndoRestoreArray

Обработчик события восстановления объекта, состояние которого было запомнено в виде массива с данными

Наследование

IUnknown Class IUndoRestoreArray

Методы интерфейса

Имя | Описание
Method RestoreArray | Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method RememberArray (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreArray.RestoreArray (метод)

Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreArray ( _
   ByVal Array() As Byte, _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreArray(
   const Array: PSafeArray;
   const Cookie: Integer
): HResult

Описание параметров

Array
[in] Массив с данными
Cookie
[in] Дополнительное значение, переданное методу RememberArray

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreArray, Group Менеджер откатов


Интерфейс IUndoRestoreBefore

Обработчик событий

Наследование

IUnknown Class IUndoRestoreBefore

Методы интерфейса

Имя | Описание
Method RestoreBefore | Метод, который вызывается менеджером откатов перед откатом или возвратом

Где используется

Класс | Член класса
Class UndoManager | Method Finish (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreBefore.RestoreBefore (метод)

Метод, который вызывается менеджером откатов перед откатом или возвратом

Синтаксис

[Visual Basic 6]
Function RestoreBefore ( _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreBefore(
   const Cookie: Integer
): HResult

Описание параметров

Cookie
[in] Дополнительное значение, переданное методу Commit

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreBefore, Group Менеджер откатов


Интерфейс IUndoRestoreBoolean

Обработчик события восстановления объекта, состояние которого было запомнено как логическое значение

Наследование

IUnknown Class IUndoRestoreBoolean

Методы интерфейса

Имя | Описание
Method RestoreBoolean | Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method RememberBoolean (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreBoolean.RestoreBoolean (метод)

Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreBoolean ( _
   ByVal Value As Boolean, _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreBoolean(
   const Value: WordBool;
   const Cookie: Integer
): HResult

Описание параметров

Value
[in] Сохранённое в буфере логическое значение
Cookie
[in] Дополнительное значение, переданное методу RememberBoolean

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreBoolean, Group Менеджер откатов


Интерфейс IUndoRestoreBuffer

Обработчик события восстановления объекта, состояние которого было запомнено в виде произвольного буфера с данными

Наследование

IUnknown Class IUndoRestoreBuffer

Методы интерфейса

Имя | Описание
Method FreeBuffer | Освобождение буфера состояния объекта. Метод вызывается менеджером откатов только тогда, когда не произошло отката или возврата буфера
Method RestoreBuffer | Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method RememberBuffer (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreBuffer.FreeBuffer (метод)

Освобождение буфера состояния объекта. Метод вызывается менеджером откатов только тогда, когда не произошло отката или возврата буфера

Синтаксис

[Visual Basic 6]
Function FreeBuffer ( _
   ByVal DataPointer As OLE_HANDLE, _
   ByVal BufferSize As Long, _
   ByVal Cookie As Long _
) As Long

[Delphi]
function FreeBuffer(
   const DataPointer: OLE_HANDLE;
   const BufferSize: Integer;
   const Cookie: Integer
): HResult

Описание параметров

DataPointer
[in] Небезопасный указатель на буфер с данными
BufferSize
[in] Размер буфера с данными
Cookie
[in] Дополнительное значение, переданное методу RememberBuffer

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Interface IUndoRestoreBuffer, Group Менеджер откатов


IUndoRestoreBuffer.RestoreBuffer (метод)

Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreBuffer ( _
   ByVal DataPointer As OLE_HANDLE, _
   ByVal BufferSize As Long, _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreBuffer(
   const DataPointer: OLE_HANDLE;
   const BufferSize: Integer;
   const Cookie: Integer
): HResult

Описание параметров

DataPointer
[in] Небезопасный указатель на буфер с данными
BufferSize
[in] Размер буфера с данными
Cookie
[in] Дополнительное значение, переданное методу RememberBuffer

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Interface IUndoRestoreBuffer, Group Менеджер откатов


Интерфейс IUndoRestoreDouble

Обработчик события восстановления объекта, состояние которого было запомнено как вещественное значение

Наследование

IUnknown Class IUndoRestoreDouble

Методы интерфейса

Имя | Описание
Method RestoreDouble | Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method RememberDouble (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreDouble.RestoreDouble (метод)

Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreDouble ( _
   ByVal Value As Double, _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreDouble(
   const Value: Double;
   const Cookie: Integer
): HResult

Описание параметров

Value
[in] Сохранённое в буфере вещественное значение
Cookie
[in] Дополнительное значение, переданное методу RememberDouble

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreDouble, Group Менеджер откатов


Интерфейс IUndoRestoreInteger

Обработчик события восстановления объекта, состояние которого было запомнено как целочисленное значение

Наследование

IUnknown Class IUndoRestoreInteger

Методы интерфейса

Имя | Описание
Method RestoreInteger | Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method RememberInteger (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreInteger.RestoreInteger (метод)

Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreInteger ( _
   ByVal Value As Long, _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreInteger(
   const Value: Integer;
   const Cookie: Integer
): HResult

Описание параметров

Value
[in] Сохранённое в буфере целочисленное значение
Cookie
[in] Дополнительное значение, переданное методу RememberInteger

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreInteger, Group Менеджер откатов


Интерфейс IUndoRestoreMethod

Обработчик события восстановления объекта

Наследование

IUnknown Class IUndoRestoreMethod

Методы интерфейса

Имя | Описание
Method RestoreMethod | Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method RememberMethod (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreMethod.RestoreMethod (метод)

Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreMethod ( _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreMethod(
   const Cookie: Integer
): HResult

Описание параметров

Cookie
[in] Дополнительное значение, переданное методу RememberMethod

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreMethod, Group Менеджер откатов


Интерфейс IUndoRestoreString

Обработчик события восстановления объекта, состояние которого было запомнено как строковое значение

Наследование

IUnknown Class IUndoRestoreString

Методы интерфейса

Имя | Описание
Method RestoreString | Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method RememberString (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreString.RestoreString (метод)

Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreString ( _
   ByVal Value As String, _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreString(
   const Value: WideString;
   const Cookie: Integer
): HResult

Описание параметров

Value
[in] Сохранённое в буфере строковое значение
Cookie
[in] Дополнительное значение, переданное методу RememberString

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreString, Group Менеджер откатов


Интерфейс IUndoRestoreUnknown

Обработчик события восстановления объекта, состояние которого было запомнено как интерфейс объекта

Наследование

IUnknown Class IUndoRestoreUnknown

Методы интерфейса

Имя | Описание
Method RestoreUnknown | Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Где используется

Класс | Член класса
Class UndoManager | Method RememberUnknown (метод)

Смотри также

Group Менеджер откатов


IUndoRestoreUnknown.RestoreUnknown (метод)

Восстановление состояния объекта. Метод вызывается менеджером откатов во время отката или возврата

Синтаксис

[Visual Basic 6]
Function RestoreUnknown ( _
   ByVal Value As IUnknown, _
   ByVal Cookie As Long _
) As Long

[Delphi]
function RestoreUnknown(
   const Value: IUnknown;
   const Cookie: Integer
): HResult

Описание параметров

Value
[in] Сохранённый в буфере интерфейс
Cookie
[in] Дополнительное значение, переданное методу RememberUnknown

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IUndoRestoreUnknown, Group Менеджер откатов


Интерфейс IView3DController

Реализуется объектами, обеспечивающими управление 3D-видом с помощью клавиатуры, джойстика

Наследование

IUnknown Class IView3DController

Свойства интерфейса

Имя | Описание
Property HorizAngle | Горизонтальный угол направления взгляда камеры в радианах
Property VertAngle | Вертикальный угол направления взгляда камеры в радианах

Методы интерфейса

Имя | Описание
Method AfterDraw | Вызывается после отрисовки основной сцены. Можно вывести какую-либо информацию поверх сцены
Method AfterRenderScene | Вызывается после каждой отрисовки сцены в поверхность
Method DrawAdditionalObjects | Вызывается после отрисовки сцены (основной или дополнительных) для отображения дополнительных объектов
Method EnterController | Вызывается перед получением управления. Можно проинициализировать внутренние переменные
Method ExitController | Вызывается перед отбиранием управления, закрытием 3D-вида. Можно деинициализировать внутренние переменные
Method FreeD3DResources | Вызывается при закрытии 3D-вида или при переинициализации устройства вывода. Контроллер должен освободить все ресурсы, связанные с выводом изображений в 3D-вид
Method GetEnabled | Разрешён ли контроллер
Method GetHandle | Handle контроллера
Method GetImageIndex | Индекс стандартной иконки для кнопки активизации контроллера
Method GetName | Имя контроллера. Отображается в настройках и пр
Method GetReleaseOnFormActivate | Требуется ли выход из контроллера при активации окна 3D-вида
Method KeyboardEvent | Событие клавиатуры. Верните True, чтобы поглотить его, в противном случае - False. Параметры, как у CADCommandKbd.ProcessKbd
Method PrepareRenderTarget | Выполнить подготовительные операции для отрисовки изображения в поверхность
Method SetEyePosition | Устанавливает позицию камеры
Method UpdatePosition | Вызывается перед тем, как требуется отрисовать кадр

Где используется

Класс | Член класса
Class SubSystem3D | Property Controller (свойство) Property Controllers (свойство) Method RegisterController (метод)

Смотри также

Enum Controller3DEventConstants, Enum ShiftStateConstants, SubSystem3DBase, Group Трёхмерный вид


IView3DController.HorizAngle (свойство)

Горизонтальный угол направления взгляда камеры в радианах

Синтаксис

[Visual Basic 6]
Property HorizAngle As Long

[Delphi]
property HorizAngle: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.VertAngle (свойство)

Вертикальный угол направления взгляда камеры в радианах

Синтаксис

[Visual Basic 6]
Property VertAngle As Long

[Delphi]
property VertAngle: HResult

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.AfterDraw (метод)

Вызывается после отрисовки основной сцены. Можно вывести какую-либо информацию поверх сцены

Синтаксис

[Visual Basic 6]
Sub AfterDraw ( _
   ByVal Direct3DDevice9 As IUnknown, _
   ByVal SubSystem3D As SubSystem3DBase _
)

[Delphi]
procedure AfterDraw(
   const Direct3DDevice9: IUnknown;
   const SubSystem3D: SubSystem3DBase
)

Описание параметров

Direct3DDevice9
[in] Устройство вывода DirectX для отрисовки 3D-объектов
SubSystem3D
[in] Вспомогательный объект для работы с 3D-видом

Замечания

Внимание! В параметре Direct3DDevice9 передаётся указатель на IDirect3DDevice9, поэтому перед использованием необходимо запросить у него соответствующий интерфейс

Смотри также

Interface IView3DController, SubSystem3DBase, Group Трёхмерный вид


IView3DController.AfterRenderScene (метод)

Вызывается после каждой отрисовки сцены в поверхность

Синтаксис

[Visual Basic 6]
Sub AfterRenderScene ( _
   ByVal MirrorIndex As Long, _
   ByVal Direct3DDevice9 As IUnknown, _
   ByVal SubSystem3D As SubSystem3D _
)

[Delphi]
procedure AfterRenderScene(
   const MirrorIndex: Integer;
   const Direct3DDevice9: IUnknown;
   const SubSystem3D: SubSystem3D
)

Описание параметров

MirrorIndex
[in] Индекс вывода сцены. Нумерация идёт от 0 (основной вывод) и выше (дополнительные)
Direct3DDevice9
[in] Устройство вывода DirectX для отрисовки 3D-объектов
SubSystem3D
[in] Подсистема 3D-вида

Замечания

В этом методе можно как-то использовать сформированное изображение

Смотри также

Interface IView3DController, Class SubSystem3D, Group Трёхмерный вид


IView3DController.DrawAdditionalObjects (метод)

Вызывается после отрисовки сцены (основной или дополнительных) для отображения дополнительных объектов

Синтаксис

[Visual Basic 6]
Sub DrawAdditionalObjects ( _
   ByVal MirrorIndex As Long, _
   ByVal Direct3DDevice9 As IUnknown, _
   ByVal SubSystem3D As SubSystem3DBase _
)

[Delphi]
procedure DrawAdditionalObjects(
   const MirrorIndex: Integer;
   const Direct3DDevice9: IUnknown;
   const SubSystem3D: SubSystem3DBase
)

Описание параметров

MirrorIndex
[in] Индекс вывода сцены, для которой формируется изображение, либо 0 для основного изображения
Direct3DDevice9
[in] Устройство вывода DirectX для отрисовки 3D-объектов
SubSystem3D
[in] Вспомогательный объект для работы с 3D-видом

Смотри также

Interface IView3DController, SubSystem3DBase, Group Трёхмерный вид


IView3DController.EnterController (метод)

Вызывается перед получением управления. Можно проинициализировать внутренние переменные

Синтаксис

[Visual Basic 6]
Sub EnterController

[Delphi]
procedure EnterController

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.ExitController (метод)

Вызывается перед отбиранием управления, закрытием 3D-вида. Можно деинициализировать внутренние переменные

Синтаксис

[Visual Basic 6]
Sub ExitController ( _
   CanExit As Boolean _
)

[Delphi]
procedure ExitController(
   out CanExit: WordBool
)

Описание параметров

CanExit
[out] Объект может вернуть CanExit=False, в этом случае не произойдёт смены контроллера

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.FreeD3DResources (метод)

Вызывается при закрытии 3D-вида или при переинициализации устройства вывода. Контроллер должен освободить все ресурсы, связанные с выводом изображений в 3D-вид

Синтаксис

[Visual Basic 6]
Sub FreeD3DResources

[Delphi]
procedure FreeD3DResources

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.GetEnabled (метод)

Разрешён ли контроллер

Синтаксис

[Visual Basic 6]
Sub GetEnabled ( _
   Enabled As Boolean _
)

[Delphi]
procedure GetEnabled(
   out Enabled: WordBool
)

Описание параметров

Enabled
[out] Объект может вернуть False, если по каким-то причинам передача ему управления 3D-видом невозможна

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.GetHandle (метод)

Handle контроллера

Синтаксис

[Visual Basic 6]
Sub GetHandle ( _
   Value As OLE_HANDLE _
)

[Delphi]
procedure GetHandle(
   out Value: OLE_HANDLE
)

Описание параметров

Value
[out] Объект должен вернуть свой Handle

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.GetImageIndex (метод)

Индекс стандартной иконки для кнопки активизации контроллера

Синтаксис

[Visual Basic 6]
Sub GetImageIndex ( _
   ImageIndex As Long _
)

[Delphi]
procedure GetImageIndex(
   out ImageIndex: Integer
)

Описание параметров

ImageIndex
[out] Индекс стандартной иконки для кнопки активизации контроллера

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.GetName (метод)

Имя контроллера. Отображается в настройках и пр

Синтаксис

[Visual Basic 6]
Sub GetName ( _
   Value As String _
)

[Delphi]
procedure GetName(
   out Value: WideString
)

Описание параметров

Value
[out] Объект должен вернуть имя контроллера

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.GetReleaseOnFormActivate (метод)

Требуется ли выход из контроллера при активации окна 3D-вида

Синтаксис

[Visual Basic 6]
Sub GetReleaseOnFormActivate ( _
   Release As Boolean _
)

[Delphi]
procedure GetReleaseOnFormActivate(
   out Release: WordBool
)

Описание параметров

Release
[out] Требуется ли выход из контроллера при активации окна 3D-вида

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.KeyboardEvent (метод)

Событие клавиатуры. Верните True, чтобы поглотить его, в противном случае - False. Параметры, как у CADCommandKbd.ProcessKbd

Синтаксис

[Visual Basic 6]
Sub KeyboardEvent ( _
   ByVal Reason As Controller3DEventConstants, _
   Key As Long, _
   ByVal Shift As ShiftStateConstants, _
   Handled As Boolean _
)

[Delphi]
procedure KeyboardEvent(
   const Reason: Controller3DEventConstants;
   var Key: Integer;
   const Shift: ShiftStateConstants;
   out Handled: WordBool
)

Описание параметров

Reason
[in] Причина вызова события
Key
[in, out] Код клавиши, если вобытие вызвано нажатием/отпусканием клавиши на клавиатуре, либо номер кнопки на джойстике, если событие вызвано нажатием/отпусканием кнопки, либо X или Y координата положения джойстика, если событие вызвано изменением координат
Shift
[in] Состояние Shift-клавиш в момент события
Handled
[out] Объект должен вернуть True, если событие обработано

Смотри также

Enum Controller3DEventConstants, Interface IView3DController, Enum ShiftStateConstants, Group Трёхмерный вид


IView3DController.PrepareRenderTarget (метод)

Выполнить подготовительные операции для отрисовки изображения в поверхность

Синтаксис

[Visual Basic 6]
Sub PrepareRenderTarget ( _
   ByVal MirrorIndex As Long, _
   ByVal Direct3DDevice9 As IUnknown, _
   Handled As Boolean _
)

[Delphi]
procedure PrepareRenderTarget(
   const MirrorIndex: Integer;
   const Direct3DDevice9: IUnknown;
   out Handled: WordBool
)

Описание параметров

MirrorIndex
[in] Индекс вывода сцены, для которого нужно подготовить устройство вывода. Нумерация идёт от 0 (основной вывод) и выше (дополнительные) Вызовы прекратятся, если возвратить Handled=False
Direct3DDevice9
[in] Устройство вывода DirectX для отрисовки 3D-объектов
Handled
[out] True - признак того, что поверхность подготовлена и необходимо теперь отрисовать всю сцену

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.SetEyePosition (метод)

Устанавливает позицию камеры

Синтаксис

[Visual Basic 6]
Function SetEyePosition ( _
   ByVal EyeX As Double, _
   ByVal EyeY As Double, _
   ByVal EyeZ As Double _
) As Long

[Delphi]
function SetEyePosition(
   const EyeX: Double;
   const EyeY: Double;
   const EyeZ: Double
): HResult

Описание параметров

EyeX
[in] Модельная X-координата позиции камеры
EyeY
[in] Модельная Y-координата позиции камеры
EyeZ
[in] Модельная Z-координата позиции камеры

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IView3DController, Group Трёхмерный вид


IView3DController.UpdatePosition (метод)

Вызывается перед тем, как требуется отрисовать кадр

Синтаксис

[Visual Basic 6]
Sub UpdatePosition ( _
   ByVal SubSystem3D As SubSystem3D _
)

[Delphi]
procedure UpdatePosition(
   const SubSystem3D: SubSystem3D
)

Описание параметров

SubSystem3D
[in] Подсистема 3D-вида

Замечания

В этом методе можно, вызвав методы подсистемы 3D-вида, установить новую позицию камеры. BeginUpdate и EndUpdate подсистемы вызываются автоматически до и после вызова данного метода

Смотри также

Interface IView3DController, Class SubSystem3D, Group Трёхмерный вид


Запись TColorVector

Поля записи

Имя | Описание
Property A |
Property R |
Property g |
Property B |

Где используется

Класс | Член класса
Class TPointInfo | Property Color (свойство)
Class TPolygonInfo | Property Color (свойство)
Class TPolylineInfo | Property Color (свойство)


TColorVector.A (поле)

Синтаксис

[Visual Basic 6]
A As Single

[Delphi]
A: Single

Смотри также

Record TColorVector


TColorVector.B (поле)

Синтаксис

[Visual Basic 6]
B As Single

[Delphi]
B: Single

Смотри также

Record TColorVector


TColorVector.g (поле)

Синтаксис

[Visual Basic 6]
g As Single

[Delphi]
g: Single

Смотри также

Record TColorVector


TColorVector.R (поле)

Синтаксис

[Visual Basic 6]
R As Single

[Delphi]
R: Single

Смотри также

Record TColorVector


Запись TPointGeometry

Поля записи

Имя | Описание
Property X |
Property Y |
Property Z |

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetPointGeometry (метод)


TPointGeometry.X (поле)

Синтаксис

[Visual Basic 6]
X As Double

[Delphi]
X: Double

Смотри также

Record TPointGeometry


TPointGeometry.Y (поле)

Синтаксис

[Visual Basic 6]
Y As Double

[Delphi]
Y: Double

Смотри также

Record TPointGeometry


TPointGeometry.Z (поле)

Синтаксис

[Visual Basic 6]
Z As Double

[Delphi]
Z: Double

Смотри также

Record TPointGeometry


Запись TPointInfo

Поля записи

Имя | Описание
Property PointType |
Property Size |
Property Rotation |
Property Shift |
Property Color |
Property TextureScale |
Property Alignment |
Property FileName |

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetMultiPointInfo (метод) Method GetPointInfo (метод)
Class TPolylineInfo | Property NodeInfo (свойство)

Смотри также

Enum TAlignmentType, Record TColorVector, Enum TPointType, Record TVector


TPointInfo.Alignment (поле)

Синтаксис

[Visual Basic 6]
Alignment As TAlignmentType

[Delphi]
Alignment: TAlignmentType

Смотри также

Enum TAlignmentType, Record TPointInfo


TPointInfo.Color (поле)

Синтаксис

[Visual Basic 6]
Color As TColorVector

[Delphi]
Color: TColorVector

Смотри также

Record TColorVector, Record TPointInfo


TPointInfo.FileName (поле)

Синтаксис

[Visual Basic 6]
FileName As String

[Delphi]
FileName: WideString

Смотри также

Record TPointInfo


TPointInfo.PointType (поле)

Синтаксис

[Visual Basic 6]
PointType As TPointType

[Delphi]
PointType: TPointType

Смотри также

Record TPointInfo, Enum TPointType


TPointInfo.Rotation (поле)

Синтаксис

[Visual Basic 6]
Rotation As TVector

[Delphi]
Rotation: TVector

Смотри также

Record TPointInfo, Record TVector


TPointInfo.Shift (поле)

Синтаксис

[Visual Basic 6]
Shift As TVector

[Delphi]
Shift: TVector

Смотри также

Record TPointInfo, Record TVector


TPointInfo.Size (поле)

Синтаксис

[Visual Basic 6]
Size As TVector

[Delphi]
Size: TVector

Смотри также

Record TPointInfo, Record TVector


TPointInfo.TextureScale (поле)

Синтаксис

[Visual Basic 6]
TextureScale As TVector

[Delphi]
TextureScale: TVector

Смотри также

Record TPointInfo, Record TVector


Запись TPolygonInfo

Поля записи

Имя | Описание
Property PolygonType |
Property Rotation |
Property Shift |
Property Color |
Property ElevationMethod |
Property Alignment |
Property Height |
Property DrawTopPlane |
Property DrawBottomPlane |
Property RoofType |
Property RoofHeight |
Property RoofLedge |
Property RoofWidth |
Property SocketHeight |
Property SurfaceType |
Property SurfaceQualityLevel |
Property SurfaceIrregularity |
Property FileName |

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetPolygonInfo (метод)

Смотри также

Enum TAlignmentType, Record TColorVector, Enum TElevationMethod, Enum TPolygonType, Enum TRoofType, Enum TSurfaceType, Record TVector


TPolygonInfo.Alignment (поле)

Синтаксис

[Visual Basic 6]
Alignment As TAlignmentType

[Delphi]
Alignment: TAlignmentType

Смотри также

Enum TAlignmentType, Record TPolygonInfo


TPolygonInfo.Color (поле)

Синтаксис

[Visual Basic 6]
Color As TColorVector

[Delphi]
Color: TColorVector

Смотри также

Record TColorVector, Record TPolygonInfo


TPolygonInfo.DrawBottomPlane (поле)

Синтаксис

[Visual Basic 6]
DrawBottomPlane As Boolean

[Delphi]
DrawBottomPlane: WordBool

Смотри также

Record TPolygonInfo


TPolygonInfo.DrawTopPlane (поле)

Синтаксис

[Visual Basic 6]
DrawTopPlane As Boolean

[Delphi]
DrawTopPlane: WordBool

Смотри также

Record TPolygonInfo


TPolygonInfo.ElevationMethod (поле)

Синтаксис

[Visual Basic 6]
ElevationMethod As TElevationMethod

[Delphi]
ElevationMethod: TElevationMethod

Смотри также

Enum TElevationMethod, Record TPolygonInfo


TPolygonInfo.FileName (поле)

Синтаксис

[Visual Basic 6]
FileName As String

[Delphi]
FileName: WideString

Смотри также

Record TPolygonInfo


TPolygonInfo.Height (поле)

Синтаксис

[Visual Basic 6]
Height As Double

[Delphi]
Height: Double

Смотри также

Record TPolygonInfo


TPolygonInfo.PolygonType (поле)

Синтаксис

[Visual Basic 6]
PolygonType As TPolygonType

[Delphi]
PolygonType: TPolygonType

Смотри также

Record TPolygonInfo, Enum TPolygonType


TPolygonInfo.RoofHeight (поле)

Синтаксис

[Visual Basic 6]
RoofHeight As Double

[Delphi]
RoofHeight: Double

Смотри также

Record TPolygonInfo


TPolygonInfo.RoofLedge (поле)

Синтаксис

[Visual Basic 6]
RoofLedge As Double

[Delphi]
RoofLedge: Double

Смотри также

Record TPolygonInfo


TPolygonInfo.RoofType (поле)

Синтаксис

[Visual Basic 6]
RoofType As TRoofType

[Delphi]
RoofType: TRoofType

Смотри также

Record TPolygonInfo, Enum TRoofType


TPolygonInfo.RoofWidth (поле)

Синтаксис

[Visual Basic 6]
RoofWidth As Double

[Delphi]
RoofWidth: Double

Смотри также

Record TPolygonInfo


TPolygonInfo.Rotation (поле)

Синтаксис

[Visual Basic 6]
Rotation As TVector

[Delphi]
Rotation: TVector

Смотри также

Record TPolygonInfo, Record TVector


TPolygonInfo.Shift (поле)

Синтаксис

[Visual Basic 6]
Shift As TVector

[Delphi]
Shift: TVector

Смотри также

Record TPolygonInfo, Record TVector


TPolygonInfo.SocketHeight (поле)

Синтаксис

[Visual Basic 6]
SocketHeight As Double

[Delphi]
SocketHeight: Double

Смотри также

Record TPolygonInfo


TPolygonInfo.SurfaceIrregularity (поле)

Синтаксис

[Visual Basic 6]
SurfaceIrregularity As Double

[Delphi]
SurfaceIrregularity: Double

Смотри также

Record TPolygonInfo


TPolygonInfo.SurfaceQualityLevel (поле)

Синтаксис

[Visual Basic 6]
SurfaceQualityLevel As Double

[Delphi]
SurfaceQualityLevel: Double

Смотри также

Record TPolygonInfo


TPolygonInfo.SurfaceType (поле)

Синтаксис

[Visual Basic 6]
SurfaceType As TSurfaceType

[Delphi]
SurfaceType: TSurfaceType

Смотри также

Record TPolygonInfo, Enum TSurfaceType


Запись TPolylineInfo

Поля записи

Имя | Описание
Property LineType |
Property Shift |
Property Rotation |
Property Color |
Property Height |
Property Width |
Property DrawNodes |
Property NodeInfo |
Property FitNodesToHeight |
Property FitTextureToLength |
Property ElevationMethod |
Property Alignment |
Property CommunicatonType |
Property FileName |

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetPolylineInfo (метод)

Смотри также

Enum TAlignmentType, Record TColorVector, Enum TCommunicationType, Enum TElevationMethod, Enum TLineType, Record TPointInfo, Record TVector


TPolylineInfo.Alignment (поле)

Синтаксис

[Visual Basic 6]
Alignment As TAlignmentType

[Delphi]
Alignment: TAlignmentType

Смотри также

Enum TAlignmentType, Record TPolylineInfo


TPolylineInfo.Color (поле)

Синтаксис

[Visual Basic 6]
Color As TColorVector

[Delphi]
Color: TColorVector

Смотри также

Record TColorVector, Record TPolylineInfo


TPolylineInfo.CommunicatonType (поле)

Синтаксис

[Visual Basic 6]
CommunicatonType As TCommunicationType

[Delphi]
CommunicatonType: TCommunicationType

Смотри также

Enum TCommunicationType, Record TPolylineInfo


TPolylineInfo.DrawNodes (поле)

Синтаксис

[Visual Basic 6]
DrawNodes As Boolean

[Delphi]
DrawNodes: WordBool

Смотри также

Record TPolylineInfo


TPolylineInfo.ElevationMethod (поле)

Синтаксис

[Visual Basic 6]
ElevationMethod As TElevationMethod

[Delphi]
ElevationMethod: TElevationMethod

Смотри также

Enum TElevationMethod, Record TPolylineInfo


TPolylineInfo.FileName (поле)

Синтаксис

[Visual Basic 6]
FileName As String

[Delphi]
FileName: WideString

Смотри также

Record TPolylineInfo


TPolylineInfo.FitNodesToHeight (поле)

Синтаксис

[Visual Basic 6]
FitNodesToHeight As Boolean

[Delphi]
FitNodesToHeight: WordBool

Смотри также

Record TPolylineInfo


TPolylineInfo.FitTextureToLength (поле)

Синтаксис

[Visual Basic 6]
FitTextureToLength As Boolean

[Delphi]
FitTextureToLength: WordBool

Смотри также

Record TPolylineInfo


TPolylineInfo.Height (поле)

Синтаксис

[Visual Basic 6]
Height As Double

[Delphi]
Height: Double

Смотри также

Record TPolylineInfo


TPolylineInfo.LineType (поле)

Синтаксис

[Visual Basic 6]
LineType As TLineType

[Delphi]
LineType: TLineType

Смотри также

Enum TLineType, Record TPolylineInfo


TPolylineInfo.NodeInfo (поле)

Синтаксис

[Visual Basic 6]
NodeInfo As TPointInfo

[Delphi]
NodeInfo: TPointInfo

Смотри также

Record TPointInfo, Record TPolylineInfo


TPolylineInfo.Rotation (поле)

Синтаксис

[Visual Basic 6]
Rotation As TVector

[Delphi]
Rotation: TVector

Смотри также

Record TPolylineInfo, Record TVector


TPolylineInfo.Shift (поле)

Синтаксис

[Visual Basic 6]
Shift As TVector

[Delphi]
Shift: TVector

Смотри также

Record TPolylineInfo, Record TVector


TPolylineInfo.Width (поле)

Синтаксис

[Visual Basic 6]
Width As Double

[Delphi]
Width: Double

Смотри также

Record TPolylineInfo


Запись TTextInfo

Поля записи

Имя | Описание
Property PointString |
Property FontName |
Property FontCharset |
Property FontSize |
Property FontStyle |


TTextInfo.FontCharset (поле)

Синтаксис

[Visual Basic 6]
FontCharset As Long

[Delphi]
FontCharset: Integer

Смотри также

Record TTextInfo


TTextInfo.FontName (поле)

Синтаксис

[Visual Basic 6]
FontName As String

[Delphi]
FontName: WideString

Смотри также

Record TTextInfo


TTextInfo.FontSize (поле)

Синтаксис

[Visual Basic 6]
FontSize As Long

[Delphi]
FontSize: Integer

Смотри также

Record TTextInfo


TTextInfo.FontStyle (поле)

Синтаксис

[Visual Basic 6]
FontStyle As Long

[Delphi]
FontStyle: Integer

Смотри также

Record TTextInfo


TTextInfo.PointString (поле)

Синтаксис

[Visual Basic 6]
PointString As String

[Delphi]
PointString: WideString

Смотри также

Record TTextInfo


Запись TTextureId

Поля записи

Имя | Описание
Property StandartTexture |
Property TextureFileName |


TTextureId.StandartTexture (поле)

Синтаксис

[Visual Basic 6]
StandartTexture As Long

[Delphi]
StandartTexture: Integer

Смотри также

Record TTextureId


TTextureId.TextureFileName (поле)

Синтаксис

[Visual Basic 6]
TextureFileName As String

[Delphi]
TextureFileName: WideString

Смотри также

Record TTextureId


Запись TTreeInfo

Поля записи

Имя | Описание
Property TreeType |
Property TreeHeight |

Смотри также

Enum TTreeType


TTreeInfo.TreeHeight (поле)

Синтаксис

[Visual Basic 6]
TreeHeight As Double

[Delphi]
TreeHeight: Double

Смотри также

Record TTreeInfo


TTreeInfo.TreeType (поле)

Синтаксис

[Visual Basic 6]
TreeType As TTreeType

[Delphi]
TreeType: TTreeType

Смотри также

Record TTreeInfo, Enum TTreeType


Запись TVector

Поля записи

Имя | Описание
Property X |
Property Y |
Property Z |

Где используется

Класс | Член класса
Class IRenderAdapter3D | Method GetCameraPosition (метод) Method GetWorldBounds (метод)
Class TPointInfo | Property Rotation (свойство) Property Shift (свойство) Property Size (свойство) Property TextureScale (свойство)
Class TPolygonInfo | Property Rotation (свойство) Property Shift (свойство)
Class TPolylineInfo | Property Rotation (свойство) Property Shift (свойство)


TVector.X (поле)

Синтаксис

[Visual Basic 6]
X As Single

[Delphi]
X: Single

Смотри также

Record TVector


TVector.Y (поле)

Синтаксис

[Visual Basic 6]
Y As Single

[Delphi]
Y: Single

Смотри также

Record TVector


TVector.Z (поле)

Синтаксис

[Visual Basic 6]
Z As Single

[Delphi]
Z: Single

Смотри также

Record TVector


Константы ADOCommandConstants

Тип команды ADO

Константы

Константа | Значение | Описание
Constant ADOCommandUnknown | 0 | Тип команды неизвестен
Constant ADOCommandText | 1 | Команда или имя хранимой процедуры, при этом результат возвращается как результат SQL-запроса
Constant ADOCommandTable | 2 | Имя таблицы
Constant ADOCommandStoredProc | 3 | Имя хранимой процедуры
Constant ADOCommandFile | 4 | Имя сохранённого файла с данными
Constant ADOCommandTableDirect | 5 | Имя таблицы. Возвращаются все колонки таблицы

Где используются

Класс | Член класса
Class LinkedADODataset | Property CommandType (свойство)

Смотри также

Group Интерфейсы с базой данных


Константы ADOLockConstants

Тип блокировки ADO

Константы

Константа | Значение | Описание
Constant ADOLockUnspecified | 0 | Не задан
Constant ADOLockReadOnly | 1 | Блокировка только для чтения
Constant ADOLockPessimistic | 2 | Пессимистичная блокировка
Constant ADOLockOptimistic | 3 | Оптимистичная блокировка
Constant ADOLockBatchOptimistic | 4 | Пакетная оптимистичная блокировка

Где используются

Класс | Член класса
Class LinkedADOCustomDataset | Property LockType (свойство)
Class LinkedADODataset | Property LockType (свойство)
Class LinkedADOQuery | Property LockType (свойство)
Class LinkedADOStoredProc | Property LockType (свойство)
Class LinkedADOTable | Property LockType (свойство)

Смотри также

Group Интерфейсы с базой данных


Константы AdjustPointConstants

Вид точки настройки

Константы

Константа | Значение | Описание
Constant AdjustPointMain | 0 | Главная
Constant AdjustPointSlave | 1 | Вторичная
Constant AdjustPointContact | 2 | Контакт
Constant AdjustPointHidden | 3 | Несуществующая
Constant AdjustPointNew | 4 | Новая

Где используются

Класс | Член класса
Class Figure | Method GetAdjustPointKind (метод)
Class ShapeFigure | Method GetAdjustPointKind (метод)
Class ShapeMultipart | Method GetAdjustPointKind (метод)
Class ShapeMultipoint | Method GetAdjustPointKind (метод)
Class ShapeMultipointM | Method GetAdjustPointKind (метод)
Class ShapeMultipointZ | Method GetAdjustPointKind (метод)
Class ShapePoint | Method GetAdjustPointKind (метод)
Class ShapePointM | Method GetAdjustPointKind (метод)
Class ShapePointZ | Method GetAdjustPointKind (метод)
Class ShapePolygon | Method GetAdjustPointKind (метод)
Class ShapePolygonM | Method GetAdjustPointKind (метод)
Class ShapePolygonZ | Method GetAdjustPointKind (метод)
Class ShapePolyline | Method GetAdjustPointKind (метод)
Class ShapePolylineM | Method GetAdjustPointKind (метод)
Class ShapePolylineZ | Method GetAdjustPointKind (метод)
Class TrnArea | Method GetAdjustPointKind (метод)
Class TrnBreak | Method GetAdjustPointKind (метод)
Class TrnFigure | Method GetAdjustPointKind (метод)
Class TrnFlip | Method GetAdjustPointKind (метод)
Class TrnModifier | Method GetAdjustPointKind (метод)
Class TrnNode | Method GetAdjustPointKind (метод)
Class TrnRib | Method GetAdjustPointKind (метод)
Class TrnSource | Method GetAdjustPointKind (метод)
Class TrnTriangle | Method GetAdjustPointKind (метод)

Смотри также

Group фигуры


Константы AlignmentConstants

Тип выравнивания

Константы

Константа | Значение | Описание
Constant AlignmentLeftJustify | 0 | Выравнивание налево
Constant AlignmentRightJustify | 1 | Выравнивание направо
Constant AlignmentCenter | 2 | Выравнивание по центру

Где используются

Класс | Член класса
Class BrowserItem | Property Alignment (свойство)
Class Field | Property Alignment (свойство)

Смотри также

Group Пользовательский интерфейс


Константы AngleModeConstants

Точность отображения углов

Константы

Константа | Значение | Описание
Constant AngleModeDefault | -1 | Берется из переменной AngleMode
Constant AngleMode10Degrees | 0 | 10° (округление до 10 градусов)
Constant AngleMode5Degrees | 1 | 5° (округление до 5 градусов)
Constant AngleModeDegrees | 2 | 1° (округление до градусов)
Constant AngleMode10Minutes | 3 | 0°10' (округление до 10 минут)
Constant AngleModeMinutes | 4 | 0°01' (округление до минут)
Constant AngleMode10Seconds | 5 | 0°00'10" (округление до 10 секунд)
Constant AngleModeSeconds | 6 | 0°00'01" (округление до секунд, по умолчанию)
Constant AngleMode100Milliseconds | 7 | 0°00'00,1" (округление до 100 миллисекунд)
Constant AngleMode10Milliseconds | 8 | 0°00'00,01" (округление до 10 миллисекунд)
Constant AngleModeMilliseconds | 9 | 0°00'00,001" (округление до миллисекунд)

Где используются

Класс | Член класса
Class SurveyEditor | Property AngleMode (свойство)

Смотри также

Group Геодезия


Константы AssemblyParameterConstants

Запоминаемые параметры в собрании слоёв

Константы

Константа | Значение | Описание
Constant AssemblyParameterVisible | 1 | Состояние видимости слоя
Constant AssemblyParameterClosed | 2 | Свёрнута ли легенда слоя
Constant AssemblyParameterTransparency | 4 | Прозрачность слоя
Constant AssemblyParameterClipRegion | 8 | Область отсечения слоя
Constant AssemblyParameterProjection | 16 | Проекция слоя
Constant AssemblyParameterData | 32 | Дополнительные параметры

Где используются

Класс | Член класса
Class Assembly | Property Parameters (свойство) Method Remember (метод)

Смотри также

Group Контейнеры изображений


Константы BSplineEdgeConstants

Тип краевого ограничения для B-сплайнов, построенных по полилиниям

Константы

Константа | Значение | Описание
Constant EdgeCurvatureNone | 0 | Одинарные точки на краях - сплайн не проходит через крайние точки
Constant EdgeCurvatureTangent | 1 | Двойные точки на краях - сплайн начинается с касательной - с отрезка на двух крайних точках
Constant EdgeCurvaturePoint | 2 | Тройные точки на краях - сплайн начинается с крайних точек

Где используются

Класс | Член класса
Class CADTriangulation | Method BuildIsoline (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод)
Class Triangulation | Method BuildIsoline (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод)

Смотри также

Group Визуализаторы данных


Константы BarButtonGroupPositionConstants

Способ участия кнопок на панели или ленте инструментов в группе кнопок

Константы

Константа | Значение | Описание
Constant BarButtonGroupPositionNone | 0 | Кнопка не участвует в группе кнопок
Constant BarButtonGroupPositionStart | 1 | Кнопка начинает новую группу кнопок
Constant BarButtonGroupPositionMember | 2 | Кнопка продолжает группу кнопок, начатую предыдущим элементом

Где используются

Класс | Член класса
Class BarItemLink | Property ButtonGroup (свойство)

Смотри также

Group Пользовательский интерфейс


Константы BarItemPositionConstants

Способ размещения элементов на ленте инструментов

Константы

Константа | Значение | Описание
Constant BarItemPositionBeginsNewRow | 0 | Элемент начинает новую строку на ленте инструментов
Constant BarItemPositionBeginsNewColumn | 1 | Элемент начинает новую колонку на ленте инструментов
Constant BarItemPositionContinuesRow | 2 | Элемент продолжает предыдущую строку на ленте инструментов

Где используются

Класс | Член класса
Class BarItemLink | Property Position (свойство)

Смотри также

Group Пользовательский интерфейс


Константы BarPaintStyleConstants

Рекомендованный способ отображения элементов на панели или ленте инструментов

Константы

Константа | Значение | Описание
Constant BarPaintStyleStandard | 0 | Стандартный способ отображения (разный для разных типов элементов)
Constant BarPaintStyleCaption | 1 | Отображение с текстовой надписью
Constant BarPaintStyleCaptionInMenu | 2 | Отображение с текстовой надписью в меню
Constant BarPaintStyleCaptionGlyph | 3 | Отображение с текстовой надписью и иконкой

Где используются

Класс | Член класса
Class BarItemLink | Property UserPaintStyle (свойство)

Смотри также

Group Пользовательский интерфейс


Константы BrowserConstants

Стиль браузера

Константы

Константа | Значение | Описание
Constant BrowserGrid | 0 | Таблица
Constant BrowserList | 1 | Список
Constant BrowserNarrowForm | 2 | Узкая форма
Constant BrowserWideForm | 3 | Широкая форма
Constant BrowserHorForm | 4 | Горизонтальная форма
Constant BrowserWrapForm | 5 | Форма с выравниванием по ширине
Constant BrowserNarrowGrid | 6 | Таблица узких форм
Constant BrowserWideGrid | 7 | Таблица широких форм
Constant BrowserHorGrid | 8 | Таблица горизонтальных форм
Constant BrowserWrapGrid | 9 | Таблица самовыравнивающихся форм

Смотри также

Group Базы данных


Константы BrushStyleConstants

Способ закраски

Константы

Константа | Значение | Описание
Constant BrushStyleSolid | 0 | Заливка сплошная
Constant BrushStyleClear | 1 | Заливки нет
Constant BrushStyleHorizontal | 2 | Горизонтальная штриховка
Constant BrushStyleVertical | 3 | Вертикальная штриховка
Constant BrushStyleFDiagonal | 4 | Прямая диагональная штриховка
Constant BrushStyleBDiagonal | 5 | Обратная диагональная штриховка
Constant BrushStyleCross | 6 | Поперечная штриховка
Constant BrushStyleDiagCross | 7 | Диагональная попереченая штриховка

Где используются

Класс | Член класса
Class ContainerSurface | Method BrushSelect (метод)
Class CustomSurface | Method BrushSelect (метод)
Class ModelSurface | Method BrushSelect (метод)
Class PaintCanvas | Property BrushStyle (свойство)

Смотри также

Group Рисование изображений


Константы CallReasonKeyboardConstants

Причина вызова метода ProcessKeyboard у текущего режима работы

Константы

Константа | Значение | Описание
Constant CallReasonKeyboardKeyDown | 0 | Нажата клавиша на клавиатуре. Key: код клавиши
Constant CallReasonKeyboardKeyUp | 1 | Отпущена клавиша на клавиатуре. Key: код клавиши
Constant CallReasonKeyboardKeyChar | 2 | В буфер клавиатуры попал символ. Key: код символа
Constant CallReasonKeyboardJoystickButtonDown | 3 | На джойстике нажата кнопка мыши. Key: номер кнопки
Constant CallReasonKeyboardJoystickButtonUp | 4 | На джойстике отпущена кнопка мыши. Key: номер кнопки
Constant CallReasonKeyboardJoystickXChanged | 5 | Джойстик повернули по оси X. Key: текущая координата X
Constant CallReasonKeyboardJoystickYChanged | 6 | Джойстик повернули по оси Y. Key: текущая координата Y
Constant CallReasonKeyboard3DxMoveXChanged | 7 | 3D-мышь толкнули вдоль оси X. Key: текущая координата X
Constant CallReasonKeyboard3DxMoveYChanged | 8 | 3D-мышь толкнули вдоль оси Y. Key: текущая координата Y
Constant CallReasonKeyboard3DxMoveZChanged | 9 | 3D-мышь толкнули вдоль оси Z. Key: текущая координата Z
Constant CallReasonKeyboard3DxRotateXChanged | 10 | 3D-мышь повернули вокруг оси X. Key: текущее значение поворота
Constant CallReasonKeyboard3DxRotateYChanged | 11 | 3D-мышь повернули вокруг оси Y. Key: текущее значение поворота
Constant CallReasonKeyboard3DxRotateZChanged | 12 | 3D-мышь повернули вокруг оси Z. Key: текущее значение поворота

Смотри также

Group Внешние модули


Константы CallReasonMouseConstants

Причина вызова метода ProcessMouse у текущего режима работы

Константы

Константа | Значение | Описание
Constant CallReasonMouseMove | 0 | Событие вызвано перемещением мыши
Constant CallReasonMouseDown | 1 | Событие вызвано нажатием клавиши мыши
Constant CallReasonMouseUp | 2 | Событие вызвано отпусканием клавиши мыши
Constant CallReasonMouseWheel | 3 | Событие вызвано вращением колеса мыши

Смотри также

Group Внешние модули


Константы CompositionLayerConstants

Тип слоя карты

Константы

Константа | Значение | Описание
Constant CompositionLayerUnknown | 0 | Неизвестный тип
Constant CompositionLayerFolder | 1 | Папка слоев
Constant CompositionLayerShape | 2 | Слой шейп-файла
Constant CompositionLayerCoverage | 3 | Слой покрытия
Constant CompositionLayerNetwork | 4 | Слой транспортной сети
Constant CompositionLayerScheme | 5 | Слой чертежа IndorGIS
Constant CompositionLayerFrame | 6 | Слой рамки оформления
Constant CompositionLayerGrid | 7 | Слой регулярной сети
Constant CompositionLayerImage | 8 | Слой растра
Constant CompositionLayerTriangulation | 9 | Слой триангуляции
Constant CompositionLayerTool | 10 | Инструментальный слой
Constant CompositionLayerIndorDraw | 11 | Слой чертежа IndorDraw
Constant CompositionLayerIndorCAD | 12 | Слой проекта IndorCAD
Constant CompositionLayerIndorGIS | 13 | Слой карты IndorGIS
Constant CompositionLayerTraces | 14 | Слой трасс
Constant CompositionLayerMosaic | 15 | Слой мозаики растров

Где используются

Класс | Член класса
Class CompositionLayer | Property Kind (свойство)
Class FolderLayer | Property Kind (свойство)
Class VectorLayer | Property Kind (свойство)

Смотри также

Group Карты


Константы CompositionSmoothFilterConstants

Тип сглаживающего фильтра в контейнере

Константы

Константа | Значение | Описание
Constant CompositionSmoothDefault | 0 | Сглаживания Сглаживание выполняется в соответствии с настройками по умолчанию
Constant CompositionSmooth2x2 | 2 | Фильтр 2x2
Constant CompositionSmooth4x4 | 4 | Фильтр 4x4
Constant CompositionSmooth8x8 | 8 | Фильтр 8x8
Constant CompositionSmooth16x16 | 16 | Фильтр 16x16

Смотри также

Group Контейнеры изображений


Константы CompressionLevelConstants

Способ сжатия данных

Константы

Константа | Значение | Описание
Constant CompressionLevelNone | 0 | Без сжатия
Constant CompressionLevelFastest | 1 | Минимальное (быстрое) сжатие
Constant CompressionLevelDefault | 2 | Средний уровень сжатия
Constant CompressionLevelMax | 3 | Максимальное (относительно медленное) сжатие

Где используются

Класс | Член класса
Class CADTriangulation | Property CompressionLevel (свойство)
Class Triangulation | Property CompressionLevel (свойство)

Смотри также

Group Триангуляция


Константы ContainerAnimationConstants

Способ анимации навигации в контейнере

Константы

Константа | Значение | Описание
Constant ContainerAnimationNone | 0 | Без анимации
Constant ContainerAnimationRect | 1 | Анимировать движущимися прямоугольниками
Constant ContainerAnimationImage | 2 | Анимировать движущимся изображением карты

Смотри также

Group Контейнеры изображений


Константы ContainerGridTypeConstants

Тип сетки в контейнере

Константы

Константа | Значение | Описание
Constant ContainerGridTypeDotsBeneath | 0 | Точки ниже изображения
Constant ContainerGridTypeDotsAbove | 1 | Точки выше изображения
Constant ContainerGridTypeCrossesBeneath | 2 | Крестики ниже изображения
Constant ContainerGridTypeCrossesAbove | 3 | Крестики выше изображения
Constant ContainerGridTypeDashesBeneath | 4 | Вертикальные и горизонтальные пунтирные линии ниже изображения
Constant ContainerGridTypeDashesAbove | 5 | Вертикальные и горизонтальные пунтирные линии выше изображения
Constant ContainerGridTypeLinesBeneath | 6 | Вертикальные и горизонтальные сплошные линии ниже изображения
Constant ContainerGridTypeLinesAbove | 7 | Вертикальные и горизонтальные сплошные линии выше изображения
Constant ContainerGridTypeSquaresBeneath | 8 | Шахматка (залитые прямоугольники) ниже изображения
Constant ContainerGridTypeSquaresAbove | 9 | Шахматка (залитые прямоугольники) выше изображения

Где используются

Класс | Член класса
Class CustomContainer | Property GridType (свойство) Property UsedGridType (свойство)
Class VectorContainer | Property GridType (свойство) Property UsedGridType (свойство)

Смотри также

Group Контейнеры изображений


Константы Controller3DEventConstants

Причина вызова метода KeyboardEvent у контроллера 3D-вида

Константы

Константа | Значение | Описание
Constant Controller3DEventKeyDown | 0 | Нажата клавиша на клавиатуре. Key: код клавиши
Constant Controller3DEventKeyUp | 1 | Отпущена клавиша на клавиатуре. Key: код клавиши
Constant Controller3DEventKeyChar | 2 | В буфер клавиатуры попал символ. Key: код символа
Constant Controller3DEventJoystickButtonDown | 3 | На джойстике нажата кнопка мыши. Key: номер кнопки
Constant Controller3DEventJoystickButtonUp | 4 | На джойстике отпущена кнопка мыши. Key: номер кнопки
Constant Controller3DEventJoystickXChanged | 5 | Джойстик повернули по оси X. Key: текущая координата X
Constant Controller3DEventJoystickYChanged | 6 | Джойстик повернули по оси Y. Key: текущая координата Y
Constant Controller3DEvent3DxMoveXChanged | 7 | 3D-мышь толкнули вдоль оси X. Key: текущая координата X
Constant Controller3DEvent3DxMoveYChanged | 8 | 3D-мышь толкнули вдоль оси Y. Key: текущая координата Y
Constant Controller3DEvent3DxMoveZChanged | 9 | 3D-мышь толкнули вдоль оси Z. Key: текущая координата Z
Constant Controller3DEvent3DxRotateXChanged | 10 | 3D-мышь повернули вокруг оси X. Key: текущее значение поворота
Constant Controller3DEvent3DxRotateYChanged | 11 | 3D-мышь повернули вокруг оси Y. Key: текущее значение поворота
Constant Controller3DEvent3DxRotateZChanged | 12 | 3D-мышь повернули вокруг оси Z. Key: текущее значение поворота

Где используются

Класс | Член класса
Class IView3DController | Method KeyboardEvent (метод)

Смотри также

Group Трёхмерный вид


Константы CursorConstants

Типы курсоров

Константы

Константа | Значение | Описание
Constant CursorDefault | 0 | Курсор по умолчанию (обычно стрелка)
Constant CursorNone | -1 | Нет курсора
Constant CursorArrow | -2 | Указатель
Constant CursorCross | -3 | Перекрестие
Constant CursorIBeam | -4 | I-знак
Constant CursorSize | -5 | Стрелки в четыре стороны
Constant CursorSizeNESW | -6 | Стрелки справа-сверху - слева-снизу
Constant CursorSizeNS | -7 | Стрелки вверх-вниз
Constant CursorSizeNWSE | -8 | Стрелки справа-снизу - слева-сверху
Constant CursorSizeWE | -9 | Стрелки влево-вправо
Constant CursorUpArrow | -10 | Стрелка вверх
Constant CursorHourGlass | -11 | Песочные часы
Constant CursorDrag | -12 | Перетаскивание
Constant CursorNoDrop | -13 | Перетаскивание запрещено
Constant CursorHSplit | -14 | Разделение по горизонтали
Constant CursorVSplit | -15 | Разделение по вертикали
Constant CursorMultiDrag | -16 | Множественное перетаскивание
Constant CursorSQLWait | -17 | Ожидание операции SQL
Constant CursorNo | -18 | Нет
Constant CursorAppStart | -19 | Запуск приложения
Constant CursorHelp | -20 | Помощь
Constant CursorHandPoint | -21 | Указательный палец
Constant CursorSizeAll | -22 | Изменение всех размеров
Constant CursorPan | 100 | Режим панорамирования
Constant CursorPanning | 101 | Режим панорамирования в действии
Constant CursorZoomIn | 102 | Режим увеличения (лупа с +)
Constant CursorZoomOut | 103 | Режим уменьшения (лупа с -)
Constant CursorAdjust | 104 | Выбор точки настройки
Constant CursorMoving | 105 | Перемещение точки настройки
Constant CursorHotLink | 106 | Горячая связь
Constant CursorMasterPan | 107 | Панорамирование главного контейнера
Constant CursorMasterPanning | 108 | Панорамирование главного контейнера в действии
Constant CursorMasterSelect | 109 | Выбор окна главного контейнера
Constant CursorSelect | 110 | Выбор элементов карты
Constant CursorSelectPlus | 111 | Выбор элементов карты с Ctrl
Constant CursorSelectMinus | 112 | Выбор элементов карты с Shift
Constant CursorSelectXor | 113 | Выбор элементов карты с Alt
Constant CursorRotate | 114 | Выбор точки вращения
Constant CursorRotating | 115 | Вращение точки вращения
Constant CursorMove | 116 | Перемещение объекта
Constant CursorCopy | 117 | Копирование объекта
Constant CursorSelecting | 118 | Процесс выделения региона на карте
Constant CursorFormat | 119 | Режим применения формата по образцу
Constant CursorService | 120 | Задание на карте сервисных пунктов
Constant CursorSwitch | 121 | Переключение состояния переключателя
Constant CursorShortCircuit | 122 | Короткое замыкание
Constant CursorData | 123 | Ввод данных по объектам
Constant CursorFormatMulti | 124 | Режим многократного применения формата по образцу
Constant CursorMeasureDistance | 125 | Измерение расстояний
Constant CursorMeasureSquare | 126 | Измерение площадей
Constant CursorInfo | 127 | Полная информация
Constant CursorHint | 128 | Краткая информация
Constant CursorDelete | 129 | Удаление объектов
Constant CursorSelectNext | 130 | Выделение следующего объекта на текущем слое
Constant CursorSelectNextLayer | 131 | Выделение следующего объекта на любом слое
Constant CursorNetwork | 132 | Выделение следующего узла маршрута транспортной сети
Constant CursorTurn | 133 | Выделение следующего узла маршрута транспортной сети
Constant CursorGoal | 134 | Расстановка поворотов транспортной сети
Constant CursorCut | 135 | Нож (разрезание объектов)
Constant CursorCutRect | 136 | Нож (разрезание объектов прямоугольником)
Constant CursorCutLine | 137 | Нож (разрезание объектов по прямой)
Constant CursorColorSelect | 139 | Выбор цвета (перекрестие с дыркой в середине)
Constant CursorLinearReference | 140 | Просмотр линейной привязки
Constant CursorLinearReferencePlay | 141 | Просмотр линейной привязки - проигрывание возможно
Constant CursorArrowUp | 142 | Стрелка вверх
Constant CursorArrowDown | 143 | Стрелка вниз
Constant CursorArrowLeft | 144 | Стрелка влево
Constant CursorArrowRight | 145 | Стрелка вправо
Constant CursorCutNode | 146 | Нож (разрезание линии по узлу)
Constant CursorCutSegment | 147 | Нож (разрезание ломаной с удалением выбранного сегмента)
Constant CursorSight | 148 | Прицел
Constant CursorMeasureAngle | 149 | Измерение углов
Constant CursorMeasurePicket | 150 | Измерение пикетажного положения
Constant CursorFlipTriangles | 151 | Перебросков треугольников в триангуляции
Constant CursorAddPointXYZ | 152 | Добавление новой трёхмерной точки
Constant CursorDerrick | 153 | Буровая вышка
Constant CursorSheet | 154 | Добавление листа
Constant CursorTree | 155 | Добавление дерева
Constant CursorTrianglesPaint | 156 | Раскраска треугольников
Constant CursorDragPlus | 157 | Перетаскивание с копированием
Constant CursorDragInsertBefore | 158 | Перетаскивание со вставкой до объекта
Constant CursorDragInsertAfter | 159 | Перетаскивание со вставкой после объекта
Constant CursorEye | 160 | Глаз (настройка видимости)
Constant CursorLock | 161 | Блокировка (замок закрытый)
Constant CursorUnlock | 162 | Разблокировка (замок открытый)
Constant CursorNoneLarge | 163 | Запрет (большой знак запрета)
Constant CursorNoneSmall | 164 | Запрет (маленький знак запрета)
Constant CursorAccept | 165 | Стрелка с большой галочкой принятия
Constant CursorSelectCheck | 166 | Стрелка с маленькой галочкой принятия в квадрате
Constant CursorText | 167 | Стрелка с символом "A" (для режима рисования надписей)
Constant CursorPoint | 170 | Стрелка с точкой
Constant CursorMultipoint | 171 | Стрелка с мультиточкой
Constant CursorLine | 172 | Стрелка с отрезком
Constant CursorPolyline | 173 | Стрелка с ломаной
Constant CursorCircle | 174 | Стрелка с окружностью
Constant CursorFillCircle | 175 | Стрелка с кругом
Constant CursorEllipse | 176 | Стрелка с эллипсом
Constant CursorFillEllipse | 177 | Стрелка с заполненным эллипсом
Constant CursorPolygon | 178 | Стрелка с полигоном
Constant CursorFillPolygon | 179 | Стрелка с заполненным полигоном
Constant CursorRectangle | 180 | Стрелка с прямоугольгиком
Constant CursorFillRectangle | 181 | Стрелка с заполненным прямоугольгиком
Constant CursorResizeVertical | 182 | Изменение размера по вертикали
Constant CursorResizeHorizontal | 183 | Изменение размера по горизонтали
Constant CursorResizeDiagonalRightUp | 184 | Изменение размера по диагонали (/)
Constant CursorResizeDiagonalRightDown | 185 | Изменение размера по диагонали ()
Constant CursorRotateSimple | 186 | Вращение (стрелки по кругу)
Constant CursorRotateBottom | 187 | Вращение прямоугольника (стрелки для области снизу)
Constant CursorRotateTop | 188 | Вращение прямоугольника (стрелки для области сверху)
Constant CursorRotateLeft | 189 | Вращение прямоугольника (стрелки для области слева)
Constant CursorRotateLeftTop | 190 | Вращение прямоугольника (стрелки для области слева-сверху)
Constant CursorRotateLeftBottom | 191 | Вращение прямоугольника (стрелки для области слева-снизу)
Constant CursorRotateRight | 192 | Вращение прямоугольника (стрелки для области справа)
Constant CursorRotateRightTop | 193 | Вращение прямоугольника (стрелки для области справа-сверху)
Constant CursorRotateRightBottom | 194 | Вращение прямоугольника (стрелки для области справа-снизу)
Constant CursorPaint | 195 | Раскраска
Constant CursorPen | 196 | Карандаш
Constant CursorAirPen | 197 | Пульверизатор
Constant CursorDropper | 198 | Пипетка (выбор цвета)
Constant CursorBrush | 199 | Кисть
Constant CursorEraser | 200 | Ластик
Constant CursorMagic | 201 | Волшебная палочка
Constant CursorFingerTips | 202 | Кончики пальцев
Constant CursorScissors | 203 | Ножницы
Constant CursorSmudge | 204 | Размазывание пальцем
Constant CursorStamp | 205 | Штапм
Constant CursorClipArea | 208 | Изменение всей области отсечения слоя
Constant CursorClipNodes | 209 | Изменение узлов области отсечения слоя
Constant CursorClipNodesMove | 210 | Изменение узлов области отсечения слоя (захват точки настройки)
Constant CursorClipNodesMoving | 211 | Изменение узлов области отсечения слоя (перемещение точки настройки)
Constant CursorClipCircle | 212 | Ввод области отсечения в виде окружности
Constant CursorClipCircleMinus | 213 | Ввод области отсечения в виде окружности (вычитание)
Constant CursorClipCirclePlus | 214 | Ввод области отсечения в виде окружности (добавление)
Constant CursorClipCircleXor | 215 | Ввод области отсечения в виде окружности (инвертирование)
Constant CursorClipEllipse | 216 | Ввод области отсечения в виде эллипса
Constant CursorClipEllipseMinus | 217 | Ввод области отсечения в виде эллипса (вычитание)
Constant CursorClipEllipsePlus | 218 | Ввод области отсечения в виде эллипса (добавление)
Constant CursorClipEllipseXor | 219 | Ввод области отсечения в виде эллипса (инвертирование)
Constant CursorClipRect | 220 | Ввод области отсечения в виде прямоугольника
Constant CursorClipRectMinus | 221 | Ввод области отсечения в виде прямоугольника (вычитание)
Constant CursorClipRectPlus | 222 | Ввод области отсечения в виде прямоугольника (добавление)
Constant CursorClipRectXor | 223 | Ввод области отсечения в виде прямоугольника (инвертирование)
Constant CursorClipPolygon | 224 | Ввод области отсечения в виде многоугольника
Constant CursorClipPolygonMinus | 225 | Ввод области отсечения в виде многоугольника (вычитание)
Constant CursorClipPolygonPlus | 226 | Ввод области отсечения в виде многоугольника (добавление)
Constant CursorClipPolygonXor | 227 | Ввод области отсечения в виде многоугольника (инвертирование)
Constant CursorResize | 230 | Изменение размера
Constant CursorShear | 231 | Изменение наклона объекта
Constant CursorShearTopLeft | 232 | Изменение наклона объекта в левом верхнем углу
Constant CursorShearTopRight | 233 | Изменение наклона объекта в правом верхнем углу
Constant CursorShearBottomLeft | 234 | Изменение наклона объекта в левом нижнем углу
Constant CursorShearBottomRight | 235 | Изменение наклона объекта в правом нижнем углу
Constant CursorShearLeftUp | 236 | Изменение наклона объекта в левом верхнем углу
Constant CursorShearLeftDown | 237 | Изменение наклона объекта в левом нижнем углу
Constant CursorShearRightUp | 238 | Изменение наклона объекта в правом верхнем углу
Constant CursorShearRightDown | 239 | Изменение наклона объекта в правом нижнем углу
Constant CursorAim | 240 | Прицел
Constant CursorAimMinus | 241 | Прицел (вычитание)
Constant CursorAimPlus | 242 | Прицел (добавление)
Constant CursorAimXor | 243 | Прицел (инвертирование)
Constant CursorAimCheck | 244 | Прицел (галочка принятия)
Constant CursorAimAccept | 245 | Прицел (завершение)
Constant CursorAimDelete | 246 | Прицел (удаление)
Constant CursorCrossing | 250 | Большое перекрестие
Constant CursorNumber1 | 291 | Стрелка с цифрой 1
Constant CursorNumber2 | 292 | Стрелка с цифрой 2
Constant CursorNumber3 | 293 | Стрелка с цифрой 3
Constant CursorNumber4 | 294 | Стрелка с цифрой 4
Constant CursorNumber5 | 295 | Стрелка с цифрой 5
Constant CursorNumber6 | 296 | Стрелка с цифрой 6
Constant CursorNumber7 | 297 | Стрелка с цифрой 7
Constant CursorNumber8 | 298 | Стрелка с цифрой 8
Constant CursorNumber9 | 299 | Стрелка с цифрой 9
Constant CursorSelectingInside | 300 | Выделение фигур, попадающих в прямоугольник
Constant CursorSelectingInsidePlus | 301 | Добавления фигур, попадающих в прямоугольник, в список выделенных
Constant CursorSelectingInsideMinus | 302 | Удаление фигур, попадающих в прямоугольник, из списка выделенных
Constant CursorSelectingTouch | 303 | Выделение фигур, попадающих в или касающихся прямоугольника
Constant CursorSelectingTouchPlus | 304 | Добавление фигур, попадающих в или касающихся прямоугольника, в список выделенных
Constant CursorSelectingTouchMinus | 305 | Удаление фигур, попадающих в или касающихся прямоугольника, из списка выделенных
Constant CursorSelectingAdjustPoint | 306 | Выделение управляющих точек
Constant CursorSelectingAdjustPointPlus | 307 | Добавления управляющих точек в список выделенных
Constant CursorSelectingAdjustPointMinus | 308 | Удаление управляющих точек из списка выделенных
Constant CursorCustom0 | 1000 | Курсор пользователя 0 (по умолчанию пуст)
Constant CursorCustom1 | 1001 | Курсор пользователя 1 (по умолчанию пуст)
Constant CursorCustom2 | 1002 | Курсор пользователя 2 (по умолчанию пуст)
Constant CursorCustom3 | 1003 | Курсор пользователя 3 (по умолчанию пуст)
Constant CursorCustom4 | 1004 | Курсор пользователя 4 (по умолчанию пуст)
Constant CursorCustom5 | 1005 | Курсор пользователя 5 (по умолчанию пуст)
Constant CursorCustom6 | 1006 | Курсор пользователя 6 (по умолчанию пуст)
Constant CursorCustom7 | 1007 | Курсор пользователя 7 (по умолчанию пуст)
Constant CursorCustom8 | 1008 | Курсор пользователя 8 (по умолчанию пуст)
Constant CursorCustom9 | 1009 | Курсор пользователя 9 (по умолчанию пуст)

Где используются

Класс | Член класса
Class Application | Method RegisterCursor (метод)
Class CustomContainer | Property ForceCursor (свойство)
Class CustomMode | Property Cursor (свойство)
Class ICommonApplication | Method RegisterCursor (метод)
Class IContainerModeEvents | Method GetCursor (метод)
Class Project | Method SetCursor (метод)
Class VectorContainer | Property ForceCursor (свойство)

Смотри также

Group Пользовательский интерфейс


Константы CurveKindConstants

Тип кривой (линия или сплайн)

Константы

Константа | Значение | Описание
Constant CurveKindLine | 0 | Прямая
Constant CurveKindSimple | 1 | Простейший сплайн
Constant CurveKindChordA | 2 | Сплайн с нормированием производной по длине хорды вида А
Constant CurveKindChordB | 3 | Сплайн с нормированием производной по длине хорды вида Б
Constant CurveKindChordV | 4 | Сплайн с нормированием производной по длине хорды вида В
Constant CurveKindNormalA | 5 | Сплайн с нормированием производной на сегменте вида А
Constant CurveKindNormalB | 6 | Сплайн с нормированием производной на сегменте вида Б
Constant CurveKindNormalV | 7 | Сплайн с нормированием производной на сегменте вида В
Constant CurveKindBSpline | 8 | Сглаживающий кубический B-сплайн

Где используются

Класс | Член класса
Class CADTriangulation | Method BuildIsoline (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод)
Class Triangulation | Method BuildIsoline (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод)

Смотри также

Group Визуализаторы данных


Константы DatasetLinkAddConstants

Режимы добавления записей при связи наборов данных

Константы

Константа | Значение | Описание
Constant DatasetLinkAddNone | 0 | Записи в подчиненный набор данных не добавляются. Все поля при этом "только для чтения".
Constant DatasetLinkAddMaster | 1 | При записи в подчиненный набор поле MasterField копируется в DetailField. Если оно пусто, то сообщение об ошибке.
Constant DatasetLinkAddAutoinc | 2 | Аналогично предыдущему, но если поле MasterField пусто, то делается в DetailDataset автоинкремент.

Где используются

Класс | Член класса
Class DatasetLink | Property AddMode (свойство)

Смотри также

Group Интерфейсы с базой данных


Константы DatasetLinkingStatusConstants

Статус подключения к набору данных

Константы

Константа | Значение | Описание
Constant DatasetLinkingStatusNone | 0 | Подключение не производилось
Constant DatasetLinkingStatusError | 1 | Ошибка подключения
Constant DatasetLinkingStatusNoLink | 2 | Связь по полям не установлена
Constant DatasetLinkingStatusLinked | 3 | Связь по полям установлена
Constant DatasetLinkingStatusNew | 4 | Добавление новой записи

Где используются

Класс | Член класса
Class LayerDataset | Property FieldStatus (свойство)

Смотри также

Group Базы данных


Константы DrawPointCaption

Варианты отображения подписи точек в плане

Константы

Константа | Значение | Описание
Constant DrawPointCaptionDefault | 0 | Подписывать точку так, как задано в настройках всех точек
Constant DrawPointCaptionNone | 1 | Не подписывать точку
Constant DrawPointCaptionOnlyZ | 2 | Подписывать только Z-отметку
Constant DrawPointCaptionOnlyName | 3 | Подписывать только имя точки
Constant DrawPointCaptionAll | 4 | Подписывать Z-отметку и имя точки

Где используются

Класс | Член класса
Class LayerPoint | Property DrawCaption (свойство)
Class LayerPoints | Property ShowCaptions (свойство)

Смотри также

Group Поверхности


Константы EdgeCurvatureConstants

Вид граничных условий при отрисовке сплайнами

Константы

Константа | Значение | Описание
Constant EdgeCurvatureNull | 0 | Нулевая производная на конце
Constant EdgeCurvatureConstant | 1 | Постоянная кривизна на последнем отрезке

Где используются

Класс | Член класса
Class CADTriangulation | Method BuildIsoline (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод)
Class Triangulation | Method BuildIsoline (метод) Method BuildIsolines (метод) Method BuildIsoslopes (метод)

Смотри также

Group Визуализаторы данных


Константы EditPhaseConstants

Фаза режима редактирования контейнера

Константы

Константа | Значение | Описание
Constant EditPhaseSelect | 0 | Элементы не выбраны, идёт их выделение
Constant EditPhaseGroup | 1 | Выбран(ы) элемент(ы), выделены их BoundsRect(s)
Constant EditPhaseAdjust | 2 | Выбран один элемент, выделены его точки настройки

Где используются

Класс | Член класса
Class VectorContainer | Property EditPhase (свойство)

Смотри также

Group Контейнеры изображений


Константы FieldConstants

Типы полей наборов данных

Константы

Константа | Значение | Описание
Constant FieldUnknown | 0 | Тип неизвестен
Constant FieldString | 1 | Строка
Constant FieldSmallint | 2 | Целое знаковое 16 бит
Constant FieldInteger | 3 | Целое знаковое 32 бита
Constant FieldWord | 4 | Целое беззнаковое 16 бит
Constant FieldBoolean | 5 | Логическое
Constant FieldFloat | 6 | Вещественное
Constant FieldCurrency | 7 | Валюта
Constant FieldBCD | 8 | BCD
Constant FieldDate | 9 | Дата
Constant FieldTime | 10 | Время
Constant FieldDateTime | 11 | Дата и время
Constant FieldBytes | 12 | Поток байтов
Constant FieldVarBytes | 13 | Поток байтов переменной длины
Constant FieldAutoInc | 14 | Автоинкрементное
Constant FieldBlob | 15 | BLOB
Constant FieldMemo | 16 | Текстовое большое
Constant FieldGraphic | 17 | Графическое
Constant FieldFmtMemo | 18 | Текстовое большое форматированное
Constant FieldParadoxOle | 19 | Объект OLE в формате Paradox
Constant FieldDBaseOle | 20 | Объект OLE в формате DBase
Constant FieldTypedBinary | 21 | BLOB типизированный
Constant FieldCursor | 22 | Курсор
Constant FieldFixedChar | 23 | Строковое фиксированное
Constant FieldWideString | 24 | Строка Unicode
Constant FieldLargeint | 25 | Целое знаковое 64-битовое
Constant FieldADT | 26 | Абстрактный тип данных
Constant FieldArray | 27 | Массив
Constant FieldReference | 28 | Ссылочное поле
Constant FieldDataSet | 29 | Набор данных
Constant FieldOraBlob | 30 | BLOB поле в формате Oracle 8
Constant FieldOraClob | 31 | CLOB поле в формате Oracle 8
Constant FieldVariant | 32 | Данные переменного типа
Constant FieldInterface | 33 | Ссылка на интерфейс IUnknown
Constant FieldIDispatch | 34 | Ссылка на интерфейс IDispatch
Constant FieldGuid | 35 | GUID
Constant FieldTimeStamp | 36 | Дата и время (при обращении через dbExpress)
Constant FieldFMTBcd | 37 | Расширенное поле BCD, не умещающееся в обычное поле BCD

Где используются

Класс | Член класса
Class CalcField | Property DataType (свойство)
Class Field | Property DataType (свойство)
Class FigureAttr | Property FieldType (свойство)

Смотри также

Group Базы данных


Константы FieldTraverseConstants

Типы теодолитных ходов

Константы

Константа | Значение | Описание
Constant FieldTraverseOpened | 0 | Разомкнутый ход
Constant FieldTraverseLocked | 1 | Замкнутый ход
Constant FieldTraverseClosed | 2 | Сомкнутый ход
Constant FieldTraverseWithoutAdjoining | 3 | Ход без примычных углов
Constant FieldTraverseHanging | 4 | Висячий ход

Где используются

Класс | Член класса
Class FieldTraverse | Property FieldTraverseType (свойство)

Смотри также

Group Геодезия


Константы FieldViewConstants

Представление полей таблицы в диалогах, способ их ввода

Константы

Константа | Значение | Описание
Constant FieldViewString | 0 | С клавиатуры в строке ввода
Constant FieldViewInteger | 1 | Ввод целых чисел
Constant FieldViewFloat | 2 | Ввод вещественных чисел
Constant FieldViewDateTime | 3 | Ввод даты и времени
Constant FieldViewComboBox | 4 | Из комбинированного списка
Constant FieldViewListBox | 5 | Выбор из списка
Constant FieldViewRadioGroup | 6 | Радио-кнопки
Constant FieldViewCheck | 7 | Переключатель
Constant FieldViewLookupCombo | 8 | По справочнику (комбосписок)
Constant FieldViewLookupList | 9 | По справочнику (список)
Constant FieldViewMemo | 10 | Многострочный текст
Constant FieldViewRichEdit | 11 | Текст RTF
Constant FieldViewImage | 12 | Графическое изображение
Constant FieldViewBinary | 13 | Двоичный массив
Constant FieldViewLink | 15 | Связь с другой таблицей

Где используются

Класс | Член класса
Class BrowserItem | Property FieldView (свойство)

Смотри также

Group Базы данных


Константы FontStyleConstants

Стиль шрифта

Константы

Константа | Значение | Описание
Constant FontStyleBold | 1 | Жирный шрифт
Constant FontStyleItalic | 2 | Наклонный шрифт
Constant FontStyleUnderline | 4 | Подчеркнутый шрифт
Constant FontStyleStrikeOut | 8 | Зачеркнутый шрифт

Где используются

Класс | Член класса
Class ContainerSurface | Method FontSelect (метод)
Class CustomSurface | Method FontSelect (метод)
Class ModelSurface | Method FontSelect (метод)
Class TopoFontStyle | Property FontStyle (свойство) Method SetFontParameters (метод)
Class TopoTextStyle | Property FontStyle (свойство) Method SetFontParameters (метод)

Смотри также

Group Рисование изображений


Константы FrameFormatConstants

Формат кадра видеоряда.

Константы

Константа | Значение | Описание
Constant FrameFormatBMP | 0 | Формат BMP
Constant FrameFormatJPG | 1 | Формат JPeg

Где используются

Класс | Член класса
Class VideoRowWriter | Method AddFrame (метод) Method AddFrameStream (метод)


Константы IntersectionConstants

Типы дополнительных точек (засечек)

Константы

Константа | Значение | Описание
Constant IntersectionKnownPoint | 0 | По известным координатам
Constant IntersectionMeasure | 1 | По промерам
Constant IntersectionBy3Point | 2 | По трем точкам
Constant IntersectionPolar | 3 | Полярная засечка
Constant IntersectionLinear | 4 | Линейная засечка
Constant IntersectionAngular | 5 | Прямая угловая засечка
Constant IntersectionRange | 6 | Створная засечка
Constant IntersectionParallel | 7 | Параллельная линия
Constant IntersectionPerpendicularToRange | 8 | Перпендикуляр в створ
Constant IntersectionPerpendicularFromRange | 9 | Перпендикуляр от створа
Constant IntersectionCrossing | 10 | Пересечение двух отрезков
Constant IntersectionInverseAngular | 11 | Обратная угловая засечка

Где используются

Класс | Член класса
Class AdditionalPoint | Property AdditionalPointType (свойство)
Class By3PointAdditionalPoint | Property AdditionalPointType (свойство)
Class FieldTraverse | Method AddAdditionalPoint (метод)
Class IntersectionAdditionalPoint | Property AdditionalPointType (свойство)
Class KnownAdditionalPoint | Property AdditionalPointType (свойство)
Class MeasureAdditionalPoint | Property AdditionalPointType (свойство)
Class RangeAdditionalPoint | Property AdditionalPointType (свойство)

Смотри также

Group Геодезия


Константы LayerDatasetModeConstants

Тип множества элементов в наборе данных слоя

Константы

Константа | Значение | Описание
Constant LayerDatasetModeLayerItems | 0 | Все фигуры слоя (поддерживается всегда актуальным)
Constant LayerDatasetModeSubItems | 1 | Только подмножество (неактуальные автоматически удаляются)
Constant LayerDatasetModeAloneShape | 2 | Одна фигура (если неактуальная, то удалаяется)
Constant LayerDatasetModeStructure | 3 | Без фигур

Где используются

Класс | Член класса
Class LayerDataset | Property Mode (свойство)
Class VectorLayer | Method GetLayerDataset (метод)

Смотри также

Group Базы данных


Константы LayerRequestConstants

Способ выполнения запроса LayerRequest

Константы

Константа | Значение | Описание
Constant LayerRequestNewSet | 0 | Новый набор
Constant LayerRequestFromSet | 1 | Из текущего набора
Constant LayerRequestAppend | 2 | Добавить к набору
Constant LayerRequestRemove | 3 | Удалить из набора

Где используются

Класс | Член класса
Class LayerRequest | Property Style (свойство)

Смотри также

Group Карты


Константы LinkedDatabaseStatusConstants

Статус подключения к БД

Константы

Константа | Значение | Описание
Constant LinkedDatabaseStatusDisconnected | 0 | Соединение не установлено
Constant LinkedDatabaseStatusConnected | 1 | Соединение установлено
Constant LinkedDatabaseStatusError | 2 | Ошибка установления связи

Где используются

Класс | Член класса
Class LinkedADODatabase | Property Status (свойство)
Class LinkedBDEDatabase | Property Status (свойство)
Class LinkedCorbaDatabase | Property Status (свойство)
Class LinkedDatabase | Property Status (свойство)
Class LinkedDCOMDatabase | Property Status (свойство)
Class LinkedDispatchDatabase | Property Status (свойство)
Class LinkedIBDatabase | Property Status (свойство)
Class LinkedOLEnterpriseDatabase | Property Status (свойство)
Class LinkedRDSDatabase | Property Status (свойство)
Class LinkedRemoteDatabase | Property Status (свойство)
Class LinkedSocketDatabase | Property Status (свойство)
Class LinkedUniDatabase | Property Status (свойство)
Class LinkedWebDatabase | Property Status (свойство)

Смотри также

Group Интерфейсы с базой данных


Константы LinkedDatasetStatusConstants

Результат последнего открытия набора данных

Константы

Константа | Значение | Описание
Constant LinkedDatasetStatusActive | 0 | Набор данных открыт
Constant LinkedDatasetStatusInactive | 1 | Набор данных не открывался
Constant LinkedDatasetStatusDatabaseError | 2 | Ошибка установления содинения с базой данных
Constant LinkedDatasetStatusDatasetError | 3 | Ошибка открытия набора данных

Где используются

Класс | Член класса
Class LinkedADOCustomDataset | Property Status (свойство)
Class LinkedADODataset | Property Status (свойство)
Class LinkedADOQuery | Property Status (свойство)
Class LinkedADOStoredProc | Property Status (свойство)
Class LinkedADOTable | Property Status (свойство)
Class LinkedBDEDataset | Property Status (свойство)
Class LinkedBDEQuery | Property Status (свойство)
Class LinkedBDEStoredProc | Property Status (свойство)
Class LinkedBDETable | Property Status (свойство)
Class LinkedClientDataset | Property Status (свойство)
Class LinkedDataset | Property Status (свойство)
Class LinkedIBDataset | Property Status (свойство)
Class LinkedIBQuery | Property Status (свойство)
Class LinkedIBStoredProc | Property Status (свойство)
Class LinkedIBTable | Property Status (свойство)
Class LinkedUniDataset | Property Status (свойство)
Class LinkedUniQuery | Property Status (свойство)
Class LinkedUniStoredProc | Property Status (свойство)
Class LinkedUniTable | Property Status (свойство)

Смотри также

Group Интерфейсы с базой данных


Константы LogPrecisionConstants

Уровень детализации при журналировани

Константы

Константа | Значение | Описание
Constant LogPrecisionNone | 0 | Журнал детализации не вести
Constant LogPrecisionMain | 1 | Журналировать только главные сообщения
Constant LogPrecisionCommon | 2 | Журналировать основные сообщения
Constant LogPrecisionDetails | 3 | Журналировать все сообщения

Где используются

Класс | Член класса
Class Application | Method Log (метод)
Class ApplicationOptions | Property LogPrecision (свойство)
Class ICommonApplication | Method Log (метод)

Смотри также

Group Приложение


Константы LogPriorityConstants

Приоритеты событий, записываемых в файл журнала

Константы

Константа | Значение | Описание
Constant LogPriorityMain | 0 | Важное событие. Пишется в журнал, даже если установлена низкий уровень детализации событий
Constant LogPriorityCommon | 1 | Событие средней значимости. Пишется в журнал, если установлена низкий или средний уровень детализации событий
Constant LogPriorityDetails | 2 | Событие низкой значимости. Пишется в журнал, только если установлена высокий уровень детализации событий

Смотри также

Group Внешние модули


Константы MouseButtonConstants

Тип кнопки мышки

Константы

Константа | Значение | Описание
Constant MouseButtonLeft | 0 | Левая кнопка
Constant MouseButtonRight | 1 | Правая кнопка
Constant MouseButtonMiddle | 2 | Средняя кнопка
Constant MouseButtonNone | -1 | Кнопка не задана

Где используются

Класс | Член класса
Class IContainerModeEvents | Method MouseDown (метод) Method MouseUp (метод)

Смотри также

Group Пользовательский интерфейс


Константы NotchKindConstants

Тип засечек на концах размерной линии

Константы

Константа | Значение | Описание
Constant NotchKindNone | 0 | Нет засечек
Constant NotchKindArrowShortSolid | 1 | Стрелка короткая (сплошная)
Constant NotchKindArrowShortSemi | 2 | Стрелка короткая (полусплошная)
Constant NotchKindArrowShortLines | 3 | Стрелка короткая (только линии)
Constant NotchKindArrowNormalSolid | 4 | Стрелка нормальная (сплошная)
Constant NotchKindArrowNormalSemi | 5 | Стрелка нормальная (полусплошная)
Constant NotchKindArrowNormalLines | 6 | Стрелка нормальная (только линии)
Constant NotchKindArrowLongSolid | 7 | Стрелка длинная (сплошная)
Constant NotchKindArrowLongSemi | 8 | Стрелка длинная (полусплошная)
Constant NotchKindArrowLongLines | 9 | Стрелка длинная (только линии)
Constant NotchKindCircleSolid | 10 | Кружок (сплошной)
Constant NotchKindCircleEmpty | 11 | Кружок (прозрачный)
Constant NotchKindRhombSolid | 12 | Ромбик (сплошной)
Constant NotchKindRhombEmpty | 13 | Ромбик (прозрачный)
Constant NotchKindSlashForward | 14 | Штрих прямой
Constant NotchKindSlashBackward | 15 | Штрих обратный

Где используются

Класс | Член класса
Class TopoArrowStyle | Property NotchKind (свойство)
Class TopoDimensionStyle | Property NotchKind (свойство)

Смотри также

Group Фигуры


Константы PanDirectionConstants

Направление панорамирования

Константы

Константа | Значение | Описание
Constant PanDirectionUp | 0 | Вверх
Constant PanDirectionUpRight | 1 | Вверх-вправо
Constant PanDirectionRight | 2 | Вправо
Constant PanDirectionDownRight | 3 | Вниз-вправо
Constant PanDirectionDown | 4 | Вниз
Constant PanDirectionDownLeft | 5 | Вниз-влево
Constant PanDirectionLeft | 6 | Влево
Constant PanDirectionUpLeft | 7 | Вверх-влево
Constant PanDirectionNone | 8 | Без перемещения

Где используются

Класс | Член класса
Class CustomContainer | Method PanTo (метод)
Class VectorContainer | Method PanTo (метод)

Смотри также

Group Контейнеры изображений


Константы PasteFromClipboardConstants

Режим вставки фигур из буфера обмена

Константы

Константа | Значение | Описание
Constant PasteFromClipboardCoordinates | 0 | Вставить точно в координаты скопированного блока
Constant PasteFromClipboardCenterView | 1 | Вставить в центр видимой области
Constant PasteFromClipboardUserMoving | 2 | Вставить и позволить сразу же интерактивно передвинуть блок мышью

Где используются

Класс | Член класса
Class VectorContainer | Method PasteFromClipboard (метод)

Смотри также

Group Карты


Константы PenStyleConstants

Способ рисования линий

Константы

Константа | Значение | Описание
Constant PenStyleSolid | 0 | Перо сплошное
Constant PenStyleDash | 1 | Перо штриховое
Constant PenStyleDot | 2 | Перо пунктирное
Constant PenStyleDashDot | 3 | Перо штрих-пунктирное
Constant PenStyleDashDotDot | 4 | Перо штрих-штрих-пунктирное
Constant PenStyleClear | 5 | Перо пустое
Constant PenStyleInsideFrame | 6 | Перо сплошное внутри контура

Где используются

Класс | Член класса
Class ContainerSurface | Method PenSelect (метод)
Class CustomSurface | Method PenSelect (метод)
Class ModelSurface | Method PenSelect (метод)
Class PaintCanvas | Property PenStyle (свойство)

Смотри также

Group Рисование изображений


Константы PluginKindConstants

Тип дополнительного модуля

Константы

Константа | Значение | Описание
Constant PluginKindFiled | 0 | Модуль, реализованный в виде отдельного файла
Constant PluginKindProcedured | 1 | Модуль, реализованный в виде набора процедур
Constant PluginKindActiveX | 2 | Модуль, реализованный в виде ActiveX-обработчика событий

Где используются

Класс | Член класса
Class Plugin | Property Kind (свойство)

Смотри также

Group Приложение


Константы PluginOptionConstants

Различные опции дополнительного модуля

Константы

Константа | Значение | Описание
Constant PluginOptionNone | 0 | Никаких опций
Constant PluginOptionDefaultEnabled | 1 | Разрешен ли модуль по умолчанию (если модуль лицензируется, то лучше, чтобы эта опция не была включена)
Constant PluginOptionRequiresRestart | 2 | Признак того, что после включения или выключения модуля требуется перезапуск системы, чтобы изменения начали действовать

Где используются

Класс | Член класса
Class IPluginEvents | Method Info (метод)

Смотри также

Group Приложение


Константы ProfilePointTypeConstants

Тип отрезка при генерации профиля

Константы

Константа | Значение | Описание
Constant ProfilePointTypeInside | 0 | Точка находится строго внутри треугольника (параметр Index не определён)
Constant ProfilePointTypeNode | 1 | Точка совпадает строго с узлом треугольника (Index = номер узла в треугольнике)
Constant ProfilePointTypeRib | 2 | Точка находится строго на ребре треугольника, но не на узле (Index = номер ребра в треугольнике)

Где используются

Класс | Член класса
Class IEnumerateProfilePoints | Method Register (метод)

Смотри также

Group Триангуляция


Константы ProfileSegmentTypeConstants

Тип отрезка при генерации профиля

Константы

Константа | Значение | Описание
Constant ProfileSegmentTypeRib | 0 | Отрезок проходит строго по ребру треугольника
Constant ProfileSegmentTypeRibToRib | 1 | Отрезок от ребра до ребра
Constant ProfileSegmentTypeInsideToRib | 2 | Отрезок от внутренности до ребра
Constant ProfileSegmentTypeRibToInside | 3 | Отрезок от ребра до внутренности
Constant ProfileSegmentTypeInside | 4 | Отрезок находится целиком внутри треугольника

Где используются

Класс | Член класса
Class IEnumerateProfile | Method Register (метод)

Смотри также

Group Триангуляция


Константы PropertyStreamConstants

Типы элементов PropertyStream'a

Константы

Константа | Значение | Описание
Constant PropertyStreamNotFound | 0 | Элемент не найден (не существует)
Constant PropertyStreamDirectory | 3 | Директория
Constant PropertyStreamBinary | 4 | Абстрактные бинарные данные
Constant PropertyStreamInteger | 5 | Целое число (32 бита)
Constant PropertyStreamDouble | 6 | Вещественное число
Constant PropertyStreamString | 7 | Строка
Constant PropertyStreamImage | 8 | Картинка (Delphi - TGraphic)
Constant PropertyStreamBoolean | 9 | Значение типа Boolean (True или False)
Constant PropertyStreamDate | 10 | Дата
Constant PropertyStreamInt64 | 11 | 64-битное целое число
Constant PropertyStreamIPicture | 12 | IPictire
Constant PropertyStreamStringObsolete | 13 | Строка (оставлена для совместимости со старой версией)
Constant PropertyStreamGUID | 14 | Значение типа GUID (128 бит)
Constant PropertyStreamXY | 15 | Пара вещественных чисел (обычно координаты)
Constant PropertyStreamXYZ | 16 | Тройка вещественных чисел (обычно координаты)
Constant PropertyStreamXYZM | 17 | Четвёрка вещественных чисел (обычно координаты)
Constant PropertyStreamIdXY | 18 | Пара вещественных чисел (обычно координаты) с целочисленным идентификатором
Constant PropertyStreamIdXYZ | 19 | Тройка вещественных чисел (обычно координаты) с целочисленным идентификатором
Constant PropertyStreamIdXYZM | 20 | Четвёрка вещественных чисел (обычно координаты) с целочисленным идентификатором
Constant PropertyStreamXYint | 21 | Пара целых чисел (обычно координаты)
Constant PropertyStreamWideString | 22 | Строка широкая (Unicode)

Где используются

Класс | Член класса
Class PropertyStream | Method GetItemInfo (метод)

Смотри также

Group Внешние модули


Константы RepresentLineConstants

Комбинацией данных флагов определяется, какие данные будут возвращены при представлении ломаной

Константы

Константа | Значение | Описание
Constant RepresentLinePicket | 1 | Возвращать пикетажное положение точек ломаной
Constant RepresentLineXY | 2 | Возвращать плановое положение точек ломаной (пара координат: X, Y)
Constant RepresentLineZ | 4 | Возвращать Z-отметку точек ломаной
Constant RepresentLinePicketXY | 3 | Возвращать пикетажное и плановое положение точек ломаной (тройка координат: PK, X, Y)
Constant RepresentLineXYZ | 6 | Возвращать плановое и высотное положение точек ломаной (тройка координат: X, Y, Z)
Constant RepresentLinePicketXYZ | 7 | Возвращать пикетажное, плановое и высотное положение точек ломаной (четвёрка координат: PK, X, Y, Z)

Где используются

Класс | Член класса
Class Route | Method RepresentCodedLineAsPolyline (метод)

Смотри также

Group Трассы


Константы RequestVariableConstants

Способ ввода значений переменных, участвующих в запросе к карте

Константы

Константа | Значение | Описание
Constant RequestVariableEditBox | 0 | Строка ввода
Constant RequestVariableListBox | 1 | Список
Constant RequestVariableComboEdit | 2 | Строка ввода с комбосписком
Constant RequestVariableComboList | 3 | Комбосписок
Constant RequestVariableLookupList | 4 | Список из другой таблицы
Constant RequestVariableLookupCombo | 5 | Комбосписок из другой таблицы

Где используются

Класс | Член класса
Class RequestVariable | Property Style (свойство)

Смотри также

Group Карты


Константы RouteModelModifiedConstants

Комбинацией данных флагов определяется, что изменилось в элементах трассы

Константы

Константа | Значение | Описание
Constant RouteModelModifiedZ | 1 | Изменилась Z-отметка оси трассы
Constant RouteModelModifiedCrossection | 2 | Изменилась модель поперечного профиля
Constant RouteModelModifiedProjectSurface | 3 | Изменилась форма проектной поверхности

Где используются

Класс | Член класса
Class IRoutesEvents | Method DigitalModelChanged (метод)
Class Routes | Event DigitalModelChanged (событие)

Смотри также

Group Трассы


Константы SelectModeConstants

Способы выделения объектов

Константы

Константа | Значение | Описание
Constant SelectModeInsideRect | 0 | Строго внутри прямоугольника
Constant SelectModeByRect | 1 | Внутри или касаясь прямоугольника
Constant SelectModeInsidePolygon | 2 | Строго внутри полигона
Constant SelectModeByPolygon | 3 | Внутри или касаясь полигона
Constant SelectModeInsideCircle | 4 | Строго внутри окружности
Constant SelectModeByCircle | 5 | Внутри или касаясь окружности

Смотри также

Group Контейнеры изображений


Константы SelectsConstants

Типы селекций, реализованных в системе (используются дополнительными модулями)

Константы

Константа | Значение | Описание
Constant SelectsPreSelected | 0 | Предварительное выделение (обычно фиолетового цвета), рисуется поверх обычного выделения
Constant SelectsSelected | 1 | Обычное выделение (обычно желтого цвета)
Constant SelectsThinDot | 2 | Тонкая красная пунктирная линия

Где используются

Класс | Член класса
Class Project | Method SelectsAddCircle (метод) Method SelectsAddLine (метод) Method SelectsAddPoint (метод)

Смотри также

Group Внешние модули


Константы ServerTypeConstants

Тип сервера данных и, соответственно, диалекта языка SQL

Константы

Константа | Значение | Описание
Constant ServerTypeMSSQL | 0 | Microsoft SQL Server (servers: SQL Server 2008, SQL Server 2005 (including Compact and Express editions), SQL Server 2000, SQL Server 7, and MSDE; clients: SQL OLE DB and SQL Native Client)
Constant ServerTypeOracle | 1 | Oracle (servers: 11g, 10g, 9i, 8i, 8.0, 7.3, 10g Express, 8i Personal, Lite editions; x86 clients: 11g, 10g, 9i, 8i, 8.0, and 7.3.)
Constant ServerTypePostgreSQL | 2 | PostgreSQL (all versions since 7.1 up to 9.0)
Constant ServerTypeMySQL | 3 | MySQL (servers: 5.1, 5.0, 4.1, 4.0, and 3.23; embedded servers: 5.1, 4.1, and 4.0; clients: Direct mode, 5.1, 5.0, 4.1, 4.0, and 3.23)
Constant ServerTypeInterBase | 4 | InterBase (versions 5.x and higher; Firebird: versions 2.x, 1.x; Yaffil)
Constant ServerTypeDB2 | 5 | DB2 (all versions since 8.0 and higher)
Constant ServerTypeSQLite | 6 | SQLite (version 3)
Constant ServerTypeSybase | 7 | Sybase (Sybase Adaptive Server Enterprise servers and clients: 11.0 and higher)

Где используются

Класс | Член класса
Class UniConnection | Property ServerType (свойство)
Class UniConnectionParameters | Property ServerType (свойство)


Константы ShapeFieldConstants

Тип атрибута шейп-файла

Константы

Константа | Значение | Описание
Constant ShapeFieldNumeric | 0 | Числовой
Constant ShapeFieldDate | 1 | Дата
Constant ShapeFieldString | 2 | Строка
Constant ShapeFieldBoolean | 3 | Логический

Где используются

Класс | Член класса
Class ShapeField | Property FieldKind (свойство)
Class ShapeFile | Method CreateNewField (метод)

Смотри также

Group Шейп-файлы


Константы ShapeTypeConstants

Тип шейп-фигур

Константы

Константа | Значение | Описание
Constant ShapeTypeNullshape | 0 | Пустая фигура
Constant ShapeTypePoint | 1 | Точка
Constant ShapeTypePolyline | 3 | Полилиния
Constant ShapeTypePolygon | 5 | Полигон
Constant ShapeTypeMultiPoint | 8 | Мультиточка
Constant ShapeTypePointZ | 11 | Точка трёхмерная
Constant ShapeTypePolylineZ | 13 | Полилиния трёхмерная
Constant ShapeTypePolygonZ | 15 | Полигон трёхмерный
Constant ShapeTypeMultiPointZ | 18 | Мультиточка трёхмерная
Constant ShapeTypePointM | 21 | Точка с мерой
Constant ShapeTypePolylineM | 23 | Полилиния с мерой
Constant ShapeTypePolygonM | 25 | Полигон с мерой
Constant ShapeTypeMultiPointM | 28 | Мультиточка с мерой

Где используются

Класс | Член класса
Class CustomContainer | Method TrackFlatFillPolygon (метод) Method TrackFlatPolygon (метод) Method TrackFlatPolyline (метод) Method TrackFlatSegment (метод) Method TrackModelCircle (метод) Method TrackModelEllipse (метод) Method TrackModelFillCircle (метод) Method TrackModelFillEllipse (метод) Method TrackModelFillPolygon (метод) Method TrackModelFillRectangle (метод) Method TrackModelPolygon (метод) Method TrackModelPolyline (метод) Method TrackModelRectangle (метод) Method TrackModelSegment (метод)
Class ShapeFigure | Property ShapeType (свойство)
Class ShapeFile | Property ShapeType (свойство) Property SimpleType (свойство) Method ConvertToFile (метод) Method CreateNew (метод) Method CreateNewLike (метод) Method CreateNewTemporal (метод)
Class ShapeMultipart | Property ShapeType (свойство)
Class ShapeMultipoint | Property ShapeType (свойство)
Class ShapeMultipointM | Property ShapeType (свойство)
Class ShapeMultipointZ | Property ShapeType (свойство)
Class ShapePoint | Property ShapeType (свойство)
Class ShapePointM | Property ShapeType (свойство)
Class ShapePointZ | Property ShapeType (свойство)
Class ShapePolygon | Property ShapeType (свойство)
Class ShapePolygonM | Property ShapeType (свойство)
Class ShapePolygonZ | Property ShapeType (свойство)
Class ShapePolyline | Property ShapeType (свойство)
Class ShapePolylineM | Property ShapeType (свойство)
Class ShapePolylineZ | Property ShapeType (свойство)
Class VectorContainer | Method TrackFlatFillPolygon (метод) Method TrackFlatPolygon (метод) Method TrackFlatPolyline (метод) Method TrackFlatSegment (метод) Method TrackModelCircle (метод) Method TrackModelEllipse (метод) Method TrackModelFillCircle (метод) Method TrackModelFillEllipse (метод) Method TrackModelFillPolygon (метод) Method TrackModelFillRectangle (метод) Method TrackModelPolygon (метод) Method TrackModelPolyline (метод) Method TrackModelRectangle (метод) Method TrackModelSegment (метод)

Смотри также

Group Фигуры


Константы ShiftStateConstants

Состояния клавиш Ctrl, Alt, Shift, кнопок мышки, а также контроллера привязки. Данные константы могут использоваться в комбинации для задания состояния сразу нескольких клавиш клавиатуры, кнопок мышки и контроллера привязки

Константы

Константа | Значение | Описание
Constant ShiftStateShift | 1 | Данный флаг установлен только в том случае, если клавиша Shift на клавиатуре в настоящее время нажата
Constant ShiftStateAlt | 2 | Данный флаг установлен только в том случае, если клавиша Alt на клавиатуре в настоящее время нажата
Constant ShiftStateCtrl | 4 | Данный флаг установлен только в том случае, если клавиша Ctrl на клавиатуре в настоящее время нажата
Constant ShiftStateLeft | 8 | Данный флаг установлен только в том случае, если левая кнопка мышки в настоящее время нажата
Constant ShiftStateRight | 16 | Данный флаг установлен только в том случае, если правая кнопка мышки в настоящее время нажата
Constant ShiftStateMiddle | 32 | Данный флаг установлен только в том случае, если средняя кнопка мышки в настоящее время нажата
Constant ShiftStateDouble | 64 | Данный флаг установлен только в том случае, если было зафиксировано двойное нажатие кнопки мышки
Constant ShiftStateSnap | 128 | Данный флаг установлен только в том случае, если в данный момент координаты курсора изменены контроллером привязки

Где используются

Класс | Член класса
Class IContainerModeEvents | Method KeyDown (метод) Method KeyUp (метод) Method MouseDown (метод) Method MouseMove (метод) Method MouseUp (метод) Method MouseWheel (метод)
Class IView3DController | Method KeyboardEvent (метод)

Смотри также

Group Пользовательский интерфейс


Константы SlopeModeConstants

Способ задания наклона поверхности к горизонтали

Константы

Константа | Значение | Описание
Constant SlopeModeRadians | 0 | В радианах
Constant SlopeModeDegrees | 1 | В градусах
Constant SlopeModePercents | 2 | В процентах
Constant SlopeModePermiles | 3 | В промилях

Где используются

Класс | Член класса
Class CADTriangulation | Method BuildIsoexpos (метод) Method BuildIsoslopes (метод) Method ExpositionAtPoint (метод) Method SlopeAtPoint (метод)
Class Triangulation | Method BuildIsoexpos (метод) Method BuildIsoslopes (метод) Method ExpositionAtPoint (метод) Method SlopeAtPoint (метод)
Class TrnTriangle | Method Exposition (метод)

Смотри также

Group Триангуляция


Константы StatusPanelConstants

Индексы панелей в строке статуса главного окна приложения

Константы

Константа | Значение | Описание
Constant StatusPanelCoordinates | 0 | Место для вывода текущих координат мыши в плане (только для внутреннего использования)
Constant StatusPanelAuxilary | 1 | Дополнительное место для вывода информации в строке статуса
Constant StatusPanelStandard | 2 | Стандартное место для вывода информации в строке статуса

Где используются

Класс | Член класса
Class Project | Method SetStatusText (метод)

Смотри также

Group Внешние модули, Group Пользовательский интерфейс


Константы SurfaceDifferenceProjectionConstants

Виды проекций для отображения отметок при построении разности поверхностей

Константы

Константа | Значение | Описание
Constant SurfaceDifferenceProjectionNone | 0 | Не отображаются отметки разности поверхностей
Constant SurfaceDifferenceProjectionTopToBottom | 1 | Отображаются отметки проекций узлов верхнего слоя на нижний
Constant SurfaceDifferenceProjectionBottomToTop | 2 | Отображаются отметки проекций узлов нижнего слоя на верхний
Constant SurfaceDifferenceProjectionBoth | 3 | Отображаются отметки проекций как верхнего слоя на нижний, так и нижнего на верхний

Где используются

Класс | Член класса
Class SurfaceDifference | Property ProjectionKind (свойство)

Смотри также

Group Поверхности


Константы SurveyEditorPageConstants

Страницы геодезического редактора

Константы

Константа | Значение | Описание
Constant SurveyEditorPageParameters | 0 | Страница с параметрами хода
Constant SurveyEditorPageStations | 1 | Страница со станциями хода
Constant SurveyEditorPageSurveys | 2 | Страница со съёмками и съёмочными точками
Constant SurveyEditorPageAditionalPoints | 3 | Страница с дополнительными точками (засечками)
Constant SurveyEditorPagePlan | 4 | Страница с планом
Constant SurveyEditorPageProfile | 5 | Страница с продольным профилем

Где используются

Класс | Член класса
Class SurveyEditor | Property ActivePage (свойство)

Смотри также

Group Геодезия


Константы SwitchItemStateConstants

Требуемое состояние при переключении состояний элементов

Константы

Константа | Значение | Описание
Constant ItemSwitchNext | 0 | Выбрать следующее состояние по циклу
Constant ItemSwitchState1 | 1 | Выбрать состояние с номером 1
Constant ItemSwitchState2 | 2 | Выбрать состояние с номером 2
Constant ItemSwitchState3 | 3 | Выбрать состояние с номером 3
Constant ItemSwitchState4 | 4 | Выбрать состояние с номером 4
Constant ItemSwitchState5 | 5 | Выбрать состояние с номером 5
Constant ItemSwitchState6 | 6 | Выбрать состояние с номером 6
Constant ItemSwitchState7 | 7 | Выбрать состояние с номером 7
Constant ItemSwitchState8 | 8 | Выбрать состояние с номером 8
Constant ItemSwitchState9 | 9 | Выбрать состояние с номером 9

Где используются

Класс | Член класса
Class VectorContainer | Method SwitchAtLayer (метод) Method SwitchFigure (метод)

Смотри также

Group Карты


Константы SwitchItemTypesConstants

Допустимые типы переключаемых элементов чертежа

Константы

Константа | Значение | Описание
Constant SwitchItemAll | 0 | Переключать все типы элементов
Constant SwitchItemExSymbol | 1 | Переключать только символы
Constant SwitchItemExPolyline | 2 | Переключать только линии
Constant SwitchItemExPolygon | 3 | Переключать только полигоны

Где используются

Класс | Член класса
Class VectorContainer | Method SwitchAtLayer (метод) Method SwitchFigure (метод)

Смотри также

Group Карты


Константы SystemAxesConstants

Тип ввода мультиточек

Константы

Константа | Значение | Описание
Constant SystemAxesXright_Yup | 0 | X - вправо, Y - вверх (обычная система координат)
Constant SystemAxesXright_Ydown | 1 | X - вправо, Y - вниз (зеркалирует и поворачивается на 180°)
Constant SystemAxesXleft_Yup | 2 | X - влево, Y - вверх (зеркалирует без поворота)
Constant SystemAxesXleft_Ydown | 3 | X - влево, Y - вниз (только поворот на 180°)
Constant SystemAxesXup_Yright | 4 | X - вверх, Y - вправо (зеркалирует и поворачивается на 270°)
Constant SystemAxesXdown_Yright | 5 | X - вниз, Y - вправо (только поворот на 270°)
Constant SystemAxesXup_Yleft | 6 | X - вверх, Y - влево (только поворот на 90°)
Constant SystemAxesXdown_Yleft | 7 | X - вниз, Y - влево (зеркалирует и поворачивается на 90°)

Где используются

Класс | Член класса
Class Composition | Property SystemAxes (свойство)
Class LayeredComposition | Property SystemAxes (свойство)

Смотри также

Group Контейнеры изображений


Константы TAlignmentType

Константы

Константа | Значение | Описание
Constant atCenter | 0 | Выравнивать по центру
Constant atUpEdge | 1 | Выравнивать по верхнему краю
Constant atLowEdge | 2 | Выравнивать по нижнему краю
Constant atDisable | 3 | Не делать выравнивание

Где используются

Класс | Член класса
Class TPointInfo | Property Alignment (свойство)
Class TPolygonInfo | Property Alignment (свойство)
Class TPolylineInfo | Property Alignment (свойство)


Константы TCommunicationType

Константы

Константа | Значение | Описание
Constant cmtTube | 0 | Трубопровод
Constant cmtMetalLap | 1 | ЛЭП на металической опоре
Constant cmtWoodLap | 2 | ЛЭП на деревянной опоре
Constant cmtConcrete | 3 | ЛЭП на железобетонной опоре
Constant cmtLampLap | 4 | Фонарь

Где используются

Класс | Член класса
Class TPolylineInfo | Property CommunicatonType (свойство)


Константы TElevationMethod

Константы

Константа | Значение | Описание
Constant emMinZ | 0 | Восстанавливать высоту с минимальной Z
Constant emMaxZ | 1 | Восстанавливать высоту с максимальной Z
Constant emFollowZ | 2 | Восстанавливать высоту в соответствии с Z каждой точки

Где используются

Класс | Член класса
Class TPolygonInfo | Property ElevationMethod (свойство)
Class TPolylineInfo | Property ElevationMethod (свойство)


Константы TLineType

Константы

Константа | Значение | Описание
Constant ltPlane | 0 | Визуализация плоскостями
Constant ltCube | 1 | Визуализация параллелепипедами
Constant ltCylinder | 2 | Визуализация цилиндрами
Constant ltCommunication | 3 | Коммуникация
Constant ltXFile | 4 | Визуализация объектом из Х файла

Где используются

Класс | Член класса
Class TPolylineInfo | Property LineType (свойство)


Константы TObjectType

Константы

Константа | Значение | Описание
Constant otNone | 0 | Объект не для 3D
Constant otPoint | 1 | Точка
Constant otMultiPoint | 2 | Мультиточка
Constant otPolyline | 3 | Полилиния
Constant otPolygon | 4 | Полигон

Где используются

Класс | Член класса
Class IRenderAdapter3D | Method GetItemInfo (метод)


Константы TPointType

Константы

Константа | Значение | Описание
Constant ptPlane | 0 | Визуализация плоскостью
Constant ptSphere | 1 | Визуализация сферой
Constant ptCube | 2 | Визуализация кубом
Constant ptTetrahedron | 3 | Визуализация тетраэдром
Constant ptCylinder | 4 | Визуализация цилиндром
Constant ptTree | 5 | Визуализация деревом
Constant ptXFile | 6 | Визуализация объектом из Х файла

Где используются

Класс | Член класса
Class TPointInfo | Property PointType (свойство)


Константы TPolygonType

Константы

Константа | Значение | Описание
Constant pgtPlane | 0 | Визуализация плоскостью
Constant pgtVolume | 1 | Визуализация объёмным многогранником
Constant pgtBuilding | 2 | Визуализация зданием
Constant pgtSurface | 3 | Визуализация поверхностью
Constant pgtXFile | 4 | Визуализация объектом из Х файла

Где используются

Класс | Член класса
Class TPolygonInfo | Property PolygonType (свойство)


Константы TRoofType

Константы

Константа | Значение | Описание
Constant rtPlane | 0 | Плоская крыша
Constant rtCone | 1 | Коническая крыша
Constant rtLineComZ | 2 | Крыша с коньком в виде линии с заданной высотой
Constant rtPolygonComZ | 3 | Крыша в виде полигона заданной высоты
Constant rtContour | 4 | Крыша с коньком повторяющим контур здания
Constant rtSkirting | 5 | Крыша в виде бортика
Constant rtCustom | 6 | Крыша с коньком в виде произвольной полилинии

Где используются

Класс | Член класса
Class TPolygonInfo | Property RoofType (свойство)


Константы TSurfaceType

Константы

Константа | Значение | Описание
Constant stForest | 0 | Лес
Constant stMountain | 1 | Горы

Где используются

Класс | Член класса
Class TPolygonInfo | Property SurfaceType (свойство)


Константы TTreeType

Константы

Константа | Значение | Описание
Constant ttApple | 0 | Яблоня
Constant ttBirch | 1 | Берёза
Constant ttFir | 2 | Ёлка
Constant ttPoplar | 3 | Тополь
Constant ttHawthorn | 4 | Боярышник
Constant ttElm | 5 | Вяз
Constant ttPear | 6 | Груша
Constant ttWillow | 7 | Ива
Constant ttShadberry | 8 | Ирга
Constant ttCedar | 9 | Кедр
Constant ttCypress | 16 | Кипарис
Constant ttMaple | 17 | Клён
Constant ttLinden | 18 | Липа
Constant ttPalm | 19 | Пальма
Constant ttLarch | 20 | Лиственница
Constant ttStump | 21 | Пень
Constant ttRowan | 22 | Рябина
Constant ttLilac | 23 | Сирень
Constant ttPine | 24 | Сосна
Constant ttElfinWood | 25 | Стланик
Constant ttBirdCherry | 32 | Черёмуха

Где используются

Класс | Член класса
Class TTreeInfo | Property TreeType (свойство)


Константы TimeViewStyleConstants

Тип данных времени

Константы

Константа | Значение | Описание
Constant TimeViewHourMin | 0 | Часы и минуты
Constant TimeViewHourMinSec | 1 | Часы, минуты и секунды
Constant TimeViewHourMinSecMil | 2 | Часы, минуты, секунды и милисекунды

Где используются

Класс | Член класса
Class BrowserItem | Property TimeViewStyle (свойство)

Смотри также

Group Базы данных


Константы TopoFillKindConstants

Тип площадного условного знака

Константы

Константа | Значение | Описание
Constant TopoFillKindNone | 0 | Ничего не рисуется
Constant TopoFillKindSolid | 1 | Сплошная заливка
Constant TopoFillKindSign | 2 | Топографический площадной условный знак без фоновой заливки
Constant TopoFillKindSignOverSolid | 3 | Топографический площадной условный знак поверх фоновой заливки

Где используются

Класс | Член класса
Class TopoFillStyle | Property Kind (свойство) Method SetStyle (метод)

Смотри также

Group Условные знаки


Константы TopoLineKindConstants

Тип линейного условного знака

Константы

Константа | Значение | Описание
Constant TopoLineKindNone | 0 | Ничего не рисуется
Constant TopoLineKindSolid | 1 | Сплошная линия
Constant TopoLineKindSign | 2 | Топографический линейный условный знак

Где используются

Класс | Член класса
Class TopoLineStyle | Property Kind (свойство) Method SetStyle (метод)

Смотри также

Group Условные знаки


Константы TopoSymbolKindConstants

Тип точечного условного знака

Константы

Константа | Значение | Описание
Constant TopoSymbolKindNone | 0 | Ничего не рисуется
Constant TopoSymbolKindSign | 1 | Топографический точечный условный знак

Где используются

Класс | Член класса
Class TopoSymbolStyleAux | Property Kind (свойство)

Смотри также

Group Условные знаки


Константы TrackerConstants

Тип ввода мультиточек

Константы

Константа | Значение | Описание
Constant TrackerNone | 0 | Нет знака
Constant TrackerCircle1 | 1 | Окружность маленькая
Constant TrackerCircle2 | 2 | Окружность средняя
Constant TrackerCircle3 | 3 | Окружность большая
Constant TrackerSquare1 | 4 | Квадрат маленький
Constant TrackerSquare2 | 5 | Квадрат средний
Constant TrackerSquare3 | 6 | Квадрат большой
Constant TrackerTriangle1 | 7 | Треугольник маленький
Constant TrackerTriangle2 | 8 | Треугольник средний
Constant TrackerTriangle3 | 9 | Треугольник большой

Где используются

Класс | Член класса
Class CustomContainer | Property MultiPointTracker (свойство)
Class VectorContainer | Property MultiPointTracker (свойство)

Смотри также

Group Контейнеры изображений


Константы TrackingStopConstants

Способ остановки ввода данных на карту

Константы

Константа | Значение | Описание
Constant TrackingStopNone | 0 | Без остановки
Constant TrackingStopDblClick | 1 | По двойному щелчку мышкой
Constant TrackingStopRightClick | 2 | По щелчку правой кнопкой мышки

Где используются

Класс | Член класса
Class CustomContainer | Property TrackStopMode (свойство)
Class VectorContainer | Property TrackStopMode (свойство)

Смотри также

Group Контейнеры изображений


Константы TriangulationFormatConstants

Тип исходных данных в триангуляции

Константы

Константа | Значение | Описание
Constant TriangulationFormatInteger | 0 | Целые числа
Constant TriangulationFormatSingle | 1 | Вещественные числа с одинарной точностью, пересчитываемые при построениях в целые
Constant TriangulationFormatDouble | 2 | Вещественные числа с двойной точностью, пересчитываемые при построениях в целые

Где используются

Класс | Член класса
Class CADTriangulation | Property DataFormat (свойство)
Class Triangulation | Property DataFormat (свойство)

Смотри также

Group Триангуляция


Константы TrnAreaConstants

Тип региона триангуляции

Константы

Константа | Значение | Описание
Constant TrnAreaRegion | 0 | Регион общего назначения без задания высоты границы
Constant TrnAreaRegionZ | 1 | Регион общего назначения с высотой для точек границы
Constant TrnAreaRegionComZ | 2 | Регион общего назначения с общей для границы высотой
Constant TrnAreaBoundary | 3 | Внешняя граница триангуляции (все извне отбрасывается) без задания высоты
Constant TrnAreaBoundaryZ | 4 | Внешняя граница триангуляции (все извне отбрасывается) с высотой для точек границы
Constant TrnAreaBoundaryComZ | 5 | Внешняя граница триангуляции (все извне отбрасывается) с общей для границы высотой
Constant TrnAreaHole | 6 | Внутренняя граница триангуляции (дырка) без задания высоты
Constant TrnAreaHoleZ | 7 | Внутренняя граница триангуляции (дырка) с высотой для точек границы
Constant TrnAreaHoleComZ | 8 | Внутренняя граница триангуляции (дырка) с общей для границы высотой
Constant TrnAreaEqualZ | 9 | Внутренняя зона триангуляции с одинаковыми значениями Z

Где используются

Класс | Член класса
Class TrnArea | Property Kind (свойство)

Смотри также

Group Триангуляция


Константы TrnFigureKindConstants

Тип объектов триангуляции

Константы

Константа | Значение | Описание
Constant TrnFigureUnknown | 0 | Тип неизвестен
Constant TrnFigureSource | 1 | Исходная точка
Constant TrnFigureLine | 2 | Исходная структурная линия
Constant TrnFigureArea | 3 | Исходный регион
Constant TrnFigureNode | 4 | Узел триангуляции
Constant TrnFigureRib | 5 | Неперестраиваемое ребро триангуляции
Constant TrnFigureTriangle | 6 | Треугольник триангуляции
Constant TrnFigureFlip | 7 | Переброска ребра
Constant TrnFigureModifier | 8 | Модификатор (красящая/обрезающая линия)

Где используются

Класс | Член класса
Class TrnArea | Property ObjectKind (свойство)
Class TrnBreak | Property ObjectKind (свойство)
Class TrnFigure | Property ObjectKind (свойство)
Class TrnFlip | Property ObjectKind (свойство)
Class TrnModifier | Property ObjectKind (свойство)
Class TrnNode | Property ObjectKind (свойство)
Class TrnRib | Property ObjectKind (свойство)
Class TrnSource | Property ObjectKind (свойство)
Class TrnTriangle | Property ObjectKind (свойство)

Смотри также

Group Триангуляция


Константы TrnFlipAbilityConstants

Результат проверки на возможность переброски ребра в указанной точке триангуляции

Константы

Константа | Значение | Описание
Constant TrnFlipAbilityNoRib | 0 | В указанной точке нет ребра
Constant TrnFlipAbilityCanFlip | 1 | Переброска ребра возможна
Constant TrnFlipAbilityCannotFlip | 2 | Переброска ребра невозможна (мешает жёсткое ребро или неверная конфигурация треугольников)

Где используются

Класс | Член класса
Class CADTriangulation | Method CanFlipAtPoint (метод)
Class Triangulation | Method CanFlipAtPoint (метод)

Смотри также

Group Триангуляция


Константы TrnModifierKindConstants

Тип модификатора

Константы

Константа | Значение | Описание
Constant TrnModifierKindPainter | 0 | Изменение цвета пересекаемых треугольников
Constant TrnModifierKindCutter | 1 | Пометка треугольников как невидимых
Constant TrnModifierKindNoIsoline | 2 | Запрет строить изолинии по пересекаемым треугольникам

Где используются

Класс | Член класса
Class CADTriangulation | Method AddModifier (метод) Method AddModifierShape (метод)
Class Triangulation | Method AddModifier (метод) Method AddModifierShape (метод)
Class TrnModifier | Property Kind (свойство)

Смотри также

Group Триангуляция


Константы TrnNodeConstants

Статус узла триангуляции

Константы

Константа | Значение | Описание
Constant TrnNodeNormal | 0 | Используется в стуктуре триангуляции
Constant TrnNodeStructure | 1 | Используется в стуктуре триангуляции и лежит на структурной линии
Constant TrnNodeBoundary | 2 | Используется в стуктуре триангуляции и лежит на границе полигона
Constant TrnNodeExternal | 3 | Используется в стуктуре триангуляции, но не виден из-за ограничений
Constant TrnNodeDuplicate | 4 | Не используется в структуре триангуляции
Constant TrnNodeCross | 5 | Добавлен в результате пересечения структурных линий
Constant TrnNodeThickness | 6 | Добавлен в результате сгущения триангуляции

Где используются

Класс | Член класса
Class TrnNode | Property Kind (свойство)

Смотри также

Group Триангуляция


Константы TrnNodeWeightModeConstants

Способ вычисления весов треугольников вокруг узла при вычисление нормали узла по смежным треугольникам

Константы

Константа | Значение | Описание
Constant TrnNodeWeightModeSquare | 0 | Весом выступает площадь смежных треугольников
Constant TrnNodeWeightModeAngle | 1 | Весом выступает прилегающие углы смежных треугольников
Constant TrnNodeWeightModeLengths | 2 | Вес пропорционален длинам рёбер смежных треугольников
Constant TrnNodeWeightModeReverse | 3 | Вес обратно пропорционален длинам рёбер смежных треугольников
Constant TrnNodeWeightModeRootCos | 4 | Вес вычисляется как корень квадратный из 1 - cos прилегающего угла

Где используются

Класс | Член класса
Class CADTriangulation | Method ExpositionAtPoint (метод) Method NormalAtPoint (метод) Method SlopeAtPoint (метод) Method Thicken (метод)
Class Triangulation | Method ExpositionAtPoint (метод) Method NormalAtPoint (метод) Method SlopeAtPoint (метод) Method Thicken (метод)
Class TrnTriangle | Method InterpolateRibCenter (метод) Method NodeNormal (метод)

Смотри также

Group Триангуляция


Константы TrnSaveModeConstants

Режим сохранения триангуляции

Константы

Константа | Значение | Описание
Constant TrnSaveModeNormal | 0 | Полное сохранение исходных данных и модели триангуляции
Constant TrnSaveModeSourceOnly | 1 | Сохранять только исходные данные для триангуляции (без самой триангуляции)
Constant TrnSaveModeModelOnly | 2 | Сохранять только выходные данные (топологическую структуру триангуляции)

Где используются

Класс | Член класса
Class CADTriangulation | Method ExportToXmlFile (метод) Method ExportToXmlNode (метод) Method MakeCopy (метод) Method SaveToStream (метод)
Class Triangulation | Method ExportToXmlFile (метод) Method ExportToXmlNode (метод) Method MakeCopy (метод) Method SaveToStream (метод)

Смотри также

Group Триангуляция


Константы TrnTriangleConstants

Статус треугольника триангуляции

Константы

Константа | Значение | Описание
Constant TrnTriangleNormal | 0 | Используется в стуктуре триангуляции
Constant TrnTriangleExternal | 1 | Не виден, т.к. лежит за внешней границей триангуляции (за takBoundary)
Constant TrnTriangleInternal | 2 | Не виден, т.к. лежит внутри внутренней границы триангуляции (внутри takHole)
Constant TrnTriangleEqualZ | 3 | Часть внутренней зоны триангуляции с одинаковыми значениями Z

Где используются

Класс | Член класса
Class TrnTriangle | Property Kind (свойство)

Смотри также

Group Триангуляция


Константы UndoFinishModeConstants

Режим завершения записи блока данных

Константы

Константа | Значение | Описание
Constant UndoFinishModeCommit | 0 | Завершить запись успешно
Constant UndoFinishModeRollback | 1 | Прервать запись и откатить сделанные записи
Constant UndoFinishModeAbort | 2 | Прервать запись и отбросить сделанные записи

Где используются

Класс | Член класса
Class UndoManager | Method Finish (метод)

Смотри также

Group Менеджер откатов


Константы VolumeTypeConstants

Способ вычисления объёмов работ под и над землей

Константы

Константа | Значение | Описание
Constant VolumeTypeSolid | 0 | Под землей - полная засыпка, над землей - срезка на полную глубину
Constant VolumeTypeLayers | 1 | Под землей - послойная засыпка, над землей - послойная срезка

Где используются

Класс | Член класса
Class CADTriangulation | Method ZeroEarthVolumes (метод)
Class Triangulation | Method ZeroEarthVolumes (метод)

Смотри также

Group Триангуляция


Приложение

В данном разделе представлены классы, интерфейсы и константы, предназначенные для общего управления приложением

Классы

Имя | Описание
Class Application | Приложение IndorCAD
Class ApplicationOptions | Реализация настроек программы
Class Calculator | Объект для вычисления выражений
Class CustomOptions | Настройки класса
Class Plugin | Дополнительный модуль к системе
Class PluginManager | Менеджер дополнительных модулей к системе
Class Version | Информация о версии приложения

Интерфейсы

Имя | Описание
Interface IApplicationEvents | События системы IndorCAD
Interface IPluginEvents | События, возникающие при создании дополнительного внутреннего модуля к системе

Константы

Имя | Описание
Enum LogPrecisionConstants | Уровень детализации при журналировани
Enum PluginKindConstants | Тип дополнительного модуля
Enum PluginOptionConstants | Различные опции дополнительного модуля


Пользовательский интерфейс

В данном разделе представлены классы, интерфейсы и константы, предназначенные для управления пользовательским интерфейсом

Классы

Имя | Описание
Class Bar | Панель инструментов
Class BarButton | Кнопка на панели инструментов
Class BarItem | Элемент панелей инструментов
Class BarItemLink | Ссылка на действие
Class BarItemLinks | Список ссылок на действия
Class BarLargeButton | Большая кнопка на панели инструментов
Class BarManager | Менеджер элементов панелей и лент инструментов
Class BarModeButton | Кнопка режима на панели инструментов
Class BarPopupMenu | Всплывающее меню
Class BarSeparator | Разделитель элементов меню на панели инструментов
Class BarSubItem | Подменю на панели инструментов
Class CADAction | Реализация ICADAction
Class Images | Стандартный набор картинок
Class Menu | Описание меню окна
Class MenuItem | Элемент меню
Class MenuVerb | Описание пункта меню
Class Ribbon | Лента инструментов
Class RibbonTab | Закладка на ленте инструментов
Class RibbonTabGroup | Группа действий на ленте инструментов
Class Window | Любое экранное окно

Константы

Имя | Описание
Enum AlignmentConstants | Тип выравнивания
Enum BarButtonGroupPositionConstants | Способ участия кнопок на панели или ленте инструментов в группе кнопок
Enum BarItemPositionConstants | Способ размещения элементов на ленте инструментов
Enum BarPaintStyleConstants | Рекомендованный способ отображения элементов на панели или ленте инструментов
Enum CursorConstants | Типы курсоров
Enum MouseButtonConstants | Тип кнопки мышки
Enum ShiftStateConstants | Состояния клавиш Ctrl, Alt, Shift, кнопок мышки, а также контроллера привязки. Данные константы могут использоваться в комбинации для задания состояния сразу нескольких клавиш клавиатуры, кнопок мышки и контроллера привязки
Enum StatusPanelConstants | Индексы панелей в строке статуса главного окна приложения


Проекты

В данном разделе представлены классы, интерфейсы и константы, предназначенные для управления проектами

Классы

Имя | Описание
Class Aggregate | Объект, содержащий в себе разнотипные объекты IndorCAD
Class BaseObject | Базовый объект IndorCAD
Class BaseObjectList | Базовый объект - список объектов IndorCAD
Class DrawingSheet | Лист чертежа плана
Class DrawingSheets | Листы чертежа плана
Class Grid | Сетка, покрывающая весь проект с шагом 10 см
Class Project | Проект IndorCAD
Class ProjectOptions | Настройки проекта

Интерфейсы

Имя | Описание
Interface IProjectEvents |


Поверхности

В данном разделе представлены классы и константы, предназначенные для управления поверхностями, представленными в виде слоёв проекта

Классы

Имя | Описание
Class CADTriangulation | Триангуляция поверхности IndorCAD
Class Layer | Слой цифровой модели
Class LayerOptions | Настройки слоя
Class LayerPoint | Точка поверхности
Class LayerPoints | Набор точек (рельефных и ситуационных)
Class Layers | Список слоёв в проекте
Class Line | Структурная/ситуационная линия или полигон
Class LineGroup | Группа линий/полигонов
Class Lines | Коллекция структурных/ситуационных линий слоя
Class SurfaceDifference | Разность поверхностей
Class SurfaceDifferences | Набор разностей поверхностей
Class SurfacePainter | Элемент закраски поверхности в слое
Class SurfacePainters | Список элементов закраски поверхности в слое
Class CustomOptions | Настройки класса

Константы

Имя | Описание
Enum DrawPointCaption | Варианты отображения подписи точек в плане
Enum SurfaceDifferenceProjectionConstants | Виды проекций для отображения отметок при построении разности поверхностей


Трассы

В данном разделе представлены классы и константы, предназначенные для управления трассами проекта

Классы

Имя | Описание
Class Route | Трасса
Class RouteElement | Элемент разбивки трассы (поперечник)
Class RouteOptions | Параметры трассы
Class Routes | Список трасс в проекте
Class RouteVertex | Вершина трассы
Class CustomOptions | Настройки класса

Интерфейсы

Имя | Описание
Interface IRoutesEvents |

Константы

Имя | Описание
Enum RepresentLineConstants | Комбинацией данных флагов определяется, какие данные будут возвращены при представлении ломаной
Enum RouteModelModifiedConstants | Комбинацией данных флагов определяется, что изменилось в элементах трассы


Трёхмерный вид

В данном разделе представлены классы и константы, предназначенные для управления трёхмерным видом

Классы

Имя | Описание
Class Options3D | Настройки отображения 3D-вида проекта
Class SubSystem3D | Подсистема 3D-вида

Интерфейсы

Имя | Описание
Interface IView3DController | Реализуется объектами, обеспечивающими управление 3D-видом с помощью клавиатуры, джойстика
Interface IObject3D | Реализуется объектами, поддерживающими отрисовку себя (и своих подобъектов) в 3D-виде
Interface IObject3DLight | Реализуется объектами, которые выставляют дополнительные источники освещения
Interface IObject3DTransparent | Реализуется объектами, поддерживающими отрисовку себя (и своих подобъектов) в 3D-виде в полупрозрачном состоянии

Константы

Имя | Описание
Enum Controller3DEventConstants | Причина вызова метода KeyboardEvent у контроллера 3D-вида


Внешние модули

В данном разделе представлены классы и константы, предназначенные для создания внешних модулей

Интерфейсы

Имя | Описание
Interface ICADAssignableWithLayerObject | Реализуется объектами IndorCAD, поддерживающими импорт своих данных из другого проекта или слоя
Interface ICADDataCreator | Реализуется объектами, которые регистрируются в Application.RegisterData и умеют создавать экземпляры данных для IndorCAD
Interface ICADObject | Интерфейс, который обязан реализовывать любой объект IndorCAD, встраивающийся в дерево объектов
Interface IDocTreeHandler | Обработчик "перечисления" объектов какой-либо ветви проекта
Interface IImporter | Реализуется объектами, регистрируемыми в Application.RegisterImport, которые могут импортировать какие-либо данные из файла
Interface IObject3D | Реализуется объектами, поддерживающими отрисовку себя (и своих подобъектов) в 3D-виде
Interface IObject3DLight | Реализуется объектами, которые выставляют дополнительные источники освещения
Interface IObject3DTransparent | Реализуется объектами, поддерживающими отрисовку себя (и своих подобъектов) в 3D-виде в полупрозрачном состоянии

Константы

Имя | Описание
Enum CallReasonKeyboardConstants | Причина вызова метода ProcessKeyboard у текущего режима работы
Enum CallReasonMouseConstants | Причина вызова метода ProcessMouse у текущего режима работы
Enum LogPriorityConstants | Приоритеты событий, записываемых в файл журнала
Enum PropertyStreamConstants | Типы элементов PropertyStream'a
Enum SelectsConstants | Типы селекций, реализованных в системе (используются дополнительными модулями)
Enum StatusPanelConstants | Индексы панелей в строке статуса главного окна приложения


Триангуляция

В данном разделе представлены классы и константы, предназначенные для управления триангуляциями

Классы

Имя | Описание
Class Triangulation | Триангуляция
Class TrnArea | Регион триагуляции
Class TrnBreak | Структурная линия триангуляции
Class TrnFigure | Исходная точка для построения триангуляции
Class TrnFlip | Дополнительная переброска рёбер триангуляции
Class TrnModifier | Красящие и отсекающие линии триангуляции
Class TrnNode | Узел триангуляции
Class TrnRib | Структурное неперестраиваемое ребро триангуляции
Class TrnSource | Исходная точка для построения триангуляции
Class TrnTools | Объект для выполнения различных высокоуровневых операций с помощью триангуляции
Class TrnTriangle | Треугольник триангуляции. Состоит из указателей на точки и соседние треугольники. Напротив i-й точки P[i] всегда задается i-й треугольник. Точки нумеруются по часовой стрелке
Class CADTriangulation | Триангуляция поверхности IndorCAD

Интерфейсы

Имя | Описание
Interface IEnumerateNodes | Интерфейс, используемый в методе EnumerateNodes узла для получения всех узлов, смежных с данным узлом
Interface IEnumerateProfile | Интерфейс, используемый в методе EnumerateProfile триангуляции для получения всех отрезков профиля вдоль заданного отрезка
Interface IEnumerateProfilePoints | Интерфейс, используемый в методе EnumerateProfilePoints триангуляции для получения всех точек профиля вдоль заданного отрезка
Interface IEnumerateRibs | Интерфейс, используемый в методе EnumerateRibs узла для получения всех рёбер, смежных с данным узлом
Interface IEnumerateTriangles | Интерфейс, используемый в методе EnumerateTriangles узла для получения всех треугольников, смежных с данным узлом
Interface ITrnFigureFilter | Интерфейс, используемый в методах GetItem[s]AtPoint/GetItemsAtRect триангуляции для получения объектов в заданной точки плоскости

Константы

Имя | Описание
Enum CompressionLevelConstants | Способ сжатия данных
Enum ProfilePointTypeConstants | Тип отрезка при генерации профиля
Enum ProfileSegmentTypeConstants | Тип отрезка при генерации профиля
Enum SlopeModeConstants | Способ задания наклона поверхности к горизонтали
Enum TriangulationFormatConstants | Тип исходных данных в триангуляции
Enum TrnAreaConstants | Тип региона триангуляции
Enum TrnFigureKindConstants | Тип объектов триангуляции
Enum TrnFlipAbilityConstants | Результат проверки на возможность переброски ребра в указанной точке триангуляции
Enum TrnModifierKindConstants | Тип модификатора
Enum TrnNodeConstants | Статус узла триангуляции
Enum TrnNodeWeightModeConstants | Способ вычисления весов треугольников вокруг узла при вычисление нормали узла по смежным треугольникам
Enum TrnSaveModeConstants | Режим сохранения триангуляции
Enum TrnTriangleConstants | Статус треугольника триангуляции
Enum VolumeTypeConstants | Способ вычисления объёмов работ под и над землей


Инженерные коммуникации

В данном разделе представлены классы, предназначенные для управления данными по инженерным коммуникациям


Рисование изображений

В данном разделе представлены классы и константы, предназначенные для отрисовки изображений

Классы

Имя | Описание
Class PaintCanvas | Компонента, на которую осуществляется отрисовка

Константы

Имя | Описание
Enum BrushStyleConstants | Способ закраски
Enum FontStyleConstants | Стиль шрифта
Enum PenStyleConstants | Способ рисования линий


Разное

В данном разделе представлены классы и константы, не вошедшие в другие разделы

Классы

Имя | Описание
Class PropertyStream | Объект для записи и чтения данных из потока
Class StringName | Имя линии
Class StringNameCollection | Набор имён линий
Class StringNameGroup | Группа имён линий
Class UniConnection | Параметры подключения к абстрактной базе данных
Class UniConnectionParameters | Параметры подключения к абстрактной базе данных
Class VideoRowViewer | Объект "Просмотрщик видеорядов"
Class VideoRowWriter | Объект "Запись видеорядов"

Интерфейсы

Имя | Описание
Interface IMultiPointGeometry | Геометрия мультиточек
Interface IPolygonGeometry | Геометрия полигона
Interface IPolylineGeometry | Геометрия полилинии
Interface IPropertyStreamed | Объект, умеющий сохраняться/загружаться, используя IPropertyStream
Interface IRenderAdapter3D | Интерфейс для передачи данных в 3D вид
Interface ITextureIdContainer | Массив идентификаторов текстур

Записи

Имя | Описание
Record TColorVector |
Record TPointGeometry |
Record TPointInfo |
Record TPolygonInfo |
Record TPolylineInfo |
Record TTextInfo |
Record TTextureId |
Record TTreeInfo |
Record TVector |

Константы

Имя | Описание
Enum FrameFormatConstants | Формат кадра видеоряда.
Enum ServerTypeConstants | Тип сервера данных и, соответственно, диалекта языка SQL
Enum TAlignmentType |
Enum TCommunicationType |
Enum TElevationMethod |
Enum TLineType |
Enum TObjectType |
Enum TPointType |
Enum TPolygonType |
Enum TRoofType |
Enum TSurfaceType |
Enum TTreeType |


Геодезия

В данном разделе представлены классы, отвечающие за взаимодействие с модулем обработки геодезических данных

Классы

Имя | Описание
Class AdditionalPoint | Абстрактная дополнительная точка (засечка)
Class By3PointAdditionalPoint | Дополнительная точка, вычисленная по трем точкам
Class CustomSurveyPoint | Абстрактная съёмочная точка
Class FieldTraverse | Теодолитный ход
Class FieldTraversePoint | Точка теодолитного хода
Class GeodesyAngle | Геодезический угол
Class GeodesyBook | Геодезический редактор
Class GeoPoint | Абстрактная геодезическая точка
Class IntersectionAdditionalPoint | Засечки
Class KnownAdditionalPoint | Точка с известными координатами
Class LinkedGeoPoint | Точка хода с возможностью ссылки на другую точку
Class MeasureAdditionalPoint | Дополнительная точка, вычисленная по промерам
Class Measuring | Абстрактная съёмка
Class RangeAdditionalPoint | Абстрактная дополнительная точка со створом
Class Survey | Пикетажная съёмка
Class SurveyEditor | Геодезический редактор
Class SurveyPoint | Съёмочная точка

Константы

Имя | Описание
Enum AngleModeConstants | Точность отображения углов
Enum FieldTraverseConstants | Типы теодолитных ходов
Enum IntersectionConstants | Типы дополнительных точек (засечек)
Enum SurveyEditorPageConstants | Страницы геодезического редактора


Железные дороги

В данном разделе представлены классы и константы, предназначенные для управления железными дорогами проекта


Поддержка продукта

В случае возникновения каких-либо вопросов по применению программных продуктов, разработанных в ООО "ИндорСофт", вы можете поступить следующим образом:

  • Обратиться на Web-сайт компании ООО "ИндорСофт" по адресу www.indorsoft.ru.
  • Обратиться по электронной почте в службу технической поддержки компании по адресу support@indorsoft.ru. Как правило время ответа на письма составляет не более суток.
  • Позвонить по телефону в службу технической поддержки по номеру +7-(382-2)-651-386. Служба технической поддержки работает с понедельника по пятницу с 6-00 до 15-00 по московскому времени.

Обращайтесь за помощью в любое время! Наша компания всегда с удовольствием ответит на любые интересующие вас вопросы!


Лицензионное соглашение

Лицензионное соглашение на использование системы автоматизированного проектирования IndorCAD 7

Данное лицензионное соглашение является официальным договором между Вами (физическим или юридическим лицом) и ООО "ИндорСофт. Инженерные сети и дороги" - производителем системы IndorCAD. Начиная пользоваться данным программным продуктом (ПО) Вы автоматически соглашаетесь с условиями данного соглашения. Если Вы не согласны с условиями, то не устанавливайте систему IndorCAD и верните все полученные с системой материалы продавцу для возврата затраченных средств.

1. ПРАВО ИСПОЛЬЗОВАНИЯ. Данное лицензионное соглашение даёт Вам право использовать систему IndorCAD на рабочих местах в соответствии с количеством разрешённых рабочих мест в электронном ключе, поставляемом с данным ПО.

2. АВТОРСКОЕ ПРАВО. Система автоматизированного проектирования IndorCAD, включая все поставляемые файлы графических (векторных и растровых) данных, проекты, темы, ex-шрифты и тексты, является собственностью ООО "ИндорСофт. Инженерные сети и дороги", что защищено законодательством Российской федерации и международными соглашениями. Данное ПО является таким же охраняемым продуктом, как печатная продукция, аудио- и видеозаписи, за исключением того, что Вы можете сделать одну копию данного ПО в целях резервного или архивного копирования на любом носителе. Вы не имеете право копировать любую печатную продукцию, поставляемую с данным ПО.

3. ОГРАНИЧЕНИЯ. Вы не можете использовать, копировать, эмулировать, создавать новые версии данного ПО, сдавать в наем или аренду, продавать, изменять, декомпилировать, дизассемблировать, изучать код программы другими способами, передавать программу или любые из ее составляющих. Любое такое нелегальное использование означает автоматическое и немедленное прекращение действия настоящего соглашения и может преследоваться по закону.

4. ДРУГИЕ ПРАВА. Все права не предоставленные в данном лицензионном соглашении явно сохраняются за ООО "ИндорСофт. Инженерные сети и дороги". Производитель данного ПО оставляет за собой право отменить или изменить действие данной лицензии для любой из следующих версий системы IndorCAD.

5. ГАРАНТИИ. Никаких гарантий при поставке системы IndorCAD не прилагается и не предусматривается. Вы используете это программное обеспечение на свой риск. Производитель не будет отвечать ни за какие потери или искажения данных, любую упущенную выгоду в процессе использования или неправильного использования данного ПО.

6. ТЕХНИЧЕСКАЯ ПОДДЕРЖКА. Техническая поддержка и сопровождение данного продукта оказываются только при условии наличия дополнительного соглашения о технической поддержке и сопровождении.

Производителем данного ПО является ООО "ИндорСофт. Инженерные сети и дороги":

Почтовый адрес: Россия, 634057, г. Томск, пр. Мира 3, оф. 135
Телефон: +7-(382-2)-651-386. Факс: +7-(382-2)-66-00-84
Электронная почта: support@indorsoft.ru
Web-сайт: www.indorsoft.ru


Класс Action

Действие для помещения в меню или на панель инструментов

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Caption | Название в меню
Property Category | Категория
Property Checked | Отмечено ли действие в меню
Property Enabled | Доступно ли действие
Property GroupIndex | Номер (радио)группы
Property Hint | Всплывающая подсказка
Property ImageIndex | Код иконки
Property Name (только для чтения) | Уникальное имя в виде
Property ShortCut | Код горячей клавиши
Property Visible | Видим ли пункт меню

Методы класса

Имя | Описание
Method Advise | Подключиться к событиям действия (возвращаемое число нужно впоследствии передать в метод Unadvise)
Method Delete | Удалить действие, ранее созданное методом CreateNew класса Actions
Method DoExecute | Выполнить действие
Method DoUpdate | Принудительно обновить действие (редко, когда надо вызывать явно, т.к. эта команда вызывается сама автоматически во времы простоя системы и перед каждым выполнением команды)
Method Unadvise | Отключиться от событий действия (передаваемое число ранее должно быть получено от метода Advise)

События класса

Имя | Описание
Method Execute | Выполнить действие
Method Update | Обновить параметры действия

Где используется

Класс | Член класса
Class Action | Event Execute (событие) Event Update (событие)
Class Actions | Property Actions (свойство) Method ActionByName (метод) Method CreateNew (метод)
Class BarButton | Property Action (свойство)
Class BarItem | Property Action (свойство)
Class BarLargeButton | Property Action (свойство)
Class BarModeButton | Property Action (свойство)
Class BarSeparator | Property Action (свойство)
Class BarSubItem | Property Action (свойство)
Class IActionEvents | Method Execute (метод) Method Update (метод)

Смотри также

Group Пользовательский интерфейс


Action.Advise (метод)

Подключиться к событиям действия (возвращаемое число нужно впоследствии передать в метод Unadvise)

Синтаксис

[Visual Basic 6]
Function Advise ( _
   ByVal EventHandler As IActionEvents _
) As Long

[Delphi]
function Advise(
   const EventHandler: IActionEvents
): Integer

Описание параметров

EventHandler
[in] Обработчик событий действия

Возвращаемое значение

Возвращает код соединения, который нужно впоследствии передать в метод Unadvise

Смотри также

Class Action, Interface IActionEvents, Group Пользовательский интерфейс


Action.Caption (свойство)

Название в меню

Синтаксис

[Visual Basic 6]
Property Caption As String

[Delphi]
property Caption: WideString

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Category (свойство)

Категория

Синтаксис

[Visual Basic 6]
Property Category As String

[Delphi]
property Category: WideString

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Checked (свойство)

Отмечено ли действие в меню

Синтаксис

[Visual Basic 6]
Property Checked As Boolean

[Delphi]
property Checked: WordBool

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Delete (метод)

Удалить действие, ранее созданное методом CreateNew класса Actions

Синтаксис

[Visual Basic 6]
Sub Delete

[Delphi]
procedure Delete

Смотри также

Class Action, Group Пользовательский интерфейс


Action.DoExecute (метод)

Выполнить действие

Синтаксис

[Visual Basic 6]
Sub DoExecute

[Delphi]
procedure DoExecute

Смотри также

Class Action, Group Пользовательский интерфейс


Action.DoUpdate (метод)

Принудительно обновить действие (редко, когда надо вызывать явно, т.к. эта команда вызывается сама автоматически во времы простоя системы и перед каждым выполнением команды)

Синтаксис

[Visual Basic 6]
Sub DoUpdate

[Delphi]
procedure DoUpdate

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Enabled (свойство)

Доступно ли действие

Синтаксис

[Visual Basic 6]
Property Enabled As Boolean

[Delphi]
property Enabled: WordBool

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Execute (метод)

Выполнить действие

Синтаксис

[Visual Basic 6]
Event Execute ( _
   ByVal Action As Action _
)

[Delphi]
procedure Execute(
   const Action: Action
)

Описание параметров

Action
[in] Выполняемое действие

Смотри также

Class Action, Group Пользовательский интерфейс


Action.GroupIndex (свойство)

Номер (радио)группы

Синтаксис

[Visual Basic 6]
Property GroupIndex As Long

[Delphi]
property GroupIndex: Integer

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Hint (свойство)

Всплывающая подсказка

Синтаксис

[Visual Basic 6]
Property Hint As String

[Delphi]
property Hint: WideString

Смотри также

Class Action, Group Пользовательский интерфейс


Action.ImageIndex (свойство)

Код иконки

Синтаксис

[Visual Basic 6]
Property ImageIndex As Long

[Delphi]
property ImageIndex: Integer

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Name (свойство)

Уникальное имя в виде

Синтаксис

[Visual Basic 6]
ReadOnly Property Name As String

[Delphi]
{только для чтения} property Name: WideString

Смотри также

Class Action, Group Пользовательский интерфейс


Action.ShortCut (свойство)

Код горячей клавиши

Синтаксис

[Visual Basic 6]
Property ShortCut As Long

[Delphi]
property ShortCut: Integer

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Unadvise (метод)

Отключиться от событий действия (передаваемое число ранее должно быть получено от метода Advise)

Синтаксис

[Visual Basic 6]
Sub Unadvise ( _
   ByVal Cookie As Long _
)

[Delphi]
procedure Unadvise(
   const Cookie: Integer
)

Описание параметров

Cookie
[in] Код, возвращённый методом Advise

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Update (метод)

Обновить параметры действия

Синтаксис

[Visual Basic 6]
Event Update ( _
   ByVal Action As Action _
)

[Delphi]
procedure Update(
   const Action: Action
)

Описание параметров

Action
[in] Обновляемое действие

Смотри также

Class Action, Group Пользовательский интерфейс


Action.Visible (свойство)

Видим ли пункт меню

Синтаксис

[Visual Basic 6]
Property Visible As Boolean

[Delphi]
property Visible: WordBool

Смотри также

Class Action, Group Пользовательский интерфейс


Класс Actions

Список доступных действий

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Actions (только для чтения) | Массив доступных действий
Property Count (только для чтения) | Количество доступных действий

Методы класса

Имя | Описание
Method ActionByName | Получить действие по внутреннему имени
Method CreateNew | Создать новое действие с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Смотри также

Class Action, Group Пользовательский интерфейс


Actions.ActionByName (метод)

Получить действие по внутреннему имени

Синтаксис

[Visual Basic 6]
Function ActionByName ( _
   ByVal Name As String _
) As Action

[Delphi]
function ActionByName(
   const Name: WideString
): Action

Описание параметров

Name
[in] Имя действия

Возвращаемое значение

Возвращает действие по указанному имени или Nothing, если такового не существует

Смотри также

Class Action, Class Actions, Group Пользовательский интерфейс


Actions.Actions (свойство)

Массив доступных действий

Синтаксис

[Visual Basic 6]
ReadOnly Property Actions As Action

[Delphi]
{только для чтения} property Actions: Action

Смотри также

Class Action, Class Actions, Group Пользовательский интерфейс


Actions.Count (свойство)

Количество доступных действий

Синтаксис

[Visual Basic 6]
ReadOnly Property Count As Long

[Delphi]
{только для чтения} property Count: Integer

Смотри также

Class Actions, Group Пользовательский интерфейс


Actions.CreateNew (метод)

Создать новое действие с указанным именем. Если имя не задано, то оно будет выбрано автоматически. Если же указанное имя уже используется, то будет сгенерирована ошибка

Синтаксис

[Visual Basic 6]
Function CreateNew ( _
   [ByVal Name As String = ""] _
) As Action

[Delphi]
function CreateNew(
   const Name: WideString
): Action

Описание параметров

Name
[in] Имя нового действия в виде

Возвращаемое значение

Возвращает новое действие

Смотри также

Class Action, Class Actions, Group Пользовательский интерфейс


Константы ActionTypeConstants

Тип выполняемого действия, помещаемого на панели инструментов и в меню

Константы

Константа | Значение | Описание
Constant ActionTypeAction | 0 | Встроенное действие
Constant ActionTypeCommonAction | 1 | Встроенное действие (общее для системы)
Constant ActionTypeMacro | 2 | Макрос
Constant ActionTypeCommonMacro | 3 | Макрос (общий для системы)
Constant ActionTypeSeparator | 4 | Разделитель
Constant ActionTypeContainerMode | 5 | Режим работы контейнера

Где используются

Класс | Член класса
Class MenuItem | Property ActionType (свойство)

Смотри также

Group Пользовательский интерфейс


Константы BorderConstants

Тип рамки

Константы

Константа | Значение | Описание
Constant BorderNone | 0 | Рамки нет
Constant BorderSingle | 1 | Простая рамка

Где используются

Класс | Член класса
Class CustomContainer | Property BorderStyle (свойство)
Class VectorContainer | Property BorderStyle (свойство)

Смотри также

Group Пользовательский интерфейс


Константы ButtonCaptionsConstants

Способы подписывания кнопок на панели инструментов

Константы

Константа | Значение | Описание
Constant ButtonCaptionsNone | 0 | Кнопки не подписывать
Constant ButtonCaptionsBottom | 1 | Кнопки подписывать снизу
Constant ButtonCaptionsRight | 2 | Кнопки подписывать справа

Смотри также

Group Пользовательский интерфейс


Константы CalculatorResultConstants

Тип результата вычисления выражения в калькуляторе

Константы

Константа | Значение | Описание
Constant CalculatorResultNone | 0 | Нет результата
Constant CalculatorResultBoolean | 1 | Логический
Constant CalculatorResultString | 2 | Строка
Constant CalculatorResultInteger | 3 | Целое
Constant CalculatorResultReal | 4 | Вещественное
Constant CalculatorResultDate | 5 | Дата
Constant CalculatorResultError | 6 | Ошибка
Constant CalculatorResultReport | 7 | Отчёт

Где используются

Класс | Член класса
Class Calculator | Property ResultKind (свойство)
Class LayerCalculator | Property ResultKind (свойство)
Class RequestVariable | Property Kind (свойство)

Смотри также

Group Карты


Константы CheckBoxConstants

Состояние checkbox

Константы

Константа | Значение | Описание
Constant CheckBoxUnchecked | 0 | Не отмечено
Constant CheckBoxChecked | 1 | Отмечено
Constant CheckBoxGrayed | 2 | Неопределённое состояние

Где используются

Класс | Член класса
Class CompositionLayer | Property VisibleState (свойство)
Class FolderLayer | Property VisibleState (свойство)
Class VectorLayer | Property VisibleState (свойство)

Смотри также

Group Пользовательский интерфейс


Константы ColorRowConstants

Вид цветового ряда

Константы

Константа | Значение | Описание
Constant ColorRowNone | 0 | Все возможные цвета
Constant ColorRowWeb | 1 | Цвета Web
Constant ColorRowWindows | 2 | Цвета Windows
Constant ColorRowMacOS | 3 | Цвета Mac OS
Constant ColorRowGray | 4 | Серые тона
Constant ColorRowBumperHarvest | 5 | Щедрый урожай
Constant ColorRowPastel | 6 | Пастель
Constant ColorRowMinerals | 7 | Минералы
Constant ColorRowFruitVegetables | 8 | Фрукты и овощи
Constant ColorRowCold | 9 | Холодные тона
Constant ColorRowWarm | 10 | Теплые тона
Constant ColorRowAutumnLeaf | 11 | Осенние листья
Constant ColorRowEquatorialForest | 12 | Экваториальные леса
Constant ColorRowSeaWay | 13 | В открытом море
Constant ColorRowRed | 14 | Красные цвета
Constant ColorRowOrange | 15 | Оранжевые цвета
Constant ColorRowYellow | 16 | Жёлтые цвета
Constant ColorRowGreenYellow | 17 | Зеленовато-жёлтые цвета
Constant ColorRowGreen | 18 | Зелёные цвета
Constant ColorRowGreenBlue | 19 | Зеленовато-синие цвета
Constant ColorRowCyan | 20 | Циановые цвета
Constant ColorRowBlue | 21 | Синие цвета
Constant ColorRowPurple | 22 | Пурпурные цвета
Constant ColorRowViolet | 23 | Фиолетовые цвета
Constant ColorRowBlueRed | 24 | Синие и красные тона
Constant ColorRowGrayRed | 25 | Серые и красные тона
Constant ColorRowBlueOrange | 26 | Синие и оранжевые тона
Constant ColorRowPurpleOrange | 27 | Пурпурные и оранжевые тона
Constant ColorRowGreenRed | 28 | Зелёные и красные тона
Constant ColorRowGreenOrange | 29 | Зелёные и оранжевые тона
Constant ColorRowBrownBlueGreen | 30 | Коричневые и сине-зелёные тона
Constant ColorRowVioletGreen | 31 | Фиолетовые и зелёные тона
Constant ColorRowCyanRed | 32 | Цианистые и красные тона
Constant ColorRowCyanOrange | 33 | Цианистые и оранжевые тона
Constant ColorRowYellowOrangeRed | 34 | Жёлтые, оранжевые и красные тона
Constant ColorRowBeigeBrown | 35 | Бежево-коричневые тона
Constant ColorRowRedPurpleBlue | 36 | Красные, пурпурные и синие тона
Constant ColorRowGreenCyanBlue | 37 | Зелёные, цианистые и синие тона
Constant ColorRowYellowGreenNavy | 38 | Жёлтые, зелёные и темно-синие тона
Constant ColorRowEminence | 39 | Возвышенность
Constant ColorRowHeight | 40 | Высоты
Constant ColorRowRelief | 41 | Рельеф
Constant ColorRowWorldRelief | 42 | Мировой рельеф
Constant ColorRowSeaDepth | 43 | Высота на уровне моря
Constant ColorRowRainbow | 44 | Радуга
Constant ColorRowSpectrum | 45 | Полный спектр
Constant ColorRowHueCycle | 46 | Цветовой круг
Constant ColorRowPrecipitations | 47 | Осадки
Constant ColorRowTemperature | 48 | Температура
Constant ColorRowEarthSurface | 49 | Поверхность земли
Constant ColorRowMountains | 50 | Горы

Смотри также

Group Карты


Класс CustomSurface

Поверхность для рисования в некоторой системе координат

Наследование

CustomSurface Class ContainerSurface, ModelSurface

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property Canvas (только для чтения) | Получить TCanvas в режиме GDI
Property DC (только для чтения) | Получить контекст устройства в режиме GDI
Property Graphics (только для чтения) | Получить объект TGPGraphics в режиме GDI+

Методы класса

Имя | Описание
Method BrushSelect | Установить текущие параметры кисти
Method DrawArc | Нарисовать дугу эллипса, задав объемлющий эллипс прямоугольник и точки, определяющие начало и конец дуги
Method DrawBeziers | Нарисовать последовательность кривых Безье по точкам, переданным в массиве вещественных чисел
Method DrawBeziersPtr | Нарисовать последовательность кривых Безье по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawEllipse | Нарисовать эллипс без заливки
Method DrawLine | Нарисовать отрезок прямой
Method DrawPolygon | Нарисовать полигон по точкам, переданным в массиве вещественных чисел
Method DrawPolygonPtr | Нарисовать полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawPolyline | Нарисовать полилинию по точкам, переданным в массиве вещественных чисел
Method DrawPolylinePtr | Нарисовать полилинию по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawRectangle | Нарисовать прямоугольник без заливки
Method DrawText | Нарисовать текстовую надпись
Method FillEllipse | Нарисовать закрашенный эллипс
Method FillPolygon | Закрасить полигон по точкам, переданным в массиве вещественных чисел
Method FillPolygonPtr | Закрасить полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method FillRectangle | Нарисовать закрашенный прямоугольник
Method FontSelect | Установить текущие параметры шрифта
Method NeedSurfacePoints | Получить временный кусок памяти с вещественными точками. Внимание! Метод небезопасный и может быть использовать только при внутрипроцессной активации COM-сервера
Method PenSelect | Установить текущие параметры пера
Method PointModelToSurface | Преобразовать точку из системы координат модели в целочисленную систему координат устройства вывода
Method PointsModelToSurface | Преобразовать точки из системы координат модели в целочисленную систему координат устройства вывода. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Смотри также

Enum BrushStyleConstants, Enum FontStyleConstants, Enum PenStyleConstants, Group Рисование изображений


CustomSurface.BrushSelect (метод)

Установить текущие параметры кисти

Синтаксис

[Visual Basic 6]
Sub BrushSelect ( _
   ByVal Color As OLE_COLOR, _
   ByVal BrushStyle As BrushStyleConstants _
)

[Delphi]
procedure BrushSelect(
   const Color: OLE_COLOR;
   const BrushStyle: BrushStyleConstants
)

Описание параметров

Color
[in] Цвет кисти
BrushStyle
[in] Стиль заливки

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Enum BrushStyleConstants, Class CustomSurface, Group Рисование изображений


CustomSurface.Canvas (свойство)

Получить TCanvas в режиме GDI

Синтаксис

[Visual Basic 6]
ReadOnly Property Canvas As OLE_HANDLE

[Delphi]
{только для чтения} property Canvas: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DC (свойство)

Получить контекст устройства в режиме GDI

Синтаксис

[Visual Basic 6]
ReadOnly Property DC As OLE_HANDLE

[Delphi]
{только для чтения} property DC: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawArc (метод)

Нарисовать дугу эллипса, задав объемлющий эллипс прямоугольник и точки, определяющие начало и конец дуги

Синтаксис

[Visual Basic 6]
Sub DrawArc ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double, _
   ByVal StartX As Double, _
   ByVal StartY As Double, _
   ByVal EndX As Double, _
   ByVal EndY As Double _
)

[Delphi]
procedure DrawArc(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double;
   const StartX: Double;
   const StartY: Double;
   const EndX: Double;
   const EndY: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника
StartX
[in] Координата X точки, определяющей начало дуги
StartY
[in] Координата Y точки, определяющей начало дуги
EndX
[in] Координата X точки, определяющей конец дуги
EndY
[in] Координата Y точки, определяющей конец дуги

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawBeziers (метод)

Нарисовать последовательность кривых Безье по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawBeziers ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawBeziers(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты контрольных точек последовательности кривых Безье

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawBeziersPtr (метод)

Нарисовать последовательность кривых Безье по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawBeziersPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawBeziersPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив контрольных точек в модельной системе координат
PointNumber
[in] Общее число котрольных точек поледовательности линий Безье

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawEllipse (метод)

Нарисовать эллипс без заливки

Синтаксис

[Visual Basic 6]
Sub DrawEllipse ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure DrawEllipse(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X прямоугольника
Ymin
[in] Минимальная координата по Y прямоугольника
Xmax
[in] Максимальная координата по X прямоугольника
Ymax
[in] Максимальная координата по Y прямоугольника

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawLine (метод)

Нарисовать отрезок прямой

Синтаксис

[Visual Basic 6]
Sub DrawLine ( _
   ByVal X1 As Double, _
   ByVal Y1 As Double, _
   ByVal X2 As Double, _
   ByVal Y2 As Double _
)

[Delphi]
procedure DrawLine(
   const X1: Double;
   const Y1: Double;
   const X2: Double;
   const Y2: Double
)

Описание параметров

X1
[in] Координата X начальной точки отрезка
Y1
[in] Координата Y начальной точки отрезка
X2
[in] Координата X конечной точки отрезка
Y2
[in] Координата Y конечной точки отрезка

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawPolygon (метод)

Нарисовать полигон по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawPolygon ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawPolygon(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полигона

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawPolygonPtr (метод)

Нарисовать полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawPolygonPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawPolygonPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полигоне

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawPolyline (метод)

Нарисовать полилинию по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawPolyline ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawPolyline(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полилинии

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawPolylinePtr (метод)

Нарисовать полилинию по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawPolylinePtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawPolylinePtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полилинии

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawRectangle (метод)

Нарисовать прямоугольник без заливки

Синтаксис

[Visual Basic 6]
Sub DrawRectangle ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure DrawRectangle(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X прямоугольника
Ymin
[in] Минимальная координата по Y прямоугольника
Xmax
[in] Максимальная координата по X прямоугольника
Ymax
[in] Максимальная координата по Y прямоугольника

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.DrawText (метод)

Нарисовать текстовую надпись

Синтаксис

[Visual Basic 6]
Sub DrawText ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Text As String _
)

[Delphi]
procedure DrawText(
   const X: Double;
   const Y: Double;
   const Text: WideString
)

Описание параметров

X
[in] Координата X левого верхнего угла надписи
Y
[in] Координата Y левого верхнего угла надписи
Text
[in] Текст надписи

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.FillEllipse (метод)

Нарисовать закрашенный эллипс

Синтаксис

[Visual Basic 6]
Sub FillEllipse ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure FillEllipse(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.FillPolygon (метод)

Закрасить полигон по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub FillPolygon ( _
   ByVal Points() As Double _
)

[Delphi]
procedure FillPolygon(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полигона

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.FillPolygonPtr (метод)

Закрасить полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub FillPolygonPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure FillPolygonPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полигоне

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.FillRectangle (метод)

Нарисовать закрашенный прямоугольник

Синтаксис

[Visual Basic 6]
Sub FillRectangle ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure FillRectangle(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.FontSelect (метод)

Установить текущие параметры шрифта

Синтаксис

[Visual Basic 6]
Sub FontSelect ( _
   ByVal FontName As String, _
   ByVal Size As Double, _
   ByVal FontStyles As FontStyleConstants _
)

[Delphi]
procedure FontSelect(
   const FontName: WideString;
   const Size: Double;
   const FontStyles: FontStyleConstants
)

Описание параметров

FontName
[in] Имя шрифта
Size
[in] Размер шрифта
FontStyles
[in] Набор флагов, задающих стиль шрифта (любая комбинация жирности, наклона, подчеркивания и зачеркивания)

Смотри также

Class CustomSurface, Enum FontStyleConstants, Group Рисование изображений


CustomSurface.Graphics (свойство)

Получить объект TGPGraphics в режиме GDI+

Синтаксис

[Visual Basic 6]
ReadOnly Property Graphics As OLE_HANDLE

[Delphi]
{только для чтения} property Graphics: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.NeedSurfacePoints (метод)

Получить временный кусок памяти с вещественными точками. Внимание! Метод небезопасный и может быть использовать только при внутрипроцессной активации COM-сервера

Синтаксис

[Visual Basic 6]
Function NeedSurfacePoints ( _
   ByVal PointNumber As Long _
) As Long

[Delphi]
function NeedSurfacePoints(
   const PointNumber: Integer
): Integer

Описание параметров

PointNumber
[in] Требуемое число вещественных точек в выделенной области памяти

Возвращаемое значение

Возвращает указатель на кусок памяти с вещественными точками

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.PenSelect (метод)

Установить текущие параметры пера

Синтаксис

[Visual Basic 6]
Sub PenSelect ( _
   ByVal Color As OLE_COLOR, _
   ByVal Width As Double, _
   ByVal PenStyle As PenStyleConstants _
)

[Delphi]
procedure PenSelect(
   const Color: OLE_COLOR;
   const Width: Double;
   const PenStyle: PenStyleConstants
)

Описание параметров

Color
[in] Цвет пера
Width
[in] Ширина пера
PenStyle
[in] Стиль пера

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class CustomSurface, Enum PenStyleConstants, Group Рисование изображений


CustomSurface.PointModelToSurface (метод)

Преобразовать точку из системы координат модели в целочисленную систему координат устройства вывода

Синтаксис

[Visual Basic 6]
Sub PointModelToSurface ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   SurfaceX As Long, _
   SurfaceY As Long _
)

[Delphi]
procedure PointModelToSurface(
   const ModelX: Double;
   const ModelY: Double;
   out SurfaceX: Integer;
   out SurfaceY: Integer
)

Описание параметров

ModelX
[in] Исходная координата X в модельной системе координат
ModelY
[in] Исходная координата Y в модельной системе координат
SurfaceX
[out] Расчитанная координата X в системе координат поверхности
SurfaceY
[out] Расчитанная координата Y в системе координат поверхности

Смотри также

Class CustomSurface, Group Рисование изображений


CustomSurface.PointsModelToSurface (метод)

Преобразовать точки из системы координат модели в целочисленную систему координат устройства вывода. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub PointsModelToSurface ( _
   ByVal ModelPoints As Double, _
   ByVal SurfacePoints As Long, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure PointsModelToSurface(
   const ModelPoints: Double;
   const SurfacePoints: Integer;
   const PointNumber: Integer
)

Описание параметров

ModelPoints
[in] Массив исходных точек в модельной системе координат
SurfacePoints
[in] Массив расчитанных точек в системе координат поверхности
PointNumber
[in] Общее число точек

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class CustomSurface, Group Рисование изображений


Константы DateTimeConstants

Тип данных даты и времени

Константы

Константа | Значение | Описание
Constant DateTimeBoth | 0 | Дата и время
Constant DateTimeTimeOnly | 1 | Только время
Constant DateTimeDateOnly | 2 | Только дата

Где используются

Класс | Член класса
Class BrowserItem | Property DateTimeStyle (свойство)

Смотри также

Group Базы данных


Константы DropDownAlignConstants

Тип положения выпадающего списка

Константы

Константа | Значение | Описание
Constant DropDownAlignLeft | 0 | Выровнять выпадающий список по левой стороне
Constant DropDownAlignRight | 1 | Выровнять выпадающий список по правой стороне
Constant DropDownAlignCenter | 2 | Выровнять выпадающий список по центру

Где используются

Класс | Член класса
Class BrowserItem | Property DropDownAlign (свойство)

Смотри также

Group Пользовательский интерфейс


Класс FlatPoint

Точка с вещественными координатами в плоской системе координат контейнера

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.FlatPoint

ClassID = {600A0009-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property X | Координата X точки
Property Y | Координата Y точки

Методы класса

Имя | Описание
Method DistanceTo | Вычисляет расстояние от данной точки до другой заданнной

Где используется

Класс | Член класса
Class Application | Method CreateFlatPoint (метод)
Class CustomContainer | Property ViewOrigin (свойство) Property VisibleFlatCenter (свойство) Method TrackFixedRect (метод) Method TrackFlatPoint (метод) Method ZoomToPoint (метод) Method ZoomToView (метод)
Class ICommonApplication | Method CreateFlatPoint (метод)
Class LayeredComposition | Method Paint (метод)
Class VectorContainer | Property ViewOrigin (свойство) Property VisibleFlatCenter (свойство) Method TrackFixedRect (метод) Method TrackFlatPoint (метод) Method ZoomToPoint (метод) Method ZoomToView (метод)

Смотри также

Group Геометрия


FlatPoint.DistanceTo (метод)

Вычисляет расстояние от данной точки до другой заданнной

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Double

[Delphi]
function DistanceTo(
   const X: Double;
   const Y: Double
): Double

Описание параметров

X
[in] Координата X заданной точки
Y
[in] Координата Y заданной точки

Возвращаемое значение

Возвращает расстояние от данной точки до другой заданнной

Смотри также

Class FlatPoint, Group Геометрия


FlatPoint.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class FlatPoint, Group Геометрия


FlatPoint.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class FlatPoint, Group Геометрия


Класс FlatRect

Прямоугольник с вещественными координатами в плоской системе координат контейнера

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.FlatRect

ClassID = {600A000F-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Height (только для чтения) | Высота прямоугольника
Property Width (только для чтения) | Ширина прямоугольника
Property Xmax | Координата правой стороны прямоугольника (большая координата по оси X)
Property Xmin | Координата левой стороны прямоугольника (меньшая координата по оси X)
Property Ymax | Координата верхней стороны прямоугольника (большая координата по оси Y)
Property Ymin | Координата нижней стороны прямоугольника (меньшая координата по оси Y)

Методы класса

Имя | Описание
Method DistanceTo | Вычисляет расстояние от указанной точки на плоскости до данного прямоугольника
Method IsInside | Проверить, попадает ли заданная точка внутрь прямоугольника

Где используется

Класс | Член класса
Class Application | Method CreateFlatRect (метод)
Class CustomContainer | Property ImageFlatExtent (свойство) Property VisibleFlatExtent (свойство) Method CheckInView (метод) Method TrackFixedRect (метод) Method TrackFlatCircle (метод) Method TrackFlatEllipse (метод) Method TrackFlatFillCircle (метод) Method TrackFlatFillEllipse (метод) Method TrackFlatFillRectangle (метод) Method TrackFlatRectangle (метод) Method TrackZoomRect (метод) Method TrackZoomRectangle (метод) Method ZoomToExtent (метод) Method ZoomToRect (метод)
Class ICommonApplication | Method CreateFlatRect (метод)
Class VectorContainer | Property ImageFlatExtent (свойство) Property VisibleFlatExtent (свойство) Method CheckInView (метод) Method TrackFixedRect (метод) Method TrackFlatCircle (метод) Method TrackFlatEllipse (метод) Method TrackFlatFillCircle (метод) Method TrackFlatFillEllipse (метод) Method TrackFlatFillRectangle (метод) Method TrackFlatRectangle (метод) Method TrackZoomRect (метод) Method TrackZoomRectangle (метод) Method ZoomToExtent (метод) Method ZoomToRect (метод)

Смотри также

Group Геометрия


FlatRect.DistanceTo (метод)

Вычисляет расстояние от указанной точки на плоскости до данного прямоугольника

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const X: Double;
   const Y: Double;
   const InsideDistance: Double
): Double

Описание параметров

X
[in] Координата X заданной точки
Y
[in] Координата X заданной точки
InsideDistance
[in] Возвращаемое значение функции для случая, когда заданная точка оказалась внутри прямоугольника

Возвращаемое значение

Возвращает расстояние от данного прямоугольника до заданнной точки

Смотри также

Class FlatRect, Group Геометрия


FlatRect.Height (свойство)

Высота прямоугольника

Синтаксис

[Visual Basic 6]
ReadOnly Property Height As Double

[Delphi]
{только для чтения} property Height: Double

Смотри также

Class FlatRect, Group Геометрия


FlatRect.IsInside (метод)

Проверить, попадает ли заданная точка внутрь прямоугольника

Синтаксис

[Visual Basic 6]
Function IsInside ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Boolean

[Delphi]
function IsInside(
   const X: Double;
   const Y: Double
): WordBool

Описание параметров

X
[in] Координата X проверяемой точки
Y
[in] Координата Y проверяемой точки

Возвращаемое значение

Возвращает True, если проверяемая точка попадает внутрь данного прямоугольника

Смотри также

Class FlatRect, Group Геометрия


FlatRect.Width (свойство)

Ширина прямоугольника

Синтаксис

[Visual Basic 6]
ReadOnly Property Width As Double

[Delphi]
{только для чтения} property Width: Double

Смотри также

Class FlatRect, Group Геометрия


FlatRect.Xmax (свойство)

Координата правой стороны прямоугольника (большая координата по оси X)

Синтаксис

[Visual Basic 6]
Property Xmax As Double

[Delphi]
property Xmax: Double

Смотри также

Class FlatRect, Group Геометрия


FlatRect.Xmin (свойство)

Координата левой стороны прямоугольника (меньшая координата по оси X)

Синтаксис

[Visual Basic 6]
Property Xmin As Double

[Delphi]
property Xmin: Double

Смотри также

Class FlatRect, Group Геометрия


FlatRect.Ymax (свойство)

Координата верхней стороны прямоугольника (большая координата по оси Y)

Синтаксис

[Visual Basic 6]
Property Ymax As Double

[Delphi]
property Ymax: Double

Смотри также

Class FlatRect, Group Геометрия


FlatRect.Ymin (свойство)

Координата нижней стороны прямоугольника (меньшая координата по оси Y)

Синтаксис

[Visual Basic 6]
Property Ymin As Double

[Delphi]
property Ymin: Double

Смотри также

Class FlatRect, Group Геометрия


Интерфейс IActionEvents

Обрабочик событий действия

Наследование

IUnknown Class IActionEvents

Методы интерфейса

Имя | Описание
Method Execute | Выполнить действие
Method Update | Обновить параметры действия

Где используется

Класс | Член класса
Class Action | Method Advise (метод)

Смотри также

Group Пользовательский интерфейс


IActionEvents.Execute (метод)

Выполнить действие

Синтаксис

[Visual Basic 6]
Sub Execute ( _
   ByVal Action As Action _
)

[Delphi]
procedure Execute(
   const Action: Action
)

Описание параметров

Action
[in] Выполняемое действие

Смотри также

Class Action, Interface IActionEvents, Group Пользовательский интерфейс


IActionEvents.Update (метод)

Обновить параметры действия

Синтаксис

[Visual Basic 6]
Sub Update ( _
   ByVal Action As Action _
)

[Delphi]
procedure Update(
   const Action: Action
)

Описание параметров

Action
[in] Обновляемое действие

Смотри также

Class Action, Interface IActionEvents, Group Пользовательский интерфейс


Интерфейс ICommonApplication

Приложение

Наследование

IDispatch Class ICommonApplication Class Application

Свойства интерфейса

Имя | Описание
Property ApplicationHandle (только для чтения) | Handle приложения
Property AutoUnloadUnusedLibraries | Автоматически выгружать неиспользуемые библиотеки ActiveX
Property ExeName (только для чтения) | Имя главного выполняемого файла системы
Property ExePath (только для чтения) | Путь к исполняемому exe-файлу приложения
Property HelpFile | Имя файла помощи
Property HintEnable | Отображать подсказки в системе
Property HintHidePause | Задержка перед удалением подсказки с экрана в милисекундах
Property HintNextPause | Задержка перед показом следующей подсказки в милисекундах
Property HintShortcuts | Включить в подсказки сочетания клавиш
Property HintShowPause | Задержка перед отображением подсказки в милисекундах
Property Images (только для чтения) | Стандартный набор картинок
Property Plugins (только для чтения) | Менеджер дополнительных модулей к системе
Property Version (только для чтения) | Информация о версии приложения

Методы интерфейса

Имя | Описание
Method BeginProgress | Инициализация строки прогресса
Method BeginSubProgress | Разрешить вложение прогрессов, выделив в текущем прогрессе допустимый диапазон
Method CreateFlatPoint | Создать новую двумерную точку с плоскими координатами контейнера
Method CreateFlatRect | Создать новый прямоугольник с плоскими координатами контейнера
Method CreateModelParallelogram | Создать новый параллелограмм с вещественными модельными координатами
Method CreateModelPoint | Создать новую двумерную точку с вещественными модельными координатами
Method CreateModelRect | Создать новый прямоугольник с вещественными модельными координатами
Method CreateParallelogram | Создать новый параллелограмм с целочисленными координатами
Method CreatePoint | Создать новую двумерную точку с целочисленными координатами
Method CreatePoint3D | Создать новую трёхмерную точку с целочисленными координатами
Method CreateRect | Создать новый прямоугольник с целочисленными координатами
Method DisableAllWindows | Временно полностью запретить все окна системы
Method EnableAllWindows | Разрешает окна системы, ранее запрещённые вызовом DisableAllWindows
Method EndProgress | Закончить процесс вывода строки прогресса
Method EndSubProgress | Запретить вложенные прогрессы
Method GetProgress | Получить значение статуса текущей длительной операции
Method GotoWeb | Открыть домашнюю Web-страницу системы
Method IncProgress | Увеличить статус операции на заданный шаг (по умолчанию на 1)
Method IsFeatureAvailable | Проверить, доступна ли лицензия на указанный объект
Method IsProgressVisible | В настоящий момент бежит строка Progress?
Method IsSubProgress | В настоящий момент бежит строка вложенного прогресса?
Method Log | Записывает указанное сообщение в файл журнала
Method RegisterCursor | Зарегистрировать в системе новый курсор или заменить старый
Method SendEmail | Послать письмо разработчиками системы по электронной почте
Method SetProgress | Установить текущее положение строки прогресса
Method SetProgressText | Задать отображаемый текст строки прогресса
Method ShowError | Вывести в диалоге краткое сообщение об ошибке
Method ShowMessage | Вывести в диалоге краткое сообщение
Method ShowWarning | Вывести в диалоге краткое предупреждение
Method Terminate | Завершить работу системы
Method UnloadUnusedLibraries | Выгружает из памяти неиспользуемые библиотеки с объектами ActiveX

Смотри также

Enum CursorConstants, Class FlatPoint, Class FlatRect, Class Images, Enum LogPrecisionConstants, Class ModelParallelogram, Class ModelPoint, Class ModelRect, Class Parallelogram, Class PluginManager, Class Point, Class Point3D, Class Rect, Class Version


ICommonApplication.ApplicationHandle (свойство)

Handle приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property ApplicationHandle As OLE_HANDLE

[Delphi]
{только для чтения} property ApplicationHandle: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Interface ICommonApplication


ICommonApplication.AutoUnloadUnusedLibraries (свойство)

Автоматически выгружать неиспользуемые библиотеки ActiveX

Синтаксис

[Visual Basic 6]
Property AutoUnloadUnusedLibraries As Boolean

[Delphi]
property AutoUnloadUnusedLibraries: WordBool

Смотри также

Interface ICommonApplication


ICommonApplication.BeginProgress (метод)

Инициализация строки прогресса

Синтаксис

[Visual Basic 6]
Sub BeginProgress ( _
   ByVal Caption As String, _
   ByVal MaxValue As Long _
)

[Delphi]
procedure BeginProgress(
   const Caption: WideString;
   const MaxValue: Integer
)

Описание параметров

Caption
[in] Заголовок, выводимый в строке прогресса
MaxValue
[in] Макcимальное значение, до которого будет идти прогресс

Смотри также

Interface ICommonApplication


ICommonApplication.BeginSubProgress (метод)

Разрешить вложение прогрессов, выделив в текущем прогрессе допустимый диапазон

Синтаксис

[Visual Basic 6]
Sub BeginSubProgress ( _
   ByVal MainMinPos As Long, _
   ByVal MainMaxPos As Long _
)

[Delphi]
procedure BeginSubProgress(
   const MainMinPos: Integer;
   const MainMaxPos: Integer
)

Описание параметров

MainMinPos
[in] Минимальное значение диапазона в родительском прогрессе
MainMaxPos
[in] Максимальное значение диапазона в родительском прогрессе

Смотри также

Interface ICommonApplication


ICommonApplication.CreateFlatPoint (метод)

Создать новую двумерную точку с плоскими координатами контейнера

Синтаксис

[Visual Basic 6]
Function CreateFlatPoint As FlatPoint

[Delphi]
function CreateFlatPoint: FlatPoint

Возвращаемое значение

Возвращает новую двумерную точку с плоскими координатами контейнера

Смотри также

Class FlatPoint, Interface ICommonApplication


ICommonApplication.CreateFlatRect (метод)

Создать новый прямоугольник с плоскими координатами контейнера

Синтаксис

[Visual Basic 6]
Function CreateFlatRect As FlatRect

[Delphi]
function CreateFlatRect: FlatRect

Возвращаемое значение

Возвращает новый прямоугольник с плоскими координатами контейнера

Смотри также

Class FlatRect, Interface ICommonApplication


ICommonApplication.CreateModelParallelogram (метод)

Создать новый параллелограмм с вещественными модельными координатами

Синтаксис

[Visual Basic 6]
Function CreateModelParallelogram As ModelParallelogram

[Delphi]
function CreateModelParallelogram: ModelParallelogram

Возвращаемое значение

Возвращает новый прямоугольник с вещественными модельными координатами

Смотри также

Interface ICommonApplication, Class ModelParallelogram


ICommonApplication.CreateModelPoint (метод)

Создать новую двумерную точку с вещественными модельными координатами

Синтаксис

[Visual Basic 6]
Function CreateModelPoint As ModelPoint

[Delphi]
function CreateModelPoint: ModelPoint

Возвращаемое значение

Возвращает двумерную новую точку с вещественными модельными координатами

Смотри также

Interface ICommonApplication, Class ModelPoint


ICommonApplication.CreateModelRect (метод)

Создать новый прямоугольник с вещественными модельными координатами

Синтаксис

[Visual Basic 6]
Function CreateModelRect As ModelRect

[Delphi]
function CreateModelRect: ModelRect

Возвращаемое значение

Возвращает новый прямоугольник с вещественными модельными координатами

Смотри также

Interface ICommonApplication, Class ModelRect


ICommonApplication.CreateParallelogram (метод)

Создать новый параллелограмм с целочисленными координатами

Синтаксис

[Visual Basic 6]
Function CreateParallelogram As Parallelogram

[Delphi]
function CreateParallelogram: Parallelogram

Возвращаемое значение

Возвращает новый прямоугольник с целочисленными координатами

Смотри также

Interface ICommonApplication, Class Parallelogram


ICommonApplication.CreatePoint (метод)

Создать новую двумерную точку с целочисленными координатами

Синтаксис

[Visual Basic 6]
Function CreatePoint As Point

[Delphi]
function CreatePoint: Point

Возвращаемое значение

Возвращает новую двумерную точку с целочисленными координатами

Смотри также

Interface ICommonApplication, Class Point


ICommonApplication.CreatePoint3D (метод)

Создать новую трёхмерную точку с целочисленными координатами

Синтаксис

[Visual Basic 6]
Function CreatePoint3D As Point3D

[Delphi]
function CreatePoint3D: Point3D

Возвращаемое значение

Возвращает новую трёхмерную точку с целочисленными координатами

Смотри также

Interface ICommonApplication, Class Point3D


ICommonApplication.CreateRect (метод)

Создать новый прямоугольник с целочисленными координатами

Синтаксис

[Visual Basic 6]
Function CreateRect As Rect

[Delphi]
function CreateRect: Rect

Возвращаемое значение

Возвращает новый прямоугольник с целочисленными координатами

Смотри также

Interface ICommonApplication, Class Rect


ICommonApplication.DisableAllWindows (метод)

Временно полностью запретить все окна системы

Синтаксис

[Visual Basic 6]
Function DisableAllWindows As Long

[Delphi]
function DisableAllWindows: Integer

Возвращаемое значение

Возвращает код, который нужно обязательно передать в функцию EnableAllWindows после окончании взаимодействия с программой

Смотри также

Interface ICommonApplication


ICommonApplication.EnableAllWindows (метод)

Разрешает окна системы, ранее запрещённые вызовом DisableAllWindows

Синтаксис

[Visual Basic 6]
Sub EnableAllWindows ( _
   ByVal Cookie As Long _
)

[Delphi]
procedure EnableAllWindows(
   const Cookie: Integer
)

Описание параметров

Cookie
[in] Код, который был получен в предыдущем вызове DisableAllWindows

Смотри также

Interface ICommonApplication


ICommonApplication.EndProgress (метод)

Закончить процесс вывода строки прогресса

Синтаксис

[Visual Basic 6]
Sub EndProgress

[Delphi]
procedure EndProgress

Смотри также

Interface ICommonApplication


ICommonApplication.EndSubProgress (метод)

Запретить вложенные прогрессы

Синтаксис

[Visual Basic 6]
Sub EndSubProgress

[Delphi]
procedure EndSubProgress

Смотри также

Interface ICommonApplication


ICommonApplication.ExeName (свойство)

Имя главного выполняемого файла системы

Синтаксис

[Visual Basic 6]
ReadOnly Property ExeName As String

[Delphi]
{только для чтения} property ExeName: WideString

Смотри также

Interface ICommonApplication


ICommonApplication.ExePath (свойство)

Путь к исполняемому exe-файлу приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property ExePath As String

[Delphi]
{только для чтения} property ExePath: WideString

Смотри также

Interface ICommonApplication


ICommonApplication.GetProgress (метод)

Получить значение статуса текущей длительной операции

Синтаксис

[Visual Basic 6]
Function GetProgress As Long

[Delphi]
function GetProgress: Integer

Возвращаемое значение

Возвращает текущее положение отметки прогресса

Смотри также

Interface ICommonApplication


ICommonApplication.GotoWeb (метод)

Открыть домашнюю Web-страницу системы

Синтаксис

[Visual Basic 6]
Sub GotoWeb

[Delphi]
procedure GotoWeb

Смотри также

Interface ICommonApplication


ICommonApplication.HelpFile (свойство)

Имя файла помощи

Синтаксис

[Visual Basic 6]
Property HelpFile As String

[Delphi]
property HelpFile: WideString

Смотри также

Interface ICommonApplication


ICommonApplication.HintEnable (свойство)

Отображать подсказки в системе

Синтаксис

[Visual Basic 6]
Property HintEnable As Boolean

[Delphi]
property HintEnable: WordBool

Смотри также

Interface ICommonApplication


ICommonApplication.HintHidePause (свойство)

Задержка перед удалением подсказки с экрана в милисекундах

Синтаксис

[Visual Basic 6]
Property HintHidePause As Long

[Delphi]
property HintHidePause: Integer

Смотри также

Interface ICommonApplication


ICommonApplication.HintNextPause (свойство)

Задержка перед показом следующей подсказки в милисекундах

Синтаксис

[Visual Basic 6]
Property HintNextPause As Long

[Delphi]
property HintNextPause: Integer

Смотри также

Interface ICommonApplication


ICommonApplication.HintShortcuts (свойство)

Включить в подсказки сочетания клавиш

Синтаксис

[Visual Basic 6]
Property HintShortcuts As Boolean

[Delphi]
property HintShortcuts: WordBool

Смотри также

Interface ICommonApplication


ICommonApplication.HintShowPause (свойство)

Задержка перед отображением подсказки в милисекундах

Синтаксис

[Visual Basic 6]
Property HintShowPause As Long

[Delphi]
property HintShowPause: Integer

Смотри также

Interface ICommonApplication


ICommonApplication.Images (свойство)

Стандартный набор картинок

Синтаксис

[Visual Basic 6]
ReadOnly Property Images As Images

[Delphi]
{только для чтения} property Images: Images

Смотри также

Interface ICommonApplication, Class Images


ICommonApplication.IncProgress (метод)

Увеличить статус операции на заданный шаг (по умолчанию на 1)

Синтаксис

[Visual Basic 6]
Sub IncProgress ( _
   [ByVal Step As Long = 1] _
)

[Delphi]
procedure IncProgress(
   const Step: Integer
)

Описание параметров

Step
[in] Шаг, на который следует увеличить текущее состояние прогресса

Смотри также

Interface ICommonApplication


ICommonApplication.IsFeatureAvailable (метод)

Проверить, доступна ли лицензия на указанный объект

Синтаксис

[Visual Basic 6]
Function IsFeatureAvailable ( _
   ByVal FeatureName As String _
) As Boolean

[Delphi]
function IsFeatureAvailable(
   const FeatureName: WideString
): WordBool

Описание параметров

FeatureName
[in] Имя лицензируемого объекта

Возвращаемое значение

Возвращает True, если объект лицензирован

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface ICommonApplication


ICommonApplication.IsProgressVisible (метод)

В настоящий момент бежит строка Progress?

Синтаксис

[Visual Basic 6]
Function IsProgressVisible As Boolean

[Delphi]
function IsProgressVisible: WordBool

Возвращаемое значение

Возвращает True, если в настоящее время строка прогресса видна

Смотри также

Interface ICommonApplication


ICommonApplication.IsSubProgress (метод)

В настоящий момент бежит строка вложенного прогресса?

Синтаксис

[Visual Basic 6]
Function IsSubProgress As Boolean

[Delphi]
function IsSubProgress: WordBool

Возвращаемое значение

Возвращает True, если в настоящий момент бежит строка вложенного прогресса

Смотри также

Interface ICommonApplication


ICommonApplication.Log (метод)

Записывает указанное сообщение в файл журнала

Синтаксис

[Visual Basic 6]
Sub Log ( _
   ByVal Message As String, _
   [ByVal LogPrecision As LogPrecisionConstants = 1] _
)

[Delphi]
procedure Log(
   const Message: WideString;
   const LogPrecision: LogPrecisionConstants
)

Описание параметров

Message
[in] Сообщение для записи в файл журнала
LogPrecision
[in] Уровень детализации при журналировани

Смотри также

Interface ICommonApplication, Enum LogPrecisionConstants


ICommonApplication.Plugins (свойство)

Менеджер дополнительных модулей к системе

Синтаксис

[Visual Basic 6]
ReadOnly Property Plugins As PluginManager

[Delphi]
{только для чтения} property Plugins: PluginManager

Смотри также

Interface ICommonApplication, Class PluginManager


ICommonApplication.RegisterCursor (метод)

Зарегистрировать в системе новый курсор или заменить старый

Синтаксис

[Visual Basic 6]
Sub RegisterCursor ( _
   ByVal Cursor As CursorConstants, _
   ByVal HCursor As OLE_HANDLE _
)

[Delphi]
procedure RegisterCursor(
   const Cursor: CursorConstants;
   const HCursor: OLE_HANDLE
)

Описание параметров

Cursor
[in] Номер курсора (можно использовать стандартный из списка CursorConstants или любой другой номер)
HCursor
[in] HCursor нового курсора

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Enum CursorConstants, Interface ICommonApplication


ICommonApplication.SendEmail (метод)

Послать письмо разработчиками системы по электронной почте

Синтаксис

[Visual Basic 6]
Sub SendEmail

[Delphi]
procedure SendEmail

Смотри также

Interface ICommonApplication


ICommonApplication.SetProgress (метод)

Установить текущее положение строки прогресса

Синтаксис

[Visual Basic 6]
Sub SetProgress ( _
   ByVal Position As Long _
)

[Delphi]
procedure SetProgress(
   const Position: Integer
)

Описание параметров

Position
[in] Установить текущую позицию строки прогресса

Смотри также

Interface ICommonApplication


ICommonApplication.SetProgressText (метод)

Задать отображаемый текст строки прогресса

Синтаксис

[Visual Basic 6]
Sub SetProgressText ( _
   ByVal Caption As String _
)

[Delphi]
procedure SetProgressText(
   const Caption: WideString
)

Описание параметров

Caption
[in] Текст надписи прогресса

Смотри также

Interface ICommonApplication


ICommonApplication.ShowError (метод)

Вывести в диалоге краткое сообщение об ошибке

Синтаксис

[Visual Basic 6]
Sub ShowError ( _
   ByVal Text As String _
)

[Delphi]
procedure ShowError(
   const Text: WideString
)

Описание параметров

Text
[in] Текст сообщения

Смотри также

Interface ICommonApplication


ICommonApplication.ShowMessage (метод)

Вывести в диалоге краткое сообщение

Синтаксис

[Visual Basic 6]
Sub ShowMessage ( _
   ByVal Msg As String _
)

[Delphi]
procedure ShowMessage(
   const Msg: WideString
)

Описание параметров

Msg
[in] Текст выводимого сообщения

Смотри также

Interface ICommonApplication


ICommonApplication.ShowWarning (метод)

Вывести в диалоге краткое предупреждение

Синтаксис

[Visual Basic 6]
Sub ShowWarning ( _
   ByVal Text As String _
)

[Delphi]
procedure ShowWarning(
   const Text: WideString
)

Описание параметров

Text
[in] Текст предупреждения

Смотри также

Interface ICommonApplication


ICommonApplication.Terminate (метод)

Завершить работу системы

Синтаксис

[Visual Basic 6]
Sub Terminate

[Delphi]
procedure Terminate

Смотри также

Interface ICommonApplication


ICommonApplication.UnloadUnusedLibraries (метод)

Выгружает из памяти неиспользуемые библиотеки с объектами ActiveX

Синтаксис

[Visual Basic 6]
Sub UnloadUnusedLibraries

[Delphi]
procedure UnloadUnusedLibraries

Смотри также

Interface ICommonApplication


ICommonApplication.Version (свойство)

Информация о версии приложения

Синтаксис

[Visual Basic 6]
ReadOnly Property Version As Version

[Delphi]
{только для чтения} property Version: Version

Смотри также

Interface ICommonApplication, Class Version


Интерфейс IVideoRowViewerHandler

Обработчик событий от видеоряда

Наследование

IUnknown Class IVideoRowViewerHandler

Методы интерфейса

Имя | Описание
Method FrameChange | Вызывается при смене кадра
Method WindowClosed |

Где используется

Класс | Член класса
Class VideoRowViewer | Method Init (метод)


IVideoRowViewerHandler.FrameChange (метод)

Вызывается при смене кадра

Синтаксис

[Visual Basic 6]
Function FrameChange ( _
   ByVal FrameIndex As Long, _
   ByVal PK As Double, _
   ByVal DateTime As Double _
) As Long

[Delphi]
function FrameChange(
   const FrameIndex: Integer;
   const PK: Double;
   const DateTime: Double
): HResult

Описание параметров

FrameIndex
[in]
PK
[in]
DateTime
[in]

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IVideoRowViewerHandler


IVideoRowViewerHandler.WindowClosed (метод)

Синтаксис

[Visual Basic 6]
Function WindowClosed As Long

[Delphi]
function WindowClosed: HResult

Возвращаемое значение

Функция возвращает значение типа Long.

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Interface IVideoRowViewerHandler


Константы LineTextPlacementConstants

Стиль размещения подписей вдоль линий

Константы

Константа | Значение | Описание
Constant LineTextPlacementTopCopy | 0 | Над линией много
Constant LineTextPlacementTopLeft | 1 | Над линией слева
Constant LineTextPlacementTopCenter | 2 | Над линией по центру
Constant LineTextPlacementTopRight | 3 | Над линией справа
Constant LineTextPlacementCenterCopy | 4 | По центру много
Constant LineTextPlacementCenterLeft | 5 | По центру слева
Constant LineTextPlacementCenterCenter | 6 | По центру по центру
Constant LineTextPlacementCenterRight | 7 | По центру справа
Constant LineTextPlacementBottomCopy | 8 | Под линией много
Constant LineTextPlacementBottomLeft | 9 | Под линией слева
Constant LineTextPlacementBottomCenter | 10 | Под линией по центру
Constant LineTextPlacementBottomRight | 11 | Под линией справа

Смотри также

Group Карты


Класс ModelParallelogram

Параллелограмм с вещественными координатами в модельном пространстве

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ModelParallelogram

ClassID = {600A0015-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Corner | Координаты углов параллелограмма (Index должен быть от 0 до 3, при этом угол с индексом 3 запрещен на изменение, т.к. он вычисляется по координатам других углов)
Property Height | Высота параллелограмма
Property MainCorner | Координаты левого нижнего угла параллелограмма (этот же угол доступен как Corner(1))
Property Rotation | Поворот параллелограмма
Property Skew | Наклон параллелограмма
Property Square (только для чтения) | Площадь параллелограмма
Property Width | Ширина параллелограмма

Методы класса

Имя | Описание
Method DistanceTo | Вычисляет расстояние от указанной точки на плоскости до данного параллелограмма
Method IsInside | Проверить, попадает ли заданная точка внутрь параллелограмма

Где используется

Класс | Член класса
Class Application | Method CreateModelParallelogram (метод)
Class CoordinateTransformator | Method FlatRectToModelParallelogram (метод)
Class ICommonApplication | Method CreateModelParallelogram (метод)

Смотри также

Class ModelPoint, Group Геометрия


ModelParallelogram.Corner (свойство)

Координаты углов параллелограмма (Index должен быть от 0 до 3, при этом угол с индексом 3 запрещен на изменение, т.к. он вычисляется по координатам других углов)

Синтаксис

[Visual Basic 6]
Property Corner As ModelPoint

[Delphi]
property Corner: ModelPoint

Смотри также

Class ModelParallelogram, Class ModelPoint, Group Геометрия


ModelParallelogram.DistanceTo (метод)

Вычисляет расстояние от указанной точки на плоскости до данного параллелограмма

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const X: Double;
   const Y: Double;
   const InsideDistance: Double
): Double

Описание параметров

X
[in] Координата X заданной точки
Y
[in] Координата Y заданной точки
InsideDistance
[in] Возвращаемое значение функции для случая, когда заданная точка оказалась внутри полигона

Возвращаемое значение

Возвращает расстояние от указанной точки на плоскости до данного параллелограмма

Смотри также

Class ModelParallelogram, Group Геометрия


ModelParallelogram.Height (свойство)

Высота параллелограмма

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class ModelParallelogram, Group Геометрия


ModelParallelogram.IsInside (метод)

Проверить, попадает ли заданная точка внутрь параллелограмма

Синтаксис

[Visual Basic 6]
Function IsInside ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Boolean

[Delphi]
function IsInside(
   const X: Double;
   const Y: Double
): WordBool

Описание параметров

X
[in] Координата X проверяемой точки
Y
[in] Координата Y проверяемой точки

Возвращаемое значение

Возвращает True, если проверяемая точка попадает внутрь данного параллелограмма

Смотри также

Class ModelParallelogram, Group Геометрия


ModelParallelogram.MainCorner (свойство)

Координаты левого нижнего угла параллелограмма (этот же угол доступен как Corner(1))

Синтаксис

[Visual Basic 6]
Property MainCorner As ModelPoint

[Delphi]
property MainCorner: ModelPoint

Смотри также

Class ModelParallelogram, Class ModelPoint, Group Геометрия


ModelParallelogram.Rotation (свойство)

Поворот параллелограмма

Синтаксис

[Visual Basic 6]
Property Rotation As Double

[Delphi]
property Rotation: Double

Смотри также

Class ModelParallelogram, Group Геометрия


ModelParallelogram.Skew (свойство)

Наклон параллелограмма

Синтаксис

[Visual Basic 6]
Property Skew As Double

[Delphi]
property Skew: Double

Смотри также

Class ModelParallelogram, Group Геометрия


ModelParallelogram.Square (свойство)

Площадь параллелограмма

Синтаксис

[Visual Basic 6]
ReadOnly Property Square As Double

[Delphi]
{только для чтения} property Square: Double

Смотри также

Class ModelParallelogram, Group Геометрия


ModelParallelogram.Width (свойство)

Ширина параллелограмма

Синтаксис

[Visual Basic 6]
Property Width As Double

[Delphi]
property Width: Double

Смотри также

Class ModelParallelogram, Group Геометрия


Класс ModelPoint

Точка с вещественными координатами в системе координат модели

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ModelPoint

ClassID = {600A000B-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property X | Координата X точки
Property Y | Координата Y точки

Методы класса

Имя | Описание
Method DistanceTo | Вычисляет расстояние от данной точки до другой заданнной

Где используется

Класс | Член класса
Class AdditionalPoint | Property Position (свойство)
Class Application | Method CreateModelPoint (метод)
Class By3PointAdditionalPoint | Property Position (свойство) Property RangePoints (свойство)
Class CADTriangulation | Method CalcSimpleAlongSegment (метод) Method EnumerateProfile (метод) Method EnumerateProfilePoints (метод) Method FindTriangles (метод) Method GetObjectAtPoint (метод) Method GetObjectsAtPoint (метод) Method GetSoftRibAtPoint (метод)
Class CompositionLayer | Method GetDescriptionAtPos (метод)
Class ContainerBookmark | Property ViewCenter (свойство)
Class CoordinateTransformator | Property ViewOrigin (свойство) Method PointDeviceToFlat (метод) Method PointDeviceToModel (метод) Method PointFlatToDevice (метод) Method PointFlatToModel (метод) Method PointFlatToSurface (метод) Method PointModelToDevice (метод) Method PointModelToFlat (метод) Method PointModelToSurface (метод) Method PointSurfaceToFlat (метод) Method PointSurfaceToModel (метод) Method RotationModelToDevice (метод)
Class CustomContainer | Property LastViewOrg (свойство) Method TrackModelPoint (метод)
Class CustomSurveyPoint | Property Position (свойство)
Class FieldTraversePoint | Property Position (свойство)
Class Figure | Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class FolderLayer | Method GetDescriptionAtPos (метод)
Class GeoPoint | Property Position (свойство)
Class ICommonApplication | Method CreateModelPoint (метод)
Class IntersectionAdditionalPoint | Property Position (свойство) Property RangePoints (свойство)
Class KnownAdditionalPoint | Property Position (свойство)
Class LinkedGeoPoint | Property Position (свойство)
Class MeasureAdditionalPoint | Property Position (свойство) Property RangePoints (свойство)
Class ModelParallelogram | Property Corner (свойство) Property MainCorner (свойство)
Class Projection | Method GetDirectionAt (метод) Method GetHorzScaleAt (метод) Method GetScaleAt (метод) Method GetVertScaleAt (метод) Method PointProject (метод) Method PointUnproject (метод)
Class RangeAdditionalPoint | Property Position (свойство) Property RangePoints (свойство)
Class ShapeFigure | Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapeMultipart | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapeMultipoint | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapeMultipointM | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapeMultipointZ | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePoint | Property Point (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePointM | Property Point (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePointZ | Property Point (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePolygon | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePolygonM | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePolygonZ | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePolyline | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePolylineM | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class ShapePolylineZ | Property Points (свойство) Method Center (метод) Method Centroid (метод) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class SurveyPoint | Property Position (свойство)
Class Triangulation | Method CalcSimpleAlongSegment (метод) Method EnumerateProfile (метод) Method EnumerateProfilePoints (метод) Method FindTriangles (метод) Method GetObjectAtPoint (метод) Method GetObjectsAtPoint (метод) Method GetSoftRibAtPoint (метод)
Class TrnArea | Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class TrnBreak | Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class TrnFigure | Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class TrnFlip | Property Points (свойство) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class TrnModifier | Property Points (свойство) Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class TrnNode | Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class TrnRib | Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class TrnSource | Method GetAdjustPointPos (метод) Method GetContactPos (метод)
Class TrnTriangle | Method GetAdjustPointPos (метод) Method GetContactPos (метод) Method LineIntersection (метод) Method RibIntersection (метод)
Class VectorContainer | Property LastViewOrg (свойство) Method TrackModelPoint (метод)
Class VectorLayer | Method ExecuteFigureVerb (метод) Method GetDescriptionAtPos (метод) Method GetFigureAtPos (метод) Method GetFiguresAtPos (метод) Method GetFigureVerb (метод) Method GetSnapPoint (метод) Method HotLinkExists (метод)

Смотри также

Group Геометрия


ModelPoint.DistanceTo (метод)

Вычисляет расстояние от данной точки до другой заданнной

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Double

[Delphi]
function DistanceTo(
   const X: Double;
   const Y: Double
): Double

Описание параметров

X
[in] Координата X заданной точки
Y
[in] Координата Y заданной точки

Возвращаемое значение

Возвращает расстояние от данной точки до другой заданнной

Смотри также

Class ModelPoint, Group Геометрия


ModelPoint.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class ModelPoint, Group Геометрия


ModelPoint.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class ModelPoint, Group Геометрия


Класс ModelRect

Прямоугольник с вещественными координатами в пространстве модели

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ModelRect

ClassID = {600A0011-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Height (только для чтения) | Высота прямоугольника
Property Width (только для чтения) | Ширина прямоугольника
Property Xmax | Наибольшая координата прямоугольника по оси X
Property Xmin | Наименьшая координата прямоугольника по оси X
Property Ymax | Наибольшая координата прямоугольника по оси Y
Property Ymin | Наименьшая координата прямоугольника по оси Y

Методы класса

Имя | Описание
Method DistanceTo | Вычисляет расстояние от указанной точки на плоскости до данного прямоугольника
Method IsInside | Проверить, попадает ли заданная точка внутрь прямоугольника

Где используется

Класс | Член класса
Class Application | Method CreateModelRect (метод)
Class CADTriangulation | Property Bounds (свойство) Method CalcHashInRect (метод) Method CalcSimpleHashInRect (метод) Method GetObjectsAtRect (метод)
Class CompositionLayer | Property FullExtent (свойство)
Class CoordinateTransformator | Property ViewRect (свойство) Method FlatRectToModelParallelogram (метод) Method RectDeviceToFlat (метод) Method RectFlatToDevice (метод) Method RectFlatToSurface (метод) Method RectSurfaceToFlat (метод) Method SimpleRectFlatToModel (метод) Method SimpleRectModelToFlat (метод)
Class Figure | Property Bounds (свойство)
Class FigureBase | Property Bounds (свойство)
Class FigureSet | Property Bounds (свойство)
Class FolderLayer | Property FullExtent (свойство)
Class ICommonApplication | Method CreateModelRect (метод)
Class ShapeFigure | Property Bounds (свойство)
Class ShapeFile | Property Bounds (свойство)
Class ShapeMultipart | Property Bounds (свойство)
Class ShapeMultipoint | Property Bounds (свойство)
Class ShapeMultipointM | Property Bounds (свойство)
Class ShapeMultipointZ | Property Bounds (свойство)
Class ShapePoint | Property Bounds (свойство)
Class ShapePointM | Property Bounds (свойство)
Class ShapePointZ | Property Bounds (свойство)
Class ShapePolygon | Property Bounds (свойство)
Class ShapePolygonM | Property Bounds (свойство)
Class ShapePolygonZ | Property Bounds (свойство)
Class ShapePolyline | Property Bounds (свойство)
Class ShapePolylineM | Property Bounds (свойство)
Class ShapePolylineZ | Property Bounds (свойство)
Class Triangulation | Property Bounds (свойство) Method CalcHashInRect (метод) Method CalcSimpleHashInRect (метод) Method GetObjectsAtRect (метод)
Class TrnArea | Property Bounds (свойство)
Class TrnBreak | Property Bounds (свойство)
Class TrnFigure | Property Bounds (свойство)
Class TrnFlip | Property Bounds (свойство)
Class TrnModifier | Property Bounds (свойство)
Class TrnNode | Property Bounds (свойство)
Class TrnRib | Property Bounds (свойство)
Class TrnSource | Property Bounds (свойство)
Class TrnTriangle | Property Bounds (свойство)
Class VectorContainer | Property SelectionExtent (свойство)
Class VectorLayer | Property FullExtent (свойство) Method GetFiguresAtRect (метод)

Смотри также

Group Геометрия


ModelRect.DistanceTo (метод)

Вычисляет расстояние от указанной точки на плоскости до данного прямоугольника

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const X: Double;
   const Y: Double;
   const InsideDistance: Double
): Double

Описание параметров

X
[in] Координата X заданной точки
Y
[in] Координата X заданной точки
InsideDistance
[in] Возвращаемое значение функции для случая, когда заданная точка оказалась внутри прямоугольника

Возвращаемое значение

Возвращает расстояние от данного прямоугольника до заданнной точки

Смотри также

Class ModelRect, Group Геометрия


ModelRect.Height (свойство)

Высота прямоугольника

Синтаксис

[Visual Basic 6]
ReadOnly Property Height As Double

[Delphi]
{только для чтения} property Height: Double

Смотри также

Class ModelRect, Group Геометрия


ModelRect.IsInside (метод)

Проверить, попадает ли заданная точка внутрь прямоугольника

Синтаксис

[Visual Basic 6]
Function IsInside ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Boolean

[Delphi]
function IsInside(
   const X: Double;
   const Y: Double
): WordBool

Описание параметров

X
[in] Координата X проверяемой точки
Y
[in] Координата Y проверяемой точки

Возвращаемое значение

Возвращает True, если проверяемая точка попадает внутрь данного прямоугольника

Смотри также

Class ModelRect, Group Геометрия


ModelRect.Width (свойство)

Ширина прямоугольника

Синтаксис

[Visual Basic 6]
ReadOnly Property Width As Double

[Delphi]
{только для чтения} property Width: Double

Смотри также

Class ModelRect, Group Геометрия


ModelRect.Xmax (свойство)

Наибольшая координата прямоугольника по оси X

Синтаксис

[Visual Basic 6]
Property Xmax As Double

[Delphi]
property Xmax: Double

Смотри также

Class ModelRect, Group Геометрия


ModelRect.Xmin (свойство)

Наименьшая координата прямоугольника по оси X

Синтаксис

[Visual Basic 6]
Property Xmin As Double

[Delphi]
property Xmin: Double

Смотри также

Class ModelRect, Group Геометрия


ModelRect.Ymax (свойство)

Наибольшая координата прямоугольника по оси Y

Синтаксис

[Visual Basic 6]
Property Ymax As Double

[Delphi]
property Ymax: Double

Смотри также

Class ModelRect, Group Геометрия


ModelRect.Ymin (свойство)

Наименьшая координата прямоугольника по оси Y

Синтаксис

[Visual Basic 6]
Property Ymin As Double

[Delphi]
property Ymin: Double

Смотри также

Class ModelRect, Group Геометрия


Класс ModelSurface

Поверхность для рисования в системе координат модели

Наследование

CustomSurface Class ModelSurface

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.ModelSurface

ClassID = {60120008-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Canvas (только для чтения) | Получить TCanvas в режиме GDI
Property DC (только для чтения) | Получить контекст устройства в режиме GDI
Property Graphics (только для чтения) | Получить объект TGPGraphics в режиме GDI+
Property Mode (только для чтения) | Режим работы поверхности

Методы класса

Имя | Описание
Method AttachDC | Подключить поверхность для рисования на заданный DC
Method AttachWindow | Подключить поверхность для рисования в заданное окно
Method BrushSelect | Установить текущие параметры кисти
Method DrawArc | Нарисовать дугу эллипса, задав объемлющий эллипс прямоугольник и точки, определяющие начало и конец дуги
Method DrawBeziers | Нарисовать последовательность кривых Безье по точкам, переданным в массиве вещественных чисел
Method DrawBeziersPtr | Нарисовать последовательность кривых Безье по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawEllipse | Нарисовать эллипс без заливки
Method DrawLine | Нарисовать отрезок прямой
Method DrawPolygon | Нарисовать полигон по точкам, переданным в массиве вещественных чисел
Method DrawPolygonPtr | Нарисовать полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawPolyline | Нарисовать полилинию по точкам, переданным в массиве вещественных чисел
Method DrawPolylinePtr | Нарисовать полилинию по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method DrawRectangle | Нарисовать прямоугольник без заливки
Method DrawText | Нарисовать текстовую надпись
Method FillEllipse | Нарисовать закрашенный эллипс
Method FillPolygon | Закрасить полигон по точкам, переданным в массиве вещественных чисел
Method FillPolygonPtr | Закрасить полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера
Method FillRectangle | Нарисовать закрашенный прямоугольник
Method FontSelect | Установить текущие параметры шрифта
Method NeedSurfacePoints | Получить временный кусок памяти с вещественными точками. Внимание! Метод небезопасный и может быть использовать только при внутрипроцессной активации COM-сервера
Method PenSelect | Установить текущие параметры пера
Method PointModelToSurface | Преобразовать точку из системы координат модели в целочисленную систему координат устройства вывода
Method PointsModelToSurface | Преобразовать точки из системы координат модели в целочисленную систему координат устройства вывода. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Смотри также

Enum BrushStyleConstants, Enum FontStyleConstants, Enum PenStyleConstants, Enum SurfaceModeConstants, Group Рисование изображений


ModelSurface.AttachDC (метод)

Подключить поверхность для рисования на заданный DC

Синтаксис

[Visual Basic 6]
Sub AttachDC ( _
   ByVal HDC As OLE_HANDLE, _
   [ByVal GdiPlusMode As Boolean = False] _
)

[Delphi]
procedure AttachDC(
   const HDC: OLE_HANDLE;
   const GdiPlusMode: WordBool
)

Описание параметров

HDC
[in] HDC устройства вывода
GdiPlusMode
[in] Следует ли включать режим GDI+

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.AttachWindow (метод)

Подключить поверхность для рисования в заданное окно

Синтаксис

[Visual Basic 6]
Sub AttachWindow ( _
   ByVal HWnd As OLE_HANDLE, _
   [ByVal GdiPlusMode As Boolean = False] _
)

[Delphi]
procedure AttachWindow(
   const HWnd: OLE_HANDLE;
   const GdiPlusMode: WordBool
)

Описание параметров

HWnd
[in] HWnd окна вывода
GdiPlusMode
[in] Следует ли включать режим GDI+

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.BrushSelect (метод)

Установить текущие параметры кисти

Синтаксис

[Visual Basic 6]
Sub BrushSelect ( _
   ByVal Color As OLE_COLOR, _
   ByVal BrushStyle As BrushStyleConstants _
)

[Delphi]
procedure BrushSelect(
   const Color: OLE_COLOR;
   const BrushStyle: BrushStyleConstants
)

Описание параметров

Color
[in] Цвет кисти
BrushStyle
[in] Стиль заливки

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Enum BrushStyleConstants, Class ModelSurface, Group Рисование изображений


ModelSurface.Canvas (свойство)

Получить TCanvas в режиме GDI

Синтаксис

[Visual Basic 6]
ReadOnly Property Canvas As OLE_HANDLE

[Delphi]
{только для чтения} property Canvas: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DC (свойство)

Получить контекст устройства в режиме GDI

Синтаксис

[Visual Basic 6]
ReadOnly Property DC As OLE_HANDLE

[Delphi]
{только для чтения} property DC: OLE_HANDLE

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawArc (метод)

Нарисовать дугу эллипса, задав объемлющий эллипс прямоугольник и точки, определяющие начало и конец дуги

Синтаксис

[Visual Basic 6]
Sub DrawArc ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double, _
   ByVal StartX As Double, _
   ByVal StartY As Double, _
   ByVal EndX As Double, _
   ByVal EndY As Double _
)

[Delphi]
procedure DrawArc(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double;
   const StartX: Double;
   const StartY: Double;
   const EndX: Double;
   const EndY: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника
StartX
[in] Координата X точки, определяющей начало дуги
StartY
[in] Координата Y точки, определяющей начало дуги
EndX
[in] Координата X точки, определяющей конец дуги
EndY
[in] Координата Y точки, определяющей конец дуги

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawBeziers (метод)

Нарисовать последовательность кривых Безье по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawBeziers ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawBeziers(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты контрольных точек последовательности кривых Безье

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawBeziersPtr (метод)

Нарисовать последовательность кривых Безье по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawBeziersPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawBeziersPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив контрольных точек в модельной системе координат
PointNumber
[in] Общее число котрольных точек поледовательности линий Безье

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawEllipse (метод)

Нарисовать эллипс без заливки

Синтаксис

[Visual Basic 6]
Sub DrawEllipse ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure DrawEllipse(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X прямоугольника
Ymin
[in] Минимальная координата по Y прямоугольника
Xmax
[in] Максимальная координата по X прямоугольника
Ymax
[in] Максимальная координата по Y прямоугольника

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawLine (метод)

Нарисовать отрезок прямой

Синтаксис

[Visual Basic 6]
Sub DrawLine ( _
   ByVal X1 As Double, _
   ByVal Y1 As Double, _
   ByVal X2 As Double, _
   ByVal Y2 As Double _
)

[Delphi]
procedure DrawLine(
   const X1: Double;
   const Y1: Double;
   const X2: Double;
   const Y2: Double
)

Описание параметров

X1
[in] Координата X начальной точки отрезка
Y1
[in] Координата Y начальной точки отрезка
X2
[in] Координата X конечной точки отрезка
Y2
[in] Координата Y конечной точки отрезка

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawPolygon (метод)

Нарисовать полигон по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawPolygon ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawPolygon(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полигона

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawPolygonPtr (метод)

Нарисовать полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawPolygonPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawPolygonPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полигоне

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawPolyline (метод)

Нарисовать полилинию по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub DrawPolyline ( _
   ByVal Points() As Double _
)

[Delphi]
procedure DrawPolyline(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полилинии

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawPolylinePtr (метод)

Нарисовать полилинию по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub DrawPolylinePtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure DrawPolylinePtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полилинии

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawRectangle (метод)

Нарисовать прямоугольник без заливки

Синтаксис

[Visual Basic 6]
Sub DrawRectangle ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure DrawRectangle(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X прямоугольника
Ymin
[in] Минимальная координата по Y прямоугольника
Xmax
[in] Максимальная координата по X прямоугольника
Ymax
[in] Максимальная координата по Y прямоугольника

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.DrawText (метод)

Нарисовать текстовую надпись

Синтаксис

[Visual Basic 6]
Sub DrawText ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Text As String _
)

[Delphi]
procedure DrawText(
   const X: Double;
   const Y: Double;
   const Text: WideString
)

Описание параметров

X
[in] Координата X левого верхнего угла надписи
Y
[in] Координата Y левого верхнего угла надписи
Text
[in] Текст надписи

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.FillEllipse (метод)

Нарисовать закрашенный эллипс

Синтаксис

[Visual Basic 6]
Sub FillEllipse ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure FillEllipse(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.FillPolygon (метод)

Закрасить полигон по точкам, переданным в массиве вещественных чисел

Синтаксис

[Visual Basic 6]
Sub FillPolygon ( _
   ByVal Points() As Double _
)

[Delphi]
procedure FillPolygon(
   const Points: PSafeArray
)

Описание параметров

Points
[in] Массив вещественных чисел, последовательно задающих X и Y координаты точек полигона

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.FillPolygonPtr (метод)

Закрасить полигон по указателю на массив вещественных точек. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub FillPolygonPtr ( _
   ByVal Points As Double, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure FillPolygonPtr(
   const Points: Double;
   const PointNumber: Integer
)

Описание параметров

Points
[in] Указатель на массив модельных точек
PointNumber
[in] Общее число точек в полигоне

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.FillRectangle (метод)

Нарисовать закрашенный прямоугольник

Синтаксис

[Visual Basic 6]
Sub FillRectangle ( _
   ByVal Xmin As Double, _
   ByVal Ymin As Double, _
   ByVal Xmax As Double, _
   ByVal Ymax As Double _
)

[Delphi]
procedure FillRectangle(
   const Xmin: Double;
   const Ymin: Double;
   const Xmax: Double;
   const Ymax: Double
)

Описание параметров

Xmin
[in] Минимальная координата по X объемлющего эллипс прямоугольника
Ymin
[in] Минимальная координата по Y объемлющего эллипс прямоугольника
Xmax
[in] Максимальная координата по X объемлющего эллипс прямоугольника
Ymax
[in] Максимальная координата по Y объемлющего эллипс прямоугольника

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.FontSelect (метод)

Установить текущие параметры шрифта

Синтаксис

[Visual Basic 6]
Sub FontSelect ( _
   ByVal FontName As String, _
   ByVal Size As Double, _
   ByVal FontStyles As FontStyleConstants _
)

[Delphi]
procedure FontSelect(
   const FontName: WideString;
   const Size: Double;
   const FontStyles: FontStyleConstants
)

Описание параметров

FontName
[in] Имя шрифта
Size
[in] Размер шрифта
FontStyles
[in] Набор флагов, задающих стиль шрифта (любая комбинация жирности, наклона, подчеркивания и зачеркивания)

Смотри также

Enum FontStyleConstants, Class ModelSurface, Group Рисование изображений


ModelSurface.Graphics (свойство)

Получить объект TGPGraphics в режиме GDI+

Синтаксис

[Visual Basic 6]
ReadOnly Property Graphics As OLE_HANDLE

[Delphi]
{только для чтения} property Graphics: OLE_HANDLE

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.Mode (свойство)

Режим работы поверхности

Синтаксис

[Visual Basic 6]
ReadOnly Property Mode As SurfaceModeConstants

[Delphi]
{только для чтения} property Mode: SurfaceModeConstants

Смотри также

Class ModelSurface, Enum SurfaceModeConstants, Group Рисование изображений


ModelSurface.NeedSurfacePoints (метод)

Получить временный кусок памяти с вещественными точками. Внимание! Метод небезопасный и может быть использовать только при внутрипроцессной активации COM-сервера

Синтаксис

[Visual Basic 6]
Function NeedSurfacePoints ( _
   ByVal PointNumber As Long _
) As Long

[Delphi]
function NeedSurfacePoints(
   const PointNumber: Integer
): Integer

Описание параметров

PointNumber
[in] Требуемое число вещественных точек в выделенной области памяти

Возвращаемое значение

Возвращает указатель на кусок памяти с вещественными точками

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.PenSelect (метод)

Установить текущие параметры пера

Синтаксис

[Visual Basic 6]
Sub PenSelect ( _
   ByVal Color As OLE_COLOR, _
   ByVal Width As Double, _
   ByVal PenStyle As PenStyleConstants _
)

[Delphi]
procedure PenSelect(
   const Color: OLE_COLOR;
   const Width: Double;
   const PenStyle: PenStyleConstants
)

Описание параметров

Color
[in] Цвет пера
Width
[in] Ширина пера
PenStyle
[in] Стиль пера

Ограничения

Данный член класса имеет ограничения при межпроцессных вызовах. Это связано с тем, что типы, используемые в описании данного члена класса, не могут быть корректно переданы по OLE-протоколу между различными процессами в операционной системе Windows. Так, например, между процессами нельзя передать различные хендлы (типов HDC, HWnd, HPen, HBrush и др.), т.к. они всегда жестко привязываются к конкретному процессу и не имеют смысла в другом процессе. Таким образом, такие члены класса можно использовать только при написании дополнительных модулей (реализованных в виде динамических библиотек и потому работающих в одном процессе с самой системой), а также при написании программ на встроенном в систему языке Visual Basic for Applications. Удаленный межпроцессный вызов таких методов будет некорректен.

Смотри также

Class ModelSurface, Enum PenStyleConstants, Group Рисование изображений


ModelSurface.PointModelToSurface (метод)

Преобразовать точку из системы координат модели в целочисленную систему координат устройства вывода

Синтаксис

[Visual Basic 6]
Sub PointModelToSurface ( _
   ByVal ModelX As Double, _
   ByVal ModelY As Double, _
   SurfaceX As Long, _
   SurfaceY As Long _
)

[Delphi]
procedure PointModelToSurface(
   const ModelX: Double;
   const ModelY: Double;
   out SurfaceX: Integer;
   out SurfaceY: Integer
)

Описание параметров

ModelX
[in] Исходная координата X в модельной системе координат
ModelY
[in] Исходная координата Y в модельной системе координат
SurfaceX
[out] Расчитанная координата X в системе координат поверхности
SurfaceY
[out] Расчитанная координата Y в системе координат поверхности

Смотри также

Class ModelSurface, Group Рисование изображений


ModelSurface.PointsModelToSurface (метод)

Преобразовать точки из системы координат модели в целочисленную систему координат устройства вывода. Внимание! Метод небезопасный и не может быть применен при удаленном вызове COM-сервера

Синтаксис

[Visual Basic 6]
Sub PointsModelToSurface ( _
   ByVal ModelPoints As Double, _
   ByVal SurfacePoints As Long, _
   ByVal PointNumber As Long _
)

[Delphi]
procedure PointsModelToSurface(
   const ModelPoints: Double;
   const SurfacePoints: Integer;
   const PointNumber: Integer
)

Описание параметров

ModelPoints
[in] Массив исходных точек в модельной системе координат
SurfacePoints
[in] Массив расчитанных точек в системе координат поверхности
PointNumber
[in] Общее число точек

Ограничения

Данный член класса имеет жесткие ограничения по применению. Он не может быть вызван из макро-языков программирования типа Visual Basic. Тем не менее данный метод можно вызывать в более низкоуровневых языках типа C/C++ или Delphi, принимая соответствующие меры предосторожности. Обычно эти ограничения вызваны тем, что данный член класса имеет параметры, несовместимые со стандартным соглашением передачи параметров, используемым в технологии COM.

Смотри также

Class ModelSurface, Group Рисование изображений


Константы ModelUnitConstants

Виды единиц измерения

Константы

Константа | Значение | Описание
Constant ModelUnitUnknown | 0 | Неизвестно
Constant ModelUnitDegrees | 1 | Градусы
Constant ModelUnitMillimeters | 2 | Миллиметры
Constant ModelUnitCentimeters | 3 | Сантиметры
Constant ModelUnitMeters | 4 | Метры
Constant ModelUnitKilometers | 5 | Километры
Constant ModelUnitInches | 6 | Дюймы
Constant ModelUnitFeet | 7 | Футы
Constant ModelUnitYards | 8 | Ярды
Constant ModelUnitEngMiles | 9 | Английские мили
Constant ModelUnitNautMiles | 10 | Морские мили

Где используются

Класс | Член класса
Class Composition | Property DistanceUnit (свойство) Property ModelUnit (свойство) Property SquareUnit (свойство)
Class CoordinateTransformator | Property FlatUnit (свойство)
Class LayeredComposition | Property DistanceUnit (свойство) Property ModelUnit (свойство) Property SquareUnit (свойство)
Class Projection | Property MapUnit (свойство) Method GetFlatUnit (метод)

Смотри также

Group Карты


Класс Parallelogram

Параллелограмм с целочисленными координатами

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Parallelogram

ClassID = {600A0013-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Corner | Координаты углов параллелограмма (Index должен быть от 0 до 3, при этом угол с индексом 3 запрещен на изменение, т.к. он вычисляется по координатам других углов)
Property Height | Высота параллелограмма
Property MainCorner | Координаты левого нижнего угла параллелограмма (этот же угол доступен как Corner(1))
Property Rotation | Поворот параллелограмма
Property Skew | Наклон параллелограмма
Property Square (только для чтения) | Площадь параллелограмма
Property Width | Ширина параллелограмма

Методы класса

Имя | Описание
Method DistanceTo | Вычисляет расстояние от указанной точки на плоскости до данного параллелограмма
Method IsInside | Проверить, попадает ли заданная точка внутрь параллелограмма

Где используется

Класс | Член класса
Class Application | Method CreateParallelogram (метод)
Class ICommonApplication | Method CreateParallelogram (метод)

Смотри также

Class Point, Group Геометрия


Parallelogram.Corner (свойство)

Координаты углов параллелограмма (Index должен быть от 0 до 3, при этом угол с индексом 3 запрещен на изменение, т.к. он вычисляется по координатам других углов)

Синтаксис

[Visual Basic 6]
Property Corner As Point

[Delphi]
property Corner: Point

Смотри также

Class Parallelogram, Class Point, Group Геометрия


Parallelogram.DistanceTo (метод)

Вычисляет расстояние от указанной точки на плоскости до данного параллелограмма

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const X: Double;
   const Y: Double;
   const InsideDistance: Double
): Double

Описание параметров

X
[in] Координата X заданной точки
Y
[in] Координата Y заданной точки
InsideDistance
[in] Возвращаемое значение функции для случая, когда заданная точка оказалась внутри полигона

Возвращаемое значение

Возвращает расстояние от указанной точки на плоскости до данного параллелограмма

Смотри также

Class Parallelogram, Group Геометрия


Parallelogram.Height (свойство)

Высота параллелограмма

Синтаксис

[Visual Basic 6]
Property Height As Double

[Delphi]
property Height: Double

Смотри также

Class Parallelogram, Group Геометрия


Parallelogram.IsInside (метод)

Проверить, попадает ли заданная точка внутрь параллелограмма

Синтаксис

[Visual Basic 6]
Function IsInside ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Boolean

[Delphi]
function IsInside(
   const X: Double;
   const Y: Double
): WordBool

Описание параметров

X
[in] Координата X проверяемой точки
Y
[in] Координата Y проверяемой точки

Возвращаемое значение

Возвращает True, если проверяемая точка попадает внутрь данного параллелограмма

Смотри также

Class Parallelogram, Group Геометрия


Parallelogram.MainCorner (свойство)

Координаты левого нижнего угла параллелограмма (этот же угол доступен как Corner(1))

Синтаксис

[Visual Basic 6]
Property MainCorner As Point

[Delphi]
property MainCorner: Point

Смотри также

Class Parallelogram, Class Point, Group Геометрия


Parallelogram.Rotation (свойство)

Поворот параллелограмма

Синтаксис

[Visual Basic 6]
Property Rotation As Double

[Delphi]
property Rotation: Double

Смотри также

Class Parallelogram, Group Геометрия


Parallelogram.Skew (свойство)

Наклон параллелограмма

Синтаксис

[Visual Basic 6]
Property Skew As Double

[Delphi]
property Skew: Double

Смотри также

Class Parallelogram, Group Геометрия


Parallelogram.Square (свойство)

Площадь параллелограмма

Синтаксис

[Visual Basic 6]
ReadOnly Property Square As Double

[Delphi]
{только для чтения} property Square: Double

Смотри также

Class Parallelogram, Group Геометрия


Parallelogram.Width (свойство)

Ширина параллелограмма

Синтаксис

[Visual Basic 6]
Property Width As Double

[Delphi]
property Width: Double

Смотри также

Class Parallelogram, Group Геометрия


Класс Point

Точка с целочисленными координатами

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Point

ClassID = {600A0005-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property X | Координата X точки
Property Y | Координата Y точки

Методы класса

Имя | Описание
Method DistanceTo | Вычисляет расстояние от данной точки до другой заданнной

Где используется

Класс | Член класса
Class Application | Method CreatePoint (метод)
Class CoordinateTransformator | Property DeviceOrigin (свойство) Method PointDeviceToFlat (метод) Method PointDeviceToModel (метод) Method PointFlatToDevice (метод) Method PointModelToDevice (метод)
Class CustomContainer | Method PanToPoint (метод)
Class ICommonApplication | Method CreatePoint (метод)
Class Parallelogram | Property Corner (свойство) Property MainCorner (свойство)
Class VectorContainer | Property CurrentPopupPoint (свойство) Method PanToPoint (метод)

Смотри также

Group Геометрия


Класс Point3D

Трёхмерная точка с вещественными координатами

Создание экземпляра класса

Для данного класса запрещено прямое создание экземпляров. Вы можете получить экземпляр данного класса только с помощью свойств и методов других классов.

Свойства класса

Имя | Описание
Property X | Координата X точки
Property Y | Координата Y точки
Property Z | Высота Z точки

Где используется

Класс | Член класса
Class Application | Method CreatePoint3D (метод)
Class CADTriangulation | Method NormalAtPoint (метод) Method Thicken (метод)
Class ICommonApplication | Method CreatePoint3D (метод)
Class IEnumerateProfile | Method Register (метод)
Class IEnumerateProfilePoints | Method Register (метод)
Class Triangulation | Method NormalAtPoint (метод) Method Thicken (метод)
Class TrnArea | Property Points (свойство)
Class TrnBreak | Property Points (свойство)
Class TrnNode | Property Position (свойство)
Class TrnSource | Property Position (свойство)
Class TrnTriangle | Method InterpolateRibCenter (метод) Method LineIntersection (метод) Method NodeNormal (метод) Method RibIntersection (метод)

Смотри также

Group Геометрия


Point3D.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
Property X As Double

[Delphi]
property X: Double

Смотри также

Class Point3D, Group Геометрия


Point3D.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
Property Y As Double

[Delphi]
property Y: Double

Смотри также

Class Point3D, Group Геометрия


Point3D.Z (свойство)

Высота Z точки

Синтаксис

[Visual Basic 6]
Property Z As Double

[Delphi]
property Z: Double

Смотри также

Class Point3D, Group Геометрия


Point.DistanceTo (метод)

Вычисляет расстояние от данной точки до другой заданнной

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Double

[Delphi]
function DistanceTo(
   const X: Double;
   const Y: Double
): Double

Описание параметров

X
[in] Координата X заданной точки
Y
[in] Координата Y заданной точки

Возвращаемое значение

Возвращает расстояние от данной точки до другой заданнной

Смотри также

Class Point, Group Геометрия


Point.X (свойство)

Координата X точки

Синтаксис

[Visual Basic 6]
Property X As Long

[Delphi]
property X: Integer

Смотри также

Class Point, Group Геометрия


Point.Y (свойство)

Координата Y точки

Синтаксис

[Visual Basic 6]
Property Y As Long

[Delphi]
property Y: Integer

Смотри также

Class Point, Group Геометрия


Константы PointTextPlacementConstants

Стиль размещения подписей вокруг точек

Константы

Константа | Значение | Описание
Constant PointTextPlacementRightBottom | 0 | По горизонтали - справа, по вертикали - снизу
Constant PointTextPlacementBottom | 1 | По горизонтали - по центру, по вертикали - снизу
Constant PointTextPlacementLeftBottom | 2 | По горизонтали - слева, по вертикали - снизу
Constant PointTextPlacementRight | 3 | По горизонтали - справа, по вертикали - по центру
Constant PointTextPlacementCenter | 4 | По горизонтали - по центру, по вертикали - по центру
Constant PointTextPlacementLeft | 5 | По горизонтали - слева, по вертикали - по центру
Constant PointTextPlacementRightTop | 6 | По горизонтали - справа, по вертикали - сверху
Constant PointTextPlacementTop | 7 | По горизонтали - по центру, по вертикали - сверху
Constant PointTextPlacementLeftTop | 8 | По горизонтали - слева, по вертикали - сверху

Где используются

Класс | Член класса
Class TopoTextStyle | Property Placement (свойство)

Смотри также

Group Карты


Класс Rect

Прямоугольник с целочисленными координатами

Создание экземпляра класса

Для создания экземпляра данного класса вы можете использовать следующие идентификаторы:

ProgID = IndorCAD.Rect

ClassID = {600A000D-170B-11D7-A13A-0050BF5A903A}

Свойства класса

Имя | Описание
Property Bottom | Координата нижней стороны прямоугольника (меньшая координата по оси Y)
Property Height (только для чтения) | Высота прямоугольника
Property Left | Координата левой стороны прямоугольника (меньшая координата по оси X)
Property Right | Координата правой стороны прямоугольника (большая координата по оси X)
Property Top | Координата верхней стороны прямоугольника (большая координата по оси Y)
Property Width (только для чтения) | Ширина прямоугольника
Property Xmax | Координата правой стороны прямоугольника (большая координата по оси X)
Property Xmin | Координата левой стороны прямоугольника (меньшая координата по оси X)
Property Ymax | Координата верхней стороны прямоугольника (большая координата по оси Y)
Property Ymin | Координата нижней стороны прямоугольника (меньшая координата по оси Y)

Методы класса

Имя | Описание
Method DistanceTo | Вычисляет расстояние от указанной точки на плоскости до данного прямоугольника
Method IsInside | Проверить, попадает ли заданная точка внутрь прямоугольника

Где используется

Класс | Член класса
Class Application | Method CreateRect (метод)
Class CoordinateTransformator | Property DeviceRect (свойство) Method RectDeviceToFlat (метод) Method RectFlatToDevice (метод)
Class ICommonApplication | Method CreateRect (метод)
Class LayeredComposition | Method Paint (метод)

Смотри также

Group Геометрия


Rect.Bottom (свойство)

Координата нижней стороны прямоугольника (меньшая координата по оси Y)

Синтаксис

[Visual Basic 6]
Property Bottom As Long

[Delphi]
property Bottom: Integer

Смотри также

Class Rect, Group Геометрия


Rect.DistanceTo (метод)

Вычисляет расстояние от указанной точки на плоскости до данного прямоугольника

Синтаксис

[Visual Basic 6]
Function DistanceTo ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   [ByVal InsideDistance As Double = 0] _
) As Double

[Delphi]
function DistanceTo(
   const X: Double;
   const Y: Double;
   const InsideDistance: Double
): Double

Описание параметров

X
[in] Координата X заданной точки
Y
[in] Координата X заданной точки
InsideDistance
[in] Возвращаемое значение функции для случая, когда заданная точка оказалась внутри прямоугольника

Возвращаемое значение

Возвращает расстояние от данного прямоугольника до заданнной точки

Смотри также

Class Rect, Group Геометрия


Rect.Height (свойство)

Высота прямоугольника

Синтаксис

[Visual Basic 6]
ReadOnly Property Height As Long

[Delphi]
{только для чтения} property Height: Integer

Смотри также

Class Rect, Group Геометрия


Rect.IsInside (метод)

Проверить, попадает ли заданная точка внутрь прямоугольника

Синтаксис

[Visual Basic 6]
Function IsInside ( _
   ByVal X As Double, _
   ByVal Y As Double _
) As Boolean

[Delphi]
function IsInside(
   const X: Double;
   const Y: Double
): WordBool

Описание параметров

X
[in] Координата X проверяемой точки
Y
[in] Координата Y проверяемой точки

Возвращаемое значение

Возвращает True, если проверяемая точка попадает внутрь данного прямоугольника

Смотри также

Class Rect, Group Геометрия


Rect.Left (свойство)

Координата левой стороны прямоугольника (меньшая координата по оси X)

Синтаксис

[Visual Basic 6]
Property Left As Long

[Delphi]
property Left: Integer

Смотри также

Class Rect, Group Геометрия


Rect.Right (свойство)

Координата правой стороны прямоугольника (большая координата по оси X)

Синтаксис

[Visual Basic 6]
Property Right As Long

[Delphi]
property Right: Integer

Смотри также

Class Rect, Group Геометрия


Rect.Top (свойство)

Координата верхней стороны прямоугольника (большая координата по оси Y)

Синтаксис

[Visual Basic 6]
Property Top As Long

[Delphi]
property Top: Integer

Смотри также

Class Rect, Group Геометрия


Rect.Width (свойство)

Ширина прямоугольника

Синтаксис

[Visual Basic 6]
ReadOnly Property Width As Long

[Delphi]
{только для чтения} property Width: Integer

Смотри также

Class Rect, Group Геометрия


Rect.Xmax (свойство)

Координата правой стороны прямоугольника (большая координата по оси X)

Синтаксис

[Visual Basic 6]
Property Xmax As Long

[Delphi]
property Xmax: Integer

Смотри также

Class Rect, Group Геометрия


Rect.Xmin (свойство)

Координата левой стороны прямоугольника (меньшая координата по оси X)

Синтаксис

[Visual Basic 6]
Property Xmin As Long

[Delphi]
property Xmin: Integer

Смотри также

Class Rect, Group Геометрия


Rect.Ymax (свойство)

Координата верхней стороны прямоугольника (большая координата по оси Y)

Синтаксис

[Visual Basic 6]
Property Ymax As Long

[Delphi]
property Ymax: Integer

Смотри также

Class Rect, Group Геометрия


Rect.Ymin (свойство)

Координата нижней стороны прямоугольника (меньшая координата по оси Y)

Синтаксис

[Visual Basic 6]
Property Ymin As Long

[Delphi]
property Ymin: Integer

Смотри также

Class Rect, Group Геометрия


Константы RegionTextPlacementConstants

Стиль размещения подписей вокруг полигонов

Константы

Константа | Значение | Описание
Constant RegionTextPlacementTop | 0 | Сверху
Constant RegionTextPlacementCenter | 1 | В центре
Constant RegionTextPlacementBottom | 2 | Снизу

Смотри также

Group Карты


Константы ScrollConstants

Тип полос скроллинга

Константы

Константа | Значение | Описание
Constant ScrollNone | 0 | Полос нет
Constant ScrollHorizontal | 1 | Горизонтальные
Constant ScrollVertical | 2 | Вертикальные
Constant ScrollBoth | 3 | Вертикальные и горизонтальные

Где используются

Класс | Член класса
Class BrowserItem | Property MemoScrollbars (свойство)

Смотри также

Group Пользовательский интерфейс


Константы SurfaceModeConstants

Режим работы поверхности для рисования

Константы

Константа | Значение | Описание
Constant SurfaceModeNone | 0 | Поверхность не активирована
Constant SurfaceModeGdi | 1 | Поверхность работает в режиме GDI
Constant SurfaceModeGdiPlus | 2 | Поверхность работает в режиме GDI+

Где используются

Класс | Член класса
Class ModelSurface | Property Mode (свойство)

Смотри также

Group Рисование изображений


Константы WindowStateConstants

Состояние окна (нормальное, минимизировано или максимизировано)

Константы

Константа | Значение | Описание
Constant WindowStateNormal | 0 | Окно в нормальном состоянии
Constant WindowStateMinimized | 1 | Окно минимизировано
Constant WindowStateMaximized | 2 | Окно максимизировано

Смотри также

Group Пользовательский интерфейс